Menu Close
Settings Close

Language and Page Formatting Options

7.4. 사전 업그레이드 요구 사항 검증

pre-upgrade 검증 그룹을 실행하여 사전 업그레이드 요구 사항을 확인합니다.

RHOSP(Red Hat OpenStack Platform) 검증 프레임워크에 대한 자세한 내용은 Director 설치 및 사용 가이드의 검증 프레임워크 사용을 참조하십시오.

절차

  1. stackrc 파일을 소싱합니다.

    $ source ~/stackrc
  2. --group pre-upgrade 옵션을 사용하여 openstack tripleo validator run 명령을 실행하고 /usr/libexec/platform-python python 런타임 환경을 포함합니다.

    $ openstack tripleo validator run --group pre-upgrade --python-interpreter /usr/libexec/platform-python -i inventory.yaml
  3. 검증 보고서 결과를 확인하십시오. 특정 검증의 자세한 출력을 보려면 보고서의 특정 검증 UUID에 대해 openstack tripleo validator show run --full 명령을 실행합니다.

    $ openstack tripleo validator show run  --full <UUID>
중요

검증 FAILED 로 인해 RHOSP를 배포하거나 실행할 수 없습니다. 그러나 FAILED 검증 결과는 프로덕션 환경에서 잠재적으로 문제가 발행할 수 있다는 것을 의미합니다.