11장. Camel 버전 변경

Fuse 툴링 프로젝트를 사용할 때 사용하는 Camel 버전을 변경할 수 있습니다. 예를 들어 최신 Camel 버전에서 지원되는 기능을 사용하거나 커뮤니티 버전을 사용하려는 경우 유용합니다.

프로젝트에서 사용하는 Camel 버전을 변경하려면 다음을 수행합니다.

  1. Project Explorer 에서 Camel 버전을 변경할 프로젝트를 마우스 오른쪽 버튼으로 클릭하고 ConfigureChange Camel Version 을 선택합니다.
  2. Camel 버전 변경 창에서 Camel 버전 필드 오른쪽에 있는 드롭다운을 클릭하여 사용 가능한 Camel 버전을 표시합니다.

    Apache Camel의 커뮤니티 버전을 사용하려면 버전 번호(예: 2.19.2 )를 입력합니다.

  3. 원하는 버전을 선택하거나 입력하고 마침 을 클릭합니다.

Fuse Tooling은 선택한 버전이 Fuse Tooling에서 사용 가능하고 지원되는지 확인합니다. 그런 다음 Fuse Tooling이 Camel 버전을 변경하고 프로젝트의 업데이트된 pom.xml 파일을 저장합니다. 선택한 Camel 버전을 사용할 수 없거나 지원되지 않는 경우 오류 메시지가 표시됩니다.

프로젝트의 Camel 버전은 pom.xml 파일에서 < camel.version&gt; 요소에서 확인할 수 있습니다.