4.6. 인프라 서비스

새로운 bind9.16 패키지 버전 9.16.23 도입

새로운 bind 9.16 패키지 버전 9.16.23은 구성 요소 버전 9.11.36에 대한 대안으로 도입되었습니다. 주요 개선 사항은 다음과 같습니다.

  • DNSSEC의 새로운 키 및 서명 정책 기능 도입.
  • 개인 정보를 개선하기 위해 QNAME 최소화를 도입했습니다.
  • Permanent에 대한 validate-except 기능을 도입했습니다.
  • DNSSEC 검증을 일시적으로 비활성화하려면 negative Trust Anchors.
  • RPZ(응답 정책 영역)를 리팩터링했습니다.
  • 영역 유형에 대한 새로운 명명 규칙 도입: 기본 영역 유형과 보조 영역 유형이 마스터슬레이브 에 대한 동의어로 사용됩니다.
  • dig,mdig 명령의 보조 YAML 출력 모드를 도입했습니다.
  • filter-aaaa 기능이 별도의 filter-afilter-aaa 플러그인으로 이동되었습니다.
  • 새로운 영역 유형 미러 지원(RFC 8806)을 도입했습니다.

제거된 기능:

  • dnssec-enabled 옵션이 제거되어 DNSSEC가 기본적으로 활성화되고 dnssec-enabled 키워드는 더 이상 허용되지 않습니다.
  • lwresd 경량 resolver 데몬과 liblwres 경량 resolver 라이브러리가 제거되었습니다.

(BZ#1873486)

CUPS가 컨테이너 이미지로 사용 가능

이제 Common Unix Printing System (CUPS)을 컨테이너 이미지로 사용할 수 있으며 Red Hat Container Catalog에서 배포할 수 있습니다.

(BZ#1913715)

바인딩 구성 요소를 버전 9.11.36으로 다시 기반으로 합니다.

바인딩 구성 요소가 9.11.36 버전으로 업데이트되었습니다. 주요 버그 수정 및 개선 사항은 다음과 같습니다.

  • lame-ttl 옵션을 보다 안전하게 사용할 수 있도록 개선
  • RBTDB 인스턴스에 영향을 미치는 여러 스레드 버그로 인해 더 이상 free_rbtdb() 에서 어설션 오류가 발생하지 않습니다.
  • RFC 8976과 일치하도록 ZONEMD RR 유형의 업데이트된 구현이 업데이트되었습니다.
  • 지원되는 최대 NSEC3 반복 수가 150으로 단축되었습니다. 더 많은 반복을 사용하는 레코드는 비보안으로 처리됩니다.
  • LOC 레코드의 잘못된 방향 필드가 더 이상 실패하지 않습니다.

(BZ#2013993)

CUPS 웹 UI에서 CUPS 드라이버 없는 인쇄를 사용할 수 있습니다.

IPP Everywhere 모델을 기반으로 CUPS 드라이버 없는 인쇄는 CUPS 웹 UI에서 사용할 수 있습니다. CLI에서 사용된 lpadmin 명령 외에도 CUPS 웹 UI에서 IPP Everywhere 큐를 생성하여 특수 소프트웨어 없이 네트워크 프린터로 출력할 수 있습니다.

(BZ#2032965)