4장. 시스템 요구 사항

Red Hat Ansible Automation Platform 설치를 계획하고 사용 사례에 맞는 자동화 메시 토폴로지를 설계할 때 이 정보를 사용하십시오.

사전 요구 사항

  • sudo 명령을 통해 또는 권한 에스컬레이션을 통해 root 액세스 권한을 얻을 수 있습니다. 권한 에스컬레이션에 대한 자세한 내용은 권한 에스컬레이션 이해 를 참조하십시오.
  • AWX, PostgreSQL, Event-Driven Ansible 또는 Pulp와 같은 권한을 root에서 사용자로 분리할 수 있습니다.
  • 모든 노드에 NTP 클라이언트를 구성했습니다. 자세한 내용은 Chrony를 사용하여 NTP 서버 구성 을 참조하십시오.

4.1. Red Hat Ansible Automation Platform 시스템 요구 사항

Red Hat Ansible Automation Platform을 설치하고 실행하려면 시스템에서 다음과 같은 최소 시스템 요구 사항을 충족해야 합니다.

표 4.1. 기본 시스템

요구 사항필수 항목참고

서브스크립션

유효한 Red Hat Ansible Automation Platform

 

OS

Red Hat Enterprise Linux 8.6 이상 64비트(x86, ppc64le, s390x, aarch64)

Red Hat Ansible Automation Platform은 OpenShift에서도 지원됩니다. 자세한 내용은 OpenShift Container Platform에 Red Hat Ansible Automation Platform Operator 배포를 참조하십시오.

Ansible

버전 2.14 (설치 대상)

Ansible Automation Platform에는 ansible-core 2.15가 포함된 실행 환경이 포함되어 있습니다.

Python

3.9 이상

 

브라우저

현재 지원되는 Mozilla FireFox 버전 또는 Google Chrome

 

데이터베이스

PostgreSQL 버전 13

 

다음은 프로젝트 업데이트 및 컬렉션을 사용하려면 다음과 같습니다.

  • Table 5.9에 나열된 네트워크 포트 및 프로토콜이 있는지 확인합니다. Automation Hub 를 사용하여 자동화 허브 또는 Ansible Galaxy 서버에서 컬렉션을 성공적으로 연결하고 다운로드할 수 있습니다.
  • 자체 서명된 인증서를 사용하는 경우 또는 Red Hat 도메인을 사용하는 경우 SSL 검사를 비활성화합니다.
참고

Ansible Automation Platform에서 관리하는 시스템에 대한 요구 사항은 Ansible과 동일합니다. Ansible 사용자 가이드의 Ansible 시작하기 를 참조하십시오.

Red Hat Ansible Automation Platform 요구 사항에 대한 추가 노트

  • Red Hat Ansible Automation Platform은 Ansible 플레이북에 따라 다르며 ansible-core의 안정적인 최신 버전을 설치해야 합니다. ansible-core를 수동으로 다운로드하거나 Red Hat Ansible Automation Platform 설치의 일부로 자동으로 다운로드할 수 있습니다.
  • 새로운 설치의 경우 자동화 컨트롤러는 ansible-core의 최신 릴리스 패키지를 설치합니다.
  • 번들로 제공되는 Ansible Automation Platform 설치를 수행하는 경우 설치 setup.sh 스크립트에서 번들에서 ansible-core(및 해당 종속 항목)를 설치하려고 합니다.
  • Ansible을 수동으로 설치한 경우 Ansible Automation Platform 설치 setup.sh 스크립트에서 Ansible이 설치되었음을 감지하고 다시 설치하지 않습니다.
참고

Red Hat Ansible Automation Platform이 제대로 작동하려면 dnf 와 같은 패키지 관리자를 사용하여 Ansible을 설치하고 안정적인 최신 버전의 패키지 관리자를 설치해야 합니다. 버전 2.4 이상에는 Ansible 버전 2.14가 필요합니다.