1장. 요구 사항 및 권장 사항

Kubernetes Operator용 다중 클러스터 엔진을 설치하기 전에 다음 시스템 구성 요구 사항 및 설정을 검토하십시오.

중요: 2.5 이전의 Kubernetes용 Red Hat Advanced Cluster Management가 없는 클러스터에 Kubernetes용 멀티 클러스터 엔진을 설치해야 합니다. Kubernetes용 멀티 클러스터 엔진은 동일한 관리 구성 요소를 제공하는 2.5 이전 버전에서 Red Hat Advanced Cluster Management for Kubernetes와 공존할 수 없습니다. 이전에 Red Hat Advanced Cluster Management를 설치하지 않은 클러스터에 Kubernetes용 멀티 클러스터 엔진을 설치하는 것이 좋습니다. 버전 2.5.0 이상에서 Kubernetes용 Red Hat Advanced Cluster Management를 사용하는 경우 Kubernetes용 다중 클러스터 엔진이 클러스터에 이미 설치되어 있습니다.

1.1. Kubernetes 클러스터 및 관리 클러스터에 대해 멀티 클러스터 엔진에서 지원되는 운영 체제 및 플랫폼

지원되는 운영 체제는 다음 표를 참조하십시오.

플랫폼

Kubernetes 클러스터의 멀티 클러스터 엔진에서 지원

관리형 클러스터에서 지원

Red Hat OpenShift Container Platform 3.11.200 이상 3.11.x 릴리스

없음

제공됨

Red Hat OpenShift Container Platform 4.8.2 이상

제공됨

제공됨

Amazon Web Services의 Red Hat OpenShift Container Platform

제공됨

제공됨

Microsoft Azure의 Red Hat OpenShift Container Platform

제공됨

제공됨

Google Cloud Platform의 Red Hat OpenShift Container Platform

제공됨

제공됨

Red Hat OpenShift Kubernetes Engine

없음

제공됨

Google Kubernetes Engine (Google GKE) (Kubernetes 1.17, 이상)

없음

제공됨

Amazon Elastic Kubernetes Service(Amazon EKS)(Kubernetes 1.17.6 이상)

없음

제공됨

Microsoft Azure Kubernetes Service (Microsoft AKS) (Kubernetes 1.19.6 이상)

없음

제공됨