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Abstract
Information for users installing Red Hat JBoss Developer Studio. This guide describes all
prerequisites for a successful installation of the product followed by a number of installation
methods, including how to use your existing installation of Eclipse.
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CHAPTER 1. INTRODUCING JBOSS DEVELOPER STUDIO
INSTALLATION OPTIONS

JBoss Developer Studio can be installed in a variety of ways. Depending on your circumstance, use
one of the following installation methods:

Chapter 3, Installing JBoss Developer Studio in Eclipse

Section 3.1, “Installing JBoss Developer Studio in Eclipse when Online”

Section 3.2, “Installing JBoss Developer Studio in Eclipse when Offline”

Chapter 4, Installing JBoss Developer Studio Using the Installer

Section 4.1, “Installing JBoss Developer Studio Stand-alone”

Section 4.2, “Installing JBoss Developer Studio and Red Hat JBoss EAP”

Chapter 5, Installing JBoss Developer Studio through Red Hat Development Suite

Chapter 6, Installing JBoss Developer Studio Using RPM

Chapter 7, Performing Advanced Installation Tasks

Section 7.1, “Installing JBoss Developer Studio Using a Script”

Section 7.2, “Building the JBoss Developer Studio Stand-alone Installer from Source”
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CHAPTER 2. UNDERSTANDING
JBOSS DEVELOPER STUDIO INSTALLATION
PREREQUISITES

2.1. HARDWARE AND SOFTWARE REQUIREMENTS

JBoss Developer Studio 10.2 is supported for use with a range of operating system, architecture,
and Java developer kit combinations; for a complete list, see
https://access.redhat.com/articles/427493 on the Red Hat Customer Portal.

Following are the prerequisites for installing JBoss Developer Studio:

1. Minimum hardware requirements:

a. 4 GB RAM (minimum 2 GB RAM)

b. 2 GB hard disk space

2. Software requirements:

a. Install JDK 8 (Red Hat OpenJDK is recommended)

2.2. INSTALLING OPENJDK 8

Unless you already have Java 8 installed on your system, use the OpenJDK distribution provided by
Red Hat. This section describes how to install OpenJDK by Red Hat on Microsoft Windows and
Red Hat Enterprise Linux.

2.2.1. Installing OpenJDK on Microsoft Windows

To install OpenJDK 1.8.0 on Windows using the MSI-based installer:

1. Download the MSI-based installer from:
http://developers.redhat.com/products/openjdk/overview/.

2. Run the installer and follow the on-screen instructions to install.

3. To configure JBoss Developer Studio to use OpenJDK, follow the instructions at Working
with JREs.

2.2.2. Installing OpenJDK on Red Hat Enterprise Linux

To install OpenJDK 1.8.0 on Red Hat Enterprise Linux:

Note

All the commands in the following procedure must be run as the root user.

Red Hat JBoss Developer Studio 10.2 Installation Guide
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1. Register and subscribe the system by running the following command:

# subscription-manager register

2. When prompted, enter your Red Hat Customer Portal user name and password.

3. To find a suitable subscription, such as Developer Subscription, run the following command:

# subscription-manager list --available

This command lists the available subscriptions and details of the subscriptions. Note down
the pool ID of the appropriate subscription.

4. To attach a subscription to your system, run the following command:

# subscription-manager attach --pool=<pool id from previous 
command>

5. To install OpenJDK RPMs:

# yum install java-1.8.0-openjdk-devel

Note

Install the java-1.8.0-openjdk-demo package for examples of Java applications and the
java-1.8.0-openjdk-src package to debug your applications. Both packages are available
from the Optional repository. Use the following command to enable that repository on your
system:

# subscription-manager repos --enable=rhel-7-server-optional-
rpms

Substitute the version number in the above command with 6 if you use Red Hat
Enterprise Linux 6.

Use the following command to install the packages:

# yum install java-1.8.0-openjdk-src java-1.8.0-openjdk-demo

CHAPTER 2. UNDERSTANDING JBOSS DEVELOPER STUDIO INSTALLATION PREREQUISITES
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CHAPTER 3. INSTALLING JBOSS DEVELOPER STUDIO IN
ECLIPSE

JBoss Developer Studio for Eclipse packages the JBoss Developer Studio plug-ins for your existing
Eclipse instance. You can either install JBoss Developer Studio from the Eclipse Marketplace when
you are online or use the Update Site Zip to install it when you are offline.

3.1. INSTALLING JBOSS DEVELOPER STUDIO IN ECLIPSE WHEN
ONLINE

JBoss Developer Studio is available to install from Eclipse Marketplace when you are online.

To install JBoss Developer Studio BYOE from Eclipse Marketplace:

1. Start Eclipse Neon.

2. Click Help → Eclipse Marketplace, locate Red Hat JBoss Developer Studio 10.2 GA,
and click Install.

3. Follow the on-screen instructions to complete the installation process.

During the installation process, if you receive warnings about installing unsigned content, review the
details of the content and if satisfied, click OK to continue with the installation.

Once installation is complete, you are prompted to restart Eclipse. Click Yes to restart immediately
and No if you need to save any unsaved changes to open projects. Note that IDE changes do not
take effect until Eclipse is restarted.

3.2. INSTALLING JBOSS DEVELOPER STUDIO IN ECLIPSE WHEN
OFFLINE

You need the Update Site Zip to install JBoss Developer Studio in Eclipse in the offline mode.
Alternatively, you can also use an installer downloaded on your system instead of the Update 
Site Zip to install JBoss Developer Studio in Eclipse when Offline.

Important

You must first be online to download the .zip file before proceeding to install
JBoss Developer Studio in Eclipse in the offline mode.

To install JBoss Developer Studio in Eclipse in offline mode:

1. Download the Red Hat JBoss Developer Studio 10.2 Update Site Zip from
https://devstudio.redhat.com/10.0/stable/updates/.

2. Start Eclipse Neon.

3. Click Help → Install New Software.

4. In the Work with field, enter the path of the Update Site Zip file. Alternatively, click Add and
click Archive to locate the file.

Red Hat JBoss Developer Studio 10.2 Installation Guide
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5. From the table of components, select Red Hat JBoss Developer Studio 10 - Bring Your
Own Eclipse and click Next.

6. Follow the on-screen instructions to complete the installation process.

During the installation process, you may receive warnings about installing unsigned content. If this is
the case, review the details of the content and if satisfied, click OK to continue with the installation.

Once the installation is complete, you are prompted to restart Eclipse. Click Yes to restart
immediately and No to save any unsaved changes to open projects. Note that the IDE changes do
not take effect until Eclipse is restarted.

CHAPTER 3. INSTALLING JBOSS DEVELOPER STUDIO IN ECLIPSE
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CHAPTER 4. INSTALLING JBOSS DEVELOPER STUDIO
USING THE INSTALLER

JBoss Developer Studio stand-alone packages the JBoss Developer Studio plug-ins with Eclipse
and dependent third-party plug-ins in an installer for all operating systems.

4.1. INSTALLING JBOSS DEVELOPER STUDIO STAND-ALONE

The installer provided to install JBoss Developer Studio stand-alone is available from a variety of
sources, including the Red Hat Customer Portal.

To install JBoss Developer Studio stand-alone:

1. Download Red Hat JBoss Developer Studio 10.2 Stand-alone Installer from
JBoss Developer Studio Software Downloads.

2. Start the installer:

$ cd /path/to/.jar
$ java -jar devstudio-10.2.0.GA-installer-standalone.jar

Alternatively, you can start the installer by double-clicking the .jar file. On OS X systems,
hold control and click the .jar file, click Open, review the .jar file details and if satisfied,
click Open.

3. Follow the on-screen instructions to complete the installation process.

4.2. INSTALLING JBOSS DEVELOPER STUDIO AND RED HAT
JBOSS EAP

A single installer is provided for both JBoss Developer Studio stand-alone and Red Hat JBoss
Enterprise Application Platform (JBoss EAP). A specific JBoss EAP version is packaged in the
installer. For details of the JBoss EAP version, see https://access.redhat.com/articles/427493. This
installer is available from a variety of sources, including the Red Hat Customer Portal.

To install JBoss Developer Studio stand-alone and JBoss EAP:

1. Download Red Hat JBoss Developer Studio 10.2 Installer with EAP from
JBoss Developer Studio Software Downloads.

2. Start the installer:

$ cd /path/to/.jar
$ java -jar devstudio-10.2.0.GA-installer-eap.jar

Alternatively, you can start the installer by double-clicking the .jar file. On OS X systems,
hold control and click the .jar file, click Open, review the .jar file details and if satisfied,
click Open.

3. In the Introduction Step 1 of 9 window, read the information about the installer and click
Next.

Red Hat JBoss Developer Studio 10.2 Installation Guide
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4. In the End User License Agreement Step 2 of 9 window, read the agreement and click I
accept the terms of this license agreement and click Next.

5. In the Select Target Folder Step 3 of 9 window, click Browse, select the installation path,
and click Next.

6. In the Warning dialog box, click Yes

7. In the Select Java VM Step 4 of 9 window, Default Java VM is selected by default. Ensure
that the disabled text field contains the path of the Java developer kit you want to use. This
is based on the default Java developer kit of your system. To change the specified Java
developer kit, click Specific Java VM and click Browse to locate the Java developer kit.
When the text field shows the correct Java developer kit path, click Next.

8. In the Select Platforms and Servers Step 5 of 9 window, Yes, and have it ready for use
in Red Hat JBoss Developer Studio is selected by default. Alternatively, to add a location:

a. Click Add to add locations that you want to be scanned recursively to locate
platforms and servers.

b. In the Add Location window, click Browse to select the location path.

c. Click the Scan every start check box to scan the specified path for new application
servers each time JBoss Developer Studio starts.

d. Click OK.

e. In the Select Platforms and Servers Step 5 of 9 window, click Next.

9. In the Summary Information Step 6 of 9 window, review the installation details and click
Next.

10. The Installation Step 7 of 9 window shows the progress of the installation. When the Pack
installation progress bar shows Finished, click Next.

11. In the Setup Shortcuts Step 8 of 9 window, click the relevant check box to create shortcuts
and click Next.

12. In the Finish Step 9 of 9 window, the Run Red Hat JBoss Developer Studio after
installation check box is selected by default. Click Done.

13. In the Eclipse Launcher window, Workspace field, click Browse to select the directory
where JBoss Developer Studio will store its preferences and development artifacts. Click
OK.

14. In the Red Hat JBoss Developer Studio Usage window, click Yes to allow Red Hat Inc. to
receive usage statistics for the installed JBoss Developer Studio instance or click No, as
required.

This additional installer option installs JBoss EAP in a subdirectory of the JBoss Developer Studio
installation and generates a complete default server definition within the IDE with which to manage
the JBoss EAP instance and deployed applications.

CHAPTER 4. INSTALLING JBOSS DEVELOPER STUDIO USING THE INSTALLER
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CHAPTER 5. INSTALLING JBOSS DEVELOPER STUDIO
THROUGH RED HAT DEVELOPMENT SUITE

You can install JBoss Developer Studio as part of Red Hat Development Suite on 64-bit Microsoft
Windows and macOS.

Note

The macOS Installer is released as Technology Preview in Red Hat
Development Suite Development Suite. For information on support for features released
as Technology Preview, see Technology Preview Features Support Scope.

The Red Hat Development Suite Installer installs the following components:

OpenJDK

Red Hat JBoss Developer Studio

Cygwin

Red Hat Container Development Kit

Vagrant

VirtualBox

For details of the components installed through Red Hat Development Suite, see Component Details
in the Red Hat Development Suite Installation Guide.

For instructions on installing Red Hat Development Suite, see the Red Hat Development Suite
Installation Guide.

Red Hat JBoss Developer Studio 10.2 Installation Guide
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CHAPTER 6. INSTALLING JBOSS DEVELOPER STUDIO
USING RPM

On Red Hat Enterprise Linux 7.2 and higher, JBoss Developer Studio can be installed using the
standard package management system. RPM packages that use the Software Collections format
are provided in the rh-eclipse46-devstudio-stable-10.x repository. This section explains how to
enable that repository and install JBoss Developer Studio from RPM packages.

Note

Note that the RPM package method for installing JBoss Developer Studio is being
released as a Technology Preview for this JBoss Developer Studio 10.2 release. For
information on support for features released as Technology Preview, see Technology
Preview Features Support Scope.

Important

If you install JBoss Developer Studio using this method, in addition to the following
plugins, any third-party components installed through the Help → Install New Software
menu, may corrupt your JBoss Developer Studio instance, and you may be unable to
restart JBoss Developer Studio to uninstall them.

1. From JBoss Developer Studio Integration Stack

a. JBoss Fuse & JBoss Fuse Service Works (SwitchYard 2.2.0)

b. JBoss Data Virtualization (Teiid Designer 10.0)

2. From third-party vendors:

a. Spring IDE up to 3.8.2

b. ZeroTurnaround JRebel 7.0.0

c. Atlassian connector for Eclipse 3.2.5.I20150617-0100

To uninstall these plugins, you must delete the ~/.eclipse directory and then restart
JBoss Developer Studio. However, you will have to reinstall any third-party features or
plugins that you had installed earlier through an update site or the Eclipse Marketplace.
For any third-party plugins to work, install JBoss Developer Studio using either the Red
Hat JBoss Developer Studio 10.2 Stand-alone Installer file or the Red Hat JBoss
Developer Studio 10.2 Installer with EAP file.

Prerequisites

Register your Red Hat Enterprise Linux system. For instructions on registering your system, see
How to register and subscribe a system to the Red Hat Customer Portal using Red Hat
Subscription-Manager.

Enable the rhel-server-rhscl-7-rpms  repository. For instructions on enabling the repository, see
Getting Access to Red Hat Software Collections.

CHAPTER 6. INSTALLING JBOSS DEVELOPER STUDIO USING RPM
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To install JBoss Developer Studio using the RPM package:

1. As root, create the /etc/yum.repos.d/rh-eclipse46-devstudio-stable-
10_x.repo file, and then add the following content to it:

2. Run the following command to install product signing (GPG) key:

# rpm --import 
"https://www.redhat.com/security/data/a5787476.txt"

Note

For a list of GPG keys used to automatically verify Red Hat software updates, see
https://access.redhat.com/security/team/key.

3. Run the following command to install JBoss Developer Studio and all the debendencies:

# yum install rh-eclipse46-devstudio

[rh-eclipse46-devstudio-stable-10.x]
name=rh-eclipse46-devstudio-stable-10.x
baseurl=https://devstudio.redhat.com/static/10.0/stable/rpms/x86_64
/
enabled=1
gpgcheck=1
upgrade_requirements_on_install=1
metadata_expire=24h

Red Hat JBoss Developer Studio 10.2 Installation Guide
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CHAPTER 7. PERFORMING ADVANCED INSTALLATION
TASKS

This section describes how to install JBoss Developer Studio using a script and how to build the
JBoss Developer Studio installer from source code.

7.1. INSTALLING JBOSS DEVELOPER STUDIO USING A SCRIPT

Use the scripted method to install JBoss Developer Studio stand-alone using the GUI once and then
a generated script for subsequent installations. This installation method enables simplified repeat
installations or installations in bulk without stepping through the installer GUI for every installation.

The JBoss Developer Studio stand-alone installer is available from a variety of sources, including
the Red Hat Customer Portal.

To install JBoss Developer Studio by script:

1. Download Red Hat JBoss Developer Studio 10.2 Stand-alone Installer from
JBoss Developer Studio Software Downloads.

2. Start the installer:

$ cd /path/to/.jar
$ java -jar devstudio-10.2.0.GA-installer-standalone.jar

3. Follow the on-screen instructions to complete the installation process. After the installation
is complete, an InstallConfigRecord.xml file is generated in the
JBoss Developer Studio installation directory.

4. In the terminal window, enter the following command:

$ java -jar devstudio-10.2.0.GA-installer-standalone.jar \
  /path/to/devstudio/InstallConfigRecord.xml

Note

The generated InstallConfigRecord.xml file is machine-specific and uses the Java
Developer Kit and installation paths of your system. To use the 
InstallConfigRecord.xml file for other operating systems, Java Developer Kits, or
paths, you must manually modify the file.

7.2. BUILDING THE JBOSS DEVELOPER STUDIO STAND-ALONE
INSTALLER FROM SOURCE

Prerequisite

Maven 3.2 or later, with Java 8 must be installed to build the installer from the source code. To
obtain and configure Maven, see http://maven.apache.org/.

To build the JBoss Developer Studio stand-alone installer from source:
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1. Clone the git repository by running the command:

$ git clone https://github.com/jbdevstudio/jbdevstudio-
product.git

2. Build the installer by following the instructions in the jbdevstudio-product/README.adoc
file.

Note

The jbdevstudio-product/README.adoc file is located in the extracted current folder
at the highest level.

Building takes some time to complete, after which the devstudio-[version]-installer-
standalone.jar file will be located in the /path/to/jbdevstudio-
product/installer/target directory.
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CHAPTER 8. UPGRADING JBOSS DEVELOPER STUDIO

This section describes how to upgrade to newer versions of JBoss Developer Studio.

8.1. UPGRADING MAJOR VERSIONS OF
JBOSS DEVELOPER STUDIO

Each major version of JBoss Developer Studio is based on a different version of Eclipse. As a result,
it is not possible to update an older major version of JBoss Developer Studio to a newer major
version. For example, it is not possible to update a devstudio 8.x installation to 9.x, nor is it possible
to update a 9.x installation to 10.x. However, it is possible to use the workspaces created using
JBoss Developer Studio 9.x with JBoss Developer Studio 10.x.

The following table details the version of Eclipse supported with each major version of
JBoss Developer Studio:

Table 8.1. Eclipse Version Support Matrix

JBoss Developer Studio Version Base Eclipse Version

JBoss Developer Studio 10.x Eclipse Neon (4.6)

JBoss Developer Studio 9.x Eclipse Mars (4.5)

JBoss Developer Studio 8.x Eclipse Luna (4.4)

JBoss Developer Studio 7.x Eclipse Kepler (4.3)

JBoss Developer Studio 6.x Eclipse Juno (4.2)

8.2. UPDATING MINOR VERSIONS OF JBOSS DEVELOPER STUDIO

You can update your JBoss Developer Studio to the latest minor versions within the major release.
For example, you can update your JBoss Developer Studio 10.0 installation to 10.1.

Important

Before updating, back up your workspace. In addition to your project files, your workspace
contains metadata about customized settings and preferences for the IDE. To back up
your workspace, either copy the workspace directory to a backup location, or save it as a
compressed file.
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You may be automatically notified by the IDE when the JBoss Developer Studio 10.y update is
available, depending on your IDE settings for automatic updates.

Note

If you have installed JBoss Developer Studio using the RPM package, you must update
using your package manager (example: yum update) and not look for automatic updates.

Alternatively, use the following instructions to manually check for and apply the most recent
JBoss Developer Studio update:

1. In the IDE, click Window > Preferences, expand Install/Update and click Available
Software Sites.

2. In the Available Software Sites table, ensure the URL
https://devstudio.redhat.com/10.0/stable/updates/ is listed or, if not listed, add it.

3. Close the Preferences window.

4. Click Help > Check for Updates.

5. For any JBoss Developer Studio updates found, follow the on-screen instructions to apply
the update.

During the update process, you may receive warnings about installing unsigned content. If this is the
case, review the details of the content and if satisfied click OK to continue with the update.

Once updating is complete, you are prompted to restart the IDE. Click Yes to restart immediately or
No to save any unsaved changes to open projects. Note that IDE changes do not take effect until
the IDE is restarted.
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CHAPTER 9. REPORTING ISSUES FROM WITHIN
JBOSS DEVELOPER STUDIO

Red Hat JBoss Developer Studio and JBoss Tools allow users to report issues from within the IDE
as they are encountered. It is recommended that users report issues frequently and include as much
detail as possible to help the development and testing teams replicate and fix the issue. The Report
Problem wizard creates a zip file containing the relevant IDE log files. This zip file can be attached
to the JIRAs submitted against each problem to provide context for the issue.

1. Click Help and then click Report Problem.

2. The Log file name field contains the zipped log files as a default. Click Browse to select a
different log file to attach to the JIRA.

3. In the Problem Description field, outline details about the problem, such as:

What you wanted to do with JBoss Developer Studio.

What steps you followed to arrive at the problem or error message.

Any other noteworthy information about the environment or any unsupported add-ons or
plug-ins in use.

4. Optionally, in the E-Mail field, add your e-mail address to be potentially contacted in the
future about the issue.

5. Click OK to submit the problem report.

You can also enable error reporting from: Preferences → General → Error Reporting. If enabled,
when you encounter a plugin related error, a pop-up notification describing the error will appear. The
user can either dismiss or send the error directly, or provide more details about the error. You can
optionally provide your e-mail ID to be contacted for more details on the error.
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