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第1章 はじめに

1.1. RED HAT JBOSS BRMS について

Red Hat JBoss BRMS は、ビジネスルール管理と複合イベント処理を組み合わせるオープンソースのデ
シジョン管理プラットフォームであり、ビジネスデシジョンを自動化し、ビジネスロジックをビジネ
ス全体で利用できるようにします。

Red Hat JBoss BRMS は、すべてのリソースが保存される集中リポジトリーを使用します。これによ
り、ビジネス全体で一貫性や透明性を維持し、監査を行えます。ビジネスユーザーは、IT 担当者のサ
ポートを受けなくてもビジネスロジックを編集できます。

Business Resource Planner は、本リリースの技術プレビューとして含まれています。

バグを報告する

1.2. ユースケース: JBOSS BRMS を使用した保険業界におけるビジネスデ
シジョン管理

BRMS は、Drools プロジェクトの高性能なルールエンジン、ルールリポジトリー、Drools Guvnor プロ
ジェクトの使いやすいルールオーサリングツール、および Drools Fusion プロジェクトの複合イベント
処理ルールエンジン拡張によって構成されます。また、複合計画問題 (complex planning problem) のソ
ルバーである OptaPlanner が技術プレビューとして含まれています。

消費者向け保険市場は大変競争が激しいため、インターネットの保険見積りでは効率が良く、競合に負
けない包括的なサービスを提供する必要があります。ある保険会社は、インターネットの見積りプロセ
スで適切な追加製品を提供し、高額な製品を販売することで売上を伸ばしました。

JBoss BRMS は保険会社のインフラストラクチャーと統合されていたため、保険のリクエストが処理さ
れると BRMS へ確認が行われ、適切な追加製品が保険の見積りと共に提示されました。

第1章 はじめに
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図1.1 BRMS ユースケース: 保険業界のデシジョンメーキング

BRMS は、ビジネスアナリストによって定義されたルールを基に申込者に提示する製品の自動決定機能
など、デシジョン管理機能を提供しました。ルールはデシジョンテーブルとして実装されたため、IT
部門の追加サポートを必要とせずに簡単に理解および変更できました。

バグを報告する
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第2章 RED HAT JBOSS BRMS のクイックスタート
本項では、最小手順で Red Hat JBoss BRMS をダウンロード、インストールおよび実行します。詳細な
手順や、他のインストール方法については、本項以外の内容を参照してください。

この手順では、ご使用のシステムに最小限サポートされる Java バージョンがインストールされている
ことを前提とします。Red Hat JBoss EAP サーバーが検出されない場合はインストーラーがインストー
ルするため、既存の Red Hat JBoss EAP サーバーは必須ではありません。

手順2.1 BRMS クイックスタート

1. access.redhat.com より BRMS インストーラーをダウンロードします。

2. 次のコマンドを実行して、インストーラーを起動します。

java -jar jboss-brms-installer-VERSION.GA-redhat-MINOR.jar

3. GUI インストーラーの指示に従って進み、インストール後に BRMS アプリケーションにアクセ
スするために必要なユーザー名とパスワードを書き留めておきます。

4. インストールが終了したら、コマンドプロンプトを用いて BRMS がインストールされた EAP
ホームフォルダーに移動します。

5. 次のコマンドを実行し、BRMS サーバーを起動します。

bin/standalone.sh

6. Web ブラウザーを開き、http://localhost:8080/business-central/ にアクセスして
Business Central にログインします。インストール時に作成した、BRMS アプリケーション用
のユーザー名とパスワードの組み合わせを使用してログインします。

これで BRMS が正しくインストールされ、実行されます。以下が可能になります。

ロールに関する知識を深める: 「ロールの定義」

追加ユーザーの作成: 「ユーザーの作成」

Hello World ルールの作成: 5章Hello World ルールの例

インストーラーを用いた詳細なインストール手順の確認: 『インストールガイド』

バグを報告する
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第3章 インストール

3.1. JBOSS EAP 向けの RED HAT JBOSS BRMS のダウンロード

1. Red Hat Customer Portal  にアクセスし、ログインします。

2. Downloads → Red Hat JBoss Middleware → Download Software  の順に選択します。

3. Product ドロップダウンメニューより BRMS Platform を選択します。

4. Version ドロップダウンメニューより、バージョン 6.0.2 を選択します。

5. Red Hat JBoss BRMS 6.0.2 Deployable for EAP 6.1.1 を選択し、Download をク
リックします。

バグを報告する

3.2. RED HAT JBOSS ENTERPRISE APPLICATION PLATFORM への RED
HAT JBOSS BRMS のインストール

Red Hat JBoss BRMS を JBoss Enterprise Application Platform 6.1.1 にインストールできます。未設定
の Red Hat JBoss Enterprise Application Platform 向けのデプロイ可能なパッケージをインストールす
るには、以下の手順に従います。

1. ダウンロードした zip アーカイブを Red Hat JBoss Enterprise Application Platform のホーム
ディレクトリー (EAP_HOME、jboss-eap-6.1 ディレクトリー) に移動します。

2. ダウンロードした zip アーカイブを展開します。必ず EAP_HOME ディレクトリー (jboss-
eap-6.1) へマージされるようにしてください。

警告

この手順は、EAP のインストールに使用した同じユーザーアカウントで実
行する必要があります。このアカウントは、スーパーユーザーアカウント
以外でなければなりません。

3. EAP_HOME ディレクトリーにすでに存在するファイルを、ダウンロードした zip アーカイブの
バージョンで上書きする必要があります。上書きを要求されたら、元のファイルの上書きを許
可します。

設定済みの Red Hat JBoss Enterprise Application Platform 向けのデプロイ可能なパッケージをインス
トールするには、以下の手順に従います。

1. zip アーカイブをダウンロードし、手作業でファイルを Red Hat JBoss Enterprise Application
Platform のホームディレクトリー (EAP_HOME、jboss-eap-6.1 ディレクトリー) へマージす
る準備をします。

2. ダウンロードした zip アーカイブを展開しますが、ファイルを上書きしないでください。以下
のファイルを手作業で EAP_HOME ディレクトリー (jboss-eap-6.1) にマージします。



スタートガイド
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jboss-eap-6.1/domain/configuration/*

jboss-eap-6.1/standalone/configuration/*

jboss-eap-6.1/modules/layers.conf

jboss-eap-6.1/bin/product.conf

警告

この作業は、必ず EAP をインストールしたユーザーアカウントで実行する
ようにしてください。スーパーユーザーアカウントは使用してはなりませ
ん。

3. 目的の EAP のデプロイメントに、競合する名前が含まれないようにしてください。BRMS ディ
ストリビューションから、フォルダー jboss-eap-6.1/standalone/deployments を
EAP_HOME ディレクトリーにコピーします。

4. BRMS という名前の EAP モジュールレイヤーが存在しないことを確認し、フォルダー jboss-
eap-6.1/modules/system/layers/brms を EAP 6.1.1 フォルダーにコピーします。

Red Hat Enterprise Linux では、以下のコマンドを使用すると BPMS zip ファイルの展開と EAP ディレ
クトリーへのマージが一度に行えます。

例3.1 unzip コマンド

バグを報告する

3.3. ロールの定義

サーバーを起動し、Business Central へログインする前に、ユーザーアカウントを作成する必要があり
ます。本項では、Red Hat JBoss BRMS で使用されるユーザーロールについて説明します。

admin: admin ロールを持つユーザーは、アプリケーションの管理者です。管理者は、ユーザー
やリポジトリー (作成およびクローン) を管理でき、アプリケーションに必要な変更を加えるた
め完全アクセスを持ちます。管理者はシステム内のすべてのエリアにアクセスできます。

analyst: analyst ロールは、プロジェクトをモデル化するため、すべての高レベル機能へアクセ
スできます。しかし、analyst ロールを持つユーザーは Authoring → Administration へアクセ
スできません。また、Deployment → Artifact Repository  など、開発者を対象とする低レベル
機能の一部にもアクセスできません。しかし、Project Editor を使用すると、Build & 
Deploy ボタンを使用できます。



unzip -u jboss-brms-VERSION-redhat-VERSION-deloyable-eap6.x.zip -d 
EAP_HOME_PARENT_DIR

unzip -u jboss-brms-VERSION-redhat-VERSION-deployable-eap6.x.zip -d 
/home/john/myEAP/
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注記

上記のロールは、ユーザー作成のプロセス中に入力します。

バグを報告する

3.4. ユーザーの作成

新規ユーザーを追加するには、EAP の bin ディレクトリーより add-user.sh スクリプト (Unix システム
の場合) または add-user.bat ファイル (Windows システムの場合) を実行する必要があります。

1. Unix システムの場合は ./add-user.sh を、Windows システムの場合は add-user.bat を bin ディ
レクトリーより実行します。

2. ユーザータイプ入力のプロンプトが表示されたら「b」を入力して Application User を選択し、
Enter キーを押します。

3. Enter を押してデフォルトのレルム (ApplicationRealm) を許可します。

4. ユーザー名入力のプロンプトが表示されたら、ユーザー名を入力し (例: helloworlduser)、
確認します。

5. パスワード入力のプロンプトが表示されたらユーザーのパスワードを入力し (例: 
Helloworld@123)、再入力します。

注記

パスワードは 8 文字以上で、アルファベットの大文字と小文字 (A-Z、a-z)、1 文
字以上の数字 (0-9)、および 1 文字以上の特殊文字 (~ ! @ # $ % ^ * ( ) - _ + =) が
含まれる必要があります。

6. ロール入力のプロンプトが表示されたら、ユーザーが必要となるロールのコンマ区切りリスト
を入力します (「ロールの定義」 を参照してください)。

Business Central のユーザーには analyst または admin ロールが必要となります。

7. ユーザーを追加することを確認します。

8. 次のプロンプトで「yes」を入力します (これにより、必要な場合にクラスタリングを有効にし
ます)。

バグを報告する

3.5. RED HAT JBOSS WEB SERVER 上での RED HAT JBOSS BRMS のイ
ンストール

汎用デプロイ可能パッケージは、Red Hat JBoss BRMS 6 を既存のアプリケーションサーバーへインス
トールするために提供されます。以下の手順は、既存の Red Hat JBoss Web Server 2.0.1 インスタンス
へのインストールについて説明しています。

手順3.1 汎用デプロイ可能パッケージのインストール

スタートガイド
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1. Red Hat カスタマーポータルより汎用デプロイ可能 zip パッケージをダウンロードするに
は、https://access.redhat.com へアクセスし、ログインします。

2. Downloads → Red Hat JBoss Middleware → Download Software  の順に選択します。

3. Product ドロップダウンメニューより BRMS Platform を選択します。

4. Version ドロップダウンメニューより製品のバージョンを選択します。

5. Red Hat JBoss BRMS 6.0.2 Deployable for all supported containers パッ
ケージを選択し、Download をクリックします。

6. ダウンロードしたアーカイブを展開すると、以下の zip アーカイブが作成されます。

jboss-brms-engine.zip

jboss-brms-manager.zip

7. jboss-brms-manager.zip アーカイブから business-central.war を展開
し、tomcat7/webapps/ へコピーします。

8. business-central.war の .war 拡張子を削除し、ディレクトリーの名前が business-
central になるようにします。

9. 次のように、tomcat7/conf/tomcat-users.xml でユーザーおよびロールを定義します。

  <role rolename="admin"/>
  <role rolename="analyst"/>
  <user username="user" password="password" roles="admin,analyst"/>

10. TOMCAT-JEE-SECURITY が付けられたすべてのエントリーをアンコメント
し、tomcat7/webapps/business-central/WEB-INF ディレクトリーの web.xml ファイ
ルを編集します。以下に例を示します。

上記を以下のようにアンコメントします。

<!-- TOMCAT-JEE-SECURITY -->
    <!--
    <init-param>
      <param-name>org.uberfire.auth.scheme</param-name>
      <param-
value>org.uberfire.security.server.auth.JACCAuthenticationScheme</pa
ram-value>
    </init-param>
    -->

<!-- TOMCAT-JEE-SECURITY -->

    <init-param>
      <param-name>org.uberfire.auth.scheme</param-name>
      <param-
value>org.uberfire.security.server.auth.JACCAuthenticationScheme</pa

第3章 インストール

9

https://access.redhat.com


11. BRMS ディストリビューションの business-central/WEB-INF/lib にある kie-tomcat-
integration-VERSION.jar ファイルを tomcat7/lib にコピーします。

12. BRMS ディストリビューションの business-central/WEB-INF/lib にある slf4j-api-
VERSION.jar および slf4j-ext-VERSION.jar ファイルを tomcat7/lib にコピーしま
す。

13. 以下のファイルをダウンロードし、tomcat7/lib ディレクトリーに置きます。

javax.security.jacc-api.jar

14. 以下の Tomcat Valve 宣言を tomcat7/conf/server.xml (関連する <host> 要素内) へ追加し
ます。

<Valve className="org.kie.integration.tomcat.JACCValve"/>

15. business-central/WEB-INF/classes/META-INF/services 内
で、org.uberfire.security.auth.AuthenticationSource を 
org.uberfire.security.auth.AuthenticationSource-ORIGIN という名前に変更
し、org.uberfire.security.auth.AuthenticationSource-TOMCAT-JEE-SECURITY
を org.uberfire.security.auth.AuthenticationSource という名前に変更します。

16. tomcat7/bin ディレクトリーで startup.sh を実行し、JBoss Web Server を起動します。

17. Web ブラウザで http://localhost:8080/business-central にアクセスします。

18. ユーザーロールを定義した tomcat-users.xml ファイルに指定されている正しいユーザー名
とパスワードを使用して、ログインします。

バグを報告する

3.6. サーバーの起動

インストーラーまたは EAP 6 のバンドルインストールを使用して BRMS をインストールした場合は、2
つのモードの 1 つでサーバーを起動できます。

注記

Red Hat Java Web Server 上の汎用デプロイ可能バージョンを使用して BRMS をインス
トールした場合は、ダウンロードおよびインストールの手順にサーバー起動の手順が含
まれているため、以下の説明に従う必要はありません。

Red Hat JBoss BRMS に含まれるデフォルトの起動スクリプト standalone.sh は、パフォーマンス
重視で最適化されています。パフォーマンスモードでサーバーを実行する場合は、以下の手順に従いま
す。

1. コマンドラインで、$SERVER_HOME/bin/ ディレクトリーへ移動します。

ram-value>
    </init-param>

./startup.sh

スタートガイド
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2. Unix 環境では以下を実行します。

./standalone.sh

Windows 環境では以下を実行します。

./standalone.bat

Red Hat JBoss BRMS には、セキュリティー重視で最適化されている standalone-secure.sh スク
リプトも含まれています。 このスクリプトによって、既知の脆弱性を保護するセキュリティーポリ
シーがデフォルトで適用されます。

注記

本番環境では standalone-secure.sh スクリプトの使用が推奨されます。

警告

セキュリティーマネージャーを使用すると、パフォーマンスが著しく劣化するこ
とに注意してください。セキュリティーとパフォーマンスのバランスは、個々の状
況を判断して決定する必要があります。「Java Security Manager とパフォーマン
ス管理」 を参照してください。

このスクリプトを用いてサーバーをセキュアモードで実行する場合は、以下の手順に従います。

1. コマンドラインで、$SERVER_HOME/bin/ ディレクトリーへ移動します。

2. Unix 環境では以下を実行します。

./standalone-secure.sh

Windows 環境では以下を実行します。

./standalone-secure.bat

バグを報告する

3.7. JAVA SECURITY MANAGER とパフォーマンス管理

前述のとおり、BRMS で MVEL スクリプトの評価をサンドボックス化できるように Java Security
Manager (JSM) を有効にすると、高負荷の環境ではパフォーマンスが劣化します。BRMS をデプロイす
る場合、環境やパフォーマンスに注意する必要があります。以下のガイドラインを使用して、セキュア
で高パフォーマンスな BRMS アプリケーションをデプロイしてください。

パフォーマンスが重要な高負荷の環境では、他のシステムで開発され、適切に評価されたアプ
リケーションのみをデプロイすることが推奨されます。また、このようなシステムでは、
Analyst ロールを持つユーザーを作成しないことが推奨されます。このような対策が取られた


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場合、パフォーマンスの劣化が発生しないため、このようなシステムで JSM を無効にしても安
全です。

高負荷にならないテストおよび開発環境や、ルールやプロセスのオーサリングが外部ネット
ワークに公開される環境では、MVEL の評価を適切にサンドボックス化してセキュリティーを
強化するため、JSM を有効にすることが推奨されます。

JSM が無効な状態で、Analyst ロールを持つユーザーに Business Central コンソールへのログインを許
可するのはセキュアでないため、推奨されません。

バグを報告する
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第4章 BUSINESS CENTRAL へのログイン
サーバーの起動後に、Business Central へログインします。

1. Web ブラウザーで http://localhost:8080/business-central にアクセスします。ドメイン名か
ら実行するようユーザーインターフェースが設定されている場合
は、http://www.example.com:8080/business-central のように localhost をドメイン名に置
き換えます。

2. インストール中に作成されたユーザークレデンシャルを使用してログインします (例: ユーザー 
helloworlduser とパスワード Helloworld@123)。

バグを報告する
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第5章 HELLO WORLD ルールの例
JBoss BRMS の基本機能を実証するため、本章では Hello World ビジネスルールを使用して Hello 
World プロジェクトを設定する方法を説明します。

手順では以下を行います。

1. Artifact リポジトリーに Hello World リポジトリーを作成します。

2. Hello World プロジェクトを作成します。

3. Hello World ルールを作成します。

4. プロジェクトをビルドおよびデプロイします。

バグを報告する

5.1. リポジトリー構造の作成

すべてのビジネス資産は、組織単位 (Organizational Unit) にあるリポジトリーに存在します。組織単位
は Artifact リポジトリーのディレクトリーです。デフォルトでは、Artifact リポジトリーには組織単位
が含まれていません。そのため、独自のビジネス資産を作成するには、Artifact リポジトリーに組織単
位を作成し、リポジトリー (Git) を作成する必要があります。作成後、リポジトリーにプロジェクトを
追加できます。プロジェクトには、内容を論理「ディレクトリー」構造にする任意のパッケージ構造を
含むことができます。ビジネス資産には任意のパッケージを追加できます (Artifact リポジトリーの詳
細は、『Red Hat JBoss BRMS ユーザーガイド』を参照してください)。

リポジトリー構造を作成するには、以下の手順に従います。

1. Web ブラウザーで Business Central を開き (ローカルで実行している場合は
http://localhost:8080/business-central)、admin ロールを持つユーザーとしてログインします
(helloworlduser)。

2. Artifact リポジトリーに組織単位を作成します。

a. Authoring → Administration に移動します。

b. パースペクティブメニューで Organizational Units → Manage Organizational Units  の順
に選択します。

c. 表示された Organizational Unit Manager ビューで Add をクリックします。

表示された Add New Organizational Unit ダイアログボックスでユニットプロパ
ティーを定義し、OK をクリックします。

名前: helloworld

所有者: helloworlduser

3. helloworld 組織単位に新しいリポジトリーを作成します。

a. Authoring → Administration に移動します。

b. パースペクティブメニューで Repositories → New repository  の順に選択します。

スタートガイド
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c. 表示された Create Repository ダイアログボックスでリポジトリープロパティーを定
義します。

リポジトリー名: helloworldrepo

組織単位: helloworld

4. Authoring → Project Authoring に移動します。

5. 組織単位ドロップダウンボックスの Project Explorer で helloworld を選択し、リポジトリー
ドロップダウンボックスで helloworldrepo を選択します。

図5.1 Project Explorer の helloworld 組織単位で helloworldrepo リポジトリーを選択

6. helloworld リポジトリーでプロジェクトを作成します。

a. パースペクティブメニューで New Item  → Project に移動します。

b. 表示された Create new ダイアログボックスでプロジェクトプロパティーを定義します。

リソース名 (プロジェクト名): HelloWorld

パス: default://master@helloworldrepo/

c. New Project Wizard ダイアログで、プロジェクトの maven プロパティーを定義しま
す。各エントリーの入力後に Enter キーを押します。

グループ ID: org.brms

アーティファクト ID: HelloWorld

バージョン ID: 1.0

d. Finish をクリックします。

バグを報告する

5.2. ビジネスルールの作成

第5章 HELLO WORLD ルールの例
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ビジネスルールは when-then ステートメントで定義され、true の場合に何かが発生します (例: 18 歳以
上の場合に特定のコンテンツにアクセスできる)。ビジネスルールは DRL ファイルに保存されます。

HelloWorld プロジェクトの helloworldrule ビジネスルールを定義するには、以下の手順に従いま
す。

1. Project Explorer にて helloworld 組織単位、helloworldrepo リポジト
リー、HelloWorld プロジェクトおよび default パッケージを選択します。

注記

必ず default パッケージを選択してください。誤ったパッケージを選択するとデ
プロイメントに失敗します。

2. DRL ファイルを作成します。

a. パースペクティブメニューで New Item  → DRL file と選択します。

b. Create new ダイアログボックスで、リソース名を helloworldrule として定義し、宛
先パスが default://master@helloworldrepo/HelloWorld/src/main/resources
であることを確認します。

c. OK をクリックします。

3. 表示された DRL エディターと helloworldrule.drl ファイルでルールを定義します。

このルールは when 条件を定義しません。そのため、発火される (実行するため呼び出される)
と常に true になり、Hello World! フレーズが出力されます。

4. Save をクリックします。

5. Save this item プロンプトが表示されます。Check-in comment を入力し、Save をク
リックします。

注記

check-in comment は変更内容の簡単な説明などで、資産を保存するたびに入力
する必要があります。

バグを報告する

5.3. 構築とデプロイ

プロジェクト全体を構築し、実行サーバーへデプロイします。

1. Business Central のメインメニューで Authoring → Project Authoring に移動します。

rule "helloworldrule"
ruleflow-group "helloworldgroup"
when 
then
 System.out.println("Hello World!");
end

スタートガイド
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2. Project Explorer で Hello World プロジェクトを見つけます。

3. プロジェクトエディターでプロジェクトを開きます。Tools → Project Editor  とクリックしま
す。

4. Project Screen に正しいプロジェクト詳細が表示されていることを確認し、Project Screen
ビューの右上隅にある Build & Deploy ボタンをクリックします。

図5.2 プロジェクトエディターと helloWorld プロジェクトプロパティー

プロジェクトが構築され、インスタンス化が可能になったことを伝える緑色の通知が画面上部に表示さ
れます。以前のバージョンの helloWorld デプロイメントが、Business Rule Task がある新バージョ
ンに置き換えられることに注意してください。新旧両方のデプロイメントを保持したい場合は、プロ
ジェクトエディターにあるプロジェクトのバージョン番号を変更します。

バグを報告する

第5章 HELLO WORLD ルールの例
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第6章 RED HAT JBOSS DEVELOPER STUDIO
Red Hat JBoss Developer Studio は Eclipse を基にした JBoss 統合開発環境 (IDE) で、Red Hat カスタ
マーポータルの https://access.redhat.com から入手できます。JBoss Developer Studio は Red Hat
JBoss BRMS および Red Hat JBoss BPM Suite  用のツールとインターフェースを持つプラグインを提供
します。これらのプラグインはコミュニティーバージョンの製品が基になっています。そのため、
BRMS プラグインは Drools プラグインと呼ばれ、BPM Suite プラグインは jBPM プラグインと呼ばれま
す。

インストールまたは設定の手順は、『Red Hat JBoss Developer Studio』ドキュメントを参照してくだ
さい。

バグを報告する

6.1. JBOSS DEVELOPER STUDIO プラグインのインストール

JBoss Developer Studio の Drools プラグインは更新サイトより入手できます。

手順6.1 Drools JBoss Developer Studio プラグインのインストール

1. JBoss Developer Studio を起動します。

2. Help → Install New Software  と選択します。

3. Add をクリックして Add Repository メニューを入力します。

4. Name フィールドのソフトウェアサイトの名前を指定し、Location フィールドに URL
https://devstudio.jboss.com/updates/7.0/integration-stack/ を追加します。

5. OK をクリックします。

6. 利用可能なオプションより JBoss Business Process and Rule Development 機能を選
択して Next をクリックし、再度 Next をクリックします。

7. ライセンスの内容を確認し、該当のラジオボタンを押して内容に同意し、Finish をクリック
します。

8. プラグインのインストールが完了してから、JBoss Developer Studio を再起動します。

バグを報告する

6.2. DROOLS ランタイムの設定

Red Hat JBoss Developer Studio で JBoss BRMS プラグインを使用するには、ランタイムを設定する必
要があります。

ランタイムは、このソフトウェアの特定のリリースを示す jar ファイルを集めたもので、ビジネス資産
のコンパイルおよび実行に必要なライブラリを提供します。

JBoss BRMS の汎用デプロイ可能 zip アーカイブ (EAP 6 のデプロイ可能 zip アーカイブではありませ
ん) の jboss-brms-engine.zip アーカイブにあるランタイム jar ファイルを展開します (Red Hat カスタ
マーポータル より入手可能です)。

手順6.2 BRMS ランタイムの設定

スタートガイド

18

https://access.redhat.com
https://bugzilla.redhat.com/enter_bug.cgi?cf_environment=Build+Name%3A+22694%2C+Getting+Started+Guide-6.0-1%0ABuild+Date%3A+05-08-2014+13%3A33%3A33%0ATopic+IDs%3A%0A9490-623282+%5BSpecified%5D&comment=Title%3A+Red+Hat+JBoss+Developer+Studio%0A%0ADescribe+the+issue%3A%0A%0A%0ASuggestions+for+improvement%3A%0A%0A%0AAdditional+information%3A&product=JBoss+BRMS+Platform+6&component=Documentation&version=6.0.2
https://devstudio.jboss.com/updates/7.0/integration-stack/
https://bugzilla.redhat.com/enter_bug.cgi?cf_environment=Build+Name%3A+22694%2C+Getting+Started+Guide-6.0-1%0ABuild+Date%3A+05-08-2014+13%3A33%3A33%0ATopic+ID%3A+9495-591882+%5BSpecified%5D&comment=Title%3A+JBoss+Developer+Studio+%E3%83%97%E3%83%A9%E3%82%B0%E3%82%A4%E3%83%B3%E3%81%AE%E3%82%A4%E3%83%B3%E3%82%B9%E3%83%88%E3%83%BC%E3%83%AB%0A%0ADescribe+the+issue%3A%0A%0A%0ASuggestions+for+improvement%3A%0A%0A%0AAdditional+information%3A&cf_build_id=Translation+9495-591882-75559+ja+%5BSpecified%5D&product=JBoss+BRMS+Platform+6&component=Documentation&version=6.0.2
https://access.redhat.com


1. JBoss Developer Studio メニューより Window を選択し、Preferences をクリックします。

2. Drools → Installed Drools Runtimes  と選択します。

3. Add... をクリックし、新しいランタイムの名前を指定します。 Browse をクリックしてラン
タイムが存在するディレクトリーを選択します。OK をクリックし、選択したランタイムを
JBDS に登録します。

4. 横にあるチェックボックスをクリックして、作成したランタイムをデフォルトの Drools ラン
タイムとして指定します。

5. OK をクリックします。既存のプロジェクトがある場合は、JBDS を再起動してランタイムの更
新を行う必要があると、ダイアログボックスに表示されます。

バグを報告する

6.3. JBOSS BRMS サーバーの設定

Red Hat JBoss BRMS サーバーを実行するよう、JBoss Developer Studio を設定できます。

手順6.3 サーバーの設定

1. Drools ビューを開きます。Window → Open Perspective → Other の順に選択し、Drools を
選択して OK をクリックします。

2. Window → Show View → Other... の順に選択して Server → Servers と選択し、サーバー
ビューを追加します。

3. サーバーパネルを右クリックしサーバーメニューを開き、New → Server を選択します。

4. JBoss Enterprise Middleware → JBoss Enterprise Application Platform 6.1+  と選択してサー
バーを定義し、Next をクリックします。

5. Browse をクリックし、ホームディレクトリーを設定します。JBoss BRMS がインストールさ
れた JBoss EAP 6.1.1 のインストールディレクトリーを選択します。

6. Name フィールドにサーバー名を指定します。設定ファイルが設定されていることを確認して
から Finish をクリックします。

バグを報告する

6.4. GIT リポジトリーから JBOSS DEVELOPER STUDIO へのプロジェク
トのインポート

中心の Git 資産リポジトリーへ接続するよう、JBoss Developer Studio を設定できます。リポジトリー
にはルール、モデル、関数、およびプロセスのバージョンが保存されます。この Git リポジトリーはす
でに KIE Workbench によって定義されている必要があります。

ローカルの Git リポジトリーをインポートするか、リモート Git リポジトリーをクローンする必要があ
ります。

手順6.4 ローカル Git リポジトリーのインポート

1. Red Hat JBoss BRMS サーバーが稼働していない場合は、サーバータブよりサーバーを選択
し、Start アイコンをクリックして起動します。

第6章 RED HAT JBOSS DEVELOPER STUDIO
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2. File → Import... と選択し、Git フォルダーを選択します。Git フォルダーを開き、Projects
from Git を選択して Next をクリックします。

3. リポジトリーソースとして Existing local repository  を選択し、Next をクリックします。

図6.1 Git リポジトリーの詳細

4. 使用できるリポジトリーのリストから設定するリポジトリーを選択します。

5. 次のウィンドウでプロジェクトを一般プロジェクトとしてインポートし、Next をクリックし
ます。このプロジェクトに名前を付け、Finish をクリックします。

手順6.5 リモート Git リポジトリーのクローン

1. Red Hat JBoss BRMS サーバーが稼働していない場合は、サーバータブよりサーバーを選択
し、Start アイコンをクリックして起動します。

2. セキュアシェルサーバーが稼働していない場合は、以下のコマンドを使用して同時に起動しま
す。コマンドは、Linux および Mac 固有のみになります。これらのプラットフォームで sshd
がすでに起動しているとこのコマンドに失敗しますが、無視しても問題ありません。

3. File → Import... と選択し、Git フォルダーを選択します。Git フォルダーを開き、Projects
from Git を選択して Next をクリックします。

4. Clone URI としてリポジトリーソースを選択し、Next をクリックします。

5. 次のウインドウに Git リポジトリーの詳細を入力し、Next をクリックします。

/sbin/service sshd start

スタートガイド
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図6.2 Git リポジトリーの詳細

6. 次のウインドウでインポートするブランチを選択し、Next をクリックします。

7. このプロジェクトのローカルストレージを定義するオプションが表示されます。空でないディ
レクトリーを入力 (または選択) して設定の変更を行い、Next をクリックします。

8. 次のウィンドウでプロジェクトを一般プロジェクトとしてインポートし、Next をクリックし
ます。このプロジェクトに名前を付け、Finish をクリックします。

バグを報告する

6.5. DROOLS プロジェクトの作成

手順6.6 新しい Red Hat JBoss Developer Studio プロジェクトの作成

1. メインメニューから File → New → Project を選択します。
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Drools → Drools Project と選択し、Next をクリックします。

2. プロジェクト名を Project name: テキストボックスに入力し、Next をクリックします。

注記

JBoss Developer Studio は、サンプル HelloWorld ルールファイルをプロジェク
トに追加するオプションを提供します。Next をクリックしてこのデフォルトを
許可し、以下の手順でサンプルプロジェクトをテストします。

3. Drools ランタイムを選択します (またはデフォルトを使用します)。

4. Drools 6.0.x と互換性のあるコードを選択します。GroupID、ArtifactID、および 
Version を入力し、Finish をクリックします。

5. プロジェクトをテストするには、主なメソッドを含む Java ファイルを右クリックして、Run
→ run as  → Java Application の順に選択してください。

Console タブに出力が表示されます。

バグを報告する
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第7章 BUSINESS RESOURCE PLANNER
Business Resource Planner  は、Red Hat JBoss BRMS では技術プレビューとして使用できます。
Business Resource Planner はライトウェイトの組み込み可能なプランニングエンジンで、プランニン
グの問題を最適化します。通常の Java TM プログラマーがプランニングの問題を効率的に解決できるよ
うにし、最適化ヒューリスティックおよびメタヒューリスティックと、大変効率的なスコア計算を組
み合わせます。

プランナーは、次のようなさまざまなユースケースの解決に便利です。

従業員/患者の勤務表: プランナーを使用して看護婦の勤務シフトを作成でき、患者のベッド管
理を追跡できます。

学校の時間割: プランナーは、授業、コース、試験、および会議のプレゼンテーションの計画を
容易にします。

工場の計画: プランナーは、自動車の組み立てライン、機械の待機計画、および作業計画を追跡
します。

在庫の削減: プランナーを使用すると、紙や金属などの資源の消費を削減し、無駄を最小限にす
ることができます。

バグを報告する

7.1. BUSINESS RESOURCE PLANNER のインストール

1. Red Hat カスタマーポータル にアクセスし、ユーザークレデンシャルを使用してログインしま
す。

2. Downloads → Red Hat JBoss Middleware → Download Software  の順に選択します。

3. Products ドロップダウンメニューより BPM Suite を選択します。

4. Version ドロップダウンメニューより、製品バージョン 6.0.2 を選択します。

5. Red Hat JBoss BPM Suite 6.0.2 Business Resource Planner を選択
し、Download をクリックします。

バグを報告する

7.2. BUSINESS RESOURCE PLANNER サンプルの実行

1. コマンドラインで examples/ ディレクトリーに移動します。

2. Unix 環境では、以下のコマンドを実行します。

./runExamples.sh

Windows 環境では、以下のコマンドを実行します。

./runExamples.bat

3. 開かれた GUI アプリケーションサンプルよりサンプルを 1 つ選択し、任意の IDE で実行しま
す。

第7章 BUSINESS RESOURCE PLANNER
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バグを報告する
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