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. In accordance with CC-BY-SA, if you distribute this document or an adaptation of it, you must
provide the URL for the original version.

Red Hat, as the licensor of this document, waives the right to enforce, and agrees not to assert,
Section 4d of CC-BY-SA to the fullest extent permitted by applicable law.
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logo, and RHCE are trademarks of Red Hat, Inc., registered in the United States and other
countries.
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other countries.
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概要

本ガイドには、Red Hat JBoss BPM Suite の使用を開始するための情報が記載されています。
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第1章 RED HAT JBOSS BPM SUITE のクイックスタート
本セクションでは、Red Hat JBoss BPM Suite をダウンロード、インストールおよび実行する方法につ
いて説明します。インストールの詳細な手順や他のインストール方法については、Red Hat JBoss
BPM Suite Installation Guide を参照してください。

前提条件

システムに Java のサポート対象バージョンがインストールされていること。Java のサポート
対象バージョンについては、Red Hat カスタマーポータルの Red Hat JBoss BPM Suite 6 でサ
ポートされる構成 を参照してください。

Red Hat JBoss EAP サーバーインストールのバージョン 6.4 以降があること。インストーラー
ファイルを使用している場合は、Red Hat JBoss EAP 6 のバージョン 6.4.7 以降がインストー
ルされているはずです。

注記

Red Hat JBoss EAP サーバーを更新する必要があることがあります。インストーラーで
更新の必要性が通知された場合は、Red Hat カスタマーポータル から最新のパッチをダ
ウンロードし、『Red Hat JBoss EAP Installation Guide』に記述された更新手順に
従ってください。

手順: Red Hat JBoss BPM Suite のクイックスタート

1. Red Hat カスタマーポータルの Software Downloads セクションからインストーラーをダウン
ロードします。

2. 次のコマンドを実行して、インストーラーを起動します。

java -jar jboss-bpmsuite-VERSION-installer.jar

3. インストールプロセスを完了させます。インストール後に Red Hat JBoss BPM Suite にアクセ
スするためのユーザー名とパスワードを書き留めます。

4. インストールが終了したら、Red Hat JBoss BPM Suite のインストール先である EAP_HOME
ディレクトリーにコマンドプロンプトで移動します。

5. サーバーを起動します。

bin/standalone.sh

6. Web ブラウザーを開いて、http://localhost:8080/business-central/ に移動し、イ
ンストール時に作成した Red Hat JBoss BPM Suite アプリケーションにアクセスする際のユー
ザー名とパスワードでログインします。

これで Red Hat JBoss BPM Suite が正常にインストールされ、稼働します。

次のステップ

ロールに関する知識を深めます (「ロールの定義」)

追加ユーザーを作成します (「ユーザーの作成」 を参照)

Red Hat JBoss BPM Suite 6.4 スタートガイド
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Hello World プロジェクトを作成します (4章Hello World プロジェクト)

Red Hat JBoss EAP と他のコンテナーでのインストールについての詳細情報は、『Red Hat JBoss
BPM Suite Installation Guide』を参照してください。
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第2章 インストール
本セクションでは、インストール済みの Red Hat JBoss EAP 6.4 以降に Red Hat JBoss BPM Suite をイ
ンストールする方法について説明します。別のコンテナーをお使いの場合は、Red Hat JBoss BPM
Suite Installation Guide を参照してください。

1章Red Hat JBoss BPM Suite のクイックスタート の指示に従っていれば、JAR インストーラーを使用
して Red Hat JBoss BPM Suite が既にインストールされています。その場合は、次のステップ の指示
に従ってください。

注記

Red Hat JBoss BPM Suite は、UTF-8 エンコーディングで機能するよう設計されていま
す。JVM で別のエンコーディングシステムを使用すると、予期せぬエラーが発生する可
能性があります。JVM で UTF-8 を使用するようにするには、"-
Dfile.encoding=UTF-8" のシステムプロパティーを使用してください。

2.1. RED HAT JBOSS EAP 用 RED HAT JBOSS BPM SUITE のダウン
ロード

1. ブラウザーで Red Hat カスタマーポータルの DOWNLOADS セクションを開きます。

2. 表示された 製品のダウンロード ページで Red Hat JBoss BPM Suite をクリックして、ログイ
ンします。

3. バージョン のドロップダウンメニューからバージョン 6.4 を選択します。

4. Red Hat JBoss BPM Suite 6.4.0 Deployable for EAP 6 を選択して、Download をクリックし
ます。Red Hat JBoss EAP 7.0 を使用している場合は、Red Hat JBoss BPM Suite 6.4.0
Deployable for EAP 7 を選択します。

2.2. RED HAT JBOSS BPM SUITE を RED HAT JBOSS ENTERPRISE
APPLICATION PLATFORM にインストールする

2.2.1. Red Hat JBoss EAP 新規インスタンスへのインストール

Red Hat JBoss Enterprise Application Platform にデプロイ可能なパッケージをインストールするには、
以下の手順に従います。

1. 「Red Hat JBoss EAP 用 Red Hat JBoss BPM Suite のダウンロード」 でダウンロードした ZIP
アーカイブを Red Hat JBoss Enterprise Application Platform ホームディレクトリー
(EAP_HOME、jboss-eap-6.4 ディレクトリー) の 親 ディレクトリーに移動します。

2. ダウンロードした ZIP アーカイブを展開し、EAP_HOME ディレクトリー (jboss-eap-6.4) に
マージします。

Red Hat JBoss BPM Suite 6.4 スタートガイド
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警告

この手順は、Red Hat JBoss EAP のインストールに使用したユーザーアカ
ウントと同じアカウントで実行します。このアカウントは、スーパーユー
ザーアカウント 以外 である必要があります。

3. プロンプトが出たら、EAP_HOME ディレクトリーにあるファイルをダウンロードした ZIP アー
カイブで上書きします。

2.2.2. 既存の Red Hat JBoss EAP 上でのインストール

警告

以下の手順は Red Hat JBoss BRMS をインストールするためのものであって、既
存の JBoss BRMS インスタンスを更新するものではありません。ターゲットとな
る EAP に既存の JBoss BRMS インストールがないことを確認してください。

設定済みの Red Hat JBoss EAP にデプロイ可能なパッケージをインストールするには、以下の手順に
従います。

1. 「Red Hat JBoss EAP 用 Red Hat JBoss BPM Suite のダウンロード」 でダウンロードした
Red Hat JBoss EAP 用のデプロイ可能な ZIP パッケージを展開します。

2. ダウンロードした zip アーカイブを解凍しますが、ファイルを上書きしないでください。手作
業で以下のファイルを EAP_HOME ディレクトリー (jboss-eap-6.4) にマージします。

jboss-eap-6.4/domain/configuration/* (JBoss BPM Suite には JMS が必要なた
め、Red Hat JBoss BPM Suite ディストリビューションで提供される domain.xml にある
すべてのプロファイルに JMS がデフォルトで追加されることに留意してください。)

jboss-eap-6.4/standalone/configuration/* (JBoss BMP Suite には JMS が必要
なため、Red Hat JBoss BPM Suite ディストリビューションで提供されるすべてのプロ
ファイルの設定ファイルに (standalone.xml および standalone-ha.xml を含む) JMS
がデフォルトで追加されることに注意してください。)

警告

この作業は、必ず EAP をインストールしたユーザーアカウントで実行する
ようにしてください。スーパーユーザーアカウントは使用しないでくださ
い。






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3. Red Hat JBoss BPM Suite ディストーションから jboss-eap-
6.4/standalone/deployments を EAP_HOME ディレクトリーにコピーします。

注記

Red Hat JBoss EAP にすでにデプロイメントがある場合は、現在のデプロイメ
ントが Red Hat JBoss BPM Suite のデプロイメントと同じ名前にならないよう
にしてください。

2.3. ロールの定義

サーバーを起動し、Business Central へログインする前に、ユーザーアカウントを作成する必要があり
ます。本セクションでは、Red Hat JBoss BPM Suite で使用されるユーザーロールについて説明しま
す。

admin: admin ロールを持つユーザーは、アプリケーションの管理者です。管理者は、ユーザー
やリポジトリー (作成およびクローン) を管理し、アプリケーションに必要な変更を加えるため
の完全アクセスがあります。管理者はシステム内のすべてのエリアにアクセスできます。

developer: 開発者はほとんどの機能にアクセスでき、ルール、モデル、プロセスフロー、
フォーム、およびダッシュボードを管理できます。資産リポジトリーを管理でき、プロジェク
トの作成、構築、およびデプロイが可能です。また、Red Hat JBoss Developer Studio を使用
してプロセスを表示できます。developer ロールは、新規リポジトリーの作成やクローンなど、
管理機能の一部のみを使用できません。

analyst: analyst ロールは、プロジェクトをモデル化するため、すべての機能へアクセスでき
ますが、analyst ロールを持つユーザーは Authoring → Administration へアクセスできませ
ん。また、Deployment → Artifact Repository ビューなど、開発者を対象とする低レベル機能
の一部にもアクセスできませんが、Project Editor を使用すると、Build & Deploy ボタンを使用
できます。

user: ユーザーまたはビジネスユーザーは、特定プロセスを操作するために使用されるビジネ
スタスクリストの作業を行います。このロールを持つユーザーは、ダッシュボードへのアクセ
スやプロセスの管理が可能です。

manager: マネージャーはシステムを監視し、ビジネスプロセスに関する統計、ビジネスプロ
セスのパフォーマンス、ビジネス指標、およびシステムのその他のレポート内容に関心があり
ます。このロールを持つユーザーは BAM にのみアクセスできます。

ロールに関する詳しい情報は、『Red Hat JBoss Administration and Configuration
Guide』の「Access Control」の項を参照してください。ロールとタスクの対話に関する詳しい情報
は、『Red Hat JBoss BPM Suite User Guide』の「User Task」項を参照してください。

遭遇する可能性のあるその他のロールを以下に示します。

REST API のアクセス制御ロール。詳しい情報は、『Red Hat JBoss BPM Suite Development
Guide』の「Control of REST API」を参照してください。

Intelligent Process Server kie-server ルール。詳しい情報は、『Red Hat JBoss BPM Suite
Development Guide』の「Intelligent Process Server and Realtime Decision Server」の章を参
照してください。

管理リポジトリー機能の kiemgmt ロール。『Red Hat JBoss BPM Suite Administration and
Configuration Guide』の「Managing Assets」の項を参照してください。

Red Hat JBoss BPM Suite 6.4 スタートガイド

8

https://access.redhat.com/documentation/en/red-hat-jboss-bpm-suite/6.4/single/administration-and-configuration-guide/#access_control2
https://access.redhat.com/documentation/en/red-hat-jboss-bpm-suite/6.4/single/user-guide/#sect_user_task
https://access.redhat.com/documentation/en/red-hat-jboss-bpm-suite/6.4/single/development-guide/#control_api
https://access.redhat.com/documentation/en/red-hat-jboss-bpm-suite/6.4/single/development-guide/#chap_the_exec_server
https://access.redhat.com/documentation/en/red-hat-jboss-bpm-suite/6.4/single/administration-and-configuration-guide#managing_assets


注記

上記のロールは、ユーザー作成のプロセス中に入力します。

2.4. ユーザーの作成

新規ユーザーの追加を開始するには、Unix システムでは add-user.sh スクリプトを、Windows シス
テムでは add-user.bat ファイルを EAP bin ディレクトリーから実行する必要があります。

手順: 新規ユーザーの作成

1. EAP_HOME ディレクトリーに移動します。

2. Unix システムでは、以下のコマンドを実行します。

bin/add-user.sh

Windows システムでは以下を実行します。

bin\add-user.bat

3. b を入力して、アプリケーションユーザーを選択し、Enter を押します。

4. Enter を押して、デフォルトのレルム (ApplicationRealm) を確定します。

5. ユーザー名入力のプロンプトが表示されたら、ユーザー名を入力し (例: helloworlduser)、
確認します。

重要

すでにあるロールやグループと選択したユーザー名が 競合しない ようにしてく
ださい。

たとえば、admin と呼ばれるロールがある場合は、admin という名前のユー
ザーは作成しないでください。

6. パスワード入力のプロンプトが表示されたらユーザーのパスワードを入力し (例: 
Helloworld@123)、再入力します。

注記

パスワードは 8 文字以上で、アルファベットの大文字と小文字 (A-Z、a-z)、1 文
字以上の数字 (0-9)、および 1 文字以上の特殊文字 (~ ! @ # $ % ^ * ( ) - _ + =) が
含まれる必要があります。

7. ロール入力のプロンプトが表示されたら、ユーザーが必要とするロールをコンマ区切りのリス
トで入力します。詳細は、「ロールの定義」 を参照してください。
Business Central のユーザーには analyst か admin のロールを割り当てる必要があり、
Dashboard Builder のユーザーには admin ロールの割り当てが必要となります。

8. ユーザーを追加することを確認します。

9. 次のプロンプトで yes を入力してクラスタリングを有効にします。
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2.5. サーバーの起動

サーバーは、2 つのモードのいずれかで起動できます。

standalone.sh スクリプトを使用した standalone モード。

standalone-secure.sh スクリプトを使用したstandalone-secure モード。

注記

サーバーをドメインモードで起動する場合は、対応するスクリプトはそれぞれ 
domain.sh と domain-secure.sh になります。

デフォルトの起動スクリプトは standalone.sh になります。これは、パフォーマンス重視で最適化
されています。パフォーマンスモードでサーバーを実行する場合は、以下の手順に従います。

1. コマンドラインで EAP_HOME ディレクトリーに移動します。

2. Unix 環境 の場合は以下を実行します。

bin/standalone.sh

Windows 環境の場合は以下を実行します。

bin\standalone.bat

standalone-secure.sh スクリプトは、セキュリティー重視で最適化されています。このスクリプト
では、既知の脆弱性を保護するセキュリティーポリシーが適用されます。

注記

実稼働環境では standalone-secure.sh スクリプトの使用が推奨されます。

警告

セキュリティーマネージャーを使用すると、パフォーマンスが著しく低下します。
どちらのスクリプトを使用するかは、個々の状況を判断して決定してくださ
い。「Java Security Manager とパフォーマンス管理」を参照してください。

セキュアモードでサーバーを起動するには、以下の手順に従います。

1. コマンドラインで EAP_HOME ディレクトリーに移動します。

2. Unix 環境 の場合は以下を実行します。

bin/standalone-secure.sh

Windows 環境の場合は以下を実行します。


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bin\standalone-secure.bat

注記

JAR インストーラーを使用して Red Hat JBoss BPM Suite をインストールした場合は、
インストール中にセキュリティーポリシーの適用を選択できます。インストーラーでは
別個の standalone-secure.sh スクリプトは提供されません。

2.6. JAVA SECURITY MANAGER とパフォーマンス管理

Red Hat JBoss BPM Suite で MVEL スクリプトの評価をサンドボックス化できるように Java Security
Manager (JSM) を有効にすると、高負荷環境でのパフォーマンスが低下します。Red Hat JBoss BPM
Suite アプリケーションをデプロイする場合は、ご自身の環境でのパフォーマンスニーズを考慮してく
ださい。以下のガイドラインを使用して、セキュアで高パフォーマンスな Red Hat JBoss BPM Suite ア
プリケーションをデプロイしてください。

高負荷環境でパフォーマンス重視の場合は、

他のシステムで開発され、適切なレビューを経ているアプリケーションをデプロイします。

システム上で analyst ロールのあるユーザーを作成しないでください。

これらの対策が取られた場合には、パフォーマンスが低下しないので JSM を無効にした状態のままで
も安全です。

高負荷にならないテストおよび開発環境や、ルールやプロセスのオーサリングが外部ネットワークに公
開される環境では、

MVEL の評価を適切にサンドボックス化してセキュリティーを強化するため、JSM を有効にし
ます。

JSM が無効な状態で、analyst ロールを持つユーザーに Business Central コンソールへのロ
グインを許可しないでください。これは安全でないため、推奨されません。
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第3章 BUSINESS CENTRAL へのログイン
Business Central にログインするには、以下を実行します。

1. Red Hat JBoss BPM Suite でサーバーを起動します。

2. Web ブラウザーで http://localhost:8080/business-central にアクセスします。ドメ
イン名から実行するようユーザーインターフェースが設定されている場合
は、http://www.example.com:8080/business-central のように localhost をドメイ
ン名に置き換えます。

3. インストール中に作成されたユーザー認証情報を使用してログインします (例: ユーザー名 
helloworlduser とパスワード Helloworld@123)。
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第4章 HELLO WORLD プロジェクト
本章では、Hello World ビジネスプロセスで Hello World プロジェクトを作成する方法を説明します。

このビジネスプロセスでは、Hello World! メッセージを表示し、実行を完了します。完全な when-
then ルール機能を使用する他の例については、『Red Hat JBoss BPM Suite Development
Guide』の「Getting Started with Rules and Facts」を参照してください。

ここからの章では、以下を行います。

1. リポジトリーの作成

2. Hello World プロジェクトの作成

3. Hello World プロセスのモデル化

4. プロジェクトの構築と、ローカルで実行されている実行エンジンへのデプロイ

5. Hello World プロセスの実行

6. プロセス実行の監視

4.1. リポジトリー構造の作成

ビジネスアセットはすべてリポジトリーに格納されており、これらは組織単位 (Organizational Unit) に
関連付けられています。デフォルトでは、アーティファクトリポジトリーには組織単位が含まれていま
せん。ビジネスプロセスなどのビジネスアセットを作成するには、まず組織単位と Git リポジトリーを
作成します。

リポジトリーにはプロジェクトが格納されます。プロジェクトには、コンテンツをディレクトリー構造
にすることが可能な任意のパッケージ構造を含めることができます。パッケージにはビジネスアセット
を含めることができます。アーティファクトリポジトリーの詳細については、『Red Hat JBoss BPM
Suite User Guide』を参照してください。

リポジトリー構造を作成するには、以下の手順に従います。

1. Web ブラウザーで Business Central を開き、admin ロールを持つユーザー (たとえ
ば、helloworlduser) としてログインします。

2. 組織単位を作成します。

a. Authoring → Administration をクリックします。

b. パースペクティブメニューで Organizational Units → Manage Organizational Units をク
リックします。

c. 表示された Organizational Unit Manager のビューで、Add をクリックします。
表示された Add New Organizational Unit ダイアログボックスで以下のようにユニットプ
ロパティーを定義し、Ok をクリックします。

Name: Loan Application

Owner: finance-dept@company.org

3. Loan Application 組織単位に新しいリポジトリーを作成します。
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a. Authoring → Administration をクリックします。

b. パースペクティブメニューで Repositories → New repository をクリックします。

c. 表示された New Repository ダイアログボックスで以下のようにリポジトリープロパ
ティーを定義します。

Repository Name: helloworldrepo

Organizational Unit: Loan Application

d. Finish をクリックします。

4. Authoring → Project Authoring をクリックします。

5. 組織単位ドロップダウンボックスの Project Explorer で Loan Application を選択し、リポ
ジトリードロップダウンボックスで helloworldrepo を選択します。

図4.1 Project Explorer の Loan Application 組織グループでの helloworldrepo リポジトリー
の選択

6. helloworld リポジトリーでプロジェクトを作成します。

a. パースペクティブメニューで New Item → Project をクリックします。

b. 表示された New Project ウィザードで以下のようにプロジェクトプロパティーを定義しま
す。

Project Name: Hello World

Group ID: org.bpms

Artifact ID: HelloWorld

Version ID: 1.0

c. Finish をクリックします。
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第5章 HELLO WORLD プロセス
本章では、引き続き Hello World の例を取り上げます。エンドツーエンドのビジネスプロセスを作成
し、基本的な Hello World プロセスの作成について説明します。

5.1. ビジネスプロセスの作成

新しいビジネスプロセス定義を作成するには、以下の手順に従います。

1. Authoring → Project Authoring をクリックし、Project Authoring パースペクティブを表示し
ます。

2. 左側の Project Explorer ビューで Loan Application 組織単位、helloworldrepo リポジト
リー、および HelloWorld プロジェクトを選択します。

3. パースペクティブメニューで New Item → Business Process をクリックして、プロセス定義
の詳細を定義します。

Hello World をビジネスプロセス名として入力します。

org.bpms.helloworld パッケージを選択します。これにより、ビジネスプロセス定義を
作成する場所が定義されます。

4. OK をクリックします。

作成されたプロセス定義のキャンバスを持つプロセスデザイナーが開かれます。

5.2. ビジネスプロセスのモデル化

ビジネスプロセス定義を作成したら、ビジネスプロセスデザイナーでビジネスプロセスを設計します。
ビジネスプロセスデザイナーは右側のタブに開きます。プロジェクトエクスプローラーのタブを閉じて
しまった場合は、BUSINESS PROCESSES 下の HelloWorld をクリックして、ビジネスプロセスデ
ザイナーを再度開きます。正しいパッケージ (org.bpms.helloworld) を選択するようにしてくださ
い。

プロセスコンテンツを設計するには、以下の手順に従います。

1. Start Event 要素 (  ) をクリックすると、ノードの周りで quick linker アイテムが確認できま

す。 

2. Task (  ) アイコンをクリックし、外向きのシーケンスフローおよび Start Event へ紐付けさ
れた Task 要素を作成します。

3. Business Process Designer タブ右上隅にある  をクリックし、Object Library パレットを展
開します。

4. パレットから Timer (Catching Intermediate Events の下にある) をドラッグアンドドロップ
し、クイックリンクメニューの Edge 要素を使用して Task を Timer 要素に紐付けします。
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5. Timer Event 要素へ紐付けされる End Event 要素を作成します (クイックリンク機能を使用する
か、パレットからドラッグします)。

図5.1 Hello World プロセスのドラフト

5.3. 要素プロパティーの定義

要素プロパティーを定義するには、以下を実行します。

1. 右上隅にある二重矢印 (  ) をクリックし、Properties タブを展開します。

2. キャンバスの空白部分をクリックします。Properties タブに Hello World プロセスのプロパ
ティーが表示されます。
必要なプロパティーは事前定義されていますが、必要に応じて値を変更できます。

3. Start 要素と End 要素はオプションのプロパティーのみを持ちますが、Task 要素ではタイプが
必要となり、タイプ固有のプロパティーを定義する必要があります。Task をクリックし、必要
なプロパティーを定義します。

Name: ScriptTask

Task Type: Script

Script Language: java

Script:  をクリックし、以下を入力します: System.out.println("Hello 
World!");

これで実行時にスクリプトを実行するタスクが定義されました。スクリプトは Java で定義さ
れ、System.out.println("Hello World!") を実行します。このメソッドは、サーバーの
標準出力に Hello World! を書き込みます。デフォルトでは、サーバーの標準出力はサー
バーが起動したコンソールになります。

4. 実行を検証できるようにするために、プロセスが実行時に待機するようタイマーのプロパ
ティーを定義します。タイマーをクリックし、実行を待機する時間を定義します。

Time Duration:  をクリックして次を入力します: 5m

この結果、プロセスはスクリプトタスクの実行後にタイマーイベントで 5 分間待機します。

5. タイマー要素をクリックし、Name: Timer と入力してから、ビジネスプロセスエディターの上
部にある Save をクリックしてプロセスを保存します。

6. Save this item  のプロンプトが表示されます。Check-in comment を入力してください。
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注記

check-in comment とは、変更内容の簡単な説明などで、資産の保存時には毎回
入力する必要があります。

7. プロセスデザイナーのツールバーにある  をクリックし、Start validating を選択して、定義
されたプロセスが有効であることを確認します。1 つ以上の検証エラーがある要素は外側がオ
レンジ色になります。検証機能については、『Red Hat JBoss BPM Suite User Guide』を参
照してください。

プロセス要素やそれらのプロパティーに関する詳細は、『Red Hat JBoss BPM Suite User Guide』を
参照してください。

5.4. ビルドとデプロイ

Hello World プロセスをインスタンス化する前に、プロジェクトをビルドし、実行サーバーへデプロイ
します。

1. Business Central のメインメニューで、Authoring → Project Authoring をクリックします。

2. Project Explorer で Hello World プロジェクトを見つけます。

3. プロジェクトエディターでプロジェクトを開きます。Project Explorer で Open Project Editor
をクリックします。

4. プロジェクト画面に正しいプロジェクト詳細が表示されていることを確認し、プロジェクト画
面ビューの右上隅にある Build → Build & Deploy を選択します。

図5.2 プロジェクトエディターでの Hello World プロジェクトプロパティー

プロジェクトのビルドおよび実行サーバーへのデプロイメントが完了し、インスタンス化が可能になっ
たことを伝える緑色の通知が画面上部に表示されます。

5.5. ビジネスプロセスのインスタンス化
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Hello World プロセスのインスタンスを作成する (つまり、ビジネスプロセスを実行する) には、以下の
手順に従います。

1. メインメニューで Process Management → Process Definitions をクリックします。

2. 表示された Process Definitions タブで HelloWorld プロセス定義を見つけます。どれも利用
可能になっていない場合は、Refresh ボタンをクリックしてリストにプロセス定義を表示させ
ます。

3. プロセス定義エントリーの横にある Start (  ) をクリックし、ダイアログボックスで
Submit をクリックして、プロセスのインスタンス化を確認します。
現在ログインしているユーザーがプロセス所有者となってプロセスがインスタンス化され、プ
ロセスフォームが表示されます。ビジネスプロセスのフォームを定義する場合は、プロセスの
インスタンス化の際に、フォームを使ってユーザーからの入力を要求します。詳細について
は、『Red Hat JBoss BPM Suite User Guide』を参照してください。

起動されたプロセスインスタンスの詳細を示す Process Instance Details ビューが表示されま
す。Hello World! メッセージが標準出力に表示されます。通常、標準出力はサーバーが起動した
ターミナルエミュレーターになります。プロセスはタイマーが完了するまで待機します。

Options → Process Model をクリックして現在の実行ステータスを表示します。

図5.3 HelloWorld のリアルタイム実行図: タイマーイベントの実行

5.6. ビジネスプロセスの中止

「ビジネスプロセスのインスタンス化」 を完了していれば、実行サーバーにアクティブな Hello World
プロセスインスタンスが格納されています。プロセスインスタンスは、Process Instances ビューで確
認できます。

Process Management → Process Instances をクリックしてビューを表示します。
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Process Instances ビューでは、選択されたプロセスの行をクリックしてインスタンスの詳細を表示で

きます。また、プロセスインスタンスへのシグナル送信 (  ) や、その中止 (  ) など、
基本的な管理アクションを実行することもできます。

ビジネスプロセスはインスタンス化されると、タイマーイベントを待機します。インスタンスを中止す

るには、インスタンス情報がある行で  をクリックします。インスタンスが Active プロセスイ
ンスタンスのリストで表示されなくなり、Aborted リストに表示されます。

図5.4 中止されたプロセスインスタンスのリスト
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第6章 HELLO WORLD ビジネスルール
Red Hat JBoss BPM Suite には Red Hat JBoss BRMS が統合されているため、本章ではビジネスルール
の仕組みと Red Hat JBoss BPM Suite への統合方法について説明します。

特定のビジネスルールグループのビジネスルールを実行する新しいビジネスルールタスクを Hello
World プロセスに追加します。

ここでは非常に単純な統合ケースを取り上げますが、実稼働環境では高度な概念や技術が必要になるこ
とがあります。ビジネスルール の詳細については、『Red Hat JBoss BPM Suite Development
Guide』を参照してください。

6.1. ビジネスルールの作成

ビジネスルールは when-then ステートメントで定義され、true の場合に何かが発生します (例: 18 歳以
上の場合に特定のコンテンツにアクセスできる)。ビジネスルールは DRL ファイルに保存されます。

Hello World プロジェクトの helloworldrule ビジネスルールを定義するには、以下の手順に従いま
す。

1. Project Explorer で Loan Application 組織単位、helloworldrepo リポジト
リー、HelloWorld プロジェクト、default パッケージを選択します。

2. DRL ファイルを作成します。

a. パースペクティブメニューで New Item → DRL file に移動します。

b. Create new DRL file ダイアログボックスで、リソース名を helloworldrule と定義し、
パッケージが default に設定されていることを確認します。

c. OK をクリックします。

3. DRL エディターで表示された helloworldrule.drl ファイルで、ルールを定義します。

このルールは when 条件を定義しません。つまり、チェックされる (実行するため呼び出され
る) と常に true になり、Hello World! フレーズが出力されます。

4. 保存 をクリックします。

5. Save this item  のプロンプトが表示されます。Check-in comment を入力して、Save をク
リックしてください。

6.2. ビジネスルールタスクの追加

ビジネスルールタスクは、特定のルールフローグループに属するルールをチェックするタスクのことで
す。

rule "helloworldrule"
ruleflow-group "helloworldgroup"

when
then
  System.out.println("Hello World!");
end
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ビジネスルールタスクをプロセスに追加するには、以下の手順に従います。

1. Project Explorer で、組織単位パスの横にある矢印をクリックします。

2. BUSINESS PROCESSES を展開し、「HelloWorld」を選択します。
注記: 新規インストールでプロジェクトを作成している場合は、矢印をクリックするまで
BUSINESS PROCESSES メニューは表示されません。

図6.1 Hello World の組織単位パス

3. Hello World プロセスで表示されるビジネスプロセスデザイナーで、プロセス要素を持つ
Object Library パレットを展開します。ビジネスプロセスデザイナータブの左上にある二重矢

印のボタン (  ) をクリックします。

4. Tasks メニューを展開し、ビジネスルールタスクを右側のキャンバスへドラッグアンドドロッ
プします。
フローの紐付けを調整し、タスクをワークフローへ統合します。

5. ビジネスルールタスクを選択し、そのプロパティーを Properties パネルで定義します。

Name: BusinessRule

Ruleflow Group: helloworldgroup
Ruleflow Group プロパティーは、タスクの実行時にチェックされるルールのグループを定
義します。この例では、helloworldrule.drl ファイルで定義された helloworldrule
ルールのみが、helloworldgroup グループに存在します。

図6.2 Hello World プロセスのビジネスルールタスクおよびそのプロパティー
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6. Save ボタンをクリックし、変更を保存します。

6.3. ビルドとデプロイ

プロジェクトを構築し、実行サーバーへデプロイします。

1. Business Central のメインメニューで、Authoring → Project Authoring をクリックします。

2. Project Explorer で Hello World プロジェクトを見つけます。

3. プロジェクトエディターでプロジェクトを開きます。Project Explorer で Open Project Editor
をクリックします。

4. Version を 1.0.1 に設定します。

5. Save をクリックして、変更保存を確認します。

6. プロジェクト画面に正しいプロジェクト詳細が表示されていることを確認し、プロジェクト画
面ビューの右上隅にある Build → Build & Deploy をクリックします。

プロジェクトのビルドおよび実行サーバーへのデプロイメントが完了し、インスタンス化が可能になっ
たことを伝える緑色の通知が画面上部に表示されます。

6.4. ビジネスプロセスのインスタンス化

Hello World プロセスのインスタンスを作成するには、以下の手順に従います。

1. メインメニューで Process Management → Process Definitions をクリックします。

2. 表示された Process Definitions タブで新規の HelloWorld プロセス定義を見つけます。この
例では、org.bpms:HelloWorld:1.0.1 になります。利用可能になっていない場合
は、Refresh ボタンをクリックしてプロセス定義を表示させます。

3. プロセス定義エントリーの横にある Start (  ) をクリックし、ダイアログボックスで
Submit をクリックして、プロセスのインスタンス化を確認します。
現在ログインしているユーザーがプロセス所有者となってプロセスがインスタンス化され、プ
ロセスフォームが表示されます。ビジネスプロセスのフォームを定義する場合は、プロセスの
インスタンス化の際に、フォームを使ってユーザーからの入力を要求します。詳細について
は、『Red Hat JBoss BPM Suite User Guide』を参照してください。

起動されたプロセスインスタンスの詳細を示す Process Instance Details ビューが表示されま
す。Hello World! メッセージが標準出力に 2 回出力されます。通常、標準出力はサーバーが起動し
たターミナルエミュレーターになります。

Options → Process Model をクリックして現在の実行ステータスを表示します。
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図6.3 Hello World のリアルタイム実行図: タイマーイベントの実行

第6章 HELLO WORLD ビジネスルール

23



第7章 BAM

7.1. RED HAT JBOSS BPM SUITE DASHBUILDER へのアクセス

Dashbuilder は、Red Hat JBoss BPM Suite に含まれるビジネスアクティビティー監視用の Web ベース
ユーザーインターフェースです。Business Central から Dashbuilder にアクセスするに
は、Dashboards → Process & Task Dashboards をクリックします。

表示されるダッシュボードには、左側で選択されたランタイムデータの統計が表示されます。
Dashbuilder で独自のダッシュボードを作成するには、Dashboards → Business Dashboards とク
リックして Dashbuilder を表示します。

7.2. インスタンスの監視

Dashbuilder は、実行エンジン上のランタイムデータ (プロセスインスタンスおよびタスク) の状態を監
視できる特別なダッシュボードを提供します。

このデータを表示するには、Dashboards → Process & Task Dashboard に移動します。

図7.1 プロセスおよびタスクダッシュボード

統計を表示するエンティティーをクリックします。
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第8章 RED HAT JBOSS DEVELOPER STUDIO
Red Hat JBoss Developer Studio は Eclipse をベースにした JBoss 統合開発環境 (IDE) です。最新の
Red Hat JBoss Developer Studio は Red Hat カスタマーポータルの DOWNLOADS セクションから入手
してください。Red Hat JBoss Developer Studio は Red Hat JBoss BRMS および Red Hat JBoss BPM
Suite 用のツールおよびインターフェースを持つプラグインを提供します。これらのプラグインはコ
ミュニティーバージョンの製品が基になっています。Red Hat JBoss BRMS プラグインは Drools プラ
グインと呼ばれ、BPM Suite プラグインは jBPM プラグインと呼ばれます。

Red Hat JBoss Developer Studio のインストールまたは設定の手順は、『Red Hat JBoss Developer
Studio』のドキュメントを参照してください。

警告

複数バイトの名前を処理する方法における問題のため、Red Hat JBoss Developer
Studio のインスタンスは、エンコーディングが UTF-8 に設定されたファイルで開
始する必要があります。$JBDS_HOME/studio/jbdevstudio.ini ファイルに 
"-Dfile.encoding=UTF-8" というプロパティーを追加することでこれが可能に
なります。

8.1. JBOSS CENTRAL

Red Hat JBoss Developer Studio を最初に起動する際には、JBoss Central はワークベンチのメインウィ
ンドウに表示されます。Start from scratch 下にあるメニューオプションを選択すると、JBoss Central
から新しいプロジェクトを作成できます。サンプルプロジェクトを起動するには、Start from a sample
下のリンクを選択します。

注記

GWT3 の問題のため、Red Hat JBoss Developer Studio では GWT3 を使用しないように
設定してください。以下のように、システムプロパティーを 0 に設定することで、これ
が可能になります。

# Do not use GTK 3.
export SWT_GTK3=0


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図8.1 JBoss Central

8.2. RED HAT JBOSS DEVELOPER STUDIO プラグインのインストール

JBoss Developer Studio の Drools および jBPM プラグインは更新サイトより入手できます。

手順: Drools および jBPM Red Hat JBoss Developer Studio プラグインのインストール

1. Red Hat JBoss Developer Studio を起動します。

2. Help → Install New Software をクリックします。

3. Add をクリックして Add Repository メニューに入ります。

4. Name フィールドの横にソフトウェアサイトの名前を指定し、Location フィールドに 
https://devstudio.jboss.com/10.0/stable/updates/integration-stack/ の
URL を追加します。

5. OK をクリックします。

6. 利用可能なオプションから JBoss Business Process and Rule Development 機能を選択し
て、Next をクリックし、もう一度 Next をクリックします。

7. ライセンス内容を確認して、該当のラジオボタンを押してライセンス内容に同意し、Finish を
クリックします。
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8. インストールが完了したら、Red Hat JBoss Developer Studio を再起動します。

8.3. DROOLS ランタイムの設定

Red Hat JBoss Developer Studio で Red Hat JBoss BRMS プラグインを使用するには、ランタイムを設
定する必要があります。

ランタイムは、このソフトウェアの特定のリリースを表す JAR ファイルを集めたもので、ビジネス資
産のコンパイルおよび実行に必要なライブラリを提供します。

手順: Red Hat JBoss BRMS Runtime の設定

1. Red Hat カスタマーポータルの DOWNLOADS セクションを開きます。

2. Red Hat JBoss BRMS をクリックしてログインします。

3. Red Hat JBoss BRMS 6.4.0 Core Engine をダウンロードします。

4. jboss-brms-VERSION-engine.zip に格納されているランタイム JAR ファイルを展開しま
す。

5. Red Hat JBoss Developer Studio メニューより Window → Preferences をクリックします。

6. Drools → Installed Drools Runtimes を選択します。

7. Add… ​ をクリックして、新しいランタイムの名前を入力し Browse をクリックして、展開した
ランタイムファイルのあるディレクトリーに移動します。OK をクリックして、選択したラン
タイムを Red Hat JBoss Developer Studio に登録します。

8. 横にあるチェックボックスをクリックして、作成したランタイムをデフォルトの Drools ランタ
イムとして指定します。

9. OK をクリックします。既存のプロジェクトがある場合はダイアログボックスが表示され、Red
Hat JBoss Developer Studio を再起動してランタイムを更新する必要があることが示されま
す。

8.4. RED HAT JBOSS BPM SUITE RUNTIME の設定

Red Hat JBoss BPM Suite の汎用デプロイ可能 ZIP アーカイブを Red Hat カスタマーポータル から以
前にダウンロードした場合には、ランタイムを構成する JAR ファイルは jboss-bpms-engine.zip
アーカイブにあります。

手順: jBPM ランタイムの設定

1. Red Hat カスタマーポータルの DOWNLOADS セクションを開きます。

2. Red Hat JBossBPM Suite をクリックしてログインします。

3. Red Hat JBoss BPM Suite 6.4.0 Core Engine をダウンロードします。

4. Red Hat JBoss Developer Studio メニューより Window → Preferences をクリックします。

5. jBPM → Installed jBPM Runtimes を選択します。
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6. Add… ​ をクリックして新しいランタイムの名前を入力し、Browse をクリックして、ランタイ
ムのあるディレクトリーに移動します。

7. OK をクリックし、新しいランタイムを選択してもう一度 OK をクリックします。既存のプロ
ジェクトがある場合はダイアログボックスが表示され、Red Hat JBoss Developer Studio を再
起動してランタイムを更新する必要があることが示されます。

8.5. RED HAT JBOSS BPM SUITE サーバーの設定

Red Hat JBoss BRM Suite サーバーを実行するように Red Hat JBoss Developer Studio を設定できま
す。

手順: サーバーの設定

1. Window → Perspective → Open Perspective → Other と選択した後に jBPM を選んで jBPM
を開き、OK をクリックします。

2. Window → Show View → Other… ​ と選択した後に、Server → Servers とクリックし
て、Server のビューを追加します。

3. Servers パネルを右クリックしてサーバーメニューを開き、New → Server を選択します。

4. JBoss Enterprise Middleware → JBoss Enterprise Application Platform 6.1+ を選択
し、Next をクリックして、サーバーを定義します。

5. JBoss EAP 6.4 Runtime をクリックして Create new runtime (next page) を選択しま
す。Next をクリックします。

6. Browse をクリックしてホームディレクトリーを設定します。Red Hat JBoss BPM Suite をイ
ンストールした Red Hat JBoss EAP 6.4 のインストールディレクトリーを選択します。

7. Name フィールドにサーバーの名前を指定して、設定ファイルが設定されていることを確認
し、Finish をクリックします。

8.6. KIE NAVIGATOR

Kie Navigator を使用すると、Red Hat JBoss BPM Suite サーバーのコンテンツの閲覧、変更、およびデ
プロイが可能になります。つまり、Red Hat JBoss Developer Studio と Red Hat JBoss BPM Suite の
シームレスな統合ができるようになります。

Kie Navigator の設定

1. Red Hat JBoss Developer Studio で Window → Show View → Other… ​ とクリックします。

2. Kie Navigator と入力し、Kie Navigator オプションを選択します。

3. Red Hat JBoss Developer Studio で Red Hat JBoss BPM Suite サーバーが設定されていない場
合は、この設定を求められます。詳細は、「Red Hat JBoss BPM Suite サーバーの設定」 を参
照してください。

4. 使用するサーバー名を右クリックして、Properties を選びます。

5. kie のロールがあるユーザー名とパスワードを入力します。例えば、kie-server となりま
す。
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6. 以下を入力します。

KIE Application Name: business-central

HTTP Port: 8080

Git Port: 8001

注記

上記の値はデフォルト値です。Git または Business Central ポートのデフォ
ルト値を変更している場合は、その値を使用してください。

7. Use default Git Repository Path にチェックを入れ、Apply をクリックします。

8. Servers タブでサーバーを起動し、稼働するまで待機します。

9. Kie Navigator タブで使用するサーバーを右クリックし、Refresh をクリックします。Red Hat
JBoss BPM Suite git リポジトリーのコンテンツが確認できます。Red Hat JBoss Developer
Studio にインポートするプロジェクトをダブルクリックします。

Kie Navigator の機能
Kie Navigator ツリーでは、以下の 4 つのレベルを確認できます。

サーバー (  )

組織単位 (  )

リポジトリー (  )

プロジェクト (  )
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Kie Navigator サーバーレベル

 を右クリックすると、以下のオプションが選択できます。

Refresh

REST を実行してツリー全体を更新します。

Create Organization

新規の組織単位を作成します。

Properties

サーバーのプロパティーを表示します。

Kie Navigator 組織単位レベル

 を右クリックすると、以下のオプションが選択できます。

Add Repository…

別の組織単位に関連付けられていないリポジトリーを追加します。

Create Repository…

リポジトリーを作成します。

Delete Organization…

選択した組織単位を削除します。

Properties

選択した組織単位のプロパティーを表示します。

Kie Navigator リポジトリーレベル

 を右クリックすると、以下のオプションが選択できます。

Import Repository

リポジトリーをクローンして、Git Repository ビューで利用可能にします。このメニューのアクショ
ンは、リポジトリーがクローンされていない場合に利用可能になります。

Create Project…

プロジェクトを作成します。

Remove Repository…

選択したリポジトリーを削除します。

Show in Git Repository View

Git Repositories ビューを開いて、選択したリポジトリーをハイライト表示します。

Properties

選択したリポジトリーのプロパティーを表示します。

Kie Navigator プロジェクトレベル

 を右クリックすると、以下のオプションが選択できます。

Import Project

Red Hat JBoss Developer Studio にプロジェクトをインポートします。

Delete Project…

選択したプロジェクトを削除します。

Properties
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プロジェクトのプロパティーを表示します。

8.7. GIT リポジトリーから RED HAT JBOSS DEVELOPER STUDIO への
プロジェクトのインポート

注記

この追加機能は、Red Hat JBoss Developer Studio での作業には必須ではありません。

Red Hat JBoss Developer Studio は、中央の Git 資産リポジトリーへ接続するように設定できます。リ
ポジトリーにはルール、モデル、関数、およびプロセスが保存されます。

ローカルの Git リポジトリーをインポートするか、リモート Git リポジトリーをクローンすることがで
きます。

手順: リモート GIT リポジトリーのクローン

1. Server タブから Red Hat JBoss BPM Suite サーバーを選択し、Start アイコンをクリックして
起動します。

2. セキュアシェルサーバーが稼働していない場合は、以下のコマンドを使用してこれを起動しま
す。コマンドは、Linux および Mac 環境に固有のものです。これらのプラットフォームで 
sshd がすでに起動していると、このコマンドに失敗しますが、無視しても問題ありません。

/sbin/service sshd start

3. JBoss Developer Studio で File → Import… ​ とクリックし、Git フォルダーに移動します。Git
フォルダーを開き、Projects from Git を選択して Next をクリックします。

4. Clone URI としてリポジトリーのソースを選択して、Next をクリックします。

5. 次のウィンドウで Git リポジトリーの詳細を入力して 次へ をクリックします。
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図8.2 Git リポジトリーの詳細

6. 次のウインドウでインポートするブランチを選択し、Next をクリックします。

7. このプロジェクトのローカルストレージを定義するために、空でないディレクトリーを入力 (ま
たは選択) して設定を変更し、Next をクリックします。

8. 次のウィンドウでプロジェクトを一般プロジェクトとしてインポートし、Next をクリックしま
す。このプロジェクトに名前を付け、Finish をクリックします。

手順: ローカル GIT リポジトリーのインポート

1. Server タブから Red Hat JBoss BPM Suite サーバーを選択し、Start アイコンをクリックして
起動します。

2. JBoss Developer Studio で File → Import… ​ とクリックし、Git フォルダーに移動します。Git
フォルダーを開き、Projects from Git を選択して Next をクリックします。

3. Existing local repository としてリポジトリーのソースを選択して、Next をクリックします。
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図8.3 Git リポジトリーの詳細

4. 使用可能なリポジトリーリストから設定するリポジトリーを選択し、Next をクリックします。

5. 表示されたダイアログで、Wizard for project import group から Import as general project
のラジオボタンを選択して、Next をクリックします。プロジェクトの名前を指定して Finish
をクリックしてください。
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図8.4 プロジェクトインポートのウィザード

8.8. DROOLS プロジェクトの作成

手順: Red Hat JBoss Developer Studio 新規プロジェクトの作成

1. メインメニューから File → New → Project をクリックします。

2. Drools → Drools Project を選択して、Next をクリックします。

3. ここで、2 つ目のオプションを選択します。Red Hat JBoss Developer Studio では、Red Hat
JBoss BPM Suite の例があるプロジェクトが作成されます。Next をクリックします。

4. Project name: テキストボックスにプロジェクト名を入力して Finish をクリックします。

プロジェクトをテストするには、以下を実行します。

1. src/main/java ディレクトリーに移動し、com.sample パッケージを展開します。

2. Java クラスを右クリックして、Run As → Java Application を選択します。
Console タブに出力が表示されます。
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8.9. RED HAT JBOSS BPM SUITE プロジェクトの作成

手順: Red Hat JBoss Developer Studio での Red Hat JBoss BRM Suite プロジェクトの作成

1. メインメニューから File → New → Project を選択します。

2. jBPM → jBPM Project を選択して Next をクリックします。

3. ここで、2 つ目のオプションを選択します。Red Hat JBoss Developer Studio では、Red Hat
JBoss BPM Suite の例があるプロジェクトが作成されます。Next をクリックします。

4. Project name: テキストボックスにプロジェクト名を入力して Also include a sample JUnit
test for the process オプションにチェックを入れます。

5. Finish をクリックします。

プロジェクトをテストするには、以下を実行します。

1. src/main/java ディレクトリーに移動し、com.sample パッケージを展開します。

2. ProcessTest.java を右クリックして、Run As → JUnit Test を選択します。
Console タブに出力が表示されます。

第8章 RED HAT JBOSS DEVELOPER STUDIO

35



第9章 BUSINESS RESOURCE PLANNER
Business Resource Planner は軽量で組み込み可能なプランニングエンジンで、プランニングの問題を
最適化します。Java™ 開発者がプランニングの問題を効率的に解決できるようにし、最適化ヒューリ
スティックおよびメタヒューリスティックと、大変効率的なスコア計算を組み合わせます。

このプランナーは、次のようなさまざまなユースケースの解決に役立ちます。

従業員勤務表/患者の名簿: プランナーを使用して看護婦の勤務時間割を作成し、患者のベッド
管理を追跡できます。

学校の時間割: プランナーは、授業、コース、試験、および会議のプレゼンテーションの計画を
容易にします。

工場の計画: プランナーは、自動車の組み立てライン、機械の待機計画、および作業員のタスク
計画を追跡します。

在庫の削減: プランナーを使用すると、紙や金属などの資源の消費を削減し、無駄を最小限にす
ることができます。

9.1. BUSINESS RESOURCE PLANNER のインストール

1. Red Hat カスタマーポータルの DOWNLOADS セクションを開きます。

2. Red Hat JBossBPM Suite をクリックしてログインします。

3. バージョン のドロップダウンメニューからバージョン 6.4 を選択します。

4. Red Hat JBoss BPM Suite 6.4.0 Business Resource Planner を選択して、Download をク
リックします。

9.2. BUSINESS RESOURCE PLANNER サンプルの実行

1. コマンドラインで examples/ ディレクトリーに移動します。

2. Unix 環境では以下を実行します。

./runExamples.sh

Windows 環境では以下を実行します。

runExamples.bat

3. 表示された Examples GUI アプリケーションよりサンプルを 1 つ選択し、任意の IDE で実行し
ます。
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