Menu Close

15.3.4. バージョン範囲の指定

Mvn URL で version の値を指定する場合は、バージョン番号の代わりにバージョンの範囲 (標準の Maven バージョン範囲の構文を使用) を指定できます。角括弧([ and ]-to は包含範囲および括弧 および ))を表すものを使用して、排他的範囲を指定します。たとえば、範囲 [1.0.4,2.0) は、1.0.4 v < 2.0 を満たすすべてのバージョン v と一致します。以下のように Mvn URL でこのバージョン範囲を使用できます。

mvn:org.fusesource.example/bundle-demo/[1.0.4,2.0)