1.2.3. パースペクティブのカスタマイズ

現在のパースペクティブをカスタマイズするには、Window > Customize Perspective を選択します。これで Customize Perspective (パースペクティブのカスタマイズ) メニューが開き、表示可能なツールバー、メインメニューアイテム、コマンドグループ、ショートカットが設定可能となります。
ワークベンチ内の各ビューの場所は、ビューのタイトルをクリックして移動した場所にドラッグすることでカスタマイズできます。
パースペクティブメニューのカスタマイズ

図1.16 パースペクティブメニューのカスタマイズ

図1.16「パースペクティブメニューのカスタマイズ」Tool Bar Visibility タブを表示しています。名前が示すようにこのタブではツールバー表示を変更できます (図1.17「ツールバー」)。
ツールバー

図1.17 ツールバー

以下の図では Customize Perspective Menu の他のタブを表示しています。
Menu Visibility タブ

図1.18 Menu Visibility タブ

Menu Visibility タブでは、各メインメニューアイテムで表示される機能を設定します。メインメニューアイテムの概要については、『C/C++ Development User Guide』 の 『Reference』 > 『C/C++ Menubar』 か 『Java Development User Guide』 の 『Reference』 > 『Menus and Actions』 を参照してください。
Command Group Availability タブ

図1.19 Command Group Availability タブ

コマンドグループでは、機能またはオプションをメインメニューもしくはツールバーのエリアに追加します。Command Group Availability タブを使ってコマンドグループを追加もしくは削除します。Menubar detailsToolbar details フィールドでは、コマンドグループがそれぞれメインメニューとツールバーエリアに追加した機能もしくはオプションが表示されます。
Shortcuts タブ

図1.20 Shortcuts タブ

Shortcuts タブ タブでは、以下のサブメニューで利用可能なメニューアイテムを設定します。
  • File > New
  • Window > Open Perspective
  • Window > Show View