1.2. Eclipse ユーザーインターフェース

図1.4「Eclipse ユーザーインターフェース (デフォルト)」 内のユーザーインターフェース全体は、Eclipse ワークベンチ と呼ばれています。通常これは、コードの EditorProject Explorer ウィンドウ、いくつかのビューで構成されます。Eclipse ワークベンチ内のすべての要素は設定可能で、『Workbench User Guide』 (Help Contents) に詳細があります。ユーザーインターフェースのカスタマイズに関する概要は、「パースペクティブのカスタマイズ」 を参照してください。
Eclipse には異なる パースペクティブ の機能があります。パースペクティブは、ビューとエディターのセットで、特定の種類のタスクやプロジェクトに有用なものです。Eclipse ワークベンチには 1 つ以上のパースペクティブを入れることができます。図1.4「Eclipse ユーザーインターフェース (デフォルト)」 は C/C++ 向けのデフォルトのパースペクティブを表示しています。
また Eclipse は多くの機能をいくつかのクラスに分け、個別のメニューアイテム 内にこれらを格納します。たとえば、プロジェクト メニューにはプロジェクトのコンパイル/構築関連の機能が格納されます。ウィンドウ メニューにはパースペクティブやメニューアイテム、その他のユーザーインターフェース要素を作成/カスタマイズするオプションが格納されます。各メインメニューの簡単な概要については、『C/C++ Development User Guide』 の Reference>C/C++ Menubar か 『Java Development User Guide』 の ReferenceMenus and Actions を参照してください。
以下のセクションでは、Eclipse 統合開発環境 (IDE) のデフォルトのユーザーインターフェースで表示される異なる要素の高レベルな概要を説明します。
Eclipse ワークベンチは、開発プロセスの各フェーズで必須の数多くの機能やツールにおけるユーザーインターフェースを提供します。このセクションでは、Eclipse の主要ユーザーインターフェースの概要を説明します。
Eclipse ユーザーインターフェース (デフォルト)

図1.4 Eclipse ユーザーインターフェース (デフォルト)

図1.4「Eclipse ユーザーインターフェース (デフォルト)」 では C/C++ プロジェクト用のデフォルトのワークベンチが示されています。ワークベンチ内で利用可能なパースペクティブの切り替えを行うには、Ctrl+F8 を押します。パースペクティブのカスタマイズに関するヒントについては、「パースペクティブのカスタマイズ」 を参照してください。以下に続く図は、デフォルトの C/C++ パースペクティブで表示される基本的な要素です。
Eclipse Editor

図1.5 Eclipse Editor

Editor はソースファイルの書き込みおよび編集に使用します。Eclipse はほとんどのタイプのソース言語で、適正な言語エディターを自動検出し読み込みます (たとえば、.c で終わっているファイルには C Editor )。Editor を設定するには、Window > Preferences > language (たとえば、Java、C++) > Code Style に移動します。
Project Explorer

図1.6 Project Explorer

Project Explorer View は、全プロジェクトリソースの階層ビューを提供します (バイナリー、ソースファイルなど)。このビューからファイルを開いたり、削除したり、編集したりすることができます。
Project Explorer ViewView Menu ボタンを使うと、Project Explorer View のトップレベルアイテムをプロジェクトとするか working sets とするかを設定できます。working set は一つのセットとして任意に分類されたプロジェクトのグループです。これは、関連またはリンクしているプロジェクトの編成に便利なものです。
Outline Window

図1.7 Outline Window

Outline ウィンドウは、ソースファイル内のコードの圧縮ビューを提供します。Editor 内の選択ファイルからの異なる変数や関数、ライブラリー、その他の構造体の要素を詳細表示します。これらはすべて、エディター固有のものです。
Console View

図1.8 Console View

Eclipse の機能やプラグインプログラムのなかには出力を Console ビューに送信するものもあります。このビューの Display Selected Console を使うと異なるコンソール間の切り替えができます。
Tasks View

図1.9 Tasks View

Tasks ビューでは、コード内で特別にマークされたリマインダのコメントを追跡できます。このビューでは、各タスクコメントの場合が表示され、いくつかの方法でこれらを分類できます。
追跡されたコメントの例

図1.10 追跡されたコメントの例

ほとんどの Eclipse エディターは //FIXME または //TODO タグでマークされたコメントを追跡します。タスクタグ と呼ばれるこれらの追跡されたタグは、他の言語で記述されたソースファイルによって異なります。タスクタグを追加または設定するには、Window > Preferences に移動し、task tags のキーワードで特定のエディター/言語のタスクタグ設定メニューを表示します。
Task Properties

図1.11 Task Properties

別の方法では、Edit > Add Task に移動して、タスクの Properties メニュー (図1.11「Task Properties」) を開くこともできます。この方法だと、タスクタグを使わずにソースファイルの特定の場所にタスクを追加することができます。
Problems View

図1.12 Problems View

Problems ビューは、ビルドやクリーン、プロファイルの実行など特定のアクションの実行中に発生したエラーや警告を表示します。特定の問題に対する "quick fix (緊急措置) " の例を表示するには、問題を選択して Ctrl+1 を押します。

1.2.1. クイックアクセスメニュー

Eclipse で最も便利な機能の一つが、quick access メニューです。quick access メニューに単語を入力すると、その単語に関連したビューやコマンド、ヘルプファイル、その他のアクションの一覧が表示されます。このメニューを開くには、Ctrl+3 を押します。
クイックアクセスメニュー

図1.13 クイックアクセスメニュー

図1.13「クイックアクセスメニュー」Views > Project Explorer をクリックすると、Project Explorer ウィンドウが表示されます。CommandsMenusNewPreferences カテゴリーからアイテムを選択して、これをクリックして実行します。これは、メニューオプションやタスクバーのアイコンをクリックするのと同様の動作です。また、矢印キーを使って quick access メニューを移動することもできます。