1.4. Eclipse での Java ソースコードの編集

Red Hat Enterprise Linux 6 は Java (Java SE) 開発用の Eclipse プラグイン JDT を提供します。Java ソースコードや ant build.xml 用の特別エディターも含まれています。プログラムの実行およびデバッグの機能も利用できます。
Eclipse は Java 開発者用にフル機能搭載のインタラクティブな開発環境を提供します。
New Project ウィザード

Eclipse の New Project ウィザード は、Java プロジェクトの開始に必要な標準的セットアップのほとんどを実行します。これによりユーザーは、どの Java ランタイム環境を使用するかや望ましいプロジェクトファイルツリーのレイアウトなどの様々なオプションを選択したり、カスタマイズしたりすることができます。

既存プロジェクトのエクスポートと同じ手順を行い、場所を求められたら、代わりに既存プロジェクトの場所を入力します。
新規 Java プロジェクトの設定に関する詳細は、Help > Help Contents > Java Development > Getting Started > Basic Tutorial > Creating Your First Java Project を参照してください。
コンテンツアシスタンス

Eclipse の Java 開発環境 (JDT) は、豊富なコンテンツアシスタンス機能を提供することで、生産性を高め、エラーを減らします。これは通常、Ctrl + Space を押すと起動します。この機能に含まれるのは、コードやライブラリーでのメソッド名の完成や、Javadoc でのパラメーター名の挿入、メソッド呼び出しの際のパラメーターの記入などです。これは完全にカスタマイズ可能で、特定候補を禁止したり、コード記入の際に使用するカスタムコードテンプレートを追加したりすることができます。

これらの機能の概要については、Help > Help Contents > Java Development User Guide > Tips and Tricks を参照してください。
コードの書式設定

コードの書式設定は Ctrl + Shift + F でアクセスできる JDT の別の便利な機能です。書式設定は Window > Preferences > Java > Code Styler > Formatter に移動し、インストール済みの書式設定プロファイルを使用するか、プロジェクトのスタイルに一致するように新たなプロファイルを作成するかを選択することができます。

デバッグ機能

JDT にはデバッグ機能もいくつかあります。対象のコードの行の左マージンでダブルクリックすると、ブレークポイントが作成されます。デバッガーの実行中は、そのコード行でプログラムは停止するので、これはエラーの場所の検出に役立ちます。

デバッガーの初回実行時に設定されるデバッグパースペクティブは、デバッグに関連するビューをよりすぐれたものにする別のレイアウトです。たとえば、Expressions ビューは、現行フレームのコンテキスト内での Java 演算の評価を可能にします。
デバッグパースペクティブを構成するビューは、すべてのビューがそうであるように、Window > Show View でアクセスでき、これらのビューへのアクセスにデバッグする必要はありません。
デバッグ中に変数の上にカーソルを持って行くと、その値が表示されます。または、Variables ビューを使用します。デバッグビューを使用すると、プログラムの実行を管理し、スタック上の様々なフレームを参照することができます。
JDT でのデバッグに関する詳細は、Help > Help Contents > Java Development > Getting Started > Basic Tutorial > Debugging Your Programs を参照してください。
JDT 機能

JDT は高度にカスタマイズ可能で、幅広い機能があり、その一覧は、Window > Preferences > JavaProject > Properties の Java 設定で表示されます。JDT の詳細なドキュメントとその機能については、Help > Help Contents > Java Development User Guide にある 『Java Development User Guide』 を参照してください。