4.4.4.7. nsslapd-require-internalop-index

プラグインがデータを変更すると、データベースに書き込みロックがあります。大規模なデータベースでは、プラグインがインデックスのない検索を実行すると、プラグインはすべてのデータベースロックを使用し、データベースが破損したり、サーバーが応答しなくなります。この問題を回避するには、nsslapd-require-internalop-index パラメーターを有効にして、インデックス化されていない内部検索を拒否することができるようになりました。

パラメーター説明

エントリー DN

cn=database_name,cn=ldbm database,cn=plugins,cn=config

有効な値

on | off

デフォルト値

off

構文

DirectoryString

nsslapd-require-internalop-index: off