サポートされる構成およびコンポーネント

Red Hat CodeReady Studio 12.21

Red Hat CodeReady Studio でサポートされる構成およびコンポーネント

概要

本書には、Red Hat CodeReady Studio のサポートされる構成に関する情報と、各リリースに含まれるコンポーネントの詳細が記載されています。

多様性を受け入れるオープンソースの強化

Red Hat では、コード、ドキュメント、Web プロパティーにおける配慮に欠ける用語の置き換えに取り組んでいます。まずは、マスター (master)、スレーブ (slave)、ブラックリスト (blacklist)、ホワイトリスト (whitelist) の 4 つの用語の置き換えから始めます。この取り組みは膨大な作業を要するため、今後の複数のリリースで段階的に用語の置き換えを実施して参ります。詳細は、弊社 の CTO、Chris Wright のメッセージ を参照してください。

第1章 サポートされる構成およびコンポーネント

Red Hat CodeReady Studio の各リリースは、主要なオペレーティングシステム、Java 仮想マシン (JVM)、および Red Hat JBoss Enterprise Application Platform サーバーおよびテクノロジーでテストされ、サポートされています。
本ガイドでは、CodeReady Studio 12.21 リリースでサポートされる構成およびコンポーネントについて詳しく説明します。
CodeReady Studio の以前のリリースに関連する情報は、access.redhat.com の「Supported Configurations and Components」を参照してください。

1.1. CodeReady Studio のコンポーネント

CodeReady Studio 12.21 リリースは、以下の表に記載されているコンポーネントバージョンの Eclipse および JBoss Tools で構成されます。

CodeReady Studio

12.21

Eclipse

2021-09 GA

JBoss Tools

4.21.0

1.2. サポートされるプラットフォームおよびランタイムサーバー

CodeReady Studio 12.21 は、以下のバージョンの Red Hat JBoss Enterprise Application Platform をサポートします。

  • 7.x、 6.x
注記

これらのバージョンの JBoss EAP にビルドされた製品もサポートされます。これには、Red Hat JBoss Fuse Service Works (旧名 JBoss Enterprise SOA Platform) や Red Hat JBoss Portal (旧名 JBoss Enterprise Portal Platform) などがあります。6.x サーバーはテスト対象外となりました。

1.3. サポートされるフレームワーク

CodeReady Studio 12.21 リリースでサポートされるフレームワークを以下の表に示します。

JakartaEE

8

Hibernate

3.5、3.6、4.0、4.3、5.0、5.1、5.2、5.3、5.4

jQuery Mobile

1.3、1.4

AngularJS + Ionic

AngularJS 1.4.14
Ionic 1.0

1.4. サポートされるオペレーティングシステムおよび Java Development Kit

CodeReady Studio 12.21 リリースでサポートされるオペレーティングシステム、チップアーキテクチャー、および Java Development Kit を以下の表に示します。

オペレーティングシステムチップアーキテクチャーJava Development Kit

Red Hat Enterprise Linux 7、Red Hat Enterprise Linux 8

x86_64

OpenJDK 11

Microsoft Windows 8 および Microsoft Windows 10

x86_64

OpenJDK 11、Oracle JDK 11

macOS Catalina (10.15) および macOS Big Sur (11.0)

x86_64

Oracle JDK 11、OpenJDK 11

Fedora 33 および Fedora 34

x86_64

OpenJDK 11、Oracle JDK 11

Ubuntu 20.04 LTS および Ubuntu 21.04

x86_64

OpenJDK 11、Oracle JDK11

重要

Eclipse 2021-09 GA は、Java Development Kit 11 の CodeReady Studio 12.21 でテストされています。これよりも古い Jave Development Kit は CodeReady Studio の実行ではサポートされません。ただし、古いバージョンは、アプリケーションの開発およびデプロイメントでサポートされます。

注記

Java Development Kit 11 で CodeReady Studio を実行する場合、既知の問題が存在します。詳細は、JBDS-4751 を参照してください。

1.4.1. その他のリソース