
Red Hat CodeReady Studio 12.16

コンテナーおよびクラウドベースの開発のスター
トガイド

Red Hat CodeReady Studio を使用したコンテナーおよびクラウドベースのアプリ
ケーション開発

Last Updated: 2021-03-23





Red Hat CodeReady Studio 12.16 コンテナーおよびクラウドベースの開発
のスタートガイド

Red Hat CodeReady Studio を使用したコンテナーおよびクラウドベースのアプリケーション開発

Levi Valeeva
levi@redhat.com

Supriya Takkhi
sbharadw@redhat.com

Yana Hontyk
yhontyk@redhat.com



法律上の通知

Copyright © 2021 Red Hat, Inc.

The text of and illustrations in this document are licensed by Red Hat under a Creative Commons
Attribution–Share Alike 3.0 Unported license ("CC-BY-SA"). An explanation of CC-BY-SA is
available at
http://creativecommons.org/licenses/by-sa/3.0/
. In accordance with CC-BY-SA, if you distribute this document or an adaptation of it, you must
provide the URL for the original version.

Red Hat, as the licensor of this document, waives the right to enforce, and agrees not to assert,
Section 4d of CC-BY-SA to the fullest extent permitted by applicable law.

Red Hat, Red Hat Enterprise Linux, the Shadowman logo, the Red Hat logo, JBoss, OpenShift,
Fedora, the Infinity logo, and RHCE are trademarks of Red Hat, Inc., registered in the United States
and other countries.

Linux ® is the registered trademark of Linus Torvalds in the United States and other countries.

Java ® is a registered trademark of Oracle and/or its affiliates.

XFS ® is a trademark of Silicon Graphics International Corp. or its subsidiaries in the United States
and/or other countries.

MySQL ® is a registered trademark of MySQL AB in the United States, the European Union and
other countries.

Node.js ® is an official trademark of Joyent. Red Hat is not formally related to or endorsed by the
official Joyent Node.js open source or commercial project.

The OpenStack ® Word Mark and OpenStack logo are either registered trademarks/service marks
or trademarks/service marks of the OpenStack Foundation, in the United States and other
countries and are used with the OpenStack Foundation's permission. We are not affiliated with,
endorsed or sponsored by the OpenStack Foundation, or the OpenStack community.

All other trademarks are the property of their respective owners.

概要

本書のトピックでは、コンテナー化されたアプリケーションの開発や、クラウドデプロイメントの
アプリケーションの開発を始める方法を説明します。
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第1章 コンテナーおよびクラウドを使用した開発

1.1. CODEREADY STUDIO での RED HAT CODEREADY CONTAINERS
ツールの使用

Red Hat CodeReady Containers (CRC) は、ローカルシステムに最小限の OpenShift 4 クラスターを提
供します。このクラスターは、開発およびテストを目的とする最低限の環境を提供します。これは主に
開発者のデスクトップでの実行を目的としています。ヘッドレス、複数開発者、またはチームベースの
セットアップなどの他のユースケースでは、完全な OpenShift インストーラー  を使用することが推奨
されます。

OpenShift の詳細は、OpenShift のドキュメント を参照してください。

前提条件

1. 最新リリースの CodeReady Containers とプルシークレットをダウンロード  しておく必要があ
ります。

2. CRC ファイルの展開しておく必要があります。
CRC のインストールおよび設定方法の詳細は、『Getting started with CodeReady Containers
Guide』の「Installation」の章を参照してください。

1.1.1. CodeReady Studio での Red Hat CodeReady コンテナーのダウンロードおよびイ
ンストール

CodeReady Studio で CodeReady コンテナーを設定する方法を説明します。ここでは、本章の前提条
件に記載されている手順が完了済みであることを仮定しています。

手順

1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。

第1章 コンテナーおよびクラウドを使用した開発
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3. 検索フィールドに Server と入力します。

4. Servers を選択します。

5. Open をクリックします。
Servers ビューが表示されます。

6. Servers ビューの任意の場所をクリックします。
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7. New → Server とクリックします。
Define a New Server ウィンドウが表示されます。
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8. CodeReady Containers 1.0+ を選択します。

9. Next をクリックします。
CodeReady Containers ウインドウが表示されます。

10. Browse をクリックして CRC binary を見つけます。

11. Browse をクリックして CRC Pull Secret File を見つけます。

12. Finish をクリックします。

新たに追加された CodeReady Containers 1.0+ サーバーアダプターが Servers ビューに表示されます。

1.1.2. OpenShift Container Platform ツールの使用

CodeReady Studio で OpenShift コンテナーを使用する方法を説明します。

前提条件

CRC サーバーアダプターが設定済みである必要があります。
詳細は、「CodeReady Studio での Red Hat CodeReady コンテナーのダウンロードおよびイン
ストール」 を参照してください。

手順

1. CodeReady Studio を起動します。
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2. CRC サーバーアダプターを起動します。

3. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。
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4. 検索フィールドに OpenShift と入力します。

5. OpenShift Explorer を選択します。

6. Open をクリックします。
OpenShift Explorer ビューが表示されます。

7. Ctrl+N キーを押します。
Select a wizard ウインドウが表示されます。

8. 検索フィールドに OpenShift と入力します。

9. OpenShift Application を選択します。

10. Next をクリックします。
Sign in to OpenShift ウィンドウが表示されます。
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11. Next をクリックします。
Create OpenShift Project ウインドウが表示されます。

12. プロジェクトに名前を付けます。

13. Finish をクリックします。
Select template ウインドウが表示されます。

第1章 コンテナーおよびクラウドを使用した開発
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14. テンプレートを選択します。

15. Next をクリックします。
Build Configuration ウインドウが表示されます。

Red Hat CodeReady Studio 12.16 コンテナーおよびクラウドベースの開発のスタートガイド

10



16. ビルド設定が正しいことを確認します。

17. Finish をクリックします。

新たに作成された OpenShift アプリケーションプロジェクトが OpenShift Explorer ビューに表示され
ます。
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その他のリソース

OpenShift Container Platform プロジェクトおよびアプリケーションで追加のタスクを実行す
る方法の詳細は、「OpenShift を使用したクラウド向けの開発」を参照してください。

1.2. CODEREADY STUDIO での RED HAT CONTAINER DEVELOPMENT
KIT ツールの使用

Red Hat Container Development Kit (CDK) は、Red Hat Enterprise Linux (RHEL) をベースとした事前
にビルドされたコンテナー開発環境です。CDK は、コンテナーベースのアプリケーションをすぐに開
発できるようにします。CodeReady Studio 内で CDK を簡単に設定できます。

1.2.1. CodeReady Studio での Container Development Kit のインストール

CodeReady Studio 内から CDK をインストールする方法を説明します。

前提条件

ハイパーバイザーがシステムにインストールされ、設定されていることを確認します。

VirtualBox、Linux KVM/libvirt (Linux)

xhyve (macOS)

Hyper-V (Windows)

システムでハードウェアの仮想化が有効になっていることを確認します。
詳細は『Setting Up the Virtualization Environment』を参照してください。

Red Hat Developer アカウントがあることを確認してください。
新規アカウントを作成する場合は、https://developers.redhat.com/ にアクセスします。

CDK の詳細は『Red Hat Container Development Kit Getting Started Guide 』を参照してください。

手順

1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。
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3. 検索フィールドに Server と入力します。

4. Servers を選択します。

5. Open をクリックします。
Servers ビューが表示されます。

6. Servers ビューの任意の場所をクリックします。
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7. New → Server とクリックします。
Define a New Server ウィンドウが表示されます。
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8. Red Hat Container Development Kit 3.2+ を選択します。

9. Next をクリックします。
Red Hat Container Development Environment ウインドウが表示されます。

10. Download and install runtime をクリックします。
Download Runtimes ウィンドウが表示されます。
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11. Red Hat CDK バージョンを選択します。

12. Next をクリックします。

13. access.redhat.com のログインクレデンシャルが正しいことを確認します。

14. Next をクリックします。

15. ライセンス契約書を読み、承諾してから Next をクリックします。

16. インストールフォルダーを選択し、Finish をクリックします。
ランタイムのダウンロードおよびインストールが完了するまで時間がかかることがあるため注
意してください。

17. Finish をクリックします。
新たに作成された Container Development Environment 3.2+ サーバーが Servers ビューに表
示されます。

Red Hat CodeReady Studio 12.16 コンテナーおよびクラウドベースの開発のスタートガイド

16



18. CDK server adapter → Start を右クリックします。

注記

サーバーアダプターを起動する前に CDK を設定しなかった場合は、CDK has
not been properly initialized! という警告が表示されます。

画面の指示に従って CDK を初期化します。

1.2.2. Docker ツールの使用

IDE で CDK サーバーを起動したら、2 つあるコンテナー開発ワークフローの 1 つに従って Docker ツー
ルを使用できます。

1.2.2.1. Dockerfile の作成

前提条件

CDK サーバーアダプターが設定済みである必要があります。
詳細は、「CodeReady Studio での Container Development Kit のインストール」  を参照してく
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詳細は、「CodeReady Studio での Container Development Kit のインストール」  を参照してく
ださい。

手順

1. CodeReady Studio を起動します。

2. CDK サーバーアダプターを起動します。

3. Ctrl+N キーを押します。
Select a wizard ウインドウが表示されます。
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4. 検索フィールドに Java Project と入力します。

5. Java Project を選択します。

6. Next をクリックします。
New Java Project ウインドウが表示されます。

第1章 コンテナーおよびクラウドを使用した開発
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7. プロジェクトに名前を付けます。

8. プロジェクトの場所を選択します。

9. Finish をクリックします。
新たに作成された Java プロジェクトが CodeReady Studio ビューに表示されます。

10. Java project → New → File を右クリックします。
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Create New File ウインドウが表示されます。
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11. 親フォルダーを選択します。

12. ファイルに名前を付けます。

13. Finish をクリックします。
新たに作成されたファイルが CodeReady Studio エディターに表示されます。

14. 新たに作成されたファイルに以下の内容を貼り付けます。

    # Use latest jboss/base-jdk:8 image as the base
FROM jboss/base-jdk:8

# Set the WILDFLY_VERSION env variable
ENV WILDFLY_VERSION 10.1.0.Final
ENV WILDFLY_SHA1 9ee3c0255e2e6007d502223916cefad2a1a5e333
ENV JBOSS_HOME /opt/jboss/wildfly

USER root
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# Add the WildFly distribution to /opt, and make wildfly the owner of the extracted tar content
# Make sure the distribution is available from a well-known place
RUN cd $HOME \
    && curl -O https://download.jboss.org/wildfly/$WILDFLY_VERSION/wildfly-
$WILDFLY_VERSION.tar.gz \
    && sha1sum wildfly-$WILDFLY_VERSION.tar.gz | grep $WILDFLY_SHA1 \
    && tar xf wildfly-$WILDFLY_VERSION.tar.gz \
    && mv $HOME/wildfly-$WILDFLY_VERSION $JBOSS_HOME \
    && rm wildfly-$WILDFLY_VERSION.tar.gz \
    && chown -R jboss:0 ${JBOSS_HOME} \
    && chmod -R g+rw ${JBOSS_HOME}

    # Ensure signals are forwarded to the JVM process correctly for graceful shutdown
    ENV LAUNCH_JBOSS_IN_BACKGROUND true

    USER jboss

    # Expose the ports we're interested in
    EXPOSE 8080

    # Set the default command to run on boot
    # This will boot WildFly in the standalone mode and bind to all interface
    CMD ["/opt/jboss/wildfly/bin/standalone.sh", "-b", "0.0.0.0"]

15. Ctrl+S キーを押して変更を保存します。

その他のリソース

Dockerfile の詳細は、「Dockerfile reference」を参照してください。

1.2.2.2. Container Development Environment を使用した Docker イメージのビルド

前提条件

CDK サーバーアダプターが設定済みである必要があります。
詳細は、「CodeReady Studio での Container Development Kit のインストール」  を参照してく
ださい。

Java プロジェクトと Docrefile を作成します。
詳細は、「Dockerfile の作成」 を参照してください。

手順

1. CodeReady Studio を起動します。

2. CDK サーバーアダプターを起動します。

第1章 コンテナーおよびクラウドを使用した開発
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3. Java プロジェクトを展開します。

4. Dockerfile → Run as → Docker Image Build を右クリックします。

Docker Image Build Configuration ウインドウが表示されます。
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5. コネクションとして Container Development Environment サーバーアダプターを選択します。

6. イメージに名前を付けます。

7. OK をクリックします。

Console ビューが表示され、docker イメージのビルドプロセスが表示されます。

1.2.2.3. その他のリソース

Docker Tooling の基本に関する詳細は、「Docker ツールの使用」を参照してください。

1.2.3. OpenShift Container Platform ツールの使用

CodeReady Studio で OpenShift コンテナーを使用する方法を説明します。

前提条件

CRC サーバーアダプターが設定済みである必要があります。
詳細は、「CodeReady Studio での Red Hat CodeReady コンテナーのダウンロードおよびイン
ストール」 を参照してください。

手順

1. CodeReady Studio を起動します。

2. CRC サーバーアダプターを起動します。
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3. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。
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4. 検索フィールドに OpenShift と入力します。

5. OpenShift Explorer を選択します。

6. Open をクリックします。
OpenShift Explorer ビューが表示されます。

7. Ctrl+N キーを押します。
Select a wizard ウインドウが表示されます。

8. 検索フィールドに OpenShift と入力します。

9. OpenShift Application を選択します。

10. Next をクリックします。
Sign in to OpenShift ウィンドウが表示されます。
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11. Next をクリックします。
Create OpenShift Project ウインドウが表示されます。

12. プロジェクトに名前を付けます。

13. Finish をクリックします。
Select template ウインドウが表示されます。
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14. テンプレートを選択します。

15. Next をクリックします。
Build Configuration ウインドウが表示されます。
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16. ビルド設定が正しいことを確認します。

17. Finish をクリックします。

新たに作成された OpenShift アプリケーションプロジェクトが OpenShift Explorer ビューに表示され
ます。
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その他のリソース

OpenShift Container Platform プロジェクトおよびアプリケーションで追加のタスクを実行す
る方法の詳細は、「OpenShift を使用したクラウド向けの開発」を参照してください。

1.2.4. その他のリソース

OpenShift Container Platform ツールでタスクを実行する方法の詳細は、「OpenShift を使用し
たクラウド向けの開発」を参照してください。

CodeReady Studio で OpenShift を使用する方法の詳細は、「CodeReady Studio での
OpenShift の基本」を参照してください。
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第2章 OPENSHIFT を使用したクラウド向けの開発

2.1. CODEREADY STUDIO での OPENSHIFT CONTAINER PLATFORM ア
プリケーションの作成

OpenShift Container Platform ツールを使用すると、OpenShift Container Platform アプリケーション
を作成、インポート、および変更できます。

2.1.1. 新規 OpenShift Container Platform コネクションの作成

IDE で OpenShift ツールを使用するには、CodeReady Studio の OpenShift Explorer ビューで
OpenShift コネクションを作成する必要があります。OpenShift コネクションは、IDE を OpenShift イ
ンスタンス (CDK、OpenShift Online、Kubernetes、minishift をベースとした) に接続します。コネク
ションは OpenShift Explorer ビューに表示されます。IDE に複数の OpenShift コネクションを設定で
きます。

手順

1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。
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3. 検索フィールドに OpenShift と入力します。

4. OpenShift Explorer を選択します。

5. Open をクリックします。
OpenShift Explorer ビューが表示されます。

6. OpenShift Explorer の任意の場所を右クリックします。
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7. New → Connection とクリックします。
Sign in to OpenShift ウィンドウが表示されます。

8. Server フィールドに OpenShift サーバーの URL を貼り付けます。

9. トークンまたはログインクレデンシャルを使用して認証します。

注記
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注記

または、ログインコマンドを OpenShift Container Platform Web UI からコピー
することもできます。

ログインクレデンシャルを取得するには、drop-down menu in the top right
corner → Copy Login Command とクリックします。

10. Finish をクリックします。

新たに追加されたコネクションが OpenShift Explorer ビューに表示されます。

2.1.2. 新規 OpenShift Container Platform プロジェクトの作成

通常ユーザーのリソースへのアクセスを一元管理するには、追加のアノテーションを持つ namespace
であるプロジェクトを作成する必要があります。

前提条件

OpenShift Container Platform コネクション。
新たに OpenShift Container Platform コネクションを作成する方法の詳細は、「新規
OpenShift Container Platform コネクションの作成」 を参照してください。

手順

1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。
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3. 検索フィールドに OpenShift と入力します。

4. OpenShift Explorer を選択します。

5. Open をクリックします。
OpenShift Explorer ビューが表示されます。

6. OpenShift Container Platform connection → New → Project を右クリックします。

New OpenShift Project ウインドウが表示されます。
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7. プロジェクトに名前を付けます。

8. Finish をクリックします。

新たに作成された OpenShift プロジェクトが OpenShift Explorer ビューに表示されます。

2.1.3. 新規 OpenShift Container Platform アプリケーションの作成

IDE の OpenShift Application ウィザードを使用して、デフォルトまたはカスタムテンプレートから
OpenShift Container Platform アプリケーションを作成できます。

前提条件

OpenShift Container Platform コネクション。
新たに OpenShift Container Platform コネクションを作成する方法の詳細は、「新規
OpenShift Container Platform コネクションの作成」 を参照してください。

OpenShift Container Platform プロジェクト。
新たに OpenShift Container Platform プロジェクトを作成する方法の詳細は、「新規
OpenShift Container Platform プロジェクトの作成」 を参照してください。

手順

1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。
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3. 検索フィールドに OpenShift と入力します。

4. OpenShift Explorer を選択します。

5. Open をクリックします。
OpenShift Explorer ビューが表示されます。

6. OpenShift Container Platform connection → New → Application を右クリックします。

Select template ウインドウが表示されます。
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7. テンプレートを選択します。

8. Next をクリックします。
Template Parameters ウインドウが表示されます。

9. Next をクリックします。
Resource Labels ウィンドウが表示されます。
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10. Add をクリックしてラベルを追加します。

11. Finish をクリックします。
Create Application Summary ウィンドウが表示されます。
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12. OK をクリックします。
Import OpenShift appliation ウインドウが表示されます。
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13. Git Clone Location を選択します。

14. Finish をクリックします。

新たに作成された OpenShift Container Platform アプリケーションが OpenShift Explorer ビューに表
示されます。

その他のリソース

OpenShift Container Platform でテンプレートを使用および作成する方法については、「Using
Templates」を参照してください。

2.1.4. 既存の OpenShift Container Platform アプリケーションの IDE へのインポート

IDE の OpenShift Explorer ビューには、OpenShift Container Platform アカウントに関連付けられたア
プリケーションが表示されます。Import OpenShift Application ウィザードを使用すると、これらのア
プリケーションのソースコードを個別に IDE にインポートできます。アプリケーションをインポートし
た後、アプリケーションのソースコードの変更、アプリケーションのビルド、およびWeb ブラウザーで
の表示を簡単に行うことができます。

前提条件

IDE にインポートするアプリケーションのソースは build config ファイルに指定されている必
要があります。

OpenShift Container Platform コネクション。
新たに OpenShift Container Platform コネクションを作成する方法の詳細は、「新規
OpenShift Container Platform コネクションの作成」 を参照してください。
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手順

1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。

3. 検索フィールドに OpenShift と入力します。

4. OpenShift Explorer を選択します。

5. Open をクリックします。
OpenShift Explorer ビューが表示されます。

6. OpenShift Container Platform connection → Import OpenShift Application を右クリックし
ます。
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Select Build Config ウインドウが表示されます。
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7. インポートするアプリケーションを選択します。

8. Next をクリックします。
Import OpenShift appliation ウインドウが表示されます。

9. Git Clone Location を選択します。

10. Finish をクリックします。

新たにインポートされた OpenShift Container Platform アプリケーションが OpenShift Explorer
ビューに表示されます。

2.1.5. サーバーアダプターを使用したアプリケーションのデプロイ

サーバーアダプターを使用すると、ワークスペースプロジェクトに追加した変更を OpenShift インスタ
ンス上で実行中の OpenShift アプリケーションにパブリッシュできます。これにより、アプリケーショ
ンの変更部分を OpenShift にデプロイされた Pod に直接デプロイできます。サーバーアダプターを使
用すると、ソースコードを Git リポジトリーにコミットせずに、アプリケーションの変更を直接実行中
の OpenShift アプリケーションにプッシュできます。

前提条件

OpenShift Container Platform コネクション。
新たに OpenShift Container Platform コネクションを作成する方法の詳細は、「新規
OpenShift Container Platform コネクションの作成」 を参照してください。

手順
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1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。

3. 検索フィールドに OpenShift と入力します。

4. OpenShift Explorer を選択します。

5. Open をクリックします。
OpenShift Explorer ビューが表示されます。

6. OpenShift Container Platform コネクションを展開します。

7. application → Server Adapterを右クリックします。
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Server Settings ウィンドウが表示されます。

8. Finish をクリックします。

Servers ビューが表示され、サーバーアダプターを起動します。

ブラウザーでアプリケーションを開くには、 application → Show In → Web Browser を右クリックしま
す。
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CodeReady Studio の組み込み Web ブラウザーが開かれ、アプリケーションが表示されます。

2.1.6. OpenShift Container Platform プロジェクトの削除

プロジェクトの開発を新たに開始する場合や、プロジェクトの開発が終了した後に、ワークスペースか
らプロジェクトを削除することがあります。プロジェクトを削除すると、プロジェクトに関連付けられ
たリソースはすべて削除されます。

手順

1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。
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3. 検索フィールドに OpenShift と入力します。

4. OpenShift Explorer を選択します。

5. Open をクリックします。
OpenShift Explorer ビューが表示されます。

6. OpenShift Container Platform コネクションを展開します。

7. project → Delete を右クリックします。
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Delete OpenShift Resource ウインドウが表示されます。

8. OK をクリックします。

これでプロジェクトが削除されます。

2.2. OPENSHIFT CONTAINER PLATFORM アプリケーションの設定および
リモート監視

IDE を使用すると、ユーザーは OpenShift Container Platform のリモートインスタンスへのコネクショ
ンを設定し、ログ (アプリケーションログおよびビルドログ) を使用して、実行中のアプリケーションを
トラブルシューティングおよび監視できます。

2.2.1. OpenShift Client Binaries の設定

前提条件

ポート転送の設定や、アプリケーションおよびビルドログのストリーミングを行う前に、必ず
OpenShift Client Binaries を設定する必要があります。

手順

1. CodeReady Studio を起動します。

2. Window → Preferences をクリックします。
Preferences ウィンドウが表示されます。
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3. 検索フィールドに OpenShift と入力します。

4. OpenShift を選択します。

5. Browse をクリックして、oc 実行可能ファイルを見つけます。

6. Apply and Close をクリックします。

これで、OpenShift Client Binaries が設定されます。

2.2.2. ポート転送の設定

Application Port Forwarding ウィンドウを使用すると、ローカルポートをリモートポートに接続し、
データのアクセスやアプリケーションのデバッグを行うことができます。以下のいずれかの理由で、
ポート転送は自動的に停止します。

OpenShift Container Platform コネクションの終了

IDE のシャットダウン

ワークスペースの変更

ポート転送は、IDE から OpenShift Container Platform に接続するたびに有効にする必要があります。

手順

第2章 OPENSHIFT を使用したクラウド向けの開発

51



1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。

3. 検索フィールドに OpenShift と入力します。

4. OpenShift Explorer を選択します。

5. Open をクリックします。
OpenShift Explorer ビューが表示されます。

6. OpenShift Container Platform コネクションを展開します。

7. application → Port Forwarding を右クリックします。
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Port Forwarding ウィンドウが表示されます。
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8. Find free local ports for remote ports ボックスを選択します。

9. Start All をクリックします。

10. OK をクリックします。

Console ビューが表示され、ポート転送の開始プロセスが表示されます。

2.2.3. Pod ログのストリーミング

Pod ログは、リモート OpenShift Container Platform インスタンスで実行されるアプリケーションの一
般的なログです。IDE のストリーミングアプリケーションログ機能は、アプリケーションを監視し、ア
プリケーションが失敗したりエラーを返した場合に以前の Pod ログを使用してトラブルシューティン
グを行います。

手順

1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。
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3. 検索フィールドに OpenShift と入力します。

4. OpenShift Explorer を選択します。

5. Open をクリックします。
OpenShift Explorer ビューが表示されます。

6. OpenShift Container Platform コネクションを展開します。

7. application → Port Log を右クリックします。
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Console ビューが表示され、Pod ログが表示されます。

2.2.4. ビルドログのストリーミング

ビルドログは、リモート OpenShift Container Platform インスタンスで実行されているアプリケーショ
ンへの変更を記録するログです。IDE のストリーミングビルドログ機能は、アプリケーションのビルド
プロセスの進捗や、アプリケーションのデバッグに使用されます。

手順

1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。
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3. 検索フィールドに OpenShift と入力します。

4. OpenShift Explorer を選択します。

5. Open をクリックします。
OpenShift Explorer ビューが表示されます。

6. OpenShift Container Platform コネクションを展開します。

7. application → Build Log を右クリックします。

Console ビューが表示され、ビルドログが表示されます。
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2.3. その他のリソース

OpenShift Application Explorer の詳細は、『CodeReady Studio ツールのスタートガイド』を
参照してください。
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第3章 DOCKER での開発

前提条件

Docker がシステムにインストールされている。
Docker のインストール方法の詳細は、「Get Docker」を参照してください。

Docker ID を取得している。
Docker ID を取得する方法の詳細は「Register for a Docker ID」を参照してください。

3.1. DOCKER コネクションの管理

3.1.1. CodeReady Studio での Docker アカウントの設定

CodeReady Studio で Docker アカウントを設定する方法を説明します。ここでは、本章の前提条件に
記載されている手順が完了済みであることを仮定しています。

手順

1. CodeReady Studio を起動します。

2. Window → Preferences をクリックします。
Preferences ウィンドウが表示されます。
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3. 検索フィールドに Registry Accounts と入力します。

4. Registry Accounts を選択します。

5. Add をクリックします。
New Registry Account ウィンドウが表示されます。

6. Docker ハブの Server Address を入力します。

7. Docker ID を Username として入力します。

8. Docker アカウントに関連するメールを入力します。

9. パスワードを入力します。

10. OK をクリックします。

11. Apply and Close をクリックします。

3.1.2. Docker コネクションのテスト

前提条件

CodeReady Studio に Docker アカウントが設定されている。
CodeReady Studio に Docker アカウントを設定する方法の詳細は、「CodeReady Studio での
Docker アカウントの設定」 を参照してください。

手順

1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。
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3. 検索フィールドに Docker と入力します。

4. Docker Explorer を選択します。

5. Open をクリックします。
Docker Explorer ビューが表示されます。

6. Docker socket → Edit を右クリックします。
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Edit Docker Connection ウインドウが表示されます。

7. Test Connection をクリックします。
コネクションが正しく設定されていれば、Ping succeeded! を示すウィンドウが表示されま
す。

8. OK をクリックします。
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9. Finish をクリックします。

3.1.3. Docker コネクションの編集

前提条件

CodeReady Studio に Docker アカウントが設定されている。
CodeReady Studio に Docker アカウントを設定する方法の詳細は、「CodeReady Studio での
Docker アカウントの設定」 を参照してください。

手順

1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。

3. 検索フィールドに Docker と入力します。

4. Docker Explorer を選択します。
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5. Open をクリックします。
Docker Explorer ビューが表示されます。

6. Docker socket → Edit を右クリックします。

Edit Docker Connection ウインドウが表示されます。
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7. Unix socket Location フィールドで Browse をクリックして新しいソケットを見つける
か、TCP Connection オプションを選択して URI を追加します。

8. Finish をクリックします。

3.2. DOCKER イメージの管理

3.2.1. Docker イメージのプル

手順

1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。
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3. 検索フィールドに Docker と入力します。

4. Docker Explorer を選択します。

5. Open をクリックします。
Docker Explorer ビューが表示されます。

6. Docker socket フォルダーを展開します。
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7. Images → Pull を右クリックします。

Pull Image ウインドウが表示されます。

8. Search をクリックします。
Search the Docker Registry for images ウィンドウが表示されます。
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9. 検索フィールドにイメージ名を入力します。

10. Next をクリックします。
Choose a tag for the selected image ウィンドウが表示されます。
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11. イメージのタグを選択します。

12. Finish をクリックします。
Search the Docker Registry for images ウィンドウが表示されます。
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13. Finish をクリックします。

新しい Docker イメージが Docker Explorer ビューに表示されます。

3.2.2. Docker イメージのプッシュ

Docker イメージをプッシュする前に、タグを付ける必要があります。CodeReady Studio で Docker イ
メージにタグを付け、プッシュする方法を説明します。

手順

1. CodeReady Studio を起動します。
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2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。

3. 検索フィールドに Docker と入力します。

4. Docker Explorer を選択します。

5. Open をクリックします。
Docker Explorer ビューが表示されます。
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6. Docker socket → Images を展開します。

7. タグを付けるイメージを右クリックします。

8. Add tag をクリックします。

Tag Image ウインドウが表示されます。

9. New Tag フィールドにタグを入力します。
タグは username/image_name:tag_name の形式で指定する必要があります。ここ
で、username は https://hub.docker.com 上の Docker ID、 image_name はイメージの名
前、tag_name はイメージのバージョンに置き換えます。
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10. Finish をクリックします。

11. tagged image → Push を右クリックします。

Push image to Registry ウインドウが表示されます。
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12. Docker ID で始まる Registry Account を選択します。

13. Finish をクリックします。

イメージをプッシュすると、Docker Cloud に表示されます。その後、このイメージは他の開発者が使
用できるようになります。

3.2.3. Docker イメージの実行

手順

1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。
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3. 検索フィールドに Docker と入力します。

4. Docker Explorer を選択します。

5. Open をクリックします。
Docker Explorer ビューが表示されます。

6. Docker socket → Images を展開します。
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7. 実行するイメージを右クリックします。

8. Run クリックします。

Docker Container settings ウィンドウが表示されます。
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9. コンテナーに名前を付けます。

10. Publish all exposed ports to random ports on the host interfaces チェックボックスを非選択
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10. Publish all exposed ports to random ports on the host interfaces チェックボックスを非選択
にします。

11. 8080 ポートのチェックボックスを選択します。

12. Finish をクリックします。
Console ビューが表示され、イメージを起動するプロセスが表示されます。

13. Web ブラウザーで http://localhost:8080/ に移動し、実行中のイメージを確認します。

3.2.4. Dockerfile でのイメージのビルド

既存のイメージを変更して、イメージをビルドまたは作成できます。通常、これには新しいパッケージ
をインストールする必要があります。新しい Docker イメージの指定は、Dockerfile で行います。

前提条件

ローカルマシンに Dockerfile が作成されている。
Dockerfile の作成方法の詳細は、「Dockerfile の作成」 を参照してください。

手順

1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。
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3. 検索フィールドに Docker と入力します。

4. Docker Images を選択します。

5. Open をクリックします。
Docker Images ビューが表示されます。

6. イメージの Build Image アイコンをクリックします。
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Build a Docker Image ウィンドウが表示されます。

7. repo/name:version の形式で、イメージに名前を付けます。

8. Browse をクリックして Dockerfile を見つけます。

9. Finish をクリックします。

Console ビューが表示され、ビルドのプロセスが表示されます。

3.3. DOCKER コンテナーの管理

Docker コンテナーは、Docker イメージを基にした分離されたプロセスです。コンテナーの作成後、
ユーザーはコンテナーを停止、起動、一時停止、一時停止解除、kill、または削除できます。また、コン
テナーのログの読み取りも可能です。

CodeReady Studio で Docker コンテナーを管理する方法を説明します。

手順
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1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
Show View ウインドウが表示されます。

3. 検索フィールドに Docker と入力します。

4. Docker Containers を選択します。

5. Open をクリックします。
Docker Containers ビューが表示されます。
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パネルを使用して、コンテナーを起動、一時停止、一時停止解除、停止、kill、再開、削除、または更新
できます。
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