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概要概要

本書のトピックでは、開発を効率的に進めるために Red Hat CodeReady Studio ツールの使用する
方法を説明します。
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第1章 CODEREADY STUDIO の GIT の基本
CodeReady Studio には、開発者がグラフィカルインターフェースから Git リポジトリーを管理できる
Git Perspective が含まれています。ここでは、Git Perspective における Git プロジェクトの基本ワーク
フローの概要と、最も一般的な Git 関連のタスクを実行する方法を説明します。

1.1. GIT PERSPECTIVE の設定

CodeReady Studio で Git Perspective を開く方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Window → Perspective → Open Perspective → Other とクリックします。

Open Perspective ウィンドウが表示されます。

Red Hat CodeReady Studio 12.16 CodeReady Studio ツールのスタートガイドツールのスタートガイド
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3. Git を選択します。

4. Open をクリックします。
Git Repositories ビューが表示されます。

第第1章章 CODEREADY STUDIO のの GIT の基本の基本
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1.2. GIT PERSPECTIVE でのリポジトリーの管理

1.2.1. 新規 Git リポジトリーの作成

Git Perspective を使用して新規 Git リポジトリーを作成する方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Git Perspective を開きます。

3. Create a new Git Repository and add it to this view アイコンをクリックします。

Create a Git Repository ウィンドウが表示されます。

デフォルトの Repository ディレクトリーディレクトリー へのパスが自動的に生成されます。デフォルトのパ

Red Hat CodeReady Studio 12.16 CodeReady Studio ツールのスタートガイドツールのスタートガイド
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デフォルトの Repository ディレクトリーディレクトリー へのパスが自動的に生成されます。デフォルトのパ
スが適切であれば、リポジトリーの作成を続行します。

必要に応じて、Create as bare repository チェックボックスを選択します。

注記注記

ベアリポジトリーは中央リポジトリーに推奨されますが、開発環境には推奨され
ません。ベアリポジトリーには、ソースファイルの作業用のコピーや、チェック
アウトされたコピーが含まれません。そのため、ファイルの編集や変更のコミッ
トができません。さらに、リポジトリーの Git リビジョンの履歴は、.git サブ
フォルダーではなく、ルートのフォルダーに保存されます。

4. Create をクリックします。
新しい Git リポジトリーがローカルマシンに作成され、Git Repositories ビューに表示されま
す。

1.2.2. 既存のローカル Git リポジトリーの追加

Git Perspective を使用して、ローカル Git リポジトリーを IDE に追加する方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Git Perspective を開きます。

3. Add an existing local Git Repository to this view アイコンをクリックします。

Add Git Repositories ウィンドウが表示されます。

4. Browse をクリックして、ローカルの Git リポジトリーを見つけます。

第第1章章 CODEREADY STUDIO のの GIT の基本の基本
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5. Search results フィールドで、.git ファイルへのパスを示すチェックボックスを選択します。

6. Add をクリックします。

ローカルリポジトリーが Git Repositories ビューに表示されます。

1.2.3. 既存の Git リポジトリーのクローン作成

Git Perspective を使用して、オンラインにすでに存在するリポジトリー (GitHub、GitLab) のローカル
クローンを作成する方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Git Perspective を開きます。

3. Clone a Git Repository and add the clone to this view アイコンをクリックします。

Red Hat CodeReady Studio 12.16 CodeReady Studio ツールのスタートガイドツールのスタートガイド
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Clone Git Repository ウィンドウが表示されます。

4. ソースリポジトリーのアドレスを URI フィールドに追加します。
Host および Repository path フィールドが自動的に入力されます。

5. Next をクリックします。

6. クローンを作成するブランチを選択します。

7. Next をクリックします。

8. Directory パスとInitial branch が正しく設定されていることを確認してください。

第第1章章 CODEREADY STUDIO のの GIT の基本の基本
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9. Finish をクリックします。

クローンしたリポジトリーが、CodeReady Studio の Git Repository ビューに表示されます。

1.2.4. リポジトリーのリモートの追加

Git Perspective にリポジトリーを設定したら、リポジトリーにリモートを追加します。これは、新たに

Red Hat CodeReady Studio 12.16 CodeReady Studio ツールのスタートガイドツールのスタートガイド
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Git Perspective にリポジトリーを設定したら、リポジトリーにリモートを追加します。これは、新たに
作成または追加されたリポジトリーに 1 度だけ必要な設定ステップです。

Git Perspective を使用してリポジトリーにリモートを設定する方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Git Perspective を開きます。

3. リポジトリーを展開します。

4. Remotes → Create Remote と右クリックします。
New Remote ウインドウが表示されます。

第第1章章 CODEREADY STUDIO のの GIT の基本の基本
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5. リモートに名前を付けます。

6. Configure push が選択されていることを確認します。

7. Create をクリックします。
Configure Push ウィンドウが表示されます。

Red Hat CodeReady Studio 12.16 CodeReady Studio ツールのスタートガイドツールのスタートガイド

12



8. Change をクリックします。
Select a URI ウィンドウが表示されます。

第第1章章 CODEREADY STUDIO のの GIT の基本の基本
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9. ソースリポジトリーの URI、ユーザー名、およびパスワードを追加します。
Host および Repository パスフィールドが自動的に入力されます。

10. Finish をクリックします。

11. Save をクリックします。

新たに追加されたリモートが、CodeReady Studio の Git Repositories ビューに表示されます。

Red Hat CodeReady Studio 12.16 CodeReady Studio ツールのスタートガイドツールのスタートガイド
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1.3. GIT PERSPECTIVE でのブランチの管理

1.3.1. 新規ブランチの作成

Git パースペクティブを使用して新規ブランチを作成する方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Git Perspective を開きます。

3. リポジトリーを展開して、すべてのリモートブランチを表示します。

4. master → Create Branch と右クリックします。

第第1章章 CODEREADY STUDIO のの GIT の基本の基本
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Create Branch ウインドウが表示されます。
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5. Select をクリックして、新規ブランチのソースを選択します。

6. ブランチに名前を付けます。

7. Configure upstream for push and pull および Checkout new branch チェックボックスを選択
します。

8. When pulling フィールドで、適切なオプションを選択します。

9. Finish をクリックします。

新たに追加されたブランチが、CodeReady Studio の Git Repositories ビューに表示されます。

第第1章章 CODEREADY STUDIO のの GIT の基本の基本
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1.3.2. ブランチの使用

Git Perspective で組み込みターミナルを開く方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Git Perspective を開きます。

3. Shift+Ctrl+Alt+T キーを押します。
Launch Terminal ウインドウが表示されます。
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4. Local Terminal を選択します。

5. Encoding を Default (ISO-8859-1) に設定します。

6. OK をクリックします。
Terminal ウインドウにコマンドラインターミナルが表示されます。

デフォルトでは、現在の作業用ディレクトリーは、現在のユーザーのホームディレクトリーであること
に注意してください。

1.3.3. プルリクエストの送信

特に共有リポジトリーで作業を行う場合、変更をマージする前に、ローカルリポジトリーを更新するこ
とが強く推奨されます。

Git Perspective を使用してプルリクエスト (PR) を送信する方法を説明します。

手順手順

1. CodeReady Studio を起動します。

第第1章章 CODEREADY STUDIO のの GIT の基本の基本
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2. Git Perspective を開きます。

3. repository → Pull と右クリックします。

Pull Results ウインドウが表示されます。

4. Close をクリックします。

これで、リモートリポジトリーからの変更がローカルリポジトリーにマージされます。

1.4. 変更のコミットおよびプッシュ

CodeReady Studio で変更をコミットおよびプッシュする方法を説明します。

手順手順

1. CodeReady Studio を起動します。

Red Hat CodeReady Studio 12.16 CodeReady Studio ツールのスタートガイドツールのスタートガイド
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2. Git Perspective を開きます。

3. repository → Commit と右クリックします。

Git Staging ビューが表示されます。

4. ステージする変更を選択します。

5. Add selected files to the index アイコンをクリックし、変更をステージします。

6. Commit Message フィールドにコミットメッセージを追加します。
Author および Committer フィールドが自動的に入力されます。

7. Commit をクリックして変更をコミットするか、Commit and Push をクリックして変更をコ
ミットし、リモートリポジトリーにプッシュします。
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Commit and Push オプションを選択すると、リポジトリーアドレスと、リポジトリーのアクセスユー
ザー名およびパスワードの入力を要求されることに注意してください。
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第2章 CODEREADY STUDIO における MAVEN の基本
Maven はアプリケーション開発の標準化されたビルドシステムを提供し、1 つ以上のリポジトリーから
依存関係のフェッチを容易にします。

ルート Maven プロジェクトは、複数の Maven モジュール (サブプロジェクト) のアグリゲーターとし
て提供できます。Maven プロジェクトの一部である各モジュールには、<module> エントリーがプロ
ジェクトの pom.xml ファイルに追加されます。pom.xml には <module> エントリーが含まれ、アグリアグリ
ゲーターゲーター pom とも呼ばれます。

モジュールがプロジェクトに含まれる場合は、親プロジェクトディレクトリーから実行された 1 つコマ
ンドにて、すべてのモジュールで Maven ゴールを実行できます。

2.1. 新規 MAVEN プロジェクトの作成

CodeReady Studio で新しい Maven プロジェクトを作成する方法を説明します。この手順では、パッ
ケージオプションが、マルチモジュールの Maven プロジェクトの要件である pom に設定されているこ
とを確認します。代わりにスタンドアロンの Maven プロジェクトを作成する場合は、パッケージオプ
ションを jar または war に設定します。

手順手順

1. CodeReady Studio を起動します。

2. Ctrl+N キーを押します。
Select a wizard ウインドウが表示されます。
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3. Wizards フィールドに Maven と入力します。

4. Maven Projects を選択します。

5. Next をクリックします。
New Maven Project ウインドウが表示されます。
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6. Create a simple project チェックボックスを選択します。

注記注記

Create a simple project チェックボックスを選択すると、archetype の選択が省
略され、プロジェクトタイプは POM (Project Object Model) に自動設定されま
す。スタンドアロンのプロジェクトを作成するには、Create a simple project
チェックボックスを未選択にし、画面の指示に従います。

7. Browse をクリックしてワークスペースの場所を選択します。

8. Next をクリックします。
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9. グループ ID とアーティファクト ID を入力します。

注記注記

値には、スペースや特殊文字を使用できません。使用できる特別文字は、ピリオ
ド (.)、アンダースコア (_)、およびダッシュ (-) のみです。一般的なグループ ID
またはアーティファクト ID の例は org.company-name_project-name です。

必要に応じて、プロジェクトに名前を付け、説明を追加できます。

10. Packaging を pom に設定します。

11. Finish をクリックします。

新たに作成された Maven プロジェクトが CodeReady Studio ビューに表示されます。

2.2. 既存の MAVEN プロジェクトのインポート

既存の Maven プロジェクトを CodeReady Studio にインポートする方法を説明します。
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2.2.1. ローカルに保存された既存の Maven プロジェクトのインポート

ローカルに保存された既存の Maven プロジェクトを CodeReady Studio にインポートする方法を説明
します。

手順手順

1. CodeReady Studio を起動します。

2. File → Import とクリックします。

Import ウインドウが表示されます。
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3. Select an import wizard フィールドに Maven と入力します。

4. Existing Maven Projects を選択します。

5. Next をクリックします。
Import Maven Project ウインドウが表示されます。
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6. Browse をクリックして、Maven プロジェクトを見つけます。

7. Finish をクリックします。

ローカルの Maven プロジェクトが CodeReady Studio ビューに表示されます。

2.2.2. リモートで保存された 既存の Maven プロジェクトのインポート

リモートで保存された既存の Maven プロジェクトを CodeReady Studio にインポートする方法を説明
します。

手順手順

1. CodeReady Studio を起動します。

2. Git Perspective を開きます。

3. Clone a Git repository and import existing Maven projects アイコンをクリックします。
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Check out as Maven project from SCM ウィンドウが表示されます。

4. ソースリポジトリーのアドレスを SCM URL フィールドに追加します。

5. Next をクリックします。
Select Project Location ウインドウが表示されます。
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6. Browse をクリックしてワークスペースの場所を選択します。

7. Finish をクリックします。

リモート Maven プロジェクトが Git Perspective ビューに追加されます。

2.3. 新しい MAVEN モジュールの作成

新しい Maven モジュールの作成方法を説明します。

前提条件前提条件

既存の Maven プロジェクト。
Maven プロジェクトの作成方法に関する詳細は、「新規 Maven プロジェクトの作成」  を参照
してください。

手順手順

1. CodeReady Studio を起動します。

2. Ctrl+N キーを押します。
Select a wizard ウインドウが表示されます。
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3. Wizards フィールドに Maven と入力します。

4. Maven Module を選択します。

5. Next ボタンをクリックします。
New Maven Module ウインドウが表示されます。
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6. Create a simple project チェックボックスを選択します。

注記注記

Create a simple project チェックボックスを選択すると、archetype の選択が省
略され、プロジェクトタイプは POM (Project Object Model) に自動設定されま
す。スタンドアロンのモジュールを作成するには、Create a simple project
チェックボックスを未選択にし、画面の指示に従います。

7. モジュールに名前を付けます。

8. Browse をクリックして、親プロジェクトを選択します。

9. Next をクリックします。
Configure Project ウインドウが表示されます。
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10. Packaging を pom に設定します。
必要に応じて、モジュールに名前を付け、説明を追加できます。

11. Finish をクリックします。

新たに作成された Maven モジュールが CodeReady Studio ビューに表示されます。

2.4. MAVEN 依存関係の MAVEN プロジェクトへの追加

CodeReady Studio で Maven プロジェクトに Maven 依存関係を追加する方法を説明します。

前提条件前提条件

既存の Maven プロジェクト。
Maven プロジェクトの作成方法に関する詳細は、「新規 Maven プロジェクトの作成」  を参照
してください。

手順手順

1. CodeReady Studio を起動します。
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2. Project Explorer を開きます。

3. Maven の project → Maven → Add Dependency を右クリックします。

Add Dependency ウインドウが表示されます。
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4. Enter groupId, artifactId or sha1 prefix or pattern フィールドに、グループ ID またはアーティ
ファクト ID を入力します。
上記のフィールドは自動的に入力されます。

5. OK をクリックします。

依存関係がプロジェクトの pom.xml ファイルに追加されます。

2.5. MAVEN サポートを MAVEN 以外の既存プロジェクトへ追加

Maven サポートを使用せずに作成されたアプリケーションに Maven サポートを追加する方法を説明し
ます。

1. CodeReady Studio を起動します。

2. Project Explorer を開きます。
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3. project → Configure → Convert to Maven Project を右クリックします。

Create a new POM ウインドウが表示されます。
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すべてのフィールドは自動的に入力されます。グループ ID またはアーティファクト ID を変更
する場合は、値にスペースまたは特殊文字を使用できません。使用できる特別文字は、ピリオ
ド (.)、アンダースコア (_)、およびダッシュ (-) のみです。

4. Finish をクリックします。
新たに生成された pom.xml ファイルが CodeReady Studio ビューに表示されます。

2.6. その他のリソース

Maven の使用方法については、「JBoss Community Archive」を参照してください。

Red Hat CodeReady Studio 12.16 CodeReady Studio ツールのスタートガイドツールのスタートガイド

38

https://developer.jboss.org/en/build/content?filterID=contentstatus[published]~objecttype~objecttype[document]


第3章 CODEREADY STUDIO でのアプリケーションデプロイメン
ト

IDE 内からサーバーにアプリケーションをデプロイするには、サーバーに関する情報で IDE を設定する
必要があります。ローカルサーバーの場合、この情報には以下が含まれます。

サーバーランタイム環境 (サーバーの場所、ランタイム JRE、設定ファイルの詳細など)

サーバーアダプターとサーバーランタイム環境の管理設定 (アクセスパラメーター、起動引数、
パブリッシュオプションなど)

JBoss Server Tools を使用すると、Runtime Detection (ランタイム検出) を使用して、ローカルサー
バーを効率的に設定し、IDE と使用できるようにすることができます。この機能はアプリケーションの
デプロイとテストを行うサーバーを迅速に設定するのに役立ちます。

3.1. ローカルサーバーの設定

Runtime Detection (ランタイム検出) は、指定のローカルシステムパスを検索し、特定タイプのランタ
イムサーバーを見つけます。Runtime Detection は、見つかったサーバーに対してデフォルトのサー
バーランタイム環境とデフォルトのサーバーアダプターの両方を自動的に生成します。これらは、アプ
リケーションを即座にデプロイするためにそのまま使用したり、要件に合わせてカスタマイズしたりで
きます。

CodeReady Studio でローカルサーバーを設定する方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Window → Preferences をクリックします。

Preferences ウィンドウが表示されます。
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3. 検索フィールドに JBoss と入力します。

4. JBoss Runtime Detection を選択します。

5. Add ボタンをクリックします。

6. ランタイムサーバーが含まれるディレクトリーを見つけます。

7. Open をクリックします。
Searching for runtimes ウィンドウが表示されます。
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8. OK をクリックします。

9. ランタイムサーバーのディレクトリーへのパスを選択します。
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10. Apply and Close をクリックします。

3.2. リモートサーバーの設定

CodeReady Studio でリモートサーバーを設定する方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Ctrl+N キーを押します。
Select a wizard ウインドウが表示されます。
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3. 検索フィールドに Server と入力します。

4. Server を選択します。

5. Next ボタンをクリックします。
Define a New Server ウィンドウが表示されます。
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6. 適切なサーバータイプを選択します。

7. Next をクリックします。
Create a new Server Adapter ウィンドウが表示されます。

8. Remote チェックボックスを選択します。

9. 適切な Controlled by オプションを選択します。

10. Server lifecycle external managed チェックボックスを選択します。

11. Assign a runtime to server チェックボックスを選択します。

12. Next をクリックします。
JBoss Runtime ウィンドウが表示されます。
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13. Home Directory フィールドの Browse をクリックして、ランタイムサーバーを見つけます。

14. Next をクリックします。
Remote System Integration ウィンドウが表示されます。

15. Remote Server Home フィールドで Browse をクリックします。
Browse remote system ウインドウが表示されます。

第第3章章 CODEREADY STUDIO でのアプリケーションデプロイメントでのアプリケーションデプロイメント

45



16. リモートサーバーが含まれるディレクトリーへのパスを指定します。

17. Finish をクリックします。

3.3. アプリケーションのデプロイ

ローカルサーバーの設定後に、サーバーアダプターを使用して IDE からサーバーにアプリケーションを
デプロイできます。サーバーアダプターは、アプリケーションとサーバー管理を簡単にデプロイできる
ように、サーバーと IDE 間のランタイムの通信を可能にします。

CodeReady Studio のサーバーにアプリケーションをデプロイする方法を説明します。
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手順手順

1. CodeReady Studio を起動します。

2. project → Run as → Run on Server を右クリックします。

Run on Server ウインドウが表示されます。
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3. Choose an existing server チェックボックスを選択します。

4. デプロイメントのサーバーを選択します。

5. Finish をクリックします。

内部の CodeReady Studio Web ブラウザーでアプリケーションが開かれます。
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第4章 CODEREADY STUDIO の JBOSS EAP および JBOSS WFK
の基本

Eclipse IDE は、Red Hat JBoss Enterprise Application Platform (JBoss EAP) および Red Hat JBoss
Web Framework Kit (JBoss WFK) でのアプリケーション開発およびデプロイメントをサポートします。
ただし、最初に Maven リポジトリーを設定する必要があります。この設定は、Red Hat Central で提供
される、エンタープライズバージョンの Maven プロジェクトサンプルの使用に不可欠です。これらの
プロジェクトは JBoss EAP へのデプロイメントを目的としており、JBoss EAP リポジトリーおよび
JBoss WFK リポジトリーへの IDE のアクセスが必要になります。

4.1. MAVEN リポジトリーの設定

Maven リポジトリーを設定する方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Window → Preferences をクリックします。

Preferences ウィンドウが表示されます。
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3. 検索フィールドに JBoss と入力します。

4. JBoss Maven Integration を選択します。

5. Configure Maven Repositories をクリックします。
Configure Maven Repositories ウインドウが表示されます。
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6. Add Repository をクリックします。
Add Maven Repository ウインドウが表示されます。
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7. Profile ID フィールドの下向き矢印をクリックします。

8. redhat-ga-repository を選択します。
他のフィールドは自動的に入力されます。

9. OK をクリックします。

10. Finish をクリックします。
Confirm File Update ウインドウが表示されます。

11. Yes をクリックします。

12. Apply and Close をクリックします。

その他のリソースその他のリソース

Maven リポジトリーの詳細は、「Maven: Getting Started - Developers」を参照してくださ
い。

4.2. JBOSS EAP の設定

Eclipse IDE で JBoss EAP を設定するには、IDE がローカルまたはリモートのランタイムサーバーを示
すようにする必要があります。これにより、IDE と JBoss EAP サーバー間の通信チャネルが確立さ
れ、デプロイメントおよびサーバー管理のワークフローが効率的になります。

CodeReady Studio で JBoss EAP をインストールする方法を説明します。

前提条件前提条件

設定済みの Maven リポジトリー。

Maven リポジトリーの設定方法に関する詳細は、「Maven リポジトリーの設定」 を参照して
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Maven リポジトリーの設定方法に関する詳細は、「Maven リポジトリーの設定」 を参照して
ください。

手順手順

1. CodeReady Studio を起動します。

2. Window → Preferences をクリックします。

Preferences ウィンドウが表示されます。
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3. 検索フィールドに JBoss と入力します。

4. JBoss Runtime Detection を選択します。

5. Download をクリックします。
Download Runtimes ウィンドウが表示されます。
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6. 適切な JBoss EAP のバージョンを選択します。

注記注記

JBoss EAP バージョン 6.0.x 以前を選択した場合は、画面の指示に従います。
6.0.x よりも新しいバージョンを選択した場合は、以下の手順に従います。

7. Next をクリックします。
Credentials ウインドウが表示されます。
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8. Add をクリックします。

9. access.redhat.com のユーザー名とパスワードを入力します。

10. OK をクリックします。

11. Next をクリックします。
ライセンス契約の内容を確認します。ライセンス契約に同意し、Next をクリックしてインス
トールを続行します。

Download Runtimes ウィンドウが表示されます。

12. Browse をクリックして、Install folder を選択します。

13. Browse をクリックして、Download folder を選択します。
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14. Finish をクリックします。
Runtime のダウンロードとインストールには時間がかかる場合があるため注意してください。

JBoss Runtime Detection ウインドウが表示されます。

15. JBoss EAP インストールファイルへのパスを選択します。

16. Apply and Close をクリックします。

検証手順検証手順

1. Window → Show View → Other とクリックします。
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Show View ウインドウが表示されます。
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2. 検索フィールドに Servers と入力します。

3. Servers を選択します。

4. Open をクリックします。
Servers ビューが表示されます。

新たに追加された JBoss EAP が Servers ビューに表示されます。
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第5章 CODEREADY STUDIO での OPENSHIFT の基本
CodeReady Studio には OpenShift Application Explorer ビューが含まれています。これにより、ユー
ザーエクスペリエンスが簡素化され、内部ループで簡単および迅速にフィードバックすることができ、
デバックも容易および迅速に行うことができます。

5.1. OPENSHIFT APPLICATION EXPLORER ビューの設定

CodeReady Studio で OpenShift Application Explorer を開く方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
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Show View ウインドウが表示されます。
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3. 検索フィールドに OpenShift と入力します。

4. OpenShift Application Explorer を選択します。

5. Open をクリックします。
OpenShift Application Explorer ビューが表示されます。

5.2. OPENSHIFT APPLICATION EXPLORER を使用した OPENSHIFT クラ
スターへの接続
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OpenShift Application Explorer を使用して CodeReady Studio で OpenShift クラスターにログインする
方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. OpenShift Application Explorer を開きます。

3. Can't connect to cluster. Click to loging. をクリックします。

Login ウインドウが表示されます。

4. ログインのクレデンシャルを入力します。

5. Finish ボタンをクリックします。

プロジェクトが OpenShift Application Explorer ビューに表示されます。

5.3. 新しいランチャープロジェクトの作成
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CodeReady Studio で新しいランチャープロジェクトを作成する方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Ctrl+N キーを押します。
Select a wizard ウインドウが表示されます。

3. 検索フィールドに Launcher と入力します。

4. Launcher project を選択します。

5. Next をクリックします。
New Launcher project ウインドウが表示されます。
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6. 希望する Mission を設定します。

7. 希望する Runtime を設定します。

8. プロジェクトに名前を付けます。

9. プロジェクトの場所を選択します。

10. Finish ボタンをクリックします。
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依存関係の解決プロセスが完了するまで時間がかかることがあるため注意してください。

新たに作成されたランチャープロジェクトが Project Explorer ビューに表示されます。

5.4. OPENSHIFT APPLICATION EXPLORER を使用した新規プロジェクト
の作成

CodeReady Studio で OpenShift Application Explorer を使用して新しいプロジェクトを作成する方法を
説明します。

手順手順

1. CodeReady Studio を起動します。

2. OpenShift Application Explorer を起動します。

3. OpenShift Application Explorer → New → Project の任意の場所をクリックします。

New project ウインドウが表示されます。

4. プロジェクトに名前を付けます。

5. OK をクリックします。
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新たに作成したプロジェクトが OpenShift Application Explorer ビューに表示されます。

5.5. OPENSHIFT APPLICATION EXPLORER を使用した新規コンポーネン
トの作成

CodeReady Studio で OpenShift Application Explorer を使用して新しいコンポーネントを作成する方法
を説明します。

手順手順

1. CodeReady Studio を起動します。

2. OpenShift Application Explorer を起動します。

3. ターゲットの Project → New → Component を右クリックします。

Create component ウィンドウが表示されます。
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4. プロジェクトに名前を付けます。

5. Browse をクリックして Eclipse Project を選択します。

6. 希望の Component type を設定します。

7. 希望の Component version を設定します。

8. アプリケーションに名前を付けます。

9. Push after create チェックボックスを未選択にします。

10. Finish をクリックします。
Console ビューが表示され、検証プロセスが表示されます。

新たに作成されたコンポーネントが、プロジェクト下の OpenShift Application Explorer ビューに表示
されます。

5.6. OPENSHIFT APPLICATION EXPLORER を使用したクラスターへのコ
ンポーネントのデプロイ

CodeReady Studio で OpenShift Application Explorer を使用して、クラスターにコンポーネントをデプ
ロイする方法を説明します。

手順手順
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1. CodeReady Studio を起動します。

2. OpenShift Application Explorer を起動します。

3. プロジェクトを展開します。

4. アプリケーションを展開します。

5. component → Push を右クリックします。

Console ビューが表示され、ファイル同期化のプロセスが表示されます。

5.7. OPENSHIFT APPLICATION EXPLORER を使用した外部アクセス URL
の定義

CodeReady Studio で OpenShift Application Explorer を使用して外部アクセス URL を定義する方法を
説明します。

手順手順

1. CodeReady Studio を起動します。

2. OpenShift Application Explorer を起動します。

3. プロジェクトを展開します。

4. アプリケーションを展開します。

5. component → New → URL を右クリックします。
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Create URL ウインドウが表示されます。

6. URL に名前を付けます。

7. Port の値を 8080 に設定します。

8. Finish をクリックします。
Console ビューが表示され、URL 作成のプロセスが表示されます。
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9. OpenShift Application Explorer で、component → Push を右クリックします。

Console ビューが表示され、ファイル同期化のプロセスが表示されます。

新たに作成された URL がコンポーネント下の OpenShift Application Explorer ビューに表示されま
す。

5.8. OPENSHIFT APPLICATION EXPLORER を使用したクラスターでのア
プリケーションのデバッグ

CodeReady Studio で OpenShift Application Explorer を使用してコンポーネントをデバッグする方法を
説明します。

手順手順

1. CodeReady Studio を起動します。

2. OpenShift Application Explorer を起動します。

3. プロジェクトを展開します。

4. アプリケーションを展開します。

5. component → Debug を右クリックします。
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Console ビューが表示されます。

6. OpenShift Application Explorer で、コンポーネントを展開します。

7. url → Open in Browser を右クリックします。

Confirm Perspective Switch ウインドウが表示されます。

8. Switch をクリックします。
Debug Perspective ウィンドウが表示され、デバッグプロセスが表示されます。
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第6章 CODEREADY STUDIO の QUARKUS ツールの基本
Quarkus は Kubernetes ネイティブのフルスタック Java フレームワークで、Java 仮想マシンとの作業
を最適化することを目的としています。Quarkus は、Quarkus アプリケーション開発者向けのツールを
提供します。Java アプリケーションおよびコンテナーイメージフットプリントのサイズを削減し、プ
ログラミングの負担をなくし、必要になるメモリー量を削減します。

前提条件前提条件

最新バージョンの JBoss Tools がインストールされていることを確認してください。詳細は、
「JBoss Tools」を参照してください。

6.1. 新しい QUARKUS プロジェクトの作成

CodeReady Studio で新しい Quarkus プロジェクトを作成する方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Ctrl+N キーを押します。
Select a wizard ウインドウが表示されます。

3. 検索フィールドに Quarkus と入力します。
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4. Quarkus Project を選択します。

5. Next をクリックします。
New Quarkus project ウインドウが表示されます。

6. 適切なプロジェクトタイプを選択します。

7. プロジェクトに名前を付けます。

8. プロジェクトの場所を選択します。

9. Next をクリックします。
Project type ウインドウが表示されます。
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10. デフォルト値が正しいことを確認します。

11. Next をクリックします。
Quarkus extensions ウインドウが表示されます。
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12. プロジェクトに適した Categories を選択します。
選択したカテゴリーに使用可能なエクステンションが Extensions 列に表示されます。

13. プロジェクトに適した Extensions を選択します。
エクステンションをダブルクリックして選択または選択解除します。選択したエクステンショ
ンが Selected 列に表示されます。

14. Finish をクリックします。

新たに作成された Quarkus プロジェクトが Project Explorer ビューに表示されます。

6.2. QUARKUS アプリケーションの実行

CodeReady Studio で Quarkus アプリケーションを実行する方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Run → Run Configurations とクリックします。

Run Configurations ウィンドウが表示されます。

3. Quarkus Application まで下へスクロールします。
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4. Quarkus Application → New Configuration を右クリックします。

5. 設定に名前を付けます。

6. Browse をクリックしてプロジェクトを見つけます。
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7. Apply をクリックします。

8. Run クリックします。
Console ビューが表示されます。

アプリケーションは、ビルドプロセスの後に起動します。

6.3. QUARKUS アプリケーションのデバッグ

CodeReady Studio で Quarkus アプリケーションをデバッグする方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Run → Debug Configurations とクリックします。

Debug Configurations ウィンドウが表示されます。
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3. Quarkus Application を展開します。

4. 設定を選択します。

5. Debug  をクリックします。
Console ビューが表示されます。

Quarkus アプリケーションが起動し、リモート JVM デバッグ設定に接続します。アプリケーションの
ソースファイルにブレークポイントを設定すると、ブレークポイントに到達した後に実行が自動的に停
止します。

6.4. CODEREADY STUDIO での言語サポートの使用

すべての Quarkus アプリケーションは、application.properties 設定ファイルを使用して設定されま
す。この設定ファイルの内容は、アプリケーションが使用している Quarkus エクステンションのセット
によって異なります。

Quarkus ツールには、コード補完、検証、およびドキュメントを提供するコンテンツアシストが含まれ
ています。コード補完により、コードのステートメントを迅速に完了できます。ポップアップから複数
の選択肢を利用することができます。

この言語サポートは、Kubernetes、OpenShift、S2i、Docker プロパティー、MicroProfile REST Client
プロパティー、および MicroProfile Health アーティファクトで使用できるようになりました。

6.4.1. Quarkus コード補完の使用

CodeReady Studio で Quarkus の application.properties コンテントアシストを使用する方法を説明し
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CodeReady Studio で Quarkus の application.properties コンテントアシストを使用する方法を説明し
ます。

前提条件前提条件

既存の Quarkus プロジェクト。
Quarkus プロジェクトの作成方法に関する詳細は、「新しい Quarkus プロジェクトの作成」  を
参照してください。

手順手順

1. CodeReady Studio を起動します。

2. Project Explorer を起動します。

3. Quarkus project → src → main → resources を展開します。

4. application.properties → Open With → Generic Text Editor を右クリックします。

Text Editor ウインドウが表示されます。

5. 空の行に移動します。

6. Ctr+Space キーを押して、コード補完を実行します。
コード補完のサジェスチョンが表示されます。マウスカーソルをサジェスチョンの上に移動
し、ドキュメントを表示します。
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エディターで誤った値を入力すると、エラーの下に赤い波線が表示されます。

その他のリソースその他のリソース

MicroProfile REST Client プロパティーと MicroProfile Health アーティファクトの言語サポート
は、個別に有効にする必要があります。詳細は、「MicroProfile の言語サポートの有効化」 を
参照してください。

6.4.2. MicroProfile の言語サポートの有効化

MicroProfile REST Client プロパティーの言語サポートを有効にする方法を説明します。

前提条件前提条件

既存の Quarkus プロジェクト。
Quarkus プロジェクトの作成方法に関する詳細は、「新しい Quarkus プロジェクトの作成」  を
参照してください。

手順手順

1. CodeReady Studio を起動します。

2. Project Explorer を起動します。

3. Quarkus project → src/main/java を展開します。

4. org.acme → New → Other を右クリックします。
Select wizard ウインドウが表示されます。
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5. 検索フィールドに file と入力します。

6. File を選択します。

7. Next ボタンをクリックします。
Create a new file resource ウインドウが表示されます。
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8. 新しいファイルに名前を付けます。

9. Finish をクリックします。

10. 新たに作成されたファイルに以下の内容を貼り付けます。

package org.acme;

import javax.ws.rs.GET;
import javax.ws.rs.Path;
import javax.ws.rs.core.Response;

import org.eclipse.microprofile.rest.client.inject.RegisterRestClient;

@RegisterRestClient
public interface MyServiceClient {
 @GET
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11. Ctrl+S キーを押して変更を保存します。

クライアントの設定キーを @RegisterRestClient から @RegisterRestClient(configKey = "myclient")
に変更すると、言語サポートを調整することができます。言語サポートは状況に応じて調整されます。

その他のリソースその他のリソース

言語サポートの使用方法の詳細は、「Quarkus コード補完の使用」 を参照してください。

    @Path("/greet")
    Response greet();
}
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第7章 CODEREADY STUDIO の HIBERNATE TOOLS の基本
Hibernate Tools は、Hibernate バージョン 5 以前に関連するプロジェクトのツールのコレクションで
す。このツールは、Hibernate とのリバースエンジニアリング、コード生成、可視化、および対話を行
う Eclipse プラグインを提供します。

前提条件前提条件

1. h2 バージョンの Sakila データベース  をダウンロードします。

2. runh2.sh ファイルが含まれるディレクトリーに移動します。

3. runh2.sh ファイルを実行します。

$ ./runh2.sh

7.1. 新規 JPA プロジェクトの作成

CodeReady Studio で新規 JPA プロジェクトを作成する方法を説明します。ここでは、前提条件に記載
されている手順が完了済みであることを仮定しています。

手順手順

1. CodeReady Studio を起動します。

2. Ctrl+N キーを押します。
Select a Wizard ウインドウが表示されます。
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3. 検索フィールドに JPA と入力します。

4. JPA Project を選択します。

5. Next をクリックします。
New JPA Project ウインドウが表示されます。
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6. プロジェクトに名前を付けます。

7. プロジェクトの場所を選択します。

8. Target runtime フィールドで下矢印をクリックし、ランタイムサーバーを選択します。
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9. JPA version を 2.1 に設定します。

10. Next をクリックします。
Java ウィンドウが表示されます。

11. ソースフォルダーを選択します。

12. Next をクリックします。
JPA Facet ウィンドウが表示されます。
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13. Platform フィールドの下矢印をクリックし、Hibernate (JPA 2.1) を選択します。

14. ユーザーライブラリーを追加するか、JPA Implementation Type を Disable Library
Configuration に設定します。
ユーザーライブラリーの設定方法の詳細は、「ライブラリーの追加」 を参照してください。

15. Add connection をクリックします。
Connection Profile ウインドウが表示されます。
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16. 検索フィールドに Generic と入力します。

17. Generic JDBC を選択します。

18. Name フィールドに sakila と入力します。

19. Next をクリックします。
Specify a Driver and Connection Details ウィンドウが表示されます。

20. New Driver Definition アイコンをクリックします。

New Driver Definition ウインドウが表示されます。
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21. Generic JDBC Driver を選択します。

22. JAR List タブをクリックします。
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23. Add JAR/Zip ボタンをクリックします。

24. Sakila データベースの .jar ファイルを選択します。

25. Properties タブをクリックします。

26. Connection URL フィールドに jdbc:h2:tcp://localhost/./sakila を追加します。

27. Driver Class フィールドをクリックします。

28. Driver Class フィールドの末尾にある、点 3 つのアイコンをクリックします。
Available Classes from Jar List ウインドウが表示されます。
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29. Browse the Class オプションを選択します。

30. org.h2.Driver を選択します。

31. OK をクリックします。

32. User ID フィールドに sa と入力します。

33. OK → Finish → Finish とクリックします。
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新たに作成された JPA プロジェクトが Project Explorer に表示されます。

7.2. ライブラリーの追加

CodeReady Studio で、Hibernate プロジェクトにライブラリーを追加する方法を説明します。

手順手順

1. Hibernate ORM をダウンロードします。

2. ファイルを展開します。

3. CodeReady Studio を起動します。

4. Window → Preferences をクリックします。

Preferences ウィンドウが表示されます。
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5. 検索フィールドに Libraries と入力します。

6. Java で User Libraries を選択します。

7. New ボタンをクリックします。
New User Library ウィンドウが表示されます。

8. ユーザーライブラリーに名前を付けます。

9. OK をクリックします。

10. 新しいユーザーライブラリーを選択します。
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11. Add External JARs ボタンをクリックします。

12. Hibernate ORM ファイルを展開したディレクトリーを選択します。

13. /lib/required/ ディレクトリーに移動します。

14. .jar ファイルを選択します。

15. Open をクリックします。
選択した .jar ファイルがユーザーライブラリーに表示されます。
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16. Apply and Close をクリックします。

7.3. エンティティーの生成

CodeReady Studio で Hibernate プロジェクトのエンティティーを生成する方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Project Explorer を開きます。

3. JPA project → JPA Tools → Generate Tables from Entities を右クリックします。
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Generate Table from Entities ウィンドウが表示されます。
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4. Use Console Configuration チェックボックスを選択します。

5. Finish をクリックします。

7.4. HIBERNATE マッピングファイルの作成

Hibernate マッピングファイルは、オブジェクトがどのようにデータベーステーブルに関連するかを指
定します。

CodeReady Studio で Hibernate マッピングファイルを作成する方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Ctr+N キーを押します。
Select a wizard ウインドウが表示されます。
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3. 検索フィールドに Hibernate と入力します。

4. Hibernate XML Mapping file (hbm.xml) を選択します。

5. Next をクリックします。
Create Hibernate XML Mapping file ウインドウが表示されます。
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6. Add Class ボタンをクリックしてクラスを追加します。

7. Add Package ボタンをクリックしてパッケージを追加します。
または、パッケージまたはクラスを選択せずに空の .hbm.xml ファイルを作成することもでき
ます。

8. depth control チェックボックスを選択し、クラスの選択時に使用される依存関係の深さを定義
します。

9. Next をクリックします。
New Hibernate XML Mapping files ウインドウが表示されます。
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10. 親ディレクトリーを選択します。

11. .hbm.xml ファイルに名前を付けます。

12. Finish をクリックします。

7.5. HIBERNATE 設定ファイルの作成

リバースエンジニアリング、プロトタイプクエリー、または Hibernate Core の使用に
は、hibernate.properties または hibernate.cfg.xml ファイルが必要になります。CodeReady Studio
には、hibernate.cfg.xml ファイルを生成するウィザードがあります。

CodeReady Studio で Hibernate 設定ファイルを作成する方法を説明します。

手順手順

1. CodeReady Studio を起動します。
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2. Ctr+N キーを押します。
Select a wizard ウインドウが表示されます。

3. 検索フィールドに Hibernate と入力します。

4. Hibernate Configuration file (cfg.xml) を選択します。

5. Next をクリックします。
Create Hibernate Configuration file (cfg.xml) ウインドウが表示されます。
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6. 親ディレクトリーを選択します。

7. Next をクリックします。
Hibernate Configuration File(cfg.xml) ウインドウが表示されます。
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8. Database dialect フィールドの下矢印をクリックして、データベースを選択します。

9. Driver class フィールドの下矢印をクリックして、ドライバーを選択します。

10. Connection URL フィールドの下矢印をクリックし、URL を選択します。

11. Finish をクリックします。

7.6. HIBERNATE コンソール設定ファイルの作成

コンソール設定ファイルには、Hibernate プラグインがどのように Hibernate を設定するかが記述され
ています。また、POJO や JDBC ドライバーなどのロードに必要な設定ファイルおよびクラスパスも
記述されています。これは、クエリープロトタイピング、リバースエンジニアリング、およびコードの
生成を使用するために必要です。プロジェクトごとに複数のコンソール設定を指定できますが、1 つの
設定で十分です。

CodeReady Studio で Hibernate コンソール設定ファイルを作成する方法を説明します。

手順手順
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1. CodeReady Studio を起動します。

2. Ctr+N キーを押します。
Select a wizard ウインドウが表示されます。

3. 検索フィールドに Hibernate と入力します。

4. Hibernate Console Configuration を選択します。

5. Next をクリックします。
Create Hibernate Console Configuration ウィンドウが表示されます。
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6. 設定ファイルに名前を付けます。

7. Type が Core に設定されていることを確認します。

8. Hibernate version を選択します。

9. Browse をクリックしてプロジェクトを見つけます。

10. New をクリックして、新しい Database connection を設定します。
New Connection Profile ウインドウが表示されます。

11. Data Connection を選択するか、新たに作成します。

12. Setup をクリックし、Property file を設定します。
Setup property file ウインドウを表示します。

13. Create new をクリックします。
Create Hibernate Properties file (.properties) ウインドウが表示されます。
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14. 親ディレクトリーを選択します。

15. .properties ファイルに名前を付けます。

16. Finish をクリックします。

17. Setup をクリックし、Configuration file を設定します。

18. ターゲット .cfg.xml ファイルへのパスを選択します。
Setup configuration file ウインドウが表示されます。

19. Create new をクリックします。
Create Hibernate Configuration file (cfg.xml) ウインドウが表示されます。
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20. 親ディレクトリーを選択します。

21. Next をクリックします。
Hibernate Configuration File(cfg.xml) ウインドウが表示されます。
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22. Database dialect フィールドの下矢印をクリックして、データベースを選択します。

23. Driver class フィールドの下矢印をクリックして、ドライバーを選択します。

24. Connection URL フィールドの下矢印をクリックし、URL を選択します。

25. Finish をクリックします。
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26. Finish をクリックします。

7.7. HIBERNATE プロジェクト設定の編集

CodeReady Studio で Hibernate プロジェクトの設定を編集する方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Window → Show View → Other とクリックします。
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Show View ウインドウが表示されます。
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3. 検索フィールドに Hibernate と入力します。

4. Hibernate Configurations を選択します。

5. Open をクリックします。
Hibernate Configurations ビューが表示されます。
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6. project → Edit Configuration を右クリックします。
Edit Configuration ウインドウが表示されます。
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7. 設定を編集します。

8. Apply をクリックします。
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9. OK をクリックします。
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第8章 CODEREADY STUDIO での MOBILE WEB TOOLS の基本
Mobile Web Tools は、モバイルデバイス向けに最適化された Web アプリケーションの作成を可能にす
る HTML5 Project ウィザードを提供します。HTML5 Project ウィザードは、IDE ですべての新規
HTML5 Web アプリケーションを作成するための便利なウィザードです。このウィザードは、Maven
archetype からの REST リソースを使用して、そのままデプロイできる HTML5 モバイルアプリケー
ションのサンプルを生成します。

組み込みエディターを使用してアプリケーションをカスタマイズでき、組み込みブラウザーでアプリ
ケーションをデプロイおよび表示できます。

IDE では、ユーザーが対話式の Web アプリケーションを作成できる Mobile Web パレットが提供され
ます。このパレットは、HTML5、jQuery Mobile、および Ionic タグなどの一般的な Web インター
フェースフレームワーク機能を html ファイルに追加するドラッグアンドドロップウィジェットなど、
幅広い機能を提供します。また、よりユーザーフレンドリーで効率的なアプリケーションを実現するた
めの、Panels、Pages、Lists、Buttons などのウィジェットも含まれています。

前提条件前提条件

設定済みのサーバー。
ローカルランタイムサーバーの設定およびアプリケーションのローカルランタイムサーバーへ
のデプロイメントに関する詳細は、「ローカルサーバーの設定」 を参照してください。

IDE は、アプリケーションをデプロイするすべてのサーバーに対して設定する必要があります。これに
は、アプリケーションサーバーの場所およびタイプ、カスタム設定、カスタム管理設定などが含まれま
す。ここでは、事前に設定が完了していることを前提としていますが、デプロイメント時に手順を完了
することもできます。

8.1. HTML5 プロジェクトの作成

HTML5 Project ウィザードは、Maven アーキタイプと、提供するプロジェクトおよびアプリケーショ
ン識別子を基にして、サンプルプロジェクトを生成します。Maven archetype バージョンは、ウィザー
ドの最初のページにある Description フィールドに示されます。バージョンを変更できるため、ウィ
ザード内でエンタープライズまたは非エンタープライズいずれかのターゲットランタイムを選択して、
プロジェクトの見た目と依存関係も変更できます。

CodeReady Studio で HTML5 プロジェクトを作成する方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Ctr+N キーを押します。
Select a wizard ウインドウが表示されます。
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3. 検索フィールドに HTML5 と入力します。

4. HTML5 Project を選択します。

5. Next をクリックします。
New Project Example ウィンドウが表示されます。
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6. Target Runtime フィールドの下矢印をクリックします。

7. サーバーを選択します。

8. Next をクリックします。

9. プロジェクトとパッケージに名前を付けます。

10. プロジェクトの場所を選択します。

11. Finish をクリックします。
プロジェクトの生成には時間がかかる場合があります。

New Project Example ウィンドウが表示されます。

12. Finish をクリックします。

新たに作成されたプロジェクトが Project Explorer ビューに表示されます。

8.2. 新しい HTML5 JQUERY MOBILE ファイルの追加

HTML5 jQuery Mobile ファイルテンプレートは、ファイルの HTML ヘッダーに挿入される JavaScript
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HTML5 jQuery Mobile ファイルテンプレートは、ファイルの HTML ヘッダーに挿入される JavaScript
および CSS ライブラリー参照で構成されます。このテンプレートは、jQuery Mobile ページのスケルト
ンや、ファイルの HTML ボディーの listview ウィジェットも挿入します。

既存のプロジェクトに新しい HTML5 jQuery Mobile ファイルを追加する方法を説明します。

手順手順

1. CodeReady Studio を起動します。

2. Ctr+N キーを押します。
Select a wizard ウインドウが表示されます。

3. 検索フィールドに HTML と入力します。

4. HTML File を選択します。

5. Next をクリックします。
New HTML File ウインドウが表示されます。
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6. ファイルの場所を選択します。

7. ファイルに名前を付けます。

8. Next をクリックします。
Select HTML Template ウインドウが表示されます。
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9. テンプレートを選択します。

10. Finish をクリックします。
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新たに作成された HTML ファイルが CodeReady Studio エディターに表示されます。

8.3. 新しいモバイルページの追加

既存の Web アプリケーションに新しい jQuery Mobile ページを追加する方法を説明します。

前提条件前提条件

HTML5 プロジェクト。
HTML5 プロジェクトの作成方法についての詳細は、「HTML5 プロジェクトの作成」 を参照し
てください。

手順手順

1. CodeReady Studio を起動します。

2. Window → Show view → Other とクリックします。
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Show View ウインドウが表示されます。
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3. 検索フィールドに Palette と入力します。

4. Palette を選択します。

5. Open をクリックします。
Palette ビューが表示されます。

6. Page アイコンをクリックします。
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Insert Tag ウィンドウが表示されます。

7. Header に名前を付けます。

8. Footer に名前を付けます。

9. Finish をクリックします。

新たに追加されたページが CodeReady Studio エディターに表示されます。

Palette ビューからのウィジェットを選択して、Web アプリケーションのページをカスタマイズする場
合、同じワークフローが使用されます。
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