第5章 CLI の使用によるマイナーバージョン内でのクラスターの更新

OpenShift CLI (oc) を使用して OpenShift Container Platform クラスターをマイナーバージョン内で更新するか、またはアップグレードすることができます。

5.1. 前提条件

  • admin 権限を持つユーザーとしてクラスターにアクセスできること。「RBAC の使用によるパーミッションの定義および適用」を参照してください。
  • アップグレードが失敗し、クラスターを直前の状態に復元する 必要がある場合に、最新の etcd バックアップ があること。
  • Operator Lifecycle Manager (OLM) で以前にインストールされたすべての Operator が、最新チャネルの最新バージョンに更新されていることを確認します。Operator を更新することで、デフォルトの OperatorHub カタログが、クラスターのアップグレード時に現行のマイナーバージョンから次のマイナーバージョンに切り替わる際、確実に有効なアップグレードパスがあるようにします。詳細は、「インストールされた Operator のアップグレード」を参照してください。
  • すべてのマシン設定プール (MCP) が実行中であり、一時停止していないことを確認します。一時停止した MCP に関連付けられたノードは、更新プロセス中にスキップされます。
  • クラスターで手動で保守される認証情報を使用する場合は、Cloud Credential Operator (CCO) がアップグレード可能な状態であることを確認します。「AWS」、「Azure」、または「GCP」の 手動で保守される認証情報を使用したクラスターのアップグレード」を参照してください。
重要

unsupportedConfigOverrides セクションを使用して Operator の設定を変更することはサポートされておらず、クラスターのアップグレードをブロックする可能性があります。クラスターをアップグレードする前に、この設定を削除する必要があります。