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はじめに

1. ドキュメント規則

本ガイドでは、いくつかの規則を使用して特定の単語やフレーズを強調表示し、特定の情報への注意を
促しています。

1.1. 表記規則

特定の単語や句への注意を促すために 4 つの表記慣習を使用しています。これらの規則や、これらが適
用される状況は以下のとおりです。

等幅ボールド等幅ボールド

シェルコマンド、ファイル名、パスなど、システム入力を強調表示するために使用されます。キーと
キーの組み合わせを強調表示するためにも使用されます。以下に例を示します。

現在の作業ディレクトリーのファイル my_next_bestselling_novel の内容を表示する
には、シェルプロンプトで cat my_next_bestselling_novel コマンドを入力し、Enter
を押してコマンドを実行します。

上記には、ファイル名、シェルコマンドおよびキーが含まれます。これはすべて等幅ボールドで表示さ
れ、コンテキストにより区別可能なものになります。

キーの組み合わせは、各部分をつなぐプラス記号によって、個別のキーと区別できます。以下に例を示
します。

Enter を押してコマンドを実行します。

Ctrl+Alt+F2 を押して、仮想ターミナルに切り替えます。

最初の例では、押す特定のキーを強調表示しています。2 つ目の例は、同時に押す 3 つのキーのセット
というキーの組み合わせを強調表示しています。

ソースコードの場合、段落内で記述されるクラス名、メソッド、関数、変数名、および戻り値は、上記
のように 等幅ボールド等幅ボールド で示されます。以下に例を示します。

ファイル関連のクラスには、ファイルシステムの filesystem、ファイルの file、ディレ
クトリーの dir が含まれます。各クラスには、独自の関連付けられたパーミッション
セットがあります。

プロポーショナルボールドプロポーショナルボールド

これは、アプリケーション名、ダイアログボックステキスト、ラベルが付いたボタン、チェックボック
スおよびラジオボタン、メニュータイトルおよびサブメニュータイトルなど、システムで発生した単語
またはフレーズを示します。以下に例を示します。

メインメニューバーから System → Preferences → Mouse を選択し、Mouse
Preferences を起動します。Buttons タブで、Left-handed mouse チェックボックス
を選択し、Close をクリックしてメインのマウスボタンを左から右に切り替えます (マ
ウスを左手で使い易くします)。

特殊文字を gedit ファイルに挿入するには、メインメニューバーから Applications →
Accessories → Character Map を選択します。次に、Character Map メニューバーか
ら Search → Find… を選択し、Search フィールドに文字の名前を入力して Next をク
リックします。目的の文字が Character Table で強調表示されます。この強調表示し
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た文字をダブルクリックして Text to copy フィールドに配置し、Copy ボタンをク
リックします。ここでドキュメントに戻り、gedit メニューバーから Edit → Paste を
選択します。

上記のテキストにはアプリケーション名、システム全体のメニュー名および項目、アプリケーション固
有のメニュー名、GUI インターフェイス内のボタンおよびテキストなどがあります。すべては
proportional bold で示され、コンテキストと区別できます。

等幅ボールドイタリック等幅ボールドイタリック または プロポーショナルボールドイタリックプロポーショナルボールドイタリック

等幅ボールドまたはプロポーショナルボールドのいずれでも、イタリックが追加されると、置換または
変数テキストを意味します。イタリックは、状況に応じて変化するテキストや、文字を入力しないテキ
ストを表します。以下に例を示します。

ssh を使用してリモートマシンに接続するには、シェルプロンプトで ssh 
username@domain.name を入力します。リモートマシンが example.com で、その
マシン上でのユーザー名が john の場合は、ssh john@example.com と入力します。

mount -o remount file-system コマンドにより、指定したファイルシステムが再マウ
ントされます。たとえば、/home ファイルシステムを再マウントする場合、コマンド
は mount -o remount /home となります。

現在インストールされているパッケージのバージョンを表示するには、rpm -q 
package コマンドを使用します。これにより、package-version-release のような結
果が返されます。

上記の太字のイタリック体の用語、username、domain.name、file-system、package、version、および
release に注意してください。各単語はプレースホルダーで、コマンドの発行時に入力するテキストま
たはシステムによって表示されるテキストのどちらかになります。

作業のタイトルを示す標準的な使用法のほかに、イタリックは新用語と重要な用語の最初の使用を示し
ます。以下に例を示します。

Publican は DocBook 公開システムです。

1.2. 引用規則

端末の出力およびソースコードの一覧は、周りのテキストから視覚的に表示されます。

ターミナルに送信される出力は mono-spaced roman に設定され、以下のように表示されます。

books        Desktop   documentation  drafts  mss    photos   stuff  svn
books_tests  Desktop1  downloads      images  notes  scripts  svgs

ソースコードの一覧も mono-spaced roman に設定されますが、以下のように構文の強調表示が追加
されます。

static int kvm_vm_ioctl_deassign_device(struct kvm *kvm,
                 struct kvm_assigned_pci_dev *assigned_dev)
{
         int r = 0;
         struct kvm_assigned_dev_kernel *match;

         mutex_lock(&kvm->lock);

         match = kvm_find_assigned_dev(&kvm->arch.assigned_dev_head,

JBoss Enterprise SOA Platform 5 ESB ツールリファレンスガイドツールリファレンスガイド
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1.3. 注記および警告

最後に、3 つの視覚的スタイルを使用して、見落とす可能性のある情報に注意を促します。

注記注記

注記とは、タスクへのヒント、ショートカット、または代替アプローチです。注意を無
視しても悪い結果を招くことはありませんが、便利なヒントを見逃してしまう可能性が
あります。

重要重要

見落としやすい詳細のある重要なボックス: 現行セッションにのみ適用される設定変更
や、更新を適用する前に再起動が必要なサービスなどです。Important というラベルが付
いたボックスを無視しても、データが失われることはありませんが、スムーズな操作が
行えないことがあります。

警告警告

警告は無視すべきではありません。警告を無視すると、データが失われる可能性が
あります。

2. ヘルプの利用とフィードバック提供

2.1. ヘルプが必要ですか ?

本ガイドで説明されている手順で問題が発生した場合は、Red Hat カスタマーポータル
http://access.redhat.com にアクセスしてください。カスタマーポータルでは、以下を行うことができ
ます。

Red Hat 製品に関する技術サポート記事の知識ベースの検索または閲覧。

                                       assigned_dev->assigned_dev_id);
         if (!match) {
                 printk(KERN_INFO "%s: device hasn't been assigned before, "
                   "so cannot be deassigned\n", __func__);
                 r = -EINVAL;
                 goto out;
         }

         kvm_deassign_device(kvm, match);

         kvm_free_assigned_device(kvm, match);

out:
         mutex_unlock(&kvm->lock);
         return r;
}



はじめにはじめに
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Red Hat グローバルサポートサービス (GSS) へのサポートケースの送信。

その他の製品ドキュメントへのアクセス。

Red Hat は、Red Hat のソフトウェアおよびテクノロジーについて、多くの電子メーリングリストも提
供しています。一般に公開されているメーリングリストの一覧
は、https://www.redhat.com/mailman/listinfoを参照してください。メーリングリストの名前をクリッ
クして、その一覧をサブスクライブするか、またはメーリングリストのアーカイブにアクセスします。

2.2. ご意見をお寄せください

本ガイドで誤字脱字を発見されたり、このマニュアルを改善するための提案をお持ちの場合は、弊社ま
でご連絡ください。JBoss Enterprise SOA Platform の製品に対して、http://bugzilla.redhat.com/ から
Bugzilla レポートを送信してください。

バグレポートを送信する際には、マニュアル識別子である 『ESB_Tools_Reference_Guide』 を指定し
てください。

本ガイドを改善するためのご意見やご提案をお寄せいただく場合は、できるだけ具体的にご説明くださ
い。エラーが見つかった場合は、簡単に確認できるように、セクション番号と前後のテキストを含めて
ください。

JBoss Enterprise SOA Platform 5 ESB ツールリファレンスガイドツールリファレンスガイド
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第1章 はじめに

1.1. ビジネス統合

動的かつアジャイルなビジネスインフラストラクチャーを提供するためには、異なるアプリケーション
とデータソースが最小限のオーバーヘッドで相互に通信できるように、サービス指向のアーキテク
チャーを用意することが重要です。

JBoss Enterprise SOA Platform は、ビジネスプロセスの変更に対応するために、継続的に再利用する
ことなく、ビジネスサービスをオーケストレーションできるフレームワークです。JBoss Enterprise
SOA Platform では、ビジネスルールとメッセージの変換およびルーティング機能を使用することで、
複数のソースからビジネスデータを操作できます。

バグの報告

1.2. サービス指向アーキテクチャーとは

はじめにはじめに

SOA (Service Oriented Architecture) は単一のプログラムまたはテクノロジーではありません。ソフト
ウェア設計パラダイムと見なします。

すでに分かっているように、ハードウェアバス は、複数のシステムとサブシステムを結び付ける物理コ
ネクターです。これを使用する場合は、システムのペア間で多数のポイントツーポイントコネクターを
使用する代わりに、各システムを中央バスに接続するだけです。エンタープライズサービスバス (ESB)
は、ソフトウェアとまったく同じことを行います。

アーキテクトは、メッセージングシステムの上記のアーキテクチャー層にあります。このメッセージン
グシステムは、このメッセージングシステムを使用することでサービス間の 非同期通信 を容易にしま
す。実際、アーキテクトを使用している場合、すべてを概念的に、サービス （このコンテキストではア
プリケーションソフトウェア）またはサービス間で送信される メッセージ のいずれかです。サービス
は接続アドレスとして一覧表示されます (エンドポイント参照 と呼ばれています)。

このコンテキストでは、サービスは必ずしも Web サービスであるとは限らないことに注意することが
重要です。File Transfer Protocol や Java Message Service などのトランスポートを使用する他のタイ
プのアプリケーションもサービスになる可能性があります。

注記注記

この時点で、エンタープライズサービスバスがサービス指向のアーキテクチャーと同じ
場合は、妨げられる場合があります。回答は Not exactly です。 アーキテクトは、サー
ビス指向のアーキテクチャーを形成しません。代わりに、ツールを多数使用して構築で
きます。特に、SOA が必要とする loose-coupling および 非同期メッセージを渡すこと
が容易になります。SOA は常にソフトウェア以外のものと考えてください。これは一連
の原則、パターン、およびベストプラクティスです。

バグの報告

1.3. サービス指向アーキテクチャーの重要なポイント

以下は、サービス指向のアーキテクチャーの主要なコンポーネントです。
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1. 交換される メッセージ

2. サービスリクエスターおよびプロバイダーとして動作する エージェント

3. メッセージを送受信できるようにする 共有トランスポートメカニズム。

バグの報告

1.4. JBOSS ENTERPRISE SOA PLATFORM とは

JBoss Enterprise SOA Platform は、エンタープライズアプリケーションインテグレーション (EAI) およ
びサービス指向アーキテクチャー (SOA) ソリューションを開発するためのフレームワークです。これ
は、エンタープライズサービスバス (JBoss Warehouse) およびビジネスプロセス自動化インフラストラ
クチャーで設定されます。これにより、ビジネスサービスの構築、デプロイ、統合、オーケストレー
ションを行うことができます。

バグの報告

1.5. SERVICE-ORIENTED ARCHITECTURE PARADIGM

SOA (Service-ient Architecture)は、リクエスター、プロバイダー、およびブローカーの 3 つのロール
で設定されます。

サービスプロバイダーサービスプロバイダー

サービスプロバイダーはサービスへのアクセスを許可し、サービスの説明を作成し、サービスブ
ローカーに公開します。

サービスリクエスターサービスリクエスター

サービスリクエスターは、サービスブローカーが提供するサービスの説明を検索して、サービスを
検出します。リクエスターはサービスプロバイダーが提供するサービスにバインドするロールも果
たします。

サービスブローカーサービスブローカー

サービスブローカーは、サービスの説明のレジストリーをホストします。リクエスターをサービス
プロバイダーにリンクします。

バグの報告

1.6. コアおよびコンポーネント

JBoss Enterprise SOA Platform は、データ統合のニーズに対応する包括的なサーバーを提供します。
基本的なレベルでは、Enterprise Service Bus を介してビジネスルールを更新し、メッセージをルー
ティングすることができます。

JBoss Enterprise SOA Platform の中心となるのは、Enterprise Service Bus です。JBoss (ESB) はメッ
セージの送受信を行う環境を作成します。メッセージにアクションを適用して変換し、サービス間で
ルーティングすることができます。

JBoss Enterprise SOA Platform を設定するコンポーネントは複数あります。ESB とともに、レジスト

JBoss Enterprise SOA Platform 5 ESB ツールリファレンスガイドツールリファレンスガイド
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JBoss Enterprise SOA Platform を設定するコンポーネントは複数あります。ESB とともに、レジスト
リ (jUDDI)、変換エンジン (Smooks)、メッセージキュー (HornetQ)、BPEL エンジン (Riftsaw) が用意
されています。

バグの報告

1.7. JBOSS ENTERPRISE SOA PLATFORM のコンポーネント

完全な Java EE 準拠のアプリケーションサーバー (JBoss Enterprise Application Platform)

Enterprise Service Bus (JBoss ESB)

ビジネスプロセス管理システム (jBPM)

ビジネスルールエンジン (JBoss ルール)

オプションの JBoss Enterprise Data Services (EDS) 製品のサポート。

バグの報告

1.8. JBOSS ENTERPRISE SOA PLATFORM の機能

JBoss Enterprise Service Bus (ESB)

ドメインはサービス間でメッセージを送信し、それらを変換して、異なるタイプのシステムで処理
できるようにします。

Business Process Execution Language (BPEL)

Web サービスを使用して、この言語を使用してビジネスルールをオーケストレーションできます。
これは、ビジネスプロセス命令を簡単に実行するために SOA に含まれています。

Java Universal Description、、Discovery and Integration (jUDDI)

これは SOA のデフォルトサービスレジストリーです。ここで説明する内容は、インストラクター上
のサービスに関する情報をすべて保管する場所です。

Smooks

この変換エンジンは SOA と組み合わせて使用してメッセージを処理できます。また、メッセージを
分割して正しい宛先に送信するためにも使用できます。

JBoss ルールルール

これは、SOA にパッケージ化されたルールエンジンです。受信するメッセージからデータを推測し
て、実行する必要があるアクションを判別できます。

バグの報告

1.9. JBOSS ENTERPRISE SOA PLATFORM の JBOSSESB コンポーネント
の機能
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JBoss Enterprise SOA Platform の JBossESB コンポーネントは以下をサポートします。

複数のトランスポートおよびプロトコル

リスナーアクションモデル (これにより、サービスを相互に選択可能)

コンテンツベースのルーティング (JBoss Rules エンジン、XPath、Regex、および Smooks 経
由)

サービスオーケストレーション機能を提供するために JBoss Business Process Manager (jBPM)
との統合

ビジネスルールの開発機能を提供するために、JBoss ルールとの統合

BPEL エンジンとの統合。

さらに、新しいデプロイメントにレガシーシステムを統合し、同期または非同期で通信できるようにし
ます。

さらに、エンタープライズサービスバスは、以下を可能にするインフラストラクチャーおよびツール
セットを提供します。

さまざまなトランスポートメカニズム (電子メールや JMS など) と連携するよう設定されま
す。

汎用オブジェクトリポジトリーとして使用します。

プラグ可能なデータ変換メカニズムを実装できるようにします。

対話のロギングをサポートします。

重要重要

ソースコードには、org.jboss.internal.soa.esb と org.jboss.soa.esb の 2 つのツリーが
あります。org.jboss.internal.soa.esb パッケージの内容をそのまま使用します。これ
は、通知なしに変更される可能性があるためです。これとは対照的
に、org.jboss.soa.esb パッケージ内のすべての内容は、Red Hat の非推奨ポリシーでカ
バーされます。

バグの報告

1.10. タスク管理

JBoss SOA は、影響を受けるすべてのシステムで汎用的に実行するタスクを指定することにより、タ
スクを簡素化します。つまり、ユーザーは各ターミナルで個別に実行するようにタスクを設定する必要
はありません。ユーザーは、Web サービスを使用してシステムを簡単に接続できます。

JBoss SOA を使用して各マシンに複数回ではなく、ネットワーク全体でトランザクションを 1 回委譲す
ることで、時間を節約できます。これにより、エラーが発生する可能性も低くなります。

バグの報告

1.11. 統合のユースケース
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ACME Equity は、大規模な経理サービスです。会社には多くのデータベースやシステムがあります。旧
式の COBOL ベースのレガシーシステムや、近年で小規模な企業で取得されるデータベースもありま
す。ビジネスルールが頻繁に変化するため、これらのデータベースを統合することは困難でコストがか
かります。会社は、クライアント向け e-commerce の Web サイトを新たに開発することを希望してい
ますが、現在使用している既存のシステムとは同期しない場合があります。

会社は、安価なソリューションを希望していますが、企業セクターの厳密な規制およびセキュリティー
要件に準拠するソリューションを検討しています。会社が望ましくないことは、レガシーデータベース
およびシステムを接続するために glob コードを作成および維持する必要があることです。

JBoss Enterprise SOA Platform は、これらのレガシーシステムを新しいお客様の Web サイトに統合す
るためにミドルウェアレイヤーとして選択されました。フロントエンドシステムとバックエンドシステ
ムの間のブリッジを提供します。JBoss Enterprise SOA Platform で実装されたビジネスルールは、す
ぐに簡単に更新できます。

その結果、SOA の統合方法により、古いシステムは新しいシステムと同期できるようになりました。1
カ月あたり数万のトランザクションであっても、ボトルネックはありません。XML、JMS、FTP など
のさまざまな統合タイプは、システム間でデータを移動するために使用されます。数多くのエンタープ
ライズ標準のメッセージングシステムの 1 つを JBoss Enterprise SOA Platform にプラグインすること
で、柔軟性を高めることができます。

さらに利点は、既存のインフラストラクチャーにより多くのサーバーやデータベースが追加されると、
システムを簡単にスケールアップできることです。

バグの報告

1.12. ビジネス環境での JBOSS ENTERPRISE SOA PLATFORM の使用

エラーメッセージが発生する可能性が低いサービスの実装により、コストを削減できます。生産性と
ソーシングオプションの強化により、継続的なコストを削減できます。

情報およびビジネスプロセスは、接続が増加するため、迅速に共有できます。これは Web サービスに
よって強化され、クライアントを簡単に接続するために使用できます。

レガシーシステムは Web サービスと組み合わせて使用して、異なるシステムが同じ言語にピークにす
ることができます。これにより、システムの同期に必要なアップグレードおよびカスタムコードの量が
減ります。

バグの報告
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第2章 はじめに

2.1. ESB ツールリファレンスガイドの対象読者

はじめにはじめに

本書は、タスクの実行と JBoss Enterprise Service Bus の機能の使用について学びたい開発者を対象と
しています。

バグの報告

2.2. ESB ツールリファレンスガイドの目的

本書は、JBoss ESB プラグインが JBoss ESB と連携するために提供する機能についてユーザーに説明
することを目的としています。読者は、ESB プロジェクトの作成、ESB エディターの使用などの基本
的なタスクの実行方法、および機能を利用してより効率的なワークフローを作成する方法を学習しま
す。

バグの報告

2.3. データのバックアップ

警告警告

Red Hat は、本ガイドに記載されている設定タスクを行う前に、システム設定と
データのバックアップを行うことを推奨します。

バグの報告


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第3章 タスク

3.1. SOA プラットフォームの使用と設定

1. JBoss Enterprise SOA Platform を設定するには、Window → Preferences → Server →
Runtime Environments を選択します。これにより、サーバーランタイム環境を追加、削除、
および編集できるサーバーランタイム環境ページが開きます。

2. Add を選択し、ランタイム環境のタイプとして JBoss Enterprise Middleware → JBoss
Enterprise Application Platform 5.x Runtime を選択し、Create a new local server ボックス
をチェックして Next をクリックします。

3. 次のステップでは、サーバーランタイム環境の名前を指定し、その場所を参照できま
す。Finish をクリックして、サーバーランタイム環境を追加します。

4. これで、SOA プラットフォームが設定されました。ESB プロジェクトを作成して実行し、設定
を確認します。

バグの報告

3.2. JBOSS SOA ツールプラグインのインストール

手順手順3.1 タスクタスク

1. JBoss Developer スタジオを起動します。

2. メインメニューから Get started with JBoss Central を選択します。

3. メニューから Software/Update を選択します。

4. SOA Tooling Plug-in を選択し、Install をクリックします。

5. インストールの詳細が正しいことを確認し、Next へをクリックしてから、もう一度 Next をク
リックします。

6. 使用許諾契約を読んで同意し、Finished をクリックします。

7. JBoss Developer Studio を再起動して、インストールを完了します。

バグの報告

3.3. 新しい ESB ランタイムの設定

1. Window → Preferences → JBoss Tools → JBoss ESB Runtimes をクリックして、JBoss ESB
ランタイムを追加、削除、編集できる JBoss ESB ランタイムページを開きます。

図図3.1 ランタイムランタイム
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図図3.1 ランタイムランタイム

2. Add を選択して、JBoss ESB ランタイムの場所、名前、およびバージョン番号を指定できるダ
イアログボックスを開きます。ホームディレクトリーを JBoss AS または SOA-P として指定す
ると、設定を定義できます。スタンドアロン ESB ランタイムの場所を選択すると、設定は空に
なり、無視できます。Customize JBoss ESB Runtime jars ボックスをチェックして、ランタイ
ムのライブラリーをカスタマイズすることもできます。

3. 新しい JBoss ESB ランタイムが設定されます。Finish をクリックして設定を終了し、保存しま
す。JBoss ESB プロジェクトの作成時に設定を使用できます。

4. ESB ランタイムがプロジェクト用に設定されている場合、ESB ランタイムのクラスパスコンテ
ナーページを使用して変更できます。これを行うには、Package Explorer ビューに移動し、
JBoss ESB Runtime ライブラリーを右クリックします。

5. Properties を選択すると、利用可能なすべての JBoss ESB ランタイムを一覧表示するテーブル
が表示されます。

6. ESB プロジェクトに設定するランタイムの 1 つを選択し、OK をクリックします。

7. ESB コンテナーでは、含まれている各 JAR のプロパティーダイアログを介して、ソースと
JavaDoc の場所を設定できます。任意の JAR ファイルを右クリックし、Properties を選択し
ます。
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8. Java Source Attachment を選択し、選択した JAR ファイルの新しいソースを含む場所 (フォ
ルダー、JAR、または zip) を選択します。これは、推奨されるオプション (ワークスペース、
外部フォルダーまたはファイル) のいずれかを使用して行うことができます。パスを手動で入力
することもできます。

9. Apply をクリックしてから OK をクリックします。

10. Javadoc の場所を変更するには、Javadoc Location を選択し、Javadoc によって生成された
ドキュメントへの URL を指定します。Javadoc の場所には、package-list というファイルが含
まれます。

11. Apply をクリックしてから OK をクリックします。

バグの報告

3.4. ESB プロジェクトの作成

1. メインメニューバーで File → New → Project... を選択して JBoss ESB Project Creation ウィ
ザードを開きます。(サーバーランタイムと ESB ランタイムが JBDS で定義されていることを
確認してください。)

2. ダイアログボックスで ESB → ESB Project を選択します。

3. Next をクリックすると、プロジェクト名、ESB バージョン、およびターゲット JBoss ランタ
イムを指定する JBoss ESB プロジェクトウィザードページに移動します。たとえば、次のよう
に指定します。 helloworld をプロジェクト名として入力し、デフォルトの JBoss ESB バージョ
ンを受け入れます。

4. Next ボタンをクリックしてウィザードの次のステップに進み、ソースフォルダーと出力フォル
ダーを選択します。

5. Next ボタンをクリックして、ESB コンテンツディレクトリーを表示できる ESB ファセットの
インストールウィザードページを表示します。このフォルダーには、ESB アーカイブに必要な
ほとんどのアーティファクトが含まれています。

6. Server Supplied ESB Runtime を使用して、ESB ライブラリーをプロジェクトに設定できま
す。プロジェクトにターゲットランタイムセットがあり、このランタイムに ESB ランタイムが
インストールされていることを確認してください。

注記注記

JBoss SOA Platform 5.3 以降を使用している場合は、ESB 設定バージョン 1.3.1
を選択します。

7. Finish ボタンをクリックすると、デフォルトの jboss-esb.xml ファイルを含む ESB プロジェ
クトが作成されます。

バグの報告

3.5. ESB プロジェクトの使用例

1. 注記注記
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1. 注記注記

ESB プロジェクトの例を作成すると、完成したプロジェクトがどのように動作
するかを観察するのに役立ちます。

ESB プロジェクト例を作成する前に、 JBoss SOA-P ランタイムを作成します。

2. メインメニューバーで File → New → Other... を選択し、新しいダイアログで Examples →
JBoss Tools → Project Examples をクリックします。

3. Next ボタンをクリックすると、リストから ESB プロジェクトの例を選択できるウィザード
ページが表示されます。

4. すべての ESB サンプルには 2 つのプロジェクトがあります。1 つは ESB プロジェクトで、もう
1 つは ESB プロジェクトのテストに使用される Java プロジェクトです。以下は、すぐに使える
例のリストです。各例には、SOA-P サーバーにデプロイされる ESB アプリケーションと、
Java アプリケーションとして実行され、デプロイされた ESB アプリケーションと対話するテ
ストクライアントが含まれています。

5. JBoss ESB HelloWorld の例の例 - 基本的な ESB コンポーネントを実行し、ESB ランタイムが
適切に設定されていることを証明するために必要な最小限のファイルを示します。

JBoss ESB HelloWorld アクションの例アクションの例 - 単一の設定から複数のアクション呼び出しを使用
する方法を示します。1 つの Action クラスを使用して複数のメソッド呼び出しを行うか、
複数の Action クラスを使用できます。

JBoss ESB HelloWorld ファイルアクションの例ファイルアクションの例 - JBoss ESB のファイルゲートウェイ機
能の使用方法を示します。特定の拡張子を持つ特定のディレクトリーで見つかったファイ
ルは、処理のためのアクションとともに JMS キューに送信されます。

JBoss ESB Web サービスのサービスの consumer1 の例の例 - ESB アクションで JSR181 Web サービスを
使用する方法を示します。

JBoss ESB Web サービスプロデューサーの例サービスプロデューサーの例 - SOAPProcessor アクションを使用して
JBossESB に JSR181 Web サービスエンドポイントをデプロイする方法を示します。

JBoss ESB Smooks CSV -> XML Example - コンマ区切り値 (CSV) ファイルを XML に変
換する方法を示します。

JBoss ESB Smooks XML -> POJO Example - XML ファイルを Java POJO に変換するこ
とで単純な変換を実行する Smooks の使用方法を示します。

JBoss ESB Smooks XML -> XML date-manipulation Example - JBoss ESB 内でメッセー
ジ変換を手動で定義および適用する方法を示します。

JBoss ESB Smooks XML -> XML Example - JBoss ESB 内でメッセージ変換を手動で定義
および適用する方法の非常に基本的な例。非常に単純な XSLT を SampleOrder.xml メッ
セージに適用し、前後の XML をコンソールに出力します。

6. 関連する ESB プロジェクトの例を選択し、Finish ボタンをクリックします。ESB アプリケー
ションプロジェクトとテストクライアントプロジェクトが作成されます。

図図3.2 HelloWorld の例の例
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図図3.2 HelloWorld の例の例

7. ESB プロジェクトをデプロイし、テストクラスをローカル Java アプリケーションとして実行
して、コンソールビューでテスト結果を確認します。

バグの報告

3.6. JBOSS サーバーモジュールリストへの ESB プロジェクトの追加

1. ESB プロジェクトをデプロイする前に、Window → Show View → Other → Server → Servers
を選択してサーバービューを開きます。

2. サーバービューに ESB ランタイムがインストールされた JBoss サーバーを作成し、起動しま
す。

3. 新しい JBoss サーバーを右クリックし、Add and Remove Projects を選択して、デプロイす
る ESB プロジェクトを開いているダイアログに追加します。

4. Finish ボタンをクリックして、プロジェクトをサーバーに追加します。ESB プロジェクトを
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4. Finish ボタンをクリックして、プロジェクトをサーバーに追加します。ESB プロジェクトを
Project Explorer ビューからサーバーにドラッグすることもできます。

バグの報告

3.7. ESB プロジェクトのデプロイ

1. ESB プロジェクトを JBoss サーバーモジュールリストに追加した後、JBoss サーバーを右ク
リックし、Publish を選択して、サーバー上でプロジェクトを発行します。デプロイ結果はコ
ンソールビューで確認できます。

2. Run および Debug オプションは ESB プロジェクトで機能し、ユーザーが指定したサーバーの
(再) デプロイを引き起こします。

フィンガータッチボタンをクリックして、サーバーを再起動せずにプロジェクトをすばやく再
起動することもできます。

3. エクスポート中エクスポート中
さらに、ESB プロジェクトを .esb アーカイブとしてデプロイできます。プロジェクトを右ク
リックし、Export を選択します。

ESB → ESB File を選択し、Next をクリックします。

ESB プロジェクトをファイルシステムにエクスポートします。宛先とターゲットランタイムを
選択し、アーカイブに適切な設定を行います。最後に、Finish をクリックします。

4. プロジェクトが .esb アーカイブとしてデプロイされました。

バグの報告

3.8. ESB ファイルの作成

1. ESB ファセットが有効になっているプロジェクトを開きます。選択したプロジェクトのメイン
メニューバーまたはコンテキストメニューで File → New → Other... を選択し、新しいダイアロ
グで ESB → ESB File をクリックします。

2. Next ボタンをクリックすると、フォルダー、名前、およびバージョンを指定するウィザード
ページが表示されます。たとえば、名前として jboss-esb.xml を選択し、選択したプロジェク
トフォルダーとデフォルトバージョンを受け入れます。

注記注記

SOA-P バージョン 5.3 の場合、ESB バージョンは 4.11 で、ESB ファイルスキー
マバージョンは 1.3.1 です。古い SOA-P サーバーリリースを使用している場合
は、古い ESB ファイルスキーマバージョンもサポートされます。

3. デフォルトでは、選択したプロジェクトのフォルダーにファイルが作成されます。保存先の
フォルダーを変更する場合は、Browse をクリックして別の保存先を選択します。

4. Finish をクリックしてファイルを生成します。
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バグの報告

3.9. ESB アクションの作成

1. ESB または Javaプロジェクトを開きます。

2. メインメニューまたはコンテキストプロジェクトメニューから File → New → Other を選択し
ます。次に、新しいダイアログで ESB → ESB Action をクリックします。

3. Next をクリックすると、 New ESB Action クラス名を指定するウィザードが開きます。パッ
ケージを設定したり、インターフェイスを追加したりすることもできます。

4. JBoss ESB 4.9 では、アクションアノテーションの新しいセットが導入されました。アクショ
ンアノテーションの新しいセットは、インターフェイスと抽象クラスの実装の複雑さを隠し、
ConfigTree タイプを処理することで、クリーンな ESB アクションの実装を簡単に作成できる
ようにします。これらのアノテーションを使用する場合は、タイプ As annotated POJO を確
認してください。それ以外の場合は、タイプ As AbstractActionPipelineProcessor
implementation を確認してください。

アノテーションは次のとおりです。

@Process

@ConfigProperty

@Initialize

@Destroy

@BodyParam

@PropertyParam

@AttachmentParam

@OnSucess

@OnException

5. Finish をクリックして、 ESB Action クラスを作成します。このクラスは ESB Editor ウィザー
ドで利用できるようになります。

バグの報告
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第4章 参照資料

4.1. JBOSS ESB エディター

1. JBoss ESB エディターには、ツリーとソースの 2 つのビューがあります。エディターの下部に
ある Source タブを選択してツリービューからソースビューに簡単に切り替え、ソースビュー
で作業することができます。

図図4.1 ソースビューソースビュー

2. どちらのビューも、アウトラインビューと完全に統合されています。アウトラインビューに
は、ESB ファイルのツリー構造が表示されます。アウトラインビューで任意の要素を選択する
と、ツリー/ソースエディターの同じ場所にジャンプするため、アウトラインビューでソース
コードをナビゲートできます。

3. 両方のビューは互いに同期されているため、一方のビューで行われた変更は、すぐにもう一方
のビューに反映されます。

4. エディターのツリービューには、すべての ESB アーティファクトがツリー形式で表示されま
す。任意のノードを選択すると、右側に表示されるそのプロパティーを表示および編集できま
す。一部のプロパティーは、関連するエディターへのリンクとして表されます。

図図4.2 ツリー表示ツリー表示
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図図4.2 ツリー表示ツリー表示

5. 他のファイル (Drools、Groovy、Smooks など) を参照する ESB アクションを編集する場合、
フィールドのラベルは、そのファイルの適切なエディターを起動するためのリンクに変わりま
す。

6. 一部のアーティファクト操作の追加、編集、または削除は、ツリービューで直接実行できま
す。任意のノードを右クリックし、コンテキストメニューで使用可能なアクションの 1 つを選
択します。

7. 同じ方法で、または右側にある 追加、編集、および 削除 ボタンのあるフォームを使用して、
プロバイダーのチャネルとプロパティーを追加できます。

8. さらに、サービスとその新しいリスナーを追加できます。この方法でフィルターを追加するこ
ともできます。

バグの報告

4.2. JBOSS ESB エディターでの新しいカスタムアクションの追加

1. 新しいカスタムアクションを ESB XML ファイルに追加するには、JBoss ESB エディターのツ
リービューに移動します。

2. Services ノードの下の Actions ノードを選択し、右クリックして New → Custom Action を選
択します。

または、 editor の左側にある Add... ボタンをクリックします。
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3. ESB アクションウィザードが表示されます。名前と Java クラスを指定します。必要に応じ
て、アクションのプロセスを指定できます。

4. アクションを作成すると、Actions ノードの下のツリービューに表示されます。左側の Form
editor でプレビューと設定の編集ができます。

バグの報告

4.3. ESB XML ファイルのコンテンツアシスト

ソースモードで ESB XML ファイルを操作する場合、 Content Assist  は利用可能です。コードステート
メントを完成させるのに役立つポップアップヒントが表示されます。利用可能なヒントを表示するに
は、Ctrl-Space を入力します。

図図4.3 ESB XML ファイルのコンテンツアシストファイルのコンテンツアシスト

バグの報告

4.4. OPENON FOR ESB XML

ESB ファイルには、ファイル内の複数の参照を利用できる OpenOn 機能が付属しています。Ctrl キー
を押したままクリックして表示します。

図図4.4 OpenOn
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https://bugzilla.redhat.com/enter_bug.cgi?cf_environment=Instance+Name%3A+Not+Defined%0ABuild%3A+CSProcessor+Builder+Version+1.7%0ABuild+Name%3A+6854%2C+ESB+Tools+Reference+Guide-5-5.3.1%0ABuild+Date%3A+20-02-2013+16%3A54%3A23&cf_build_id=6802-365852+20+Feb+2013+16%3A54+en-US+%5BLatest%5D&short_desc=Adding+a+New+Custom+Action+in+JBoss+ESB+Editor&product=JBoss+Enterprise+SOA+Platform+5&component=doc-ESB_Tools_Reference_Guide&version=5.3.1
https://bugzilla.redhat.com/enter_bug.cgi?cf_environment=Instance+Name%3A+Not+Defined%0ABuild%3A+CSProcessor+Builder+Version+1.7%0ABuild+Name%3A+6854%2C+ESB+Tools+Reference+Guide-5-5.3.1%0ABuild+Date%3A+20-02-2013+16%3A54%3A23&cf_build_id=6803-375396+20+Feb+2013+16%3A54+en-US+%5BLatest%5D&short_desc=Content+Assist+for+ESB+XML+Files&product=JBoss+Enterprise+SOA+Platform+5&component=doc-ESB_Tools_Reference_Guide&version=5.3.1


図図4.4 OpenOn

OpenOn は、.xsd .xml などの拡張子を持つさまざまな種類のファイルに対して実装されます。

バグの報告
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https://bugzilla.redhat.com/enter_bug.cgi?cf_environment=Instance+Name%3A+Not+Defined%0ABuild%3A+CSProcessor+Builder+Version+1.7%0ABuild+Name%3A+6854%2C+ESB+Tools+Reference+Guide-5-5.3.1%0ABuild+Date%3A+20-02-2013+16%3A54%3A23&cf_build_id=6804-375401+20+Feb+2013+16%3A54+en-US+%5BLatest%5D&short_desc=OpenOn+for+ESB+XML&product=JBoss+Enterprise+SOA+Platform+5&component=doc-ESB_Tools_Reference_Guide&version=5.3.1


第5章 概要

5.1. ESB ツールと追加リソースのまとめ

本書は、JBoss ESB プラグインが JBoss ESB で動作するために提供する機能に関するすべての必要な
情報を提供しました。

以下のリンクにアクセスすると、追加情報を見つけることができます。

JBoss ESB

JBoss Wiki

JBoss ESB ドキュメンテーションライブラリー

最新の JBoss Tools/JBoss Developer Studio ドキュメンテーションビルドは、JBoss Tools ナイトリー
ドキュメンテーションページ で入手できます。

バグの報告
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