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Abstract

This book provides the basic steps to get started with JBoss EAP 6.
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CHAPTER 1. INTRODUCTION

1.1. ABOUT RED HAT JBOSS ENTERPRISE APPLICATION PLATFORM
6

Red Hat JBoss Enterprise Application Platform 6 (JBoss EAP 6) is a middleware platform built on open
standards and compliant with the Java Enterprise Edition 6 specification. It integrates JBoss Application
Server 7 with high-availability clustering, messaging, distributed caching, and other technologies.

JBoss EAP 6 includes a new, modular structure that allows service enabling only when required,
improving start-up speed.

As well, the Management Console and Management Command Line Interface make editing XML
configuration files unnecessary and add the ability to script and automate tasks.

In addition, JBoss EAP 6 includes APIs and development frameworks for quickly developing secure and
scalable Jave EE applications.

Report a bug

1.2. ABOUT THE RED HAT CUSTOMER PORTAL

The Red Hat Customer Portal is the centralized platform for Red Hat knowledge and subscription
resources. Use the Red Hat Customer Portal to:

Manage and maintain Red Hat entitlements and support contracts;

Download officially-supported software;

Access product documentation and the Red Hat Knowledgebase;

Contact Global Support Services; and

File bugs against Red Hat products.

The Customer Portal is available here: https://access.redhat.com.

Report a bug

1.3. ABOUT THE RED HAT JBOSS DEVELOPER PROGRAM

The Red Hat JBoss Developer Program ("the Program") allows you to deploy, free of charge, certain
Red Hat Subscriptions for development purposes. The Red Hat Subscriptions offered to you in this
Program are unsupported and may not address known security vulnerabilities. They may be used for
development purposes only and are not intended for other purposes such as use in production
environments or for accessing updates without (an) active Red Hat Subscription(s). For complete details
about the Red Hat JBoss Developer Program, see http://www.jboss.org/developer-
program/termsandconditions.

Report a bug

1.4. ABOUT THE FULL RED HAT JBOSS COMMERCIAL PROGRAM

The Full Red Hat JBoss Commercial Program allows you to deploy to production environments. It

Getting Started Guide

4

https://bugzilla.redhat.com/enter_bug.cgi?cf_environment=Build+Name%3A+22526%2C+Getting+Started+Guide-6.2-1%0ABuild+Date%3A+18-03-2014+15%3A53%3A08%0ATopic+ID%3A+228-591648+%5BSpecified%5D&comment=Title%3A+About+Red+Hat+JBoss+Enterprise+Application+Platform+6%0A%0ADescribe+the+issue%3A%0A%0A%0ASuggestions+for+improvement%3A%0A%0A%0AAdditional+information%3A&cf_build_id=228-591648+23+Feb+2014+16%3A54+en-US+%5BSpecified%5D&product=JBoss+Enterprise+Application+Platform+6&version=6.2.0&keywords=Documentation
https://access.redhat.com
https://bugzilla.redhat.com/enter_bug.cgi?cf_environment=Build+Name%3A+22526%2C+Getting+Started+Guide-6.2-1%0ABuild+Date%3A+18-03-2014+15%3A53%3A08%0ATopic+ID%3A+254-619958+%5BSpecified%5D&comment=Title%3A+About+the+Red+Hat+Customer+Portal%0A%0ADescribe+the+issue%3A%0A%0A%0ASuggestions+for+improvement%3A%0A%0A%0AAdditional+information%3A&cf_build_id=254-619958+11+Mar+2014+02%3A12+en-US+%5BSpecified%5D&product=JBoss+Enterprise+Application+Platform+6&version=6.2.0&keywords=Documentation
http://www.jboss.org/developer-program/termsandconditions
https://bugzilla.redhat.com/enter_bug.cgi?cf_environment=Build+Name%3A+22526%2C+Getting+Started+Guide-6.2-1%0ABuild+Date%3A+18-03-2014+15%3A53%3A08%0ATopic+ID%3A+26695-592669+%5BSpecified%5D&comment=Title%3A+About+the+Red+Hat+JBoss+Developer+Program%0A%0ADescribe+the+issue%3A%0A%0A%0ASuggestions+for+improvement%3A%0A%0A%0AAdditional+information%3A&cf_build_id=26695-592669+23+Feb+2014+16%3A59+en-US+%5BSpecified%5D&product=JBoss+Enterprise+Application+Platform+6&version=6.2.0&keywords=Documentation


provides additional entitlements to software updates and patches, support services, and access to the
Red Hat Knowledgebase. To participate in the program, you must create an account on the Customer
Portal at https://access.redhat.com/. To learn more about this program, see Section 1.2, “About the Red
Hat Customer Portal”.

Report a bug

1.5. HOW TO FIND MORE INFORMATION

The purpose of this guide is to get you up and running with Red Hat JBoss Enterprise Application
Platform as quickly as possible. If you want to learn more, the complete documentation suite for Red Hat
JBoss EAP is available on the Customer Portal at https://access.redhat.com/site/documentation/en-
US/JBoss_Enterprise_Application_Platform

Report a bug
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CHAPTER 2. PREREQUISITES

2.1. JBOSS EAP 6 INSTALLATION PREREQUISITES

Summary

JBoss EAP is available under the Red Hat JBoss Developer Program or the Full Red Hat JBoss
Commercial Program. For more information about the Red Hat JBoss Developer Program, see
Section 1.3, “About the Red Hat JBoss Developer Program”. For more information about the Full Red
Hat JBoss Commercial Program. see Section 1.4, “About the Full Red Hat JBoss Commercial Program”.
The following steps describe the prerequisites for both programs.

Common Prerequisites

Review the supported configurations and ensure your system is supported:
https://access.redhat.com/site/articles/111663.

If you set up an account on the Red Hat Customer Portal and are participating in the Full Red
Hat JBoss Commercial Program, ensure that your system is up to date with Red Hat issued
updates and errata.

ZIP/Installer Prerequisites

You must grant administration privileges for the installation directory.

Ensure that the chosen JDK has been extracted (or installed). See the JDK documentation for
information on how to do this.

On Microsoft Windows Server, ensure that the JAVA_HOME and PATH environment variables
have been set, otherwise shortcuts will not work.

On Hewlett-Packard HP-UX, ensure that an unzip utility has been installed.

Report a bug
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CHAPTER 3. DOWNLOAD AND INSTALL THE PRODUCT

3.1. JBOSS EAP INSTALLATION OVERVIEW

This guide provides instructions for the simplest installation process to help you get started using JBoss
EAP as quickly as possible. Complete installation procedures can be found in the Installation Guide for
JBoss EAP. After you install JBoss EAP, you can configure the server using the Management CLI or the
Management Console. For information about how to configure JBoss EAP, see the Administration and
Configuration Guide for JBoss EAP. Both guides are located on the Customer Portal at
https://access.redhat.com/site/documentation/JBoss_Enterprise_Application_Platform/.

You can install JBoss EAP in either of the following ways.

You can install JBoss EAP using the graphical installation program.

You can install JBoss EAP using a ZIP file.

Follow the instructions based on your preferred method of installation.

Report a bug

3.2. DOWNLOAD AND INSTALL JBOSS EAP USING THE GRAPHICAL
INSTALLATION PROGRAM

3.2.1. Download the JBoss EAP 6 Installation Program

Summary

JBoss EAP is available under the Red Hat JBoss Developer Program or the Full Red Hat JBoss
Commercial Program. Follow the procedure below that matches your program choice.

Procedure 3.1. Download the JBoss EAP Installation Program from the Customer Portal under
the Full Red Hat JBoss Commercial Program

Follow this procedure if you are participating in the Full Red Hat JBoss Commercial Program. For more
information about this program, see Section 1.4, “About the Full Red Hat JBoss Commercial Program”.

1. Open a browser and log into https://access.redhat.com.

2. Select Downloads from the menu at the top of the page.

3. Find Red Hat JBoss Middleware and click the Download Software button.

4. Select Application Platform from the Product drop-down menu that appears on the next
screen.

5. Find Red Hat JBoss Enterprise Application Platform 6.x.x Installer in the
list and click Download.

6. You are prompted to save the JAR file to a directory of your choice. Choose a directory and save
the file.

Result

The JBoss EAP 6 installation program JAR file has been downloaded successfully to the target machine.

CHAPTER 3. DOWNLOAD AND INSTALL THE PRODUCT
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Report a bug

3.2.2. Run the JBoss EAP Installation Program

The JBoss EAP installation program can be run in either graphical or text mode. This topic covers the
command to run the installation program in graphical mode.

If you are unsure about an option, simply take the default. You can easily configure the server at a later
time. For more information about how configure the JBoss EAP server, see the Administration and
Configuration Guide for Red Hat JBoss Enterprise Application Platform 6 located on the Customer Portal
at https://access.redhat.com/site/documentation/JBoss_Enterprise_Application_Platform/.

Procedure 3.2. Run the JBoss EAP Installation Program

1. Open a terminal and navigate to the directory containing the downloaded installation program
JAR.

2. Type the following command:

java -jar jboss-eap-6.3.0.jar

3. Follow the instructions in the table below.

Table 3.1. JBoss EAP Installation Program Screens

Screen name When it Appears Description

Section A.1, “Language
Selection”

Always Choose the desired language for the installation
program and click OK.

Section A.2, “End User
License Agreement”

Always The EULA for RED HAT JBOSS MIDDLEWARE.

Select "I accept the terms of this license agreement",
and click Next.

Section A.3, “Installation
Path”

Always Select the installation path for JBoss EAP and click 
Next. You are prompted to create the new directory,
or, if it exists, to replace the named directory.

Section A.4,
“Administrative User
Creation”

Always Create an administrative user and assign a password.
Then click Next.

Section A.5, “Quickstart
Installation”

Always Install the quickstart examples. Choose Yes and
select the installation path. Then click Next.

Getting Started Guide
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Section A.6, “Maven
Repository Setup”

If you choose to install
the quickstart examples

A publicly hosted Maven repository is available for
use with the quickstarts. This is the easiest way to
run the quickstarts.

Click Next to skip Maven repository setup. You
receive a warning that a Maven repository is required.
Maven configuration instructions are provided later in
this document, so you can safely click Yes to
continue.

Section A.7, “Pack
Installation”

Always Select the packs to install. Click Next to continue.

Section A.8, “Socket
Binding Setup”

Always Keep the default port bindings, then click Next.

Section A.9, “Server
Launch”

Always Select the startup option required on completion of
the installation process. Then click Next.

Section A.10, “Configure
Logging Levels”

Always Choose No to skip configuration of logging levels.
Then click Next.

Section A.11, “Review
Installation
Components”

Always Review your selections and click Next.

Section A.12,
“Installation Progress”

Always This screen displays the component installation
progress.

Upon completion, click Next.

Section A.13, “Post-
Install Configuration”

Always Choose Do not perform additional 
post-install configuration. Then click 
Next.

Section A.14,
“Installation Processing”

Always When processing completes, click Next.

Section A.15, “Create
Shortcuts”

Always Accept the default and click Next.

Section A.16, “Generate
Install Script”

Always Accept the default and click Next.

Installation complete Always Click Done.

Screen name When it Appears Description

Result

The installation is complete and JBoss EAP 6 is installed on your target machine.

Report a bug
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3.3. DOWNLOAD AND INSTALL JBOSS EAP USING THE ZIP

3.3.1. Download JBoss EAP 6 (ZIP Installation)

Summary

JBoss EAP is available under the Red Hat JBoss Developer Program or the Full Red Hat JBoss
Commercial Program. Follow the procedure below that matches your program choice.

Procedure 3.3. Download the ZIP file from the Customer Portal under the Full Red Hat JBoss
Commercial Program

Follow this procedure if you are participating in the Full Red Hat JBoss Commercial Program. For more
information about this program, see Section 1.4, “About the Full Red Hat JBoss Commercial Program”.

1. Open a browser and log into https://access.redhat.com.

2. Select Downloads from the menu at the top of the page.

3. Find Red Hat JBoss Middleware and click the Download Software button.

4. Select Application Platform from the Product drop-down menu that appears on the next
screen.

5. Find Red Hat JBoss Enterprise Application Platform 6.x.x in the list and click 
Download.

6. You are prompted to save the ZIP file to a directory of your choice. Choose a directory and save
the file.

Procedure 3.4. Download the ZIP file from jboss.org under the Red Hat JBoss Developer Program

Follow this procedure if you are participating in the Red Hat JBoss Developer Program. For more
information about this program, see Section 1.3, “About the Red Hat JBoss Developer Program”.

1. Open a browser and access the following URL: http://www.jboss.org/products/.

2. Find Red Hat JBoss Enterprise Application Platform in the list.

3. Click on the Download Now button.

4. You are prompted to save the ZIP file to a directory of your choice. Choose a directory and save
the file.

Result

The JBoss EAP 6 ZIP file has been downloaded successfully to the target machine.

Report a bug

3.3.2. Install JBoss EAP 6 (ZIP Installation)

Summary

This topic covers the steps to install JBoss EAP 6 using the downloaded ZIP file.
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Procedure 3.5. ZIP File Installation

1. Move the ZIP archive to the desired location.
Move the ZIP file to the server and directory where you plan to install JBoss EAP 6. The user
who will start and stop the server must have read and write access to this directory.

2. Use an appropriate application to extract the ZIP archive to the desired location.
In a Red Hat Enterprise Linux environment, use the unzip utility to extract the contents of the
ZIP archive.

In a Microsoft Windows environment, right-click the file and select Extract All.

In a Hewlett-Packard HP-UX environment, use the unzip utility to extract the contents of the ZIP
archive.

Result

JBoss EAP 6 has been installed successfully. The directory created by extracting the ZIP archive is the
top-level directory for the server. This is referred to as EAP_HOME.

Report a bug

3.4. DOWNLOAD THE QUICKSTART CODE EXAMPLES

3.4.1. Download the Quickstarts

Summary

JBoss EAP 6 comes with a comprehensive set of quickstart code examples designed to help users
begin writing applications using the Java EE 6 technologies.

If you chose to install the quickstart examples when you installed JBoss EAP, you can skip this topic.
Otherwise, you can download them now under the Red Hat JBoss Developer Program or the Full Red
Hat JBoss Commercial Program. Follow the procedure below that matches your program choice.

Procedure 3.6. Download the Quickstarts under the Full Red Hat JBoss Commercial Program

Follow this procedure if you are participating in the Full Red Hat JBoss Commercial Program. For more
information about this program, see Section 1.4, “About the Full Red Hat JBoss Commercial Program”.

1. Open a browser and log into https://access.redhat.com.

2. Find Red Hat JBoss Middleware and click the Download Software button.

3. Select Application Platform from the Product drop-down menu that appears on the next
screen.

4. Find Red Hat JBoss Enterprise Application Platform 6.x.x Quickstarts in
the list and click Download.

5. You are prompted to save the ZIP file to a directory of your choice. Choose a directory and save
the file.

6. Unzip the archive in a directory of your choosing.

Procedure 3.7. Download the Quickstarts under the Red Hat JBoss Developer Program
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Follow this procedure if you are participating in the Red Hat JBoss Developer Program. For more
information about this program, see Section 1.3, “About the Red Hat JBoss Developer Program”.

1. Open a web browser and access this URL: http://www.jboss.org/jdf/quickstarts/get-started/

2. Click the Download button to download a Zip archive containing the examples.

3. Unzip the archive in a directory of your choosing.

Report a bug
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CHAPTER 4. POST-INSTALL INSTRUCTIONS

4.1. SET UP THE DEVELOPMENT ENVIRONMENT

4.1.1. JBoss Developer Studio Installation Overview

This guide provides instructions for the simplest install path for JBoss Developer Studio. For complete
JBoss Developer Studio installation procedures, see the Installation Guide for JBoss Developer Studio
on https://access.redhat.com/site/documentation/en-US/Red_Hat_JBoss_Developer_Studio/.

Report a bug

4.1.2. Download JBoss Developer Studio

1. Go to http://www.jboss.org/products/.

2. Find Red Hat JBoss Developer Studio in the list.

3. Click the Download Now button. You are prompted to save the ZIP file to a directory of your
choice.

Report a bug

4.1.3. Install JBoss Developer Studio

1. Open a terminal and navigate to the directory containing the downloaded .jar file.

2. Run the following command to launch the GUI installation program:

java -jar jbdevstudio-build_version.jar

NOTE

Alternatively, you may be able to double-click the .jar file to launch the
installation program.

3. Click Next to start the installation process.

4. Select I accept the terms of this license agreement and click Next.

5. Adjust the installation path and click Next.

NOTE

If the installation path folder does not exist, a prompt will appear. Click Ok to
create the folder.

6. Choose a JVM, or leave the default JVM selected, and click Next.

7. JBoss Developer Studio includes JBoss Enterprise Application Platform. If it was previously
installed, choose No. Otherwise, choose Yes to install and configure it for use with JDBS.
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8. Review the installation details, and click Next.

9. Click Next when the installation process is complete.

10. Configure the desktop shortcuts for JBoss Developer Studio, and click Next.

11. Click Done.

Report a bug

4.1.4. Start JBoss Developer Studio

To start JBoss Developer Studio, you can double-click on the desktop shortcut created during the
installation, or you can start it in a command line. This topic describes how to start JDBS using the
command line.

Procedure 4.1. Command to start JBoss Developer Studio

1. Open a terminal and navigate to the JBoss Developer Studio installation directory.

2. Run the following command to start the JBoss Developer Studio:

For Linux:

[localhost]$ ./jbdevstudio

For Microsoft Windows:

C:\JDBS_INSTALL_DIRECTORY > jbdevstudio.bat

Report a bug

4.1.5. Add the JBoss EAP Server Using Runtime Detection

These instructions assume this is your first introduction to JBoss Developer Studio 7.x and you have not
yet added any JBoss EAP 6 servers. The procedure below adds the JBoss server using JBoss Server
Tools runtime detection.

Procedure 4.2. Define a Server Using Runtime Detection

1. Click Window→Preferences, expand JBoss Tools and select JBoss Runtime 
Detection.
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Figure 4.1. JBoss Runtime Detection Pane

2. Click Add.

3. Select the directory containing the JBoss Enterprise Application Platform 6.2
installation and click OK. The directory is now scanned to find JBoss Enterprise Application
Platform 6.2 application servers.

Figure 4.2. JBoss Enterprise Application Platform 6.x Found by Runtime Detection

4. Be sure the jboss-eap-6.2 check box is selected and click OK.

5. Click Apply to create a server for JBoss Enterprise Application Platform 6.2. Then click OK to
close the Preferences window. The server is listed in the Servers view.
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Figure 4.3. JBoss Enterprise Application Platform 6.2 Server Listed in Servers View

6. The server is initially shown in stopped mode. The server starts automatically when you deploy
a quickstart. To manually start the server, right-click jboss-eap-6.2 and click Start. After a
short pause, the view switches to the Console view and shows the startup output of the server.

Report a bug

4.1.6. Add the JBoss EAP Server Using Define New Server

These instructions assume this is your first introduction to JBoss Developer Studio 7.x and you have not
yet added any JBoss EAP servers. The procedure below adds the JBoss server using the Define New
Server wizard.

Procedure 4.3. Add the server

1. Open the Servers tab. If there is no Servers tab, add it to the panel as follows:

a. Click Window → Show View → Other....

b. Select Servers from the Server folder and click OK.

2. Click on the link to create a new server or right-click within the blank Server panel and
select New → Server.

Figure 4.4. Add a new server - No servers available

3. Expand JBoss Enterprise Middleware and choose JBoss Enterprise Application
Platform 6.1+. In the same dialog, click on the Add... link to define the new server runtime
environment and click Next.
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Figure 4.5. Define a New Server

4. Click Browse and navigate to your JBoss EAP install location. Then click Next.
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Figure 4.6. Add New Server Runtime Environment

5. Review the new JBoss EAP Server definition and click Next to continue.
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Figure 4.7. Review the New Server Definition

6. On this screen you define the server behavior. You can start the server manually or let JBoss
Developer Studio manage it for you. You can also define a remote server for deployment and
determine if you want to expose the management port for that server, for example, if you need
connect to it using JMX. In this example, we assume the server is local and you want JBoss
Developer Studio to manage your server so you do not need to check anything. Click Next.
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Figure 4.8. Define the New JBoss Server Behavior

7. This screen allows you to configure existing projects for the new server. Because you do not
have any projects at this point, click Finish.
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Figure 4.9. Modify resources for the new JBoss server

Result

The JBoss EAP Runtime Server is listed in the Servers tab.
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Figure 4.10. Server appears in the server list

Report a bug

4.2. CONFIGURE MAVEN

4.2.1. About Maven

Apache Maven is a distributed build automation tool used in Java application development to create,
manage, and build software projects. Maven uses standard configuration files called Project Object
Model, or POM, files to define projects and manage the build process. POMs describe the module and
component dependencies, build order, and targets for the resulting project packaging and output using
an XML file. This ensures that the project is built in a correct and uniform manner.

Maven achieves this by using a repository. A Maven repository stores Java libraries, plug-ins, and other
build artifacts. The default public repository is the Maven 2 Central Repository, but repositories can be
private and internal within a company with a goal to share common artifacts among development teams.
Repositories are also available from third-parties. JBoss EAP 6 includes a Maven repository that contains
many of the requirements that Java EE developers typically use to build applications on JBoss EAP 6.

For more information about Maven, see Welcome to Apache Maven.

For more information about Maven repositories, see Apache Maven Project - Introduction to
Repositories.

For more information about how to use Maven in JBoss EAP, see the chapter entitled Maven Guide in
the Development Guide for JBoss Enterprise Application Platform 6 located on the Customer Portal at
https://access.redhat.com/site/documentation/JBoss_Enterprise_Application_Platform/.

Report a bug

4.2.2. Configure the Maven Settings

The artifacts and dependencies needed to build and deploy applications to JBoss EAP 6 are hosted on a
public repository. You must direct Maven to use this repository when you build your applications. How
you do this depends on whether you plan to use JBoss Developer Studio or Maven command line to
build and deploy your applications.

JBoss Developer Studio includes Maven, so there is no need to download and install it separately. If you
plan to use JBoss Developer Studio to build and deploy your applications, use the following instructions
to configure the Maven settings: Section 4.2.3.1, “Configure Maven for Use with JBoss Developer
Studio”

If you plan to use the Maven command line to build and deploy your applications, you must first
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download and install Maven using the instructions here: Section 4.2.4.1, “Download and Install Maven”.
Then follow these instructions to configure the Maven settings: Section 4.2.4.2, “Configure the Maven
Settings for Use with Command Line”

Report a bug

4.2.3. Configure Maven for JBoss Developer Studio

4.2.3.1. Configure Maven for Use with JBoss Developer Studio

The artifacts and dependencies needed to build and deploy applications to JBoss EAP 6 are hosted on a
public repository. You must direct Maven to use this repository when you build your applications. This
topic covers the steps to configure Maven if you plan to build and deploy application using JBoss
Developer Studio. If you plan to use Maven command line to build and deploy applications, you can skip
this topic. Instead, follow the instructions here: Section 4.2.4.2, “Configure the Maven Settings for Use
with Command Line”.

Maven is distributed with JBoss Developer Studio, so it is not necessary to install it separately. However,
you must configure Maven for use by the Java EE Web Project wizard for deployments to JBoss
Enterprise Application Server 6.x. The procedure below demonstrates how to configure Maven for use
with JBoss Enterprise Application Server 6.x by editing the Maven configuration file from within JBoss
Developer Studio.

Procedure 4.4. Configure Maven in JBoss Developer Studio

1. Click Window→Preferences, expand JBoss Tools and select JBoss Maven 
Integration.

Figure 4.11. JBoss Maven Integration Pane in the Preferences Window

2. Click Configure Maven Repositories.

3. Click Add Repository to configure the JBoss GA Tech Preview Maven repository. Complete
the Add Maven Repository dialog as follows:

a. Set the Profile ID, Repository ID, and Repository Name values to jboss-ga-
repository.

CHAPTER 4. POST-INSTALL INSTRUCTIONS

23

https://bugzilla.redhat.com/enter_bug.cgi?cf_environment=Build+Name%3A+22526%2C+Getting+Started+Guide-6.2-1%0ABuild+Date%3A+18-03-2014+15%3A53%3A08%0ATopic+ID%3A+27043-619648+%5BSpecified%5D&comment=Title%3A+Configure+the+Maven+Settings%0A%0ADescribe+the+issue%3A%0A%0A%0ASuggestions+for+improvement%3A%0A%0A%0AAdditional+information%3A&cf_build_id=27043-619648+10+Mar+2014+14%3A09+en-US+%5BSpecified%5D&product=JBoss+Enterprise+Application+Platform+6&version=6.2.0&keywords=Documentation


b. Set the Repository URL value to 
http://maven.repository.redhat.com/techpreview/all.

c. Click the Active by default checkbox to enable the Maven repository.

d. Click OK

Figure 4.12. Add Maven Repository - JBoss Tech Preview

4. Click Add Repository to configure the JBoss Early Access Maven repository. Complete the 
Add Maven Repository dialog as follows:

a. Set the Profile ID, Repository ID, and Repository Name values to jboss-
earlyaccess-repository.

b. Set the Repository URL value to 
http://maven.repository.redhat.com/earlyaccess/all/.

c. Click the Active by default checkbox to enable the Maven repository.

d. Click OK
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Figure 4.13. Add Maven Repository - JBoss Early Access

5. Review the repositories and click Finish.
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Figure 4.14. Review Maven Repositories

6. You are prompted with the message "Are you sure you want to update the file
'MAVEN_HOME/settings.xml'?". Click Yes to update the settings. Click OK to close the dialog.

The JBoss EAP Maven repository is now configured for use with JBoss Developer Studio.

Report a bug

4.2.4. Configure Maven for Command Line

4.2.4.1. Download and Install Maven

If you plan to use Maven command line to build and deploy your applications to JBoss EAP, you must
download and install Maven. If you plan to use JBoss Developer Studio (JDBS) to build and deploy your
applications, you can skip this procedure as Maven is distributed with JBDS.

1. Go to Apache Maven Project - Download Maven and download the latest distribution for your
operating system.

2. See the Maven documentation for information on how to download and install Apache Maven for
your operating system.

Report a bug
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4.2.4.2. Configure the Maven Settings for Use with Command Line

The artifacts and dependencies needed to build and deploy applications to JBoss EAP 6 are hosted on a
public repository. If you plan to use JBoss Developer Studio to build and deploy applications, you can
skip this topic. Instead, follow the instructions here: Section 4.2.3.1, “Configure Maven for Use with
JBoss Developer Studio”. However, if you plan to use Maven command line, you must direct Maven to
use the JBoss EAP 6 Maven Repository across your projects using the Maven settings.

There are 2 ways to configure the settings for use with Maven command line.

You can copy the preconfigured settings.xml file that ships with the quickstarts.

You can manually edit the Maven settings.xml file.

This topic describes both methods. If you have downloaded the quickstarts, the first procedure is the
simplest way to configure the settings.

Prerequisites

You must install Maven before you configure the settings. For more information, see: Section 4.2.4.1,
“Download and Install Maven”

Procedure 4.5. Configure Maven Using the Settings Shipped with the Quickstart Examples

The Red Hat JBoss Enterprise Application Platform Quickstarts ship with a settings.xml file that is
configured to use the online JBoss EAP Maven repository. If you have downloaded the quickstarts, this is
the easiest way to configure the settings.

1. This procedure overwrites the existing Maven settings file, so you must back up the existing
Maven settings.xml file.

a. Locate the Maven install directory for your operating system. It is usually installed in 
USER_HOME/.m2/ directory.

For Linux or Mac, this is: ~/.m2/

For Windows, this is: \Documents and Settings\USER_NAME\.m2\ or 
\Users\USER_NAME\.m2\

b. If you have an existing USER_HOME/.m2/settings.xml file, rename it or make a backup
copy so you can restore it later.

2. If have not yet downloaded the quickstarts, follow the instructions here: Section 3.4.1,
“Download the Quickstarts”.

3. Copy the QUICKSTART_HOME/settings.xml file to the USER_HOME/.m2/ directory.

4. If you modify the settings.xml file while JBoss Developer Studio is running, follow the
procedure at the end of this topic entitled Refresh the JBoss Developer Studio User Settings.

Procedure 4.6. Manually Edit and Configure the Maven Settings To Use the Online JBoss EAP
Maven Repository

You can manually add the JBoss EAP profiles to an existing Maven settings file.

1. Locate the Maven install directory for your operating system. It is usually installed in 
USER_HOME/.m2/ directory.
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For Linux or Mac, this is ~/.m2/

For Windows, this is \Documents and Settings\USER_NAME\.m2\ or 
\Users\USER_NAME\.m2\

2. If you do not find a settings.xml file, copy the settings.xml file from the 
USER_HOME/.m2/conf/ directory into the USER_HOME/.m2/ directory.

3. Copy the following XML into the <profiles> element of the file.

<!-- Configure the JBoss GA Maven repository -->
<profile>
  <id>jboss-ga-repository</id>
  <repositories>
    <repository>
      <id>jboss-ga-repository</id>
      <url>http://maven.repository.redhat.com/techpreview/all</url>
      <releases>
        <enabled>true</enabled>
      </releases>
      <snapshots>
        <enabled>false</enabled>
      </snapshots>
    </repository>
  </repositories>
  <pluginRepositories>
    <pluginRepository>
      <id>jboss-ga-plugin-repository</id>
      <url>http://maven.repository.redhat.com/techpreview/all</url>
      <releases>
        <enabled>true</enabled>
      </releases>
      <snapshots>
        <enabled>false</enabled>
      </snapshots>
    </pluginRepository>
  </pluginRepositories>
</profile>
<!-- Configure the JBoss Early Access Maven repository -->
<profile>
  <id>jboss-earlyaccess-repository</id>
  <repositories>
    <repository>
      <id>jboss-earlyaccess-repository</id>
      <url>http://maven.repository.redhat.com/earlyaccess/all/</url>
      <releases>
        <enabled>true</enabled>
      </releases>
      <snapshots>
        <enabled>false</enabled>
      </snapshots>
    </repository>
  </repositories>
  <pluginRepositories>
    <pluginRepository>
      <id>jboss-earlyaccess-plugin-repository</id>
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Copy the following XML into the <activeProfiles> element of the settings.xml file.

4. If you modify the settings.xml file while JBoss Developer Studio is running, follow the
procedure at the end of this topic entitled Refresh the JBoss Developer Studio User Settings.

Procedure 4.7. Refresh the JBoss Developer Studio User Settings

If you modify the settings.xml file while JBoss Developer Studio is running, you must refresh the user
settings.

1. From the menu, choose Window → Preferences.

2. In the Preferences Window, expand Maven and choose User Settings.

3. Click the Update Settings button to refresh the Maven user settings in JBoss Developer
Studio.

      <url>http://maven.repository.redhat.com/earlyaccess/all/</url>
      <releases>
        <enabled>true</enabled>
      </releases>
      <snapshots>
        <enabled>false</enabled>
      </snapshots>
    </pluginRepository>
  </pluginRepositories>
</profile>

<activeProfile>jboss-ga-repository</activeProfile>
<activeProfile>jboss-earlyaccess-repository</activeProfile>
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Figure 4.15. Update Maven User Settings

IMPORTANT

If your Maven repository contains outdated artifacts, you may encounter one of the
following Maven error messages when you build or deploy your project:

Missing artifact ARTIFACT_NAME

[ERROR] Failed to execute goal on project PROJECT_NAME; Could not resolve
dependencies for PROJECT_NAME

To resolve the issue, delete the cached version of your local repository to force a
download of the latest Maven artifacts. The cached repository is located in your 
~/.m2/repository/ subdirectory on Linux, or the 
%SystemDrive%\Users\USERNAME\.m2\repository\ subdirectory on Windows.

Report a bug
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CHAPTER 5. TRY IT OUT

5.1. RUN THE QUICKSTARTS

5.1.1. Run the Quickstarts in JBoss Developer Studio

Procedure 5.1. Import the quickstarts into JBoss Developer Studio

Each quickstart ships with a POM (Project Object Model) file that contains project and configuration
information for the quickstart. Using this POM file, you can easily import the quickstart into JBoss
Developer Studio.

1. If you have not yet done so, Section 4.2.4.2, “Configure the Maven Settings for Use with
Command Line”.

2. Start JBoss Developer Studio.

3. From the menu, select File → Import.

4. In the selection list, choose Maven → Existing Maven Projects, then click Next.
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Figure 5.1. Import Existing Maven Projects

5. Browse to the directory of the quickstart you plan to test, for example the helloworld
quickstart, and click OK. The Projects list box is populated with the pom.xml file of the
selected quickstart project.
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Figure 5.2. Select Maven Projects

6. Click Finish.

Procedure 5.2. Build and Deploy the helloworld quickstart

The helloworld quickstart is one of the simplest quickstarts and is a good way to verify that the JBoss
server is configured and running correctly.

1. If you do not see a Servers tab, add it the panel as follows:

a. Click Window → Show View → Other....

b. Select Servers from the Server folder and click OK.

2. Right-click on the jboss-helloworld project in the Project Explorer tab and select Run
As. You are provided with a list of choices. Select Run on Server.

CHAPTER 5. TRY IT OUT

33



Figure 5.3. Run As - Run on Server

3. Select jboss-eap-6.2 from the server list and click Next.
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Figure 5.4. Run on Server

4. The next screen displays the resources that are configured on the server. The jboss-
helloworld quickstart is configured for you. Click Finish to deploy the quickstart.
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Figure 5.5. Modify Resources Configured on the Server

5. Review the results.

In the Server tab, the JBoss EAP 6.2 Runtime Server status changes to [Started, 
Republish] .

The server Console tab shows messages detailing the JBoss EAP 6.2 server start and the
helloworld quickstart deployment.

A helloworld tab appears displaying the URL http://localhost:8080/jboss-
helloworld/HelloWorld and the text "Hello World!".

The following messages in the Console confirm deployment of the jboss-
helloworld.war file:

JBAS018210: Register web context: /jboss-helloworld
JBAS018559: Deployed "jboss-helloworld.war" (runtime-name : 
"jboss-helloworld.war")
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The registered web context is appended to http://localhost:8080 to provide the URL
used to access the deployed application.

6. To verify the helloworld quickstart deployed successfully to the JBoss server, open a web
browser and access the application at this URL: http://localhost:8080/jboss-helloworld

Report a bug

5.1.2. Run the Quickstarts Using a Command Line

Procedure 5.3. Build and Deploy the Quickstarts Using a Command Line

You can easily build and deploy the quickstarts using a command line. Be aware that, when using a
command line, you are responsible for starting the JBoss server if it is required.

1. If you have not yet done so, Section 4.2.4.2, “Configure the Maven Settings for Use with
Command Line”.

2. Review the README file in the root directory of the quickstarts.
This file contains general information about system requirements, how to configure Maven, how
to add users, and how to run the Quickstarts. Be sure to read through it before you get started.

It also contains a table listing the available quickstarts. The table lists each quickstart name and
the technologies it demonstrates. It gives a brief description of each quickstart and the level of
experience required to set it up. For more detailed information about a quickstart, click on the
quickstart name.

Some quickstarts are designed to enhance or extend other quickstarts. These are noted in the 
Prerequisites column. If a quickstart lists prerequisites, you must install them first before
working with the quickstart.

Some quickstarts require the installation and configuration of optional components. Do not install
these components unless the quickstart requires them.

3. Run the helloworld quickstart.
The helloworld quickstart is one of the simplest quickstarts and is a good way to verify that
the JBoss server is configured and running correctly. Open the README file in the root of the 
helloworld quickstart. It contains detailed instructions on how to build and deploy the
quickstart and access the running application

4. Run the other quickstarts.
Follow the instructions in the README file located in the root folder of each quickstart to run the
example.

Report a bug
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APPENDIX A. INSTALLATION PROGRAM SCREEN SHOTS

A.1. LANGUAGE SELECTION

Figure A.1. JBoss EAP Installation Program Language Selection
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A.2. END USER LICENSE AGREEMENT
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Figure A.2. JBoss EAP Installation Program End User License Agreement
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A.3. INSTALLATION PATH
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Figure A.3. JBoss EAP Installion Program Installation Path
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A.4. ADMINISTRATIVE USER CREATION

Getting Started Guide

40

https://bugzilla.redhat.com/enter_bug.cgi?cf_environment=Build+Name%3A+22526%2C+Getting+Started+Guide-6.2-1%0ABuild+Date%3A+18-03-2014+15%3A53%3A08%0ATopic+ID%3A+21930-592440+%5BSpecified%5D&comment=Title%3A+Installation+Path%0A%0ADescribe+the+issue%3A%0A%0A%0ASuggestions+for+improvement%3A%0A%0A%0AAdditional+information%3A&cf_build_id=21930-592440+23+Feb+2014+16%3A58+en-US+%5BSpecified%5D&product=JBoss+Enterprise+Application+Platform+6&version=6.2.0&keywords=Documentation


Figure A.4. JBoss EAP Installation Program Administrative User Creation
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A.5. QUICKSTART INSTALLATION
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Figure A.5. JBoss EAP Installation Program Quickstart Setup

Report a bug

A.6. MAVEN REPOSITORY SETUP
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Figure A.6. JBoss EAP Installation Program Skip Maven Repository Installation
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Figure A.7. JBoss EAP Installation Program Configure Maven Repository Installation
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A.7. PACK INSTALLATION
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Figure A.8. JBoss EAP Installation Program Package Installation
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A.8. SOCKET BINDING SETUP

Determine whether to use the default bindings, or configure custom bindings.
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Figure A.9. JBoss EAP Installation Program Default Socket Bindings
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A.9. SERVER LAUNCH
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Figure A.10. JBoss EAP Installation Program Server Launch
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A.10. CONFIGURE LOGGING LEVELS
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Figure A.11. JBoss EAP Installation Program Configure Logging Levels
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A.11. REVIEW INSTALLATION COMPONENTS
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Figure A.12. JBoss EAP Installation Program Review Selected Components
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A.12. INSTALLATION PROGRESS
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Figure A.13. JBoss EAP Installation Program Component Installation Progress
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A.13. POST-INSTALL CONFIGURATION

You can choose to perform post-installation configuration tasks or finish the install and configure these
components later.
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Figure A.14. JBoss EAP Installation Program Skip Post-Install Configuration
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A.14. INSTALLATION PROCESSING
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Figure A.15. JBoss EAP Installation Program Processing
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A.15. CREATE SHORTCUTS
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Figure A.16. JBoss EAP Installer Create Shortcuts
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A.16. GENERATE INSTALL SCRIPT
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Figure A.17. JBoss EAP Installation Program Generate Install Script
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