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Abstract

Use this guide to understand and manage content in Satellite 6. Examples of such content include
RPM files, and ISO images. Red Hat Satellite 6 manages this content using a set of Content Views
promoted across the application lifecycle. This guide demonstrates how to create an application
lifecycle that suits your organization and content views that fulfils host states within lifecycle
environments. These content views eventually form the basis for provisioning and updating hosts in
your Red Hat Satellite 6 environment.
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We appreciate your input on our documentation. Please let us know how we could make it better.

® Forsimple comments on specific passages:

1. Ensure you are viewing the documentation in the Multi-page HTML format.
In addition, ensure you see the Feedback button in the upper right corner of the document.

2. Use your mouse cursor to highlight the part of text that you want to comment on.
3. Click the Add Feedback pop-up that appears below the highlighted text.
4. Follow the displayed instructions.
® For submitting feedback via Bugzilla, create a new ticket:
1. Go to the Bugzilla website.
2. As the Component, use Documentation.

3. Fillin the Description field with your suggestion for improvement. Include a link to the
relevant part(s) of documentation.

4. Click Submit Bug.


https://bugzilla.redhat.com/enter_bug.cgi?product=Red Hat Satellite
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CHAPTER 1. INTRODUCTION TO CONTENT MANAGEMENT

In the context of Satellite, content is defined as the software installed on systems. This includes, but is
not limited to, the base operating system, middleware services, and end-user applications. With Red Hat
Satellite, you can manage the various types of content for Red Hat Enterprise Linux systems at every
stage of the software life cycle.

Red Hat Satellite manages the following content:

Subscription management
This provides organizations with a method to manage their Red Hat subscription information.
Content management

This provides organizations with a method to store Red Hat content and organize it in various ways.
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CHAPTER 2. CONTENT MANAGEMENT TYPES OVERVIEW

With Red Hat Satellite, you can manage the following content types:

RPM Packages

Import RPM packages from repositories related to your Red Hat subscriptions. Satellite Server
downloads the RPM files from Red Hat's Content Delivery Network and stores them locally. You can
use these repositories and their RPM files in Content Views.

Kickstart Trees

Import the kickstart trees for creating a system. New systems access these kickstart trees over a
network to use as base content for their installation. Red Hat Satellite also contains some predefined
kickstart templates as well as the ability to create your own, which are used to provision systems and
customize the installation.

You can also manage other types of custom content in Satellite. For example:

ISO and KVM Images

Download and manage media for installation and provisioning. For example, Satellite downloads,
stores, and manages ISO images and guest images for specific Red Hat Enterprise Linux and non-
Red Hat operating systems.

You can use the procedure to add custom content for any type of content you require, for example, SSL
certificates and OVAL files.
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CHAPTER 3. MANAGING ORGANIZATIONS

Organizations divide Red Hat Satellite resources into logical groups based on ownership, purpose,
content, security level, or other divisions. You can create and manage multiple organizations through
Red Hat Satellite, then divide and assign your Red Hat subscriptions to each individual organization. This
provides a method of managing the content of several individual organizations under one management
system. Here are some examples of organization management:

Single Organization

A small business with a simple system administration chain. In this case, you can create a single
organization for the business and assign content to it.

Multiple Organizations

A large company that owns several smaller business units. For example, a company with separate
system administration and software development groups. In this case, you can create organizations
for the company and each of the business units it owns. This keeps the system infrastructure for
each separate. You can then assign content to each organization based on its needs.

External Organizations

A company that manages external systems for other organizations. For example, a company offering
cloud computing and web hosting resources to customers. In this case, you can create an
organization for the company’s own system infrastructure and then an organization for each external
business. You can then assign content to each organization where necessary.

A default installation of Red Hat Satellite has a default organization called Default_Organization.

New Users

If a new user is not assigned a default organization, their access is limited. To grant systems rights to
users, assign them to a default organization. The next time the user logs on to Satellite, the user’s
account has the correct system rights.

3.1. CREATING AN ORGANIZATION

Use this procedure to create an organization. To use the CLI instead of the Satellite web Ul, see CLI
procedure.

Procedure
1. In the Satellite web Ul, navigate to Administer > Organizations.

2. Click New Organization.

3. Inthe Name field, enter a name for the organization.

4. In the Label field, enter a unique identifier for the organization. This is used for creating and
mapping certain assets, such as directories for content storage. Use letters, numbers,
underscores, and dashes, but no spaces.

5. Optional: in the Description field, enter a description for the organization.

6. Click Submit.

7. If you have hosts with no organization assigned, select the hosts that you want to add to the
organization, then click Proceed to Edit
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8. In the Edit page, assign the infrastructure resources that you want to add to the organization.
This includes networking resources, installation media, kickstart templates, and other
parameters. You can return to this page at any time by navigating to Administer >
Organizations and then selecting an organization to edit.

9. Click Submit.

CLI procedure

1. To create an organization, enter the following command:

# hammer organization create \

--name "My _Organization" \

--label "My _QOrganization_Label" \
--description "My _Organization_Description"

2. Optional: To edit an organization, enter the hammer organization update command. For
example, the following command assigns a compute resource to the organization:

# hammer organization update \
--name "My _Organization" \
--compute-resource-ids 1

3.2.SETTING THE ORGANIZATION CONTEXT
An organization context defines the organization to use for a host and its associated resources.

Procedure

The organization menu is the first menu item in the menu bar, on the upper left of the Satellite web Ul. If
you have not selected a current organization, the menu says Any Organization. Click the Any
Organization button and select the organization to use.

CLI procedure

While using the CLI, include either --organization "My_Organization" or --organization-label
"My_Organization_Label" as an option. For example:

# hammer subscription list \
--organization "My _Organization"

This command outputs subscriptions allocated for the My_Organization.

3.3. CREATING AN ORGANIZATION DEBUG CERTIFICATE

If you require a debug certificate for your organization, use the following procedure.

Procedure
1. In the Satellite web Ul, navigate to Administer > Organizations.
2. Select an organization that you want to generate a debug certificate for.

3. Click Generate and Download
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4. Save the certificate file in a secure location.

Debug Certificates for Provisioning Templates

Debug Certificates are automatically generated for provisioning template downloads if they do not
already exist in the organization for which they are being downloaded.

3.4. BROWSING REPOSITORY CONTENT USING AN ORGANIZATION
DEBUG CERTIFICATE

You can view an organization’s repository content using a web browser or using the API if you have a
debug certificate for that organization.

Prerequisites

1. Create and download an organization certificate as described in Section 3.3, “Creating an
Organization Debug Certificate”.

2. Open the X.509 certificate, for example, for the default organization:
I $ vi 'Default Organization-key-cert.pem'’

3. Copy the contents of the file from ----- BEGIN RSA PRIVATE KEY----- 1O =m=m- END RSA
PRIVATE KEY-----, into a key.pem file.

4. Copy the contents of the file from ===-- BEGIN CERTIFICATE----- to ----- END CERTIFICATE---
--, into a cert.pem file.

Procedure

To use a browser, you must first convert the X.509 certificate to a format your browser supports and
then import the certificate.

For Firefox Users

To use an organization debug certificate in Firefox, complete the following steps:

1. To create a PKCS12 format certificate, enter the following command:

$ openssl pkcs12 -keypbe PBE-SHA1-3DES -certpbe PBE-SHA1-3DES -export -in cert.pem
-inkey key.pem -out My_Organization_Label.pfx -name My _Organization

2. In the Firefox browser, navigate to Edit > Preferences > Advanced Tab.
3. Select View Certificates, and click the Your Certificates tab.
4. Click Import and select the .pfx file to load.

5. Enter the following URL in the address bar to browse the accessible paths for all the
repositories and check their contents:

I https://satellite.example.com/pulp/content/

Pulp uses the organization label, therefore, you must enter the organization label into the URL.

For CURL Users

10
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To use the organization debug certificate with CURL, enter the following command:

$ curl -k --cert cert.pem --key key.pem \
https://satellite.example.com/pulp/content/ My _Organization_Label/Library/content/dist/rhel/server/7/7S
erver/x86_64/os/

Ensure that the paths to cert.pem and key.pem are the correct absolute paths otherwise the command
fails silently.

3.5.DELETING AN ORGANIZATION

You can delete an organization if the organization is not associated with any life cycle environments or
host groups. If there are any life cycle environments or host groups associated with the organization you
are about to delete, remove them by navigating to Administer > Organizations and clicking the relevant
organization. Do not delete the default organization created during installation because the default
organization is a placeholder for any unassociated hosts in the Satellite environment. There must be at
least one organization in the environment at any given time.

Procedure

1. In the Satellite web Ul, navigate to Administer > Organizations.
2. From the list to the right of the name of the organization you want to delete, select Delete.

3. Click OK to delete the organization.

CLI procedure
1. Enter the following command to retrieve the ID of the organization that you want to delete:

I # hammer organization list

From the output, note the ID of the organization that you want to delete.

2. Enter the following command to delete an organization:

I # hammer organization delete --id Organization_ID

1
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CHAPTER 4. MANAGING LOCATIONS

Locations function similar to organizations: they provide a method to group resources and assign hosts.
Organizations and locations have the following conceptual differences:

® | ocations are based on physical or geographical settings.

® | ocations have a hierarchical structure.

4.1. CREATING A LOCATION

Use this procedure to create a location so that you can manage your hosts and resources by location. To
use the CLI instead of the Satellite web Ul, see the CLI procedure.

Procedure

1. In the Satellite web Ul, navigate to Administer > Locations.
2. Click New Location.
3. Optional: from the Parent list, select a parent location. This creates a location hierarchy.
4. In the Name field, enter a name for the location.
5. Optional: in the Description field, enter a description for the location.
6. Click Submit.

7. If you have hosts with no location assigned, add any hosts that you want to assign to the new
location, then click Proceed to Edit

8. Assign any infrastructure resources that you want to add to the location. This includes
networking resources, installation media, kickstart templates, and other parameters. You can
return to this page at any time by navigating to Administer > Locations and then selecting a
location to edit.

9. Click Submit to save your changes.

CLI procedure

® Enter the following command to create a location:

# hammer location create \

--description "My _Location_Description" \
--name "My _Location" \

--parent-id "My _Location_Parent _ID"

4.2. CREATING MULTIPLE LOCATIONS

The following example Bash script creates three locations - London, Munich, Boston - and assigns them
to the Example Organization.

ORG="Example Organization"
LOCATIONS="London Munich Boston"

12
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for LOC in ${LOCATIONS}
do

hammer location create --name "${LOC}"

hammer location add-organization --name "${LOC}" --organization "${ORG}"
done

4.3.SETTING THE LOCATION CONTEXT

A location context defines the location to use for a host and its associated resources.

Procedure

The location menu is the second menu item in the menu bar, on the upper left of the Satellite web Ul. If
you have not selected a current location, the menu displays Any Location. Click Any location and select
the location to use.

CLI procedure

While using the CLI, include either --location "My _Location" or --location-id "My _Location_ID" as an
option. For example:

I # hammer host list --location "My _Location"

This command lists hosts associated with the My_Location location.

4.4 DELETING A LOCATION

You can delete a location if the location is not associated with any life cycle environments or host
groups. If there are any life cycle environments or host groups associated with the location you are
about to delete, remove them by navigating to Administer > Locations and clicking the relevant
location. Do not delete the default location created during installation because the default location is a

placeholder for any unassociated hosts in the Satellite environment. There must be at least one location
in the environment at any given time.

Procedure

1. In the Satellite web Ul, navigate to Administer > Locations.
2. Select Delete from the list to the right of the name of the location you want to delete.

3. Click OK to delete the location.
CLI procedure
1. Enter the following command to retrieve the ID of the location that you want to delete:
I # hammer location list

From the output, note the ID of the location that you want to delete.

2. Enter the following command to delete the location:

I # hammer location delete --id Location ID

13
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CHAPTER 5. MANAGING RED HAT SUBSCRIPTIONS

Red Hat Satellite can import content from the Red Hat Content Delivery Network (CDN). Satellite
requires a Red Hat Subscription Manifest to find, access, and download content from the corresponding
repositories. You must have a Red Hat Subscription Manifest containing a subscription allocation for
each organization on Satellite Server. All subscription information is available in your Red Hat Customer
Portal account.

Before you can complete the tasks in this chapter, you must create a Red Hat Subscription Manifest in
the Customer Portal.

Note that the entitlement-based subscription model is deprecated and will be removed in a future
release. Red Hat recommends that you use the access-based subscription model of Simple Content
Access instead.

To create, manage, and export a Red Hat Subscription Manifest in the Customer Portal, see Using
Manifests in the Using Red Hat Subscription Management guide.

Use this chapter to import a Red Hat Subscription Manifest and manage the manifest within the Satellite
web Ul

Subscription Allocations and Organizations

You can manage more than one organization if you have more than one subscription allocation. Satellite
requires a single allocation for each organization configured in Satellite Server. The advantage of this is

that each organization maintains separate subscriptions so that you can support multiple organizations,

each with their own Red Hat accounts.

Future-Dated subscriptions

You can use future-dated subscriptions in a subscription allocation. When you add future-dated
subscriptions to content hosts before the expiry date of the existing subscriptions, you can have
uninterrupted access to repositories.

Manually attach the future-dated subscriptions to your content hosts before the current subscriptions
expire. Do not rely on the auto-attach method because this method is designed for a different purpose
and might not work. For more information, see Section 5.6, "Attaching Red Hat Subscriptions to
Content Hosts".

5.1. IMPORTING A RED HAT SUBSCRIPTION MANIFEST INTO
SATELLITE SERVER

Use the following procedure to import a Red Hat Subscription Manifest into Satellite Server.

Prerequisites

® You must have a Red Hat Subscription Manifest file exported from the Customer Portal. For
more information, see Creating and Managing Manifests in Using Red Hat Subscription
Management.

Procedure

1. In the Satellite web Ul, ensure the context is set to the organization you want to use.

2. In the Satellite web Ul, navigate to Content > Subscriptions and click Manage Manifest.

14
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3. In the Manage Manifest window, click Browse.
4. Navigate to the location that contains the Red Hat Subscription Manifest file, then click Open. If

the Manage Manifest window does not close automatically, click Close to return to the
Subscriptions window.

CLI procedure

1. Copy the Red Hat Subscription Manifest file from your client to Satellite Server:

I $ scp ~/manifest file.zip root@satellite.example.com:~/.

2. Login to Satellite Server as the root user and import the Red Hat Subscription Manifest file:

# hammer subscription upload \
--file ~/manifest_file.zip \
--organization "My _Organization"

You can now enable repositories and import Red Hat content. For more information, see Importing
Content in the Content Management guide.

5.2. LOCATING A RED HAT SUBSCRIPTION

When you import a Red Hat Subscription Manifest into Satellite Server, the subscriptions from your
manifest are listed in the Subscriptions window. If you have a high volume of subscriptions, you can filter
the results to find a specific subscription.

Prerequisite

® You must have a Red Hat Subscription Manifest file imported to Satellite Server. For more
information, see Section 5.1, “Importing a Red Hat Subscription Manifest into Satellite Server” .

Procedure

1. In the Satellite web Ul, ensure the context is set to the organization you want to use.
2. In the Satellite web Ul, navigate to Content > Subscriptions.

3. In the Subscriptions window, click the Search field to view the list of search criteria for building
your search query.

4. Select search criteria to display further options.
5. When you have built your search query, click the search icon.
For example, if you place your cursor in the Search field and select expires, then press the space bar,

another list appears with the options of placing a >, <, or = character. If you select >and press the space
bar, another list of automatic options appears. You can also enter your own criteria.

5.3. ADDING RED HAT SUBSCRIPTIONS TO SUBSCRIPTION
ALLOCATIONS

Use the following procedure to add Red Hat subscriptions to a subscription allocation in the Satellite
web Ul

15
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Prerequisite

® You must have a Red Hat Subscription Manifest file imported to Satellite Server. For more
information, see Section 5.1, “Importing a Red Hat Subscription Manifest into Satellite Server” .

Procedure

1. In the Satellite web Ul, ensure the context is set to the organization you want to use.
2. In the Satellite web Ul, navigate to Content > Subscriptions.
3. In the Subscriptions window, click Add Subscriptions.

4. On the row of each subscription you want to add, enter the quantity in the Quantity to Allocate
column.

5. Click Submit

5.4. REMOVING RED HAT SUBSCRIPTIONS FROM SUBSCRIPTION
ALLOCATIONS

Use the following procedure to remove Red Hat subscriptions from a subscription allocation in the
Satellite web Ul.

NOTE
Manifests must not be deleted. If you delete the manifest from the Red Hat Customer

Portal or in the Satellite web Ul, all of the entitlements for all of your content hosts will be
removed.

Prerequisite

® You must have a Red Hat Subscription Manifest file imported to Satellite Server. For more
information, see Section 5.1, “Importing a Red Hat Subscription Manifest into Satellite Server” .

Procedure

1. In the Satellite web Ul, ensure the context is set to the organization you want to use.
2. In the Satellite web Ul, navigate to Content > Subscriptions.
3. On the row of each subscription you want to remove, select the corresponding checkbox.

4. Click Delete, and then confirm deletion.

5.5. UPDATING AND REFRESHING RED HAT SUBSCRIPTION
MANIFESTS

Every time that you change a subscription allocation, you must refresh the manifest to reflect these
changes. For example, you must refresh the manifest if you take any of the following actions:

® Renewing a subscription

® Adjusting subscription quantities
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® Purchasing additional subscriptions

You can refresh the manifest directly in the Satellite web Ul. Alternatively, you can import an updated
manifest that contains the changes.

Procedure
1. In the Satellite web Ul, ensure the context is set to the organization you want to use.
2. In the Satellite web Ul, navigate to Content > Subscriptions.
3. In the Subscriptions window, click Manage Manifest.

4. In the Manage Manifest window, click Refresh.

5.6. ATTACHING RED HAT SUBSCRIPTIONS TO CONTENT HOSTS

Using activation keys is the main method to attach subscriptions to content hosts during the
provisioning process. However, an activation key cannot update an existing host. If you need to attach
new or additional subscriptions, such as future-dated subscriptions, to one host, use the following
procedure.

For more information about updating multiple hosts, see Section 5.7, “Updating Red Hat Subscriptions
on Multiple Hosts".

For more information about activation keys, see Chapter 10, Managing Activation Keys.

Satellite Subscriptions

In Satellite, you must maintain a Red Hat Enterprise Linux Satellite subscription, formerly known as
Red Hat Enterprise Linux Smart Management, for every Red Hat Enterprise Linux host that you want to
manage.

However, you are not required to attach Satellite subscriptions to each content host. Satellite
subscriptions cannot attach automatically to content hosts in Satellite because they are not associated
with any product certificates. Adding a Satellite subscription to a content host does not provide any

content or repository access. If you want, you can add a Satellite subscription to a manifest for your own
recording or tracking purposes.

Prerequisite

® You must have a Red Hat Subscription Manifest file imported to Satellite Server.

Procedure

1. In the Satellite web Ul, ensure the context is set to the organization you want to use.
2. In the Satellite web Ul, navigate to Hosts > Content Hosts.

3. On the row of each content host whose subscription you want to change, select the
corresponding checkbox.

4. From the Select Action list, select Manage Subscriptions.

5. Optionally, enter a key and value in the Search field to filter the subscriptions displayed.
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6. Select the checkbox to the left of the subscriptions that you want to add or remove and click
Add Selected or Remove Selected as required.

7. Click Done to save the changes.

CLI procedure

1. Connect to Satellite Server as the root user, and then list the available subscriptions:

# hammer subscription list \
--organization-id 1

2. Attach a subscription to the host:

# hammer host subscription attach \
--host host_name\
--subscription-id subscription_id

5.7. UPDATING RED HAT SUBSCRIPTIONS ON MULTIPLE HOSTS

Use this procedure for post-installation changes to multiple content hosts at the same time.

Procedure

1. In the Satellite web Ul, ensure the context is set to the organization you want to use.
2. In the Satellite web Ul, navigate to Hosts > Content Hosts.

3. On the row of each content host whose subscription you want to change, select the
corresponding checkbox.

4. From the Select Action list, select Manage Subscriptions.
5. Optionally, enter a key and value in the Search field to filter the subscriptions displayed.

6. Select the checkbox to the left of the subscriptions to be added or removed and click Add
Selected or Remove Selected as required.

7. Click Done to save the changes.
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CHAPTER 6. IMPORTING CONTENT

This chapter outlines how you can import different types of custom content to Satellite. If you want to
import RPMs, Files, or different content types to Satellite, it is done with largely the same procedures in
this chapter.

For example, you can use the following chapters for information on specific types of custom content but
the underlying procedures are the same:

® Chapter 13, Managing ISO Images

® Chapter 14, Managing Custom File Type Content

6.1. USING PRODUCTS AND REPOSITORIES IN SATELLITE
Both Red Hat content and custom content in Satellite have similarities:

® The relationship between a product and its repositories is the same and the repositories still
require synchronization.

e custom products require a subscription for clients to access, similar to subscriptions to Red Hat
Products. Satellite creates a subscription for each custom product you create.

Red Hat Content is already organized into Products. For example, Red Hat Enterprise Linux Server is a
Product in Satellite. The repositories for that Product consist of different versions, architectures, and
add-ons. For Red Hat repositories, products are created automatically after enabling the repository. For
more information, see Section 6.5, "Enabling Red Hat Repositories”.

Other custom content can be organized into Products however you want. For example, you might create
an EPEL (Extra Packages for Enterprise Linux) product and add an "EPEL 7 x86_64" repository to it.

For more information about creating and packaging RPMs, see the RPM Packaging Guide in the
Red Hat Enterprise Linux documentation.

6.2. IMPORTING CUSTOM SSL CERTIFICATES

Before you synchronize custom content from an external source, you might need to import SSL
certificates into your custom product. This might include client certs and keys or CA certificates for the
upstream repositories you want to synchronize.

If you require SSL certificates and keys to download RPMs, you can add them to Satellite.

To use the CLI instead of the Satellite web Ul, see the CLI procedure.

Procedure

1. In the Satellite web Ul, navigate to Content > Content Credentials. In the Content Credentials
window, click Create Content Credential.

2. In the Name field, enter a name for your SSL certificate.
3. From the Type list, select SSL Certificate.

4. In the Content Credentials Content field, paste your SSL certificate, or click Browse to upload
your SSL certificate.
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5. Click Save.

CLI procedure

1. Copy the SSL certificate to your Satellite Server:
I $ scp My _SSL_Certificate root@satellite.example.com:~/.

Or download the SSL certificate to your Satellite Server from an online source:
I $ wget -P ~ http://upstream-satellite.example.com/pub/katello-server-ca.crt

2. Upload the SSL Certificate to Satellite:

# hammer content-credential create \
--content-type cert \
--name "My _SSL_Certificate" \
--organization "My _Organization" \
--path ~/My_SSL_Certificate

6.3. CREATING A CUSTOM PRODUCT

Use this procedure to create a custom product that you can then add repositories to. To use the CLI
instead of the Satellite web Ul, see the CLI procedure.

Procedure

1. In the Satellite web Ul, navigate to Content > Products, click Create Product.

2. Inthe Name field, enter a name for the product. Satellite automatically completes the Label
field based on what you have entered for Name.

3. Optional: From the GPG Key list, select the GPG key for the product.

4. Optional: From the SSL CA Cert list, select the SSL CA certificate for the product.

5. Optional: From the SSL Client Certlist, select the SSL client certificate for the product.
6. Optional: From the SSL Client Key list, select the SSL client key for the product.

7. Optional: From the Sync Plan list, select an existing sync plan or click Create Sync Planand
create a sync plan for your product requirements.

8. In the Description field, enter a description of the product.
9. Click Save.
CLI procedure

To create the product, enter the following command:

# hammer product create \
--name "My _Product" \
--sync-plan "Example Plan" \
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--description "Content from My Repositories" \
--organization "My _Organization"

6.4. ADDING CUSTOM RPM REPOSITORIES

Use this procedure to add custom RPM repositories in Satellite. To use the CLI instead of the Satellite
web Ul, see the CLI procedure.

The Products window in the Satellite web Ul also provides a Repo Discovery function that finds all
repositories from a URL and you can select which ones to add to your custom product. For example, you
can use the Repo Discovery to search http://yum.postgresql.org/9.5/redhat/ and list all repositories
for different Red Hat Enterprise Linux versions and architectures. This helps users save time importing
multiple repositories from a single source.

Support for Custom RPMs

Red Hat does not support the upstream RPMs directly from third-party sites. These RPMs are used to
demonstrate the synchronization process. For any issues with these RPMs, contact the third-party
developers.

Procedure

1. In the Satellite web Ul, navigate to Content > Products and select the product that you want to
use, and then click New Repository.

2. Inthe Name field, enter a name for the repository. Satellite automatically completes the Label
field based on what you have entered for Name.

3. Optional: In the Description field, enter a description for the repository.
4. From the Type list, select yum as type of repository.

5. Optional: From the Restrict to Architecturelist, select an architecture. If you want to make the
repository available to all hosts regardless of the architecture, ensure to select No restriction.

6. Optional: From the Restrict to OS Versionlist, select the OS version. If you want to make the
repository available to all hosts regardless of the OS version, ensure to select No restriction.

7. Optional: In the Upstream URL field, enter the URL of the external repository to use as a
source. Satellite supports three protocols: http:/, https://, and file://. If you are using a file://
repository, you have to place it under /var/lib/pulp/sync_imports/ directory.

If you do not enter an upstream URL, you can manually upload packages.

8. Optional: Check the Ignore SRPMs checkbox to exclude source RPM packages from being
synchronized to Satellite.

9. Select the Verify SSL checkbox if you want to verify that the upstream repository’s SSL
certificates are signed by a trusted CA.

10. Optional: In the Upstream Username field, enter the user name for the upstream repository if
required for authentication. Clear this field if the repository does not require authentication.

1. Optional: In the Upstream Password field, enter the corresponding password for the upstream
repository. Clear this field if the repository does not require authentication.
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12.

13.

14.

15.

16.

17.

18.

19.

20.

21.

22.

23.

Optional: In the Upstream Authentication Token field, provide the token of the upstream
repository user for authentication. Leave this field empty if the repository does not require
authentication.

From the Download Policy list, select the type of synchronization Satellite Server performs. For
more information, see Section 6.7, "Download Policies Overview".

From the Mirroring Policy list, select the type of content synchronization Satellite Server
performs. For more information, see Section 6.10, “Mirroring Policies Overview”.

Optional: In the Retain package versionsfield, enter the number of versions you want to retain
per package.

Optional: In the HTTP Proxy Policy field, select an HTTP proxy.
From the Checksum list, select the checksum type for the repository.

Optional: You can clear the Unprotected checkbox to require a subscription entitlement
certificate for accessing this repository. By default, the repository is published through HTTP.

Optional: From the GPG Key list, select the GPG key for the product.

Optional: In the SSL CA Cert field, select the SSL CA Certificate for the repository.
Optional: In the SSL Client cert field, select the SSL Client Certificate for the repository.
Optional: In the SSL Client Key field, select the SSL Client Key for the repository.

Click Save to create the repository.

CLI procedure

1.

Enter the following command to create the repository:

# hammer repository create \
--arch "My _Architecture" \
--content-type "yum" \
--gpg-key-id My _GPG_Key ID\
--name "My _Repository" \
--organization "My _Organization" \
--o0s-version "My_OS_Version"\
--product "My_Product" \
--publish-via-http true \

--url My_Upstream_URL

Continue to synchronize the repository.

6.5. ENABLING RED HAT REPOSITORIES

If outside network access requires usage of an HTTP Proxy, configure a default HTTP Proxy for your
server. See Adding a default HTTP Proxy

To select the repositories to synchronize, you must first identify the product that contains the
repository, and then enable that repository based on the relevant release version and base architecture.
For Red Hat Enterprise Linux 8, you must enable both AppStream and BaseOS repositories.

22


https://access.redhat.com/documentation/en-us/red_hat_satellite/6.11/html-single/installing_satellite_server_in_a_connected_network_environment/index#adding-a-default-http-proxy_satellite

CHAPTER 6. IMPORTING CONTENT

Repository Versioning

The difference between associating Red Hat Enterprise Linux operating system with either 7 Server
repositories or 7.X repositories is that 7 Server repositories contain all the latest updates while Red Hat
Enterprise Linux 7.X repositories stop getting updates after the next minor version release. Note that
Kickstart repositories only have minor versions.

For Red Hat Enterprise Linux 8 Clients

To provision Red Hat Enterprise Linux 8 clients, you require the Red Hat Enterprise Linux 8 for x86_64
- AppStream (RPMS) and Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs)repositories.

For Red Hat Enterprise Linux 7 Clients

To provision Red Hat Enterprise Linux 7 clients, you require the Red Hat Enterprise Linux 7 Server
(RPMs) repository.

Procedure

1. In the Satellite web Ul, navigate to Content > Red Hat Repositories.

2. To find repositories, either enter the repository name, or toggle the Recommended
Repositories button to the on position to view a list of repositories that you require.

3. In the Available Repositories pane, click a repository to expand the repository set.

4. Click the Enable icon next to the base architecture and release version that you want.
CLI procedure
1. To search for your product, enter the following command:

I # hammer product list --organization "My _Organization"

2. List the repository set for the product:

# hammer repository-set list \
--product "Red Hat Enterprise Linux Server" \
--organization "My _Organization"

3. Enable the repository using either the name or ID number. Include the release version, for
example,7Server and base architecture, for example, x86_64. For example:

# hammer repository-set enable \

--name "Red Hat Enterprise Linux 7 Server (RPMs)" \
--releasever "7Server" \

--basearch "x86_64"\

--product "Red Hat Enterprise Linux Server" \
--organization "My _Organization"

6.6. SYNCHRONIZING REPOSITORIES

Procedure
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1. In the Satellite web Ul, navigate to Content > Products and select the product that contains

the repositories that you want to synchronize.

2. Select the repositories that you want to synchronize and click Sync Now.

To view the progress of the synchronization in the Satellite web Ul, navigate to Content > Sync Status
and expand the corresponding product or repository tree.

CLI procedure

® Synchronize an entire Product:

# hammer product synchronize \
--name "My _Product" \
--organization "My _Organization"

® Synchronize an individual repository:

# hammer repository synchronize \
--name "My _Repository" \
--organization "My _Organization" \
--product "My Product"

The synchronization duration depends on the size of each repository and the speed of your network
connection. The following table provides estimates of how long it would take to synchronize content,
depending on the available Internet bandwidth:

256 Kbps

512 Kbps

T1(1.5 Mbps)

10 Mbps

100 Mbps

1000 Mbps

Single Package (10Mb)

5 Mins 27 Secs

2 Mins 43.84 Secs

54.33 Secs

8.39 Secs

0.84 Secs

0.08 Secs

Minor Release (750Mb)

6 Hrs 49 Mins 36 Secs

3 Hrs 24 Mins 48 Secs

1Hr 7 Mins 54.78 Secs

10 Mins 29.15 Secs

1Min 2.91Secs

6.29 Secs

Major Release (6Gb)

2 Days 7 Hrs 55 Mins

1Day 3 Hrs 57 Mins

9 Hrs 16 Mins 20.57
Secs

1Hr 25 Mins 53.96 Secs

8 Mins 35.4 Secs

51.54 Secs

Create a sync plan to ensure updates on a regular basis. See Section 6.18, “Creating a Sync Plan”.

6.6.1. Synchronizing All Repositories in an Organization

Use this procedure to synchronize all repositories within an organization.

Procedure

To synchronize all repositories within an organization, run the following Bash script on your

Satellite Server:
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ORG="My_Organization"

for i in $(hammer --no-headers --csv repository list --organization $ORG | awk -F, {'print $1'})
do

hammer repository synchronize --id ${i} --organization $ORG --async
done

6.7. DOWNLOAD POLICIES OVERVIEW

Red Hat Satellite provides multiple download policies for synchronizing RPM content. For example, you
might want to download only the content metadata while deferring the actual content download for
later.

Satellite Server has the following policies:

Immediate
Satellite Server downloads all metadata and packages during synchronization.
On Demand

Satellite Server downloads only the metadata during synchronization. Satellite Server only fetches
and stores packages on the file system when Capsules or directly connected clients request them.
This setting has no effect if you set a corresponding repository on a Capsule to Immediate because
Satellite Server is forced to download all the packages.

The On Demand policy acts as a Lazy Synchronization feature because they save time synchronizing
content. The lazy synchronization feature must be used only for yum repositories. You can add the
packages to Content Views and promote to life cycle environments as normal.

Capsule Server has the following policies:

Immediate

Capsule Server downloads all metadata and packages during synchronization. Do not use this setting
if the corresponding repository on Satellite Server is set to On Demand as Satellite Server is forced
to download all the packages.

On Demand

Capsule Server only downloads the metadata during synchronization. Capsule Server fetches and
stores packages only on the file system when directly connected clients request them. When you use
an On Demand download policy, content is downloaded from Satellite Server if it is not available on
Capsule Server.

Inherit

Capsule Server inherits the download policy for the repository from the corresponding repository on
Satellite Server.

6.8. CHANGING THE DEFAULT DOWNLOAD POLICY

You can set the default download policy that Satellite applies to repositories that you create in all
organizations.

Depending on whether it is a Red Hat or non-Red Hat custom repository, Satellite uses separate
settings. Changing the default value does not change existing settings.

Procedure
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1. In the Satellite web Ul, navigate to Administer > Settings.
2. Click the Content tab.

3. Change the default download policy depending on your requirements:

® To change the default download policy for a Red Hat repository, change the value of the
Default Red Hat Repository download policysetting.

® To change the default download policy for a custom repository, change the value of the
Default Custom Repository download policysetting.

CLI procedure

® To change the default download policy for Red Hat repositories to one of immediate or
on_demand, enter the following command:

# hammer settings set \
--name default_redhat_download_policy \
--value immediate

® To change the default download policy for a non-Red Hat custom repository to one of
immediate or on_demand, enter the following command:

# hammer settings set \
--name default_download_policy \
--value immediate

6.9. CHANGING THE DOWNLOAD POLICY FOR A REPOSITORY

You can set the download policy for a repository.

Procedure

1. In the Satellite web Ul, navigate to Content > Products.
2. Select the required product name.

3. On the Repositories tab, click the required repository name, locate the Download Policy field,
and click the edit icon.

4. From the list, select the required download policy and then click Save.
CLI procedure

1. List the repositories for an organization:

# hammer repository list \
--organization-label My Organization_Label

2. Change the download policy for a repository to immediate or on_demand:

# hammer repository update \
--download-policy immediate \
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--name "My _Repository" \
--organization-label My_Organization_Label\
--product "My_Product"

6.10. MIRRORING POLICIES OVERVIEW

Mirroring keeps the local repository exactly in synchronization with the upstream repository. If any
content is removed from the upstream repository since the last synchronization, with the next
synchronization, it will be removed from the local repository as well.

You can use mirroring policies for finer control over mirroring of repodata and content when
synchronizing a repository. For example, if it is not possible to mirror the repodata for a repository, you
can set the mirroring policy to mirror only content for this repository.

Satellite Server has the following mirroring policies:

Additive

Neither the content nor the repodata is mirrored. Thus, only new content added since the last
synchronization is added to the local repository and nothing is removed.

Content Only

Mirrors only content and not the repodata. Some repositories do not support metadata mirroring, in
such cases you can set the mirroring policy to content only to only mirror the content.

Complete Mirroring

Mirrors content as well as repodata. This is the fastest method. This mirroring policy is only available
for Yum content.

6.1. CHANGING THE MIRRORING POLICY FOR A REPOSITORY

You can set the mirroring policy for a repository.

Procedure

1. In the Satellite web Ul, navigate to Content > Products.
2. Select the product name.

3. On the Repositories tab, click the repository name, locate the Mirroring Policy field, and click
the edit icon.

4. From the list, select a mirroring policy and click Save.

6.12. UPLOADING CONTENT TO CUSTOM RPM REPOSITORIES

You can upload individual RPMs and source RPMs to custom RPM repositories. You can upload RPMs
using the Satellite web Ul or the Hammer CLI. You must use the Hammer CLI to upload source RPMs.

Procedure

1. In the Satellite web UlI, click Content > Products.

2. Click the name of the custom product.
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3.

4.

5.

In the Repositories tab, click the name of the custom RPM repository.
Under Upload Package, click Browse... and select the RPM you want to upload.

Click Upload.

To view all RPMs in this repository, click the number next to Packages under Content Counts.

CLI procedure

Enter the following command to upload an RPM:

# hammer repository upload-content \
--id Repository ID\
--path /path/to/example-package.rpm

Enter the following command to upload a source RPM:

# hammer repository upload-content \
--content-type srpm \

--id Repository ID \

--path /path/to/example-package.src.rpm

When the upload is complete, you can view information about a source RPM by using the
commands hammer srpm list and hammer srpm info --id srpom_ID.

6.13. CONFIGURING SELINUX TO PERMIT CONTENT
SYNCHRONIZATION ON CUSTOM PORTS

SELinux permits access of Satellite for content synchronization only on specific ports. By default,
connecting to web servers running on the following ports is permitted: 80, 81, 443, 488, 8008, 8009,
8443, and 9000.

Procedure

1.

On Satellite, to verify the ports that are permitted by SELinux for content synchronization, enter
a command as follows:

# semanage port - | grep *http_port_t
http_port_t tcp 80, 81, 443, 488, 8008, 8009, 8443, 9000

To configure SELinux to permit a port for content synchronization, for example 10011, enter a
command as follows:

I # semanage port -a -t http_port_t -p tcp 10011

6.14. RECOVERING A CORRUPTED REPOSITORY

In case of repository corruption, you can recover it by using an advanced synchronization, which has
three options:

Optimized Sync
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Synchronizes the repository bypassing RPMs that have no detected differences from the upstream
RPMs,

Complete Sync

Synchronizes all RPMs regardless of detected changes. Use this option if specific RPMs could not be
downloaded to the local repository even though they exist in the upstream repository.

Verify Content Checksum

Synchronizes all RPMs and then verifies the checksum of all RPMs locally. If the checksum of an RPM
differs from the upstream, it re-downloads the RPM. This option is relevant only for yum
repositories. Use this option if you have one of the following errors:

® Specific RPMs cause a 404 error while synchronizing with yum.

e Package does not match intended download error, which means that specific RPMs are
corrupted.

Procedure

1. In the Satellite web Ul, navigate to Content > Products.
2. Select the product containing the corrupted repository.
3. Select the name of a repository you want to synchronize.

4. To perform optimized sync or complete sync, select Advanced Sync from the Select Action
menu.

5. Select the required option and click Sync.

6. Optional: To verify the checksum, click Verify Content Checksum from the Select Action
menu.

CLI procedure

1. Obtain a list of repository IDs:

# hammer repository list \
--organization "My _Organization"

2. Synchronize a corrupted repository using the necessary option:

® For the optimized synchronization:

# hammer repository synchronize \
--id My_ID

® Forthe complete synchronization:

# hammer repository synchronize \
--id My_ID\
--skip-metadata-check true

® For the validate content synchronization:
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# hammer repository synchronize \
--id My_ID\
--validate-contents true

6.15. ADDING AN HTTP PROXY

Use this procedure to add HTTP proxies to Satellite. You can then specify which HTTP proxy to use for
Products, repositories, and supported compute resources.

Prerequisites

Your HTTP proxy must allow access to the following hosts:

Host name Port Protocol
subscription.rhsm.redhat.com 443 HTTPS
cdn.redhat.com 443 HTTPS
*.akamaiedge.net 443 HTTPS
cert.console.redhat.com (if using Red Hat Insights) 443 HTTPS
api.access.redhat.com (if using Red Hat Insights) 443 HTTPS
cert-api.access.redhat.com (if using Red Hat 443 HTTPS
Insights)

If Satellite Server uses a proxy to communicate with subscription.rhsm.redhat.com and cdn.redhat.com
then the proxy must not perform SSL inspection on these communications.

To use the CLlI instead of the Satellite web Ul, see the CLI procedure.

Procedure

1. In the Satellite web Ul, navigate to Infrastructure > HTTP Proxies and select New HTTP
Proxy.

2. Inthe Name field, enter a name for the HTTP proxy.
3. Inthe URL field, enter the URL for the HTTP proxy, including the port number.
4. If your HTTP proxy requires authentication, enter a Username and Password.

5. Optional: In the Test URL field, enter the HTTP proxy URL, then click Test Connection to
ensure that you can connect to the HTTP proxy from Satellite.

6. Click the Locations tab and add a location.
7. Click the Organization tab and add an organization.

8. Click Submit.
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CLI procedure

® On Satellite Server, enter the following command to add an HTTP proxy:

# hammer http-proxy create --name proxy-name\
--url proxy-URL:port-number

If your HTTP proxy requires authentication, add the --username name and --password
password options.

For further information, see the Knowledgebase article How to access Red Hat Subscription Manager
(RHSM) through a firewall or proxy on the Red Hat Customer Portal.

6.16. CHANGING THE HTTP PROXY POLICY FOR A PRODUCT

For granular control over network traffic, you can set an HTTP proxy policy for each Product. A
Product’'s HTTP proxy policy applies to all repositories in the Product, unless you set a different policy
for individual repositories.

To set an HTTP proxy policy for individual repositories, see Section 6.17, “Changing the HTTP Proxy
Policy for a Repository”.

Procedure

1. In the Satellite web Ul, navigate to Content > Products and select the checkbox next to each of
the Products that you want to change.

2. From the Select Action list, select Manage HTTP Proxy.

3. Select an HTTP Proxy Policy from the list:

® Global Default: Use the global default proxy setting.

® No HTTP Proxy: Do not use an HTTP proxy, even if a global default proxy is configured.

® Use specific HTTP Proxy: Select an HTTP Proxy from the list. You must add HTTP proxies
to Satellite before you can select a proxy from this list. For more information, see

Section 6.15, “Adding an HTTP Proxy”.

4. Click Update.

6.17. CHANGING THE HTTP PROXY POLICY FOR A REPOSITORY

For granular control over network traffic, you can set an HTTP proxy policy for each repository. To use
the CLl instead of the Satellite web Ul, see the CLI procedure.

To set the same HTTP proxy policy for all repositories in a Product, see Section 6.16, “Changing the
HTTP Proxy Policy for a Product”.

Procedure

1. In the Satellite web Ul, navigate to Content > Products and click the name of the Product that
contains the repository.

2. In the Repositories tab, click the name of the repository.
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3. Locate the HTTP Proxy field and click the edit icon.

4. Select an HTTP Proxy Policy from the list:

® Global Default: Use the global default proxy setting.

® No HTTP Proxy: Do not use an HTTP proxy, even if a global default proxy is configured.

® Use specific HTTP Proxy: Select an HTTP Proxy from the list. You must add HTTP proxies
to Satellite before you can select a proxy from this list. For more information, see

Section 6.15, “Adding an HTTP Proxy”.

5. Click Save.

CLI procedure

® On Satellite Server, enter the following command, specifying the HTTP proxy policy you want to
use:

# hammer repository update --id repository-1D \
--http-proxy-policy policy

Specify one of the following options for --http-proxy-policy:
o none: Do not use an HTTP proxy, even if a global default proxy is configured.
o global_default_http_proxy: Use the global default proxy setting.
o use_selected_http_proxy: Specify an HTTP proxy using either --http-proxy proxy-name

or --http-proxy-id proxy-ID. To add a new HTTP proxy to Satellite, see Section 6.15,
“Adding an HTTP Proxy”.

6.18. CREATING ASYNC PLAN

A sync plan checks and updates the content at a scheduled date and time. In Satellite, you can create a
sync plan and assign products to the plan.

To use the CLI instead of the Satellite web Ul, see the CLI procedure.

Procedure

1. In the Satellite web Ul, navigate to Content > Sync Plans and click New Sync Plan.

2. Inthe Name field, enter a name for the plan.

3. Optional: In the Description field, enter a description of the plan.

4. From the Interval list, select the interval at which you want the plan to run.

5. From the Start Date and Start Time lists, select when to start running the synchronization plan.

6. Click Save.

CLI procedure

1. To create the synchronization plan, enter the following command:
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# hammer sync-plan create \

--name "Red Hat Products 2"\

--description "Example Plan for Red Hat Products" \
--interval daily \

--sync-date "2016-02-01 01:00:00" \

--enabled true \

--organization "My _Organization"

2. View the available sync plans for an organization to verify that the sync plan has been created:

I # hammer sync-plan list --organization "Default Organization"

6.19. ASSIGNING ASYNC PLAN TO A PRODUCT

A sync plan checks and updates the content at a scheduled date and time. In Satellite, you can assign a
sync plan to products to update content regularly.

To use the CLI instead of the Satellite web Ul, see the CLI| procedure.

Procedure

1. In the Satellite web Ul, navigate to Content > Products.
2. Select a product.

3. On the Details tab, select a Sync Plan from the drop down menu.

CLI procedure

1. Assign a sync plan to a product:

# hammer product set-sync-plan \
--name "Product_Name" \
--sync-plan "Sync_Plan_Name" \
--organization "My _Organization"

6.20. ASSIGNING ASYNC PLAN TO MULTIPLE PRODUCTS

Use this procedure to assign a sync plan to the products in an organization that have been synchronized
at least once and contain at least one repository.

Procedure

1. Run the following Bash script:

ORG="Your_Organization"
SYNC_PLAN="daily_sync_at 3_a.m"

hammer sync-plan create --name $SYNC_PLAN --interval daily --sync-date "2023-04-5
03:00:00" --enabled true --organization $ORG

for i in $(hammer --no-headers --csv --csv-separator="|" product list --organization $ORG --
per-page 999 | grep -vi not_synced | awk -F'[' '$5 |="0" { print $1}')
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do
hammer product set-sync-plan --sync-plan $SYNC_PLAN --organization $ORG --id $i
done

2. After executing the script, view the products assigned to the sync plan:

I # hammer product list --organization $ORG --sync-plan $SYNC_PLAN

6.21. LIMITING SYNCHRONIZATION CONCURRENCY

By default, each Repository Synchronization job can fetch up to ten files at a time. This can be adjusted
on a per repository basis.

Increasing the limit may improve performance, but can cause the upstream server to be overloaded or
start rejecting requests. If you are seeing Repository syncs fail due to the upstream servers rejecting

requests, you may want to try lowering the limit.

CLI procedure

# hammer repository update \
--download-concurrency 5\

--id Repository ID\
--organization "My _Organization"

6.22. IMPORTING A CUSTOM GPG KEY
When clients are consuming signed custom content, ensure that the clients are configured to validate
the installation of packages with the appropriate GPG Key. This helps to ensure that only packages from

authorized sources can be installed.

Red Hat content is already configured with the appropriate GPG key and thus GPG Key management of
Red Hat Repositories is not supported.

To use the CLI instead of the Satellite web Ul, see the CLI procedure.

Prerequisites

Ensure that you have a copy of the GPG key used to sign the RPM content that you want to use and
manage in Satellite. Most RPM distribution providers provide their GPG Key on their website. You can
also extract this manually from an RPM:

1. Download a copy of the version specific repository package to your client system:
I $ wget htto.//www.example.com/9.5/example-9.5-2.noarch.rpom
2. Extract the RPM file without installing it:
I $ rpm2cpio example-9.5-2.noarch.rpm | cpio -idmv
The GPG key is located relative to the extraction at etc/pki/rpm-gpg/RPM-GPG-KEY-EXAMPLE-95.

Procedure
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he Satellite web Ul, navigate to Content > Content Credentials and in the upper-right of
window, click Create Content Credential

2. Enter the name of your repository and select GPG Key from the Type list.

3. Either paste the GPG key into the Content Credential Contents field, or click Browse and
select the GPG key file that you want to import.
If your custom repository contains content signed by multiple GPG keys, you must enter all
required GPG keys in the Content Credential Contents field with new lines between each key,

for

example:

mQINBFy/HE4BEADttv2TCPzVrre+aJ9f5QsR60WZMm7N5Lwxjm5x5zA9BLIPPGFN
4aTUR/g+K1S0aqCU+ZS3Rnxb+6fnBxD+COHIKMgXHi3M5UNzbp5SWhCdUpISXjipU
XIFFWBPuBfyr/FKRknFH15P+9kLZLxCpVZZLsweL WCuw+JKCMmnA

—F6VG

mQINBFw467UBEACMREzDeK/kuScCmfJfHJaOWgh/2fbJLLt3KSvsgDhORIptf+PP
OTFDIKuLkJx99ZYG5xMnBG47C7ByoMec1j94YeXczuBbynOyyPlvduma/zf8oB9e
WI5GnzcLGAnUSRamfqGUWcyMMinHHIKIc1X1P4l=

=WPpl

4. Click Save.

CLI procedure

1. Co

py the GPG key to your Satellite Server:

$ scp ~/etc/pki/rpm-gpg/RPM-GPG-KEY-EXAMPLE-95 root@satellite.example.com:~/.

2. Upload the GPG key to Satellite:

# hammer content-credentials create \
--content-type gpg_key \

--name "My _GPG_Key"\
--organization "My _Organization" \
--path ~/RPM-GPG-KEY-EXAMPLE-95

6.23. RESTRICTING CUSTOM REPOSITORIES TO RHEL 9 IN SATELLITE

Procedure

1. In the Satellite web Ul, navigate to Content > Products.

2. Select the product that contains the repository sets that you want to restrict.

3. Inthe Repositories tab, click the repository that you want to restrict.
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4. From the Restrict to OSllist, select the operating system to include Red Hat Enterprise Linux
operating systems for their corresponding Red Hat Enterprise Linux repositories.

5. Click Save to submit your change.
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CHAPTER 7. MANAGING APPLICATION LIFE CYCLES

This chapter outlines the application life cycle in Satellite and how to create and remove application life
cycles for Satellite and Capsule.

7.1. INTRODUCTION TO APPLICATION LIFE CYCLE

The application life cycle is a concept central to Satellite’s content management functions. The
application life cycle defines how a particular system and its software look at a particular stage. For
example, an application life cycle might be simple; you might only have a development stage and
production stage. In this case the application life cycle might look like this:

® Development
® Production

However, a more complex application life cycle might have further stages, such as a phase for testing or
a beta release. This adds extra stages to the application life cycle:

® Development
® Testing

® Beta Release
® Production

Satellite provides methods to customize each application life cycle stage so that it suits your
specifications.

Each stage in the application life cycle is called an environment in Satellite. Each environment uses a
specific collection of content. Satellite defines these content collections as a Content View. Each
Content View acts as a filter where you can define what repositories, and packages to include in a
particular environment. This provides a method for you to define specific sets of content to designate to
each environment.

For example, an email server might only require a simple application life cycle where you have a
production-level server for real-world use and a test server for trying out the latest mail server
packages. When the test server passes the initial phase, you can set the production-level server to use
the new packages.

Another example is a development life cycle for a software product. To develop a new piece of software

in a development environment, test it in a quality assurance environment, pre-release as a beta, then
release the software as a production-level application.
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Figure 7.1. The Satellite Application Life Cycle
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7.2. PROMOTING CONTENT ACROSS THE APPLICATION LIFE CYCLE

In the application life cycle chain, when content moves from one environment to the next, this is called
promotion.

Example Content Promotion Across Satellite Life Cycle Environments

Each environment contains a set of systems registered to Red Hat Satellite. These systems only have
access to repositories relevant to their environment. When you promote packages from one
environment to the next, the target environment’s repositories receive new package versions. As a
result, each system in the target environment can update to the new package versions.

Development Testing Production
example_software-1.1- example_software-1.0- example_software-1.0-
O.noarch.rpm O.noarch.rpm O.noarch.rpm

After completing development on the patch, you promote the package to the Testing environment so
the Quality Engineering team can review the patch. The application life cycle then contains the following
package versions in each environment:

Development Testing Production

example_software-1.1- example_software-1.1- example_software-1.0-
O.noarch.rpm O.noarch.rpm O.noarch.rpm

While the Quality Engineering team reviews the patch, the Development team starts work on
example_software 2.0. This results in the following application life cycle:
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Development Testing Production

exampleware-2.0-0.noarch.rpm exampleware-1.1-0.noarch.rpm exampleware-1.0-0.noarch.rpm

The Quality Engineering team completes their review of the patch. Now example_software 1.1is ready to
release. You promote 1.1 to the Production environment:

Development Testing Production
example_software-2.0- example_software-1.1- example_software-1.1-
O.noarch.rpm O.noarch.rpm O.noarch.rpm

The Development team completes their work on example_software 2.0 and promotes it to the Testing
environment:

Development Testing Production
example_software-2.0- example_software-2.0- example_software-1.1-
O.noarch.rpm O.noarch.rpm O.noarch.rpm

Finally, the Quality Engineering team reviews the package. After a successful review, promote the
package to the Production environment:

Development Testing Production

exampleware-2.0-0.noarch.rpm exampleware-2.0-0.noarch.rpm exampleware-2.0-0.noarch.rpm

For more information, see Section 8.3, “Promoting a Content View".

7.3. CREATING A LIFE CYCLE ENVIRONMENT PATH
To create an application life cycle for developing and releasing software, use the Library environment as

the initial environment to create environment paths. Then optionally add additional environments to the
environment paths.

Procedure
1. In the Satellite web Ul, navigate to Content > Lifecycle Environments.
2. Click New Environment Pathto start a new application life cycle.
3. Inthe Name field, enter a name for your environment.
4. In the Description field, enter a description for your environment.

5. Click Save.

W
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6. Optional: To add an environment to the environment path, click Add New Environment,
complete the Name and Description fields, and select the prior environment from the Prior
Environment list.

CLI procedure

1. To create an environment path, enter the hammer lifecycle-environment create command
and specify the Library environment with the --prior option:

# hammer lifecycle-environment create \
--name "Environment Path Name" \
--description "Environment Path Description" \
--prior "Library" \

--organization "My _Organization"

2. Optional: To add an environment to the environment path, enter the hammer lifecycle-
environment create command and specify the parent environment with the --prior option:

# hammer lifecycle-environment create \
--name "Environment Name" \
--description "Environment Description" \
--prior "Prior Environment Name" \
--organization "My _Organization"

3. To view the chain of the life cycle environment, enter the following command:
I # hammer lifecycle-environment paths --organization "My _Organization"

7.4. REMOVING LIFE CYCLE ENVIRONMENTS FROM
SATELLITE SERVER

Use this procedure to remove a life cycle environment.

Procedure

1. In the Satellite web Ul, navigate to Content > Life Cycle Environments.

2. Click the name of the life cycle environment that you want to remove, and then click Remove
Environment.

3. Click Remove to remove the environment.

CLI procedure

1. List the life cycle environments for your organization and note the name of the life cycle
environment you want to remove:

# hammer lifecycle-environment list \
--organization "My _Organization"

2. Use the hammer lifecycle-environment delete command to remove an environment:
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# hammer lifecycle-environment delete \
--name "My _Environment" \
--organization "My _Organization"

7.5. REMOVING LIFE CYCLE ENVIRONMENTS FROM
CAPSULE SERVER

When life cycle environments are no longer relevant to the host system or environments are added
incorrectly to Capsule Server, you can remove the life cycle environments from Capsule Server.

You can use both the Satellite web Ul and the Hammer CLI to remove life cycle environments from
Capsule.

Procedure

1. In the Satellite web Ul, navigate to Infrastructure > Capsules, and select the Capsule that you
want to remove a life cycle from.

2. Click Edit and click the Life Cycle Environments tab.

3. From the right menu, select the life cycle environments that you want to remove from Capsule,
and then click Submit.

4. To synchronize Capsule’s content, click the Overview tab, and then click Synchronize.

5. Select either Optimized Sync or Complete Sync.
CLI procedure
1. Select Capsule Server that you want from the list and take note of its id:

I # hammer capsule list

2. To verify Capsule Server's details, enter the following command:

# hammer capsule info \
--id Capsule_ID

3. Verify the list of life cycle environments currently attached to Capsule Server and take note of
the Environment ID:

# hammer capsule content lifecycle-environments \
--id Capsule_ID

4. Remove the life cycle environment from Capsule Server:

# hammer capsule content remove-lifecycle-environment \
--id Capsule_ID
--lifecycle-environment-id Lifecycle Environment_ID

Repeat this step for every life cycle environment that you want to remove from Capsule Server.

5. Synchronize the content from Satellite Server’s environment to Capsule Server:

41



Red Hat Satellite 6.11 Managing Content

# hammer capsule content synchronize \
--id Capsule_ID

7.6. ADDING LIFE CYCLE ENVIRONMENTS TO CAPSULE SERVERS

If your Capsule Server has the content functionality enabled, you must add an environment so that
Capsule can synchronize content from Satellite Server and provide content to host systems.

Do not assign the Library lifecycle environment to your Capsule Server because it triggers an automated
Capsule sync every time the CDN updates a repository. This might consume multiple system resources
on Capsules, network bandwidth between Satellite and Capsules, and available disk space on Capsules.

You can use Hammer CLI| on Satellite Server or the Satellite web UI.

Procedure

1.

In the Satellite web Ul, navigate to Infrastructure > Capsules, and select the Capsule that you
want to add a life cycle to.

Click Edit and click the Life Cycle Environments tab.

From the left menu, select the life cycle environments that you want to add to Capsule and click
Submit.

To synchronize the content on the Capsule, click the Overview tab and click Synchronize.

Select either Optimized Sync or Complete Sync.
For definitions of each synchronization type, see Recovering a Repository.

CLI procedure

1.
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To display a list of all Capsule Servers, on Satellite Server, enter the following command:
I # hammer capsule list

Note the Capsule ID of the Capsule that you want to add a life cycle to.

Using the ID, verify the details of your Capsule:

I # hammer capsule info --id capsule_id

To view the life cycle environments available for your Capsule Server, enter the following
command and note the ID and the organization name:

I # hammer capsule content available-lifecycle-environments --id capsule_id
Add the life cycle environment to your Capsule Server:

# hammer capsule content add-lifecycle-environment \

--id capsule_id --organization "My _Organization" \

--lifecycle-environment-id lifecycle-environment _id

Repeat for each life cycle environment you want to add to Capsule Server.


https://access.redhat.com/documentation/en-us/red_hat_satellite/6.11/html-single/managing_content/index#Recovering_a_Corrupted_Repository_content-management
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5. Synchronize the content from Satellite to Capsule.

® To synchronize all content from your Satellite Server environment to Capsule Server, enter
the following command:

I # hammer capsule content synchronize --id capsule_id

® To synchronize a specific life cycle environment from your Satellite Server to
Capsule Server, enter the following command:

# hammer capsule content synchronize --id external_capsule id\
--lifecycle-environment-id lifecycle-environment _id
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CHAPTER 8. MANAGING CONTENT VIEWS

Red Hat Satellite uses Content Views to create customized repositories from the repositories. To do
this, you must define which repositories to use and then apply certain filters to the content. These filters
include package filters, package group filters, errata filters, module stream filters, and container image
tag filters. You can use Content Views to define which software versions a particular environment uses.
For example, a Production environment might use a Content View containing older package versions,
while a Development environment might use a Content View containing newer package versions.

Alternatively, a Default Organization View is an application-controlled Content View for all content that
is synchronized to Satellite. This type is useful if you want to register a host to Satellite and access
content using a subscription, without manipulating content views and lifecycle environments.

Each Content View creates a set of repositories across each environment, which Satellite Server stores
and manages. When you promote a Content View from one environment to the next environment in the
application life cycle, the respective repository on Satellite Server updates and publishes the packages.

Development Testing Production

Content View Version Version 2 - Version1- Version1-

and Contents example_software-1.1- example_software-1.0- example_software-1.0-
O.noarch.rpm O.noarch.rpm O.noarch.rpm

The repositories for Testing and Production contain the example_software-1.0-0.noarch.rpm package.
If you promote Version 2 of the Content View from Development to Testing, the repository for Testing
regenerates and then contains the example_software-1.1-0.noarch.rpm package:

Development Testing Production

Content View Version Version 2 - Version 2 - Version1-
and Contents example_software-1.1- example_software-1.1- example_software-1.0-
O.noarch.rpm O.noarch.rpm O.noarch.rpm

This ensures systems are designated to a specific environment but receive updates when that
environment uses a new version of the Content View.

The general workflow for creating Content Views for filtering and creating snapshots is as follows:
1. Create a Content View.
2. Add one or more repositories that you want to the Content View.

3. Optional: Create one or more filters to refine the content of the Content View. For more
information, see Section 8.9, "Content Filter Examples”.

4. Optional: Resolve any package dependencies for a Content View. For more information, see
Section 8.8, "Resolving Package Dependencies”.

5. Publish the Content View.

6. Optional: Promote the Content View to another environment. For more information, see
Section 8.3, “Promoting a Content View".
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7. Attach the content host to the Content View.

If a repository is not associated with the Content View, the file /etc/yum.repos.d/redhat.repo remains
empty and systems registered to it cannot receive updates.

Hosts can only be associated with a single Content View. To associate a host with multiple Content
Views, create a composite Content View. For more information, see Section 8.6, “Creating a Composite
Content View".

8.1. CREATING A CONTENT VIEW

Use this procedure to create a simple Content View. To use the CLI instead of the Satellite web Ul, see
the CLI procedure.

Prerequisites

While you can stipulate whether you want to resolve any package dependencies on a Content View by
Content View basis, you might want to change the default Satellite settings to enable or disable
package resolution for all Content Views. For more information, see Section 8.8, “Resolving Package
Dependencies”.

Procedure

1. In the Satellite web Ul, navigate to Content > Content Views and click Create content view

2. Inthe Name field, enter a name for the view. Satellite automatically completes the Label field
from the name you enter.

3. In the Description field, enter a description of the view.

4. In the Type field, select a Content view or a Composite content view

5. Optional: If you want to solve dependencies automatically every time you publish this Content
View, select the Solve dependencies check box. Dependency solving slows the publishing time
and might ignore any Content View filters you use. This can also cause errors when resolving

dependencies for errata.

6. Optional: If you want to designate this Content View for importing from an upstream server,
select the Import only check box. Import-only content views cannot be published directly.

7. Click Create content view

Content View Steps

1. Click Create content viewto create the Content View.

2. In the Repositories tab, select the repository from the Type list that you want to add to your
Content View, select the checkbox next to the available repositories you want to add, then click
Add repositories.

3. Click Publish new version and in the Description field, enter information about the version to
log changes.

4. Optional: You can enable a promotion path by clicking Promote to Select a lifecycle
environment from the available promotion paths to promote new version.
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5. Click Next.

6. On the Review page, you can review the environments you are trying to publish.

7. Click Finish.

NOTE

Remove and Delete are similar but the Delete option deletes an entire Content
View and the versions associated with that lifecycle environment. The Remove
option allows you to choose which version you want removed from the lifecycle
environment.

You can view the Content View in the Content Views window. To view more information about the
Content View, click the Content View name. To register a host to your Content View, see Registering
Hosts in Managing Hosts.

CLI procedure

1. Obtain a list of repository IDs:
I # hammer repository list --organization "My _Organization"
2. Create the Content View and add repositories:

# hammer content-view create \
--description "My _Content_View" \
--name "My _Content_View"\
--organization "My _Organization" \
--repository-ids 1,2

For the --repository-ids option, you can find the IDs in the output of the hammer repository
list command.

3. Publish the view:
# hammer content-view publish \
--description "My _Content_View" \

--name "My _Content_View"\
--organization "My _Organization"

4. Optional: To add a repository to an existing Content View, enter the following command:

# hammer content-view add-repository \
--name "My _Content_View"\
--organization "My _Organization" \
--repository-id repository_ID

Satellite Server creates the new version of the view and publishes it to the Library environment.

8.2. VIEWING MODULE STREAMS

In Satellite, you can view the module streams of the repositories in your Content Views.
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Procedure

1. In the Satellite web Ul, navigate to a published version of a Content View > Module Streams to
view the module streams that are available for the Content Types.

2. Use the Search field to search for specific modules.

3. To view the information about the module, click the module and its corresponding tabs to
include Details, Repositories, Profiles, and Artifacts.

8.3. PROMOTING A CONTENT VIEW

Use this procedure to promote Content Views across different lifecycle environments. To use the CLI
instead of the Satellite web Ul, see the CLI procedure.

Permission Requirements for Content View Promotion

Non-administrator users require two permissions to promote a Content View to an environment:
1. promote_or_remove_content_views
2. promote_or_remove_content_views_to_environment.

The promote_or_remove_content_views permission restricts which Content Views a user can
promote.

The promote_or_remove_content_views_to_environment permission restricts the environments to
which a user can promote Content Views.

With these permissions you can assign users permissions to promote certain Content Views to certain
environments, but not to other environments. For example, you can limit a user so that they are
permitted to promote to test environments, but not to production environments.

You must assign both permissions to a user to allow them to promote Content Views.

Procedure

1. In the Satellite web Ul, navigate to Content > Content Views and select the Content View that
you want to promote.

2. Select the version that you want to promote, click the vertical ellipsis icon, and click Promote.
3. Select the environment where you want to promote the Content View and click Promote.

Now the repository for the Content View appears in all environments.

CLI procedure

® Promote the Content View using the hammer content-view version promote each time:

# hammer content-view version promote \
--content-view "Database" \

--version 1\

--to-lifecycle-environment "Development” \
--organization "My _Organization"

# hammer content-view version promote \
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--content-view "Database" \

--version 1\

--to-lifecycle-environment "Testing" \
--organization "My _Organization"

# hammer content-view version promote \
--content-view "Database" \

--version 1\

--to-lifecycle-environment "Production” \
--organization "My _Organization"

Now the database content is available in all environments.

To register a host to your Content View, see Registering Hosts in the Managing Hosts guide.

8.4. PROMOTING A CONTENT VIEW ACROSS ALL LIFE CYCLE
ENVIRONMENTS WITHIN AN ORGANIZATION

Use this procedure to promote Content Views across all lifecycle environments within an organization.

Procedure

1. To promote a selected Content View version from Library across all life cycle environments
within an organization, run the following Bash script:

ORG="My_Organization"
CVV_ID=3

for i in $(hammer --no-headers --csv lifecycle-environment list --organization $ORG | awk -F,
{'print $1'} | sort -n)
do

hammer content-view version promote --organization $ORG --to-lifecycle-environment-id $i
--id $CVV_ID
done

2. Display information about your Content View version to verify that it is promoted to the
required lifecycle environments:

I # hammer content-view version info --id 3

8.5. COMPOSITE CONTENT VIEWS OVERVIEW

A Composite Content View combines the content from several Content Views. For example, you might
have separate Content Views to manage an operating system and an application individually. You can
use a Composite Content View to merge the contents of both Content Views into a new repository. The
repositories for the original Content Views still exist but a new repository also exists for the combined
content.

If you want to develop an application that supports different database servers. The example_application
appears as:
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example_software

Application
Database

Operating System

Example of four separate Content Views:
® Red Hat Enterprise Linux (Operating System)
® PostgreSQL (Database)
® MariaDB (Database)
® example_software (Application)
From the previous Content Views, you can create two Composite Content Views.

Example Composite Content View for a PostgreSQL database:

Composite Content View 1-example_software on PostgreSQL

example_software (Application)

PostgreSQL (Database)

Red Hat Enterprise Linux (Operating System)

Example Composite Content View for a MariaDB:

Composite Content View 2 - example_software on MariaDB

example_software (Application)
MariaDB (Database)

Red Hat Enterprise Linux (Operating System)

Each Content View is then managed and published separately. When you create a version of the
application, you publish a new version of the Composite Content Views. You can also select the Auto
Publish option when creating a Composite Content View, and then the Composite Content View is
automatically republished when a Content View it includes is republished.

Repository Restrictions
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You cannot include more than one of each repository in Composite Content Views. For example, if you
attempt to include two Content Views using the same repository in a Composite Content View,
Satellite Server reports an error.

8.6. CREATING A COMPOSITE CONTENT VIEW

Use this procedure to create a composite Content View. To use the CLI instead of the Satellite web U],
see the CLI procedure.

Procedure

1.

2.

1.

12.

13

In the Satellite web Ul, navigate to Content > Content Views and click Create content view

In the Create content viewwindow, enter a name for the view in the Name field. Red Hat
Satellite automatically completes the Label field from the name you enter.

Optional: In the Description field, enter a description of the view.
On the Type tab, select Composite content view.

Optional: If you want to automatically publish a new version of the Composite Content View
when a Content View is republished, select the Auto publish checkbox.

Click Create content view

On the Content views tab, select the Content Views that you want to add to the Composite
Content View, and then click Add content views

In the Add content viewswindow, select the version of each Content View.

Optional: If you want to automatically update the Content View to the latest version, select the
Always update to latest version checkbox.

. Click Add, then click Publish new version.

Optional: In the Description field, enter a description of the Content View.
In the Publish window, set the Promote switch, then select the lifecycle environment.

Click Next, then click Finish.

CLI procedure

1.
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Before you create the Composite Content Views, list the version IDs for your existing Content
Views:

# hammer content-view version list \
--organization "My _Organization"

Create a new Composite Content View. When the --auto-publish option is set to yes, the
Composite Content View is automatically republished when a Content View it includes is
republished:

# hammer content-view create \
--composite \
--auto-publish yes \
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--name "Example_Composite_Content_View" \
--description "Example Composite Content View" \
--organization "My _Organization"

3. Add a Content View to the Composite Content View. You can identify Content View, Content
View version, and Organization in the commands by either their ID or their name. To add multiple
Content Views to the Composite Content View, repeat this step for every Content View you
want to include.

e |f you have the Always update to latest versionoption enabled for the Content View:

# hammer content-view component add \
--component-content-view-id Content_View_ID\
--composite-content-view "Example_Composite_Content View" \
--latest \

--organization "My _Organization"

e |f you have the Always update to latest versionoption disabled for the Content View:

# hammer content-view component add \
--component-content-view-id Content_View_ID\
--composite-content-view "Example_Composite_Content_View" \
--component-content-view-version-id Content_View_Version_ID \
--organization "My _Organization"

4. Publish the Composite Content View:

# hammer content-view publish \

--name "Example_Composite_Content_View" \
--description "Initial version of Composite Content View" \
--organization "My _Organization"

5. Promote the Composite Content View across all environments:

# hammer content-view version promote \
--content-view "Example_Composite _Content_View" \
--version 1\

--to-lifecycle-environment "Development” \
--organization "My _Organization"

# hammer content-view version promote \
--content-view "Example_Composite _Content_View" \
--version 1\

--to-lifecycle-environment "Testing" \

--organization "My _Organization"

# hammer content-view version promote \
--content-view "Example_Composite_Content_View" \
--version 1\

--to-lifecycle-environment "Production” \
--organization "My _Organization"

8.7. CONTENT FILTER OVERVIEW

Content Views also use filters to include or restrict certain RPM content. Without these filters, a
Content View includes everything from the selected repositories.
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There are two types of content filters:

Table 8.1. Filter Types

Filter Type Description

Include You start with no content, then select which content
to add from the selected repositories. Use this filter
to combine multiple content items.

Exclude You start with all content from selected repositories,
then select which content to remove. Use this filter
when you want to use most of a particular content
repository but exclude certain packages, such as
blacklisted packages. The filter uses all content in the
repository except for the content you select.

Include and Exclude Filter Combinations

If using a combination of Include and Exclude filters, publishing a Content View triggers the include
filters first, then the exclude filters. In this situation, select which content to include, then which content
to exclude from the inclusive subset.

Content Types

There are also five types of content to filter:

Table 8.2. Content Types

Content Type Description

RPM Filter packages based on their name and version
number. The RPM option filters non-modular RPM
packages and errata.

Package Group Filter packages based on package groups. The list of
package groups is based on the repositories added
to the Content View.

Erratum (by ID) Select which specific errata to add to the filter. The
list of Errata is based on the repositories added to
the Content View.

Erratum (by Date and Type) Select a issued or updated date range and errata
type (Bugfix, Enhancement, or Security) to add to
the filter.

Module Streams Select whether to include or exclude specific module

streams. The Module Streams option filters modular
RPMs and errata, but does not filter non-modular
content that is associated with the selected module
stream.
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Content Type Description

Container Image Tag Select whether to include or exclude specific
container image tags.

8.8. RESOLVING PACKAGE DEPENDENCIES

In Satellite, you can use the package dependency resolution feature to ensure that any dependencies
that packages have within a Content View are added to the dependent repository as part of the Content
View publication process.

You can select to resolve package dependencies for any Content View that you want, or you can change
the default setting to enable or disable resolving package dependencies for all new Content Views.

Note that resolving package dependencies can cause significant delays to Content View promotion. The
package dependency resolution feature does not consider packages that are installed on your system
independently of the Content View or solve dependencies across repositories.

Resolving Package Dependencies and Filters

Filters do not resolve any dependencies of the packages listed in the filters. This might require some
level of testing to determine what dependencies are required.

If you add a filter that excludes some packages that are required and the Content View has dependency
resolution enabled, Satellite ignores the rules you create in your filter in favor of resolving the package

dependency.

If you create a content filter for security purposes, to resolve a package dependency, Satellite can add
packages that you might consider insecure.

8.9. CONTENT FILTER EXAMPLES

Use any of the following examples with the procedure that follows to build custom content filters.

Example 1

Create a repository with the base Red Hat Enterprise Linux packages. This filter requires a Red Hat
Enterprise Linux repository added to the Content View.

Filter:
® Inclusion Type:Include
® Content Type: Package Group
® Filter: Select only the Base package group

Example 2

Create a repository that excludes all errata, except for security updates, after a certain date. This is
useful if you want to perform system updates on a regular basis with the exception of critical security
updates, which must be applied immediately. This filter requires a Red Hat Enterprise Linux repository
added to the Content View.

Filter:
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® Inclusion Type: Exclude

® Content Type: Erratum (by Date and Type)

e Filter: Select only the Bugfix and Enhancement errata types, and clear the Security errata
type. Set the Date Type to Updated On. Set the Start Date to the date you want to restrict

errata. Leave the End Date blank to ensure any new non-security errata is filtered.

Example 3
A combination of Example 1and Example 2 where you only require the operating system packages and
want to exclude recent bug fix and enhancement errata. This requires two filters attached to the same
Content View. The Content View processes the Include filter first, then the Exclude filter.
Filter 1:

® Inclusion Type:Include

® Content Type: Package Group

® Filter: Select only the Base package group
Filter 2:

® Inclusion Type: Exclude

® Content Type: Erratum (by Date and Type)

e Filter: Select only the Bugfix and Enhancement errata types, and clear the Security errata

type. Set the Date Type to Updated On. Set the Start Date to the date you want to restrict

errata. Leave the End Date blank to ensure any new non-security errata is filtered.

Example 4

Filter a specific module stream in a Content View.
Filter 1:

® Inclusion Type:Include

® Content Type: Module Stream

® Filter: Select only the specific module stream that you want for the Content View, for example
ant, and click Add Module Stream.

Filter 2:
® Inclusion Type: Exclude
® Content Type: Package
e Filter: Add arule to filter any non-modular packages that you want to exclude from the Content
View. If you do not filter the packages, the Content View filter includes all non-modular
packages associated with the module stream ant. Add a rule to exclude all * packages, or specify

the package names that you want to exclude.

For another example of how content filters work, see the following article: "How do content filters work
in Satellite 6".
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8.10. CREATING A CONTENT FILTER FOR YUM CONTENT

You can filter Content Views containing Yum content to include or exclude specific packages, package
groups, errata, or module streams. Filters are based on a combination of the name, version, and
architecture.

To use the CLI instead of the Satellite web Ul, see the CLI| procedure.

For examples of how to build a filter, see Section 8.9, “Content Filter Examples”.

Procedure

1.

2

3.

1.

12.

In the Satellite web Ul, navigate to Content > Content Views and select a Content View.
On the Filters tab, click Create filter.

Enter a name.

From the Content type list, select a content type.

From the Inclusion Type list, select either Include filter or Exclude filter.

Optional: In the Description field, enter a description for the filter.

Click Create filter to create your content filter.

Depending on what you enter for Content Type, add rules to create the filter that you want.

Select if you want the filter to Apply to subset of repositoriesor Apply to all repositories.

. Click Publish New Version to publish the filtered repository.

Optional: In the Description field, enter a description of the changes.

Click Create filter to publish a new version of the Content View.
You can promote this Content View across all environments.

CLI procedure

1.

2.

Add a filter to the Content View. Use the --inclusion false option to set the filter to an Exclude
filter:

# hammer content-view filter create \

--name "Errata Filter" \

--type erratum --content-view "Example_Content _View"\
--description "My latest filter" \

--inclusion false \

--organization "My _Organization"

Add a rule to the filter:

# hammer content-view filter rule create \
--content-view "Example_Content_View"\
--content-view-filter "Errata Filter' \
--start-date "YYYY-MM-DD" \
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--types enhancement,bugfix \
--date-type updated \
--organization "My _Organization"

3. Publish the Content View:

4.

# hammer content-view publish \
--name "Example_Content_View'\
--description "Adding errata filter" \
--organization "My _Organization"

Promote the view across all environments:

# hammer content-view version promote \
--content-view "Example_Content_View" \
--version 1\

--to-lifecycle-environment "Development” \
--organization "My _Organization"

# hammer content-view version promote \
--content-view "Example_Content_View" \
--version 1\

--to-lifecycle-environment "Testing" \
--organization "My _Organization"

# hammer content-view version promote \
--content-view "Example_Content_View" \
--version 1\

--to-lifecycle-environment "Production” \
--organization "My _Organization"

8.1. DELETING A CONTENT VIEW VERSION

Use this procedure to delete a Content View ver