7.6. Linguaggi di programmazione dinamici, server web e database (traduzione automatica)

I server di database non sono installabili in parallelo

I moduli mariadbe mysqli moduli non possono essere installati in parallelo in RHEL 8.0 a causa di pacchetti RPM contrastanti.

Per progettazione, è impossibile installare più di una versione (stream) dello stesso modulo in parallelo. Per esempio, è necessario scegliere solo uno dei flussi disponibili dal postgresqlmodulo, o (predefinito10) o 9.6. L'installazione parallela dei componenti è possibile nelle Red Hat Software Collections per RHEL 6 e RHEL 7. In RHEL 8, diverse versioni di server di database possono essere utilizzate in container.

(BZ#1566048)

Problemi nella mod_cgidregistrazione

Se il modulo mod_cgidApache httpd è usato sotto un modulo threaded multi-processing (MPM), che è la situazione di default in RHEL 8, si verificano i seguenti problemi di logging:

  • L'stderroutput dello script CGI non è preceduto da informazioni standard di timestamp.
  • L'stderroutput dello script CGI non è correttamente reindirizzato ad un file di log specifico per il VirtualHost, se configurato.

(BZ#1633224)

Il modulo IO::Socket::SSLPerl non supporta TLS 1.3

Nuove funzionalità del protocollo TLS 1.3, come la ripresa della sessione o l'autenticazione post-handshake, sono state implementate nella libreria RHEL 8 OpenSSLma non nel modulo Net::SSLeayPerl, e quindi non sono disponibili nel modulo IO::Socket::SSLPerl. Di conseguenza, l'autenticazione del certificato client potrebbe non riuscire e il ripristino delle sessioni potrebbe essere più lento rispetto al protocollo TLS 1.2.

Per ovviare a questo problema, disabilitare l'utilizzo di TLS 1.3 impostando l'SSL_versionopzione sul !TLSv1_3valore quando si crea un IO::Socket::SSLoggetto.

(BZ#1632600)