Red Hat Training

A Red Hat training course is available for Red Hat Enterprise Linux

1.2. Compatibilità delle applicazioni

Questa versione di Red Hat Enterprise Linux fornisce le dipendenze necessarie alle applicazioni sviluppate per versioni precedenti del sistema operativo per una esecuzione con interruzioni minime. Sono incluse versioni meno recenti di librerie per preservare le interfacce ereditate e modificate in questa release. Le suddette librerie servono come dipendenze principalmente per le applicazioni scritte in C/C++.
Da notare che non sarà necessario eseguire un nuovo test o ricertificare le applicazioni tra versioni minori di Red Hat Enterprise Linux. Le politiche di compatibilità di Red Hat Enterprise Linux assicurano che le applicazioni eseguite su di una versione della release potranno essere eseguite durante tutto il ciclo di vita della release stessa. Per esempio, le applicazioni certificate su Red Hat Enterprise Linux 6.0 saranno completamente compatibili su Red Hat Enterprise Linux 6.1 e così via.
Consultate la seguente tabella per le informazioni relative ai pacchetti di compatibilità:

Tabella 1.1. Librerie di compatibilità

Pacchetto Descrizione
compat-db La libreria di compatibilità del database Berkeley DB. Il Berkeley Database (Berkeley DB) è un toolkit programmatico in grado di fornire un supporto embedded del database per entrambe le applicazioni client/server e tradizionali. Questo pacchetto contiene varie versioni di Berkeley DB incluse nelle release precedenti.
compat-expat1 Expat è un analizzatore XML orientato sul flusso. Questo pacchetto fornisce la compatibilità per la libreria con versioni precedenti.
compat-glibc glibc è la libreria C usata per le chiamate del sistema ed altre funzioni di base. Questo pacchetto fornisce la compatibilità (e le librerie per il runtime) per la compilazione delle librerie che necessitano di versioni più vecchie di glibc, permettendo loro di essere eseguite su questa release di Red Hat Enterprise Linux.
compat-libf2c-34 Questo pacchetto fornisce le versioni più vecchie delle librerie condivise Fortran 77, necessarie per eseguire i programmi Fortran 77 collegati dinamicamente.
compat-libgcc-296 Contiene la libreria 2.96 libgcc.a e supporta i file dell'oggetto per mantenere la compatibilità con le versioni più vecchie di GCC.
compat-libgfortran-41 Questo pacchetto include una libreria per il runtime Fortran 95 per la compatibilità con le applicazioni Fortran compilate con GCC 4.1.x
compat-libstdc++-295 Fornisce una compatibilità con la versione 2.95 della libreria C++ standard di GNU
compat-libstdc++-296 Fornisce una compatibilità con la versione 2.96 della libreria C++ standard di GNU
compat-libstdc++-33 Fornisce una compatibilità con la versione 3.3 della libreria C++ standard di GNU
compat-libtermcap Questo pacchetto fornisce una compatibilità per programmi basati su termcap più vecchi.
compat-openldap OpenLDAP è una suite open source di applicazioni LDAP (Lightweight Directory Access Protocol) e tool di sviluppo. Il pacchetto compat-openldap include le versioni più vecchie delle librerie condivise OpenLDAP le quali possono essere necessarie per alcune applicazioni.
openssl098e Questo pacchetto fornisce OpenSSL 0.98e, il quale può essere necessario per alcune applicazioni SSL.