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1. INSTALL OPTIONS

Red Hat JBoss Developer Studio Integration Stack is provided as a set of plug-ins for Eclipse or JBoss
Developer Studio.

Depending on whether you are already using Eclipse or JBoss Developer Studio, there are a variety of
ways of installing JBoss Developer Studio Integration Stack and instructions are given here for each
variation:

Section 3, “Install JBoss Developer Studio Integration Stack in Eclipse when Online”

Section 4, “Install JBoss Developer Studio Integration Stack in Eclipse when Offline”

Section 5, “Install JBoss Developer Studio Integration Stack in JBoss Developer Studio when
Online”

Section 6, “Install JBoss Developer Studio Integration Stack in JBoss Developer Studio when
Offline”

NOTE

At this time, it is not possible to install JBoss Developer Studio Integration Stack
without first installing Eclipse or installing JBoss Developer Studio. To install Eclipse,
see https://eclipse.org/users/ on the Eclipse website. To install JBoss Developer Studio
BYOE or standalone, see the Install Red Hat JBoss Developer Studio document for the
relevant version on the Red Hat JBoss Developer Studio documentation page

IMPORTANT

A variety of Eclipse installations are available, each with a different default configuration
and selection of preinstalled plug-ins. For using JBoss Developer Studio Integration
Stack, it is recommended that you use the variant Eclipse Luna for Java EE 
Developers.

Report a bug

2. SYSTEM REQUIREMENTS

This release of JBoss Developer Studio is supported for use with a range of operating system,
architecture and Java developer kit combinations; for a complete list, see
https://access.redhat.com/articles/427493 on the Red Hat Customer Portal.

To install and run this release of JBoss Developer Studio, the following memory requirements are
recommended:

4 GB RAM

2 GB of hard disk space

Install Red Hat JBoss Developer Studio Integration Stack
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NOTE

The minimum memory requirements are 2 GB RAM and 1 GB of hard disk space.

Report a bug

3. INSTALL JBOSS DEVELOPER STUDIO INTEGRATION STACK IN
ECLIPSE WHEN ONLINE

JBoss Developer Studio Integration Stack is available to install in Eclipse when you are online. You
must first install JBoss Developer Studio and then install JBoss Developer Studio Integration Stack
from JBoss Central Software/Update tab.

To first install JBoss Developer Studio in Eclipse when online, complete the following steps:

1. Start Eclipse Luna for Java EE Developers .

2. Drag the following link into your Eclipse workspace:
http://marketplace.eclipse.org/marketplace-client-intro?mpc_install=1616973. Alternatively,
click Help→Eclipse Marketplace, locate Red Hat JBoss Developer Studio (Luna) and
click Install.

Figure 1. Red Hat JBoss Developer Studio (Luna) Available from Eclipse Marketplace

3. Follow the on-screen instructions to complete the installation process.

To subsequently install JBoss Developer Studio Integration Stack in Eclipse when online, complete the
following steps:

1. In JBoss Central, click the Software/Update tab.

3. INSTALL JBOSS DEVELOPER STUDIO INTEGRATION STACK IN ECLIPSE WHEN ONLINE
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2. In the list of available software, locate JBoss Developer Studio Integration Stack .

3. Select the check boxes corresponding to the JBoss Developer Studio Integration Stack
functionality you want to install:

For JBoss Fuse, select the JBoss Fuse Development check box

For JBoss Data Virtualization, select the JBoss Data Virtualization 
Developement check box

For JBoss BRMS and JBoss BPM Suite, select the JBoss Business and Rules 
Development check box

For JBoss SOA Platform 5.x, select the JBoss SOA 5.x Development check box

For JBoss Fuse Service Works, select the JBoss Integration and SOA 
Development check box

4. Click Install/Update.

5. Follow the on-screen instructions to complete the installation process.

During the installation process, warnings about installing unsigned content may display. If this is the
case, review the details of the content and if satisfied click OK to continue with the installation.

WARNING

The IDE changes do not take effect until the IDE is restarted and the IDE may be
unstable until it is restarted.

Once installed, complete the additional configuration actions before you can use the JBoss Developer
Studio Integration Stack functionality. For plug-in specific configuration information, see the
appropriate Red Hat JBoss product documentation available from the Red Hat Customer Portal

IMPORTANT

If you choose to install only selected functionality of a JBoss Developer Studio
Integration Stack category, for example only ModeShape Client from the JBoss 
Data Virtualization Development category, then the category continues to be
listed as uninstalled in the JBoss Central Software/Update tab.

Report a bug

4. INSTALL JBOSS DEVELOPER STUDIO INTEGRATION STACK IN
ECLIPSE WHEN OFFLINE

Three .zip files are necessary for installing JBoss Developer Studio Integration Stack in Eclipse in
offline mode, one containing JBoss Developer Studio Integration Stack and two containing JBoss
Developer Studio Update archive and Target Platform archive. The JBoss Developer Studio



Install Red Hat JBoss Developer Studio Integration Stack
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Integration Stack .zip file is available from the customer portal and also from
https://devstudio.jboss.com/updates/8.0/integration-stack. The JBoss Developer Studio Update and
Target Platform .zip files are available from https://devstudio.jboss.com/updates/8.0/ under 
Offline Install.

IMPORTANT

You must first be online to download the .zip files before proceeding to install JBoss
Developer Studio Integration Stack in offline mode.

To install JBoss Developer Studio Integration Stack in Eclipse when offline, complete the following
steps:

1. Locate and download Red Hat JBoss Developer Studio Integration Stack 
8.0.6.GA Update Site Zip and Red Hat JBoss Developer Studio 8.1.0.GA 
Update Site Zip and Target Platform Zip.

2. Start Eclipse Luna for Java EE Developers .

3. Click Window→Preferences→Install/Update→Available Software Sites .

4. Click Add, click Archive to locate the Red Hat JBoss Developer Studio 
Integration Stack 8.0.6.GA Update Site.zip file, select the file and click OK.

5. Click Add, click Archive to locate the Red Hat JBoss Developer Studio 8.1.0.GA 
Target Platform.zip file, select the file and click OK.

6. Click OK again to close the Preferences window.

7. Click Help→Install New Software .

8. Next to the Work with field, click Add and click Archive to locate the JBoss Developer
Studio Integration Stack .zip file.

9. From the table of categories, select the JBoss Developer Studio Integration Stack
functionality you want to install:

For JBoss Fuse, select the JBoss Fuse Development check box

For JBoss Data Virtualization, select the JBoss Data Virtualization 
Developement check box

For JBoss BRMS and JBoss BPM Suite, select the JBoss Business and Rules 
Development check box

For JBoss SOA Platform 5.x, select the JBoss SOA 5.x Development check box

For JBoss Fuse Service Works, select the JBoss Integration and SOA 
Development check box

10. Click Next.

11. Follow the on-screen instructions to complete the installation process.

4. INSTALL JBOSS DEVELOPER STUDIO INTEGRATION STACK IN ECLIPSE WHEN OFFLINE
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During the installation process, you may receive warnings about installing unsigned content. If this is
the case, review the details of the content and if satisfied click OK to continue with the installation.

Once installation is complete, you are prompted to restart the IDE. Click Yes to restart immediately
and No if you need to save any unsaved changes to open projects.

WARNING

The IDE changes do not take effect until the IDE is restarted and the IDE may be
unstable until it is restarted.

Report a bug

5. INSTALL JBOSS DEVELOPER STUDIO INTEGRATION STACK IN
JBOSS DEVELOPER STUDIO WHEN ONLINE

JBoss Developer Studio Integration Stack is available to install from JBoss Developer Studio, through
JBoss Central Software/Update tab, when online.

IMPORTANT

To install JBoss Developer Studio Integration Stack as detailed in the steps below, it is
essential that you have an instance of JBoss Developer Studio installed. For detailed
steps to install JBoss Developer Studio refer to Section 3, “Install JBoss Developer
Studio Integration Stack in Eclipse when Online”

To install JBoss Developer Studio Integration Stack in JBoss Developer Studio when online, complete
the following steps:

1. Start JBoss Developer Studio.

2. In JBoss Central, select the Software/Update tab.

NOTE

If JBoss Central is not visible, click Window → JBoss Central.

3. In the list of available software, locate JBoss Developer Studio Integration Stack .

4. Select the check boxes corresponding to the JBoss Developer Studio Integration Stack
functionality you want to install:

For JBoss Fuse, select the JBoss Fuse Development check box

For JBoss Data Virtualization, select the JBoss Data Virtualization 
Developement check box


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For JBoss BRMS and JBoss BPM Suite, select the JBoss Business and Rules 
Development check box

For JBoss SOA Platform 5.x, select the JBoss SOA 5.x Development check box

For JBoss Fuse Service Works, select the JBoss Integration and SOA 
Development check box

5. Click Install/Update.

6. Follow the on-screen instructions to complete the installation process.

WARNING

The IDE changes do not take effect until the IDE is restarted and the IDE may be
unstable until it is restarted.

Once installed, you may need to complete additional configuration actions before you can use the
JBoss Developer Studio Integration Stack functionality. For plug-in specific configuration information,
see the appropriate Red Hat JBoss product documentation available from the Red Hat Customer
Portal

IMPORTANT

If you choose to install only selected functionality of a JBoss Developer Studio
Integration Stack category, for example only ModeShape Client from the JBoss 
Data Virtualization Development category, then the category continues to be
listed as uninstalled in the JBoss Central Software/Update tab.

Report a bug

6. INSTALL JBOSS DEVELOPER STUDIO INTEGRATION STACK IN
JBOSS DEVELOPER STUDIO WHEN OFFLINE

IMPORTANT

To install JBoss Developer Studio Integration Stack as detailed in the steps below, it is
essential that you have an instance of JBoss Developer Studio installed. For detailed
steps to install JBoss Developer Studio refer to Section 3, “Install JBoss Developer
Studio Integration Stack in Eclipse when Online”

Two .zip files are provided for installing JBoss Developer Studio Integration Stack in JBoss
Developer Studio in offline mode: the  Red Hat JBoss Developer Studio Integration 
Stack 8.0.6.GA Update Site Zip that is available from
https://devstudio.jboss.com/updates/8.0/integration-stack and the  Red Hat JBoss Developer 
Studio 8.1.0.GA Target Platform Zip available from
https://devstudio.jboss.com/updates/8.0/ .


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IMPORTANT

You must first be online to download the .zip files before proceeding to installing
JBoss Developer Studio Integration Stack in offline mode.

To install JBoss Developer Studio Integration Stack in JBoss Developer Studio when offline, complete
the following steps:

1. Locate and download Red Hat JBoss Developer Studio Integration Stack 
8.0.6.GA Update Site Zip and Red Hat JBoss Developer Studio 8.1.0.GA 
Target Platform Zip.

2. Start JBoss Developer Studio 8.

3. Click Window→Preferences→Install/Update→Available Software Sites ..

4. Click Add, click Archive to locate the Red Hat JBoss Developer Studio 8.1.0.GA 
Target Platform.zip file, select the file and click OK.

5. Click OK again to close the Preferences window.

6. Click Help→Install New Software .

7. Next to the Work with field, click Add and click Archive to locate the Red Hat JBoss 
Developer Studio Integration Stack 8.0.6.GA Update Site.zip file.

8. From the table of categories, select the JBoss Developer Studio Integration Stack
functionality you want to install:

For JBoss Fuse, select the JBoss Fuse Development check box

For JBoss Data Virtualization, select the JBoss Data Virtualization 
Developement check box

For JBoss BRMS and JBoss BPM Suite, select the JBoss Business and Rules 
Development check box

For JBoss SOA Platform 5.x, select the JBoss SOA 5.x Development check box

For JBoss Fuse Service Works, select the JBoss Integration and SOA 
Development check box

9. Click Next.

10. Follow the on-screen instructions to complete the installation process.

During the installation process, you may receive warnings about installing unsigned content. If this is
the case, review the details of the content and if satisfied click OK to continue with the installation.

Once installation is complete, you are prompted to restart the IDE. Click Yes to restart immediately
and No if you need to save any unsaved changes to open projects.

Install Red Hat JBoss Developer Studio Integration Stack
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WARNING

The IDE changes do not take effect until the IDE is restarted and the IDE may be
unstable until it is restarted.

Report a bug

7. UNINSTALL OPTIONS

After concluding development in one of the Red Hat JBoss Developer Studio Integration Stack tooling
plug-ins, you can choose to uninstall either an entire category of plug-ins, or individual plug-ins.
Removing one or more plug-ins that are no longer required provides continued stability and ensures
continued optimal performance due to a smaller memory footprint. Uninstall a category of features to
remove all related features in an efficient manner, or select individual plug-ins to remove for a
customized uninstall process.

To uninstall an entire category of features, refer to: Section 8, “Uninstall an Entire Category of
JBoss Developer Studio Integration Stack”

To uninstall a single feature, refer to: Section 9, “Uninstall a Single Feature of JBoss Developer
Studio Integration Stack”

Report a bug

8. UNINSTALL AN ENTIRE CATEGORY OF JBOSS DEVELOPER STUDIO
INTEGRATION STACK

To uninstall an entire category of JBoss Developer Studio Integration Stack:

1. In JBoss Central, click the Software/Update tab.

NOTE

If JBoss Central is not visible, click Window→JBoss Central.

2. Click the Show installed check box.

3. In the Features Available  list, locate JBoss Developer Studio Integration Stack.

4. Select the check boxes corresponding to the JBoss Developer Studio Integration Stack
category to uninstall:

For JBoss Data Virtualization, select the JBoss Data Virtualization 
Developement check box

For JBoss BRMS and JBoss BPM Suite, select the JBoss Business and Rules 
Development check box

For JBoss SOA Platform 5.x, select the JBoss SOA 5.x Development check box


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For JBoss Fuse Service Works, select the JBoss Integration and SOA 
Development (Early Access) check box

For JBoss Fuse, select the JBoss Fuse Development check box

5. Click Uninstall.

6. Follow the on-screen instructions to complete the process of uninstalling the selected
category.

7. Restart the IDE to implement the changes. An immediate restart is recommended because the
IDE may be unstable until a restart.

Report a bug

9. UNINSTALL A SINGLE FEATURE OF JBOSS DEVELOPER STUDIO
INTEGRATION STACK

To uninstall a single feature of JBoss Developer Studio Integration Stack:

1. Click Help→Installation Details.

2. In the search field type the feature to uninstall.

3. Click the feature to uninstall and click Uninstall.

NOTE

To delete more than one feature select the features while pressing the Shift
key.

4. Follow the on-screen instructions to complete the process of uninstalling the selected feature.

5. Restart the IDE to implement the changes. An immediate restart is recommended because the
IDE may be unstable until a restart.

Report a bug
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A. REVISION HISTORY

Revision 8.0.0-13 Tue Mar 29 2016 Supriya Bharadwaj
Created for 8.0.6 GA.

Revision 8.0.0-12 Tue Jan 19 2016 Misha Husnain Ali
TOOLSDOC-707: Fixed broken link.

Revision 8.0.0-11 Mon Dec 07 2015 Supriya Bharadwaj
Updated document for 8.0.4 GA

Revision 8.0.0-10 Fri Nov 20 2015 Misha Husnain Ali
TOOLSDOC-690: Removed indications that Data Transformation and SwitchYard are Tech Preview as they are supported for
8.0.4.

Revision 8.0.0-9 Thu Jun 18 2015 Misha Husnain Ali
Slight changes to steps.

Revision 8.0.0-7 Tue Jun 16 2015 Supriya Bharadwaj
Updated document for 8.0.2 GA release.

Revision 8.0.0-6 Mon May 18 2015 Supriya Bharadwaj
Added the uninstall instructions.

Revision 8.0.0-5 Mon Apr 13 2015 Supriya Bharadwaj
Incorporated QE feedback (JBQA-11656).
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Troubleshooting splash page.
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