5.3. Pcre

Le paquetage pcre a été mis à jour à la version 7.8. Il inclut les modifications de comportement suivantes :
  • La vérification UTF-8 référence maintenant RFC 3629 au lieu de RFC 2279. Ceci la rend plus restrictive dans le choix des chaînes acceptées. Par exemple, la valeur ordinale des caractères UTF-8 est maintenant limitée à 0x0010FFFF :
    $ echo -ne "\x00\x11\xff\xff" | recode UCS-4-BE..UTF8 | pcregrep --utf-8 '.'
    pcregrep: pcre_exec() error -10 while matching this line:
    
    Veuillez vous reporter au RFC pour plus de détails : http://tools.ietf.org/html/rfc3629#section-12.
  • Les modèles enregistrés qui ont été compilés par des versions précédentes de PCRE doivent être recompilées. Ceci affecte les applications qui sérialisent des expressions PCRE pré-compilées vers une mémoire externe (par exemple, un fichier) et qui les chargent plus tard. Ceci est effectué pour des raisons liées à la performance, par exemple pour les filtres spam de grande taille.