4.11. PostgreSQL

Mise à jour de bases de données

Si vous effectuez une mise à niveau depuis une installation existante de Red Hat Enterprise Linux 5 dans laquelle PostgreSQL 8.4 (paquetages postgresql84-*) était utilisé, les paquetages PostgreSQL de Red Hat Enterprise 6 opéreront en tant que remplacement.

Cependant, si vous effectuez une mise à niveau depuis une installation de Red Hat Enterprise Linux 5 dans laquelle PostgreSQL 8.4 (paquetages postgresql84-*) ou une de ses versions ultérieures était utilisé et que vous possédez un contenu de base de données devant être préservé, vous devrez suivre la procédure de vidage et de rechargement à cause des modifications du format des données : http://www.postgresql.org/docs/8.4/interactive/install-upgrading.html. Assurez-vous de bien effectuer l'étape de vidage avant de procéder à la mise à niveau vers Red Hat Enterprise Linux 6.
Autres changements

Reportez-vous à l'URL suivant pour tout problème de compatibilité d'application probablement lié à la transition de PostgreSQL 8.1 à 8.4 : http://wiki.postgresql.org/wiki/WhatsNew84