4.11. PostgreSQL

Actualizando bases de datos

Si está actualizando desde una instalación de Red Hat Enterprise Linux 5 en la cual PostgreSQL 8.4 (paquetes postgresql84-*) estaba en uso, los paquetes PostgreSQL de Red Hat Enterprise 6 funcionarán como un remplazo exacto.

Sin embargo, si está actualizando desde la instalación de Red Hat Enterprise Linux 5 en la cual PostgreSQL 8.1 (paquetes postgresql-*) o anteriores estaban en uso, y si tiene contenido de base de datos que necesita preservarse, deberá seguir el vaciado y recargar el procedimiento aquí debido a los cambios en el formato de datos: http://www.postgresql.org/docs/8.4/interactive/install-upgrading.html. Asegúrese de realizar el paso de vaciado antes de actualizar a Red Hat Enterprise Linux 6.
Otros cambios

Consulte la siguiente URL para posibles problemas de compatibilidad de aplicaciones asociados con la transición de PostgreSQL 8.1 a 8.4: http://wiki.postgresql.org/wiki/WhatsNew84