Red Hat Satellite 6.0
User Guide

A guide to using Satellite entitlement management software.


		[image: ]

	


      ⁠Red Hat Satellite Documentation Team 



Legal Notice

		Copyright © 2015 Red Hat.
	

		This document is licensed by Red Hat under the Creative Commons Attribution-ShareAlike 3.0 Unported License. If you distribute this document, or a modified version of it, you must provide attribution to Red Hat, Inc. and provide a link to the original. If the document is modified, all Red Hat trademarks must be removed.
	

		Red Hat, as the licensor of this document, waives the right to enforce, and agrees not to assert, Section 4d of CC-BY-SA to the fullest extent permitted by applicable law.
	

		Red Hat, Red Hat Enterprise Linux, the Shadowman logo, JBoss, OpenShift, Fedora, the Infinity logo, and RHCE are trademarks of Red Hat, Inc., registered in the United States and other countries.
	

		Linux® is the registered trademark of Linus Torvalds in the United States and other countries.
	

		Java® is a registered trademark of Oracle and/or its affiliates.
	

		XFS® is a trademark of Silicon Graphics International Corp. or its subsidiaries in the United States and/or other countries.
	

		MySQL® is a registered trademark of MySQL AB in the United States, the European Union and other countries.
	

		Node.js® is an official trademark of Joyent. Red Hat Software Collections is not formally related to or endorsed by the official Joyent Node.js open source or commercial project.
	

		The OpenStack® Word Mark and OpenStack logo are either registered trademarks/service marks or trademarks/service marks of the OpenStack Foundation, in the United States and other countries and are used with the OpenStack Foundation's permission. We are not affiliated with, endorsed or sponsored by the OpenStack Foundation, or the OpenStack community.
	

		All other trademarks are the property of their respective owners.
	


Abstract

			The Red Hat Satellite 6 User Guide describes how to use Satellite, including subscriptions, content management, provisioning, and system control.
		






      ⁠Chapter 1. Introduction to Red Hat Satellite




		Red Hat Satellite 6 is the evolution of Red Hat's life cycle management platform. It provides the capabilities that administrators have come to expect in a tool focused on managing systems and content for a global enterprise. Satellite 6 covers the use cases requested by Satellite 5 customers, but also includes functionality that enables larger scale, federation of content, better control of systems during the provisioning process, and a much more simplified approach to life cycle management. Satellite 6 also further evolves the inherent approach to certificate-based entitlements and integrated subscription management. Satellite 6 is based on years of customer feedback and is an evolution of previous versions.
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      ⁠1.1. Red Hat Satellite 6 System Architecture




		Red Hat Satellite 6 is based upon several open source projects arranged in the following architecture.
	

      ⁠[image: Red Hat Satellite 6 System Architecture]

Figure 1.1. Red Hat Satellite 6 System Architecture

	
      ⁠Foreman
	
					Foreman is an open source application used for provisioning and life cycle management of physical and virtual systems. Foreman automatically configures these systems using various methods, including kickstart and Puppet modules. Foreman also provides historical data for reporting, auditing, and troubleshooting.
				

	
      ⁠Katello
	
					Katello is a subscription and repository management application. It provides a means to subscribe to Red Hat repositories and download content. You can create and manage different versions of this content and apply them to specific systems within user-defined stages of the application life cycle.
				

	
      ⁠Candlepin
	
					Candlepin is a service within Katello that handles subscription management.
				

	
      ⁠Pulp
	
					Pulp is a service within Katello that handles repository and content management.
				

	
      ⁠Hammer
	
					Hammer is a CLI tool that provides command line and shell equivalents of most Web UI functions.
				

	
      ⁠REST API
	
					Red Hat Satellite 6 includes a RESTful API service that allows system administrators and developers to write custom scripts and third-party applications that interface with Red Hat Satellite.
				

	
      ⁠Capsule
	
					Red Hat Satellite Capsule Server acts as a proxy for some of the main Satellite functions including repository storage, DNS, DHCP, and Puppet Master configuration. Each Satellite Server also contains integrated Capsule Server services.
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      ⁠1.2. Red Hat Satellite 6 Layout and Topology




		The Red Hat Satellite infrastructure layout has to be considered prior to installing Red Hat Satellite 6. Determining the organization of your infrastructure helps align the Satellite Server and Satellite Capsule Servers to best serve your requirements. The following topology diagrams provide examples of infrastructure layout.
	

      ⁠[image: Single Satellite with Integrated Capsule]

Figure 1.2. Single Satellite with Integrated Capsule


		This topology demonstrates the basic use of Red Hat Satellite 6. In this example, there are five pools of hosts registered to the Satellite Server. Red Hat Satellite 6 categorizes these pools into three locations: United States, United Kingdom, and Japan. In addition, each department uses a distinct organization: Finance, Marketing, and Sales. All Satellite Server functions are shared among these Locations and Organizations.
	

      ⁠[image: Single Satellite with Integrated Capsule and Backup Capsules]

Figure 1.3. Single Satellite with Integrated Capsule and Backup Capsules


		This topology shows the addition of two backup Satellite Capsule Servers based in Boston. One Capsule Server caters to the three US-based offices: Phoenix, San Francisco, and Boston. The other caters to the international offices: London and Tokyo. Assigning one backup Capsule Server to the United States location and the other to the United Kingdom and Japan locations, the load reduces on the main Satellite Server and its integrated Capsule. As new offices are created in these locations, the Satellite Server can add them to their location categories and the Capsule Server services the new offices.
	

      ⁠[image: Remote Capsules Based on Location]

Figure 1.4. Remote Capsules Based on Location


		This topology assigns Satellite Capsule Servers to specific locations. The Satellite Server can create a hierarchy of locations; for example, having cities attached to a country. The Satellite Capsule Servers based in these locations are registered to the central Satellite Server in Boston and assigned to their respective locations. Each Capsule services all hosts in each respective location.
	

      ⁠[image: Remote Capsules Based on Location and Organization]

Figure 1.5. Remote Capsules Based on Location and Organization


		This topology demonstrates Satellite Capsule Servers assignment to organizations. For example, two Capsule servers are assigned to the Phoenix location, but to different organizations: one for Marketing and the other for Sales. Likewise, two Satellite Capsule Servers are assigned to two organizations: one for both the Sales and Marketing organizations in London, and the other for both the Sales and Marketing organizations in Tokyo. This shows how the combination of Satellite Server and associated Satellite Capsule Servers can manage the layout of multiple organizations in multiple locations working together.
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      ⁠1.3. Red Hat Satellite Server 6 Basic Configuration Workflow




      ⁠Prerequisites

			Before continuing with this workflow you must have successfully installed a Red Hat Satellite 6 Server and any additional required remote capsules. See the Red Hat Satellite 6 Server Installation Workflow in the Red Hat Satellite 6 Installation Guide for further information.
		

      ⁠Initial Configuration

			These are the initial procedures to configure a basic Red Hat Satellite Server:
		
	
				Log in to the Satellite Server. This requires the administration user and password. See Section 2.1, “Logging in to Red Hat Satellite” for more information.
			

				For information about changing the password, see Section 2.2, “Changing the Password in Red Hat Satellite”.
			

	
				Edit the Red Hat Satellite Integrated Capsule Server to select the desired organizations and locations. The name of the Satellite Integrated Capsule Server will be the same as the hostname of the server that Satellite 6 Server is installed on. See Section 3.1.3, “Editing an Organization” and Section 3.2.2, “Editing a Location” for more information.
			

	
				Edit the desired location to select the resources to be associated with that location. See Section 3.1, “Organizations” for more information.
			

	
				Edit the default organization to select the resources to be associated with that organization. See Section 3.2, “Locations” for more information.
			

	
				Refresh the Satellite Capsule Server. See Section 15.9, “Refreshing a Red Hat Satellite Capsule Server” for more information.
			




      ⁠Configuring a Red Hat Satellite Server

			These are the initial procedures to configure a basic Red Hat Satellite Server:
		
	
				Create a domain. See Section 11.3.1, “Domains” for more information.
			

	
				Create a subnet. See Section 11.3.2, “Subnets” for more information.
			

	
				Create the desired life cycle environments. See Section 3.3, “Life Cycle Environments” for more information.
			

	
				Create any desired custom products. See Section 4.2.2.1, “Creating a Product” for more information.
			

	
				Choose the desired Red Hat Repositories.
			
	
						Create a manifest from the Red Hat Customer Portal. See Section 4.2.1.1, “Setting up a Manifest” for more information.
					

	
						Upload the manifest in the Satellite Server web interface. This will propagate the subscription information into the Satellite Server. See Section 4.2.1.2, “Uploading a Subscription Manifest” for more information.
					

	
						Once the manifest has been uploaded, the Red Hat Repositories available from valid Red Hat Subscriptions are imported into the Satellite Server. Choose which repositories are relevant to your organization. See Section 4.2.1.2, “Uploading a Subscription Manifest” for more information.
					

	
						Optional: 
							
									Red Hat source repositories update content based on security errata, bug fixes, and enhancements. To ensure that the Satellite Server is updated automatically, Section 4.2.3.2, “Creating a Synchronization Plan” and Section 4.2.3.3, “Applying a Synchronization Schedule” are recommended practices.
								





					




	
				Manually synchronize content. See Section 4.2.3.1, “Synchronization Status” for more information.
			

	
				Create a content view with the desired repositories, puppet modules, and filters. Publish the content view then promote it to other life cycle environments as required. See Chapter 5, Using Content Views for more information.
			

	
				Optional:
			
	
						Create a host collection and assign it to the desired life cycle environment and content view. See Chapter 14, Configuring Host Collections for more information.
					




	
				Create an activation key assigning it to the desired life cycle environment and content view. See Section 9.1, “Creating an Activation Key” for more information.
			

	
				Edit an existing provisioning template and associate it with the previously created operating system. See Section 11.3.9, “Provisioning Templates” for more information.
			

	
				Edit the operating system created by default when creating the content view with the desired details and ensure it is associated with the desired partition table and provisioning template. See Section 11.3.7, “Operating Systems” for more information.
			

	
				Create a installation medium with the desired details. Ensure that the media is associated with the required locations and organizations. See Section 11.3.6, “Installation Media” for more information.
			

	
				Create a host group with the desired details. See Section 11.1, “Creating a Host Group” for more information.
			




      ⁠Creating a Backup of a Red Hat Satellite Server

			This is the procedure to create a backup of the Red Hat Satellite Server:
		
	
				Create a backup of the Satellite Server containing the required configuration files, data files, repositories, and databases. See the Section 18.1, “Backing up Red Hat Satellite” for more information.
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      ⁠Chapter 2. Accessing Red Hat Satellite




      ⁠2.1. Logging in to Red Hat Satellite




		After Red Hat Satellite has been installed and configured use the web user interface to log in to Satellite for further configuration.
	

		These steps show how to log in to Red Hat Satellite.
	
	
				Access the Satellite server using a web browser pointed to the following address:
			

				https://HOSTNAME/
			

				To identify your hostname, use the hostname command at the prompt:
			
# hostname
Important


					An untrusted connection warning appears on your web browser when accessing Satellite for the first time. Accept the self-signed certificate and add the Satellite URL as a security exception to override the settings. This procedure might differ depending on the browser being used.
				

					Only do this if you are sure that the Satellite URL is a trusted source.
				

      ⁠[image: Untrusted Connection Warning]

Figure 2.1. Untrusted Connection Warning




	
				Enter the user name and password created during the configuration process. If a user was not created during the configuration process, the default user name is admin.
			




      ⁠Result

			When you have successfully logged in, you are taken to the Satellite dashboard. The dashboard contains an overview of the Satellite and the hosts registered.
		

		The main navigation tabs are as follows:
	

      ⁠Table 2.1.  Navigation Tabs 
	 Navigation Tabs 	 Description 
	 Organization@Location 	 Clicking this tab changes the organization and location. If no organization or location is selected, the default organization is Any Organization and the default location is Any Location. Use this tab to change to different values. 
	 Monitor 	 Provides summary dashboards and reports. 
	 Content 	 Provides content management tools. This includes Content Views, Activation Keys, and Life Cycle Environments. 
	 Hosts 	 Provides host inventory and provisioning configuration tools. 
	 Configure 	 Provides general configuration tools and data including Host Groups and Puppet data. 
	 Infrastructure 	 Provides tools on configuring how Satellite 6 interacts with the environment. 
	 Administer 	 Provides advanced configuration for settings such as Users and RBAC, as well as general settings. 
	 User Name 	 Provides user administration where users can edit their personal information. 



Note


			If you have forgotten the administrative password, log on to the Satellite command-line interface to reset the administration user and password:
		

# foreman-rake permissions:reset
Reset to user: admin, password: qwJxBptxb7Gfcjj5


			This will reset the password of the default user admin to the one printed on the command line. Change this password upon logging in to prevent any security issues from occurring.
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      ⁠2.2. Changing the Password in Red Hat Satellite




		These steps show how to change your password.
	

      ⁠Procedure 2.1. Changing Password
	
				Click your user name at the top right corner.
			

	
				Select My Account from the menu.
			

	
				Type in a new password in the Password field.
			

	
				Type in the new password again in the Verify field.
			

	
				Click the Submit button to save your new password.
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      ⁠Chapter 3. Configuring Organizations, Locations and Life Cycle Environments




		Red Hat Satellite 6 takes a consolidated approach to Organization and Location management. System administrators define multiple Organizations and multiple Locations in a single Satellite server. For example, a company might have three Organizations (Finance, Marketing, and Sales) across three countries (United States, United Kingdom, and Japan). In this example, the Satellite server manages all Organizations across all geographical Locations, creating nine distinct contexts for managing systems. In addition, users can define specific locations and nest them to create a hierarchy. For example, Satellite administrators might divide the United States into specific cities, such as Boston, Phoenix, or San Francisco.
	

      ⁠[image: Example Topology for Red Hat Satellite 6. The Satellite server defines all locations and organizations. Each respective Satellite Capsule server synchronizes content and handles configuration of systems in a different location.]

Figure 3.1. Example Topology for Red Hat Satellite 6


		The main Satellite server retains the management function, while the content and configuration is synchronized between the main Satellite server and a Satellite Capsule assigned to certain locations.
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      ⁠3.1. Organizations




			Organizations divide hosts into logical groups based on ownership, purpose, content, security level, or other divisions.
		

			Multiple organizations can be viewed, created, and managed within the web interface. Software and host entitlements can be allocated across many organizations, and access to those organizations controlled.
		

			Each organization must be created and used by a single Red Hat customer account, however each account can manage multiple organizations. Subscription manifests can only be imported into a single organization and Satellite will not upload a certificate that has already been uploaded into a different organization.
		

			By default, Red Hat Satellite will have one organization already created, called Default Organization, which can be modified to suit your own installation, or deleted.
		
Important


				If a new user is not assigned a default organization their access will be limited. To grant the user systems rights, assign them a default organization and have them log out and log back in again.
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      ⁠3.1.1. Creating an Organization




		These steps show how to create a new organization.
	

      ⁠Procedure 3.1. Creating an Organization
	
				Click the Administer → Organizations menu on the top right hand corner.
			

	
				Click the New Organization button.
			

	
				Type in the name of the new organization in the Name field.
			

	
				Type in the label of the new organization in the Label field.
			

	
				Type in a description of the new organization in the Description field.
			

	
				Click the Submit button.
			

	
				Select the hosts to assign to the new organization.
			
	
						Click the Assign All button to assign all hosts with no organization to the new organization.
					

	
						Click the Manually Assign button to manually select and assign the hosts with no organization.
					

	
						Click the Proceed to Edit button to skip assigning hosts.
					







      ⁠Result:

			A new organization is created.
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      ⁠3.1.2. Creating an Organization Debug Certificate




		These steps show how to generate and download a debug certificate for an organization. Debug certificates unlock all content from an organization and are required for exporting provisioning templates.
	

      ⁠Procedure 3.2. Creating a New Organization Debug Certificate
	
				Click the Administer → Organizations menu on the upper right corner.
			

	
				Select an existing organization from the list on the left.
			

	
				Click the Generate and Download button. This generates a debug certificate. Save the certificate in a secure location.
			



Note


			Debug Certificates are automatically generated for provisioning template downloads if they do not already exist in the organization for which they are being downloaded.
		



      ⁠Result:

			Red Hat Satellite generates a debug certificate and saves it to a location of your choice.
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      ⁠3.1.3. Editing an Organization




      ⁠Procedure 3.3. Editing an Organization
	
				Click the Administer → Organizations menu on the top right hand corner.
			

	
				Click the name of the organization to be edited.
			

	
				Select the resource to edit from the list on the left.
			

	
				Click the name of the desired items to add them to the Selected Items list.
			

	
				Click the Submit button.
			




      ⁠Result

			The organization is updated and saved.
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      ⁠3.1.4. Removing an Organization




      ⁠Procedure 3.4. Removing an Organization
	
				Click the Administer → Organizations menu on the top right hand corner.
			

	
				Select Delete from the drop down menu to the right of the name of the organization you want to remove.
			

	
				An alert box appears:
			

				
Delete Organization Name?


			

	
				Click the OK button.
			




      ⁠Result

			The organization is removed from Red Hat Satellite.
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      ⁠3.2. Locations




			Locations divide organizations into logical groups based on geographical location.
		

			Each location must be created and used by a single Red Hat customer account, however each account can manage multiple locations and organizations.
		

			By default, Red Hat Satellite will have one location already created, called Default, which can be modified to suit your own installation, or deleted.
		
Important


				If a new user is not assigned a default location their access will be limited. To grant the user systems rights, assign them a default location and have them log out and log back in again.
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      ⁠3.2.1. Creating a Location




		These steps show how to create a location.
	

      ⁠Procedure 3.5. Creating a Location
	
				Click the Administer → Locations menu on the top right hand corner.
			

	
				Click the New Location button.
			

	
				Type in the name of the new location in the Name field and click the Submit button.
			

	
				Select the hosts to assign to the new location.
			
	
						Click the Assign All button to assign all hosts with no location to the new location.
					

	
						Click the Manually Assign button to manually select and assign the hosts with no location.
					

	
						Click the Proceed to Edit button to skip assigning hosts.
					







      ⁠Result:

			A location is created.
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      ⁠3.2.2. Editing a Location




      ⁠Procedure 3.6. Editing a Location
	
				Click the Administer → Locations menu on the top right hand corner.
			

	
				Click the name of the location to be edited.
			

	
				Select the resource to edit from the list on the left.
			

	
				Click the name of the desired items to add them to the Selected Items list.
			

	
				Click the Submit button.
			




      ⁠Result

			The location is updated and saved.
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      ⁠3.2.3. Removing a Location




		These steps show how to remove an existing location.
	

      ⁠Procedure 3.7. Removing a Location
	
				Click the Administer → Locations menu on the top right hand corner.
			

	
				Select Delete from the drop down menu to the right of the name of the location you want to remove.
			

				An alert box appears:
			

				
Delete Location Name


			

	
				Click the OK button.
			




      ⁠Result

			The location is removed from Red Hat Satellite.
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      ⁠3.3. Life Cycle Environments




			Application life cycles are divided into life cycle environments, which represent each stage of the application life cycle. Life cycle environments are linked to form an environment path. You can promote content along the environment path to the next life cycle environment when required. For example, if development ends on a particular version of an application, you can promote this version to the testing environment and start development on the next version.
		

      ⁠[image: An environment path containing four environments, including the base Library environment.]

Figure 3.2. An Environment Path Containing Four Environments
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      ⁠3.3.1. Creating Life Cycle Environments




				This procedure describes how to create a life cycle environment in Red Hat Satellite.
			

      ⁠Procedure 3.8. To Create a Life Cycle Environment:
	
						On the main menu, click Content → Life Cycle Environments and then click New Environment Path.
					

	
						Enter a name and label for the life cycle environment. The Description field is optional.
					

	
						Click Save to create the environment.
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      ⁠3.3.2. Promoting Content Views




				After you have created a content view and an environment path consisting of two or more life cycle environments, you can promote the content view from one environment to the next as required. This means that the most recent version of the content view that exists in a specified environment will be promoted, or copied, to the next environment in the life cycle environment path.
			

      ⁠Procedure 3.9. To Promote a Content View:
	
						On the main menu, click Content → Content Views.
					

	
						In the Name column, click the name of the content view that you want to promote.
					

	
						On the Versions tab, identify the latest version, and click Promote.
					

	
						Identify the promotion path where you want to promote the content view, select the appropriate life cycle environment, and click Promote Version.
					
Note


							You can only promote content views to the next environment in the promotion path. You cannot skip environments.
						



	
						After the promotion has completed, the Versions tab updates to display the new status of your content views.
					





      ⁠3.3.3. Removing Life Cycle Environments




				This procedure describes how to remove a life cycle environment from Red Hat Satellite.
			

      ⁠Procedure 3.10. To Remove a Life Cycle Environment:
	
						On the main menu, click Content → Life Cycle Environments.
					

	
						Click the name of the life cycle environment that you want to remove, and then click Remove Environment.
					

	
						In the confirmation dialog box, click Remove to remove the environment.
					



Note


					You can only delete the latest environment in an environment path. For example, if three environments exist in the order Library, Dev, and Prod, you need to delete Prod before you can delete Dev. You cannot delete the Library environment.
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      ⁠Chapter 4. Using Content Management




      ⁠4.1. Using the Red Hat Satellite Content Dashboard




      ⁠	
      ⁠The Satellite Content Dashboard
	
					The dashboard provides a status overview of the subscriptions and hosts currently registered, an overview of promotions and synchronization, and a list of the latest notifications.
				

					Satellite is used to manage entitlements for client machines. Each entitlement provides access to a specified number of certificates. Each certificate grants the right for the client machine to download, update, and receive support for a product.
				

					The dashboard is accessed by clicking the Monitor → Content Dashboard menu. The dashboard can be rearranged by clicking on a section title and dragging the section to another position.
				
	
      ⁠Content Host Subscription Status
	
								The Content Host Subscription Status gives an overview of the status of the subscriptions currently being managed by Satellite. A subscription is a purchased certificate that unlocks access to software, upgrades, and security fixes for hosts.
							

      ⁠Table 4.1. Host Subscription States
	 
												State
											

											 	 
												Description
											

											 	 
												Icon
											

											 
	 Invalid Subscriptions 	 
												Hosts that have products installed, but have not consumed a subscription. These hosts need attention immediately.
											

											 	 [image: red square]
											 
	 Insufficient Subscriptions 	 
												Hosts that have consumed a subscription and have a valid entitlement, but that are not consuming their full entitlements. These hosts should be monitored to ensure they are configured as expected.
											

											 	 [image: yellow triangle]
											 
	 Current Subscriptions 	 
												Hosts that have a valid entitlement and are consuming their full entitlements.
											

											 	 [image: green circle]
											 




	
      ⁠Latest Notifications
	
								All messages produced by the host are listed in the Latest Notifications section. This includes administration information, product and subscription changes, and any errors. Clicking on the cog button displays a drop down menu to change the number of notifications displayed. This can be set to 5 results, 15 results, or 30 results.
							

								This section should be monitored for global notifications sent to all users as well as to pick up any unusual activity or errors.
							

	
      ⁠Sync Overview
	
								An overview of all products or repositories enabled in Satellite and their Synchronization status. All products that are in the queue for synchronization, are unsynchronized or have been previously synchronized are listed in the Sync Overview section. Click a product name to view the synchronization status. Clicking on the cog button displays a drop down menu to change the number of notifications displayed. This can be set to 5 results, 15 results, or 30 results.
							

	
      ⁠Host Collections
	
								A list of all Host Collections in Satellite and their status, including the number of content hosts in each host collection. Click a host collection name to view that host collection. Clicking on the cog button displays a drop down menu to change the number of notifications displayed. This can be set to 5 results, 15 results, or 30 results.
							

	
      ⁠Current Subscription Totals
	
								An overview of the current subscription totals thats shows the number of active subscriptions, the number of subscriptions that expire in the next 120 days, and the number of subscriptions that have recently expired. Clicking on the number for each type of subscription will show a list of those subscriptions.
							

	
      ⁠Content Views Overview
	
								A list of all Content Views in Satellite and their publish status. Clicking on the cog button displays a drop down menu to change the number of notifications displayed. This can be set to 5 results, 15 results, or 30 results.
							

	
      ⁠Errata Overview
	
								A list of all errata in Satellite. Clicking on the cog button displays a drop down menu to change the number of notifications displayed. This can be set to 5 results, 15 results, or 30 results.
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      ⁠4.2. Connected Satellite




			Red Hat Satellite provides different types of content to subscribed client hosts. Content types include packages, errata updates, kickstart trees, and installation images.
		

			Satellite Server requires a source to provide this content. The content is configured by uploading a subscription manifest file to the Satellite. This file can be obtained through the Red Hat Customer Portal, or by contacting Red Hat Support. Manifests provide subscriptions to client hosts through the Red Hat Satellite rather than through Red Hat Network.
		

			This chapter outlines the process of populating your Red Hat Satellite Server, whether it is a connected Red Hat Satellite Server or a disconnected Red Hat Satellite Server, with the content it requires so client hosts can be subscribed to it and receive updates.
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      ⁠4.2.1. Using Red Hat Content Providers




      ⁠4.2.1.1. Setting up a Manifest




		A subscription manifest can be obtained through the method below or by contacting Red Hat Support. The manifest is used to set up Red Hat content providers and contains repository information and subscriptions. It is used as a basis of dispensing subscriptions and Red Hat Network (RHN) content to client systems from Red Hat Satellite.
	

      ⁠Prerequisites

			You must meet the following conditions before continuing with this task:
		
	
				A Customer Portal user name and password.
			

	
				Sufficient subscriptions to add to the manifest.
			




		These steps show how to obtain the subscription manifest from the Customer Portal:
	
	
				Log in to the Customer Portal.
			

	
				Click Subscriptions → Subscriptions Management → Subscriptions Management Applications and then click Satellite.
			

	
				On the upper right corner of the Subscriptions Management Applications page, click Register a Satellite.
			

	
				Create a name to distinguish your Satellite from the other Satellite systems in your account.
			

	
				Select 6.0 from the drop-down menu as the Satellite Version. It is important to select the correct version as each version requires a certain subset of packages.
			

	
				Click Register.
			

	
				Click Attach a subscription, add the subscriptions required for Red Hat Satellite, and then click Attach Selected. See How to generate a certificate for more information.
			

	
				Click Download manifest to generate an archive in .zip format that contains the manifest for Red Hat Satellite.
			




      ⁠Result:

			A subscription manifest is created and downloaded for Red Hat Satellite.
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      ⁠4.2.1.2. Uploading a Subscription Manifest




		This section describes how to upload a subscription manifest to an organization. Because subscription manifests are assigned to an organization, ensure you select an organization before you try to upload a subscription manifest. Failing to do so will cause a permission denied error (Error 403).
	

      ⁠Procedure 4.1. To Upload Subscription Manifest:
	
				Log in to the Satellite server.
			

	
				Click Any Context → Any Organization and select the organization that you want to assign the subscription manifest to.
			

	
				Click Content → Red Hat Subscriptions and then click Manage Manifest at the upper right of the page.
			

	
				In the Subscription Manifest section, click Actions and under the Upload New Manifest subsection, click Browse.
			

	
				Select the manifest file to upload, and then click Upload.
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      ⁠4.2.1.3. Enabling Red Hat Repositories




		The Red Hat Satellite manifest file provides access to Red Hat products and repositories. Because most products have several architectures and product versions, Red Hat Satellite Server allows the Satellite administrators to choose which repositories are required by their organizations. You need to enable the repositories in Red Hat Satellite Server to prepare them for synchronization.
	

      ⁠Procedure 4.2. To Enable Red Hat Repositories:
	
				On the main menu, click Content → Red Hat Repositories and then click the tab for the type of content that you want to enable.
			

	
				Click the product name for which you want to add repositories. This expands the list of available repository sets.
			

	
				Click each repository set from which you want to select repositories, and select the check box for each required repository. The repository is automatically enabled.
			
Important


					Ensure you enable the Satellite Tools repository. This repository provides the katello-agent and puppet-agent packages for clients registered to the Satellite Server.
				






		The following is an example set of subscriptions that contain repositories with the latest packages for Red Hat Enterprise Linux 6:
	
	
				Red Hat Enterprise Linux 6 Server Kickstart x86_64 6Server Repository
			

	
				Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server Repository
			

	
				Red Hat Enterprise Linux 6 Server - Satellite Tools RPMs x86_64 Repository
			




		Report a bug
	



      ⁠4.2.2. Using Products




      ⁠4.2.2.1. Creating a Product




		These steps show how to create a new product in Red Hat Satellite.
	

      ⁠Procedure 4.3. Creating a Product
	
				Click Content → Products.
			

	
				Click the + New Product link.
			

	
				Type in the name of the new product in the Name field.
			

	
				Type in label for the new product in the Label field.
			

	
				Select a GPG key from the GPG Key drop down menu.
			

	
				Select a synchronization plan from the Sync Plan drop down menu. Alternatively select the + New Sync Plan link to create a new synchronization plan.
			

	
				Type in a description of the new product in the Description field.
			

	
				Click the Save button to save your new product.
			




      ⁠Result:

			A new product is created.
		

		Report a bug
	


      ⁠4.2.2.2. Adding Repositories to a Product




		These steps show how to add repositories to a product in Red Hat Satellite.
	

      ⁠Procedure 4.4. Adding Repositories to a Product
	
				Click Content → Products.
			

	
				Click the product you wish to add a repository to.
			

	
				Click the Repositories subtab.
			

	
				Click the Create Repository button.
			

	
				Type in the name of the new repository in the Name field.
			

	
				Type in a label for the new repository in the Label field.
			

	
				Select the type of the repository from the Type drop down menu.
			

	
				Type in the URL of the repository in the URL field.
			

	
				Choose whether to publish the repository via HTTP by clicking the Publish via HTTP check box.
			

	
				Select a GPG key for the repository from the GPG Key drop down menu.
			

	
				Click the Create button to save your new repository.
			




      ⁠Result:

			A new repository is added to your product.
		

		Report a bug
	


      ⁠4.2.2.3. Using Bulk Actions for Products




		This section describes how to use bulk actions to synchronize or remove products in Red Hat Satellite. The procedure described here requires that at least one product be available.
	

      ⁠Procedure 4.5. To Perform Tasks on Multiple Products:
	
				Click Content → Products.
			

	
				Select the check box for the products you want to work with.
			

	
				Click Bulk Actions.
			

	
					
						To synchronize all selected products, click the Product Sync tab and then click Sync Now.
					


				 	
						To remove all selected products, click Remove Products and then click Remove.
					



			




      ⁠Updating Synchronization Plans

			You can also update the synchronization plans for multiple products at the same time.
		
	
				To create a new synchronization plan, click Create Sync Plan.
			

	
				To remove the synchronization plans from the selected products, click Unattach Sync Plan.
			

	
				To update the synchronization plans for the selected products, click Update Sync Plan.
			




		Report a bug
	


      ⁠4.2.2.4. Using Repository Discovery




		Repository discovery allows you to search a URL to discover repositories available there to include in a product.
	

      ⁠Procedure 4.6. Using Repository Discovery
	
				Click the Content → Products menu.
			

	
				Click the Repo Discovery button.
			

	
				Enter the URL where the repositories are located in the Yum Repo Discovery field.
			

	
				Click the Discover button.
			

	
				A list of the repositories at the URL is displayed under Results.
			

	
				Click the Discovered URLs check box for the repositories to be added to a product.
			

	
				Click the Create selected button.
			

	
				Choose whether to add the repositories to an existing product or create a new product.
			
	
						To add the repositories to an existing product:
					
	
								Select the Existing Product radio button.
							

	
								Select the required product from the drop down menu.
							



	
						To create a new product to add the repositories to:
					
	
								Select the New Product radio button.
							

	
								Enter the Name and Label for the new product and select a GPG Key from the drop down menu.
							





	
				Select the Serve via HTTP check box to serve the repository via HTTP.
			

	
				Edit the Name and Label for the Selected URLs.
			

	
				Click the Create button.
			




      ⁠Result:

			The repositories have been discovered and added to a product.
		

		Report a bug
	


      ⁠4.2.2.5. Removing a Product




		This section describes how to remove products from Red Hat Satellite.
	

      ⁠Procedure 4.7. To Remove a Product from Satellite:
	
				Click Content → Products.
			

	
				Select the check box next to the products you want to remove.
			

	
				Click Bulk Actions and then click Remove Products.
			

	
				Click Remove to confirm that you want to remove the products.
			




		Report a bug
	



      ⁠4.2.3. Synchronizing Content




				Synchronization is the act of coordinating updates between the Red Hat Satellite repositories and the source repositories being used. It is a required step after enabling repositories, in order to populate the Red Hat Satellite with content from the source repositories.
			

				Constant, scheduled synchronization will result in:
			
	
						Data integrity between packages
					

	
						Updated packages, security fixes, and errata
					




				Satellite's synchronization management capabilities allow organization administrators to create synchronization plans to configure how often a host should look for and install updates. Synchronization plans are then paired with the product repositories to come up with a synchronization schedule that will allow products to be updated at specific intervals that are convenient for the organization's network.
			

				Report a bug
			

      ⁠4.2.3.1. Synchronization Status



Important


			The manual synchronization of repositories is required after enabling them. It is at this point that the local repository in the Satellite is populated by the required packages.
		



		These steps show how to synchronize products in Red Hat Satellite.
	

      ⁠Procedure 4.8. Synchronize Products
	
				Click Content → Sync Status. Based on the subscriptions and repositories enabled, the list of product channels available for synchronization is displayed.
			

	
				Click the arrow next to the product name to see available content.
			

	
				Select the content you wish to synchronize.
			

	
				Click the Synchronize Now button to starting synchronizing. The status of the synchronization process will appear in the Result column. If synchronization is successful, Sync complete will appear in the Result column. If synchronization failed, Error syncing will appear.
			




      ⁠Result:

			A product is synchronized.
		
Note


			Content synchronization can take a long time. The length of time required is dependent on the speed of disk drives, network connection speed, and the amount of content selected for synchronization.
		



		Report a bug
	


      ⁠4.2.3.2. Creating a Synchronization Plan




		Regular, frequent synchronization is required to maintain data integrity between packages as well as making sure that packages are updated to the latest security fixes. Red Hat Satellite provides the ability to create scheduled synchronization plans that allow package updates at intervals convenient to the organization.
	

      ⁠Procedure 4.9. To Create a Synchronization Plan:
	
				Click Content → Sync Plans.
			

	
				Click the New Sync Plan link to create a new synchronization plan.
			

	
				Enter the Name, Description and other details for the plan.
			

	
				Click Save to create the synchronization plan.
			




		Report a bug
	


      ⁠4.2.3.3. Applying a Synchronization Schedule




		After you have created a synchronization plan, you need to associate products with that plan to create a synchronization schedule. The following procedure describes how to create a synchronization schedule in Red Hat Satellite 6.
	

      ⁠Procedure 4.10. To Create a Synchronization Schedule:
	
				Click Content → Sync Plans and select the synchronization plan you want to implement.
			

	
				Click Products → Add in the synchronization plan main page.
			

	
				Select the check box of the product to associate with the synchronization plan.
			

	
				Click Add Selected.
			




		Report a bug
	




      ⁠4.3. Disconnected Satellite




			In high security environments where hosts are required to function in a closed network, disconnected from the internet, the Red Hat Satellite Server can provision systems with the latest security updates, errata, and packages. This is achieved by using two important components: the katello-disconnected utility and a synchronization host.
		

			The diagram below illustrates how a disconnected Satellite is able to keep its content updated even without an internet connection. An intermediary system with an internet connection is needed to act as a synchronization host. This synchronization host is in a separate network from the Satellite server.
		

			The synchronization host imports content from the Red Hat Content Delivery Network (CDN) through pulp. The content is then exported onto a media, such as DVDs, CDs, or external hard drives and transferred to the disconnected Satellite server. The following sections in this chapter will guide you through the whole process.
		

      ⁠[image: Disconnected Satellite]

Figure 4.1. Disconnected Satellite


			Report a bug
		

      ⁠4.3.1. Configuring the Synchronization Host




      ⁠Prerequisites

			To import content from the Red Hat Content Distribution Network (CDN), the synchronization host requires:
		
	
				An Internet connection
			

	
				Valid Red Hat Network subscriptions
			

	
				A valid manifest (See Section 4.2.1.1, “Setting up a Manifest” for instructions on how to obtain one.)
			




      ⁠Procedure 4.11. To Configure a Host to Synchronize and Export Content from the Red Hat CDN: 
	
				Use Red Hat Subscription Manager to register the synchronization host to RHN.
			

	
				List all the available subscriptions to find the correct Red Hat Satellite product to allocate to your system:
			
# subscription-manager list --available --all

				This command displays output similar to the following:
			

+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+


ProductName:        Red Hat Satellite
ProductId:          SKU123456
PoolId:             e1730d1f4eaa448397bfd30c8c7f3d334bd8b
Quantity:           10
Multi-Entitlement:  No
Expires:            08/20/2013
MachineType:        physical

Note


					The SKU and Pool ID depend on the Red Hat Satellite product type that corresponds to your system version and product type.
				



	
				Subscribe to the pool using the following command:
			

# subscription-manager subscribe --pool=Red_Hat_Satellite_Pool_Id
# subscription-manager subscribe --pool=Red_Hat_Enterprise_Linux_Pool_Id
# subscription-manager subscribe --pool=Red_Hat_Enterprise_Linux_Software_Collections_Pool_Id


	
				Disable all existing repositories:
			

# subscription-manager repos --disable "*"


	
				Enable the Red Hat Satellite and Red Hat Enterprise Linux and Red Hat Software Collections repositories. Ensure the Red Hat Enterprise Linux repository matches the specific version you are using.
			

# subscription-manager repos --enable rhel-6-server-rpms \
--enable rhel-server-rhscl-6-rpms \
--enable rhel-6-server-satellite-6.0-rpms

Note


					The commands above are based on Red Hat Enterprise Linux 6. If you are using a different version of Red Hat Enterprise Linux, change the repository based on your specific version.
				



	
				Install katello-utils and associated RPMs:
			

# yum install python-qpid-qmf python-qpid  qpid-cpp-server katello-utils


				katello-utils includes the katello-disconnected utility that is required to set up repositories for import while qpid related packages are necessary for pulp configuration.
			

	
				Generate a secret 32-character alphanumeric string for the oauth_secret entry in the /etc/pulp/server.conf file:
			
# tr -dc "[:alnum:]" < /dev/urandom | head -c 32
randomly_generated_value

	
				In the /etc/pulp/server.conf, uncomment the [oauth] entry and add the randomly generated value from the previous step as the oauth_secret value:
			

[oauth]
enabled: true
oauth_key: katello
oauth_secret: randomly_generated_value

	
				Disable authentication in /etc/qpid/qpidd.conf:
			

# Configuration file for qpidd. Entries are of the form:
#   name=value
#
# (Note: no spaces on either side of '=').
# Run "qpidd --help" or see "man qpidd" for more details.

auth=no


				All incoming connections authenticate using the Satellite's default realm.
			

	
				Configure the connection from katello-disconnected to Pulp with the previously generated value as your --oauth-secret option:
			

# katello-disconnected setup --oauth-key=katello --oauth-secret=randomly_generated_value

				This places a configuration value in ~/.katello-disconnected.
			

	
				Configure Pulp on the Synchronization Server:
			

sudo service qpidd start
sudo chkconfig qpidd on
sudo service mongod start
sleep 10
sudo chkconfig mongod on
sudo -u apache pulp-manage-db
sudo service httpd restart
sudo chkconfig pulp_workers on
sudo service pulp_workers start
sudo chkconfig pulp_celerybeat on
sudo service pulp_celerybeat start
sudo chkconfig pulp_resource_manager on
sudo service pulp_resource_manager start


	
				Import the manifest:
			

# katello-disconnected import -m ./manifest.zip


				Importing the manifest sets up the list of available repositories to synchronize to based on the subscriptions you selected.
			




		The synchronization host is now ready to synchronize content from the Red Hat CDN.
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      ⁠4.3.2. Synchronizing Content




		By default, katello-disconnected enables all repositories that are included in the manifest for synchronization. Synchronization time is directly related to the amount of repositories to be synchronized. If the manifest has a large amount of repositories, the synchronization will take time and network resources.
	

		katello-disconnected allows for the synchronization of specific repositories. This section will set up Pulp for synchronizing content.
	
	
				Disable all repositories:
			

# katello-disconnected disable --all


				katello-disconnected enables all repositories by default.
			

	
				Choose which repositories you wish to sync by listing all available repositories from the manifest:
			

# katello-disconnected list --disabled
rhel-5-server-debug-rpms-5Server-i386
rhel-5-server-debug-rpms-5Server-ia64
rhel-5-server-debug-rpms-5Server-x86_64
rhel-5-server-debug-rpms-5_7-i386
rhel-5-server-debug-rpms-5_7-ia64
rhel-5-server-debug-rpms-5_7-x86_64
rhel-5-server-debug-rpms-5_8-i386
rhel-5-server-debug-rpms-5_8-ia64
rhel-5-server-debug-rpms-5_8-x86_64
rhel-5-server-debug-rpms-5_9-i386
rhel-5-server-debug-rpms-5_9-ia64
rhel-5-server-debug-rpms-5_9-x86_64
rhel-5-server-isos-5Server-i386


	
				Enable the chosen repositories for synchronization:
			

# katello-disconnected enable -r rhel-6-server-sam-rpms-6_4-x86_64


	
				Create the repositories and push them to Pulp to allow synchronization:
			

# katello-disconnected configure

Note


					The configure option for katello-disconnected reads the manifest, creates pulp repositories, and generates scripts before synchronization. It needs to be run each time a repository is enabled or disabled.
				



	
				Synchronize the repositories:
			

# katello-disconnected sync


				You can use the watch option to monitor the synchronization process.
			

# katello-disconnected watch
Watching sync... (this may be safely interrupted with Ctrl+C)
running:
rhel-6-server-sam-rpms-6_4-x86_64 

running:
rhel-6-server-sam-rpms-6_4-x86_64 
...
finished:
rhel-6-server-sam-rpms-6_4-x86_64 


Watching finished





		Content is now synchronized.
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      ⁠4.3.3. Exporting Content




      ⁠Prerequisites

			An external export media such as a CD, DVD, or external hard drive.
		

			The synchronized content needs to be exported to enable importing into the disconnected Red Hat Satellite. To do so:
		
	
				Export the synchronized repositories:
			

# katello-disconnected export -t /var/tmp/export


				The output will look similar to:
			


# katello-disconnected export -t /var/tmp/export
# katello-disconnected watch
Watching sync... (this may be safely interrupted with Ctrl+C)
running:
rhel-6-server-sam-rpms-6_4-x86_64

finished:
rhel-6-server-sam-rpms-6_4-x86_64
Watching finished
Done watching ...
 Copying content to /var/tmp/export
 Archiving contents of /var/tmp/export into 4600M tar archives.
 NOTE: This may take a while.
tar: Removing leading `/' from member names

Done exporting content, please copy /var/tmp/export/* to your disconnected host


				This operation will create the following files in /var/tmp/export:
			

# ls /var/tmp/export/
content-export-00 content-export-01 content-export-02 expand_export.sh


	
				Copy the files from /var/tmp/export into the external media.
			
Note


					If the files are too big for your external media, the files can be copied sequentially in a series of DVDs.
				






		The synchronized content has now been exported and ready for importing to the disconnected Satellite server.
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      ⁠4.3.4. Importing Content to a Disconnected Satellite Server




      ⁠Prerequisites

			Ensure that the directory and file system containing the exports has enough space to contain the extracted archives. For example, if your export is 40 GB, the disconnected Satellite Server directory and file system where you are importing the content will need an extra 40 GB of space to expand it on the same file system.
		
	
				Copy ALL of the Satellite Content ISOs to a directory that the Satellite can access. This example uses /root/isos.
			

	
				Create a local directory that will be shared via httpd on the Satellite. This example uses /var/www.html/sat-import/.
			

				

# mkdir -p /var/www/html/sat-import/



			

	
				Recursively copy the contents of the first ISO to the local directory:
			

				

# mount -o loop /root/isos/first iso /mnt/iso
# cp -ruv /mnt/iso/* /var/www/html/sat-import/
# umount /mnt/iso



			

	
				Repeat the above step for each ISO until you have copied all the data from the series of ISOs into the local directory /var/www/html/sat-import/.
			

	
				Ensure that the SELinux contexts is correct:
			

# restorecon -rv /var/www/html/sat-import/


	
				Change the CDN URL to reference the loaction that the ISOs were copied to. This example uses the Satellite fully qualified domain name (FQDN) server.example.com, so the URL is:
			

http //server.example.com/sat-import/

Note


					The Satellite is now acting as its own CDN with the files located in http://localhost/content. This is not a requirement. The CDN can be hosted on a different machine inside the same disconnected network as long as it is accessible to the Satellite server via HTTP.
				



	
				Add the CDN address to the Satellite web interface:
			
	
						Log in to the Satellite web interface.
					

	
						Click Content → Red Hat Subscriptions and then click Manage Manifest.
					

	
						On the Subscription Manifest information screen, scroll to Red Hat Provider Details. Click the edit icon on the Repository URL entry and change the entry to the CDN's repository URL.
					

	
						Click Browse to choose the manifest file.
					

	
						Click Upload to import your manifest.
					



	
				Enable the repositories from the local CDN:
			
	
						Click Content → Red Hat Repositories
					

	
						Enable the repositories that were enabled and synchronized in the Synchronizing Content section.
					



	
				Click Content → Sync Status.
			

	
				Select the repositories you want to synchronize and click Synchronize Now.
			




		Once the synchronize finishes, the disconnected Satellite is now ready to serve the content to client systems.
	

		Report a bug
	




      ⁠Chapter 5. Using Content Views




		Content views are managed selections of content, which contain one or more repositories (yum / puppet) with optional filtering. These filters can be either inclusive or exclusive, and tailor a system view of content for life cycle management. They are used to customize content to be made available to client systems.
	

      ⁠[image: This diagram details the creation of new versions of a Content View. These content view versions are promoted along an environment path during the application life cycle.]

Figure 5.1. This diagram details the creation of new versions of a Content View. These content view versions are promoted along an environment path during the application life cycle.


		Published content views are used with life cycle environments.
	

		Report a bug
	

      ⁠5.1. Creating a Content View




		A user with administrator privileges creates content views for use within the life cycle environments. To create a content view:
	


		
	
				Log in as a Satellite administrator.
			

	
				Click Content → Content Views.
			

	
				Click Create New View.
			

	
				Fill in the following fields:
			
	
						Name
					

	
						Label - this field is automatically populated when the Name field is filled out.
					

	
						Description
					




	
				Select the Composite View check box to combine a series of published content views into one and choose which content view.
			
Note


					If you select Composite View it will override any filtering and allow you to choose a group of published content views and bundle those views into a composite one.
				



	
				Click Save.
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      ⁠5.2. Adding Repositories to the Content View




		A Repository provides storage for a collection of content. For example, a YUM repository, Puppet repository, or a Docker repository. Perform the following steps to associate a repository with a specific content view:
	
	
				Click Content → Content Views and choose the Content View to add repositories to.
			

	
				Depending on the type of content you wish to store:
			
	
						Click Yum Content and select Repositories from the drop down menu. From the submenu, click Add.
					

	
						Click Puppet Modules and click Add New Module.
					

	
						Click Docker Content and click Add in the submenu.
					




	
				Select the repositories to add. Once all the intended repositories have been selected, click +Add Repositories.
			




		Repositories have now been added to the Content View.
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      ⁠5.3. Filtering Content




			Filters are created to prevent packages from being promoted to subsequent environments. Package names or regular expressions are added to the filter to create the rules to blacklist packages and the filter is then associated to entire products or individual repositories within any product.
		

      ⁠5.3.1. Creating a Filter




		These steps show how to create a filter.
	

      ⁠Procedure 5.1. Creating a Filter
	
				Click Content → Content Views.
			

	
				Select the Content View you wish to filter.
			

	
				Click the Content → Filters subtab.
			

	
				Click on the +New Filter button.
			

	
				Type in the name of the new filter in the Name field.
			

	
				Choose a content type from the Content Type drop down menu.
			

	
				Choose whether the filter includes or excludes the selected content type by selecting the Type drop down menu.
			

	
				Optionally, enter a description in the Description field.
			

	
				Click the Save button to save your new filter.
			




      ⁠Result:

			A filter is created.
		

		Report a bug
	


      ⁠5.3.2. Adding Content to a Filter




      ⁠Prerequisites

			Requires a created Filter.
		
	
				Click Content → Content Views.
			

	
				Select the Content View you wish to filter.
			

	
				Click the Content → Filters subtab.
			

	
				Click a created package filter's name. Depending on the type of filter selected, the readout will be different.
			
	
						If the filter is made for Packages:
					
	
								Enter a package name and select a Detail value from the dropdown menu. Click +Add to add the package to the filter.
							

	
								Under the Affected Repositories subtab, choose whether the filter will affect all or a subset of repositories. If you choose a subset of repositories, then choose the desired repositories and click Update Repositories.
							



	
						If the filter is made for package groups:
					
	
								Click on the Add subtab, and choose the desired package group. Click the +Add Package Group button.
							

	
								Under the Affected Repositories subtab, choose whether the filter will affect all or a subset of repositories. If you choose a subset of repositories, then choose the desired repositories and click the Update Repositories button.
							



	
						If the filter is made for Errata:
					
	
								Click on the Add subtab. Check the desired boxes for the Errata type, whether is be Security, Enhancement, or Bugfix. Then choose a start date and end date. Click the +Add Errata button.
							

	
								Under the Affected Repositories subtab, choose whether the filter will affect all or a subset of repositories. If you choose a subset of repositories, then choose the desired repositories and click the Update Repositories button.
							



	
						If the filter is made for Errata - Date and Type:
					
	
								Under the Erratum Date Range subtab, check the desired boxes for the Errata type, whether is be Security, Enhancement, or Bugfix. Then choose a start date and end date. Click the Save button.
							

	
								Under the Affected Repositories subtab, choose whether the filter will affect all or a subset of repositories. If you choose a subset of repositories, then choose the desired repositories and click the Update Repositories button.
							





	
				Click the Publish New Version button. Enter a comment if desired, then click the Save button.
			




      ⁠Result

			Packages are added to the filter.
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      ⁠5.3.3. Removing Content from a Filter




      ⁠Prerequisites

			Requires a created Filter.
		
	
				Click Content → Content Views.
			

	
				Select the Content View you wish to filter.
			

	
				Click the Content → Filters subtab.
			

	
				Click a created package filter's name. Depending on the type of filter selected, the readout will be different.
			
	
						If the filter is made for Packages:
					
	
								Click the Packages subtab then click the Package Name checkbox next to the package to remove. Click the Remove Packages button to remove the package from the filter.
							

	
								Under the Affected Repositories subtab, choose whether the filter will affect all or a subset of repositories. If you choose a subset of repositories, then choose the desired repositories and click the Update Repositories button.
							



	
						If the filter is made for package groups:
					
	
								Click the List/Remove subtab then click the Name checkbox next to the package group to remove. Click the Remove Package Group button to remove the package group from the filter.
							

	
								Under the Affected Repositories subtab, choose whether the filter will affect all or a subset of repositories. If you choose a subset of repositories, then choose the desired repositories and click the Update Repositories button.
							



	
						If the filter is made for Errata:
					
	
								Click the List/Remove subtab then click the Errata ID checkbox next to the errata to remove. Click the Remove Errata button to remove the errata from the filter.
							

	
								Under the Affected Repositories subtab, choose whether the filter will affect all or a subset of repositories. If you choose a subset of repositories, then choose the desired repositories and click the Update Repositories button.
							



	
						If the filter is made for Errata - Date and Type:
					
	
								Under the Erratum Date Range subtab, check the desired boxes for the Errata type, whether is be Security, Enhancement, or Bugfix. Then edit the start date and end date. Click the Save button.
							

	
								Under the Affected Repositories subtab, choose whether the filter will affect all or a subset of repositories. If you choose a subset of repositories, then choose the desired repositories and click the Update Repositories button.
							





	
				Click the Publish New Version button. Enter a comment if desired, then click the Save button.
			




      ⁠Result

			Packages are removed from the filter.
		

		Report a bug
	


      ⁠5.3.4. Removing a Filter




		These steps show how to remove a filter.
	

      ⁠Procedure 5.2. Remove a Filter
	
				Click Content → Content Views.
			

	
				Select the Content View you wish to filter.
			

	
				Click the Content → Filters subtab.
			

	
				Click the checkbox next to the name of the package filter you wish to remove.
			

	
				Click the Remove Filters button.
			




      ⁠Result:

			A filter is removed.
		

		Report a bug
	



      ⁠5.4. Publishing a Content View




		Once a content view has been created, it needs to be published in order for it to be visible and usable by hosts. Before publishing the content view definition, make sure that the content view definition has the necessary products, repositories and filters.
	

		To publish a content view definition:
	
	
				Click Content → Content Views.
			

	
				Click on the content view to be published.
			

	
				Click the Publish New Version button.
			

	
				Fill in a comment.
			

	
				Click the Save button.
			




		A published content view is now available.
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      ⁠Chapter 6. Searching for Content




      ⁠6.1. Basic Content Search




		Content Search allows users to look for specific information about content views, products, repositories, or errata.
	

      ⁠Procedure 6.1. To Perform a Content Search:
	
				Click Content → Content Search.
			

	
				Select either Content Views, Products, Repositories, Packages, Errata, or Puppet Modules from the Content drop-down menu.
			

	
				Enter the name of the content view, product, repository, package, errata, or puppet module you are searching for in the Products field, and click Search.
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      ⁠6.2. Content Comparison across Environments




		You can compare content across different environments using the content search feature.
	

      ⁠Procedure 6.2. To Search for and Compare Content Across Different Environments:
	
				Click Content → Content Search.
			

	
				Select the entity type that you want to compare from the Content drop-down menu.
			

	
				Enter the name of the entity in the Products field and click Add.
			

	
				On the right panel, move your cursor over the "plus" (+) icon, select the environments you want to compare, and click Search.
			

	
				Select either Union, Intersection, or Difference from the View drop-down menu to filter your results.
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      ⁠Chapter 7. Viewing and Applying Errata




		Software packages in Red Hat products are subject to updates, referred to as errata, that are released at regular intervals as well as asynchronously. Red Hat Satellite provides tools to inspect and filter errata, allowing for precise update management. This way, you can select relevant updates and propagate them through content views to selected content hosts. See Chapter 5, Using Content Views) for more information on content views.
	

		To apply the latest updates, make sure you have correctly synchronized the Satellite content. For more information on synchronizing content, see Section 4.2.3, “Synchronizing Content” for a connected Satellite and Section 4.2.3, “Synchronizing Content” for a disconnected Satellite. Navigate to Monitor → Content Dashboard to see the overview of errata synchronization.
	

		Errata contain advisories that describe the changes introduced by the update. There are three types of advisories (in order of importance):
	
	
				Security Advisory describes fixed security issues found in the package. The security impact of the issue can be Low, Moderate, Important, or Critical.
			

	
				Bug Fix Advisory describes bug fixes for the package.
			

	
				Product Enhancement Advisory describes enhancements and new features added to the package.
			



Note


			Errata are labeled according to the most important advisory type they contain. Therefore, errata labeled as Product Enhancement Advisory can contain only enhancement updates, while Bug Fix Advisory errata can contain both bug fixes and enhancements, and Security Advisory can contain all three types.
		



		In Red Hat Satellite, two keywords describe errata with regard to their relationship to the available content hosts:
	
	
				Applicable: errata applies to one or more content hosts, which means it updates packages present on the content host. Applicable errata are not yet accessible by the content host.
			

	
				Installable: errata applies to one or more content hosts and it has been made available to the content host. Installable errata are present in the content host’s life cycle environment and content view, but are not yet installed. This way, errata can be installed by users that have permissions to manage content hosts, but are not entitled for errata management at higher levels.
			




      ⁠7.1. Inspecting Available Errata




			The following procedure describes how to view and filter the available errata and how to display metadata of the selected advisory.
		

      ⁠Procedure 7.1. To Inspect Available Errata:
	
					Navigate to Content → Errata to view the list of available errata.
				

	
					Use the filtering tools on the top of the page to limit the number of displayed errata:
				
	
							Select the repository to be inspected from the drop-down list. All Repositories is selected by default.
						

	
							The Applicable check box is selected by default to view only errata applicable to the selected repository. Select the Installable check box to view only errata marked as installable.
						

	
							To search the table of errata, type the query in the Search field in the form of:
						
parameter operator value

							See Table 7.1, “Parameters Available for Errata Search” for the list of parameters available for search, find the list of applicable operators in Table 16.2, “Supported Operators for Granular Search”. Automatic suggestion works as you type, you can also combine queries with the use of and and or operators. For example, to display only security advisories related to the kernel package, type:
						
type = security and package_name = kernel

							Press Enter to start the search.
						




	
					Click Errata ID of the errata you want to inspect:
				
	
							The Details tab contains the description of the updated package as well as documentation of important fixes and enhancements provided by the update.
						

	
							On the Content Hosts tab, you can apply the errata to selected content hosts as described in Section 7.2, “Applying Errata to Content Hosts”.
						

	
							The Repositories tab lists repositories that already contain the errata. You can filter repositories by the environment and content view, and search for them by the repository name.
						







      ⁠Table 7.1. Parameters Available for Errata Search
	Parameter	Description	Example
	 bug 	 Search by the Bugzilla number. 	 bug = BZ#1172165 
	 cve 	 Search by the CVE number. 	 cve = CVE-2015-0235 
	 id 	 Search by the errata ID. The auto-suggest system displays a list of available IDs as you type. 	 id = RHBA-2014:2004 
	 issued 	 Search by the issue date. You can specify the exact date, like "Feb 16,2015", or use keywords, for example "Yesterday", or "1 hour ago". The time range can be specified with the use of the "<" and ">" operators. 	 issued < "Jan 12,2015" 
	 package 	 Search by the full package build name. The auto-suggest system displays a list of available packages as you type. 	 package = glib2-2.22.5-6.el6.i686 
	 package_name 	 Search by the package name. The auto-suggest system displays a list of available packages as you type. 	 package_name = glib2 
	 severity 	 Search by the severity of the issue fixed by the security update. One of Critical, Important, Moderate. 	 severity = Critical 
	 title 	 Search by the advisory title. 	 title ~ openssl 
	 type 	 Search by the advisory type. Specify security, bugfix, or enhancement. 	 type = bugfix 
	 updated 	 Search by the date of the last update. You can use the same formats as with the issued parameter. 	 updated = "6 days ago" 





      ⁠7.2. Applying Errata to Content Hosts




			The following procedures show how to apply one or more errata to content hosts.
		

      ⁠Procedure 7.2. To Apply a Single Errata to Content Hosts:
	
					Navigate to Content → Errata to view the list of available errata.
				

	
					Click Errata ID of the errata you want to apply.
				

	
					On the Content Hosts tab, select one or more content hosts to be updated. You can filter the available content hosts by the environment, and search for them by name. If you select the check box on the top of the page, only the content hosts that already have the installable errata in their life cycle environment are displayed.
				

	
					Click Apply to Hosts.
				
	
							If the errata is applicable, a new minor version of the content view is created. If you select Apply Errata to Content Hosts Immediately after publishing, Satellite will automatically install errata on the content host when promoting the updated content view. Otherwise, errata will be made available for installation on the content host. Installable errata can be applied later using the same procedure, or manually per content host as described in Procedure 7.4, “Applying Installable Errata to a Content Host”.
						

	
							If the errata is installable, which means it is already present on selected content hosts but was not installed yet, no new content view version is created.
						




	
					Click Confirm.
				
	
							If the errata is applicable, a new task is started for the update procedure. After the task is completed successfully, you can investigate the updated content host at Host → Content Hosts.
						

	
							If the errata is installable, it is installed on selected content hosts. You can investigate the updated content host at Host → Content Hosts.
						







      ⁠Procedure 7.3. To Apply Multiple Errata to Content Hosts:
	
					Navigate to Content → Errata to view the list of available errata.
				

	
					Select errata you want to apply by selecting the check box to the left of the Errata ID field.
				

	
					Click Apply Errata to apply all selected errata.
				

	
					Select one or more content hosts to be updated. You can filter the available content hosts by the environment, and search for them by name. If you select the check box on the top of the page, only content hosts that already have the installable errata in their life cycle environment are displayed.
				

	
					Click Next. If some of the selected errata are applicable, a new minor version of the content view is created. If you select Apply Errata to Content Hosts Immediately after publishing, Satellite will automatically install errata on the content host when promoting the updated content view. If all selected errata are installable, they are installed without creating a new content view version.
				




      ⁠Procedure 7.4. Applying Installable Errata to a Content Host

				If the content host's life cycle environment contains installable errata, you can install them from the Content Hosts page. This way, errata can be applied by users that have permissions to manage content hosts, but are not entitled for errata management at higher levels.
			
	
					Navigate to Hosts → Content Hosts
				

	
					Click the name of the content host you want to manage.
				

	
					On the Errata tab, select advisories you want to install.
				

	
					Click Apply Selected to install the selected updates.
				





      ⁠7.3. Subscribing to Errata Notifications




			The following procedure shows how to configure email notifications about errata.
		

      ⁠Procedure 7.5. To Configure Errata Notifications:
	
					Navigate to Administer → Users.
				

	
					Click user name of the user you want to edit.
				

	
					On the Mail Preferences tab, select Mail enabled to enable updates.
				

	
					Select the type of notifications the user will receive. The following notification types are relevant to errata management:
				
	
							Satellite host advisory is a summary of applicable and installable errata for hosts managed by the user. Choose the frequency of emails from the drop-down list that offers daily, weekly, or monthly updates.
						

	
							Satellite promote errata is a notification sent only after a content view promotion. It contains a summary of errata applicable and installable to hosts registered to the promoted content view. This allows you to monitor what updates have been applied to which hosts. To enable these notifications, select Subscribe from the drop-down menu.
						

	
							Satellite sync errata is a notification sent only after synchronizing a repository. It contains a summary of new errata introduced by the synchronization. To enable these notifications, select Subscribe from the drop-down menu.
						




	
					Click Submit.
				




			Report a bug
		



      ⁠Chapter 8. Working with Containers




		Docker is an open source project that automates the deployment of applications inside Linux Containers, and provides the capability to package an application with its runtime dependencies into a container. Linux containers enable rapid application deployment, simpler testing, maintenance, and troubleshooting while improving security. For more information see Get Started with Docker Formatted Container Images on Red Hat Systems on the Red Hat Customer Portal.
	

		A container in the Docker format is composed of the following parts:
	
	
				Container (in the narrow sense of the word) is an application sandbox. Each container is based on an image that holds necessary configuration data. When you launch a container from an image, a writable layer is added on top of this image. Every time you commit a container a new image layer is added to store your changes.
			

	
				Image is a static snapshot of the containers' configuration. Image is a read-only layer that is never modified, all changes are made in top-most writable layer, and can be saved only by creating a new image. Each image depends on one or more parent images.
			

	
				Platform image an image that has no parent. Platform images define the runtime environment, packages and utilities necessary for containerized applications to run. The platform image is read-only, so any changes are reflected in the copied images stacked on top of it. See Get Started with Docker Formatted Container Images on Red Hat Systems for information on how to access Red Hat Enterprise Linux platform images. See Example 8.1, “Creating a Red Hat Enterprise Linux Container in Satellite”.
			

	
				Registry is a public or private archive that contains images available for download. Some registries allow users to upload images to make them available to others. Red Hat Satellite allows you to import images from local and external registries. Satellite itself can act as an image registry for hosts, however, hosts cannot push changes back to the registry. For more information, see Section 8.1.1, “Creating a New Container”
			

	
				Tags are added to images to differentiate them from similar images in a repository. In practice, they typically mark versions of the application inside the image. Repositories are used to group similar images together in a container registry. Images only have unique alphanumeric identifiers, so repositories provide a way to name images (by using tags). Naming in form or repository:tag is a human-readable way of identifying images. See Section 8.5, “Using Tags”, or Section 8.2, “Working with Repositories” for details.
			




		With Red Hat Satellite, you can create an on premise registry, import images from various sources and distribute them to containers using content views. Satellite provides a Docker compute resource, that acts as a server for running containers. This way, you can import an image, start a container based on this image, monitor the container's activity, and commit it's state to a new image layer that can be further propagated. For more information on loading images to a content view, see Section 5.2, “Adding Repositories to the Content View”.
	

      ⁠8.1. Managing Containers




			The following sections show how to create, view, start, stop, and commit a container.
		

      ⁠8.1.1. Creating a New Container




				In Red Hat Satellite, you can deploy containers only on a compute resource of the Docker provider type. Therefore, when attempting to view or create containers for the first time, you are prompted to create the Docker compute resource. To do so, follow the steps described in Section 11.3.4, “Compute Resources”.
			

				Once there is at least one Docker compute resource present on your Satellite, you can create and view containers. To create a new container, follow the steps described in Procedure 8.1, “Creating a Container”. For instructions on how to investigate the already created containers, see Section 8.1.2, “Investigating Containers”.
			

				To create a container, you first have to import an image, which can be a platform image, or a previously created layered image. Satellite supports the following image sources:
			
	
						Local content: represented by the Satellite option when creating a container. This option allows you to import an image from a repository that is already present on a capsule server in a certain content view and life cycle environment. For more information on how to create and populate a local registry, see Section 8.2, “Working with Repositories”.
					

	
						Docker Hub: allows you to search the Docker Hub registry and pull images from there. Make sure that you pull only trusted images with verified content.
					

	
						External Registry: allows you to import images from a previously created external registry. For more information on creating registries in Red Hat Satellite, see Section 8.3, “Adding an External Registry”.
					



Note


					Note that you can not change the container configuration once the container is created. To alter the configuration, you have to create a replacement container with modified settings as described in Procedure 8.1, “Creating a Container”. Therefore, make sure that containers can be easily replaced in your workflow.
				



      ⁠Procedure 8.1. Creating a Container
	
						Navigate to Containers → New Container. Alternatively, navigate to Containers → All Containers and click New container.
					

	
						In the Preliminary stage of container creation configure the following settings:
					
	
								On the Compute resource tab, select the compute resource from the Deployed on drop-down menu. See Section 11.3.4, “Compute Resources” for more information on compute resources.
							

	
								On the Locations tab, select the locations where the new container will be available.
							

	
								On the Organizations tab, select the organizations where the new container will be available.
							




						Click Next to proceed.
					

	
						In the Image stage of container creation import an image that will act as a base for your container. This can be a platform image, or a previously created layered image. Select from one of the following options:
					
	
								Select the Satellite tab to import an image from a life cycle environment. Specify the life cycle environment, content view, repository, tag, and Capsule Server.
							

	
								Select the Docker hub tab to import an image from the Docker Hub registry. Once you type an image name to the Search field, Satellite automatically searches the compute resource first. Click the looking glass icon to search the Docker Hub. If the image is found, Satellite displays the image metadata and populates the Tag field with tags available for the selected image name.
							

	
								Select the External registry tab to import an image from an existing registry. Select the registry from the drop-down menu, and search it by the image name. Satellite populates the Tag field with tags available for the selected image name. See Section 8.3, “Adding an External Registry” for details.
							




						Click Next to proceed.
					

	
						In the Configuration stage of container creation set the following parameters:
					
	
								Select a name for the container.
							

	
								Specify a command to run inside the container.
							

	
								Specify an entrypoint, which is a command that is executed automatically as soon as the container starts. The default entrypoint is /bin/sh -c.
							

	
								Assign CPUs to the container. For example, 0-2,16 represents CPUs 0, 1, 2, and 16.
							

	
								Define the relative share of CPU time for the container.
							

	
								Specify a memory limit for the container. For example, 512m limits the container memory usage to 512 MB.
							




						Click Next to proceed.
					

	
						In the final stage of container creation named Environment, select if you want to allocate a pseudo-tty, attach STDIN, STDOUT, and STDERR to the container. Click Add environment variable to create a custom environment variable for the container.
					

	
						Click Submit to create the container.
					




				After creating a container, Satellite displays a summary of container metadata. By default, the newly created container is inactive, for instructions how to start it see Procedure 8.3, “Starting and Stopping a Container”.
			
Note


					Red Hat Satellite currently supports only Red Hat Enterprise Linux 7 container hosts.
				



      ⁠Example 8.1. Creating a Red Hat Enterprise Linux Container in Satellite

					To enable a Red Hat Enterprise Linux container in Red Hat Satellite, perform the following actions:
				

      ⁠	
							Create a custom registry as described in Section 8.3, “Adding an External Registry”. Specify registry.access.redhat.com as a registry URL and insert your access credentials for the Red Hat Customer Portal.
						

	
							Create a new container as described in Section 8.1.1, “Creating a New Container”. In the Image stage of container creation, navigate to the External registry tab and select the registry created in the previous step from the drop-down list. Use the search field to find the desired version of the Red Hat Enterprise Linux image. Proceed through the Configuration and Environment stages to finalize the container.
						







      ⁠8.1.2. Investigating Containers




				Red Hat Satellite provides means to monitor the status of containers as well as processes running inside of them. Some containers can be marked as managed, which means they were created and provisioned inside the Satellite environment.
			

				The following procedure shows how to view a list of containers present in the current organization and how to investigate the container metadata.
			

      ⁠Procedure 8.2. Investigating a Container
	
						Navigate to Containers → All Containers.
					

	
						On the Containers page, every Docker compute resource has a dedicated tab. Each of these tabs contains the table of available containers together with selected parameters of each container. Select the tab of the compute resource you want to inspect.
					

	
						To view the container metadata, click the name of the container you want to inspect. Satellite displays the table of container properties.
					

	
						On the Processes tab, you can view processes that are currently running in the container. Click on the process name to view the metadata of the process.
					

	
						If the container is running, you can view its standard output in the Logs tab. If you selected the allocate a pseudo-tty check box when creating a container, the console is interactive. Otherwise, it displays only the initial standard output produced when the container started.
					





      ⁠8.1.3. Starting, Committing, and Removing Containers




				A new container is by default disabled. By enabling a container, you start the processes of the containerized application in the compute resource that acts as a container server. Hosts are then able to communicate with the container as with a web application. The following procedure shows how to start a container:
			

      ⁠Procedure 8.3. Starting and Stopping a Container
	
						Navigate to Containers → All Containers to view the list of available containers.
					

	
						Click Power On next to the container you want to start. After starting the container, the button changes to Power Off, which allows for stopping the container. These actions are equivalent to the docker start and docker stop commands.
					




				By committing a container, you create a new image layer that stores the status of the container. The following procedure shows how to commit the container to an image.
			

      ⁠Procedure 8.4. Committing a Container
	
						Navigate to Containers → All Containers to view the list of available containers.
					

	
						Click the name of the container you want to commit.
					

	
						Click Commit. Satellite then prompts you to provide the following information:
					
	
								Specify a repository name. This can be a single name or combined with the user name, for example user/my-rhel-image.
							

	
								Assign a tag to the image.
							

	
								Provide your contact information.
							

	
								Provide an informative comment about the image.
							




	
						Click Submit.
					



Note


					The container is committed to the repository of the original image. For example, if the container is based on an image pulled from the Docker Hub, when you commit this container, the changes are pushed back to the Docker Hub.
				



      ⁠Procedure 8.5. Removing a Container
	
						Navigate to Containers → All Containers to view the list of available containers.
					

	
						Click the name of the container you want to delete.
					

	
						Click Delete.
					

	
						In the alert box, click OK to remove the container.
					






      ⁠8.2. Working with Repositories




			This section shows how to create an internal repository for container images. You can use such repository to create containers as described in Section 8.1.1, “Creating a New Container”.
		

      ⁠8.2.1. Creating a Repository




				Repositories provide a way to synchronize the container content either from the Red Hat Content Delivery Network or from other sources. To create a repository for container images in a selected product, follow the steps described in Procedure 4.4, “Adding Repositories to a Product”. Select docker as a repository type.
			


      ⁠8.2.2. Uploading Images to a Repository




				The following procedure shows how to import images to an existing repository.
			

      ⁠Procedure 8.6. Uploading Images to a Repository
	
						Navigate to Content → Products
					

	
						Select the product that contains the repository you want to update.
					

	
						Navigate to the Repositories tab and select the docker repository you want to update.
					

	
						Click Browse.
					

	
						Navigate to the location of the image you want to upload. Click Open.
					

	
						Click Upload
					






      ⁠8.3. Adding an External Registry




			The following procedure shows how to import an external registry registry to the Red Hat Satellite.
		

      ⁠Procedure 8.7. Adding an External Registry
	
					Navigate to Containers → Registries.
				

	
					Click New Registry.
				

	
					On the Registry tab, specify the following parameters:
				
	
							Specify the name of the registry. This setting is required.
						

	
							Specify the URL of the registry. This setting is required.
						

	
							Provide a brief description of the registry.
						

	
							Specify a user name if required for accessing the registry.
						

	
							Specify a password if required for authentication to the registry.
						




	
					On the Locations tab, select the locations where the new registry will be available.
				

	
					On the Organizations tab, select the organizations where the new registry will be available.
				

	
					Click Submit to create the registry.
				





      ⁠8.4. Importing Images to a Compute Resource




			Importing an image is a necessary step for creating any container as described in Procedure 8.1, “Creating a Container”. You can also import images to a compute resource before creating a container as described in the following procedure.
		

      ⁠Procedure 8.8. Adding Images to a Compute Resource
	
					Navigate to Infrastructure → Compute resources to view a list of compute resources.
				

	
					Select the compute resource you want to edit. The compute resource must be of type Docker.
				

	
					Click New image.
				

	
					Specify the image details including the image name, operating system, architecture, user credentials, and a parent image. Select User data to enable user input for this image.
				

	
					Click Submit.
				





      ⁠8.5. Using Tags




			Tags are convenient for organizing images, especially when you operate with several versions of an image. A combination of a repository name and a tag in the form of repository:tag is a human-readable alternative to an image ID.
		

      ⁠Procedure 8.9. Searching Registries by Tags
	
					Navigate to Content → Docker tags.
				

	
					Use the search field to filter tags by the image name, tag name, or repository name. Automatic suggestion works as you type. For example, the following query searches for tags applied on images from the repository named test_repo:
				
repository = test_repo

					See Table 16.2, “Supported Operators for Granular Search” for the list of alternative comparison operators. By default, the search field recognizes the input string as a tag name. For example, the following query searches for all centos tags:
				
centos

	
					Click the name of the tag you want to observe. Satellite displays a list of images that use this tag.
				

	
					Select an image to view its environment, and content view version. The Published At field shows the URL that you can use to pull the image from the command line.
				






      ⁠Chapter 9. Configuring Activation Keys




		Activation Keys are preset keys used when registering the host and define:
	
	
				Which life cycle environment the host should be placed in.
			

	
				Which host collection the host should be assigned to.
			

	
				Which organization the host should be a part of.
			

	
				Whether to use a provisioning template for the host.
			

	
				Setting up a subscription usage limit for the host.
			

	
				Assigning a specific subscription to the host.
			




		Report a bug
	

      ⁠9.1. Creating an Activation Key




		This section describes how to create an activation key.
	

      ⁠Procedure 9.1. To Create an Activation Key:
	
				Click Content → Activation Keys.
			

	
				Click New Activation Key.
			

	
				Enter the required details for the activation key in the relevant fields.
			

	
				Clear the Unlimited check box if the activation key is to be used with limitations. Type the usage limit in the Limit field.
			

	
				Enter a suitable description in the Description field.
			

	
				Select the Environment and Content View that this key should apply to.
			

	
				Click Save to create the activation key.
			



Note


			You can change the activation key details on the Details tab of the Activation Key.
		



		Report a bug
	


      ⁠9.2. Removing an Activation Key




		This section describes how to remove an activation key.
	

      ⁠Procedure 9.2. To Remove an Activation Key
	
				Click Content → Activation Keys.
			

	
				Click the activation key name that you want to remove.
			

	
				In the upper right of the Activation Key detail panel, click Remove.
			

	
				In the alert box, click Remove to confirm that you want to remove the key.
			




		Report a bug
	


      ⁠9.3. Adding Objects to Activation Keys




			This section describes how to add different types of objects to activation keys.
		

      ⁠9.3.1. Adding Subscriptions to an Activation Key




		This section describes how to add subscriptions to an activation key.
	

      ⁠Procedure 9.3. To Add a Subscription to an Activation Key:
	
				Click Content → Activation Keys.
			

	
				Click the name of the activation key that you want to add subscriptions to.
			

	
				Click Subscriptions → Add.
			

	
				From the list of available subscriptions, select the subscriptions you want to add and then click Add Selected.
			




		Report a bug
	


      ⁠9.3.2. Adding Host Collections to an Activation Key




		These steps show how to add host collections to an activation key.
	

      ⁠Procedure 9.4. To Add Host Collections to an Activation Key:
	
				Click Content → Activation Keys.
			

	
				Click the activation key that you want to add a host collection to.
			

	
				Click Host Collections and then click Add to display the list of available host collections.
			

	
				Select the host collections you want to add, and then click Add Selected to add the host collections to the activation key.
			



Note


			After you have added the host collections to the activation key, they no longer appear in the list of available collections. To view the host collections that have been added to an activation key, click List/Remove.
		



		Report a bug
	



      ⁠9.4. Removing Objects from Activation Keys




      ⁠9.4.1. Removing Subscriptions from an Activation Key




		These steps show how to remove subscriptions from an activation key.
	

      ⁠Procedure 9.5. Remove Subscriptions from an Activation Key
	
				Click Content → Activation Keys.
			

	
				A list of activation keys is displayed. Click the activation key you wish to remove subscriptions from.
			

	
				Click the Subscriptions subtab.
			

	
				A list of subscriptions is displayed. Select the subscriptions you wish to remove.
			

	
				Click the Remove Selected button to remove subscriptions from the activation key.
			




      ⁠Result:

			Subscriptions are removed from your activation key.
		

		Report a bug
	


      ⁠9.4.2. Removing Host Collections from an Activation Key




		These steps show how to remove host collections from an activation key.
	

      ⁠Procedure 9.6. Remove Host Collections from the Activation Key
	
				Click Content → Activation Keys.
			

	
				A list of activation keys is displayed. Click the activation key you wish to remove host collections from.
			

	
				Click the Host Collections subtab.
			

	
				A list of host collections attached to the Activation Key is displayed. Tick the checkbox of the host collections you wish to remove.
			

	
				Click the Remove Selected button to remove host collections from the activation key.
			




      ⁠Result:

			Host collections are removed from your activation key.
		

		Report a bug
	




      ⁠Chapter 10. Configuring GPG Keys




		GPG keys allow you to add your existing GPG keys to Red Hat Satellite Server products and repositories to enable pairing with your repositories.
	

		Report a bug
	

      ⁠10.1. Creating a GPG Key




		This section describes how to add a GPG key to Red Hat Satellite.
	

      ⁠Procedure 10.1. To Add a GPG Key to Satellite:
	
				Click Content → GPG Keys and then click New GPG Key.
			

	
				Enter a name for the GPG key in the Name field.
			

	
				Either upload the GPG key file or paste the GPG key contents into the text box.
			

	
				Click Save to add the GPG key to Satellite.
			




		Report a bug
	


      ⁠10.2. Removing a GPG Key




		This section describes how to remove a GPG from Red Hat Satellite.
	

      ⁠Procedure 10.2. To Remove a GPG Key:
	
				Click Content → GPG Keys.
			

	
				Click the GPG key that you want to remove, and then click Remove GPG Key.
			

	
				In the confirmation box, click Remove to confirm that you want to remove the selected key.
			




		Report a bug
	



      ⁠Chapter 11. Configuring the Provisioning Environment




      ⁠11.1. Creating a Host Group




		A host group defines a set of default values that hosts inherit when placed in that group. Hosts can belong to only one host group, but host groups can be nested in hierarchies. You can create a "base" or "parent" host group that represents all hosts in your organization, and then create nested or "child" host groups under that parent to provide specific settings. This section describes how to create a host group.
	

      ⁠Procedure 11.1. To Add a Host Group to Satellite:
	
				Click Configure → Host Groups and then click New Host Group.
			

	
				Enter the required details for the Host Group, and then click Submit.
			




      ⁠Host Group Attributes

			The following table describes the attributes that apply to Satellite Host Groups.
		

      ⁠Table 11.1. Table of Host Group Attributes
	 
						Submenu
					

					 	 
						Options
					

					 	 
						Description
					

					 
	 
						Host Group
					

					 	 
						Parent
					

					 	 
						The parent Host Group for the new Host Group.
					

					 
	 
						Name
					

					 	 
						The name of the Host Group.
					

					 
	 
						Life Cycle Environment
					

					 	 
						The environment containing this Host Group.
					

					 
	 
						Puppet CA
					

					 	 
						The Red Hat Satellite Capsule Server to use for the Puppet CA server.
					

					 
	 
						Puppet Master
					

					 	 
						The Red Hat Satellite Capsule Server to use as the Puppet Master.
					

					 
	 
						Puppet Classes
					

					 	 
						Included Classes
					

					 	 
						The Puppet Classes included with the Host Group.
					

					 
	 
						Available Classes
					

					 	 
						The Puppet Classes available to use with the Host Group.
					

					 
	 
						Network
					

					 	 
						Domain
					

					 	 
						The domain for hosts in the Host Group.
					

					 
	 
						Subnet
					

					 	 
						The subnet for hosts in the Host Group.
					

					 
	 
						Operating System
					

					 	 
						Architecture
					

					 	 
						The default architecture for systems in the Host Group.
					

					 
	 
						Operating Systems
					

					 

					

					 	 
						The default operating system for systems in the Host Group.
					

					 
	 
						Media
					

					 

					

					 	 
						The location of the installation media for the operating system.
					

					 
	 
						Partition Table
					

					 

					

					 	 
						A file system partition layout for the operating system installation.
					

					 
	 
						Root Password
					

					 	 
						The root password for the operating system.
					

					 
	 
						Parameters
					

					 	 
						Add Parameter
					

					 	 
						Provides a Name and Value pair to set parameters for the Host Group.
					

					 
	 
						Organizations
					

					 	 
						Organizations
					

					 	 
						The organizations that own this host group.
					

					 
	 
						Activation Keys
					

					 	 
						Content Environment
					

					 	 
						Defines the activation keys made available in templates as @host.params['kt_activation_keys'].
					

					 




		Report a bug
	


      ⁠11.2. Parameters




			Red Hat Satellite parameters define key-value pairs to use when provisioning hosts. These are similar to Puppet's concept of a default scope parameter. You can define parameters when setting up a host with Puppet and also define a hierarchy of parameter inheritance.
		

			The following parameter hierarchy applies:
		
	
      ⁠Global Parameters
	
						The default parameter that applies to every host in Satellite. Configured in Configure → Global parameters.
					

	
      ⁠Domain Parameters
	
						Parameters that affect all hosts in a given domain. Domain parameters override Global parameters. Configured in Infrastructure → Domains.
					

	
      ⁠Host Group Parameters
	
						Parameters that affect all hosts in the Host Group. Host Group parameters override both Global and Domain parameters. Configured in Configure → Host Groups.
					

	
      ⁠Host Parameters
	
						Parameters that affect a specific host. All previous inherited parameters are visible on the Parameters subtab and can be overridden. Configured in Hosts → All hosts → [choose_a_host] → Parameters or Hosts → Content Hosts → [choose_a_host] → Parameters.
					




			Different types of parameters also exist:
		
	
      ⁠Simple Parameters
	
						A basic parameter that defines a relationship between a key and value pair.
					

	
      ⁠Smart Parameters
	
						A complex parameter that defines a value for a key but allows conditional arguments, validation, and overrides for specific object types.
					

	
      ⁠Parameterized Classes
	
						Parameters for classes imported from a Puppet Master.
					



Important


				Ensure you enable parameterized class support. Navigate to Administer → Settings, select the Puppet tab, and ensure the Parametrized_Classes_in_ENC is set to True.
			



			Report a bug
		

      ⁠11.2.1. Creating a Global Simple Parameter




		This procedure shows how to add a new global parameter to Satellite.
	
	
				Click Configure → Global Parameters.
			

	
				Click the New Parameter button.
			

	
				Type a Name for the parameter's key.
			

	
				Type a Value for the parameter.
			

	
				Click the Submit button.
			




		Report a bug
	


      ⁠11.2.2. Creating a Puppet Class




		This procedure shows how to add a new Puppet Class to Satellite.
	
	
				Click Configure → Puppet Classes.
			

	
				Click the New Puppet class button.
			

	
				Type a Name for the Puppet Class.
			

	
				Type a Puppet Environments for the Puppet Class.
			

	
				Select one or more Host groups that own the Puppet Class.
			

	
				Click Submit.
			




		Report a bug
	


      ⁠11.2.3. Configuring Smart Parameters




		The following procedure configures smart parameters in a Puppet class.
	

      ⁠Procedure 11.2. To configure smart parameters
	
				Click Configure → Puppet Classes.
			

	
				Select a class from the list.
			

	
				Click the  Smart Variables tab. This displays a new screen. The left section contains a list of possible parameters the class supports. The right section contains the configuration options for the parameter selected. Click the Add Variable to add a new parameter. Otherwise, select a parameter from the left-hand list.
			

	
				Type a name for the Parameter field.
			

	
				Edit the Description text box to add any plain text notes.
			

	
				Select the Parameter type of data to pass. This is most commonly a string, but other data types are supported.
			

	
				Type a Default Value for the parameter.
			

	
				Use the Optional Input Validator section to restrict the allowed values for the parameter. Choose a Validator type (either a list of comma separated values or a regular expression, regexp) and input the allows values or regular expression code in the Validator rule field.
			

	
				The Override Value For Specific Hosts section at the bottom of the page provides options for overriding values based upon conditional arguments known as Matchers. Define the Order that the host values resolve, then click Add Matcher-Value to add your conditional argument.
			

				For example, if desired value of the parameter is test for any host with a fully qualified domain name of www.example.com, then specify the Match as fqdn=www.example.com and the Value as test.
			

	
				Click Submit to save your changes.
			




      ⁠Result:

			Satellite configures the smart parameter.
		

		Report a bug
	


      ⁠11.2.4. Importing Parameterized Classes from a Puppet Master




		The following procedure imports parameterized classes from your Puppet Master.
	

      ⁠Procedure 11.3. To import parameterized classes
Note


				The import of parameterized classes happens automatically if your puppet modules are managed via a Product and a Content View.
			


	
				Click Configure → Puppet Classes.
			

	
				Click Import from Host Name to import parameterized classes from your Puppet Master.
			

	
				The Puppet Classes page displays with the new classes listed.
			




      ⁠Result:

			Satellite imports the Puppet Master's parameterized classes.
		

		Report a bug
	


      ⁠11.2.5. Configuring Parameterized Classes




		The following procedure configures parameterized classes.
	

      ⁠Procedure 11.4. To configure parameterized classes
	
				Click Configure → Puppet Classes.
			

	
				Select a class from the list.
			

	
				Click the Smart Class Parameter tab. This displays a new screen. The left section contains a list of possible parameters the class supports. The right section contains the configuration options for the parameter selected.
			

	
				Select the a parameter from the left-hand list.
			

	
				Edit the Description text box to add any plain text notes.
			

	
				Click the Override checkbox to allow Satellite control over this variable. If the checkbox is not selected, Satellite does not pass this variable to Puppet.
			

	
				Select the Parameter type of data to pass. This is most commonly a string, but other data types are supported.
			

	
				Type a Default Value for the parameter.
			

	
				The Override Value For Specific Hosts section at the bottom of the page provides options for overriding values based upon conditional arguments known as Matchers. Define the Order that the host values resolve, then click Add Matcher-Value to add your conditional argument.
			

				For example, if desired value of the parameter is test for any host with a fully qualified domain name of www.example.com, then specify the Match as fqdn=www.example.com and the Value as test.
			

	
				Click Submit to save your changes.
			




      ⁠Result:

			Satellite configures the parameters for the class.
		

		Report a bug
	



      ⁠11.3. Configuring Provisioning Settings




      ⁠11.3.1. Domains




				Satellite has the ability to assign domain names with Red Hat Satellite Capsule Server DNS. This provides users with a means to group and name hosts within a particular domain.
			

      ⁠11.3.1.1. Creating a Domain




		This procedure shows how to add a Domain.
	

      ⁠Procedure 11.5. Creating a Domain
	
				Click Infrastructure → Domains.
			

	
				Click the New Domain button.
			

	
				Type a Name for the Domain. This is the DNS domain name.
			

	
				Type a Description for the Domain.
			

	
				Choose a DNS-enabled Red Hat Satellite Capsule Server from the DNS Capsule selection box.
			

	
				Click the Locations tab and click the desired locations to add them to the Selected Items list.
			

	
				Click the Organizations tab and click the desired organizations to add them to the Selected Items list.
			
Important


					Ensure that the Locations and Organizations are configured as they will help with future debugging.
				



	
				Click Submit.
			




		Satellite creates a Domain and registers it on the DNS server configured with the selected Smart Proxy.
	

		Report a bug
	



      ⁠11.3.2. Subnets




				Satellite has the ability to create networks for groups of systems. Subnets use standard IP address settings to define the network and use the Red Hat Satellite Capsule Server's DHCP features to assign IP addresses to systems within the subnet.
			

      ⁠11.3.2.1. Creating a Subnet




		The following procedure shows how to create a Subnet:
	

      ⁠Procedure 11.6. Creating a Subnet
	
				Click Infrastructure → Subnets.
			

	
				Click the New Subnet button.
			

	
				Type a Name for the Subnet.
			

	
				Type the IP address for the Subnet into the Network box.
			

	
				Type the mask for the network's IP address into the Network mask box.
			

	
				Type the Gateway address for the Subnet.
			

	
				Type the Primary DNS server and Secondary DNS server for the Subnet.
			

	
				Define the IP assignment range with the Start of IP range and End of IP range fields.
			

	
				Define the VLAN ID for the subnet.
			

	
				Select the applicable domain for the subnet from the Domains tab.
			

	
				Click the Capsules tab, and select a Red Hat Satellite Capsule Server for the DHCP Proxy, TFTP Proxy, and DNS Proxy services.
			

	
				Click the Locations tab and click the desired locations to add them to the Selected Items list.
			

	
				Click the Organizations tab and click the desired organizations to add them to the Selected Items list.
			
Important


					Ensure that the Locations and Organizations are configured as they will help with future debugging.
				



	
				Click the Submit button.
			




		Report a bug
	



      ⁠11.3.3. Architectures




				An architecture in Satellite represents a logical grouping of hosts and operating systems. Architectures are created by Satellite automatically when hosts check in with Puppet. However, none exist with a default installation and require creation.
			

      ⁠11.3.3.1. Creating an Architecture




		This procedure shows how to create an architecture.
	

      ⁠Procedure 11.7. To Create an Architecture:
	
				Click Hosts → Architectures and then click New Architecture.
			

	
				Type a Name for the architecture.
			

	
				Select any Operating Systems that include this architecture. If none are available, you can create and assign them under Hosts → Operating Systems.
			

	
				Click Submit.
			




		Report a bug
	



      ⁠11.3.4. Compute Resources




				Compute resources are hardware abstractions from virtualization and cloud providers. Satellite uses compute resources to provision virtual machines and containers. Supported private providers include Red Hat Enterprise Virtualization, oVirt, OpenStack, VMware, Libvirt, and Docker. Supported public cloud providers include Amazon EC2, Google Compute Engine, and Rackspace.
			

      ⁠11.3.4.1. Creating a Compute Resource




		The following procedure shows how to add a Compute Resource.
	

      ⁠Procedure 11.8. Creating a Compute Resource
	
				Navigate to Infrastructure → Compute Resources.
			

	
				Click New Compute Resource.
			

	
				Type a Name for the Compute Resource.
			

	
				Select a Provider type.
			

	
				Optionally, enter a Description.
			

	
				Depending on the provider type chosen, the next few fields ask for authentication and datacenter details. Refer to the following table for more information about each provider type.
			

      ⁠Table 11.2. Provider Settings
	 
								Type
							

							 	 
								Description
							

							 
	 
								RHEV
							

							 	 
								Suits Red Hat Enterprise Virtualization environments. Requires the URL of the Manager API, a valid Username and Password, and a Datacenter on the system to abstract compute resources. Click Load Datacenters to populate the drop-down menu. Optionally, you can specify a Quota ID and provide one or more certificate authorities in the X509 Certification Authorities field.
							

							 
	 
								Libvirt
							

							 	 
								Suits Libvirt-based environments. Requires the URL of the virtual machine. Select the Display type. Click Test Connection to test if the virtual machine is available. Select Console passwords to set a randomly generated password on the display connection.
							

							 
	 
								VMware
							

							 	 
								Suits VMware-based environments. Requires the hostname of the VCenter/Server, a valid VMware Username and Password, and a Datacenter to abstract compute resources. Click Load Datacenters to populate the drop-down menu. You can specify a certificate Fingerprint and select Console passwords to set a randomly generated password on the display connection.
							

							 
	 
								RHEL OpenStack Platform
							

							 	 
								Suits OpenStack-based environments. Requires the URL of the OpenStack server, a valid OpenStack Username and Password, and a Tenant to abstract compute resources. Click Load Tenants to populate the drop-down menu.
							

							 
	 
								Rackspace
							

							 	 
								Suits Rackspace public cloud accounts. Requires the URL of the Rackspace API, a valid Rackspace Username and API Key, and a Region to abstract compute resources. Click Test Connection to make sure your connection to the chosen region is valid.
							

							 
	 
								EC2
							

							 	 
								Suits Amazon EC2 public cloud accounts. Requires the Access Key and Secret Key available from any valid Amazon EC2 account. Requires a Region to act as a Datacenter for resource abstraction. Click Load Regions to populate the selection drop-down menu.
							

							 
	 
								Google
							

							 	 
								Suits Google Compute Engine public cloud accounts. Requires the Google Project ID, a valid Client Email and a Certificate path to the p12 file. You can also specify a Zone to abstract compute resources. Click Load zones to populate the drop-down menu.
							

							 
	 
								Docker
							

							 	 
								Suits container registries. Requires the URL of the internal or external compute resource. Optionally, specify a Username, Password, and a contact Email. Click Test Connection to test if the connection is available.
							

							 




	
				Click the Locations tab and click the desired locations to add them to the Selected Items list.
			

	
				Click the Organizations tab and click the desired organizations to add them to the Selected Items list.
			
Important


					Ensure that the Locations and Organizations are configured as they will help with future debugging.
				



	
				Click Submit.
			




		Report a bug
	



      ⁠11.3.5. Hardware Models




				Hardware models help run unattended Solaris installations. For Solaris SPARC-based machines, users define the CPU and Vendor information, while other architectures do not need to do so.
			

      ⁠11.3.5.1. Creating a Hardware Model




		This procedure shows how to add a Hardware Model.
	

      ⁠Procedure 11.9. Creating a Hardware Model
	
				Click Hosts → Hardware Models.
			

	
				Click the New Model button.
			

	
				Type a Name for the Hardware Model.
			

	
				For Sparc Solaris builds, enter the CPU Hardware model and Vendor class. Other architectures do not require values in these fields.
			

	
				Enter a description of the Hardware Model in the Information textbox.
			

	
				Click Submit.
			




		Report a bug
	



      ⁠11.3.6. Installation Media




				Red Hat Satellite uses installation media (ISO images) as content for kickstart trees and new host installations.
			

      ⁠11.3.6.1. Adding Installation Media




		This procedure shows how to add new Installation Media to Satellite.
	
	
				Click Hosts → Installation Media.
			

	
				Click the New Installation Medium button.
			

	
				Type a Name for the Installation Media.
			

	
				Type a Path to the Installation Medium. Options include either a URL or a valid NFS server.
			

	
				Select an Operating System Family to define the Installation Media's type.
			

	
				Click the Locations tab and click the desired locations to add them to the Selected Items list.
			

	
				Click the Organizations tab and click the desired organizations to add them to the Selected Items list.
			
Important


					Ensure that the Locations and Organizations are configured as they will help with future debugging.
				



	
				Click the Submit button.
			




		Report a bug
	



      ⁠11.3.7. Operating Systems




				Operating Systems define combinations of installation methods and media and are grouped within families. As a default, Red Hat Satellite uses a RedHat family. Families allow Satellite to change certain behaviors when provisioning hosts.
			

      ⁠11.3.7.1. Adding an Operating System




		This procedure shows how to add a Operating System to Satellite.
	

      ⁠Procedure 11.10. Adding an Operating System
	
				Click Hosts → Operating Systems.
			

	
				Click the New Operating system button.
			

	
				Type a Name for the Operating System.
			

	
				Define the Major Version of the Operating System.
			

	
				Define the Minor Version of the Operating System.
			

	
				Select the OS Family to define the Operating System type.
			

	
				Select the Architectures from the list of available Architectures. If none are available, create and assign them under Hosts → Architectures.
			

	
				Click the Partition tables tab, then add the applicable file system layouts from the list.
			

	
				Click the Installation Media tab, then add the applicable file system layouts from the list.
			

	
				Click the Submit button.
			




		Report a bug
	



      ⁠11.3.8. Partition Tables




				Partition tables define the partitions and file system layout for new installations when provisioning systems. Satellite users specify the host's disk layout as an explicit sequence of partitions or use a dynamic disk layout script.
			

      ⁠11.3.8.1. Defining a New Partition Table




		This procedure shows how to define a new Partition Table for new installations.
	
	
				Click Hosts → Partition Tables.
			

	
				Click the New Partition Table button.
			

	
				Type a Name for the partition table.
			

	
				Enter the Layout for the Partition Table. The Layout textbox also accepts dynamic disk partitioning scripts.
			

	
				Select the operating system from the OS Family tab to define the Operating System type for the partitions.
			

	
				Click the Submit button.
			




		Report a bug
	



      ⁠11.3.9. Provisioning Templates




				Provisioning templates provide the systematic means to run unattended installations. Provisioning templates can be executed via several methods including bash scripts, kickstart scripts, and PXE-based installations.
			

      ⁠11.3.9.1. Creating a Provisioning Template




		This procedure shows how to create a Provisioning Template.
	

      ⁠Procedure 11.11. Creating a Provisioning Template
	
				Click Hosts → Provisioning Templates.
			

	
				Click the New Template button.
			

	
				Type a Name for the template.
			

	
				Enter your template in the Template editor field. Alternatively, upload your template with the Template file browser below the Template editor textbox. This replaces the content in the Template editor field with the content of your chosen file.
			

	
				Enter a comment in the Audit Comment field. Satellite adds the comment to the template history to track changes. View the template history under the History tab.
			

	
				Click the Type tab, then select Snippet to store the template code without defining it as particular script or template type, or select the type from the Type dropdown menu.
			

	
				Select the Association tab to associate the template to Hostgroups, Environments and Operating Systems. Select the operating systems from the Applicable Operating Systems list. Click the Add Combination button and select a Hostgroup and Environment to limit the template's use.
			

	
				Click the Submit button.
			




		Report a bug
	




      ⁠11.4. Storing and Maintaining Host Information




		Red Hat Satellite 6 uses a combination of applications to gather information about managed hosts and to ensure that those hosts are maintained in the desired state. These applications include: 
			
					Foreman: Provides for the provisioning and life cycle management of physical and virtual systems. Foreman automatically configures these systems using various methods, including kickstart and Puppet modules.
				

	
					Puppet: A client/server architecture for configuring hosts, consisting of the Puppet Master (server) and the Puppet Agent (client).
				

	
					Facter: Puppet's system inventory tool. Facter gathers basic information (facts) about hosts such as hardware details, network settings, OS type and version, IP addresses, MAC addresses, SSH keys, and more. These facts are then made available in Puppet manifests as variables.
				





	

		The use of Puppet, Facter, and facts is discussed in more detail below.
	

      ⁠11.4.1. The Puppet Architecture




			Puppet usually runs in an agent/master (also known as a client/server) architecture, where a Puppet server controls important configuration information, and managed hosts (clients) request only their own configuration catalogs. Puppet configures hosts in two steps: 
				
						It compiles a catalog
					

	
						It applies that catalog to the appropriate host
					





		

			In the agent/master setup, the Puppet client sends facts gathered by Facter and other information to the Puppet Master. The Puppet Master compiles a catalog based on these facts, and then sends this catalog to the client. The client sends a report of all the changes it made, or would have made if the --noop parameter had been used, to the Puppet Master, which in turn sends the results to Foreman. This catalog describes the desired state for one specific host. It lists the resources to manage on that host, including any dependencies between those resources. The agent applies the catalog to the host.
		

			This communication between master and agent occurs every 30 minutes by default. You can specify a different value in the /etc/puppet/puppet.conf file using the runinterval parameter. You can also run puppet agent apply to initiate communication manually.
		


      ⁠11.4.2. Using Facter and Facts




			Facter is Puppet's system inventory tool, and includes a large number of built-in facts. You can run Facter at the command line on a local host to display fact names and values. You can extend Facter with custom facts, and then use these to expose site-specific details of your hosts to your Puppet manifests. You can also use the facts provided by Facter to inform conditional expressions in Puppet.
		

			Puppet determines a system state based on resources; for example, you can tell Puppet that the httpd service should always be running and puppet knows how to handle that. If you are managing different operating systems, you can use the osfamily fact to create conditional expressions to tell Puppet which service to watch or which package to install. You can use the operatingsystemmajrelease and versioncmp parameters to create conditional expressions based on different versions of the same operating system. See Example 11.1, “Using Conditional Expressions with Facts” for an example of using conditional expressions.
		

      ⁠Example 11.1. Using Conditional Expressions with Facts

if $:: osfamily == 'RedHat' {
  if $::operatingsystemmajrelease == '6' {
   $ntp_service_name = 'ntpd'
   }

  elseif versioncmp($::operatingsystemmajrelease, '7') >= 0 {
   $ntp_service_name = 'chrony'
   }
 }



Note


				This example uses the expression "versioncmp($::operatingsystemmajrelease, '7') >= 0" to test for version 7 or later of Red Hat Enterprise Linux. Do not use the expression "$::operatingsystemmajrelease >= '7'" to perform this test. See https://docs.puppetlabs.com/references/latest/function.html#versioncmp for more information about this and other Puppet functions.
			



			Puppet also sets other special variables that behave a lot like facts. See Special Variables Added by Puppet
      ⁠[1] and Core Facts
      ⁠[2] for more information.
		

      ⁠11.4.2.1. Displaying Facts for a Particular Host




				Puppet can access Facter's built-in core facts as well as any custom or external facts present in your Puppet modules. You can view available facts from the command line (facter -p) and also from the web UI (Monitor → Facts). You can browse the list of facts or use the Search box to search for specific facts. For example, type "facts." to display a list of available facts.
			
Note


					The list of available facts is very long. The UI only displays 20 facts at a time. The list of facts gradually filters as you enter more details. For example, type "facts.e" to display all facts that begin with the letter "e."
				



      ⁠Procedure 11.12. To View Facts for a Particular Host:
	
						On the main menu, click Hosts → All Hosts and then click the name of the host that you want to inspect.
					

	
						In the Details pane, click Facts to display all known facts about the host.
					



Note

	
							For any fact listed on this page, you can click Chart to display a chart of the distribution of this fact name over all managed hosts.
						

	
							You can bookmark a search to make it easier to use in the future. When you have refined your search, click the drop-down arrow next to the Search button, and click Bookmark this search. Bookmarked searches appear in the Search drop-down list, and also under Administer → Bookmarks on the main menu.
						







      ⁠11.4.2.2. Searching for Hosts based on Facts




				You can use Facter information to search for specific hosts. This means that you can search for all hosts that match specific fact criteria, such as facts.architecture = x86_64.
			

      ⁠Procedure 11.13. To Search for Hosts Based on Facts:
	
						On the main menu, click Monitor → Facts to display the Fact Values page.
					

	
						In the Search field, start typing the name of the fact that you want to filter by. You can search by specific name, name/value pairs, and so on.
					

	
						Click Search to retrieve the list of matching hosts.
					




				Report a bug
			





[1] 
				https://docs.puppetlabs.com/puppet/3.7/reference/lang_facts_and_builtin_vars.html#special-variables-added-by-puppet
			

[2] 
				https://docs.puppetlabs.com/facter/latest/core_facts.html
			




      ⁠Chapter 12. Configuring Hosts




		In Red Hat Satellite, hosts are client systems which have Red Hat Subscription Manager installed. Red Hat Subscription Manager sends updates to Red Hat Satellite and Red Hat Satellite provides updates to these client systems.
	

		Hosts must be registered in order to be managed. Once a host has been registered, it can be viewed and edited in the Hosts tab. This enables a user to add and manage subscriptions, add and remove software packages, and apply updates.
	

      ⁠12.1. Creating a Host




			The following procedure describes how to create a host in Red  Hat Satellite.
		

      ⁠Procedure 12.1. To Create a Host:
	
					Click Hosts → New Host to open the New Host page.
				

	
					On the Host tab, enter the required details.
				

	
					On the Network tab, enter the Domain and Realm details. It is required to specify a domain to make the host provisioning possible. This automatically updates the Subnet list with a selection of suitable subnets.
				

	
					Enter the Primary Interface details. The MAC Address setting is required. Select a subnet from the drop-down menu, and specify an IP address. If there is a DHCP-enabled Capsule Server on the selected subnet, the IP address is automatically suggested. Click IP address auto-suggest to automatically select an address.
				

	
					It is possible to include an additional network interface by clicking Add Interface. See Section 12.4, “Configuring Additional Network Interfaces” for details.
				

	
					On the Operating System tab, enter the required details. You can select a partition table from the drop-down list or enter a custom partition table in the Custom partition table field. You cannot specify both.
				

	
					On the Parameters tab, click Add Parameter to add any required parameters. This includes all Puppet Class Parameters and Host Parameters associated with the host.
				

	
					On the Additional Information tab, enter any required information.
				

	
					Click Submit to complete your provisioning request.
				




			Report a bug
		


      ⁠12.2. Configuring Hosts for Registration




			Red Hat Enterprise Linux hosts register to Red Hat Network (RHN) by default. You must update each host configuration so that they register to and update from the correct Red Hat Satellite Server. Address the following requirements before proceeding:
		
	
					Hosts must be the following Red Hat Enterprise Linux Version: 
						
								5.8 or later
							

	
								6.4 or later
							

	
								7.0 or later
							





				

	
					All architectures of Red Hat Enterprise Linux are supported (i386, x86_64, s390x, ppc_64)
				

	
					On the Red Hat Satellite Server, ensure that the date and time are correct and synchronized with the client.
				

	
					On each client system, address the following requirements: 
						
								Ensure that the date and time are correct and synchronized with the server.
							

	
								Enable ntpd or a similar time synchronization tool in all virtual environments: 
# chkconfig ntpd on; service ntpd start


							





				




			Report a bug
		


      ⁠12.3. Configuration Options




      ⁠12.3.1. Automated Configuration




					These steps show how to automatically configure your client system to register to Red Hat Satellite.
				
	
						Take note of the Red Hat Satellite hostname or the fully qualified domain name (fqdn).
					

	
						Open a terminal console and login as root on the command line.
					

	
						Download and install a copy of the CA Certificate for Red Hat Satellite:
					

yum -y --nogpgcheck install http://[hostname]/pub/katello-ca-consumer-latest.noarch.rpm

Important


							yum in Red Hat Enterprise Linux 5 does not support installation via HTTP. If registering a Red Hat Enterprise Linux 5 client, download the RPM package first and then run yum on the package. For example:
						

# wget http://[hostname]/pub/katello-ca-consumer-latest.noarch.rpm
# yum -y --nogpgcheck install katello-ca-consumer-latest.noarch.rpm



Note


							katello-ca-consumer-[hostname]-1.0-1.noarch.rpm is an additional katello-ca-consumer rpm available that contains the server's hostname. The katello-ca-consumer-latest.noarch.rpm rpm will always reflect the most updated version. Both serve the same purpose.
						







      ⁠12.3.2. Manual Configuration




					These steps show how to manually configure your client system to register to Red Hat Satellite.
				
	
						Make the following changes in /etc/rhsm/rhsm.conf:
					

[server]
hostname =[satellite_fqdn]


[rhsm]
baseurl=https://[fqdn_pulp]/pulp/repos/
repo_ca_cert = %(ca_cert_dir)scandlepin-local.pem
ca_cert_dir = /etc/rhsm/ca/


	
						Change directories to the ca directory, remote copy and move the candlepin-ca.crt certificate:
					

# cd /etc/rhsm/ca
scp  [satellite.fqdn]:/etc/candlepin/certs/candlepin-ca.crt .
mv candlepin-ca.crt candlepin-local.pem





				Report a bug
			



      ⁠12.4. Configuring Additional Network Interfaces




			Red Hat Satellite supports specifying multiple network interfaces for a single host. You can configure these interfaces when creating a new host as described in Section 12.1, “Creating a Host” or when editing an existing host.
		

			There are several types of network interfaces that you can attach to a host. When adding a new interface, select one of:
		
	
					Interface: Allows you to specify an additional physical or virtual interface. There are two types of virtual interfaces you can create. Use VLAN when the host needs to communicate with several (virtual) networks using a single interface, while these networks are not accessible to each other. Another type of virtual interface is alias, which is an additional IP address attached to an existing interface. See Section 12.4.2, “Adding a Virtual Interface”, or Section 12.4.1, “Adding a Physical Interface” for details.
				

	
					Bond: Creates a bonded interface. NIC bonding is a way to bind multiple network interfaces together into a single channel that appears as a single device and has a single MAC address. This enables two or more network interfaces to act as one, simultaneously increasing the bandwidth and providing redundancy. See Section 12.4.3, “Adding a Bonded Interface” for details.
				

	
					BMC: Baseboard Management Controller (BMC) allows you to remotely monitor and manage physical state of machines. See Section 15.5, “Using Power Management Features on Managed Hosts” for more information on BMC, and Section 12.4.4, “Adding a BMC Interface” for details on configuring a BMC interface.
				



Note


				Additional interfaces have by default the Managed flag enabled, which means the new interface is configured automatically during provisioning by the DNS and DHCP Capsule Servers associated with the selected subnet. This requires a subnet with correctly configured DNS and DHCP Capsule Servers.
			



      ⁠12.4.1. Adding a Physical Interface




				The following steps show how to add and additional physical interface to a host.
			

      ⁠Procedure 12.2. Adding a Physical Interface
	
						Navigate to Hosts → All hosts to view available hosts.
					

	
						Click Edit next to the host you want to edit.
					

	
						On the Network tab, click Add Interface.
					

	
						Keep the Interface option selected in the Type menu.
					

	
						Specify a MAC address of the additional interface. This setting is required.
					

	
						Specify the device Identifier, for example eth0 or eth1.1. Identifier is used for bonded interfaces (in the Attached devices field, see Procedure 12.4, “Adding a Bonded Interface”), VLANs and aliases (in the Attached to field, see Procedure 12.3, “Adding a Virtual Interface”).
					

	
						Specify the DNS name associated with the host's IP address. Satellite saves this name in the "DNS A" and "DNS PTR" fields in the Capsule Server associated with the selected subnet. A single host can therefore have several DNS entries.
					

	
						Select a domain from the Domain drop-down menu. To create and manage domains, navigate to Infrastructure → Domains.
					

	
						Select a subnet from the Subnet drop-down menu. To create and manage subnets, navigate to Infrastructure → Subnets.
					

	
						Specify the interface IP address. Managed interfaces with assigned DHCP Capsule Server require this setting for creating a DHCP lease. DHCP-enabled managed interfaces provide an automatic suggestion of IP address.
					

	
						Decide if the interface will be managed. If the Managed check box is selected, the interface configuration is pulled from the associated Capsule Server during provisioning, and DNS and DHCP entries are created.
					

	
						Select the Virtual NIC check box to create a virtual interface. See Section 12.4.2, “Adding a Virtual Interface” for details.
					

	
						Click OK to save the interface configuration, and then click Submit to apply the changes to the host.
					





      ⁠12.4.2. Adding a Virtual Interface




				The following steps show how to configure an additional virtual interface for a host.
			

      ⁠Procedure 12.3. Adding a Virtual Interface
	
						Navigate to Hosts → All hosts to view available hosts.
					

	
						Click Edit next to the host you want to edit.
					

	
						On the Network tab, click Add Interface.
					

	
						Keep the Interface option selected in the Type menu.
					

	
						Specify the general interface settings. The applicable configuration options are the same as for the physical interfaces described in Section 12.4.1, “Adding a Physical Interface”. Specify MAC address for managed virtual interfaces so that the configuration files for provisioning are generated correctly. However, MAC address is not required for virtual interfaces that are not managed. If creating a VLAN, specify ID in the form of eth1.10 in the Identifier field. If creating an alias, use ID in the form of eth1:10.
					

	
						Select the Virtual NIC check box. Additional configuration options specific to virtual interfaces are appended to the form:
					
	
								Tag: You can specify tags per interface to provide a higher-level segmentation of the network. If left blank, managed interfaces inherit the tag form the VLAN ID of the associated subnet, given that this subnet has the VLAN ID specified. User-specified entries from this field are not applied on alias interfaces.
							

	
								Attached to: Specify the identifier of the physical interface to which the virtual interface belongs, for example eth1. This setting is required.
							




	
						Click OK to save the interface configuration. Then click Submit to apply the changes to the host.
					





      ⁠12.4.3. Adding a Bonded Interface




				The following steps show how to configure a bonded interface for a host.
			

      ⁠Procedure 12.4. Adding a Bonded Interface
	
						Navigate to Hosts → All hosts to view available hosts.
					

	
						Click Edit next to the host you want to edit.
					

	
						On the Network tab, click Add Interface.
					

	
						Select Bond from the Type menu. Additional type-specific configuration options are appended to the form.
					

	
						Specify the general interface settings. The applicable configuration options are the same as for the physical interfaces described in Section 12.4.1, “Adding a Physical Interface”. Bonded interfaces use IDs in the form of bond0 in the Identifier field. It is sufficient if you specify just a single MAC address in the MAC address field.
					

	
						Specify the configuration options specific to bonded interfaces:
					
	
								Mode: Select the bonding mode that defines a policy for fault tolerance and load balancing. See Table 12.1, “Bonding Modes Available in Red Hat Satellite” for a brief description of individual bonding modes.
							

	
								Attached devices: Specify a comma separated list of identifiers of attached devices. These can be physical interfaces or VLANs.
							

	
								Bond options: Specify a space separated list of configuration options, for example miimon=100. There are several configuration options you can specify for the bonded interface, see Red Hat Enterprise Linux 7 Networking Guide for details.
							




	
						Click OK to save the interface configuration. Then click Submit to apply the changes to the host.
					




      ⁠Table 12.1. Bonding Modes Available in Red Hat Satellite
	Bonding Mode	Description
	 balance-rr 	 Transmissions are received and sent out sequentially on each bonded interface. 
	 active-backup 	 Transmissions are received and sent out via the first available bonded interface. Another bonded interface is only used if the active bonded interface fails. 
	 balance-xor 	 Transmissions are based on the selected hash policy. In this mode, traffic destined for specific peers will always be sent over the same interface. 
	 broadcast 	 All transmissions are sent on all bonded interfaces. 
	 802.a3 	 Creates aggregation groups that share the same settings. Transmits and receives on all interfaces in the active group. 
	 balance-tlb 	 The outgoing traffic is distributed according to the current load on each bonded interface. 
	 balance-alb 	 Receive load balancing is achieved through Address Resolution Protocol (ARP) negotiation. 





      ⁠12.4.4. Adding a BMC Interface




				The following steps show how to configure and additional BMC interface for a host. See Section 15.5, “Using Power Management Features on Managed Hosts” for more information on BMC.
			

      ⁠Procedure 12.5. Adding a BMC Interface
	
						Navigate to Hosts → All hosts to view available hosts.
					

	
						Click Edit next to the host you want to edit.
					

	
						On the Network tab, click Add Interface.
					

	
						Select BMC from the Type menu. Type-specific configuration options are appended to the form.
					

	
						Specify the general interface settings. The applicable configuration options are the same as for the physical interfaces described in Section 12.4.1, “Adding a Physical Interface”.
					

	
						Specify the configuration options specific to BMC interfaces:
					
	
								Username, Password: Here you can specify authentication credentials required by BMC.
							

	
								Provider: Specify the BMC provider, currently the only supported provider is the Intelligent Platform Management Interface (IPMI).
							




	
						Click OK to save the interface configuration. Then click Submit to apply the changes to the host.
					




				Report a bug
			



      ⁠12.5. Registration




      ⁠12.5.1. Registering a Host




				These steps show how to register hosts in Red Hat Satellite Server. Hosts provisioned by Satellite Server appear on the Hosts page accessible through Hosts → All hosts. Hosts registered to the Satellite Server via Red Hat Subscription Manager, which can occur either during the post phase of a kickstart or through the terminal, will appear on the Content Hosts page accessible through Hosts → Content Hosts.
			

				You must meet the following conditions before continuing with this task:
			
	
						Ensure that all steps in Section 12.2, “Configuring Hosts for Registration” have been completed.
					

	
						Make sure there is a pre-existing activation key for the system or create an activation key for the system. See Section 9.1, “Creating an Activation Key” for instructions on creating an activation key.
					




      ⁠Procedure 12.6. Registering Systems
	
						Open a terminal console and login as root on the command line.
					

	
						Clear old system data in preparation for registering. This makes sure that your updated system data is uploaded correctly.
					

subscription-manager clean


	
						Register the system using the Red Hat Subscription Manager (RHSM):
					

# subscription-manager register --org [your_org_name] --activationkey [your_activation_key]

Note


							Activation keys will allow you to add environments, provisioning templates and dictate what subscriptions are available and should be applied to the registering system.
						

							There are various options that may be added. For more information, use the command man subscription-manager.
						






				The command line output after the registration should look like:
			

# subscription-manager register --org MyOrg --activationkey TestKey-1
The system has been registered with id: 62edc0f8-855b-4184-b1b8-72a9dc793b96


				The system should now appear in the Red Hat Satellite Server.
			
Note


					For systems with Red Hat Enterprise Linux 6.3, the release version defaults to version 6.0. To ensure that it is pointing to the 6.3 repository, please follow these steps:
				
	
							On Red Hat Satellite, select Hosts → Content Hosts.
						

	
							Select the system that needs to be changed and click Edit.
						

	
							Click on the Operating System tab.
						

	
							Select '6.3' from the Operating system drop-down menu.
						

	
							Click Save.
						







      ⁠12.5.2. Installing the Katello Agent




      ⁠Prerequisites

					The Red Hat Common repository must be enabled in the Red Hat Satellite Server as it provides the required packages.
				

				These steps show how to install and enable the Katello agent. The katello-agent must be enabled so that the Red Hat Satellite Server or Capsule Server can provide information about errata that are applicable for the system.
			

					To install katello-agent:
				
	
						Open a terminal console and log in as root on the command line.
					

	
						Install the katello-agent using the following command:
					

# yum install katello-agent






      ⁠12.5.3. Installing and Configuring the Puppet Agent




				This section describes how to install and configure the Puppet agent on a Satellite 6 host. When you have correctly installed and configured the Puppet agent, you can navigate to Hosts → All hosts to list all hosts visible to Red Hat Satellite Server.
			
Important


					The puppet package is part of the Red Hat Common repository. Ensure you enable this repository before you proceed.
				



      ⁠Procedure 12.7. Installing and Enabling the Puppet Agent
	
						Open a terminal console and log in as root.
					

	
						Install the Puppet agent:
					

# yum install puppet


	
						Configure the puppet agent to start at boot:
					

							
								On Red Hat Enterprise Linux 6:
							
# chkconfig puppet on


						 	
								On Red Hat Enterprise Linux 7:
							
# systemctl enable puppet



					




      ⁠Procedure 12.8. Configuring the Puppet Agent

      ⁠Prerequisites

						You must meet the following conditions before continuing with this task:
					
	
							The host must be registered to the Red Hat Satellite Server.
						

	
							The Red Hat Common repository must be enabled.
						

	
							Puppet packages must be installed on the host.
						



	
						Configure the Puppet agent by changing the /etc/puppet/puppet.conf file:
					

# vi /etc/puppet/puppet.conf


[main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl

[agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion.  Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt
    pluginsync = true
    report = true
    ignoreschedules = true
    daemon = false
    ca_server = satellite.example.com
    server = satellite.example.com

    # Where puppetd caches the local configuration.  An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig


	
						Run the Puppet agent on the host: 

# puppet agent -t --server satellite.example.com


					

	
						Sign the SSL certificate for the puppet client through the Satellite Server web interface:
					
	
								Log in to the Satellite Server through the web interface.
							

	
								Select Infrastructure → Capsules.
							

	
								Click Certificates to the right of the required host.
							

	
								Click Sign.
							





Note


					Once the Puppet agent is configured on the host it will be listed under All Hosts but only when Any Context is selected as the host will not be assigned to an organization or location. To assign the host to an organization see Section 3.1.3, “Editing an Organization” and to assign the host to a location see Section 3.2.2, “Editing a Location”.
				



				Report a bug
			



      ⁠12.6. Removing a Host




				To remove a host from Red Hat Satellite:
			
	
					Click Hosts → All hosts or Hosts → Content Hosts.
				

	
					Choose the hosts to be removed.
				

	
					Click Select Action and choose Delete Hosts from the drop-down menu.
				

	
					A confirmation pop-up box will appear. Select Yes to remove the host from Red Hat Satellite permanently.
				




			Report a bug
		



      ⁠Chapter 13. Using the Foreman Discovery Plug-in




		The Foreman Discovery plug-in in Red Hat Satellite Server adds Metal-as-a-Service (MaaS) features. Bare-metal hosts on Satellite Server-managed networks can be booted over the network through PXE into stripped-down Red Hat Enterprise Linux systems running from memory to collect and send hardware facts to the Satellite Server.
	

		After they have booted, these systems appear as discovered hosts on the Satellite Server. Administrators can use these collected hardware facts to provision systems, removing the need to manually collect MAC addresses and other hardware information and reducing the time required to provision hosts.
	

		After the provisioning configuration is complete, the Foreman discovery plug-in sends a reboot command to the discovered host and the installation begins. The host then moves from the Discovered Hosts list in the Satellite Server to the All Hosts list.
	

      ⁠13.1. Installing the Foreman Discovery Plug-in




			This section describes the prerequisites and installation process for the Foreman Discovery plug-in.
		

      ⁠Prerequisites

				Ensure your deployment satisfies the following requirements before installing the Foreman Discovery Plug-in:
			
	
					Red Hat Satellite Server version 6.0.5 or later with bare-metal provisioning configured.
				

	
					At least one Capsule Server with DHCP and TFTP services enabled.
				

	
					At least one host available for discovery, with at least 1 GB of RAM installed.
				




			Run the following command as the root user to install the Foreman Discovery plug-in:
		

# yum ­install foreman­-discovery-­image


			Report a bug
		


      ⁠13.2. Configuring the Foreman Discovery Plug-in




      ⁠Prerequisites

				Ensure the following are correctly configured before you configure the Foreman Discovery plug-in:
			
	
					Ensure that bare-metal provisioning is functional. See Chapter 11, Configuring the Provisioning Environment for more information. To test bare-metal provisioning, create a host entry with a MAC address and power on the system to provision it. After Foreman Discovery is configured, host creation will be automated.
				

	
					The network DHCP server must be able to serve unknown clients and it must point unknown clients to the TFTP server where the discovery image is stored. If Internet Systems Consortium (ISC) DHCP was installed via the capsule installer on the Red Hat Enterprise Linux host, this will already be configured. If you are using a different configuration or a different DHCP server, ensure the nextserver option is configured to return the correct TFTP server, which is under the Red Hat Satellite Server's control.
				

	
					Satellite 6.0 has a template locking capability which prevents some templates from being edited or renamed because the application relies on their presence and name. The locked default PXELinux template prevents the configuration of Discovery. To circumvent this, start a Rails console on the Satellite Capsule and unlock the template, as described below:
				

# foreman-­rake console
> ct = ConfigTemplate.find_by_name("PXELinux global default"); ct.locked = false; ct.save!
> exit





      ⁠Procedure 13.1. To Configure the Foreman Discovery Plug-in:
	
					Click Hosts → Provisioning templates and edit the PXELinux global default template. Add the following entries at the end of the template: 
LABEL discovery
MENU LABEL Foreman Discovery
MENU DEFAULT
KERNEL boot/foreman-discovery-image-latest.el6.iso-vmlinuz
APPEND rootflags=loop initrd=boot/foreman-discovery-image-latest.el6.iso-img root=live:/foreman.iso rootfstype=auto ro rd.live.image rd.live.check rd.lvm=0 rootflags=ro crashkernel=128M elevator=deadline max_loop=256 rd.luks=0 rd.md=0 rd.dm=0 rd.bootif=0 rd.neednet=0 nomodeset selinux=0 stateless foreman.url=FOREMAN_URL
IPAPPEND 2



				

					The foreman.url option on the APPEND line identifies the location of the Foreman instance. Ensure that this is set correctly in global settings or the discovered hosts will not register to Foreman.
				

					The IPAPPEND 2 option is important because it adds the BOOTIF=MAC option. This is reported by Facter as discovery_bootif, which is a key fact used for provisioning. It is expected that the interface that it is booted from will be the provisioning interface as well. The same interface is used as the primary interface and is used to retrieve DNS configuration from DHCP.
				

	
					Set the ONTIMEOUT parameter to discovery to make the foreman.url option the default:
				
ONTIMEOUT discovery

					Alternatively, the discovery image can search for a DNS SRV record called _x­foreman._tcp. If the DNS server is configured for this, do not configure the foreman.url option because it will override the DNS SRV record. The following is an example of the configuration for the ISC DNS server:
				
_x­foreman._tcp SRV 0 5 443 foreman

	
					Click Hosts → Provisioning templates and then click Build PXE Default to deploy the configuration file on the TFTP server.
				
Important


						The Foreman Discovery image does not support SELinux. Set selinux=0 in the template. The discovery image is read-only.
					






			Report a bug
		


      ⁠13.3. Editing the Discovered Host




			An unknown host is not visible in the Red Hat Satellite Server web interface until the unknown host boots, reports, and registers to Foreman. Only then is the host discovered and available on the Satellite Server interface for editing. At the time of reporting, the discovered host will provide Foreman with system details which populates the Discovered Host's profile.
		

			When the discovered host appears in the web UI, edit the discovered host's provisioning profile to allow the Satellite Server to provision the host with the correct requirements.
		

      ⁠Procedure 13.2. Editing the Discovered Host
	
					Click Hosts → Discovered Hosts.
				

	
					Select the host and click Provision.
				

	
					Edit the required details and then click Save.
				




			After you have saved the changes to the provisioning details, the discovered host will reboot and install the chosen operating system with the correct requirements.
		

			Report a bug
		


      ⁠13.4. Troubleshooting the Foreman Discovery Plug-in




			This section provides information about troubleshooting the Foreman Discovery plug-in. For example, instances where the unknown hosts booting up and failing to register with Foreman have a number of common causes.
		
	
					If the machine fails to boot to the correct image, verify that the /var/lib/tftp/pxelinux.cfg/default file has been configured as described in Section 13.2, “Configuring the Foreman Discovery Plug-in”
				

	
					If the machine booted the correct image but failed to contact Foreman, check the foreman.url option on the PXELinux Template. Check that the DNS is working for the image or add an IP address in the foreman.url option to check if the DHCP is handling IP addresses to the booted image correctly.
				

	
					If the root account is locked on the image and SSH access is disabled but log-in access is still available on the terminal. Provide the rootpw option on the command line. Run the following command to generate a salted password: 
$ openssl passwd ­salt RH redhat
RHhwCLrQXB8zE


				




			Report a bug
		



      ⁠Chapter 14. Configuring Host Collections




		The Host Collections application tab is a system management tool that allows the administrator to:
	
	
				Add hosts to a collection.
			

	
				Apply a mass installation of packages, errata, or package groups to all host members of a host collection.
			

	
				Update specific packages, errata, or specific package groups to all host members.
			




		Report a bug
	

      ⁠14.1. Creating a Host Collection




		These steps show how to create Host Collections in Red Hat Satellite.
	

      ⁠Procedure 14.1. Create Host Collections
	
				Click Hosts → Host Collections.
			

	
				Click the New Host Collection button.
			

	
				Add the Name and Description of the Host Collection.
			

	
				Uncheck the Unlimited Content Hosts button to specify the maximum number of hosts that will be allowed to the group. Otherwise, leave it checked to allow unlimited hosts to join the host collection.
			

	
				Click the Save button.
			




      ⁠Result:

			A new host collection is created.
		

		Report a bug
	


      ⁠14.2. Adding Hosts to a Host Collection




		These steps show how to add hosts to host collections in Red Hat Satellite.
	

      ⁠Task Prerequisites

			You must meet the following condition before continuing with this task:
		
	
				A host must be registered to Red Hat Satellite in order to add it to a Host Collection. Refer to Section 12.5.1, “Registering a Host” for information on how to register a host.
			




      ⁠Procedure 14.2. Create Host Collections
	
				Click Hosts → Host Collections.
			

	
				Click the host collection where the host should be added.
			

	
				Click the Content Hosts subtab.
			

	
				Click the Add tab.
			

	
				Check the box next to the desired host and click the Add Selected button.
			




		Report a bug
	


      ⁠14.3. Adding Content to Host Collections




      ⁠14.3.1. Adding Packages to a Host Collection




		These steps show how to add packages to host collections in Red Hat Satellite.
	

      ⁠Task Prerequisites

			You must meet the following conditions before continuing with this task:
		
	
				The content to be added should be available in one of the existing repositories or added prior to this procedure.
			

	
				Content should be promoted to the environment where the hosts are assigned.
			




      ⁠Procedure 14.3. Adding Packages to Host Collections
	
				Click Hosts → Host Collections.
			

	
				Click the host collection where the package should be added.
			

	
				Click the Collection Actions subtab.
			

	
				Click the Package Installation, Removal, and Updates link.
			

	
				In the field provided, type in the package or package group name. Then click:
			
	
						Install ‐ if you wish to install a new package
					

	
						Update ‐ if you wish to update an existing package in the host collection
					







      ⁠Result:

			The selected packages or package groups within the host collection will be installed or updated.
		

		Report a bug
	


      ⁠14.3.2. Adding Errata to a Host Collection




		These steps show how to add errata to host collections in Red Hat Satellite.
	

      ⁠Prerequisites

			You must meet the following conditions before continuing with this task:
		
	
				The errata to be added should be available in one of the existing repositories or added prior to this procedure.
			

	
				Errata should be promoted to the environment where the hosts are assigned.
			




      ⁠Procedure 14.4. Adding Errata to Host Collections
	
				Click Hosts → Host Collections.
			

	
				Choose the host collection where the errata should be added.
			

	
				Click the Collection Actions subtab.
			

	
				Click the Errata Installation link.
			

	
				Choose the errata you wish to push to the host collection and click Install Selected.
			




      ⁠Result:

			The selected errata will be installed in the hosts within the host collection.
		

		Report a bug
	



      ⁠14.4. Removing Content from a Host Collection




		These steps show how to remove packages from host collections in Red Hat Satellite.
	

      ⁠Procedure 14.5. Removing Content from Host Collections
	
				Click Hosts → Host Collections.
			

	
				Click the host collection where the package should be removed.
			

	
				Click the Collection Actions subtab.
			

	
				Click the Package Installation, Removal, and Updates link.
			

	
				In the field provided, type in the package or package group name. Then click Remove.
			




      ⁠Result:

			The package or package group will be removed from all hosts within the host collection.
		

		Report a bug
	


      ⁠14.5. Changing the Assigned Life Cycle Environment or Content View for a Host Collection




		These steps show change the assigned life cycle environment or content view of a host collections in Red Hat Satellite.
	

      ⁠Procedure 14.6. Changing the Assigned Life Cycle Environment or Content View
	
				Click Hosts → Host Collection.
			

	
				Choose the host collection where the life cycle environment or content view should be changed.
			

	
				Click the Collection Actions subtab.
			

	
				Select Change assigned Life Cycle Environment or Content View.
			

	
				Select a life cycle environment by checking the check box next to the required life cycle environment.
			

	
				Select the required content view.
			

	
				Click Assign.
			




		Report a bug
	


      ⁠14.6. Removing a Host from a Host Collection




		These steps show how to remove hosts from host collections in Red Hat Satellite.
	

      ⁠Procedure 14.7. Remove Hosts from Host Collections
	
				Click Hosts → Host Collections.
			

	
				Choose the desired Host Collection.
			

	
				Click the Content Hosts subtab.
			

	
				Check the box next to the host you wish to remove from the host collection.
			

	
				Click the Remove Selected button to remove the host from the host collection.
			




      ⁠Result:

			A host is removed from the host collection.
		

		Report a bug
	


      ⁠14.7. Removing a Host Collection




		These steps show how to remove a host collection in Red Hat Satellite.
	
	
				Click Hosts → Host Collections.
			

	
				Choose the host collection to be removed.
			

	
				Click the Remove button. An alert box appears:
			

				
Are you sure you want to remove host collection Host Collection Name?


			

	
				Click the Remove button.
			




      ⁠Result:

			The host collection is removed.
		

		Report a bug
	


      ⁠14.8. Cloning a Host Collection




		These steps show how to clone a host collection in Red Hat Satellite.
	
	
				Click Hosts → Host Collections.
			

	
				On the left hand panel, click the host collection you wish to clone.
			

	
				On the right hand corner of the host collection details, click Copy Collection.
			

	
				Add the desired name of the newly cloned host collection.
			

	
				Click the Create button.
			




      ⁠Result

			A cloned copy of the host collection is created.
		

		Report a bug
	


      ⁠14.9. Reviewing Host Collection Actions




      ⁠Prerequisites

			Requires an existing host collection.
		

      ⁠Procedure 14.8. Reviewing Host Collection Actions
	
				Click Hosts → Host Collections.
			

	
				Click the host collection you wish to view the actions of.
			

	
				Click on the Details subtab.
			




      ⁠Result

			All events history and actions performed on the host collection is displayed.
		

		Report a bug
	



      ⁠Chapter 15. Red Hat Satellite Capsule Servers




		The Red Satellite Capsule Server is a Satellite component that provides federated services to discover, provision, and configure hosts outside of the primary Satellite server. A Satellite Capsule Server provides the following features:
	
	
				Pulp Server/Content Node features, including:
			
	
						Repository synchronization
					

	
						Content delivery
					




	
				Red Hat Satellite Provisioning Smart Proxy features, including:
			
	
						DHCP, including ISC DHCP servers
					

	
						DNS, including Bind and MS DNS servers
					

	
						Any UNIX-based TFTP server
					

	
						Puppet Master servers from 0.24
					

	
						Puppet CA to manage certificate signing and cleaning
					

	
						Baseboard Management Controller (BMC) for power management
					







		The Satellite Capsule Server is a means to scale out the Satellite installation. Organizations can create various capsules in different geographical locations where the data centers are located. These are centrally managed through the Satellite Server. When a Satellite user promotes content to the production environment, the Satellite Server will push the content from the Satellite Server to each of the Satellite Capsule Servers. Host systems pull content and configuration from the Satellite Capsule Servers in their location and not from the central Satellite Server.
	

		Creating various Satellite Capsule Servers will decrease the load on the central server, increase redundancy, and reduce bandwidth usage.
	

		Report a bug
	

      ⁠15.1. Red Hat Satellite Capsule Server Scalability




			The maximum number of Capsule Servers that the Satellite Server can support has no fixed limit but has been tested on a Satellite Server with a Red Hat Enterprise Linux 6.5 and 7 host systems. To date, running 14 capsules with two vCPUs has been successfully tested.
		

			Capsule scalability depends heavily on the following factors, especially when managing puppet clients:
		
	
					Number of CPUs
				

	
					Run-interval distribution
				

	
					Number of puppet classes
				




			The Capsule Server has a concurrency limitations of 100 concurrent puppet agents running at any single point in time. Running more than 100 concurrent puppet agents will result in a 503 HTTP error.
		

			For example, assuming that the puppet agent runs are evenly distributed with less than 100 concurrent puppet agents running at any single point during a run-interval, a Capsule Server with four CPUs can expect a maximum of 1250-1600 puppet clients with a moderate workload of 10 puppet classes assigned to each puppet client. Depending on the number of puppet clients required, the Satellite installation can scale out the number of Capsule Servers to support them.
		

			Based on the following assumptions:
		
	
					There are no external puppet clients reporting directly to the Satellite 6 integrated capsule.
				

	
					All other puppet clients report directly to an external capsule.
				




			Puppet scalability within Satellite on Red Hat Enterprise Linux 6.5 Capsules are as follows:
		
	
					On the minimum amount of CPUs (two CPUs):
				
	
							At 1 puppet class per host: Not tested
						

	
							At 10 puppet classes per host: Maximum of 1020-860
						

	
							At 20 puppet classes per host: Maximum of 375-330
						




	
					On the recommended amount of CPUs (four CPUs):
				
	
							At 1 puppet class per host: Maximum of 2250-1875
						

	
							At 10 puppet classes per host: Maximum of 1600-1250
						

	
							At 20 puppet classes per host: Maximum of 700-560
						






Note


				The maximums in the above given numbers represent an evenly distributed run interval of all puppet agents. Any deviation runs the risk of filling the passenger request queue and is subject to the concurrency limitation of 100 concurrent requests.
			



			Report a bug
		


      ⁠15.2. Red Hat Satellite Capsule Server Prerequisites




		The Satellite Capsule's requirements are identical to the Satellite Server. These conditions must be met before installing Red Hat Satellite Capsule:
	

      ⁠Base Operating System

			Red Hat Satellite Capsule is supported on Red Hat Enterprise Linux 6.5 or later, as well as Red Hat Enterprise Linux 7. Install the operating system from disc, local ISO image, kickstart, or any other methods that Red Hat supports. Red Hat Satellite Capsule requires Red Hat Enterprise Linux installations with the @Base package group with no other package-set modifications, and without third-party configurations or software that is not directly necessary for the direct operation of the server. This restriction includes hardening or other non-Red Hat security software. If such software is required in your infrastructure, install and verify a complete working Red Hat Satellite Capsule first, then create a backup of the system before adding any non-Red Hat software.
		

		When installing Red Hat Enterprise Linux from CD or ISO image, there is no need to select any package groups; Red Hat Satellite Capsule only requires the base operating system installation. When installing the operating system via kickstart, select the @Base package group.
	
	
				There should be at least one networked host with the following minimum specifications:
			
	
						64-bit architecture
					

	
						Red Hat Enterprise Linux 6.5 or later
					

	
						A minimum of two CPU cores, but four CPU cores are recommended
					

	
						A minimum of 8 GB of memory but ideally 12 GB of memory for each Satellite instance. It is also recommended to use 4 GB of swap space where possible.
					

	
						A minimum of 5 GB of storage for the base install of Red Hat Enterprise Linux, 300 MB for the installation of Red Hat Satellite Capsule and at least 10 GB storage for each unique software repository to be synchronized in the /var file system.
					

						Packages that are duplicated in different channels are only stored once on the disk. Additional repositories containing duplicate packages will require less additional storage.
					
Note


							The bulk of storage resides on the /var/lib/mongodb and /var/lib/pulp directories. These end points are not manually configurable. Ensure that sufficient storage is available on the /var file system to prevent storage issues.
						



	
						No Java virtual machine installed on the system, remove any if they exist.
					

	
						No Puppet RPM files installed on the system
					

	
						No third-party unsupported yum repositories enabled. Third-party repositories may offer conflicting or unsupported package versions that may cause installation or configuration errors.
					




	
				Administrative user (root) access
			

	
				Full forward and reverse DNS resolution using a fully qualified domain name. Check that hostname and localhost resolve correctly, using the following commands:
			

# ping -c1 localhost
# ping -c1 `hostname -s` # my_system
# ping -c1 `hostname -f` # my_system.domain.com


	
				Available subscriptions on the Red Hat Satellite Server.
			



Important


			Make sure that the host system is fully updated before installing Red Hat Satellite. Attempts to install on host systems running Red Hat Enterprise Linux that are not fully updated may lead to difficulty in troubleshooting, as well as unpredictable results.
		



      ⁠Application Specifications

			Satellite application installation specifications are as follows:
		

		It is recommended that a time synchronizer such as ntpd is installed and enabled on Satellite. Run the following command to start the ntpd service and have it persist across restarts:
	
# service ntpd start; chkconfig ntpd on

      ⁠Required Network Ports

			The following conditions must be met before continuing with this task:
		
	
				Port 443 for HTTPS (secure WWW) must be open for incoming connections.
			

	
				Port 5671 must be open for SSL communication with managed systems.
			

	
				Port 80 for HTTP (WWW) must be open to download the bootstrap files.
			

	
				Port 8080 for TCP must be free for java connections.
			

	
				Port 8140 must be open for incoming Puppet connections with the managed systems.
			

	
				Port 9090 must be open for Foreman Smart Proxy connections with the managed systems.
			




		Run the following commands to configure the firewall with the iptables command and to make these rules persistent during reboots:
	
	
				For Red Hat Enterprise Linux 6:
			

# iptables -I INPUT -m state --state NEW -p tcp --dport 443 -j ACCEPT \
&& iptables -I INPUT -m state --state NEW -p tcp --dport 5671 -j ACCEPT \
&& iptables -I INPUT -m state --state NEW -p tcp --dport 80 -j ACCEPT \
&& iptables -I INPUT -m state --state NEW -p tcp --dport 8140 -j ACCEPT \
&& iptables -I INPUT -m state --state NEW -p tcp --dport 9090 -j ACCEPT \
&& iptables -I INPUT -m state --state NEW -p tcp --dport 8080 -j ACCEPT \
# iptables-save > /etc/sysconfig/iptables


	
				For Red Hat Enterprise Linux 7:
			

# firewall-cmd --permanent --add-port="443/tcp" --add-port="5671/tcp" --add-port="80/tcp" --add-port="8140/tcp" --add-port="9090/tcp" --add-port="8080/tcp"
# firewall-cmd --complete-reload





      ⁠Red Hat Satellite Server

			The Satellite Server must have the Red Hat Software Collections repositories enabled and synchronized prior to the Capsule Server installation.
		
Important


			Red Hat recommends that the Satellite Capsule system be a freshly provisioned system that serves no other function except as a Satellite Capsule.
		



		Report a bug
	


      ⁠15.3. Installing a Red Hat Satellite Capsule Server




      ⁠Prerequisites

			The Capsule Server must be registered to the Red Hat Satellite Server to use the Red Hat Satellite Server products and subscriptions:
		
	
				Install the Red Hat Satellite Server's CA certificate in the Capsule Server:
			

# rpm -Uvh http://satellite.example.com/pub/katello-ca-consumer-latest.noarch.rpm


	
				Register the Capsule Server under your chosen organization's name:
			

# subscription-manager register --org "your organization"





		This procedure installs a Red Hat Satellite Capsule Server onto a host.
	

      ⁠Procedure 15.1. To Install a Satellite Capsule Server on a Certificate-managed System:
	
				List all the available subscriptions to find the correct Red Hat Satellite and Red Hat Enterprise Linux product to allocate to your system:
			
 # subscription-manager list --available --all

				The screen displays:
			

+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+


ProductName:        Red Hat Satellite
ProductId:          SKU123456
PoolId:             e1730d1f4eaa448397bfd30c8c7f3d334bd8b
Quantity:           10
Multi-Entitlement:  No
Expires:            08/20/2013
MachineType:        physical

Note


					The SKU and Pool ID depend on the Red Hat Satellite product type that corresponds to your system version and product type.
				



	
				Subscribe to the pool using the following command:
			
# subscription-manager subscribe --pool=Red_Hat_Satellite_Pool_Id
# subscription-manager subscribe --pool=Red_Hat_Enterprise_Linux_Pool_Id
# subscription-manager subscribe --pool=Red_Hat_Enterprise_Linux_Software_Collections_Pool_Id 

	
				Disable all existing repositories:
			

# subscription-manager repos --disable "*"


	
				Enable the Satellite and Red Hat Enterprise Linux repositories by running subscription-manager. You might need to alter the Red Hat Enterprise Linux repository to match the specific version you are using.
			
# subscription-manager repos --enable rhel-6-server-rpms \
--enable rhel-server-rhscl-6-rpms \
--enable rhel-6-server-satellite-capsule-6.0-rpms

	
				Install the katello-installer and cyrus-sasl-plain packages using the yum install command as the root user:
			
# yum install katello-installer cyrus-sasl-plain

				The katello-installer provides the capsule-installer functionality while cyrus-sasl-plain is required for pulp.
			




      ⁠Result:

			The Satellite Capsule Server is installed on your host system. The Satellite Capsule Server must be configured before it can be used.
		

		Report a bug
	


      ⁠15.4. Configuring a Red Hat Satellite Capsule Server




      ⁠Prerequisite

			You must meet the following conditions before continuing on this task:
		
	
				Install the Red Hat Satellite Server.
			

	
				Set the SELinux permissions on the system designated as the Satellite Capsule Server as enforcing.
			




		The following procedures configure a Satellite Capsule Server for use with your Red Hat Satellite Server. This includes the following types of Satellite Capsule Servers:
	
	
				Satellite Capsule Server with Smart Proxy
			

	
				Satellite Capsule Server as a Content Node
			

	
				Satellite Capsule Server as a Content Node with Smart Proxy
			




			To configure a Satellite Capsule Server:
		
	
				On the Satellite Server:
			
	
						Generate a Satellite Capsule Server certificate:
					

capsule-certs-generate --capsule-fqdn capsule_FQDN --certs-tar ~/capsule.example.com-certs.tar


						Where: 
							
									capsule_FQDN is the Satellite Capsule Server's fully qualified domain name. (REQUIRED)
								

	
									certs-tar is the name of the tar file to be generated that contains the certificate to be used by the Satellite Capsule installer.
								





					

						Running capsule-certs-generate will generate the following output message:
					

    To finish the installation, follow these steps:
  1. Ensure that the capsule-installer is available on the system.
     The capsule-installer comes from the katello-installer package and
     should be acquired through the means that are appropriate to your deployment.
  2. Copy ~/capsule.example.com-certs.tar to the capsule system capsule.example.com
  3. Run the following commands on the capsule (possibly with the customized
     parameters, see capsule-installer --help and
     documentation for more info on setting up additional services):
  rpm -Uvh http://master.com/pub/katello-ca-consumer-latest.noarch.rpm
  subscription-manager register --org "Default Organization"
  capsule-installer --parent-fqdn          "sat6.example.com"\
                    --register-in-foreman  "true"\
                    --foreman-oauth-key    "xmmQCGYdkoCRcbviGfuPdX7ZiCsdExf"\
                    --foreman-oauth-secret "w5ZDpyPJ24eSBNo53AFybcnqoDYXgLUA"\
                    --pulp-oauth-secret    "doajBEXqNcANy93ZbciFyysWaiwt6BWU"\
                    --certs-tar            "~/capsule.example.com-certs.tar"\
                    --puppet               "true"\
                    --puppetca             "true"\
                    --pulp                 "true"


	
						Copy the generated tarball, capsule.example.com-certs.tar, from the Satellite Server to the Satellite Capsule host system.
					



	
				On the Satellite Capsule Server:
			
	
						Register your Satellite Capsule Server to the Satellite Server:
					

# rpm -Uvh http://sat6host.example.redhat.com/pub/katello-ca-consumer-latest.noarch.rpm
# subscription-manager register --org "Default Organization" --env [environment]/[content_view_name]

Note


							The Satellite Capsule Server must be assigned to an organization as the Satellite Capsule Server requires an environment to synchronize content from the Satellite Server. Only organizations have environments.
						

							Assigning a location is optional though recommended to indicate proximity to the hosts that the Satellite Capsule Server is managing.
						



	
						Depending on the desired Satellite Capsule Server type, choose one of the following options:
					
	
								Option 1: Satellite Capsule Server with Smart Proxy: This installs a Satellite Capsule Server with Smart Proxy features (DHCP, DNS, Puppet). Run the following commands as the root user on the Satellite Capsule Server:
							

# capsule-installer --parent-fqdn          "satellite.example.com"\
                    --register-in-foreman  "true"\
                    --foreman-oauth-key    "xmmQCGYdkoCRcbviGfuPdX7ZiCsdExf"\
                    --foreman-oauth-secret "w5ZDpyPJ24eSBNo53AFybcnqoDYXgLUA"\
                    --pulp-oauth-secret    "doajBEXqNcANy93ZbciFyysWaiwt6BWU"\
                    --certs-tar            "/root/capsule.example.com-certs.tar"\
                    --puppet               "true"\
                    --puppetca             "true"\
                    --pulp                 "true"\
                    --tftp                 "true"\
                    --dhcp                 "true"\
                    --dhcp-interface       "virbr1"\
                   --dns                  "true"\
                   --dns-forwarders       "8.8.8.8"\
                   --dns-forwarders       "8.8.4.4"\
                   --dns-interface        "virbr1"\
                   --dns-zone             "example.com"



	
								Option 2 - Satellite Capsule Server as a Content Node with Smart Proxy: This installs a Satellite Capsule Server with all the features. Run the following commands as the root user on the Satellite Capsule Server:
							

# capsule-installer --parent-fqdn          "sat6.example.com"\
                    --register-in-foreman  "true"\
                    --foreman-oauth-key    "xmmQCGYdkoCRcbviGfuPdX7ZiCsdExf"\
                    --foreman-oauth-secret "w5ZDpyPJ24eSBNo53AFybcnqoDYXgLUA"\
                    --pulp-oauth-secret    "doajBEXqNcANy93ZbciFyysWaiwt6BWU"\
                    --certs-tar            "/root/capsule.example.com-certs.tar"\
                    --puppet               "true"\
                    --puppetca             "true"\
                    --pulp                 "true"\
                    --tftp                 "true"\
                    --dhcp                 "true"\
                    --dhcp-interface       "virbr1"\
                   --dns                  "true"\
                   --dns-forwarders       "8.8.8.8"\
                   --dns-forwarders       "8.8.4.4"\
                   --dns-interface        "virbr1"\
                   --dns-zone             "example.com"







	
				Run the following commands to configure the firewall to limit elasticsearch to the foreman, katello and root users and make these rules persistent during reboots:
			
	
						For Red Hat Enterprise Linux 6:
					

iptables -A OUTPUT -o lo -p tcp -m tcp --dport 9200 -m owner --uid-owner foreman -j ACCEPT \
&& iptables -A OUTPUT -o lo -p tcp -m tcp --dport 9200 -m owner --uid-owner katello -j ACCEPT \
&& iptables -A OUTPUT -o lo -p tcp -m tcp --dport 9200 -m owner --uid-owner root -j ACCEPT \
&& iptables -A OUTPUT -o lo -p tcp -m tcp --dport 9200 -j DROP
iptables-save > /etc/sysconfig/iptables


	
						For Red Hat Enterprise Linux 7:
					

firewall-cmd --permanent --direct --add-rule ipv4 filter OUTPUT 0 -o lo -p tcp -m tcp --dport 9200 -m owner --uid-owner foreman -j ACCEPT \
&& firewall-cmd --permanent --direct --add-rule ipv6 filter OUTPUT 0 -o lo -p tcp -m tcp --dport 9200 -m owner --uid-owner foreman -j ACCEPT \
&& firewall-cmd --permanent --direct --add-rule ipv4 filter OUTPUT 0 -o lo -p tcp -m tcp --dport 9200 -m owner --uid-owner katello -j ACCEPT \
&& firewall-cmd --permanent --direct --add-rule ipv6 filter OUTPUT 0 -o lo -p tcp -m tcp --dport 9200 -m owner --uid-owner katello -j ACCEPT \
&& firewall-cmd --permanent --direct --add-rule ipv4 filter OUTPUT 0 -o lo -p tcp -m tcp --dport 9200 -m owner --uid-owner root -j ACCEPT \
&& firewall-cmd --permanent --direct --add-rule ipv6 filter OUTPUT 0 -o lo -p tcp -m tcp --dport 9200 -m owner --uid-owner root -j ACCEPT \
&& firewall-cmd --permanent --direct --add-rule ipv4 filter OUTPUT 1 -o lo -p tcp -m tcp --dport 9200 -j DROP \
&& firewall-cmd --permanent --direct --add-rule ipv6 filter OUTPUT 1 -o lo -p tcp -m tcp --dport 9200 -j DROP







Note


			If the configuration is successful, run this command as the root user on the Satellite Capsule Server:
		

# echo $?


			This command should return a "0" to indicate success. If it does not, check /var/log/kafo to debug the cause of failure. /var/log/kafo is the log file for the output generated by the commands capsule-certs-generate and capsule-installer.
		

			The Satellite Capsule Server should also appear in the Satellite Server's User Interface under Infrastructure → Capsules.
		



      ⁠Result:

			The Satellite Capsule Server is now configured and registered with the Satellite Server.
		

		Report a bug
	


      ⁠15.5. Using Power Management Features on Managed Hosts




		When you enable the BMC (Baseboard Management Controller) module on the Capsule Server, you can use power management commands on managed hosts using the IPMI (Intelligent Platform Management Interface) or a similar protocol.
	

		The BMC service on the satellite Capsule Server allows you to perform a range of power management tasks. The underlying protocol for this feature is IPMI; also referred to as the BMC function. IPMI uses a special network interface on the managed hardware that is connected to a dedicated processor that runs independently of the host's CPUs. In many instances the BMC functionality is built into chassis-based systems as part of chassis management (a dedicated module in the chassis).
	

		To take advantage of BMC features you need to add a new network interface of type "BMC" to each managed host. IPMI interfaces are nearly always password protected, to prevent unauthorized people on the same network from gaining control of that host. Satellite uses this NIC to pass the appropriate credentials to the host. See Section 12.4.4, “Adding a BMC Interface”.
	

		Red Hat Satellite supports by extension everything that either ipmitool or freeipmi BMC providers support. You can switch between the two per capsule. Note that different hardware vendors might not implement all IPMI specifications, bugs, and so on.
	

      ⁠15.5.1. Enabling BMC Power Management




			You can enable the BMC module as part of the installation process, or you can update the required configuration files on an existing system.
		
Enabling BMC During Installation

				To enable BMC power management as part of the installation process, add the following lines to the capsule-installer command:
			
--bmc "enabled"\
--bmc_default_provider "freeipmi"

			See "Installing a Red Hat Satellite Capsule Server" in the Red Hat Satellite Installation Guide for full details on installing a Capsule Server.
		
Enabling BMC After Installation

				The following procedure describes how to enable BMC power management on an existing Capsule Server. This requires editing the appropriate configuration file and restarting the required services.
			

      ⁠Procedure 15.2. To Enable BMC Power Management on an Existing Capsule:
	
					Add the following lines to the /etc/foreman-proxy/settings.d/bmc.yml file. Create the file if necessary.
				
:enabled: true
:bmc_default_provider: your_bmc_provider

	
					Restart the foreman-proxy service:
				
# service foreman-proxy restart

	
					Refresh the features for the Capsule.
				
	
							Log in to the Satellite web UI, and navigate to Infrastructure → Capsules.
						

	
							Identify the Capsule whose features you need to refresh. In the drop-down list on the right, click Refresh features. The list of features in the Features column should now include BMC.
						







      ⁠15.5.2. Configuring a BMC Interface




			This section describes how to configure a BMC interface for a host that supports this feature.
		

      ⁠15.5.2.1. Prerequisites




				Ensure the following prerequisites are satisfied before proceeding: 
					
							BMC is enabled on the Capsule, as described in Section 15.5.1, “Enabling BMC Power Management”.
						

	
							The ipmitool package is installed.
						

	
							You know the MAC address, IP address, and other details of the BMC interface on the host, and the appropriate credentials for that interface.
						





			


      ⁠15.5.2.2. Adding a BMC Interface




				This section describes how to add the actual interface configuration to the Capsule server.
			

      ⁠Procedure 15.3. To Add a BMC Interface:
	
						On the main menu, click Hosts → All Hosts and then click the name of the host that you want to configure.
					

	
						Click Edit to display the host configuration page, and then click the Network tab.
					

	
						In the Interface section, click Add Interface.
					

	
						Select BMC as the interface type, and then complete the other fields. All fields are required.
					

	
						Click Submit. The web UI refreshes and you should see a BMC tab listed with the Properties, Metrics, and Templates tabs.
					







      ⁠15.6. Adding Life Cycle Environments to a Red Hat Satellite Capsule Server




		If the newly created Red Hat Satellite Capsule Server has Content Node features enabled, the Satellite Capsule Server needs an environment added to the Satellite Capsule Server. Adding an environment to the Red Hat Satellite Capsule Server will allow the Satellite Capsule Server to synchronize content from the Satellite Server and provide content to host systems.
	
Important


			The Satellite Capsule Server is configured through the Satellite Server's command line interface (CLI). Execute all hammer commands on the Satellite Server.
		



		To add environments to your Satellite Capsule Server:
	
	
				Log in to the Satellite Server CLI as root.
			

	
				Choose the desired Red Hat Satellite Capsule Server from the list and take note of its id:
			

# hammer capsule list


				The Satellite Capsule Server's details can be verified using the command:
			

# hammer capsule info --id capsule_id_number


	
				Verify the list of life cycle environments available for the Red Hat Capsule Server and note down the environment id:
			

# hammer capsule content available-lifecycle-environments --id capsule_id_number


				Where:
			
	
						available-lifecycle-environments are life cycle environments that are available to the Satellite Capsule but are currently not attached to the Satellite Capsule.
					




	
				Add the life cycle environment to the Satellite Capsule Server:
			

# hammer capsule content add-lifecycle-environment --id capsule_id_number --lifecycle-environment-id environment_id_number


				Where:
			
	
						--id is the Satellite Capsule Server's identification number.
					

	
						--lifecycle-environment-id is the life cycle environment's identification number.
					




				Repeat this step for every life cycle environment to be added to the Capsule Server.
			

	
				Synchronize the content from the Satellite Server's environment to the Satellite Capsule Server:
			

# hammer capsule content synchronize --id capsule_id_number


				When a Satellite Capsule Server has various life cycle environments, and only one life cycle environment needs to be synchronized, it is possible to target a specific environment by specifying the environment identification:
			

# hammer capsule content synchronize --id 1 --environment-id 1





      ⁠Result:

			The chosen environments now consume packages from repositories on the desired Satellite Capsule Server.
		

		Report a bug
	


      ⁠15.7. Removing Life Cycle Environments from the Red Hat Satellite Capsule Server




		There are multiple reasons to remove life cycle environments from the Red Hat Satellite Capsule Server. For example:
	
	
				When life cycle environments are no longer relevant to the host systems
			

	
				When life cycle environments have been incorrectly added to the Satellite Capsule Server
			




		To remove a life cycle environment from the Satellite Capsule Server:
	
	
				Log in to the Satellite Server CLI as the root user.
			

	
				Choose the desired Red Hat Satellite Capsule Server from the list and take note of its id:
			

# hammer capsule list


				The Satellite Capsule Server's details can be verified using the command:
			

# hammer capsule info --id capsule_id_number


	
				Verify the list of life cycle environments currently attached to the Red Hat Capsule Server and note down the environment id:
			

hammer capsule content lifecycle-environments --id capsule_id_number


	
				Remove the life cycle environment from the Satellite Capsule Server:
			

# hammer capsule content remove-lifecycle-environment --id capsule_id_number --environment-id environment_id


				Where:
			
	
						--id is the Satellite Capsule Server's identification number.
					

	
						--environment-id is the life cycle environment's identification number.
					




				Repeat this step for every life cycle environment to be removed from the Capsule Server.
			

	
				Synchronize the content from the Satellite Server's environment to the Satellite Capsule Server:
			

# hammer capsule content synchronize --id capsule_id_number





      ⁠Result:

			The chosen environments are removed from the Satellite Capsule Server.
		

		Report a bug
	


      ⁠15.8. Registering Host Systems to a Red Hat Satellite Capsule Server




      ⁠Prerequisite

			Client system must be configured for registration. The following chapters in the Red Hat Satellite User Guide can assist with configuration:
		
	
				Configuring Hosts for Registration
			

	
				Automated Configuration
			

	
				Manual Configuration
			

	
				Creating a New Activation Key
			




		Systems can be registered to the parent host while using a Satellite Capsule as a content source. Register the system to the Satellite 6 server through subscription-manager but reference the Satellite Capsule by using the --baseurl flag provided by Subscription Manager using /pulp/repos as the prefix.
	

# subscription-manager register --org [org_name] --activationkey [your_activation_key] --baseurl https://satcapsule.example.com/pulp/repos

		Report a bug
	


      ⁠15.9. Refreshing a Red Hat Satellite Capsule Server




      ⁠Procedure 15.4. Refreshing a Red Hat Satellite Capsule Server
	
				Select Infrastructure → Capsules.
			

	
				Select Refresh Features from the drop down menu to the right of the name of the capsule you want to refresh.
			




      ⁠Result

			The capsule is refreshed with the changes that have been made.
		

		Report a bug
	



      ⁠Chapter 16. Users and Roles




		A User defines a set of details for individuals using the system. Users can be associated with organizations and environments, so that when they create new entities, the default settings are automatically used. Users can also have one or more roles attached, which grants them rights to view and manage organizations and environments. See Section 16.2, “Creating and Managing Users” for more information on working with users.
	

		Roles define a set of permissions and access levels. Each role contains one on more permission filters that specify the actions allowed for the role. Actions are grouped according to the Resource type. Once a role has been created, users and user groups can be associated with that role. This way, you can assign the same set of permissions to large groups of users. Red Hat Satellite provides a set of predefined roles and also enables creating custom roles and permission filters as described in Section 16.3, “Creating and Managing Roles”.
	

      ⁠16.1. Configuring LDAP Authentication for Red Hat Satellite




		Red Hat Satellite includes the option to use a Lightweight Directory Access Protocol (LDAP) service for user information and authentication, using one or more LDAP directories. The following procedure shows how to configuring LDAP authentication.
	

      ⁠Procedure 16.1. To Configure LDAP Authentication:
	
				Navigate to Administer → LDAP Authentication.
			

	
				Click New authentication source.
			

	
				On the LDAP Server tab, enter the LDAP server's name, hostname, port, and server type. The default port is 389. Select the LDAPS check box enable encryption.
			

	
				On the Account tab, enter the following information:
			
	
						Account username: an LDAP user who has read access to the LDAP server. User name is not required if the server allows anonymous reading, otherwise use the full path to the user's object. For example:
					

uid=$login,cn=users,cn=accounts,dc=example,dc=com


	
						Account password: the LDAP password for the user defined in the Account username field. This field can remain blank if the Account username is using the "$login" variable.
					

	
						Base DN: the top level domain name of your LDAP directory. For example:
					

cn=users,cn=accounts,dc=redhat,dc=com


	
						Groups base DN: the top level domain name of your LDAP directory tree that contains groups.
					

	
						LDAP filter: a filter to restrict your LDAP queries.
					

	
						Automatically create accounts in Foreman: creates Satellite accounts automatically for LDAP users who log in for the first time in Satellite.
					




	
				On the Attribute mappings tab, map LDAP attributes to Satellite attributes. You can map Login name, First name, Surname, Email address, and Photo attributes.
			

	
				Click Submit.
			




		Report a bug
	


      ⁠16.2. Creating and Managing Users




			For the administrator, Red Hat Satellite provides an ability to create, modify, and remove users. Also, it is possible to configure access permissions through assigning roles to users or user groups.
		

      ⁠16.2.1. Creating a User




				The following steps show how to create a user:
			

      ⁠Procedure 16.2. To Create a User:
	
						Navigate to Administer → Users and then click New User.
					

	
						Enter the required details on the User tab.
					

	
						On the Locations tab, select the required locations for this user.
					

	
						On the Organizations tab, select the required organizations for this user.
					

	
						On the Roles tab, select the required roles for this user. Active roles are displayed in the right panel.
					

	
						Click Submit to create the user.
					





      ⁠16.2.2. Editing a User




				The following steps show how to edit details of an existing user:
			

      ⁠Procedure 16.3. To Edit an Existing User:
	
						Navigate to Administer → Users.
					

	
						Click the user name of the user to be altered. General information about the user will appear on the right.
					

	
						You can modify the user's username, first name, surname, email address, default location, default organization, language, and password in the User tab.
					

	
						You can modify the user's assigned locations in the Locations tab.
					

	
						You can modify the user's assigned organizations in the Organizations tab. If no organization is selected, the user can access all available organizations.
					

	
						You can modify the user's assigned roles in the Roles tab.
					

	
						Click Save to save your changes.
					





      ⁠16.2.3. Assigning Roles to Users




				By default, a new user has no roles assigned. The following procedure describes how to assign one or more roles to a user. You can select from predefined roles, or define a custom role as described in Section 16.3.1, “Creating a Role”. You can apply a similar procedure to user groups.
			

      ⁠Procedure 16.4. To Assign a Role to a User:
	
						Navigate to Administer → Users.
					

	
						Click the user name of the user that you want to modify. General information about the user appears on the right.
					

	
						Click the Roles tab to display the list of available role assignments.
					

	
						Select role you want to assign to the user in the Roles list. The list contains the predefined roles, as well as any custom roles, see Table 16.1, “Predefined Roles Available in Red Hat Satellite”. Alternatively, select the Administrator check box to assign all available permissions to the selected user.
					

	
						Click Save.
					




				To view the roles assigned to any user, access the Roles tab as described in the first three steps of the above procedure. To remove a role, click the role name in the Selected items list in the Roles tab.
			


      ⁠16.2.4. Removing Users




				The following procedure describes how to remove an existing user.
			

      ⁠Procedure 16.5. To Remove a User:
	
						On the main menu, click Administer → Users to open the Users page.
					

	
						Click the Delete link to the right of the username you want to delete.
					

	
						In the alert box, click OK to delete the user.
					




				Report a bug
			



      ⁠16.3. Creating and Managing Roles




			Red Hat Satellite provides a set of predefined roles with permissions sufficient for standard tasks, as listed in Table 16.1, “Predefined Roles Available in Red Hat Satellite”. It is also possible to configure custom roles, and assign one or more permission filters to them. Permission filters define the actions allowed for a certain resource type. Certain Foreman plug-ins create roles automatically.
		

      ⁠Table 16.1. Predefined Roles Available in Red Hat Satellite
	Role	Description
      ⁠[a]
	 Anonymous 	 The set of permissions that every user is granted, irrespective of any other roles. 
	 Discovery manager 	 View, provision, edit, and destroy discovered hosts and manage discovery rules. 
	 Discovery reader 	 View hosts and discovery rules. 
	 Boot disk access 	 Download the boot disk. 
	 Red Hat Access Logs 	 View the log viewer and the logs. 
	 Manager 	 A most extensive set of permissions, the majority of actions from each resource type is enabled. 
	 Edit partition tables 	 View, create, edit and destroy partition tables. 
	 View hosts 	 View hosts. 
	 Edit hosts 	 View, create, edit, destroy, and build hosts. 
	 Viewer 	 A passive role that provides the ability to view the configuration of every element of the Satellite structure, logs, and statistics. 
	 Site manager 	 A restrained version of the Manager role. 
	 Tasks manager 	 View and edit Foreman tasks. 
	 Tasks reader 	 View Foreman tasks. 
	[a] 
							The exact set of allowed actions associated with predefined roles can be viewed by the privileged user as described in Section 16.3.3, “Viewing Permissions Assigned to a Role”.
						






      ⁠16.3.1. Creating a Role




				The following steps show how to create a role.
			

      ⁠Procedure 16.6. To Create a Role:
	
						Navigate to Administer → Roles.
					

	
						Click New Role.
					

	
						Provide a Name for the role.
					

	
						Click Submit to save your new role.
					




				To serve its purpose, a role must contain permissions. After creating a role, proceed to Section 16.3.2, “Adding Permissions to an Existing Role”.
			
Note


					Cloning an existing role is a time-saving method of role creation, especially if you want to create a new role that is a variation of an existing permission set. To clone a role, navigate to Administer → Roles and select Clone from the drop-down list to the right of the role to be copied. Select the name for the new role and alter the permissions as needed.
				




      ⁠16.3.2. Adding Permissions to an Existing Role




				The following steps show how to add permissions to a role.
			

      ⁠Procedure 16.7. To Add Permissions to a Role:
	
						Navigate to Administer → Roles.
					

	
						Select Add Permission from the drop-down list to the right of the required role.
					

	
						Select the Resource type from the drop-down list. The (Miscellaneous) group gathers permissions that are not associated with any resource group.
					

	
						Click the permissions you want to select from the Permission list.
					

	
						Select whether the permission is Unlimited. This option is selected by default, which means that the permission is applied on all resources of the selected type. When you disable the Unlimited check box, the Search field activates. In this field you can specify further filtering with use of the Red Hat Satellite 6 search syntax. See Section 16.4, “Granular Permission Filtering” for details.
					

	
						Click Next.
					

	
						Click Submit to save changes.
					





      ⁠16.3.3. Viewing Permissions Assigned to a Role




				The following steps show how to view permissions assigned to an existing role.
			

      ⁠Procedure 16.8. To View Permissions of a Role:
	
						Navigate to Administer → Roles.
					

	
						Click Filters to the right of the required role to get to the Filters page.
					




				The Filters page contains a table of permissions assigned to a role grouped by the resource type.
			


      ⁠16.3.4. Removing a Role




				The following steps show how to remove an existing role.
			

      ⁠Procedure 16.9. To Remove a Role:
	
						Navigate to Administer → Roles.
					

	
						Select Delete from the drop-down list to the right of the role to be deleted.
					

	
						In an alert box that appears, click OK to delete the role.
					




				Report a bug
			



      ⁠16.4. Granular Permission Filtering




			As mentioned in Section 16.3.2, “Adding Permissions to an Existing Role”, Red Hat Satellite provides an ability to limit the configured user permissions to selected instances of a resource type. These granular filters are queries to the Satellite database and are supported by the majority of resource types.
		

			To create a granular filter, specify a query in the Search field on the Edit Filter page. Deselect the Unlimited check box for the field to be active. Queries have the following form:
		
field_name operator value

			Where:
		
	
					field_name marks the field to be queried. The range of available field names depends on the resource type. For example, the Partition Table resource type offers family, layout, and name as query parameters.
				

	
					operator specifies the type of comparison between field_name and value. See Table 16.2, “Supported Operators for Granular Search” for an overview of applicable operators.
				

	
					value is the value used for filtering. This can be for example a name of an organization. Two types of wildcard characters are supported: underscore (_) provides single character replacement, while percent sign (%) replaces zero or more characters.
				




			For most resource types, the Search field provides a drop-down list suggesting the available parameters. This list appears after placing the cursor in the search field. For many resource types, it is also possible to combine the queries by using the and and or operators.
		

      ⁠Table 16.2. Supported Operators for Granular Search
	Operator	Description
	 = 	 Is equal to. An equality comparison that is case-sensitive for text fields. 
	 != 	 Is not equal to. An inversion of the = operator. 
	 ~ 	 Like. A case-insensitive occurrence search for text fields. 
	 !~ 	 Not like. An inversion of the ~ operator. 
	 ^ 	 Starts with. A case-insensitive search for text fields starting with a certain string. 
	 !^ 	 Does not start with. An inversion of the ^ operator. 
	 >, >= 	 Greater than, greater than or equal to. Supported for numerical fields only. 
	 <, <= 	 Less than, less than or equal to. Supported for numerical fields only. 




			For example, the following query applies any permissions specified for the Host/managed resource type only to hosts in the group named host-editors.
		
hostgroup = host-editors

			You can also limit permissions to a selected environment. To do so, specify the environment name in the Search field, for example:
		
Dev

			As an administrator, you can allow selected users to make changes in a certain part of the environment path. The above filter allows to work with content while it is in the development stage of the application life cycle, but the content becomes inaccessible once is pushed to production.
		
Note


				Satellite does not apply search conditions to create actions. For example, limiting the create_locations action with name = "Default Location" expression in the search field will not prevent the user from assigning a custom name to the newly created location.
			



			You can limit user permissions to a certain organization or location with use of the permission filter. However, resource types provide a GUI alternative in form of Locations and Organizations tabs. On these tabs, you can select from the list of available organizations and locations. See Example 16.1, “Creating an Organization-specific Manager Role”.
		

      ⁠Example 16.1. Creating an Organization-specific Manager Role

				This example shows how to create a manager role restricted to a single organization named org-1.
			

      ⁠	
						Navigate to Administer → Roles.
					

	
						Clone the existing Manager role. Select Clone from the drop-down list next to the Filters button. You are then prompted to insert a name for the cloned role, for example org-1 Manager.
					

	
						Click Filters next to org-1 Manager to view the filters associated with the role. All filters are marked as unlimited.
					

	
						For each filter, click Edit.
					

	
						If the filter contains the Organizations tab, navigate to it. Otherwise it is a global setting that can not be limited.
					

	
						On the Organizations tab, select org-1. Click Submit.
					

	
						The restricted filters are no longer marked as unlimited. Users assigned with the org-1 Manager role can now perform management tasks only in the selected organization.
					






			Report a bug
		



      ⁠Chapter 17. Command Line Reference




		hammer is the CLI management tool for Red Hat Satellite functionality. It can:
	
	
				Provision hosts.
			

	
				Edit the attributes of a resource or group.
			

	
				Interact and manipulate hosts, capsules and domains.
			




		hammer can be executed on the command line through its parameters and options or through the interactive shell. To invoke the shell:
	

[root@sat.example.com ~]# hammer shell
Welcome to the hammer interactive shell
Type 'help' for usage information
Command completion is disabled on ruby < 1.9 due to compatibility problems.
hammer> organization list
---|------------------|------------------|------------------------------
ID | NAME             | LABEL            | DESCRIPTION
---|------------------|------------------|------------------------------
1  | ACME_Corporation | ACME_Corporation | ACME_Corporation Organization
3  | Test Corp        | Test_Corp        |
---|------------------|------------------|------------------------------
hammer>



		The full list of options and subcommands are available in the help file:
	

# hammer -h


      ⁠Chapter 18. Backup and Disaster Recovery




		This chapter describes the minimum and typical backup and restore procedures required to ensure continuity of your Red Hat Satellite deployment and associated data in the event of a disaster. If your deployment uses custom configurations you should take these into account when planning your backup and disaster recovery policy.
	

      ⁠18.1. Backing up Red Hat Satellite




			This section describes how to prepare and back up your Red Hat Satellite Server to facilitate recovery in the event of disaster. This example uses the /backup directory as the target directory for backup archives, and is described in several parts: 
				
						Preparing the backup location and backing up configuration and data files
					

	
						Backing up the repositories
					

	
						Backing up the databases
					

	
						Verifying the backup
					





		
Note


				If SELinux is enabled and in enforcing mode, ensure that any local content requiring synchronization is labeled with "httpd_sys_content_t".
			



      ⁠Procedure 18.1. To Prepare the Backup Location and Back up Configuration and Data Files:
	
					Prepare your backup location:
				
# umask 0027
# export BDIR=/backup
# mkdir $BDIR
# chgrp postgres $BDIR
# chmod 770 $BDIR
# cd $BDIR


	
					Back up the configuration and data files:
				
# tar --selinux -czvf config_files.tar.gz \
/etc/katello \
/etc/elasticsearch \
/etc/candlepin \
/etc/pulp \
/etc/pki/katello \
/etc/pki/pulp \
/etc/qpidd.conf \
/etc/sysconfig/katello \
/etc/sysconfig/elasticsearch \
/root/ssl-build \
/var/www/html/pub/*

# tar --selinux -czvf elastic_data.tar.gz /var/lib/elasticsearch



Backing up Satellite Repositories

				The RPM files in repositories already use compression and cannot be compressed any further. Therefore, depending on instance size, the resulting backup archive (pulp_data.tar) can grow quite large. Ensure you have sufficient space to store the resulting file.
			

			There are two options for backing up repositories: online backup; and offline backup.
		

      ⁠Procedure 18.2. To Perform an Online Repository Backup:
	
					Run the following commands to perform a checksum of all time stamps, back up the repository, and perform the checksum again.
				
# find /var/lib/pulp -printf '%T@\n' | md5sum
# tar --selinux -cvf pulp_data.tar /var/lib/pulp /var/www/pub
# find /var/lib/pulp -printf '%T@\n' | md5sum

					If the checksums match, the online backup is correct and usable. If the checksums do not match, perform the repository backup again.
				
Note


						You can use the rsync command to speed up file copying. This can help to ensure the checksums match.
					






      ⁠Procedure 18.3. To Perform an Offline Repository Backup:
	
					Run the following commands to stop the required services, perform the backup, and restart the services:
				
# katello-service stop
# tar --selinux -cvf pulp_data.tar /var/lib/pulp /var/www/pub
# katello-service start
Note


						While the katello-service is stopped, Red Hat Satellite and the yum clients will be unable to maintain a connection. Any repository actions performed on Red Hat Satellite will fail during this period.
					





Backing up the Databases

				You can perform either online or offline database backups. You do not need to do both. Offline backups require that the Satellite Server be completely inactive.
			
Warning


				Red Hat Satellite must be completely inactive to do an offline backup. Following this procedure while Satellite is running may result in corrupted data.
			

				This method archives all data from the PostgreSQL and MongoDB databases. Red Hat recommends that you perform this backup during maintenance periods.
			



      ⁠Procedure 18.4. To Perform a Complete Offline Database Backup:
	
					Ensure the Satellite Server is completely stopped:
				
# katello-service stop

	
					Run the following commands to back up the PostgreSQL and MongoDB databases:
				

# tar --selinux -czvf mongo_data.tar.gz /var/lib/mongodb
# tar --selinux -czvf pgsql_data.tar.gz /var/lib/pgsql/data/


	
					Restart the required services:
				
# katello-service start



Performing Online Database Backups

				If you prefer, you can perform separate online backups of your databases. This is not necessary if you have performed complete offline backups.
			

      ⁠Procedure 18.5. To Perform an Online Backup of the PostgreSQL Database:
	
					Determine the name of the Red Hat Satellite PostgreSQL database. The default name is foreman and is specified in the /usr/share/katello-installer/modules/foreman/manifests/database/postgresql.pp file. If you chose a different name for your database, it is stored as the value of db_database in the /etc/katello-installer/answers.katello-installer.yaml file.
				
Note


						If you used the default database name, this variable has no value in the answers.katello-installer.yaml file.
					



					The Candlepin database name, candlepin, is not currently user configurable. It is specified in the /usr/share/katello-installer/modules/candlepin/manifests/init.pp file.
				

	
					Run the following commands to create online database backups. It is not necessary to stop PostgreSQL or Red Hat Satellite, and this process does not block logged-in users. However, the process can take several minutes to finish depending on database sizes.
				
# runuser - postgres -c "pg_dump -Fc foreman > /backup/foreman.dump"
# runuser - postgres -c "pg_dump -Fc candlepin > /backup/candlepin.dump"




      ⁠Procedure 18.6. To Perform an Online Backup of the MongoDB Database:
	
					Run the following command in the /backup directory to create the /backup/mongo_dump/pulp_database directory, including JSON files.
				
# mongodump --host localhost --out $BDIR/mongo_dump



Verifying Your Backups

				It is important to verify the results of your backups. The process creates the following archive files and directory:
			
# ls $BDIR
candlepin.dump
config_files.tar.gz
elastic_data.tar.gz
foreman.dump
mongo_dump/
pulp_data.tar


			If you performed the optional offline backup of the databases, the following files also appear:
		

mongo_data.tar.gz
pgsql_data.tar.gz


			Report a bug
		


      ⁠18.2. Restoring Red Hat Satellite from Backup




			The following process describes a full Red Hat Satellite restoration. This process deletes all data from an existing Red Hat Satellite instance. During this process, ensure that:
		
	
					You restore to the correct instance. The Red Hat Satellite instance must have the same configuration, package versions and errata as the original system.
				

	
					All commands are executed as root in the directory where the archives were created during the backup process.
				

	
					All SELinux contexts are correct. Run the following command to restore the correct SELinux contexts:
				

restorecon -Rnv /




Warning


				The following procedure deletes all data from an existing Red Hat Satellite instance.
			



      ⁠Procedure 18.7. To Restore a Red Hat Satellite Instance:
	
					Prepare the Red Hat Satellite host for restoration. This process restores the backup to the same server that generated the backup. If the original system is unavailable, provision the same configuration with the same settings (host name, IP address, and so on) and run katello-installer with the same options using the file from the configuration backup:
				

# tar --selinux -xzvf config_files.tar.gz -C /tmp
# katello-configure --answer-file=/etc/katello-installer/answers.katello-installer.yaml

	
					Configure and change to the backup directory.
				
# export BDIR=/backup
# chgrp postgres -R $BDIR
# cd $BDIR

	
					Determine the name of the Red Hat Satellite PostgreSQL database. The default name is foreman and is specified in the /usr/share/katello-installer/modules/foreman/manifests/database/postgresql.pp file. If you chose a different name for your database, it is stored as the value of db_database in the /etc/katello-installer/answers.katello-installer.yaml file.
				
Note


						If you used the default database name, this variable has no value in the answers.katello-installer.yaml file.
					



					The Candlepin database name, candlepin, is not currently user configurable. It is specified in the /usr/share/katello-installer/modules/candlepin/manifests/init.pp file.
				

	
					Stop all services prior to restoring the databases:
				

# katello-service stop
# service postgresql stop


	
					Restore the system files. Make sure that the files extract on the correct host. Run the following commands in the backup directory to restore all system files:
				
# tar --selinux -xzvf config_files.tar.gz -C /
# tar --selinux -xzvf elastic_data.tar.gz -C /
# tar --selinux -xvf pulp_data.tar -C /

	
					Drop any existing Red Hat Satellite PostgreSQL databases:
				
# service postgresql start
# runuser - postgres -c "dropdb foreman"
# runuser - postgres -c "dropdb candlepin"
Note


						The following error might appear during a database drop:
					
database xxx is being accessed by other users

						This typically means that some Satellite processes are still running. Ensure all processes are stopped.
					



	
					Run the following commands to restore the Red Hat Satellite PostgreSQL databases:
				
# runuser - postgres -c "pg_restore -C -d postgres /backup/katello.dump"
# runuser - postgres -c "pg_restore -C -d postgres /backup/candlepin.dump"

	
					Ensure MongoDB is running and delete the old data:
				
# service mongod start
# echo 'db.dropDatabase();' | mongo pulp_database

	
					Run the following command in the /backup directory to restore the MongoDB database:
				
# mongorestore --host localhost mongo_dump/pulp_database/

	
					Restart all Red Hat Satellite processes:
				
# service postgresql start
# katello-service start


	
					Inspect the appropriate log files for errors, and inspect the audit.log file for AVC denials. Attempt to ping the Red Hat Satellite instance:
				
# hammer -u admin -p admin ping




			If no errors are apparent, and you can ping the Satellite Server, the restoration should be complete and successful.
		
Further Reading

					
							The mongodump and mongorestore manual pages and http://www.mongodb.org/display/DOCS/Backups
						

	
							The pg_dump and pg_restore manual pages and http://www.postgresql.org/docs/8.4/static/backup.html
						





			

			Report a bug
		



      ⁠Chapter 19. Maintenance




      ⁠19.1. Logging and Reporting




			Red Hat Satellite provides system information in the form of notifications and log files.
		

			Examples of helpful log files for troubleshooting are:
		

      ⁠Table 19.1. Relevant Log Files
	 
							Log File
						

						 	 
							Description
						

						 
	 
							/var/log/elasticsearch
						

						 	 
							Errors concerning the UI search index display
						

						 
	 
							/var/log/candlepin
						

						 	 
							Errors concerning subscription management
						

						 
	 
							/var/log/foreman
						

						 	 
							Errors concerning foreman
						

						 
	 
							/var/log/foreman-proxy
						

						 	 
							Errors concerning the foreman proxy
						

						 
	 
							/var/log/httpd
						

						 	 
							Errors concerning the apache http server
						

						 
	 
							/var/log/katello-installer
						

						 	 
							Errors concerning the Satellite installer
						

						 
	 
							/var/log/libvirt
						

						 	 
							Errors concerning the virtualization API
						

						 
	 
							/var/log/mongodb
						

						 	 
							Errors concerning the database
						

						 
	 
							/var/log/pulp
						

						 	 
							Errors in repository management
						

						 
	 
							/var/log/puppet
						

						 	 
							Errors in configuration management
						

						 
	 
							/var/log/rhsm
						

						 	 
							Errors in the subscription management tool
						

						 
	 
							/var/log/tomcat6
						

						 	 
							Issues concerning the apache webserver
						

						 




			Reports can also be generated to view and monitor information about the hosts being maintained. The foreman-debug command collects configuration and log data for Red Hat Satellite, its back-end services and system information. This information is collected into a tarball.
		
Important


				foreman-debug removes all security information such as password, tokens and keys while collecting information. However, the tarball can still contain sensitive information about the Red Hat Satellite Server. It is recommended to send this information directly to the intended recipient and not publicly.
			



			Report a bug
		

      ⁠19.1.1. Viewing Import History




		These steps show how to view an import history in Red Hat Satellite.
	

      ⁠Procedure 19.1. Viewing Import History
	
				Click Content → Red Hat Subscriptions.
			

	
				Click the Manage Manifest button.
			

	
				Click the Import History tab.
			




      ⁠Result:

			Details of the import history are displayed.
		

		Report a bug
	



      ⁠19.2. Troubleshooting




      ⁠19.2.1. Changing Your Red Hat Satellite's Fully Qualified Domain Name (FQDN)




      ⁠Prerequisite

				The Satellite FQDN has been changed correctly and the /etc/sysconfig/network in Red Hat Enterprise Linux 6 or the /etc/hostname file in Red Hat Enterprise Linux 7 has been modified accordingly.
			

			Upon installation, the host system's FQDN is recorded by the Red Hat Satellite Server. Changing the FQDN without the proper precautions can prevent the Satellite Server from running correctly. It also renders all custom server certificates incorrect.
		

      ⁠Procedure 19.2. Updating Your Red Hat Satellite Configuration After an FQDN Change

				To make sure that Red Hat Satellite continues to run properly even with the FQDN change, follow these steps:
			
	
					Verify that the FQDN is being properly repored and reflects the hostname/FQDN:
				

# facter fqdn

	
					Update the katello-installer answer file to replace the old FQDN with the new one:
				

# sed -i "s/$OLD_FQDN/$NEW_FQDN/g" /etc/katello-installer/answers.katello-installer.yaml


					Where:
				
	
							$OLD_is the Satellite Server's previous FQDN.
						

	
							$NEW_FQDN is the Satellite Server's new FDQN.
						




	
					Delete the amqp-client certificate from the NSS database:
				

# certutil -D -d '/etc/pki/katello/nssdb' -n 'amqp-client'


	
					Regenerate the server certificates by running katello-installer:
				

# katello-installer --certs-update-all


	
					On client systems registered to the Red Hat Satellite Server, uninstall the existing katello-ca-consumer package since it contains the existing SSL certificate with the old FQDN information and update the package from the new FQDN:
				

# rpm -e $(rpm -qa "katello-ca-consumer*")
#rpm -Uvh http://NEW_FQDN/pub/katello-ca-consumer-latest.noarch.rpm





			The Red Hat Satellite is now fully updated with the new FQDN and server certificates.
		




      ⁠Chapter 20. Configuring Identity Management in Red Hat Satellite




		Identity Management (IDM) deals with the management of individual identities, their credentials and privileges used in a networking environment. IDM can help to increase the security of your system and ensure that the right people have access to the right information when they need it.
	

		Red Hat Satellite has a realm feature that will automatically manage the life cycle of any system registered to a realm or domain provider. This section will explain how you need to configure the Satellite Server or Capsule Server for IDM and how to automatically add client systems to the Satellite 6 Identity Management host group.
	

		Report a bug
	

      ⁠20.1. Configuring Red Hat Satellite Server or Capsule Server for IDM Realm Support




			The initial step to use Identity Management (IDM) in Red Hat Satellite is to configure the Red Hat Satellite Server or Red Hat Satellite Capsule Server.
		

      ⁠Prerequisites

				Make sure that the following are setup before configuring IDM:
			
	
					A Satellite Server registered to the content delivery network or an independent Capsule Server registered to the Satellite Server
				

	
					A realm or domain provider such as Red Hat Identity Management configured and set up
				




				To configure the Satellite Server or Capsule Server for IDM Realm Support:
			
	
					On the Satellite Server or Capsule Server, install the following packages:
				

# yum install ipa-client foreman-proxy ipa-admintools


	
					Configure the Satellite Server (or Capsule Server) as an IPA client:
				

# ipa-client-install


	
					Create a realm-capsule user and the relevant roles in Red Hat Identity Management on the Satellite Server or Capsule Server:
				

# foreman-prepare-realm admin realm-capsule


					Running foreman-prepare-realm will prepare a FreeIPA or Red Hat Identity Management server for use with the Foreman Smart Proxy. It creates a dedicated role with the permissions needed for Foreman, creates a user with that role and retrieves the keytab file. You will need your Identity Management server configuration details on this step.
				

					If the command successfully executes, you should be able to see the following command output:
				

Keytab successfully retrieved and stored in: freeipa.keytab
Realm Proxy User:    realm-capsule
Realm Proxy Keytab:  /root/freeipa.keytab


	
					Move the /root/freeipa.keytab to the /etc/foreman-proxy directory and set the ownership settings to the user foreman-proxy:
				

# mv /root/freeipa.keytab /etc/foreman-proxy
# chown foreman-proxy:foreman-proxy /etc/foreman-proxy/freeipa.keytab


	
					Configure the realm based on whether you are using Satellite Server or Capsule Server:
				

						
							If you are using the integrated capsule in the Satellite Server, use katello-installer to configure the realm:
						

# katello-installer --capsule-realm true \
  --capsule-realm-keytab /etc/foreman-proxy/freeipa.keytab \
  --capsule-realm-principal 'realm-capsule@EXAMPLE.COM' \
  --capsule-realm-provider freeipa

Note


								These options may also be run at the initial configuration of Red Hat Satellite Server.
							




					 	
							If you are using an independent Capsule Server, use capsule-installer to configure the realm:
						

# capsule-installer --realm true \
  --realm-keytab /etc/foreman-proxy/freeipa.keytab \
  --realm-principal 'realm-capsule@EXAMPLE.COM' \
  --realm-provider freeipa




				

	
					Make sure that the most updated versions of the ca-certificates package is installed and trust the IPA Certificate Authority:
				

# cp /etc/ipa/ca.crt /etc/pki/ca-trust/source/anchors/ipa.crt
# update-ca-trust enable
# update-ca-trust


	
					(Optional) If you are configuring IDM on an already existing Satellite Server or Capsule Server, the following steps should also be taken to make sure that the configuration changes take effect:
				
	
							Restart the foreman-proxy service:
						

# service foreman-proxy restart


	
							Log in to the Satellite Server and click Infrastructure → Capsules.
						

	
							Click on the drop down menu on the right-hand side of the Capsule Server you have configured for IDM and choose Refresh Features.
						



	
					Finally, create a new realm entry in the Satellite Server user interface:
				
	
							Click Infrastructure → Realms and on the right-hand corner of the main page, click New Realm.
						

	
							Fill in the fields in the following subtabs:
						
	
									Realm - provide the realm name, the type of realm to use and the realm proxy.
								

	
									Locations - choose the locations where the new realm is intended for use.
								

	
									Organizations - choose the organizations where the new realm is intended for use.
								




	
							Click Submit.
						






			The Satellite Server or Capsule Server is now ready to provision hosts that automatically register to IDM. The next section will detail the steps on how to automatically add hosts to an IDM host group.
		

			Report a bug
		


      ⁠20.2. Adding Hosts to an IDM Host Group




			Identity Management (IDM) supports the ability to set up automatic membership rules based on a system's attributes. Red Hat Satellite's realm feature provides administrators with the ability to map the Red Hat Satellite host groups to the IDM parameter "userclass" which allow administrators to configure automembership.
		

			When nested host groups are used, they are sent to the IDM server as they are displayed in the Red Hat Satellite User Interface. For example, "Parent/Child/Child".
		
Note


				The Satellite Server or Capsule Server sends updates to the IDM server, however automembership rules are only applied at initial registration.
			


	
					On the IDM server, create a host group:
				

# ipa hostgroup-add hostgroup_name
Description: hostgroup_description
----------------------------
Added hostgroup "hostgroup_name"
----------------------------
  Host-group: hostgroup_name
  Description: hostgroup_description

					Where:
				
	
							hostgroup_name is the hostgroup's name.
						

	
							hostgroup_description is the hostgroup's description.
						




	
					Create an automembership rule:
				

# ipa automember-add --type=hostgroup automember_rule
----------------------------------
Added automember rule "automember_rule"
----------------------------------
Automember Rule: automember_rule

					Where:
				
	
							automember-add flags the group as an automember group.
						

	
							--type=hostgroup identifies that the target group is a host group, not a user group.
						

	
							automember_rule is the name you wish to identify the automember rule by.
						




	
					Define an automembership condition based on the userclass attribute:
				

# ipa automember-add-condition --key=userclass --type=hostgroup --inclusive-regex=^webserver hostgroup_name
----------------------------------
Added condition(s) to "hostgroup_name"
----------------------------------
  Automember Rule: automember_rule
  Inclusive Regex: userclass=^webserver
----------------------------
Number of conditions added 1
----------------------------


					Where:
				
	
							automember-add-condition allows you to add regular expression conditions to identify group members.
						

	
							--key=userclass specifies the key attribute as userclass.
						

	
							--type=hostgroup identifies that the target group is a host group, not a user group.
						

	
							--inclusive-regex=^webserver is a regular expression pattern to identify matching values.
						

	
							hostgroup_name is the target hostgroup's name.
						







			When a system is added to the Satellite Server's hostgroup_name host group, it will now automatically be added to the Identity Management server's "hostgroup_name" host group as well. IDM host groups allow for Host-Based Access Controls (HBAC), sudo policies and other IDM functions.
		

			Report a bug
		



      ⁠Chapter 21. Red Hat Satellite User Interface Plug-ins




      ⁠21.1. Red Hat Access Plug-in




			The Red Hat Access pre-installed plug-in lets you access several Red Hat Customer Portal services from within the Red Hat Satellite web interface.
		

			The Red Hat Access plug-in provides the following services:
		
	
					Search: Search solutions in the Customer Portal from within the Red Hat Satellite interface.
				

	
					Logs: Send specific parts (snippets) of the log files to help in problem solving. Send these log snippets to the Red Hat Customer Portal diagnostic tool chain.
				

	
					Support: Access your open support cases, modify an open support casem and open a new support case from within the Red Hat Satellite interface.
				



Note


				To access Red Hat Customer Portal resources, you must log in with your Red Hat Customer Portal user identification and password.
			



			Report a bug
		

      ⁠21.1.1. Searching for Solutions in the Red Hat Access Plug-in




		The Red Hat Access plug-in provides search capabilities that look through the solutions database available in the Red Hat Customer Portal without needing to log in to the Customer Portal interface.
	

		To search for solutions from the Red Hat Satellite Server:
	
	
				In the top right, click Red Hat Access → Search.
			

	
				To log into the Red Hat Customer Portal: In the main panel top right, click Log In.
			
Note


					To access Red Hat Customer Portal resources, you need to log in with your Red Hat Customer Portal user identification and password.
				



	
				In the Red Hat Search: field, enter your search query. Search results display in the left-hand Recommendations list.
			

	
				In the Recommendations list, click a solution. The solution article displays in the main panel.
			




		Report a bug
	


      ⁠21.1.2. Using Logs in the Red Hat Access Plug-in




		The log file viewer lets you view the log files and isolate log snippets. Send the log snippets through the Customer Portal diagnostic tool chain to help with problem solving.
	

		To use the logs diagnostic tool, from the Red Hat Satellite Server:
	
	
				In the top right, click Red Hat Access → Logs.
			

	
				In the mail panel top right, click Log In to log into the Red Hat Customer Portal. If you are already logged in, skip this step.
			
Note


					To access Red Hat Customer Portal resources, you must log in with your Red Hat Customer Portal user identification and password.
				



	
				In the left file tree, select a log file and click the filename.
			

	
				Click Select File. A pop-up window displays the log file contents.
			

	
				In the log file, highlight any text sections you want diagnosed. The Red Hat Diagnose button displays.
			

	
				Click Red Hat Diagnose. The system sends the highlighted information to the Red Hat Customer Portal, and provides solutions that closely match the provided log information.
			

	
				If a solution does the following:
			
	
						Matches the problem, click the solution and follow the required steps to troubleshoot the issue.
					

	
						Does not match the problem, click Open a New Support Case. The support case pre-populates with the highlighted text from the log file. See Section 21.1.5, “Creating New Support Cases Using the Red Hat Access Plug-in”.
					







		Report a bug
	


      ⁠21.1.3. Viewing Existing Support Cases Using the Red Hat Access Plug-in




		To view existing support cases from the Red Hat Satellite Server:
	
	
				In the top right, click Red Hat Access → Support → My Cases.
			

	
				In the main panel top right, click Log In to log into the Red Hat Customer Portal. If you are already logged in, skip this step.
			
Note


					To access Red Hat Customer Portal resources, you must log in with your Red Hat Customer Portal user identification and password.
				



	
				To search for a specific support case from existing cases, do any of the following:
			
	
						In the Search field, provide a key word or phrase.
					

	
						From the drop-down list, choose a specific Case Group. Your organization has defined Case Groups inside the Red Hat Customer Portal.
					

	
						Choose a Case Status.
					




	
				From the results, choose a specific support case and click the Case ID. The support case is ready to view.
			




		Report a bug
	


      ⁠21.1.4. Modifying Existing Support Cases Using the Red Hat Access Plug-in




      ⁠Prerequisites

			Complete the instructions from the previous section. 
		

		Update Support Cases from the Red Hat Satellite Server web interface. When viewing the support case, scroll down to the sections marked to do the following:
	
	
				Attachments: - Attach a local file from the system. Add a filename to make it easier to identify.
			
Note


					Filenames must have less than 80 characters. The maximum file size for web uploaded attachments is 250 MB. Use FTP for larger files.
				



	
				Case Discussion: - Add any updated information about the case you wish to discuss with Global Support Services. After adding information, click Add Comment.
			




		Report a bug
	


      ⁠21.1.5. Creating New Support Cases Using the Red Hat Access Plug-in





	
	
				In the top right, click Red Hat Access → Support → New Case.
			

	
				In the main panel top right, click Log In to log into the Red Hat Customer Portal. If you are already logged in, skip this step.
			
Note


					To access Red Hat Customer Portal resources, you must log in with your Red Hat Customer Portal user identification and password.
				



	
				The Product and Product Version fields are automatically populated. Complete the other relevant fields, as follows:
			
	
						Summary: - Provide a brief summary of the issue.
					

	
						Description: - Write a detailed description of the issue.
					
Note


							Based on the summary, recommendations for possible solutions display in the main panel.
						






	
				Click Next. A second screen displays.
			

	
				Choose the appropriate options, as follows:
			
	
						Severity: Select the ticket urgency as 4 (low), 3 (normal), 2 (high> or 1 (urgent).
					

	
						Case Group: Based on who needs to be notified, create case groups associated with the support case. Select Case Groups in Red Hat Satellite. Create Case Groups within the Customer Portal.
					




	
				Attach any required files. Add a file description and click Attach.
			

				To ensure you provide relevant information, it is recommended that you attach the output of the following commands:
			

# sosreport
# foreman-debug

Important


					foreman-debug removes all security information such as password, tokens and keys while collecting information. However, the tarball can still contain sensitive information about the Red Hat Satellite Server. It is recommended to send this information directly to the intended recipient and not publicly.
				


Note


					Filenames must have less than 80 characters. The maximum file size for web uploaded attachments is 250 MB. Use FTP for larger files.
				



	
				Click Submit. The system uploads the case to the Customer Portal, and provides a case number for your reference.
			




		Report a bug
	




      ⁠Appendix A. Glossary of Terms




		The following terms are used throughout this document. Familiarize yourself with these terms to help your understanding of Red Hat Satellite 6.
	
	
      ⁠Activation Key
	
					A registration token used in a Kickstart file to control actions at registration. These are similar to Activation Keys in Red Hat Satellite 5, but provide a subset of features because Puppet controls package and configuration management after registration.
				

	
      ⁠Application Life Cycle Environment
	
					An Application Life Cycle Environment represents a step, or stage, in a promotion path through the Software Development Life Cycle (SDLC). Promotion paths are also known as development paths. Content such as packages and Puppet modules move through life cycle environments by publishing and promoting Content Views. All Content Views have versions, which means you can promote a specific version through a typical promotion path; for example, from development to test to production. Channel cloning implements this concept in Red Hat Satellite 5.
				

	
      ⁠Attach
	
					The process of associating a Subscription to a Host that provides access to RPM content.
				

	
      ⁠Capsule
	
					A Capsule is an additional server that can be used in a Red Hat Satellite 6 deployment to facilitate content federation and distribution in addition to other localized services (Puppet Master, DHCP, DNS, TFTP, and more).
				

	
      ⁠Catalog
	
					A Catalog is a document that describes the desired system state for one specific computer. It lists all of the resources that need to be managed, as well as any dependencies between those resources.
				

	
      ⁠Compute Profile
	
					Compute Profiles specify default attributes for new virtual machines on a compute resource.
				

	
      ⁠Compute Resource
	
					A Compute Resource is virtual or cloud infrastructure, which Red Hat Satellite 6 uses for deployment of hosts and systems. Examples include Red Hat Enterprise Virtualization Manager, OpenStack, EC2, and VMWare.
				

	
      ⁠Content
	
					Content includes software packages (RPM files) and Puppet modules. These are synchronized into the Library and then promoted into Life Cycle Environments using Content Views so that they can be consumed by Hosts.
				

	
      ⁠Content Delivery Network (CDN)
	
					The Content Delivery Network (CDN) is the mechanism used to deliver Red Hat content in a geographically co-located fashion. For example, content that is synchronized by a Satellite in Europe pulls content from a source in Europe.
				

	
      ⁠Content View
	
					A Content View is a definition of content that combines products, packages, and Puppet modules with capabilities for intelligent filtering and creating snapshots. Content Views are a refinement of the combination of channels and cloning from Red Hat Satellite 5.
				

	
      ⁠External Node Classifier
	
					An External Node Classifier is a Puppet construct that provides additional data for a Puppet Master to use when configuring Hosts. Red Hat Satellite 6 acts as an External Node Classifier to Puppet Masters in a Satellite deployment.
				

	
      ⁠Facter
	
					Facter is a program that provides information (facts) about the system on which it is run; for example, Facter can report total memory, operating system version, architecture, and more. Puppet modules enable specific configurations based on host data gathered by Facter.
				

	
      ⁠Hammer
	
					Hammer is a command line tool for Red Hat Satellite 6. Use Hammer to manage Red Hat Satellite 6 as a standard CLI, for scripts, and also through an interactive shell.
				

	
      ⁠Hiera
	
					Hiera is a key/value look-up tool for configuration data which allows keeping site-specific data out of puppet manifests.
				

	
      ⁠Host
	
					A Host refers to any system, either physical or virtual, that Red Hat Satellite 6 manages.
				

	
      ⁠Host Collection
	
					A Host Collection is equivalent to a Satellite 5 System Group, that is, a user defined group of one or more Hosts.
				

	
      ⁠Host Group
	
					A Host Group is a template for building a Host. This includes the content view (which defines the available RPM files and Puppet modules) and the Puppet classes to apply (which ultimately determines the software and configuration).
				

	
      ⁠Location
	
					A Location is collection of default settings that represent a physical place. These can be nested so that you can set up an hierarchical collection of locations. For example, you can set up defaults for "Middle East", which are refined by "Tel Aviv", which are further refined by "Data Center East", and then finally by "Rack 22".
				

	
      ⁠Library
	
					The Library contains every version, including the latest synchronized version, of the software that the user will ever deploy. For an Information Technology Infrastructure Library (ITIL) 
      ⁠[3] organization or department, this is the Definitive Media Library 
      ⁠[4] (previously named the Definitive Software Library).
				

	
      ⁠Manifest
	
					A Manifest transfers subscriptions from the Customer Portal to Red Hat Satellite 6. This is similar in function to certificates used with Red Hat Satellite 5.
				

					For more information about certificates and subscription types, see: 
						
								RHN Classic, Red Hat Satellite, and Channel Entitlements 
      ⁠[5]
							

	
								The Structure of Satellite Certificates (Classic Style of Certificates) 
      ⁠[6]
							





				

	
      ⁠Organization
	
					An Organization is an isolated collection of systems, content, and other functionality within a Satellite 6 deployment.
				

	
      ⁠Product
	
					A collection of content repositories. Products can be Red Hat products or newly-created products made up of software and configuration content.
				

	
      ⁠Promote
	
					The act of moving a content view comprised of software and configuration content from one Application Life Cycle Environment to another, such as moving from development to QA to production.
				

	
      ⁠Provisioning Template
	
					A Provisioning Template is a user-defined template for Kickstart files, snippets, and other provisioning actions. In Satellite 6 they provide similar functionality to Kickstart Profiles and cobbler Snippets in Red Hat Satellite 5.
				

	
      ⁠Pulp Node
	
					A Pulp Node is a Capsule Server component that mirrors content. This is similar to the Red Hat Satellite 5 Proxy. The main difference is that content can be staged on the Pulp Node before it is used by a Host.
				

	
      ⁠Puppet Agent
	
					The Puppet Agent is an agent that runs on a Host and applies configuration changes to that Host.
				

	
      ⁠Puppet Master
	
					A Puppet Master is a Capsule Server component that provides Puppet manifests to Hosts for execution by the Puppet Agent.
				

	
      ⁠Puppet Module
	
					A Puppet Module is a self-contained bundle of code and data that you can use to manage resources such as users, files, and services.
				

	
      ⁠Repository
	
					A Repository provides storage for a collection of content. For example, a YUM repository or a Puppet repository.
				

	
      ⁠Role
	
					A Role specifies a collection of permissions that are applied to a set of resources, such as Hosts.
				

	
      ⁠Smart Proxy
	
					A Smart Proxy is a Capsule Server component that can integrate with external services, such as DNS or DHCP.
				

	
      ⁠Smart Variable
	
					A Smart Variable is a configuration value that controls how a Puppet Class behaves. This can be set on a Host, a Host Group, an Organization, or a Location.
				

	
      ⁠Standard Operating Environment (SOE)
	
					A Standard Operating Environment (SOE) is a controlled version of the operating system on which applications are deployed.
				

	
      ⁠Subscription
	
					Subscriptions are the means by which you receive content and service from Red Hat.
				

	
      ⁠Synchronizing
	
					Synchronizing refers to mirroring content from external resources into the Red Hat Satellite 6 Library.
				

	
      ⁠Synchronization Plans
	
					Synchronization Plans provide scheduled execution of content synchronization.
				

	
      ⁠User Group
	
					A User Group is a collection of roles which can be assigned to a collection of users. This is similar to a Role in Red Hat Satellite 5.
				

	
      ⁠User
	
					A user is anyone registered to use Red Hat Satellite. Authentication and authorization is possible through built-in logic, through external LDAP resources, or with Kerberos.
				




		Report a bug
	


[3] 
						http://en.wikipedia.org/wiki/Information_Technology_Infrastructure_Library
					

[4] 
						http://en.wikipedia.org/wiki/Definitive_Media_Library
					

[5] 
									https://access.redhat.com/site/documentation/en-US/Red_Hat_Subscription_Management/1/html/MigratingRHN/sat-certs.html
								

[6] 
									https://access.redhat.com/site/documentation/en-US/Red_Hat_Subscription_Management/1/html/Subscription_Concepts_and_Workflows/index.html#subscr-legacy
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/* global window document labels lang_menu_2_div hljs */
var docs = (function(docs){
    /*
     * NOTE: The docs module will not work properly unless the init function is called, as the jQuery object is dynamically
     * loaded using requirejs.
     */
    var jQuery = window.jQuery;
    var listeners = [];
    var ready = false;

    // BEGIN UTIL FUNCTIONS
    docs.utils = (function() {
        var exports = {};

        exports.setCookie = function(name, value, expires, path, domain, secure) {
            document.cookie = name + "=" + value +
            ((expires) ? ";expires=" + expires.toGMTString() : "") +
            ((path) ? ";path=" + path : "");
            // +
            //		((domain) ? ";domain=" + domain : "") +
            //		((secure) ? ";secure" : "");
        };

        exports.isSafari = function() {
            return navigator.userAgent.indexOf("Safari") != -1 && navigator.userAgent.indexOf("Chrome") == -1;
        };

        exports.scrollToTarget = function() {
            if (jQuery(window.location.hash).length > 0) {
                jQuery('html, body').animate({ scrollTop: jQuery(window.location.hash).offset().top}, 1000);
            }
        };

        exports.getCurrentPageName = function() {
            return window.location.href.substr(window.location.href.lastIndexOf("/") + 1);
        };

        exports.escapeElementId = function(elem) {
            return elem.replace('&', '\\&');
        };

        return exports;
    }());
    // END UTIL FUNCTIONS

    // BEGIN TOC FUNCTIONS
    docs.toc = (function(utils) {
        var num_days = 7;
        var name_menu = window.location.hostname + '-publican-menu';

        function init() {
            // New toc
            var navigation = jQuery('#navigation');
            if (navigation.is(":visible")) {
                initNewToc(navigation);
            }

            // Old selectbox toc
            var docToc = jQuery(".doctoc");
            if (docToc.is(":visible")) {
                initOldToc(docToc);
            }
        }

        function initOldToc(docToc) {
            checkToc();
            docToc.load('index.html .toc:eq(0)', function () {
                loadDocNav();
            });
            utils.scrollToTarget();
        }

        function initNewToc(navigation) {
            navigation.load('index.html div > div.toc:eq(0), section > div.toc:eq(0)', function () {
                // Add the close button and bind the click event
                var tocButton = jQuery('<button class="menu-toggle"><span></span></button>');
                navigation.append(tocButton);
                tocButton.click(function (e) {
                    toggleToc();
                });

                // Check the saved state and apply the toc styling
                styleToc();
                checkToc();

                // Safari has a bug in getBoundingClientRect that needs the page to be loaded to return valid info.
                if (utils.isSafari()) {
                    jQuery(window).load(function () {
                        styleToc();
                    });
                }
            });

            jQuery(window).scroll(function (e) {
                styleToc();
            }).resize(function (e) {
                styleToc();
            });

            // Add a mechanism to handle the the main menu dropdowns.
            // TODO: This is hacky and a better way should be found to handle this.
            jQuery('.primary-nav a').on('click', function () {
                setTimeout(function () {
                    styleToc();
                }, 600);
            });
        }

        function loadDocNav() {
            var topDocNav = getTopDocNav();
            var bottomDocNav = getBottomDocNav();

            updateDocNavItems(utils.getCurrentPageName(), topDocNav, bottomDocNav);

            var onChange = function () {
                var currentPage = utils.getCurrentPageName();
                var newSelection = jQuery(this).val();
                window.location = newSelection;
                if (newSelection.indexOf(currentPage) === 0) {
                    updateDocNavItems(newSelection, getTopDocNav(), getBottomDocNav());
                }
            };
            topDocNav.change(onChange);
            bottomDocNav.change(onChange);
        }

        function updateDocNavItems(filename, topDocNav, bottomDocNav) {
            topDocNav.val(filename);
            bottomDocNav.val(filename);
        }

        function getTopDocNav() {
            return jQuery(".docnav.top").find(".pageSelect");
        }

        function getBottomDocNav() {
            return jQuery(".docnav.bottom").find("select");
        }

        function styleToc() {
            /* NOTE: We need to use an absolute position due to the portal adding content (ie outage messages), which then makes the toc overlap
             * that. There is a minor effect of some flickering, but it's minimal and currently the best situation since no events are fired by the
             * portal to say it's finished.
             */
            var nav = jQuery('#navigation');
            var navToc = nav.find('.toc');

            var main = jQuery('#legacy-portal');
            var main_rect = main[0].getBoundingClientRect();
            var main_height = main.height();
            var main_bottom = main_rect.bottom;
            var main_top = main_rect.top;

            var my_top = main.offset().top - jQuery('#main').offset().top + 5;
            var height = main_height - 5;
            var pos = "absolute";
            if (main_top <= 0) {
                my_top = 0;
                pos = "fixed";
            }

            if (navToc.is(':visible')) {
                if (pos === "fixed") {
                    if (height > ((window.innerHeight || document.documentElement.clientHeight) - my_top)) {
                        height = (window.innerHeight || document.documentElement.clientHeight) - my_top;
                    }

                    if (my_top + height > main_bottom) {
                        height = main_bottom - my_top;
                    }
                } else {
                    if (height > ((window.innerHeight || document.documentElement.clientHeight) - main_top)) {
                        height = (window.innerHeight || document.documentElement.clientHeight) - main_top - 5;
                    }

                    if (height > main_bottom) {
                        height = main_bottom;
                    }
                }

                nav.attr('style', 'top: ' + my_top + 'px !important; height: ' + height + 'px; position: ' + pos);
                navToc.attr('style', 'top: 0px !important; height: ' + height + 'px;');
            } else {
                nav.attr('style', 'top: ' + my_top + 'px !important; height: 0px; position: ' + pos);
            }
        }

        function checkToc() {
            if (document.cookie) {
                var cookies = document.cookie.split(/ *; */);
                for (var i = 0; i < cookies.length; i++) {
                    var current_c = cookies[i].split("=");
                    if (current_c[0] == name_menu) {
                        var menu_status = current_c[1];
                        if (menu_status == "closed") {
                            hideToc();
                        }
                        break;
                    }
                }
            }
        }

        function toggleToc() {
            if (jQuery("#navigation .toc").is(':visible')) {
                hideToc();
            } else {
                showToc();
            }
        }

        function hideToc() {
            var nav = jQuery("#navigation");
            nav.find("button").addClass("tocClosed");
            nav.find(".toc").hide();
            jQuery("#main").addClass('noLtoc');
            styleToc();

            var expDate = new Date();
            expDate.setDate(expDate.getDate() + num_days);
            utils.setCookie(name_menu, 'closed', expDate, '/', false, false);
        }

        function showToc() {
            var nav = jQuery("#navigation");
            nav.find("button").removeClass("tocClosed");
            nav.find(".toc").show();
            jQuery("#main").removeClass('noLtoc');
            styleToc();

            var expDate = new Date();
            expDate.setDate(expDate.getDate() + num_days);
            utils.setCookie(name_menu, 'open', expDate, '/', false, false);
        }

        return {
            init: init,
            toggleToc: toggleToc,
            getTopDocNav: getTopDocNav,
            getBottomDocNav: getBottomDocNav
        };
    }(docs.utils));
    // END TOC FUNCTIONS

    // BEGIN BREADCRUMB FUNCTIONS
    docs.breadcrumbs = (function(labels, utils) {
        var work = 1;

        function init(current_product, current_version, current_book) {
            var support_label = labels["trans_strings"]["Support"];
            var doc_label = labels["trans_strings"]["Product_Documentation"];

            // Create the very basic breadcrumb array
            var doc_array = [doc_label];
            var breadcrumbs = [
                [support_label, "/support/"],
                doc_array
            ];

            // Create the base breadcrumb, which will later be replaced with the extended version
            if (typeof current_product != "undefined" && current_product != '') {
                var prod_label = getProductLabel(current_product);
                var prod_array = [prod_label];
                breadcrumbs.push(prod_array);

                doc_array[1] = "../";

                if (typeof current_version != "undefined" && current_version != '') {
                    var version_label = getVersionLabel(current_product, current_version);
                    var version_array = [version_label];
                    breadcrumbs.push(version_array);

                    doc_array[1] = "../../";
                    prod_array[1] = "../";

                    if (typeof current_book != "undefined" && current_book != '') {
                        doc_array[1] = "../../../../";
                        prod_array[1] = "../../../";
                        version_array[1] = "../../";

                        var book_label = getBookLabel(current_product, current_version, current_book);
                        breadcrumbs.push([book_label]);
                    }
                }
            }

            window.breadcrumbs = breadcrumbs;
        }

        function getProductLabel(current_product) {
            if (current_product !== 'Products') {
                return labels[current_product]["label"];
            } else {
                return labels["trans_strings"]["Products"];
            }
        }

        function getVersionLabel(current_product, current_version) {
            if (current_version !== 'Versions') {
                return labels[current_product][current_version]["label"];
            } else {
                return labels["trans_strings"]["Versions"];
            }
        }

        function getBookLabel(current_product, current_version, current_book) {
            if (current_book !== 'Books') {
                return labels[current_product][current_version][current_book]["label"];
            } else {
                return labels["trans_strings"]["Books"];
            }
        }

        function loadMenus(toc_path, current_product, current_version, current_book) {
            var breadcrumbs = jQuery("#breadcrumbs");

            // Add a small timeout, to try to fix the items not loading
            setTimeout(function () {
                // We only care about fixing up the default breadcrumbs if we have a current product
                if (typeof current_product !== "undefined" && current_product != '') {
                    // Build the new breadcrumbs html
                    var html = jQuery(buildHTML(toc_path, current_product, current_version, current_book));

                    // Remove the dummy Product Documentation text node
                    var breadcrumbsDiv = breadcrumbs.get(0);
                    while (breadcrumbsDiv.childNodes.length > 1) {
                        breadcrumbsDiv.removeChild(breadcrumbsDiv.lastChild);
                    }

                    // Add the new breadcrumbs
                    breadcrumbs.append(html);

                    // Add a small timeout, to try to fix the items not loading
                    // Load and add the hover menus
                    loadMenu("product_menu", toc_path + "/products_menu.html");
                    loadMenu("version_menu", toc_path + '/' + current_product + "/versions_menu.html");
                    if (typeof current_version !== "undefined" && current_version != '') {
                        loadMenu("book_menu", toc_path + '/' + current_product + '/' + current_version + '/' + "/books_menu.html");
                        if (typeof current_book != "undefined" && current_book != '') {
                            loadMenu("book_lang_menu", toc_path + '/' + current_product + '/' + current_version + '/' + current_book + "/lang_menu.html");
                            loadMenu("book_format_menu", toc_path + '/' + current_product + '/' + current_version + '/' + current_book + "/format_menu.html", true);
                        }
                    }
                }

                // For splash pages the language menu is loaded in a global javascript variable
                if (typeof lang_menu_2_div != "undefined" && lang_menu_2_div != '') {
                    breadcrumbs.append(lang_menu_2_div);
                    bindMouseEvents(breadcrumbs, 'lang_menu_2', 'lang_menu_list');
                }

                bindMenuEvents(breadcrumbs, current_version, current_book);
            }, 500);
        }

        function buildHTML(toc_path, current_product, current_version, current_book) {
            // Get the labels
            var prod_label = getProductLabel(current_product);

            // Convert the default menu into something we can use
            var html = '<a href="' + toc_path + '/index.html">' + labels["trans_strings"]["Product_Documentation"] + '</a>';
            html += '<div id="product_menu"><div>' + prod_label + '</div></div>';
            if (typeof current_version !== "undefined" && current_version !== '') {
                var version_label = getVersionLabel(current_product, current_version);
                html += '<div id="version_menu"><div>' + version_label + '</div></div>';
                if (typeof current_book !== "undefined" && current_book !== '') {
                    var book_label = getBookLabel(current_product, current_version, current_book);
                    html += '<div id="book_menu"><div>' + book_label + '</div></div>';

                    if (current_book !== 'Books') {
                        html += '<div id="left-menu"><div id="book_format_menu"><div>' + labels["trans_strings"]["Formats"] + '</div></div>';
                        html += '<div id="book_lang_menu"></div></div>';
                    }
                }
            }
            return html;
        }

        // Setup the menu expand/retract listeners
        function bindMenuEvents(breadcrumbs, current_version, current_book) {
            bindMouseEvents(breadcrumbs, 'product_menu', 'product_menu_list');

            if (typeof current_version !== "undefined" && current_version !== '') {
                bindMouseEvents(breadcrumbs, 'version_menu', 'version_menu_list');

                if (typeof current_book !== "undefined" && current_book !== '') {
                    bindMouseEvents(breadcrumbs, 'book_menu', 'book_menu_list');

                    if (current_book !== 'Books') {
                        bindMouseEvents(breadcrumbs, 'book_format_menu', 'book_format_menu_list');
                        bindMouseEvents(breadcrumbs, 'book_lang_menu', 'book_lang_menu_list');
                    }
                }
            }
        }

        function bindMouseEvents(parent_ele, id, menu_id) {
            var menu_ele = jQuery('#' + id, parent_ele);
            menu_ele.on('mouseout', function () {
                work = 1;
                retractMenu(menu_id);
            });
            menu_ele.on('mouseover', function () {
                work = 1;
                expandMenu(menu_id);
            });
        }

        function loadMenu(id, url, replace) {
            jQuery.get(url, function(data) {
                if (replace) {
                    jQuery('#' + id).html(data);
                } else {
                    jQuery('#' + id).append(data);
                }
            });
        }

        function expandMenu(id) {
            if (work) {
                work = 0;
                var entity = document.getElementById(id);
                if (entity) {
                    var my_class = entity.className;
                    var my_parent = entity.parentNode;
                    if (my_class.indexOf("hidden") != -1) {
                        entity.className = my_class.replace(/hidden/, "visible");
                        my_parent.className = my_parent.className.replace(/collapsed/, "expanded");
                    }
                }
            }
        }

        function retractMenu(id) {
            if (work) {
                work = 0;
                var entity = document.getElementById(id);
                if (entity) {
                    var my_class = entity.className;
                    var my_parent = entity.parentNode;
                    if (my_class.indexOf("visible") != -1) {
                        entity.className = my_class.replace(/visible/, "hidden");
                        my_parent.className = my_parent.className.replace(/expanded/, "collapsed");
                    }
                }
            }
        }

        return {
            init: init,
            loadMenus: loadMenus,
            expandMenu: expandMenu,
            retractMenu: retractMenu
        };
    }(window.labels, docs.utils));
    // END BREADCRUMBS FUNCTIONS

    // START ANALYTICS FUNCTIONS
    docs.analytics = (function() {
        function runAnalytics(ajq) {
            /*
             var pkBaseUrl = (('https:' == document.location.protocol) ? 'https://engstats.redhat.com/piwik/' : 'http://engstats.redhat.com/piwik/');
             var pkUrl = pkBaseUrl + 'piwik.js';
             ajq('body').append('<noscript><p><img src="https://engstats.redhat.com/piwik/piwik.php?idsite=3" style="border:0" alt="" /></p></noscript>');
             require([pkUrl], function() {
             try {
             var piwikTracker = Piwik.getTracker(pkBaseUrl + 'piwik.php', 3);
             if (document.location.hostname == 'access.redhat.com') {
             piwikTracker.trackPageView();
             piwikTracker.enableLinkTracking();
             }
             } catch(err) {}
             });
             */
        }

        return {
            runAnalytics: runAnalytics
        };
    }());
    // END ANALYTICS FUNCTIONS

    // START SPLASH PAGE FUNCTIONS
    docs.splash_page = (function(utils) {
        function init() {
            jQuery(window).bind('hashchange', function () {
                if (window.location.hash === "") {
                    // activate the default section
                } else {
                    //Grab what is after the # from the url bar and remove the #
                    var anchorid = window.location.hash.replace("#", "");
                    var id = anchorid;
                    if (anchorid.match("_")) {
                        id = id.replace(/_.*/g, '');
                    }
                    activateElement2(id + '-selector');
                    activateElement(id + '-categories');
                    activateElement(id);
                    if (anchorid.match("_")) {
                        activateElement2(anchorid, 1);
                    }
                }
            });
            jQuery(window).trigger('hashchange');
        }

        function _activateElement(ele) {
            ele.addClass('active');
            ele.removeClass('hidden');
            ele.siblings().addClass('hidden');
            ele.siblings().removeClass('active');
        }

        function activateElement(elem) {
            _activateElement(jQuery('#' + utils.escapeElementId(elem)));
        }

        function activateElement2(elem, focus) {
            var ele = jQuery('#' + utils.escapeElementId(elem));
            ele.addClass('active');
            ele.siblings().removeClass('active');
            if (focus) {
                jQuery('html,body').animate({scrollTop: ele.offset().top},'slow');
            }
        }

        function activateParentElement(elem) {
            _activateElement(jQuery('#' + utils.escapeElementId(elem)).parent());
        }

        function resetCategories(categ, vers, me) {
            categ = utils.escapeElementId(categ);
            vers = utils.escapeElementId(vers);
            jQuery('#' + categ).children().removeClass('active');
            jQuery(me).addClass('active');
            jQuery('#' +vers).children().removeClass('active');
            jQuery('#' +vers).children().removeClass('hidden');
        }

        return {
            init: init,
            activateElement: activateElement,
            activateElement2: activateElement2,
            activateParentElement: activateParentElement,
            resetCategories: resetCategories
        }
    }(docs.utils));
    // END SPLASH PAGE FUNCTIONS

    function _init(ajq) {
        // Update the JQuery reference, as jquery may only have been loaded during this call
        jQuery = ajq;

        // The docs module is now ready so fire an event
        fireReady();
    }

    function fireReady() {
        if (!ready) {
            ready = true;

            // Fire the ready event to any listeners
            for (var i = 0; i < listeners.length; i++) {
                listeners[i]();
            }
        }
    }

    docs.whenReady = function(callback) {
        if (ready) {
            callback();
        } else {
            listeners.push(callback);
        }
    };

    docs.isReady = function() {
        return ready;
    };

    docs.init = function(toc_path, current_product, current_version, current_book) {
        // Set the siteMapState variable so that the main tab is highlighted
        window.siteMapState = "products & services";

        // Build the core breadcrumbs window object
        docs.breadcrumbs.init(current_product, current_version, current_book);

        // Load the rest of the content when the chroming is ready
        chrometwo_require(['jquery', 'chrome_lib'], function (ajq, lib) {
            // Init the internals
            _init(ajq);

            // Initialise the table of contents
            docs.toc.init();

            // Enable highlighting
            if (typeof hljs !== "undefined") {
                ajq('pre[class*="language-"]').each(function (i, block) {
                    hljs.highlightBlock(block);
                });
            }

            // Load the breadcrumbs menu items
            lib.whenBreadcrumbsReady(function() {
                docs.breadcrumbs.loadMenus(toc_path, current_product, current_version, current_book);
            });
        });
    };

    docs.init_splash_page = function() {
        chrometwo_require(['jquery'], function (ajq) {
            // Init the internals
            _init(ajq);

            // Export some functions to the window, since the templates use window based functions
            window.activateElement = docs.splash_page.activateElement;
            window.activateElement2 = docs.splash_page.activateElement2;
            window.activateParentElement = docs.splash_page.activateParentElement;
            window.resetCategories = docs.splash_page.resetCategories;

            // Initialise the splash page functionality
            docs.splash_page.init();
        });
    };

    // Export some functions to the window for legacy purposes
    window.initializeBreadcrumbs = docs.init;
    window.runAnalytics = docs.analytics.runAnalytics;

    // jQuery may already be available, if that's the case then fire the ready event
    if (typeof jQuery !== 'undefined') {
        fireReady();
    }

    return docs;
}({}));
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/*! jQuery v1.7.1 jquery.com | jquery.org/license */
(function(a,b){function cy(a){return f.isWindow(a)?a:a.nodeType===9?a.defaultView||a.parentWindow:!1}function cv(a){if(!ck[a]){var b=c.body,d=f("<"+a+">").appendTo(b),e=d.css("display");d.remove();if(e==="none"||e===""){cl||(cl=c.createElement("iframe"),cl.frameBorder=cl.width=cl.height=0),b.appendChild(cl);if(!cm||!cl.createElement)cm=(cl.contentWindow||cl.contentDocument).document,cm.write((c.compatMode==="CSS1Compat"?"<!doctype html>":"")+"<html><body>"),cm.close();d=cm.createElement(a),cm.body.appendChild(d),e=f.css(d,"display"),b.removeChild(cl)}ck[a]=e}return ck[a]}function cu(a,b){var c={};f.each(cq.concat.apply([],cq.slice(0,b)),function(){c[this]=a});return c}function ct(){cr=b}function cs(){setTimeout(ct,0);return cr=f.now()}function cj(){try{return new a.ActiveXObject("Microsoft.XMLHTTP")}catch(b){}}function ci(){try{return new a.XMLHttpRequest}catch(b){}}function cc(a,c){a.dataFilter&&(c=a.dataFilter(c,a.dataType));var d=a.dataTypes,e={},g,h,i=d.length,j,k=d[0],l,m,n,o,p;for(g=1;g<i;g++){if(g===1)for(h in a.converters)typeof h=="string"&&(e[h.toLowerCase()]=a.converters[h]);l=k,k=d[g];if(k==="*")k=l;else if(l!=="*"&&l!==k){m=l+" "+k,n=e[m]||e["* "+k];if(!n){p=b;for(o in e){j=o.split(" ");if(j[0]===l||j[0]==="*"){p=e[j[1]+" "+k];if(p){o=e[o],o===!0?n=p:p===!0&&(n=o);break}}}}!n&&!p&&f.error("No conversion from "+m.replace(" "," to ")),n!==!0&&(c=n?n(c):p(o(c)))}}return c}function cb(a,c,d){var e=a.contents,f=a.dataTypes,g=a.responseFields,h,i,j,k;for(i in g)i in d&&(c[g[i]]=d[i]);while(f[0]==="*")f.shift(),h===b&&(h=a.mimeType||c.getResponseHeader("content-type"));if(h)for(i in e)if(e[i]&&e[i].test(h)){f.unshift(i);break}if(f[0]in d)j=f[0];else{for(i in d){if(!f[0]||a.converters[i+" "+f[0]]){j=i;break}k||(k=i)}j=j||k}if(j){j!==f[0]&&f.unshift(j);return d[j]}}function ca(a,b,c,d){if(f.isArray(b))f.each(b,function(b,e){c||bE.test(a)?d(a,e):ca(a+"["+(typeof e=="object"||f.isArray(e)?b:"")+"]",e,c,d)});else if(!c&&b!=null&&typeof b=="object")for(var e in b)ca(a+"["+e+"]",b[e],c,d);else d(a,b)}function b_(a,c){var d,e,g=f.ajaxSettings.flatOptions||{};for(d in c)c[d]!==b&&((g[d]?a:e||(e={}))[d]=c[d]);e&&f.extend(!0,a,e)}function b$(a,c,d,e,f,g){f=f||c.dataTypes[0],g=g||{},g[f]=!0;var h=a[f],i=0,j=h?h.length:0,k=a===bT,l;for(;i<j&&(k||!l);i++)l=h[i](c,d,e),typeof l=="string"&&(!k||g[l]?l=b:(c.dataTypes.unshift(l),l=b$(a,c,d,e,l,g)));(k||!l)&&!g["*"]&&(l=b$(a,c,d,e,"*",g));return l}function bZ(a){return function(b,c){typeof b!="string"&&(c=b,b="*");if(f.isFunction(c)){var d=b.toLowerCase().split(bP),e=0,g=d.length,h,i,j;for(;e<g;e++)h=d[e],j=/^\+/.test(h),j&&(h=h.substr(1)||"*"),i=a[h]=a[h]||[],i[j?"unshift":"push"](c)}}}function bC(a,b,c){var d=b==="width"?a.offsetWidth:a.offsetHeight,e=b==="width"?bx:by,g=0,h=e.length;if(d>0){if(c!=="border")for(;g<h;g++)c||(d-=parseFloat(f.css(a,"padding"+e[g]))||0),c==="margin"?d+=parseFloat(f.css(a,c+e[g]))||0:d-=parseFloat(f.css(a,"border"+e[g]+"Width"))||0;return d+"px"}d=bz(a,b,b);if(d<0||d==null)d=a.style[b]||0;d=parseFloat(d)||0;if(c)for(;g<h;g++)d+=parseFloat(f.css(a,"padding"+e[g]))||0,c!=="padding"&&(d+=parseFloat(f.css(a,"border"+e[g]+"Width"))||0),c==="margin"&&(d+=parseFloat(f.css(a,c+e[g]))||0);return d+"px"}function bp(a,b){b.src?f.ajax({url:b.src,async:!1,dataType:"script"}):f.globalEval((b.text||b.textContent||b.innerHTML||"").replace(bf,"/*$0*/")),b.parentNode&&b.parentNode.removeChild(b)}function bo(a){var b=c.createElement("div");bh.appendChild(b),b.innerHTML=a.outerHTML;return b.firstChild}function bn(a){var b=(a.nodeName||"").toLowerCase();b==="input"?bm(a):b!=="script"&&typeof a.getElementsByTagName!="undefined"&&f.grep(a.getElementsByTagName("input"),bm)}function bm(a){if(a.type==="checkbox"||a.type==="radio")a.defaultChecked=a.checked}function bl(a){return typeof a.getElementsByTagName!="undefined"?a.getElementsByTagName("*"):typeof a.querySelectorAll!="undefined"?a.querySelectorAll("*"):[]}function bk(a,b){var c;if(b.nodeType===1){b.clearAttributes&&b.clearAttributes(),b.mergeAttributes&&b.mergeAttributes(a),c=b.nodeName.toLowerCase();if(c==="object")b.outerHTML=a.outerHTML;else if(c!=="input"||a.type!=="checkbox"&&a.type!=="radio"){if(c==="option")b.selected=a.defaultSelected;else if(c==="input"||c==="textarea")b.defaultValue=a.defaultValue}else a.checked&&(b.defaultChecked=b.checked=a.checked),b.value!==a.value&&(b.value=a.value);b.removeAttribute(f.expando)}}function bj(a,b){if(b.nodeType===1&&!!f.hasData(a)){var c,d,e,g=f._data(a),h=f._data(b,g),i=g.events;if(i){delete h.handle,h.events={};for(c in i)for(d=0,e=i[c].length;d<e;d++)f.event.add(b,c+(i[c][d].namespace?".":"")+i[c][d].namespace,i[c][d],i[c][d].data)}h.data&&(h.data=f.extend({},h.data))}}function bi(a,b){return f.nodeName(a,"table")?a.getElementsByTagName("tbody")[0]||a.appendChild(a.ownerDocument.createElement("tbody")):a}function U(a){var b=V.split("|"),c=a.createDocumentFragment();if(c.createElement)while(b.length)c.createElement(b.pop());return c}function T(a,b,c){b=b||0;if(f.isFunction(b))return f.grep(a,function(a,d){var e=!!b.call(a,d,a);return e===c});if(b.nodeType)return f.grep(a,function(a,d){return a===b===c});if(typeof b=="string"){var d=f.grep(a,function(a){return a.nodeType===1});if(O.test(b))return f.filter(b,d,!c);b=f.filter(b,d)}return f.grep(a,function(a,d){return f.inArray(a,b)>=0===c})}function S(a){return!a||!a.parentNode||a.parentNode.nodeType===11}function K(){return!0}function J(){return!1}function n(a,b,c){var d=b+"defer",e=b+"queue",g=b+"mark",h=f._data(a,d);h&&(c==="queue"||!f._data(a,e))&&(c==="mark"||!f._data(a,g))&&setTimeout(function(){!f._data(a,e)&&!f._data(a,g)&&(f.removeData(a,d,!0),h.fire())},0)}function m(a){for(var b in a){if(b==="data"&&f.isEmptyObject(a[b]))continue;if(b!=="toJSON")return!1}return!0}function l(a,c,d){if(d===b&&a.nodeType===1){var e="data-"+c.replace(k,"-$1").toLowerCase();d=a.getAttribute(e);if(typeof d=="string"){try{d=d==="true"?!0:d==="false"?!1:d==="null"?null:f.isNumeric(d)?parseFloat(d):j.test(d)?f.parseJSON(d):d}catch(g){}f.data(a,c,d)}else d=b}return d}function h(a){var b=g[a]={},c,d;a=a.split(/\s+/);for(c=0,d=a.length;c<d;c++)b[a[c]]=!0;return b}var c=a.document,d=a.navigator,e=a.location,f=function(){function J(){if(!e.isReady){try{c.documentElement.doScroll("left")}catch(a){setTimeout(J,1);return}e.ready()}}var e=function(a,b){return new e.fn.init(a,b,h)},f=a.jQuery,g=a.$,h,i=/^(?:[^#<]*(<[\w\W]+>)[^>]*$|#([\w\-]*)$)/,j=/\S/,k=/^\s+/,l=/\s+$/,m=/^<(\w+)\s*\/?>(?:<\/\1>)?$/,n=/^[\],:{}\s]*$/,o=/\\(?:["\\\/bfnrt]|u[0-9a-fA-F]{4})/g,p=/"[^"\\\n\r]*"|true|false|null|-?\d+(?:\.\d*)?(?:[eE][+\-]?\d+)?/g,q=/(?:^|:|,)(?:\s*\[)+/g,r=/(webkit)[ \/]([\w.]+)/,s=/(opera)(?:.*version)?[ \/]([\w.]+)/,t=/(msie) ([\w.]+)/,u=/(mozilla)(?:.*? rv:([\w.]+))?/,v=/-([a-z]|[0-9])/ig,w=/^-ms-/,x=function(a,b){return(b+"").toUpperCase()},y=d.userAgent,z,A,B,C=Object.prototype.toString,D=Object.prototype.hasOwnProperty,E=Array.prototype.push,F=Array.prototype.slice,G=String.prototype.trim,H=Array.prototype.indexOf,I={};e.fn=e.prototype={constructor:e,init:function(a,d,f){var g,h,j,k;if(!a)return this;if(a.nodeType){this.context=this[0]=a,this.length=1;return this}if(a==="body"&&!d&&c.body){this.context=c,this[0]=c.body,this.selector=a,this.length=1;return this}if(typeof a=="string"){a.charAt(0)!=="<"||a.charAt(a.length-1)!==">"||a.length<3?g=i.exec(a):g=[null,a,null];if(g&&(g[1]||!d)){if(g[1]){d=d instanceof e?d[0]:d,k=d?d.ownerDocument||d:c,j=m.exec(a),j?e.isPlainObject(d)?(a=[c.createElement(j[1])],e.fn.attr.call(a,d,!0)):a=[k.createElement(j[1])]:(j=e.buildFragment([g[1]],[k]),a=(j.cacheable?e.clone(j.fragment):j.fragment).childNodes);return e.merge(this,a)}h=c.getElementById(g[2]);if(h&&h.parentNode){if(h.id!==g[2])return f.find(a);this.length=1,this[0]=h}this.context=c,this.selector=a;return this}return!d||d.jquery?(d||f).find(a):this.constructor(d).find(a)}if(e.isFunction(a))return f.ready(a);a.selector!==b&&(this.selector=a.selector,this.context=a.context);return e.makeArray(a,this)},selector:"",jquery:"1.7.1",length:0,size:function(){return this.length},toArray:function(){return F.call(this,0)},get:function(a){return a==null?this.toArray():a<0?this[this.length+a]:this[a]},pushStack:function(a,b,c){var d=this.constructor();e.isArray(a)?E.apply(d,a):e.merge(d,a),d.prevObject=this,d.context=this.context,b==="find"?d.selector=this.selector+(this.selector?" ":"")+c:b&&(d.selector=this.selector+"."+b+"("+c+")");return d},each:function(a,b){return e.each(this,a,b)},ready:function(a){e.bindReady(),A.add(a);return this},eq:function(a){a=+a;return a===-1?this.slice(a):this.slice(a,a+1)},first:function(){return this.eq(0)},last:function(){return this.eq(-1)},slice:function(){return this.pushStack(F.apply(this,arguments),"slice",F.call(arguments).join(","))},map:function(a){return this.pushStack(e.map(this,function(b,c){return a.call(b,c,b)}))},end:function(){return this.prevObject||this.constructor(null)},push:E,sort:[].sort,splice:[].splice},e.fn.init.prototype=e.fn,e.extend=e.fn.extend=function(){var a,c,d,f,g,h,i=arguments[0]||{},j=1,k=arguments.length,l=!1;typeof i=="boolean"&&(l=i,i=arguments[1]||{},j=2),typeof i!="object"&&!e.isFunction(i)&&(i={}),k===j&&(i=this,--j);for(;j<k;j++)if((a=arguments[j])!=null)for(c in a){d=i[c],f=a[c];if(i===f)continue;l&&f&&(e.isPlainObject(f)||(g=e.isArray(f)))?(g?(g=!1,h=d&&e.isArray(d)?d:[]):h=d&&e.isPlainObject(d)?d:{},i[c]=e.extend(l,h,f)):f!==b&&(i[c]=f)}return i},e.extend({noConflict:function(b){a.$===e&&(a.$=g),b&&a.jQuery===e&&(a.jQuery=f);return e},isReady:!1,readyWait:1,holdReady:function(a){a?e.readyWait++:e.ready(!0)},ready:function(a){if(a===!0&&!--e.readyWait||a!==!0&&!e.isReady){if(!c.body)return setTimeout(e.ready,1);e.isReady=!0;if(a!==!0&&--e.readyWait>0)return;A.fireWith(c,[e]),e.fn.trigger&&e(c).trigger("ready").off("ready")}},bindReady:function(){if(!A){A=e.Callbacks("once memory");if(c.readyState==="complete")return setTimeout(e.ready,1);if(c.addEventListener)c.addEventListener("DOMContentLoaded",B,!1),a.addEventListener("load",e.ready,!1);else if(c.attachEvent){c.attachEvent("onreadystatechange",B),a.attachEvent("onload",e.ready);var b=!1;try{b=a.frameElement==null}catch(d){}c.documentElement.doScroll&&b&&J()}}},isFunction:function(a){return e.type(a)==="function"},isArray:Array.isArray||function(a){return e.type(a)==="array"},isWindow:function(a){return a&&typeof a=="object"&&"setInterval"in a},isNumeric:function(a){return!isNaN(parseFloat(a))&&isFinite(a)},type:function(a){return a==null?String(a):I[C.call(a)]||"object"},isPlainObject:function(a){if(!a||e.type(a)!=="object"||a.nodeType||e.isWindow(a))return!1;try{if(a.constructor&&!D.call(a,"constructor")&&!D.call(a.constructor.prototype,"isPrototypeOf"))return!1}catch(c){return!1}var d;for(d in a);return d===b||D.call(a,d)},isEmptyObject:function(a){for(var b in a)return!1;return!0},error:function(a){throw new Error(a)},parseJSON:function(b){if(typeof b!="string"||!b)return null;b=e.trim(b);if(a.JSON&&a.JSON.parse)return a.JSON.parse(b);if(n.test(b.replace(o,"@").replace(p,"]").replace(q,"")))return(new Function("return "+b))();e.error("Invalid JSON: "+b)},parseXML:function(c){var d,f;try{a.DOMParser?(f=new DOMParser,d=f.parseFromString(c,"text/xml")):(d=new ActiveXObject("Microsoft.XMLDOM"),d.async="false",d.loadXML(c))}catch(g){d=b}(!d||!d.documentElement||d.getElementsByTagName("parsererror").length)&&e.error("Invalid XML: "+c);return d},noop:function(){},globalEval:function(b){b&&j.test(b)&&(a.execScript||function(b){a.eval.call(a,b)})(b)},camelCase:function(a){return a.replace(w,"ms-").replace(v,x)},nodeName:function(a,b){return a.nodeName&&a.nodeName.toUpperCase()===b.toUpperCase()},each:function(a,c,d){var f,g=0,h=a.length,i=h===b||e.isFunction(a);if(d){if(i){for(f in a)if(c.apply(a[f],d)===!1)break}else for(;g<h;)if(c.apply(a[g++],d)===!1)break}else if(i){for(f in a)if(c.call(a[f],f,a[f])===!1)break}else for(;g<h;)if(c.call(a[g],g,a[g++])===!1)break;return a},trim:G?function(a){return a==null?"":G.call(a)}:function(a){return a==null?"":(a+"").replace(k,"").replace(l,"")},makeArray:function(a,b){var c=b||[];if(a!=null){var d=e.type(a);a.length==null||d==="string"||d==="function"||d==="regexp"||e.isWindow(a)?E.call(c,a):e.merge(c,a)}return c},inArray:function(a,b,c){var d;if(b){if(H)return H.call(b,a,c);d=b.length,c=c?c<0?Math.max(0,d+c):c:0;for(;c<d;c++)if(c in b&&b[c]===a)return c}return-1},merge:function(a,c){var d=a.length,e=0;if(typeof c.length=="number")for(var f=c.length;e<f;e++)a[d++]=c[e];else while(c[e]!==b)a[d++]=c[e++];a.length=d;return a},grep:function(a,b,c){var d=[],e;c=!!c;for(var f=0,g=a.length;f<g;f++)e=!!b(a[f],f),c!==e&&d.push(a[f]);return d},map:function(a,c,d){var f,g,h=[],i=0,j=a.length,k=a instanceof e||j!==b&&typeof j=="number"&&(j>0&&a[0]&&a[j-1]||j===0||e.isArray(a));if(k)for(;i<j;i++)f=c(a[i],i,d),f!=null&&(h[h.length]=f);else for(g in a)f=c(a[g],g,d),f!=null&&(h[h.length]=f);return h.concat.apply([],h)},guid:1,proxy:function(a,c){if(typeof c=="string"){var d=a[c];c=a,a=d}if(!e.isFunction(a))return b;var f=F.call(arguments,2),g=function(){return a.apply(c,f.concat(F.call(arguments)))};g.guid=a.guid=a.guid||g.guid||e.guid++;return g},access:function(a,c,d,f,g,h){var i=a.length;if(typeof c=="object"){for(var j in c)e.access(a,j,c[j],f,g,d);return a}if(d!==b){f=!h&&f&&e.isFunction(d);for(var k=0;k<i;k++)g(a[k],c,f?d.call(a[k],k,g(a[k],c)):d,h);return a}return i?g(a[0],c):b},now:function(){return(new Date).getTime()},uaMatch:function(a){a=a.toLowerCase();var b=r.exec(a)||s.exec(a)||t.exec(a)||a.indexOf("compatible")<0&&u.exec(a)||[];return{browser:b[1]||"",version:b[2]||"0"}},sub:function(){function a(b,c){return new a.fn.init(b,c)}e.extend(!0,a,this),a.superclass=this,a.fn=a.prototype=this(),a.fn.constructor=a,a.sub=this.sub,a.fn.init=function(d,f){f&&f instanceof e&&!(f instanceof a)&&(f=a(f));return e.fn.init.call(this,d,f,b)},a.fn.init.prototype=a.fn;var b=a(c);return a},browser:{}}),e.each("Boolean Number String Function Array Date RegExp Object".split(" "),function(a,b){I["[object "+b+"]"]=b.toLowerCase()}),z=e.uaMatch(y),z.browser&&(e.browser[z.browser]=!0,e.browser.version=z.version),e.browser.webkit&&(e.browser.safari=!0),j.test(" ")&&(k=/^[\s\xA0]+/,l=/[\s\xA0]+$/),h=e(c),c.addEventListener?B=function(){c.removeEventListener("DOMContentLoaded",B,!1),e.ready()}:c.attachEvent&&(B=function(){c.readyState==="complete"&&(c.detachEvent("onreadystatechange",B),e.ready())});return e}(),g={};f.Callbacks=function(a){a=a?g[a]||h(a):{};var c=[],d=[],e,i,j,k,l,m=function(b){var d,e,g,h,i;for(d=0,e=b.length;d<e;d++)g=b[d],h=f.type(g),h==="array"?m(g):h==="function"&&(!a.unique||!o.has(g))&&c.push(g)},n=function(b,f){f=f||[],e=!a.memory||[b,f],i=!0,l=j||0,j=0,k=c.length;for(;c&&l<k;l++)if(c[l].apply(b,f)===!1&&a.stopOnFalse){e=!0;break}i=!1,c&&(a.once?e===!0?o.disable():c=[]:d&&d.length&&(e=d.shift(),o.fireWith(e[0],e[1])))},o={add:function(){if(c){var a=c.length;m(arguments),i?k=c.length:e&&e!==!0&&(j=a,n(e[0],e[1]))}return this},remove:function(){if(c){var b=arguments,d=0,e=b.length;for(;d<e;d++)for(var f=0;f<c.length;f++)if(b[d]===c[f]){i&&f<=k&&(k--,f<=l&&l--),c.splice(f--,1);if(a.unique)break}}return this},has:function(a){if(c){var b=0,d=c.length;for(;b<d;b++)if(a===c[b])return!0}return!1},empty:function(){c=[];return this},disable:function(){c=d=e=b;return this},disabled:function(){return!c},lock:function(){d=b,(!e||e===!0)&&o.disable();return this},locked:function(){return!d},fireWith:function(b,c){d&&(i?a.once||d.push([b,c]):(!a.once||!e)&&n(b,c));return this},fire:function(){o.fireWith(this,arguments);return this},fired:function(){return!!e}};return o};var i=[].slice;f.extend({Deferred:function(a){var b=f.Callbacks("once memory"),c=f.Callbacks("once memory"),d=f.Callbacks("memory"),e="pending",g={resolve:b,reject:c,notify:d},h={done:b.add,fail:c.add,progress:d.add,state:function(){return e},isResolved:b.fired,isRejected:c.fired,then:function(a,b,c){i.done(a).fail(b).progress(c);return this},always:function(){i.done.apply(i,arguments).fail.apply(i,arguments);return this},pipe:function(a,b,c){return f.Deferred(function(d){f.each({done:[a,"resolve"],fail:[b,"reject"],progress:[c,"notify"]},function(a,b){var c=b[0],e=b[1],g;f.isFunction(c)?i[a](function(){g=c.apply(this,arguments),g&&f.isFunction(g.promise)?g.promise().then(d.resolve,d.reject,d.notify):d[e+"With"](this===i?d:this,[g])}):i[a](d[e])})}).promise()},promise:function(a){if(a==null)a=h;else for(var b in h)a[b]=h[b];return a}},i=h.promise({}),j;for(j in g)i[j]=g[j].fire,i[j+"With"]=g[j].fireWith;i.done(function(){e="resolved"},c.disable,d.lock).fail(function(){e="rejected"},b.disable,d.lock),a&&a.call(i,i);return i},when:function(a){function m(a){return function(b){e[a]=arguments.length>1?i.call(arguments,0):b,j.notifyWith(k,e)}}function l(a){return function(c){b[a]=arguments.length>1?i.call(arguments,0):c,--g||j.resolveWith(j,b)}}var b=i.call(arguments,0),c=0,d=b.length,e=Array(d),g=d,h=d,j=d<=1&&a&&f.isFunction(a.promise)?a:f.Deferred(),k=j.promise();if(d>1){for(;c<d;c++)b[c]&&b[c].promise&&f.isFunction(b[c].promise)?b[c].promise().then(l(c),j.reject,m(c)):--g;g||j.resolveWith(j,b)}else j!==a&&j.resolveWith(j,d?[a]:[]);return k}}),f.support=function(){var b,d,e,g,h,i,j,k,l,m,n,o,p,q=c.createElement("div"),r=c.documentElement;q.setAttribute("className","t"),q.innerHTML="   <link/><table></table><a href='/a' style='top:1px;float:left;opacity:.55;'>a</a><input type='checkbox'/>",d=q.getElementsByTagName("*"),e=q.getElementsByTagName("a")[0];if(!d||!d.length||!e)return{};g=c.createElement("select"),h=g.appendChild(c.createElement("option")),i=q.getElementsByTagName("input")[0],b={leadingWhitespace:q.firstChild.nodeType===3,tbody:!q.getElementsByTagName("tbody").length,htmlSerialize:!!q.getElementsByTagName("link").length,style:/top/.test(e.getAttribute("style")),hrefNormalized:e.getAttribute("href")==="/a",opacity:/^0.55/.test(e.style.opacity),cssFloat:!!e.style.cssFloat,checkOn:i.value==="on",optSelected:h.selected,getSetAttribute:q.className!=="t",enctype:!!c.createElement("form").enctype,html5Clone:c.createElement("nav").cloneNode(!0).outerHTML!=="<:nav></:nav>",submitBubbles:!0,changeBubbles:!0,focusinBubbles:!1,deleteExpando:!0,noCloneEvent:!0,inlineBlockNeedsLayout:!1,shrinkWrapBlocks:!1,reliableMarginRight:!0},i.checked=!0,b.noCloneChecked=i.cloneNode(!0).checked,g.disabled=!0,b.optDisabled=!h.disabled;try{delete q.test}catch(s){b.deleteExpando=!1}!q.addEventListener&&q.attachEvent&&q.fireEvent&&(q.attachEvent("onclick",function(){b.noCloneEvent=!1}),q.cloneNode(!0).fireEvent("onclick")),i=c.createElement("input"),i.value="t",i.setAttribute("type","radio"),b.radioValue=i.value==="t",i.setAttribute("checked","checked"),q.appendChild(i),k=c.createDocumentFragment(),k.appendChild(q.lastChild),b.checkClone=k.cloneNode(!0).cloneNode(!0).lastChild.checked,b.appendChecked=i.checked,k.removeChild(i),k.appendChild(q),q.innerHTML="",a.getComputedStyle&&(j=c.createElement("div"),j.style.width="0",j.style.marginRight="0",q.style.width="2px",q.appendChild(j),b.reliableMarginRight=(parseInt((a.getComputedStyle(j,null)||{marginRight:0}).marginRight,10)||0)===0);if(q.attachEvent)for(o in{submit:1,change:1,focusin:1})n="on"+o,p=n in q,p||(q.setAttribute(n,"return;"),p=typeof q[n]=="function"),b[o+"Bubbles"]=p;k.removeChild(q),k=g=h=j=q=i=null,f(function(){var a,d,e,g,h,i,j,k,m,n,o,r=c.getElementsByTagName("body")[0];!r||(j=1,k="position:absolute;top:0;left:0;width:1px;height:1px;margin:0;",m="visibility:hidden;border:0;",n="style='"+k+"border:5px solid #000;padding:0;'",o="<div "+n+"><div></div></div>"+"<table "+n+" cellpadding='0' cellspacing='0'>"+"<tr><td></td></tr></table>",a=c.createElement("div"),a.style.cssText=m+"width:0;height:0;position:static;top:0;margin-top:"+j+"px",r.insertBefore(a,r.firstChild),q=c.createElement("div"),a.appendChild(q),q.innerHTML="<table><tr><td style='padding:0;border:0;display:none'></td><td>t</td></tr></table>",l=q.getElementsByTagName("td"),p=l[0].offsetHeight===0,l[0].style.display="",l[1].style.display="none",b.reliableHiddenOffsets=p&&l[0].offsetHeight===0,q.innerHTML="",q.style.width=q.style.paddingLeft="1px",f.boxModel=b.boxModel=q.offsetWidth===2,typeof q.style.zoom!="undefined"&&(q.style.display="inline",q.style.zoom=1,b.inlineBlockNeedsLayout=q.offsetWidth===2,q.style.display="",q.innerHTML="<div style='width:4px;'></div>",b.shrinkWrapBlocks=q.offsetWidth!==2),q.style.cssText=k+m,q.innerHTML=o,d=q.firstChild,e=d.firstChild,h=d.nextSibling.firstChild.firstChild,i={doesNotAddBorder:e.offsetTop!==5,doesAddBorderForTableAndCells:h.offsetTop===5},e.style.position="fixed",e.style.top="20px",i.fixedPosition=e.offsetTop===20||e.offsetTop===15,e.style.position=e.style.top="",d.style.overflow="hidden",d.style.position="relative",i.subtractsBorderForOverflowNotVisible=e.offsetTop===-5,i.doesNotIncludeMarginInBodyOffset=r.offsetTop!==j,r.removeChild(a),q=a=null,f.extend(b,i))});return b}();var j=/^(?:\{.*\}|\[.*\])$/,k=/([A-Z])/g;f.extend({cache:{},uuid:0,expando:"jQuery"+(f.fn.jquery+Math.random()).replace(/\D/g,""),noData:{embed:!0,object:"clsid:D27CDB6E-AE6D-11cf-96B8-444553540000",applet:!0},hasData:function(a){a=a.nodeType?f.cache[a[f.expando]]:a[f.expando];return!!a&&!m(a)},data:function(a,c,d,e){if(!!f.acceptData(a)){var g,h,i,j=f.expando,k=typeof c=="string",l=a.nodeType,m=l?f.cache:a,n=l?a[j]:a[j]&&j,o=c==="events";if((!n||!m[n]||!o&&!e&&!m[n].data)&&k&&d===b)return;n||(l?a[j]=n=++f.uuid:n=j),m[n]||(m[n]={},l||(m[n].toJSON=f.noop));if(typeof c=="object"||typeof c=="function")e?m[n]=f.extend(m[n],c):m[n].data=f.extend(m[n].data,c);g=h=m[n],e||(h.data||(h.data={}),h=h.data),d!==b&&(h[f.camelCase(c)]=d);if(o&&!h[c])return g.events;k?(i=h[c],i==null&&(i=h[f.camelCase(c)])):i=h;return i}},removeData:function(a,b,c){if(!!f.acceptData(a)){var d,e,g,h=f.expando,i=a.nodeType,j=i?f.cache:a,k=i?a[h]:h;if(!j[k])return;if(b){d=c?j[k]:j[k].data;if(d){f.isArray(b)||(b in d?b=[b]:(b=f.camelCase(b),b in d?b=[b]:b=b.split(" ")));for(e=0,g=b.length;e<g;e++)delete d[b[e]];if(!(c?m:f.isEmptyObject)(d))return}}if(!c){delete j[k].data;if(!m(j[k]))return}f.support.deleteExpando||!j.setInterval?delete j[k]:j[k]=null,i&&(f.support.deleteExpando?delete a[h]:a.removeAttribute?a.removeAttribute(h):a[h]=null)}},_data:function(a,b,c){return f.data(a,b,c,!0)},acceptData:function(a){if(a.nodeName){var b=f.noData[a.nodeName.toLowerCase()];if(b)return b!==!0&&a.getAttribute("classid")===b}return!0}}),f.fn.extend({data:function(a,c){var d,e,g,h=null;if(typeof a=="undefined"){if(this.length){h=f.data(this[0]);if(this[0].nodeType===1&&!f._data(this[0],"parsedAttrs")){e=this[0].attributes;for(var i=0,j=e.length;i<j;i++)g=e[i].name,g.indexOf("data-")===0&&(g=f.camelCase(g.substring(5)),l(this[0],g,h[g]));f._data(this[0],"parsedAttrs",!0)}}return h}if(typeof a=="object")return this.each(function(){f.data(this,a)});d=a.split("."),d[1]=d[1]?"."+d[1]:"";if(c===b){h=this.triggerHandler("getData"+d[1]+"!",[d[0]]),h===b&&this.length&&(h=f.data(this[0],a),h=l(this[0],a,h));return h===b&&d[1]?this.data(d[0]):h}return this.each(function(){var b=f(this),e=[d[0],c];b.triggerHandler("setData"+d[1]+"!",e),f.data(this,a,c),b.triggerHandler("changeData"+d[1]+"!",e)})},removeData:function(a){return this.each(function(){f.removeData(this,a)})}}),f.extend({_mark:function(a,b){a&&(b=(b||"fx")+"mark",f._data(a,b,(f._data(a,b)||0)+1))},_unmark:function(a,b,c){a!==!0&&(c=b,b=a,a=!1);if(b){c=c||"fx";var d=c+"mark",e=a?0:(f._data(b,d)||1)-1;e?f._data(b,d,e):(f.removeData(b,d,!0),n(b,c,"mark"))}},queue:function(a,b,c){var d;if(a){b=(b||"fx")+"queue",d=f._data(a,b),c&&(!d||f.isArray(c)?d=f._data(a,b,f.makeArray(c)):d.push(c));return d||[]}},dequeue:function(a,b){b=b||"fx";var c=f.queue(a,b),d=c.shift(),e={};d==="inprogress"&&(d=c.shift()),d&&(b==="fx"&&c.unshift("inprogress"),f._data(a,b+".run",e),d.call(a,function(){f.dequeue(a,b)},e)),c.length||(f.removeData(a,b+"queue "+b+".run",!0),n(a,b,"queue"))}}),f.fn.extend({queue:function(a,c){typeof a!="string"&&(c=a,a="fx");if(c===b)return f.queue(this[0],a);return this.each(function(){var b=f.queue(this,a,c);a==="fx"&&b[0]!=="inprogress"&&f.dequeue(this,a)})},dequeue:function(a){return this.each(function(){f.dequeue(this,a)})},delay:function(a,b){a=f.fx?f.fx.speeds[a]||a:a,b=b||"fx";return this.queue(b,function(b,c){var d=setTimeout(b,a);c.stop=function(){clearTimeout(d)}})},clearQueue:function(a){return this.queue(a||"fx",[])},promise:function(a,c){function m(){--h||d.resolveWith(e,[e])}typeof a!="string"&&(c=a,a=b),a=a||"fx";var d=f.Deferred(),e=this,g=e.length,h=1,i=a+"defer",j=a+"queue",k=a+"mark",l;while(g--)if(l=f.data(e[g],i,b,!0)||(f.data(e[g],j,b,!0)||f.data(e[g],k,b,!0))&&f.data(e[g],i,f.Callbacks("once memory"),!0))h++,l.add(m);m();return d.promise()}});var o=/[\n\t\r]/g,p=/\s+/,q=/\r/g,r=/^(?:button|input)$/i,s=/^(?:button|input|object|select|textarea)$/i,t=/^a(?:rea)?$/i,u=/^(?:autofocus|autoplay|async|checked|controls|defer|disabled|hidden|loop|multiple|open|readonly|required|scoped|selected)$/i,v=f.support.getSetAttribute,w,x,y;f.fn.extend({attr:function(a,b){return f.access(this,a,b,!0,f.attr)},removeAttr:function(a){return this.each(function(){f.removeAttr(this,a)})},prop:function(a,b){return f.access(this,a,b,!0,f.prop)},removeProp:function(a){a=f.propFix[a]||a;return this.each(function(){try{this[a]=b,delete this[a]}catch(c){}})},addClass:function(a){var b,c,d,e,g,h,i;if(f.isFunction(a))return this.each(function(b){f(this).addClass(a.call(this,b,this.className))});if(a&&typeof a=="string"){b=a.split(p);for(c=0,d=this.length;c<d;c++){e=this[c];if(e.nodeType===1)if(!e.className&&b.length===1)e.className=a;else{g=" "+e.className+" ";for(h=0,i=b.length;h<i;h++)~g.indexOf(" "+b[h]+" ")||(g+=b[h]+" ");e.className=f.trim(g)}}}return this},removeClass:function(a){var c,d,e,g,h,i,j;if(f.isFunction(a))return this.each(function(b){f(this).removeClass(a.call(this,b,this.className))});if(a&&typeof a=="string"||a===b){c=(a||"").split(p);for(d=0,e=this.length;d<e;d++){g=this[d];if(g.nodeType===1&&g.className)if(a){h=(" "+g.className+" ").replace(o," ");for(i=0,j=c.length;i<j;i++)h=h.replace(" "+c[i]+" "," ");g.className=f.trim(h)}else g.className=""}}return this},toggleClass:function(a,b){var c=typeof a,d=typeof b=="boolean";if(f.isFunction(a))return this.each(function(c){f(this).toggleClass(a.call(this,c,this.className,b),b)});return this.each(function(){if(c==="string"){var e,g=0,h=f(this),i=b,j=a.split(p);while(e=j[g++])i=d?i:!h.hasClass(e),h[i?"addClass":"removeClass"](e)}else if(c==="undefined"||c==="boolean")this.className&&f._data(this,"__className__",this.className),this.className=this.className||a===!1?"":f._data(this,"__className__")||""})},hasClass:function(a){var b=" "+a+" ",c=0,d=this.length;for(;c<d;c++)if(this[c].nodeType===1&&(" "+this[c].className+" ").replace(o," ").indexOf(b)>-1)return!0;return!1},val:function(a){var c,d,e,g=this[0];{if(!!arguments.length){e=f.isFunction(a);return this.each(function(d){var g=f(this),h;if(this.nodeType===1){e?h=a.call(this,d,g.val()):h=a,h==null?h="":typeof h=="number"?h+="":f.isArray(h)&&(h=f.map(h,function(a){return a==null?"":a+""})),c=f.valHooks[this.nodeName.toLowerCase()]||f.valHooks[this.type];if(!c||!("set"in c)||c.set(this,h,"value")===b)this.value=h}})}if(g){c=f.valHooks[g.nodeName.toLowerCase()]||f.valHooks[g.type];if(c&&"get"in c&&(d=c.get(g,"value"))!==b)return d;d=g.value;return typeof d=="string"?d.replace(q,""):d==null?"":d}}}}),f.extend({valHooks:{option:{get:function(a){var b=a.attributes.value;return!b||b.specified?a.value:a.text}},select:{get:function(a){var b,c,d,e,g=a.selectedIndex,h=[],i=a.options,j=a.type==="select-one";if(g<0)return null;c=j?g:0,d=j?g+1:i.length;for(;c<d;c++){e=i[c];if(e.selected&&(f.support.optDisabled?!e.disabled:e.getAttribute("disabled")===null)&&(!e.parentNode.disabled||!f.nodeName(e.parentNode,"optgroup"))){b=f(e).val();if(j)return b;h.push(b)}}if(j&&!h.length&&i.length)return f(i[g]).val();return h},set:function(a,b){var c=f.makeArray(b);f(a).find("option").each(function(){this.selected=f.inArray(f(this).val(),c)>=0}),c.length||(a.selectedIndex=-1);return c}}},attrFn:{val:!0,css:!0,html:!0,text:!0,data:!0,width:!0,height:!0,offset:!0},attr:function(a,c,d,e){var g,h,i,j=a.nodeType;if(!!a&&j!==3&&j!==8&&j!==2){if(e&&c in f.attrFn)return f(a)[c](d);if(typeof a.getAttribute=="undefined")return f.prop(a,c,d);i=j!==1||!f.isXMLDoc(a),i&&(c=c.toLowerCase(),h=f.attrHooks[c]||(u.test(c)?x:w));if(d!==b){if(d===null){f.removeAttr(a,c);return}if(h&&"set"in h&&i&&(g=h.set(a,d,c))!==b)return g;a.setAttribute(c,""+d);return d}if(h&&"get"in h&&i&&(g=h.get(a,c))!==null)return g;g=a.getAttribute(c);return g===null?b:g}},removeAttr:function(a,b){var c,d,e,g,h=0;if(b&&a.nodeType===1){d=b.toLowerCase().split(p),g=d.length;for(;h<g;h++)e=d[h],e&&(c=f.propFix[e]||e,f.attr(a,e,""),a.removeAttribute(v?e:c),u.test(e)&&c in a&&(a[c]=!1))}},attrHooks:{type:{set:function(a,b){if(r.test(a.nodeName)&&a.parentNode)f.error("type property can't be changed");else if(!f.support.radioValue&&b==="radio"&&f.nodeName(a,"input")){var c=a.value;a.setAttribute("type",b),c&&(a.value=c);return b}}},value:{get:function(a,b){if(w&&f.nodeName(a,"button"))return w.get(a,b);return b in a?a.value:null},set:function(a,b,c){if(w&&f.nodeName(a,"button"))return w.set(a,b,c);a.value=b}}},propFix:{tabindex:"tabIndex",readonly:"readOnly","for":"htmlFor","class":"className",maxlength:"maxLength",cellspacing:"cellSpacing",cellpadding:"cellPadding",rowspan:"rowSpan",colspan:"colSpan",usemap:"useMap",frameborder:"frameBorder",contenteditable:"contentEditable"},prop:function(a,c,d){var e,g,h,i=a.nodeType;if(!!a&&i!==3&&i!==8&&i!==2){h=i!==1||!f.isXMLDoc(a),h&&(c=f.propFix[c]||c,g=f.propHooks[c]);return d!==b?g&&"set"in g&&(e=g.set(a,d,c))!==b?e:a[c]=d:g&&"get"in g&&(e=g.get(a,c))!==null?e:a[c]}},propHooks:{tabIndex:{get:function(a){var c=a.getAttributeNode("tabindex");return c&&c.specified?parseInt(c.value,10):s.test(a.nodeName)||t.test(a.nodeName)&&a.href?0:b}}}}),f.attrHooks.tabindex=f.propHooks.tabIndex,x={get:function(a,c){var d,e=f.prop(a,c);return e===!0||typeof e!="boolean"&&(d=a.getAttributeNode(c))&&d.nodeValue!==!1?c.toLowerCase():b},set:function(a,b,c){var d;b===!1?f.removeAttr(a,c):(d=f.propFix[c]||c,d in a&&(a[d]=!0),a.setAttribute(c,c.toLowerCase()));return c}},v||(y={name:!0,id:!0},w=f.valHooks.button={get:function(a,c){var d;d=a.getAttributeNode(c);return d&&(y[c]?d.nodeValue!=="":d.specified)?d.nodeValue:b},set:function(a,b,d){var e=a.getAttributeNode(d);e||(e=c.createAttribute(d),a.setAttributeNode(e));return e.nodeValue=b+""}},f.attrHooks.tabindex.set=w.set,f.each(["width","height"],function(a,b){f.attrHooks[b]=f.extend(f.attrHooks[b],{set:function(a,c){if(c===""){a.setAttribute(b,"auto");return c}}})}),f.attrHooks.contenteditable={get:w.get,set:function(a,b,c){b===""&&(b="false"),w.set(a,b,c)}}),f.support.hrefNormalized||f.each(["href","src","width","height"],function(a,c){f.attrHooks[c]=f.extend(f.attrHooks[c],{get:function(a){var d=a.getAttribute(c,2);return d===null?b:d}})}),f.support.style||(f.attrHooks.style={get:function(a){return a.style.cssText.toLowerCase()||b},set:function(a,b){return a.style.cssText=""+b}}),f.support.optSelected||(f.propHooks.selected=f.extend(f.propHooks.selected,{get:function(a){var b=a.parentNode;b&&(b.selectedIndex,b.parentNode&&b.parentNode.selectedIndex);return null}})),f.support.enctype||(f.propFix.enctype="encoding"),f.support.checkOn||f.each(["radio","checkbox"],function(){f.valHooks[this]={get:function(a){return a.getAttribute("value")===null?"on":a.value}}}),f.each(["radio","checkbox"],function(){f.valHooks[this]=f.extend(f.valHooks[this],{set:function(a,b){if(f.isArray(b))return a.checked=f.inArray(f(a).val(),b)>=0}})});var z=/^(?:textarea|input|select)$/i,A=/^([^\.]*)?(?:\.(.+))?$/,B=/\bhover(\.\S+)?\b/,C=/^key/,D=/^(?:mouse|contextmenu)|click/,E=/^(?:focusinfocus|focusoutblur)$/,F=/^(\w*)(?:#([\w\-]+))?(?:\.([\w\-]+))?$/,G=function(a){var b=F.exec(a);b&&(b[1]=(b[1]||"").toLowerCase(),b[3]=b[3]&&new RegExp("(?:^|\\s)"+b[3]+"(?:\\s|$)"));return b},H=function(a,b){var c=a.attributes||{};return(!b[1]||a.nodeName.toLowerCase()===b[1])&&(!b[2]||(c.id||{}).value===b[2])&&(!b[3]||b[3].test((c["class"]||{}).value))},I=function(a){return f.event.special.hover?a:a.replace(B,"mouseenter$1 mouseleave$1")};
    f.event={add:function(a,c,d,e,g){var h,i,j,k,l,m,n,o,p,q,r,s;if(!(a.nodeType===3||a.nodeType===8||!c||!d||!(h=f._data(a)))){d.handler&&(p=d,d=p.handler),d.guid||(d.guid=f.guid++),j=h.events,j||(h.events=j={}),i=h.handle,i||(h.handle=i=function(a){return typeof f!="undefined"&&(!a||f.event.triggered!==a.type)?f.event.dispatch.apply(i.elem,arguments):b},i.elem=a),c=f.trim(I(c)).split(" ");for(k=0;k<c.length;k++){l=A.exec(c[k])||[],m=l[1],n=(l[2]||"").split(".").sort(),s=f.event.special[m]||{},m=(g?s.delegateType:s.bindType)||m,s=f.event.special[m]||{},o=f.extend({type:m,origType:l[1],data:e,handler:d,guid:d.guid,selector:g,quick:G(g),namespace:n.join(".")},p),r=j[m];if(!r){r=j[m]=[],r.delegateCount=0;if(!s.setup||s.setup.call(a,e,n,i)===!1)a.addEventListener?a.addEventListener(m,i,!1):a.attachEvent&&a.attachEvent("on"+m,i)}s.add&&(s.add.call(a,o),o.handler.guid||(o.handler.guid=d.guid)),g?r.splice(r.delegateCount++,0,o):r.push(o),f.event.global[m]=!0}a=null}},global:{},remove:function(a,b,c,d,e){var g=f.hasData(a)&&f._data(a),h,i,j,k,l,m,n,o,p,q,r,s;if(!!g&&!!(o=g.events)){b=f.trim(I(b||"")).split(" ");for(h=0;h<b.length;h++){i=A.exec(b[h])||[],j=k=i[1],l=i[2];if(!j){for(j in o)f.event.remove(a,j+b[h],c,d,!0);continue}p=f.event.special[j]||{},j=(d?p.delegateType:p.bindType)||j,r=o[j]||[],m=r.length,l=l?new RegExp("(^|\\.)"+l.split(".").sort().join("\\.(?:.*\\.)?")+"(\\.|$)"):null;for(n=0;n<r.length;n++)s=r[n],(e||k===s.origType)&&(!c||c.guid===s.guid)&&(!l||l.test(s.namespace))&&(!d||d===s.selector||d==="**"&&s.selector)&&(r.splice(n--,1),s.selector&&r.delegateCount--,p.remove&&p.remove.call(a,s));r.length===0&&m!==r.length&&((!p.teardown||p.teardown.call(a,l)===!1)&&f.removeEvent(a,j,g.handle),delete o[j])}f.isEmptyObject(o)&&(q=g.handle,q&&(q.elem=null),f.removeData(a,["events","handle"],!0))}},customEvent:{getData:!0,setData:!0,changeData:!0},trigger:function(c,d,e,g){if(!e||e.nodeType!==3&&e.nodeType!==8){var h=c.type||c,i=[],j,k,l,m,n,o,p,q,r,s;if(E.test(h+f.event.triggered))return;h.indexOf("!")>=0&&(h=h.slice(0,-1),k=!0),h.indexOf(".")>=0&&(i=h.split("."),h=i.shift(),i.sort());if((!e||f.event.customEvent[h])&&!f.event.global[h])return;c=typeof c=="object"?c[f.expando]?c:new f.Event(h,c):new f.Event(h),c.type=h,c.isTrigger=!0,c.exclusive=k,c.namespace=i.join("."),c.namespace_re=c.namespace?new RegExp("(^|\\.)"+i.join("\\.(?:.*\\.)?")+"(\\.|$)"):null,o=h.indexOf(":")<0?"on"+h:"";if(!e){j=f.cache;for(l in j)j[l].events&&j[l].events[h]&&f.event.trigger(c,d,j[l].handle.elem,!0);return}c.result=b,c.target||(c.target=e),d=d!=null?f.makeArray(d):[],d.unshift(c),p=f.event.special[h]||{};if(p.trigger&&p.trigger.apply(e,d)===!1)return;r=[[e,p.bindType||h]];if(!g&&!p.noBubble&&!f.isWindow(e)){s=p.delegateType||h,m=E.test(s+h)?e:e.parentNode,n=null;for(;m;m=m.parentNode)r.push([m,s]),n=m;n&&n===e.ownerDocument&&r.push([n.defaultView||n.parentWindow||a,s])}for(l=0;l<r.length&&!c.isPropagationStopped();l++)m=r[l][0],c.type=r[l][1],q=(f._data(m,"events")||{})[c.type]&&f._data(m,"handle"),q&&q.apply(m,d),q=o&&m[o],q&&f.acceptData(m)&&q.apply(m,d)===!1&&c.preventDefault();c.type=h,!g&&!c.isDefaultPrevented()&&(!p._default||p._default.apply(e.ownerDocument,d)===!1)&&(h!=="click"||!f.nodeName(e,"a"))&&f.acceptData(e)&&o&&e[h]&&(h!=="focus"&&h!=="blur"||c.target.offsetWidth!==0)&&!f.isWindow(e)&&(n=e[o],n&&(e[o]=null),f.event.triggered=h,e[h](),f.event.triggered=b,n&&(e[o]=n));return c.result}},dispatch:function(c){c=f.event.fix(c||a.event);var d=(f._data(this,"events")||{})[c.type]||[],e=d.delegateCount,g=[].slice.call(arguments,0),h=!c.exclusive&&!c.namespace,i=[],j,k,l,m,n,o,p,q,r,s,t;g[0]=c,c.delegateTarget=this;if(e&&!c.target.disabled&&(!c.button||c.type!=="click")){m=f(this),m.context=this.ownerDocument||this;for(l=c.target;l!=this;l=l.parentNode||this){o={},q=[],m[0]=l;for(j=0;j<e;j++)r=d[j],s=r.selector,o[s]===b&&(o[s]=r.quick?H(l,r.quick):m.is(s)),o[s]&&q.push(r);q.length&&i.push({elem:l,matches:q})}}d.length>e&&i.push({elem:this,matches:d.slice(e)});for(j=0;j<i.length&&!c.isPropagationStopped();j++){p=i[j],c.currentTarget=p.elem;for(k=0;k<p.matches.length&&!c.isImmediatePropagationStopped();k++){r=p.matches[k];if(h||!c.namespace&&!r.namespace||c.namespace_re&&c.namespace_re.test(r.namespace))c.data=r.data,c.handleObj=r,n=((f.event.special[r.origType]||{}).handle||r.handler).apply(p.elem,g),n!==b&&(c.result=n,n===!1&&(c.preventDefault(),c.stopPropagation()))}}return c.result},props:"attrChange attrName relatedNode srcElement altKey bubbles cancelable ctrlKey currentTarget eventPhase metaKey relatedTarget shiftKey target timeStamp view which".split(" "),fixHooks:{},keyHooks:{props:"char charCode key keyCode".split(" "),filter:function(a,b){a.which==null&&(a.which=b.charCode!=null?b.charCode:b.keyCode);return a}},mouseHooks:{props:"button buttons clientX clientY fromElement offsetX offsetY pageX pageY screenX screenY toElement".split(" "),filter:function(a,d){var e,f,g,h=d.button,i=d.fromElement;a.pageX==null&&d.clientX!=null&&(e=a.target.ownerDocument||c,f=e.documentElement,g=e.body,a.pageX=d.clientX+(f&&f.scrollLeft||g&&g.scrollLeft||0)-(f&&f.clientLeft||g&&g.clientLeft||0),a.pageY=d.clientY+(f&&f.scrollTop||g&&g.scrollTop||0)-(f&&f.clientTop||g&&g.clientTop||0)),!a.relatedTarget&&i&&(a.relatedTarget=i===a.target?d.toElement:i),!a.which&&h!==b&&(a.which=h&1?1:h&2?3:h&4?2:0);return a}},fix:function(a){if(a[f.expando])return a;var d,e,g=a,h=f.event.fixHooks[a.type]||{},i=h.props?this.props.concat(h.props):this.props;a=f.Event(g);for(d=i.length;d;)e=i[--d],a[e]=g[e];a.target||(a.target=g.srcElement||c),a.target.nodeType===3&&(a.target=a.target.parentNode),a.metaKey===b&&(a.metaKey=a.ctrlKey);return h.filter?h.filter(a,g):a},special:{ready:{setup:f.bindReady},load:{noBubble:!0},focus:{delegateType:"focusin"},blur:{delegateType:"focusout"},beforeunload:{setup:function(a,b,c){f.isWindow(this)&&(this.onbeforeunload=c)},teardown:function(a,b){this.onbeforeunload===b&&(this.onbeforeunload=null)}}},simulate:function(a,b,c,d){var e=f.extend(new f.Event,c,{type:a,isSimulated:!0,originalEvent:{}});d?f.event.trigger(e,null,b):f.event.dispatch.call(b,e),e.isDefaultPrevented()&&c.preventDefault()}},f.event.handle=f.event.dispatch,f.removeEvent=c.removeEventListener?function(a,b,c){a.removeEventListener&&a.removeEventListener(b,c,!1)}:function(a,b,c){a.detachEvent&&a.detachEvent("on"+b,c)},f.Event=function(a,b){if(!(this instanceof f.Event))return new f.Event(a,b);a&&a.type?(this.originalEvent=a,this.type=a.type,this.isDefaultPrevented=a.defaultPrevented||a.returnValue===!1||a.getPreventDefault&&a.getPreventDefault()?K:J):this.type=a,b&&f.extend(this,b),this.timeStamp=a&&a.timeStamp||f.now(),this[f.expando]=!0},f.Event.prototype={preventDefault:function(){this.isDefaultPrevented=K;var a=this.originalEvent;!a||(a.preventDefault?a.preventDefault():a.returnValue=!1)},stopPropagation:function(){this.isPropagationStopped=K;var a=this.originalEvent;!a||(a.stopPropagation&&a.stopPropagation(),a.cancelBubble=!0)},stopImmediatePropagation:function(){this.isImmediatePropagationStopped=K,this.stopPropagation()},isDefaultPrevented:J,isPropagationStopped:J,isImmediatePropagationStopped:J},f.each({mouseenter:"mouseover",mouseleave:"mouseout"},function(a,b){f.event.special[a]={delegateType:b,bindType:b,handle:function(a){var c=this,d=a.relatedTarget,e=a.handleObj,g=e.selector,h;if(!d||d!==c&&!f.contains(c,d))a.type=e.origType,h=e.handler.apply(this,arguments),a.type=b;return h}}}),f.support.submitBubbles||(f.event.special.submit={setup:function(){if(f.nodeName(this,"form"))return!1;f.event.add(this,"click._submit keypress._submit",function(a){var c=a.target,d=f.nodeName(c,"input")||f.nodeName(c,"button")?c.form:b;d&&!d._submit_attached&&(f.event.add(d,"submit._submit",function(a){this.parentNode&&!a.isTrigger&&f.event.simulate("submit",this.parentNode,a,!0)}),d._submit_attached=!0)})},teardown:function(){if(f.nodeName(this,"form"))return!1;f.event.remove(this,"._submit")}}),f.support.changeBubbles||(f.event.special.change={setup:function(){if(z.test(this.nodeName)){if(this.type==="checkbox"||this.type==="radio")f.event.add(this,"propertychange._change",function(a){a.originalEvent.propertyName==="checked"&&(this._just_changed=!0)}),f.event.add(this,"click._change",function(a){this._just_changed&&!a.isTrigger&&(this._just_changed=!1,f.event.simulate("change",this,a,!0))});return!1}f.event.add(this,"beforeactivate._change",function(a){var b=a.target;z.test(b.nodeName)&&!b._change_attached&&(f.event.add(b,"change._change",function(a){this.parentNode&&!a.isSimulated&&!a.isTrigger&&f.event.simulate("change",this.parentNode,a,!0)}),b._change_attached=!0)})},handle:function(a){var b=a.target;if(this!==b||a.isSimulated||a.isTrigger||b.type!=="radio"&&b.type!=="checkbox")return a.handleObj.handler.apply(this,arguments)},teardown:function(){f.event.remove(this,"._change");return z.test(this.nodeName)}}),f.support.focusinBubbles||f.each({focus:"focusin",blur:"focusout"},function(a,b){var d=0,e=function(a){f.event.simulate(b,a.target,f.event.fix(a),!0)};f.event.special[b]={setup:function(){d++===0&&c.addEventListener(a,e,!0)},teardown:function(){--d===0&&c.removeEventListener(a,e,!0)}}}),f.fn.extend({on:function(a,c,d,e,g){var h,i;if(typeof a=="object"){typeof c!="string"&&(d=c,c=b);for(i in a)this.on(i,c,d,a[i],g);return this}d==null&&e==null?(e=c,d=c=b):e==null&&(typeof c=="string"?(e=d,d=b):(e=d,d=c,c=b));if(e===!1)e=J;else if(!e)return this;g===1&&(h=e,e=function(a){f().off(a);return h.apply(this,arguments)},e.guid=h.guid||(h.guid=f.guid++));return this.each(function(){f.event.add(this,a,e,d,c)})},one:function(a,b,c,d){return this.on.call(this,a,b,c,d,1)},off:function(a,c,d){if(a&&a.preventDefault&&a.handleObj){var e=a.handleObj;f(a.delegateTarget).off(e.namespace?e.type+"."+e.namespace:e.type,e.selector,e.handler);return this}if(typeof a=="object"){for(var g in a)this.off(g,c,a[g]);return this}if(c===!1||typeof c=="function")d=c,c=b;d===!1&&(d=J);return this.each(function(){f.event.remove(this,a,d,c)})},bind:function(a,b,c){return this.on(a,null,b,c)},unbind:function(a,b){return this.off(a,null,b)},live:function(a,b,c){f(this.context).on(a,this.selector,b,c);return this},die:function(a,b){f(this.context).off(a,this.selector||"**",b);return this},delegate:function(a,b,c,d){return this.on(b,a,c,d)},undelegate:function(a,b,c){return arguments.length==1?this.off(a,"**"):this.off(b,a,c)},trigger:function(a,b){return this.each(function(){f.event.trigger(a,b,this)})},triggerHandler:function(a,b){if(this[0])return f.event.trigger(a,b,this[0],!0)},toggle:function(a){var b=arguments,c=a.guid||f.guid++,d=0,e=function(c){var e=(f._data(this,"lastToggle"+a.guid)||0)%d;f._data(this,"lastToggle"+a.guid,e+1),c.preventDefault();return b[e].apply(this,arguments)||!1};e.guid=c;while(d<b.length)b[d++].guid=c;return this.click(e)},hover:function(a,b){return this.mouseenter(a).mouseleave(b||a)}}),f.each("blur focus focusin focusout load resize scroll unload click dblclick mousedown mouseup mousemove mouseover mouseout mouseenter mouseleave change select submit keydown keypress keyup error contextmenu".split(" "),function(a,b){f.fn[b]=function(a,c){c==null&&(c=a,a=null);return arguments.length>0?this.on(b,null,a,c):this.trigger(b)},f.attrFn&&(f.attrFn[b]=!0),C.test(b)&&(f.event.fixHooks[b]=f.event.keyHooks),D.test(b)&&(f.event.fixHooks[b]=f.event.mouseHooks)}),function(){function x(a,b,c,e,f,g){for(var h=0,i=e.length;h<i;h++){var j=e[h];if(j){var k=!1;j=j[a];while(j){if(j[d]===c){k=e[j.sizset];break}if(j.nodeType===1){g||(j[d]=c,j.sizset=h);if(typeof b!="string"){if(j===b){k=!0;break}}else if(m.filter(b,[j]).length>0){k=j;break}}j=j[a]}e[h]=k}}}function w(a,b,c,e,f,g){for(var h=0,i=e.length;h<i;h++){var j=e[h];if(j){var k=!1;j=j[a];while(j){if(j[d]===c){k=e[j.sizset];break}j.nodeType===1&&!g&&(j[d]=c,j.sizset=h);if(j.nodeName.toLowerCase()===b){k=j;break}j=j[a]}e[h]=k}}}var a=/((?:\((?:\([^()]+\)|[^()]+)+\)|\[(?:\[[^\[\]]*\]|['"][^'"]*['"]|[^\[\]'"]+)+\]|\\.|[^ >+~,(\[\\]+)+|[>+~])(\s*,\s*)?((?:.|\r|\n)*)/g,d="sizcache"+(Math.random()+"").replace(".",""),e=0,g=Object.prototype.toString,h=!1,i=!0,j=/\\/g,k=/\r\n/g,l=/\W/;[0,0].sort(function(){i=!1;return 0});var m=function(b,d,e,f){e=e||[],d=d||c;var h=d;if(d.nodeType!==1&&d.nodeType!==9)return[];if(!b||typeof b!="string")return e;var i,j,k,l,n,q,r,t,u=!0,v=m.isXML(d),w=[],x=b;do{a.exec(""),i=a.exec(x);if(i){x=i[3],w.push(i[1]);if(i[2]){l=i[3];break}}}while(i);if(w.length>1&&p.exec(b))if(w.length===2&&o.relative[w[0]])j=y(w[0]+w[1],d,f);else{j=o.relative[w[0]]?[d]:m(w.shift(),d);while(w.length)b=w.shift(),o.relative[b]&&(b+=w.shift()),j=y(b,j,f)}else{!f&&w.length>1&&d.nodeType===9&&!v&&o.match.ID.test(w[0])&&!o.match.ID.test(w[w.length-1])&&(n=m.find(w.shift(),d,v),d=n.expr?m.filter(n.expr,n.set)[0]:n.set[0]);if(d){n=f?{expr:w.pop(),set:s(f)}:m.find(w.pop(),w.length===1&&(w[0]==="~"||w[0]==="+")&&d.parentNode?d.parentNode:d,v),j=n.expr?m.filter(n.expr,n.set):n.set,w.length>0?k=s(j):u=!1;while(w.length)q=w.pop(),r=q,o.relative[q]?r=w.pop():q="",r==null&&(r=d),o.relative[q](k,r,v)}else k=w=[]}k||(k=j),k||m.error(q||b);if(g.call(k)==="[object Array]")if(!u)e.push.apply(e,k);else if(d&&d.nodeType===1)for(t=0;k[t]!=null;t++)k[t]&&(k[t]===!0||k[t].nodeType===1&&m.contains(d,k[t]))&&e.push(j[t]);else for(t=0;k[t]!=null;t++)k[t]&&k[t].nodeType===1&&e.push(j[t]);else s(k,e);l&&(m(l,h,e,f),m.uniqueSort(e));return e};m.uniqueSort=function(a){if(u){h=i,a.sort(u);if(h)for(var b=1;b<a.length;b++)a[b]===a[b-1]&&a.splice(b--,1)}return a},m.matches=function(a,b){return m(a,null,null,b)},m.matchesSelector=function(a,b){return m(b,null,null,[a]).length>0},m.find=function(a,b,c){var d,e,f,g,h,i;if(!a)return[];for(e=0,f=o.order.length;e<f;e++){h=o.order[e];if(g=o.leftMatch[h].exec(a)){i=g[1],g.splice(1,1);if(i.substr(i.length-1)!=="\\"){g[1]=(g[1]||"").replace(j,""),d=o.find[h](g,b,c);if(d!=null){a=a.replace(o.match[h],"");break}}}}d||(d=typeof b.getElementsByTagName!="undefined"?b.getElementsByTagName("*"):[]);return{set:d,expr:a}},m.filter=function(a,c,d,e){var f,g,h,i,j,k,l,n,p,q=a,r=[],s=c,t=c&&c[0]&&m.isXML(c[0]);while(a&&c.length){for(h in o.filter)if((f=o.leftMatch[h].exec(a))!=null&&f[2]){k=o.filter[h],l=f[1],g=!1,f.splice(1,1);if(l.substr(l.length-1)==="\\")continue;s===r&&(r=[]);if(o.preFilter[h]){f=o.preFilter[h](f,s,d,r,e,t);if(!f)g=i=!0;else if(f===!0)continue}if(f)for(n=0;(j=s[n])!=null;n++)j&&(i=k(j,f,n,s),p=e^i,d&&i!=null?p?g=!0:s[n]=!1:p&&(r.push(j),g=!0));if(i!==b){d||(s=r),a=a.replace(o.match[h],"");if(!g)return[];break}}if(a===q)if(g==null)m.error(a);else break;q=a}return s},m.error=function(a){throw new Error("Syntax error, unrecognized expression: "+a)};var n=m.getText=function(a){var b,c,d=a.nodeType,e="";if(d){if(d===1||d===9){if(typeof a.textContent=="string")return a.textContent;if(typeof a.innerText=="string")return a.innerText.replace(k,"");for(a=a.firstChild;a;a=a.nextSibling)e+=n(a)}else if(d===3||d===4)return a.nodeValue}else for(b=0;c=a[b];b++)c.nodeType!==8&&(e+=n(c));return e},o=m.selectors={order:["ID","NAME","TAG"],match:{ID:/#((?:[\w\u00c0-\uFFFF\-]|\\.)+)/,CLASS:/\.((?:[\w\u00c0-\uFFFF\-]|\\.)+)/,NAME:/\[name=['"]*((?:[\w\u00c0-\uFFFF\-]|\\.)+)['"]*\]/,ATTR:/\[\s*((?:[\w\u00c0-\uFFFF\-]|\\.)+)\s*(?:(\S?=)\s*(?:(['"])(.*?)\3|(#?(?:[\w\u00c0-\uFFFF\-]|\\.)*)|)|)\s*\]/,TAG:/^((?:[\w\u00c0-\uFFFF\*\-]|\\.)+)/,CHILD:/:(only|nth|last|first)-child(?:\(\s*(even|odd|(?:[+\-]?\d+|(?:[+\-]?\d*)?n\s*(?:[+\-]\s*\d+)?))\s*\))?/,POS:/:(nth|eq|gt|lt|first|last|even|odd)(?:\((\d*)\))?(?=[^\-]|$)/,PSEUDO:/:((?:[\w\u00c0-\uFFFF\-]|\\.)+)(?:\((['"]?)((?:\([^\)]+\)|[^\(\)]*)+)\2\))?/},leftMatch:{},attrMap:{"class":"className","for":"htmlFor"},attrHandle:{href:function(a){return a.getAttribute("href")},type:function(a){return a.getAttribute("type")}},relative:{"+":function(a,b){var c=typeof b=="string",d=c&&!l.test(b),e=c&&!d;d&&(b=b.toLowerCase());for(var f=0,g=a.length,h;f<g;f++)if(h=a[f]){while((h=h.previousSibling)&&h.nodeType!==1);a[f]=e||h&&h.nodeName.toLowerCase()===b?h||!1:h===b}e&&m.filter(b,a,!0)},">":function(a,b){var c,d=typeof b=="string",e=0,f=a.length;if(d&&!l.test(b)){b=b.toLowerCase();for(;e<f;e++){c=a[e];if(c){var g=c.parentNode;a[e]=g.nodeName.toLowerCase()===b?g:!1}}}else{for(;e<f;e++)c=a[e],c&&(a[e]=d?c.parentNode:c.parentNode===b);d&&m.filter(b,a,!0)}},"":function(a,b,c){var d,f=e++,g=x;typeof b=="string"&&!l.test(b)&&(b=b.toLowerCase(),d=b,g=w),g("parentNode",b,f,a,d,c)},"~":function(a,b,c){var d,f=e++,g=x;typeof b=="string"&&!l.test(b)&&(b=b.toLowerCase(),d=b,g=w),g("previousSibling",b,f,a,d,c)}},find:{ID:function(a,b,c){if(typeof b.getElementById!="undefined"&&!c){var d=b.getElementById(a[1]);return d&&d.parentNode?[d]:[]}},NAME:function(a,b){if(typeof b.getElementsByName!="undefined"){var c=[],d=b.getElementsByName(a[1]);for(var e=0,f=d.length;e<f;e++)d[e].getAttribute("name")===a[1]&&c.push(d[e]);return c.length===0?null:c}},TAG:function(a,b){if(typeof b.getElementsByTagName!="undefined")return b.getElementsByTagName(a[1])}},preFilter:{CLASS:function(a,b,c,d,e,f){a=" "+a[1].replace(j,"")+" ";if(f)return a;for(var g=0,h;(h=b[g])!=null;g++)h&&(e^(h.className&&(" "+h.className+" ").replace(/[\t\n\r]/g," ").indexOf(a)>=0)?c||d.push(h):c&&(b[g]=!1));return!1},ID:function(a){return a[1].replace(j,"")},TAG:function(a,b){return a[1].replace(j,"").toLowerCase()},CHILD:function(a){if(a[1]==="nth"){a[2]||m.error(a[0]),a[2]=a[2].replace(/^\+|\s*/g,"");var b=/(-?)(\d*)(?:n([+\-]?\d*))?/.exec(a[2]==="even"&&"2n"||a[2]==="odd"&&"2n+1"||!/\D/.test(a[2])&&"0n+"+a[2]||a[2]);a[2]=b[1]+(b[2]||1)-0,a[3]=b[3]-0}else a[2]&&m.error(a[0]);a[0]=e++;return a},ATTR:function(a,b,c,d,e,f){var g=a[1]=a[1].replace(j,"");!f&&o.attrMap[g]&&(a[1]=o.attrMap[g]),a[4]=(a[4]||a[5]||"").replace(j,""),a[2]==="~="&&(a[4]=" "+a[4]+" ");return a},PSEUDO:function(b,c,d,e,f){if(b[1]==="not")if((a.exec(b[3])||"").length>1||/^\w/.test(b[3]))b[3]=m(b[3],null,null,c);else{var g=m.filter(b[3],c,d,!0^f);d||e.push.apply(e,g);return!1}else if(o.match.POS.test(b[0])||o.match.CHILD.test(b[0]))return!0;return b},POS:function(a){a.unshift(!0);return a}},filters:{enabled:function(a){return a.disabled===!1&&a.type!=="hidden"},disabled:function(a){return a.disabled===!0},checked:function(a){return a.checked===!0},selected:function(a){a.parentNode&&a.parentNode.selectedIndex;return a.selected===!0},parent:function(a){return!!a.firstChild},empty:function(a){return!a.firstChild},has:function(a,b,c){return!!m(c[3],a).length},header:function(a){return/h\d/i.test(a.nodeName)},text:function(a){var b=a.getAttribute("type"),c=a.type;return a.nodeName.toLowerCase()==="input"&&"text"===c&&(b===c||b===null)},radio:function(a){return a.nodeName.toLowerCase()==="input"&&"radio"===a.type},checkbox:function(a){return a.nodeName.toLowerCase()==="input"&&"checkbox"===a.type},file:function(a){return a.nodeName.toLowerCase()==="input"&&"file"===a.type},password:function(a){return a.nodeName.toLowerCase()==="input"&&"password"===a.type},submit:function(a){var b=a.nodeName.toLowerCase();return(b==="input"||b==="button")&&"submit"===a.type},image:function(a){return a.nodeName.toLowerCase()==="input"&&"image"===a.type},reset:function(a){var b=a.nodeName.toLowerCase();return(b==="input"||b==="button")&&"reset"===a.type},button:function(a){var b=a.nodeName.toLowerCase();return b==="input"&&"button"===a.type||b==="button"},input:function(a){return/input|select|textarea|button/i.test(a.nodeName)},focus:function(a){return a===a.ownerDocument.activeElement}},setFilters:{first:function(a,b){return b===0},last:function(a,b,c,d){return b===d.length-1},even:function(a,b){return b%2===0},odd:function(a,b){return b%2===1},lt:function(a,b,c){return b<c[3]-0},gt:function(a,b,c){return b>c[3]-0},nth:function(a,b,c){return c[3]-0===b},eq:function(a,b,c){return c[3]-0===b}},filter:{PSEUDO:function(a,b,c,d){var e=b[1],f=o.filters[e];if(f)return f(a,c,b,d);if(e==="contains")return(a.textContent||a.innerText||n([a])||"").indexOf(b[3])>=0;if(e==="not"){var g=b[3];for(var h=0,i=g.length;h<i;h++)if(g[h]===a)return!1;return!0}m.error(e)},CHILD:function(a,b){var c,e,f,g,h,i,j,k=b[1],l=a;switch(k){case"only":case"first":while(l=l.previousSibling)if(l.nodeType===1)return!1;if(k==="first")return!0;l=a;case"last":while(l=l.nextSibling)if(l.nodeType===1)return!1;return!0;case"nth":c=b[2],e=b[3];if(c===1&&e===0)return!0;f=b[0],g=a.parentNode;if(g&&(g[d]!==f||!a.nodeIndex)){i=0;for(l=g.firstChild;l;l=l.nextSibling)l.nodeType===1&&(l.nodeIndex=++i);g[d]=f}j=a.nodeIndex-e;return c===0?j===0:j%c===0&&j/c>=0}},ID:function(a,b){return a.nodeType===1&&a.getAttribute("id")===b},TAG:function(a,b){return b==="*"&&a.nodeType===1||!!a.nodeName&&a.nodeName.toLowerCase()===b},CLASS:function(a,b){return(" "+(a.className||a.getAttribute("class"))+" ").indexOf(b)>-1},ATTR:function(a,b){var c=b[1],d=m.attr?m.attr(a,c):o.attrHandle[c]?o.attrHandle[c](a):a[c]!=null?a[c]:a.getAttribute(c),e=d+"",f=b[2],g=b[4];return d==null?f==="!=":!f&&m.attr?d!=null:f==="="?e===g:f==="*="?e.indexOf(g)>=0:f==="~="?(" "+e+" ").indexOf(g)>=0:g?f==="!="?e!==g:f==="^="?e.indexOf(g)===0:f==="$="?e.substr(e.length-g.length)===g:f==="|="?e===g||e.substr(0,g.length+1)===g+"-":!1:e&&d!==!1},POS:function(a,b,c,d){var e=b[2],f=o.setFilters[e];if(f)return f(a,c,b,d)}}},p=o.match.POS,q=function(a,b){return"\\"+(b-0+1)};for(var r in o.match)o.match[r]=new RegExp(o.match[r].source+/(?![^\[]*\])(?![^\(]*\))/.source),o.leftMatch[r]=new RegExp(/(^(?:.|\r|\n)*?)/.source+o.match[r].source.replace(/\\(\d+)/g,q));var s=function(a,b){a=Array.prototype.slice.call(a,0);if(b){b.push.apply(b,a);return b}return a};try{Array.prototype.slice.call(c.documentElement.childNodes,0)[0].nodeType}catch(t){s=function(a,b){var c=0,d=b||[];if(g.call(a)==="[object Array]")Array.prototype.push.apply(d,a);else if(typeof a.length=="number")for(var e=a.length;c<e;c++)d.push(a[c]);else for(;a[c];c++)d.push(a[c]);return d}}var u,v;c.documentElement.compareDocumentPosition?u=function(a,b){if(a===b){h=!0;return 0}if(!a.compareDocumentPosition||!b.compareDocumentPosition)return a.compareDocumentPosition?-1:1;return a.compareDocumentPosition(b)&4?-1:1}:(u=function(a,b){if(a===b){h=!0;return 0}if(a.sourceIndex&&b.sourceIndex)return a.sourceIndex-b.sourceIndex;var c,d,e=[],f=[],g=a.parentNode,i=b.parentNode,j=g;if(g===i)return v(a,b);if(!g)return-1;if(!i)return 1;while(j)e.unshift(j),j=j.parentNode;j=i;while(j)f.unshift(j),j=j.parentNode;c=e.length,d=f.length;for(var k=0;k<c&&k<d;k++)if(e[k]!==f[k])return v(e[k],f[k]);return k===c?v(a,f[k],-1):v(e[k],b,1)},v=function(a,b,c){if(a===b)return c;var d=a.nextSibling;while(d){if(d===b)return-1;d=d.nextSibling}return 1}),function(){var a=c.createElement("div"),d="script"+(new Date).getTime(),e=c.documentElement;a.innerHTML="<a name='"+d+"'/>",e.insertBefore(a,e.firstChild),c.getElementById(d)&&(o.find.ID=function(a,c,d){if(typeof c.getElementById!="undefined"&&!d){var e=c.getElementById(a[1]);return e?e.id===a[1]||typeof e.getAttributeNode!="undefined"&&e.getAttributeNode("id").nodeValue===a[1]?[e]:b:[]}},o.filter.ID=function(a,b){var c=typeof a.getAttributeNode!="undefined"&&a.getAttributeNode("id");return a.nodeType===1&&c&&c.nodeValue===b}),e.removeChild(a),e=a=null}(),function(){var a=c.createElement("div");a.appendChild(c.createComment("")),a.getElementsByTagName("*").length>0&&(o.find.TAG=function(a,b){var c=b.getElementsByTagName(a[1]);if(a[1]==="*"){var d=[];for(var e=0;c[e];e++)c[e].nodeType===1&&d.push(c[e]);c=d}return c}),a.innerHTML="<a href='#'></a>",a.firstChild&&typeof a.firstChild.getAttribute!="undefined"&&a.firstChild.getAttribute("href")!=="#"&&(o.attrHandle.href=function(a){return a.getAttribute("href",2)}),a=null}(),c.querySelectorAll&&function(){var a=m,b=c.createElement("div"),d="__sizzle__";b.innerHTML="<p class='TEST'></p>";if(!b.querySelectorAll||b.querySelectorAll(".TEST").length!==0){m=function(b,e,f,g){e=e||c;if(!g&&!m.isXML(e)){var h=/^(\w+$)|^\.([\w\-]+$)|^#([\w\-]+$)/.exec(b);if(h&&(e.nodeType===1||e.nodeType===9)){if(h[1])return s(e.getElementsByTagName(b),f);if(h[2]&&o.find.CLASS&&e.getElementsByClassName)return s(e.getElementsByClassName(h[2]),f)}if(e.nodeType===9){if(b==="body"&&e.body)return s([e.body],f);if(h&&h[3]){var i=e.getElementById(h[3]);if(!i||!i.parentNode)return s([],f);if(i.id===h[3])return s([i],f)}try{return s(e.querySelectorAll(b),f)}catch(j){}}else if(e.nodeType===1&&e.nodeName.toLowerCase()!=="object"){var k=e,l=e.getAttribute("id"),n=l||d,p=e.parentNode,q=/^\s*[+~]/.test(b);l?n=n.replace(/'/g,"\\$&"):e.setAttribute("id",n),q&&p&&(e=e.parentNode);try{if(!q||p)return s(e.querySelectorAll("[id='"+n+"'] "+b),f)}catch(r){}finally{l||k.removeAttribute("id")}}}return a(b,e,f,g)};for(var e in a)m[e]=a[e];b=null}}(),function(){var a=c.documentElement,b=a.matchesSelector||a.mozMatchesSelector||a.webkitMatchesSelector||a.msMatchesSelector;if(b){var d=!b.call(c.createElement("div"),"div"),e=!1;try{b.call(c.documentElement,"[test!='']:sizzle")}catch(f){e=!0}m.matchesSelector=function(a,c){c=c.replace(/\=\s*([^'"\]]*)\s*\]/g,"='$1']");if(!m.isXML(a))try{if(e||!o.match.PSEUDO.test(c)&&!/!=/.test(c)){var f=b.call(a,c);if(f||!d||a.document&&a.document.nodeType!==11)return f}}catch(g){}return m(c,null,null,[a]).length>0}}}(),function(){var a=c.createElement("div");a.innerHTML="<div class='test e'></div><div class='test'></div>";if(!!a.getElementsByClassName&&a.getElementsByClassName("e").length!==0){a.lastChild.className="e";if(a.getElementsByClassName("e").length===1)return;o.order.splice(1,0,"CLASS"),o.find.CLASS=function(a,b,c){if(typeof b.getElementsByClassName!="undefined"&&!c)return b.getElementsByClassName(a[1])},a=null}}(),c.documentElement.contains?m.contains=function(a,b){return a!==b&&(a.contains?a.contains(b):!0)}:c.documentElement.compareDocumentPosition?m.contains=function(a,b){return!!(a.compareDocumentPosition(b)&16)}:m.contains=function(){return!1},m.isXML=function(a){var b=(a?a.ownerDocument||a:0).documentElement;return b?b.nodeName!=="HTML":!1};var y=function(a,b,c){var d,e=[],f="",g=b.nodeType?[b]:b;while(d=o.match.PSEUDO.exec(a))f+=d[0],a=a.replace(o.match.PSEUDO,"");a=o.relative[a]?a+"*":a;for(var h=0,i=g.length;h<i;h++)m(a,g[h],e,c);return m.filter(f,e)};m.attr=f.attr,m.selectors.attrMap={},f.find=m,f.expr=m.selectors,f.expr[":"]=f.expr.filters,f.unique=m.uniqueSort,f.text=m.getText,f.isXMLDoc=m.isXML,f.contains=m.contains}();var L=/Until$/,M=/^(?:parents|prevUntil|prevAll)/,N=/,/,O=/^.[^:#\[\.,]*$/,P=Array.prototype.slice,Q=f.expr.match.POS,R={children:!0,contents:!0,next:!0,prev:!0};f.fn.extend({find:function(a){var b=this,c,d;if(typeof a!="string")return f(a).filter(function(){for(c=0,d=b.length;c<d;c++)if(f.contains(b[c],this))return!0});var e=this.pushStack("","find",a),g,h,i;for(c=0,d=this.length;c<d;c++){g=e.length,f.find(a,this[c],e);if(c>0)for(h=g;h<e.length;h++)for(i=0;i<g;i++)if(e[i]===e[h]){e.splice(h--,1);break}}return e},has:function(a){var b=f(a);return this.filter(function(){for(var a=0,c=b.length;a<c;a++)if(f.contains(this,b[a]))return!0})},not:function(a){return this.pushStack(T(this,a,!1),"not",a)},filter:function(a){return this.pushStack(T(this,a,!0),"filter",a)},is:function(a){return!!a&&(typeof a=="string"?Q.test(a)?f(a,this.context).index(this[0])>=0:f.filter(a,this).length>0:this.filter(a).length>0)},closest:function(a,b){var c=[],d,e,g=this[0];if(f.isArray(a)){var h=1;while(g&&g.ownerDocument&&g!==b){for(d=0;d<a.length;d++)f(g).is(a[d])&&c.push({selector:a[d],elem:g,level:h});g=g.parentNode,h++}return c}var i=Q.test(a)||typeof a!="string"?f(a,b||this.context):0;for(d=0,e=this.length;d<e;d++){g=this[d];while(g){if(i?i.index(g)>-1:f.find.matchesSelector(g,a)){c.push(g);break}g=g.parentNode;if(!g||!g.ownerDocument||g===b||g.nodeType===11)break}}c=c.length>1?f.unique(c):c;return this.pushStack(c,"closest",a)},index:function(a){if(!a)return this[0]&&this[0].parentNode?this.prevAll().length:-1;if(typeof a=="string")return f.inArray(this[0],f(a));return f.inArray(a.jquery?a[0]:a,this)},add:function(a,b){var c=typeof a=="string"?f(a,b):f.makeArray(a&&a.nodeType?[a]:a),d=f.merge(this.get(),c);return this.pushStack(S(c[0])||S(d[0])?d:f.unique(d))},andSelf:function(){return this.add(this.prevObject)}}),f.each({parent:function(a){var b=a.parentNode;return b&&b.nodeType!==11?b:null},parents:function(a){return f.dir(a,"parentNode")},parentsUntil:function(a,b,c){return f.dir(a,"parentNode",c)},next:function(a){return f.nth(a,2,"nextSibling")},prev:function(a){return f.nth(a,2,"previousSibling")},nextAll:function(a){return f.dir(a,"nextSibling")},prevAll:function(a){return f.dir(a,"previousSibling")},nextUntil:function(a,b,c){return f.dir(a,"nextSibling",c)},prevUntil:function(a,b,c){return f.dir(a,"previousSibling",c)},siblings:function(a){return f.sibling(a.parentNode.firstChild,a)},children:function(a){return f.sibling(a.firstChild)},contents:function(a){return f.nodeName(a,"iframe")?a.contentDocument||a.contentWindow.document:f.makeArray(a.childNodes)}},function(a,b){f.fn[a]=function(c,d){var e=f.map(this,b,c);L.test(a)||(d=c),d&&typeof d=="string"&&(e=f.filter(d,e)),e=this.length>1&&!R[a]?f.unique(e):e,(this.length>1||N.test(d))&&M.test(a)&&(e=e.reverse());return this.pushStack(e,a,P.call(arguments).join(","))}}),f.extend({filter:function(a,b,c){c&&(a=":not("+a+")");return b.length===1?f.find.matchesSelector(b[0],a)?[b[0]]:[]:f.find.matches(a,b)},dir:function(a,c,d){var e=[],g=a[c];while(g&&g.nodeType!==9&&(d===b||g.nodeType!==1||!f(g).is(d)))g.nodeType===1&&e.push(g),g=g[c];return e},nth:function(a,b,c,d){b=b||1;var e=0;for(;a;a=a[c])if(a.nodeType===1&&++e===b)break;return a},sibling:function(a,b){var c=[];for(;a;a=a.nextSibling)a.nodeType===1&&a!==b&&c.push(a);return c}});var V="abbr|article|aside|audio|canvas|datalist|details|figcaption|figure|footer|header|hgroup|mark|meter|nav|output|progress|section|summary|time|video",W=/ jQuery\d+="(?:\d+|null)"/g,X=/^\s+/,Y=/<(?!area|br|col|embed|hr|img|input|link|meta|param)(([\w:]+)[^>]*)\/>/ig,Z=/<([\w:]+)/,$=/<tbody/i,_=/<|&#?\w+;/,ba=/<(?:script|style)/i,bb=/<(?:script|object|embed|option|style)/i,bc=new RegExp("<(?:"+V+")","i"),bd=/checked\s*(?:[^=]|=\s*.checked.)/i,be=/\/(java|ecma)script/i,bf=/^\s*<!(?:\[CDATA\[|\-\-)/,bg={option:[1,"<select multiple='multiple'>","</select>"],legend:[1,"<fieldset>","</fieldset>"],thead:[1,"<table>","</table>"],tr:[2,"<table><tbody>","</tbody></table>"],td:[3,"<table><tbody><tr>","</tr></tbody></table>"],col:[2,"<table><tbody></tbody><colgroup>","</colgroup></table>"],area:[1,"<map>","</map>"],_default:[0,"",""]},bh=U(c);bg.optgroup=bg.option,bg.tbody=bg.tfoot=bg.colgroup=bg.caption=bg.thead,bg.th=bg.td,f.support.htmlSerialize||(bg._default=[1,"div<div>","</div>"]),f.fn.extend({text:function(a){if(f.isFunction(a))return this.each(function(b){var c=f(this);c.text(a.call(this,b,c.text()))});if(typeof a!="object"&&a!==b)return this.empty().append((this[0]&&this[0].ownerDocument||c).createTextNode(a));return f.text(this)},wrapAll:function(a){if(f.isFunction(a))return this.each(function(b){f(this).wrapAll(a.call(this,b))});if(this[0]){var b=f(a,this[0].ownerDocument).eq(0).clone(!0);this[0].parentNode&&b.insertBefore(this[0]),b.map(function(){var a=this;while(a.firstChild&&a.firstChild.nodeType===1)a=a.firstChild;return a}).append(this)}return this},wrapInner:function(a){if(f.isFunction(a))return this.each(function(b){f(this).wrapInner(a.call(this,b))});return this.each(function(){var b=f(this),c=b.contents();c.length?c.wrapAll(a):b.append(a)})},wrap:function(a){var b=f.isFunction(a);return this.each(function(c){f(this).wrapAll(b?a.call(this,c):a)})},unwrap:function(){return this.parent().each(function(){f.nodeName(this,"body")||f(this).replaceWith(this.childNodes)}).end()},append:function(){return this.domManip(arguments,!0,function(a){this.nodeType===1&&this.appendChild(a)})},prepend:function(){return this.domManip(arguments,!0,function(a){this.nodeType===1&&this.insertBefore(a,this.firstChild)})},before:function(){if(this[0]&&this[0].parentNode)return this.domManip(arguments,!1,function(a){this.parentNode.insertBefore(a,this)});if(arguments.length){var a=f.clean(arguments);a.push.apply(a,this.toArray());return this.pushStack(a,"before",arguments)}},after:function(){if(this[0]&&this[0].parentNode)return this.domManip(arguments,!1,function(a){this.parentNode.insertBefore(a,this.nextSibling)});if(arguments.length){var a=this.pushStack(this,"after",arguments);a.push.apply(a,f.clean(arguments));return a}},remove:function(a,b){for(var c=0,d;(d=this[c])!=null;c++)if(!a||f.filter(a,[d]).length)!b&&d.nodeType===1&&(f.cleanData(d.getElementsByTagName("*")),f.cleanData([d])),d.parentNode&&d.parentNode.removeChild(d);return this},empty:function()
    {for(var a=0,b;(b=this[a])!=null;a++){b.nodeType===1&&f.cleanData(b.getElementsByTagName("*"));while(b.firstChild)b.removeChild(b.firstChild)}return this},clone:function(a,b){a=a==null?!1:a,b=b==null?a:b;return this.map(function(){return f.clone(this,a,b)})},html:function(a){if(a===b)return this[0]&&this[0].nodeType===1?this[0].innerHTML.replace(W,""):null;if(typeof a=="string"&&!ba.test(a)&&(f.support.leadingWhitespace||!X.test(a))&&!bg[(Z.exec(a)||["",""])[1].toLowerCase()]){a=a.replace(Y,"<$1></$2>");try{for(var c=0,d=this.length;c<d;c++)this[c].nodeType===1&&(f.cleanData(this[c].getElementsByTagName("*")),this[c].innerHTML=a)}catch(e){this.empty().append(a)}}else f.isFunction(a)?this.each(function(b){var c=f(this);c.html(a.call(this,b,c.html()))}):this.empty().append(a);return this},replaceWith:function(a){if(this[0]&&this[0].parentNode){if(f.isFunction(a))return this.each(function(b){var c=f(this),d=c.html();c.replaceWith(a.call(this,b,d))});typeof a!="string"&&(a=f(a).detach());return this.each(function(){var b=this.nextSibling,c=this.parentNode;f(this).remove(),b?f(b).before(a):f(c).append(a)})}return this.length?this.pushStack(f(f.isFunction(a)?a():a),"replaceWith",a):this},detach:function(a){return this.remove(a,!0)},domManip:function(a,c,d){var e,g,h,i,j=a[0],k=[];if(!f.support.checkClone&&arguments.length===3&&typeof j=="string"&&bd.test(j))return this.each(function(){f(this).domManip(a,c,d,!0)});if(f.isFunction(j))return this.each(function(e){var g=f(this);a[0]=j.call(this,e,c?g.html():b),g.domManip(a,c,d)});if(this[0]){i=j&&j.parentNode,f.support.parentNode&&i&&i.nodeType===11&&i.childNodes.length===this.length?e={fragment:i}:e=f.buildFragment(a,this,k),h=e.fragment,h.childNodes.length===1?g=h=h.firstChild:g=h.firstChild;if(g){c=c&&f.nodeName(g,"tr");for(var l=0,m=this.length,n=m-1;l<m;l++)d.call(c?bi(this[l],g):this[l],e.cacheable||m>1&&l<n?f.clone(h,!0,!0):h)}k.length&&f.each(k,bp)}return this}}),f.buildFragment=function(a,b,d){var e,g,h,i,j=a[0];b&&b[0]&&(i=b[0].ownerDocument||b[0]),i.createDocumentFragment||(i=c),a.length===1&&typeof j=="string"&&j.length<512&&i===c&&j.charAt(0)==="<"&&!bb.test(j)&&(f.support.checkClone||!bd.test(j))&&(f.support.html5Clone||!bc.test(j))&&(g=!0,h=f.fragments[j],h&&h!==1&&(e=h)),e||(e=i.createDocumentFragment(),f.clean(a,i,e,d)),g&&(f.fragments[j]=h?e:1);return{fragment:e,cacheable:g}},f.fragments={},f.each({appendTo:"append",prependTo:"prepend",insertBefore:"before",insertAfter:"after",replaceAll:"replaceWith"},function(a,b){f.fn[a]=function(c){var d=[],e=f(c),g=this.length===1&&this[0].parentNode;if(g&&g.nodeType===11&&g.childNodes.length===1&&e.length===1){e[b](this[0]);return this}for(var h=0,i=e.length;h<i;h++){var j=(h>0?this.clone(!0):this).get();f(e[h])[b](j),d=d.concat(j)}return this.pushStack(d,a,e.selector)}}),f.extend({clone:function(a,b,c){var d,e,g,h=f.support.html5Clone||!bc.test("<"+a.nodeName)?a.cloneNode(!0):bo(a);if((!f.support.noCloneEvent||!f.support.noCloneChecked)&&(a.nodeType===1||a.nodeType===11)&&!f.isXMLDoc(a)){bk(a,h),d=bl(a),e=bl(h);for(g=0;d[g];++g)e[g]&&bk(d[g],e[g])}if(b){bj(a,h);if(c){d=bl(a),e=bl(h);for(g=0;d[g];++g)bj(d[g],e[g])}}d=e=null;return h},clean:function(a,b,d,e){var g;b=b||c,typeof b.createElement=="undefined"&&(b=b.ownerDocument||b[0]&&b[0].ownerDocument||c);var h=[],i;for(var j=0,k;(k=a[j])!=null;j++){typeof k=="number"&&(k+="");if(!k)continue;if(typeof k=="string")if(!_.test(k))k=b.createTextNode(k);else{k=k.replace(Y,"<$1></$2>");var l=(Z.exec(k)||["",""])[1].toLowerCase(),m=bg[l]||bg._default,n=m[0],o=b.createElement("div");b===c?bh.appendChild(o):U(b).appendChild(o),o.innerHTML=m[1]+k+m[2];while(n--)o=o.lastChild;if(!f.support.tbody){var p=$.test(k),q=l==="table"&&!p?o.firstChild&&o.firstChild.childNodes:m[1]==="<table>"&&!p?o.childNodes:[];for(i=q.length-1;i>=0;--i)f.nodeName(q[i],"tbody")&&!q[i].childNodes.length&&q[i].parentNode.removeChild(q[i])}!f.support.leadingWhitespace&&X.test(k)&&o.insertBefore(b.createTextNode(X.exec(k)[0]),o.firstChild),k=o.childNodes}var r;if(!f.support.appendChecked)if(k[0]&&typeof (r=k.length)=="number")for(i=0;i<r;i++)bn(k[i]);else bn(k);k.nodeType?h.push(k):h=f.merge(h,k)}if(d){g=function(a){return!a.type||be.test(a.type)};for(j=0;h[j];j++)if(e&&f.nodeName(h[j],"script")&&(!h[j].type||h[j].type.toLowerCase()==="text/javascript"))e.push(h[j].parentNode?h[j].parentNode.removeChild(h[j]):h[j]);else{if(h[j].nodeType===1){var s=f.grep(h[j].getElementsByTagName("script"),g);h.splice.apply(h,[j+1,0].concat(s))}d.appendChild(h[j])}}return h},cleanData:function(a){var b,c,d=f.cache,e=f.event.special,g=f.support.deleteExpando;for(var h=0,i;(i=a[h])!=null;h++){if(i.nodeName&&f.noData[i.nodeName.toLowerCase()])continue;c=i[f.expando];if(c){b=d[c];if(b&&b.events){for(var j in b.events)e[j]?f.event.remove(i,j):f.removeEvent(i,j,b.handle);b.handle&&(b.handle.elem=null)}g?delete i[f.expando]:i.removeAttribute&&i.removeAttribute(f.expando),delete d[c]}}}});var bq=/alpha\([^)]*\)/i,br=/opacity=([^)]*)/,bs=/([A-Z]|^ms)/g,bt=/^-?\d+(?:px)?$/i,bu=/^-?\d/,bv=/^([\-+])=([\-+.\de]+)/,bw={position:"absolute",visibility:"hidden",display:"block"},bx=["Left","Right"],by=["Top","Bottom"],bz,bA,bB;f.fn.css=function(a,c){if(arguments.length===2&&c===b)return this;return f.access(this,a,c,!0,function(a,c,d){return d!==b?f.style(a,c,d):f.css(a,c)})},f.extend({cssHooks:{opacity:{get:function(a,b){if(b){var c=bz(a,"opacity","opacity");return c===""?"1":c}return a.style.opacity}}},cssNumber:{fillOpacity:!0,fontWeight:!0,lineHeight:!0,opacity:!0,orphans:!0,widows:!0,zIndex:!0,zoom:!0},cssProps:{"float":f.support.cssFloat?"cssFloat":"styleFloat"},style:function(a,c,d,e){if(!!a&&a.nodeType!==3&&a.nodeType!==8&&!!a.style){var g,h,i=f.camelCase(c),j=a.style,k=f.cssHooks[i];c=f.cssProps[i]||i;if(d===b){if(k&&"get"in k&&(g=k.get(a,!1,e))!==b)return g;return j[c]}h=typeof d,h==="string"&&(g=bv.exec(d))&&(d=+(g[1]+1)*+g[2]+parseFloat(f.css(a,c)),h="number");if(d==null||h==="number"&&isNaN(d))return;h==="number"&&!f.cssNumber[i]&&(d+="px");if(!k||!("set"in k)||(d=k.set(a,d))!==b)try{j[c]=d}catch(l){}}},css:function(a,c,d){var e,g;c=f.camelCase(c),g=f.cssHooks[c],c=f.cssProps[c]||c,c==="cssFloat"&&(c="float");if(g&&"get"in g&&(e=g.get(a,!0,d))!==b)return e;if(bz)return bz(a,c)},swap:function(a,b,c){var d={};for(var e in b)d[e]=a.style[e],a.style[e]=b[e];c.call(a);for(e in b)a.style[e]=d[e]}}),f.curCSS=f.css,f.each(["height","width"],function(a,b){f.cssHooks[b]={get:function(a,c,d){var e;if(c){if(a.offsetWidth!==0)return bC(a,b,d);f.swap(a,bw,function(){e=bC(a,b,d)});return e}},set:function(a,b){if(!bt.test(b))return b;b=parseFloat(b);if(b>=0)return b+"px"}}}),f.support.opacity||(f.cssHooks.opacity={get:function(a,b){return br.test((b&&a.currentStyle?a.currentStyle.filter:a.style.filter)||"")?parseFloat(RegExp.$1)/100+"":b?"1":""},set:function(a,b){var c=a.style,d=a.currentStyle,e=f.isNumeric(b)?"alpha(opacity="+b*100+")":"",g=d&&d.filter||c.filter||"";c.zoom=1;if(b>=1&&f.trim(g.replace(bq,""))===""){c.removeAttribute("filter");if(d&&!d.filter)return}c.filter=bq.test(g)?g.replace(bq,e):g+" "+e}}),f(function(){f.support.reliableMarginRight||(f.cssHooks.marginRight={get:function(a,b){var c;f.swap(a,{display:"inline-block"},function(){b?c=bz(a,"margin-right","marginRight"):c=a.style.marginRight});return c}})}),c.defaultView&&c.defaultView.getComputedStyle&&(bA=function(a,b){var c,d,e;b=b.replace(bs,"-$1").toLowerCase(),(d=a.ownerDocument.defaultView)&&(e=d.getComputedStyle(a,null))&&(c=e.getPropertyValue(b),c===""&&!f.contains(a.ownerDocument.documentElement,a)&&(c=f.style(a,b)));return c}),c.documentElement.currentStyle&&(bB=function(a,b){var c,d,e,f=a.currentStyle&&a.currentStyle[b],g=a.style;f===null&&g&&(e=g[b])&&(f=e),!bt.test(f)&&bu.test(f)&&(c=g.left,d=a.runtimeStyle&&a.runtimeStyle.left,d&&(a.runtimeStyle.left=a.currentStyle.left),g.left=b==="fontSize"?"1em":f||0,f=g.pixelLeft+"px",g.left=c,d&&(a.runtimeStyle.left=d));return f===""?"auto":f}),bz=bA||bB,f.expr&&f.expr.filters&&(f.expr.filters.hidden=function(a){var b=a.offsetWidth,c=a.offsetHeight;return b===0&&c===0||!f.support.reliableHiddenOffsets&&(a.style&&a.style.display||f.css(a,"display"))==="none"},f.expr.filters.visible=function(a){return!f.expr.filters.hidden(a)});var bD=/%20/g,bE=/\[\]$/,bF=/\r?\n/g,bG=/#.*$/,bH=/^(.*?):[ \t]*([^\r\n]*)\r?$/mg,bI=/^(?:color|date|datetime|datetime-local|email|hidden|month|number|password|range|search|tel|text|time|url|week)$/i,bJ=/^(?:about|app|app\-storage|.+\-extension|file|res|widget):$/,bK=/^(?:GET|HEAD)$/,bL=/^\/\//,bM=/\?/,bN=/<script\b[^<]*(?:(?!<\/script>)<[^<]*)*<\/script>/gi,bO=/^(?:select|textarea)/i,bP=/\s+/,bQ=/([?&])_=[^&]*/,bR=/^([\w\+\.\-]+:)(?:\/\/([^\/?#:]*)(?::(\d+))?)?/,bS=f.fn.load,bT={},bU={},bV,bW,bX=["*/"]+["*"];try{bV=e.href}catch(bY){bV=c.createElement("a"),bV.href="",bV=bV.href}bW=bR.exec(bV.toLowerCase())||[],f.fn.extend({load:function(a,c,d){if(typeof a!="string"&&bS)return bS.apply(this,arguments);if(!this.length)return this;var e=a.indexOf(" ");if(e>=0){var g=a.slice(e,a.length);a=a.slice(0,e)}var h="GET";c&&(f.isFunction(c)?(d=c,c=b):typeof c=="object"&&(c=f.param(c,f.ajaxSettings.traditional),h="POST"));var i=this;f.ajax({url:a,type:h,dataType:"html",data:c,complete:function(a,b,c){c=a.responseText,a.isResolved()&&(a.done(function(a){c=a}),i.html(g?f("<div>").append(c.replace(bN,"")).find(g):c)),d&&i.each(d,[c,b,a])}});return this},serialize:function(){return f.param(this.serializeArray())},serializeArray:function(){return this.map(function(){return this.elements?f.makeArray(this.elements):this}).filter(function(){return this.name&&!this.disabled&&(this.checked||bO.test(this.nodeName)||bI.test(this.type))}).map(function(a,b){var c=f(this).val();return c==null?null:f.isArray(c)?f.map(c,function(a,c){return{name:b.name,value:a.replace(bF,"\r\n")}}):{name:b.name,value:c.replace(bF,"\r\n")}}).get()}}),f.each("ajaxStart ajaxStop ajaxComplete ajaxError ajaxSuccess ajaxSend".split(" "),function(a,b){f.fn[b]=function(a){return this.on(b,a)}}),f.each(["get","post"],function(a,c){f[c]=function(a,d,e,g){f.isFunction(d)&&(g=g||e,e=d,d=b);return f.ajax({type:c,url:a,data:d,success:e,dataType:g})}}),f.extend({getScript:function(a,c){return f.get(a,b,c,"script")},getJSON:function(a,b,c){return f.get(a,b,c,"json")},ajaxSetup:function(a,b){b?b_(a,f.ajaxSettings):(b=a,a=f.ajaxSettings),b_(a,b);return a},ajaxSettings:{url:bV,isLocal:bJ.test(bW[1]),global:!0,type:"GET",contentType:"application/x-www-form-urlencoded",processData:!0,async:!0,accepts:{xml:"application/xml, text/xml",html:"text/html",text:"text/plain",json:"application/json, text/javascript","*":bX},contents:{xml:/xml/,html:/html/,json:/json/},responseFields:{xml:"responseXML",text:"responseText"},converters:{"* text":a.String,"text html":!0,"text json":f.parseJSON,"text xml":f.parseXML},flatOptions:{context:!0,url:!0}},ajaxPrefilter:bZ(bT),ajaxTransport:bZ(bU),ajax:function(a,c){function w(a,c,l,m){if(s!==2){s=2,q&&clearTimeout(q),p=b,n=m||"",v.readyState=a>0?4:0;var o,r,u,w=c,x=l?cb(d,v,l):b,y,z;if(a>=200&&a<300||a===304){if(d.ifModified){if(y=v.getResponseHeader("Last-Modified"))f.lastModified[k]=y;if(z=v.getResponseHeader("Etag"))f.etag[k]=z}if(a===304)w="notmodified",o=!0;else try{r=cc(d,x),w="success",o=!0}catch(A){w="parsererror",u=A}}else{u=w;if(!w||a)w="error",a<0&&(a=0)}v.status=a,v.statusText=""+(c||w),o?h.resolveWith(e,[r,w,v]):h.rejectWith(e,[v,w,u]),v.statusCode(j),j=b,t&&g.trigger("ajax"+(o?"Success":"Error"),[v,d,o?r:u]),i.fireWith(e,[v,w]),t&&(g.trigger("ajaxComplete",[v,d]),--f.active||f.event.trigger("ajaxStop"))}}typeof a=="object"&&(c=a,a=b),c=c||{};var d=f.ajaxSetup({},c),e=d.context||d,g=e!==d&&(e.nodeType||e instanceof f)?f(e):f.event,h=f.Deferred(),i=f.Callbacks("once memory"),j=d.statusCode||{},k,l={},m={},n,o,p,q,r,s=0,t,u,v={readyState:0,setRequestHeader:function(a,b){if(!s){var c=a.toLowerCase();a=m[c]=m[c]||a,l[a]=b}return this},getAllResponseHeaders:function(){return s===2?n:null},getResponseHeader:function(a){var c;if(s===2){if(!o){o={};while(c=bH.exec(n))o[c[1].toLowerCase()]=c[2]}c=o[a.toLowerCase()]}return c===b?null:c},overrideMimeType:function(a){s||(d.mimeType=a);return this},abort:function(a){a=a||"abort",p&&p.abort(a),w(0,a);return this}};h.promise(v),v.success=v.done,v.error=v.fail,v.complete=i.add,v.statusCode=function(a){if(a){var b;if(s<2)for(b in a)j[b]=[j[b],a[b]];else b=a[v.status],v.then(b,b)}return this},d.url=((a||d.url)+"").replace(bG,"").replace(bL,bW[1]+"//"),d.dataTypes=f.trim(d.dataType||"*").toLowerCase().split(bP),d.crossDomain==null&&(r=bR.exec(d.url.toLowerCase()),d.crossDomain=!(!r||r[1]==bW[1]&&r[2]==bW[2]&&(r[3]||(r[1]==="http:"?80:443))==(bW[3]||(bW[1]==="http:"?80:443)))),d.data&&d.processData&&typeof d.data!="string"&&(d.data=f.param(d.data,d.traditional)),b$(bT,d,c,v);if(s===2)return!1;t=d.global,d.type=d.type.toUpperCase(),d.hasContent=!bK.test(d.type),t&&f.active++===0&&f.event.trigger("ajaxStart");if(!d.hasContent){d.data&&(d.url+=(bM.test(d.url)?"&":"?")+d.data,delete d.data),k=d.url;if(d.cache===!1){var x=f.now(),y=d.url.replace(bQ,"$1_="+x);d.url=y+(y===d.url?(bM.test(d.url)?"&":"?")+"_="+x:"")}}(d.data&&d.hasContent&&d.contentType!==!1||c.contentType)&&v.setRequestHeader("Content-Type",d.contentType),d.ifModified&&(k=k||d.url,f.lastModified[k]&&v.setRequestHeader("If-Modified-Since",f.lastModified[k]),f.etag[k]&&v.setRequestHeader("If-None-Match",f.etag[k])),v.setRequestHeader("Accept",d.dataTypes[0]&&d.accepts[d.dataTypes[0]]?d.accepts[d.dataTypes[0]]+(d.dataTypes[0]!=="*"?", "+bX+"; q=0.01":""):d.accepts["*"]);for(u in d.headers)v.setRequestHeader(u,d.headers[u]);if(d.beforeSend&&(d.beforeSend.call(e,v,d)===!1||s===2)){v.abort();return!1}for(u in{success:1,error:1,complete:1})v[u](d[u]);p=b$(bU,d,c,v);if(!p)w(-1,"No Transport");else{v.readyState=1,t&&g.trigger("ajaxSend",[v,d]),d.async&&d.timeout>0&&(q=setTimeout(function(){v.abort("timeout")},d.timeout));try{s=1,p.send(l,w)}catch(z){if(s<2)w(-1,z);else throw z}}return v},param:function(a,c){var d=[],e=function(a,b){b=f.isFunction(b)?b():b,d[d.length]=encodeURIComponent(a)+"="+encodeURIComponent(b)};c===b&&(c=f.ajaxSettings.traditional);if(f.isArray(a)||a.jquery&&!f.isPlainObject(a))f.each(a,function(){e(this.name,this.value)});else for(var g in a)ca(g,a[g],c,e);return d.join("&").replace(bD,"+")}}),f.extend({active:0,lastModified:{},etag:{}});var cd=f.now(),ce=/(\=)\?(&|$)|\?\?/i;f.ajaxSetup({jsonp:"callback",jsonpCallback:function(){return f.expando+"_"+cd++}}),f.ajaxPrefilter("json jsonp",function(b,c,d){var e=b.contentType==="application/x-www-form-urlencoded"&&typeof b.data=="string";if(b.dataTypes[0]==="jsonp"||b.jsonp!==!1&&(ce.test(b.url)||e&&ce.test(b.data))){var g,h=b.jsonpCallback=f.isFunction(b.jsonpCallback)?b.jsonpCallback():b.jsonpCallback,i=a[h],j=b.url,k=b.data,l="$1"+h+"$2";b.jsonp!==!1&&(j=j.replace(ce,l),b.url===j&&(e&&(k=k.replace(ce,l)),b.data===k&&(j+=(/\?/.test(j)?"&":"?")+b.jsonp+"="+h))),b.url=j,b.data=k,a[h]=function(a){g=[a]},d.always(function(){a[h]=i,g&&f.isFunction(i)&&a[h](g[0])}),b.converters["script json"]=function(){g||f.error(h+" was not called");return g[0]},b.dataTypes[0]="json";return"script"}}),f.ajaxSetup({accepts:{script:"text/javascript, application/javascript, application/ecmascript, application/x-ecmascript"},contents:{script:/javascript|ecmascript/},converters:{"text script":function(a){f.globalEval(a);return a}}}),f.ajaxPrefilter("script",function(a){a.cache===b&&(a.cache=!1),a.crossDomain&&(a.type="GET",a.global=!1)}),f.ajaxTransport("script",function(a){if(a.crossDomain){var d,e=c.head||c.getElementsByTagName("head")[0]||c.documentElement;return{send:function(f,g){d=c.createElement("script"),d.async="async",a.scriptCharset&&(d.charset=a.scriptCharset),d.src=a.url,d.onload=d.onreadystatechange=function(a,c){if(c||!d.readyState||/loaded|complete/.test(d.readyState))d.onload=d.onreadystatechange=null,e&&d.parentNode&&e.removeChild(d),d=b,c||g(200,"success")},e.insertBefore(d,e.firstChild)},abort:function(){d&&d.onload(0,1)}}}});var cf=a.ActiveXObject?function(){for(var a in ch)ch[a](0,1)}:!1,cg=0,ch;f.ajaxSettings.xhr=a.ActiveXObject?function(){return!this.isLocal&&ci()||cj()}:ci,function(a){f.extend(f.support,{ajax:!!a,cors:!!a&&"withCredentials"in a})}(f.ajaxSettings.xhr()),f.support.ajax&&f.ajaxTransport(function(c){if(!c.crossDomain||f.support.cors){var d;return{send:function(e,g){var h=c.xhr(),i,j;c.username?h.open(c.type,c.url,c.async,c.username,c.password):h.open(c.type,c.url,c.async);if(c.xhrFields)for(j in c.xhrFields)h[j]=c.xhrFields[j];c.mimeType&&h.overrideMimeType&&h.overrideMimeType(c.mimeType),!c.crossDomain&&!e["X-Requested-With"]&&(e["X-Requested-With"]="XMLHttpRequest");try{for(j in e)h.setRequestHeader(j,e[j])}catch(k){}h.send(c.hasContent&&c.data||null),d=function(a,e){var j,k,l,m,n;try{if(d&&(e||h.readyState===4)){d=b,i&&(h.onreadystatechange=f.noop,cf&&delete ch[i]);if(e)h.readyState!==4&&h.abort();else{j=h.status,l=h.getAllResponseHeaders(),m={},n=h.responseXML,n&&n.documentElement&&(m.xml=n),m.text=h.responseText;try{k=h.statusText}catch(o){k=""}!j&&c.isLocal&&!c.crossDomain?j=m.text?200:404:j===1223&&(j=204)}}}catch(p){e||g(-1,p)}m&&g(j,k,m,l)},!c.async||h.readyState===4?d():(i=++cg,cf&&(ch||(ch={},f(a).unload(cf)),ch[i]=d),h.onreadystatechange=d)},abort:function(){d&&d(0,1)}}}});var ck={},cl,cm,cn=/^(?:toggle|show|hide)$/,co=/^([+\-]=)?([\d+.\-]+)([a-z%]*)$/i,cp,cq=[["height","marginTop","marginBottom","paddingTop","paddingBottom"],["width","marginLeft","marginRight","paddingLeft","paddingRight"],["opacity"]],cr;f.fn.extend({show:function(a,b,c){var d,e;if(a||a===0)return this.animate(cu("show",3),a,b,c);for(var g=0,h=this.length;g<h;g++)d=this[g],d.style&&(e=d.style.display,!f._data(d,"olddisplay")&&e==="none"&&(e=d.style.display=""),e===""&&f.css(d,"display")==="none"&&f._data(d,"olddisplay",cv(d.nodeName)));for(g=0;g<h;g++){d=this[g];if(d.style){e=d.style.display;if(e===""||e==="none")d.style.display=f._data(d,"olddisplay")||""}}return this},hide:function(a,b,c){if(a||a===0)return this.animate(cu("hide",3),a,b,c);var d,e,g=0,h=this.length;for(;g<h;g++)d=this[g],d.style&&(e=f.css(d,"display"),e!=="none"&&!f._data(d,"olddisplay")&&f._data(d,"olddisplay",e));for(g=0;g<h;g++)this[g].style&&(this[g].style.display="none");return this},_toggle:f.fn.toggle,toggle:function(a,b,c){var d=typeof a=="boolean";f.isFunction(a)&&f.isFunction(b)?this._toggle.apply(this,arguments):a==null||d?this.each(function(){var b=d?a:f(this).is(":hidden");f(this)[b?"show":"hide"]()}):this.animate(cu("toggle",3),a,b,c);return this},fadeTo:function(a,b,c,d){return this.filter(":hidden").css("opacity",0).show().end().animate({opacity:b},a,c,d)},animate:function(a,b,c,d){function g(){e.queue===!1&&f._mark(this);var b=f.extend({},e),c=this.nodeType===1,d=c&&f(this).is(":hidden"),g,h,i,j,k,l,m,n,o;b.animatedProperties={};for(i in a){g=f.camelCase(i),i!==g&&(a[g]=a[i],delete a[i]),h=a[g],f.isArray(h)?(b.animatedProperties[g]=h[1],h=a[g]=h[0]):b.animatedProperties[g]=b.specialEasing&&b.specialEasing[g]||b.easing||"swing";if(h==="hide"&&d||h==="show"&&!d)return b.complete.call(this);c&&(g==="height"||g==="width")&&(b.overflow=[this.style.overflow,this.style.overflowX,this.style.overflowY],f.css(this,"display")==="inline"&&f.css(this,"float")==="none"&&(!f.support.inlineBlockNeedsLayout||cv(this.nodeName)==="inline"?this.style.display="inline-block":this.style.zoom=1))}b.overflow!=null&&(this.style.overflow="hidden");for(i in a)j=new f.fx(this,b,i),h=a[i],cn.test(h)?(o=f._data(this,"toggle"+i)||(h==="toggle"?d?"show":"hide":0),o?(f._data(this,"toggle"+i,o==="show"?"hide":"show"),j[o]()):j[h]()):(k=co.exec(h),l=j.cur(),k?(m=parseFloat(k[2]),n=k[3]||(f.cssNumber[i]?"":"px"),n!=="px"&&(f.style(this,i,(m||1)+n),l=(m||1)/j.cur()*l,f.style(this,i,l+n)),k[1]&&(m=(k[1]==="-="?-1:1)*m+l),j.custom(l,m,n)):j.custom(l,h,""));return!0}var e=f.speed(b,c,d);if(f.isEmptyObject(a))return this.each(e.complete,[!1]);a=f.extend({},a);return e.queue===!1?this.each(g):this.queue(e.queue,g)},stop:function(a,c,d){typeof a!="string"&&(d=c,c=a,a=b),c&&a!==!1&&this.queue(a||"fx",[]);return this.each(function(){function h(a,b,c){var e=b[c];f.removeData(a,c,!0),e.stop(d)}var b,c=!1,e=f.timers,g=f._data(this);d||f._unmark(!0,this);if(a==null)for(b in g)g[b]&&g[b].stop&&b.indexOf(".run")===b.length-4&&h(this,g,b);else g[b=a+".run"]&&g[b].stop&&h(this,g,b);for(b=e.length;b--;)e[b].elem===this&&(a==null||e[b].queue===a)&&(d?e[b](!0):e[b].saveState(),c=!0,e.splice(b,1));(!d||!c)&&f.dequeue(this,a)})}}),f.each({slideDown:cu("show",1),slideUp:cu("hide",1),slideToggle:cu("toggle",1),fadeIn:{opacity:"show"},fadeOut:{opacity:"hide"},fadeToggle:{opacity:"toggle"}},function(a,b){f.fn[a]=function(a,c,d){return this.animate(b,a,c,d)}}),f.extend({speed:function(a,b,c){var d=a&&typeof a=="object"?f.extend({},a):{complete:c||!c&&b||f.isFunction(a)&&a,duration:a,easing:c&&b||b&&!f.isFunction(b)&&b};d.duration=f.fx.off?0:typeof d.duration=="number"?d.duration:d.duration in f.fx.speeds?f.fx.speeds[d.duration]:f.fx.speeds._default;if(d.queue==null||d.queue===!0)d.queue="fx";d.old=d.complete,d.complete=function(a){f.isFunction(d.old)&&d.old.call(this),d.queue?f.dequeue(this,d.queue):a!==!1&&f._unmark(this)};return d},easing:{linear:function(a,b,c,d){return c+d*a},swing:function(a,b,c,d){return(-Math.cos(a*Math.PI)/2+.5)*d+c}},timers:[],fx:function(a,b,c){this.options=b,this.elem=a,this.prop=c,b.orig=b.orig||{}}}),f.fx.prototype={update:function(){this.options.step&&this.options.step.call(this.elem,this.now,this),(f.fx.step[this.prop]||f.fx.step._default)(this)},cur:function(){if(this.elem[this.prop]!=null&&(!this.elem.style||this.elem.style[this.prop]==null))return this.elem[this.prop];var a,b=f.css(this.elem,this.prop);return isNaN(a=parseFloat(b))?!b||b==="auto"?0:b:a},custom:function(a,c,d){function h(a){return e.step(a)}var e=this,g=f.fx;this.startTime=cr||cs(),this.end=c,this.now=this.start=a,this.pos=this.state=0,this.unit=d||this.unit||(f.cssNumber[this.prop]?"":"px"),h.queue=this.options.queue,h.elem=this.elem,h.saveState=function(){e.options.hide&&f._data(e.elem,"fxshow"+e.prop)===b&&f._data(e.elem,"fxshow"+e.prop,e.start)},h()&&f.timers.push(h)&&!cp&&(cp=setInterval(g.tick,g.interval))},show:function(){var a=f._data(this.elem,"fxshow"+this.prop);this.options.orig[this.prop]=a||f.style(this.elem,this.prop),this.options.show=!0,a!==b?this.custom(this.cur(),a):this.custom(this.prop==="width"||this.prop==="height"?1:0,this.cur()),f(this.elem).show()},hide:function(){this.options.orig[this.prop]=f._data(this.elem,"fxshow"+this.prop)||f.style(this.elem,this.prop),this.options.hide=!0,this.custom(this.cur(),0)},step:function(a){var b,c,d,e=cr||cs(),g=!0,h=this.elem,i=this.options;if(a||e>=i.duration+this.startTime){this.now=this.end,this.pos=this.state=1,this.update(),i.animatedProperties[this.prop]=!0;for(b in i.animatedProperties)i.animatedProperties[b]!==!0&&(g=!1);if(g){i.overflow!=null&&!f.support.shrinkWrapBlocks&&f.each(["","X","Y"],function(a,b){h.style["overflow"+b]=i.overflow[a]}),i.hide&&f(h).hide();if(i.hide||i.show)for(b in i.animatedProperties)f.style(h,b,i.orig[b]),f.removeData(h,"fxshow"+b,!0),f.removeData(h,"toggle"+b,!0);d=i.complete,d&&(i.complete=!1,d.call(h))}return!1}i.duration==Infinity?this.now=e:(c=e-this.startTime,this.state=c/i.duration,this.pos=f.easing[i.animatedProperties[this.prop]](this.state,c,0,1,i.duration),this.now=this.start+(this.end-this.start)*this.pos),this.update();return!0}},f.extend(f.fx,{tick:function(){var a,b=f.timers,c=0;for(;c<b.length;c++)a=b[c],!a()&&b[c]===a&&b.splice(c--,1);b.length||f.fx.stop()},interval:13,stop:function(){clearInterval(cp),cp=null},speeds:{slow:600,fast:200,_default:400},step:{opacity:function(a){f.style(a.elem,"opacity",a.now)},_default:function(a){a.elem.style&&a.elem.style[a.prop]!=null?a.elem.style[a.prop]=a.now+a.unit:a.elem[a.prop]=a.now}}}),f.each(["width","height"],function(a,b){f.fx.step[b]=function(a){f.style(a.elem,b,Math.max(0,a.now)+a.unit)}}),f.expr&&f.expr.filters&&(f.expr.filters.animated=function(a){return f.grep(f.timers,function(b){return a===b.elem}).length});var cw=/^t(?:able|d|h)$/i,cx=/^(?:body|html)$/i;"getBoundingClientRect"in c.documentElement?f.fn.offset=function(a){var b=this[0],c;if(a)return this.each(function(b){f.offset.setOffset(this,a,b)});if(!b||!b.ownerDocument)return null;if(b===b.ownerDocument.body)return f.offset.bodyOffset(b);try{c=b.getBoundingClientRect()}catch(d){}var e=b.ownerDocument,g=e.documentElement;if(!c||!f.contains(g,b))return c?{top:c.top,left:c.left}:{top:0,left:0};var h=e.body,i=cy(e),j=g.clientTop||h.clientTop||0,k=g.clientLeft||h.clientLeft||0,l=i.pageYOffset||f.support.boxModel&&g.scrollTop||h.scrollTop,m=i.pageXOffset||f.support.boxModel&&g.scrollLeft||h.scrollLeft,n=c.top+l-j,o=c.left+m-k;return{top:n,left:o}}:f.fn.offset=function(a){var b=this[0];if(a)return this.each(function(b){f.offset.setOffset(this,a,b)});if(!b||!b.ownerDocument)return null;if(b===b.ownerDocument.body)return f.offset.bodyOffset(b);var c,d=b.offsetParent,e=b,g=b.ownerDocument,h=g.documentElement,i=g.body,j=g.defaultView,k=j?j.getComputedStyle(b,null):b.currentStyle,l=b.offsetTop,m=b.offsetLeft;while((b=b.parentNode)&&b!==i&&b!==h){if(f.support.fixedPosition&&k.position==="fixed")break;c=j?j.getComputedStyle(b,null):b.currentStyle,l-=b.scrollTop,m-=b.scrollLeft,b===d&&(l+=b.offsetTop,m+=b.offsetLeft,f.support.doesNotAddBorder&&(!f.support.doesAddBorderForTableAndCells||!cw.test(b.nodeName))&&(l+=parseFloat(c.borderTopWidth)||0,m+=parseFloat(c.borderLeftWidth)||0),e=d,d=b.offsetParent),f.support.subtractsBorderForOverflowNotVisible&&c.overflow!=="visible"&&(l+=parseFloat(c.borderTopWidth)||0,m+=parseFloat(c.borderLeftWidth)||0),k=c}if(k.position==="relative"||k.position==="static")l+=i.offsetTop,m+=i.offsetLeft;f.support.fixedPosition&&k.position==="fixed"&&(l+=Math.max(h.scrollTop,i.scrollTop),m+=Math.max(h.scrollLeft,i.scrollLeft));return{top:l,left:m}},f.offset={bodyOffset:function(a){var b=a.offsetTop,c=a.offsetLeft;f.support.doesNotIncludeMarginInBodyOffset&&(b+=parseFloat(f.css(a,"marginTop"))||0,c+=parseFloat(f.css(a,"marginLeft"))||0);return{top:b,left:c}},setOffset:function(a,b,c){var d=f.css(a,"position");d==="static"&&(a.style.position="relative");var e=f(a),g=e.offset(),h=f.css(a,"top"),i=f.css(a,"left"),j=(d==="absolute"||d==="fixed")&&f.inArray("auto",[h,i])>-1,k={},l={},m,n;j?(l=e.position(),m=l.top,n=l.left):(m=parseFloat(h)||0,n=parseFloat(i)||0),f.isFunction(b)&&(b=b.call(a,c,g)),b.top!=null&&(k.top=b.top-g.top+m),b.left!=null&&(k.left=b.left-g.left+n),"using"in b?b.using.call(a,k):e.css(k)}},f.fn.extend({position:function(){if(!this[0])return null;var a=this[0],b=this.offsetParent(),c=this.offset(),d=cx.test(b[0].nodeName)?{top:0,left:0}:b.offset();c.top-=parseFloat(f.css(a,"marginTop"))||0,c.left-=parseFloat(f.css(a,"marginLeft"))||0,d.top+=parseFloat(f.css(b[0],"borderTopWidth"))||0,d.left+=parseFloat(f.css(b[0],"borderLeftWidth"))||0;return{top:c.top-d.top,left:c.left-d.left}},offsetParent:function(){return this.map(function(){var a=this.offsetParent||c.body;while(a&&!cx.test(a.nodeName)&&f.css(a,"position")==="static")a=a.offsetParent;return a})}}),f.each(["Left","Top"],function(a,c){var d="scroll"+c;f.fn[d]=function(c){var e,g;if(c===b){e=this[0];if(!e)return null;g=cy(e);return g?"pageXOffset"in g?g[a?"pageYOffset":"pageXOffset"]:f.support.boxModel&&g.document.documentElement[d]||g.document.body[d]:e[d]}return this.each(function(){g=cy(this),g?g.scrollTo(a?f(g).scrollLeft():c,a?c:f(g).scrollTop()):this[d]=c})}}),f.each(["Height","Width"],function(a,c){var d=c.toLowerCase();f.fn["inner"+c]=function(){var a=this[0];return a?a.style?parseFloat(f.css(a,d,"padding")):this[d]():null},f.fn["outer"+c]=function(a){var b=this[0];return b?b.style?parseFloat(f.css(b,d,a?"margin":"border")):this[d]():null},f.fn[d]=function(a){var e=this[0];if(!e)return a==null?null:this;if(f.isFunction(a))return this.each(function(b){var c=f(this);c[d](a.call(this,b,c[d]()))});if(f.isWindow(e)){var g=e.document.documentElement["client"+c],h=e.document.body;return e.document.compatMode==="CSS1Compat"&&g||h&&h["client"+c]||g}if(e.nodeType===9)return Math.max(e.documentElement["client"+c],e.body["scroll"+c],e.documentElement["scroll"+c],e.body["offset"+c],e.documentElement["offset"+c]);if(a===b){var i=f.css(e,d),j=parseFloat(i);return f.isNumeric(j)?j:i}return this.css(d,typeof a=="string"?a:a+"px")}}),a.jQuery=a.$=f,typeof define=="function"&&define.amd&&define.amd.jQuery&&define("jquery",[],function(){return f})})(window);



OEBPS/Common_Content/fonts/overpass_bold-web.eot


OEBPS/Common_Content/fonts/portal/nimbus/iconfont.eot


OEBPS/Common_Content/images/20.png





OEBPS/Common_Content/fonts/overpass_light-web.eot


OEBPS/Common_Content/scripts/highlight.pack.js
/*! highlight.js v9.2.0 | BSD3 License | git.io/hljslicense */
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