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Abstract

This document describes how to create and test an example IT orders case project in Red Hat
Process Automation Manager 7.7. The procedures in this document are based on the IT_Orders
sample case project included in Business Central.
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PREFACE
As a business rules and processes developer, you can use case management assets in Business Central
to create unpredictable and ad hoc case processes. Case workers or process administrators can also use
Business Central for case management and execution. Red Hat Process Automation Manager provides
example projects with example business assets in Business Central as a reference. This document
describes how to create and test an example IT orders project based on the IT_Orders sample project
included in Business Central.

Prerequisites

Red Hat JBoss Enterprise Application Platform 7.2 is installed. For installation information, see
Red Hat JBoss Enterprise Application Platform 7.2 Installation Guide .

Red Hat Process Automation Manager is installed and configured with KIE Server. For more
information see Installing and configuring Red Hat Process Automation Manager on Red Hat
JBoss EAP 7.2.

Red Hat Process Automation Manager is running and you can log in to Business Central with
the kie-server, user, and admin roles.

PREFACE
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CHAPTER 1. CASE MANAGEMENT
Case management is an extension of Business Process Management (BPM) that enables you to manage
adaptable business processes.

BPM is a management practice used to automate tasks that are repeatable and have a common
pattern, with a focus on optimization by perfecting a process. Business processes are usually modeled
with clearly defined paths leading to a business goal. This requires a lot of predictability, usually based on
mass-production principles. However, many real-world applications cannot be described completely
from start to finish (including all possible paths, deviations, and exceptions). Using a process-oriented
approach in certain cases can lead to complex solutions that are hard to maintain.

Case management provides problem resolution for non-repeatable, unpredictable processes as
opposed to the efficiency-oriented approach of BPM for routine, predictable tasks. It manages one-off
situations when the process cannot be predicted in advance. A case definition usually consists of loosely
coupled process fragments that can be connected directly or indirectly to lead to certain milestones and
ultimately a business goal, while the process is managed dynamically in response to changes that occur
during run time.

In Red Hat Process Automation Manager, case management includes the following core process engine
features:

Case file instance

A per case runtime strategy

Case comments

Milestones

Stages

Ad hoc fragments

Dynamic tasks and processes

Case identifier (correlation key)

Case lifecycle (close, reopen, cancel, destroy)

A case definition is always an ad hoc process definition and does not require an explicit start node. The
case definition is the main entry point for the business use case.

A process definition is introduced as a supporting construct of the case and can be invoked either as
defined in the case definition or dynamically to bring in additional processing when required. A case
definition defines the following new objects:

Activities (required)

Case file (required)

Milestones

Roles

Stages

Red Hat Process Automation Manager 7.7 Getting started with case management
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1.1. CASE FILES

A case instance is a single instance of a case definition and encapsulates the business context. All case
instance data is stored in the case file, which is accessible to all process instances that might participate
in the particular case instance. Each case instance and its case file are completely isolated from the
other cases. Only case instance participants can access the case file.

A case file is used in case management as a repository of data for the entire case instance. It contains all
roles, data objects, the data map, and any other data. The case can be closed and reopened at a later
date with the same case file attached. A case instance can be closed at any time and does not require a
specific resolution to be completed.

The case file can also include embedded documentation, references, PDF attachments, web links, and
other options.

The Case ID prefix is an optional configurable prefix that enables you to easily distinguish different
types of cases. The prefix is followed by a generated ID in the format ID-XXXXXXXXXX, where 
XXXXXXXXXX is a generated number that provides a unique ID for the case instance. If a prefix is not
provided, the default prefix is CASE with the following identifiers:

CASE-0000000001

CASE-0000000002

CASE-0000000003

You can specify any prefix. For example, if you specify the prefix IT, the following identifiers are
generated:

IT-0000000001

IT-0000000002

IT-0000000003

1.2. COMMENTS

In case management, comments facilitate collaboration within the case instance, and allow case workers
to easily communicate with each other to exchange information.

Comments are bound to the case instance. Case instances are part of the case file, so you can use
comments to take action on the instances. Basic text-based comments can have a complete operations
set, similar to CRUD (create, read, update, and delete).

1.3. CASE ROLES

Case roles provide an additional layer of abstraction for user participation in case handling. Roles, users,
and groups are used for different purposes in case management.

Roles

Roles drive the authorization for a case instance and are used for user activity assignments. A user or
one or more groups can be assigned to the owner role. The owner is whoever the case belongs to.
Roles are not restricted to a single set of people or groups as part of a case definition. Use roles to
specify task assignments instead of assigning a specific user or group to a task assignment to ensure
that the case remains dynamic.

CHAPTER 1. CASE MANAGEMENT
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Groups

A group is a collection of users who are able to carry out a particular task or have a set of specified
responsibilities. You can assign any number of people to a group and assign any group to a role. You
can add or change members of a group at any time. Do not hard code a group to a particular task.

Users

A user is an individual who can be given a particular task when you assign them a role or add them to a
group.

The following example illustrates how the preceding case management concepts apply to a hotel
reservation with:

Role = Guest

Group = Receptionist, Maid

User = Marilyn

The Guest role assignment affects the specific work of the associated case and is unique to all case
instances. The number of users or groups that can be assigned to a role is limited by the Case 
Cardinality, which is set during role creation in the process designer and case definition. For example,
the hotel reservation case has only one guest while the IT_Orders sample project has two suppliers of IT
hardware.

When roles are defined, ensure that roles are not hard-coded to a single set of people or groups as part
of case definition and that they can differ for each case instance. This is why case role assignments are
important.

Role assignments can be assigned or removed when a case starts or at any time when a case is active.
Although roles are optional, use roles in case definitions to maintain an organized workflow.

IMPORTANT

Always use roles for task assignments instead of actual user or group names. This ensures
that the case remains dynamic and actual user or group assignments can be made as late
as required.

Roles are assigned to users or groups and authorized to perform tasks when a case instance is started.

Red Hat Process Automation Manager 7.7 Getting started with case management
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CHAPTER 2. SAMPLE PROJECTS AND BUSINESS ASSETS IN
BUSINESS CENTRAL

Business Central contains sample projects with business assets that you can use as a reference for the
rules, processes, or other assets that you create in your own Red Hat Process Automation Manager
projects. Each sample project is designed differently to demonstrate process automation, decision
management, or business optimization assets and logic in Red Hat Process Automation Manager.

NOTE

Red Hat does not provide support for the sample code included in the Red Hat Process
Automation Manager distribution.

The following sample projects are available in Business Central:

Evaluation_Process: (Process automation) Evaluation process using business process assets.
Evaluates employees based on performance.

Mortgage_Process: (Process automation) Loan approval process using business process and
decision assets. Determines loan eligibility based on applicant data and qualifications.

IT_Orders: (Process automation and case management) Ordering case using business process
and case management assets. Places an IT hardware order based on needs and approvals.

Traffic_Violation: (Decision management with DMN) Traffic violation decision service using a
Decision Model and Notation (DMN) model. Determines driver penalty and suspension based
on traffic violations.

Mortgages: (Decision management with rules) Loan approval process using rule-based decision
assets. Determines loan eligibility based on applicant data and qualifications.

Employee_Rostering: (Business optimization) Employee rostering optimization using decision
and solver assets. Assigns employees to shifts based on skills.

OptaCloud: (Business optimization) Resource allocation optimization using decision and solver
assets. Assigns processes to computers with limited resources.

Course_Scheduling: (Business optimization) Course scheduling and curriculum decision
process. Assigns lectures to rooms and determines a student’s curriculum based on factors,
such as course conflicts and class room capacity.

Dinner_Party: (Business optimization) Guest seating optimization using guided decision tables.
Assigns guest seating based on each guest’s job type, political beliefs, and known relationships.

2.1. ACCESSING SAMPLE PROJECTS AND BUSINESS ASSETS IN
BUSINESS CENTRAL

You can use the sample projects in Business Central to explore business assets as a reference for the
rules or other assets that you create in your own Red Hat Process Automation Manager projects.

Prerequisites

Business Central is installed and running. For installation options, see Planning a Red Hat
Process Automation Manager installation.

CHAPTER 2. SAMPLE PROJECTS AND BUSINESS ASSETS IN BUSINESS CENTRAL
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Procedure

1. In Business Central, go to Menu → Design → Projects. If there are existing projects, you can
access the samples by clicking on the MySpace default space and selecting Try Samples from
the Add Project pull-down menu. If there are no existing projects, click Try samples.

2. Review the descriptions for each sample project to determine which project you want to
explore. Each sample project is designed differently to demonstrate process automation,
decision management, or business optimization assets and logic in Red Hat Process
Automation Manager.

3. Select one or more sample projects and click Ok to add the projects to your space.

4. In the Projects page of your space, select one of the sample projects to view the assets for that
project.

5. Select each asset to explore how the project is designed to achieve the specified goal or
workflow. Some of the sample projects contain more than one page of assets. Click the left or
right arrows in the upper-right corner to view the full asset list.

Figure 2.1. Asset page selection

6. In the upper-right corner of the project Assets page, click Build to build the sample project or
Deploy to build the project and then deploy it to KIE Server.

NOTE

You can also select the Build & Install option to build the project and publish the
KJAR file to the configured Maven repository without deploying to a KIE Server.
In a development environment, you can click Deploy to deploy the built KJAR file
to a KIE Server without stopping any running instances (if applicable), or click
Redeploy to deploy the built KJAR file and replace all instances. The next time
you deploy or redeploy the built KJAR, the previous deployment unit (KIE
container) is automatically updated in the same target KIE Server. In a production
environment, the Redeploy option is disabled and you can click Deploy only to
deploy the built KJAR file to a new deployment unit (KIE container) on a KIE
Server.

To configure the KIE Server environment mode, set the org.kie.server.mode
system property to org.kie.server.mode=development or 
org.kie.server.mode=production. To configure the deployment behavior for a
corresponding project in Business Central, go to project Settings → General
Settings → Version, toggle the Development Mode option, and click Save. By
default, KIE Server and all new projects in Business Central are in development
mode. You cannot deploy a project with Development Mode turned on or with a
manually added SNAPSHOT version suffix to a KIE Server that is in production
mode.

To review project deployment details, click View deployment details in the deployment banner
at the top of the screen or in the Deploy drop-down menu. This option directs you to the Menu
→ Deploy → Execution Servers page.

Red Hat Process Automation Manager 7.7 Getting started with case management
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CHAPTER 3. REVIEWING THE IT_ORDERS SAMPLE PROJECT
Before you create your own case management project, review the existing IT_Orders sample case
management project in Business Central. This sample project contains predefined case management
assets as a reference for your own case projects.

IMPORTANT

The business process application example includes features that are Technology Preview
only. Technology Preview features are not supported with Red Hat production service
level agreements (SLAs), might not be functionally complete, and are not recommended
for production. These features provide early access to upcoming product features,
enabling customers to test functionality and provide feedback during the development
process. For more information about Red Hat Technology Preview support, see
Technology Preview Features Support Scope .

Procedure

1. In Business Central, go to Menu → Design → Projects. If there are existing projects, you can
access the samples by clicking the MySpace default space and selecting Try Samples from the
Add Project pull-down menu. If there are no existing projects, click Try samples.

2. Select IT_Orders and click Ok.

The Assets view of the project opens. Select each example asset to explore how the project is designed
to achieve the specified goal or workflow.

Review the orderhardware Business Processes asset to help you understand the business process
flow.

NOTE

CHAPTER 3. REVIEWING THE IT_ORDERS SAMPLE PROJECT
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NOTE

The legacy process designer in Business Central is deprecated in Red Hat Process
Automation Manager 7.7.0. It will be removed in a future Red Hat Process Automation
Manager release. The legacy process designer will not receive any new enhancements or
features. Existing users of the legacy process designer are advised to migrate projects to
the new designer. For information about migrating projects to the new designer, see
Managing projects in Business Central .

Red Hat Process Automation Manager 7.7 Getting started with case management
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CHAPTER 4. CREATING A NEW IT_ORDERS CASE PROJECT
Create a new IT_Orders project in Business Central to gain an understanding of all of the required assets
and how they are used in the project.

Procedure

1. Log in to Business Central and go to Menu → Design → Projects.
Business Central provides a default space called MySpace, as shown in the following image. You
can use the default space to create and test example projects.

Figure 4.1. Default spaces

2. Click Add Project → Case project.

Figure 4.2. Case project menu

3. Enter IT_Orders_New in the Name field.

4. Click Add.

Figure 4.3. Add Project window

CHAPTER 4. CREATING A NEW IT_ORDERS CASE PROJECT
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Figure 4.3. Add Project window

The Assets view of the project opens.
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CHAPTER 5. DATA OBJECTS
Data objects are the building blocks for the rule assets that you create. Data objects are custom data
types implemented as Java objects in specified packages of your project. For example, you might create
a Person object with data fields Name, Address, and DateOfBirth to specify personal details for loan
application rules. These custom data types determine what data your assets and your decision services
are based on.

5.1. CREATING THE ITORDERSERVICE DATA OBJECT

The ITOrderService data object specifies the data type that will be used to define the IT Orders
variables.

Prerequisites

The IT_Orders_New project is created.

Procedure

1. Click Add Asset → Data Object.

2. In the Create new Data Object wizard, enter the following values:

Data Object: ITOrderService

Package: com.myspace.it_orders_new

3. Click Ok.

4. Click  next to the Package pull-down menu to specify a new package for the data object.

5. Input org.jbpm.demo.it_orders.services and click Add.

6. Click Save, and then click Yes, Move to confirm your changes.

5.2. CREATING THE SURVEY DATA OBJECT

The Survey data object contains data fields, such as deliveredOnTime and missingEquipment. You will
use the data and values when you design your case.

Prerequisites

The IT_Orders_New project is created.

Procedure

1. In Business Central, go to Menu → Design → Projects and click IT_Orders_New.

2. Click Add Asset → Data Object.

3. In the Create new Data Object wizard, enter the following values:

Data Object: Survey
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Package: com.myspace.it_orders_new

4. Click Ok.

5. Add the Survey data object constraints.

a. Click add field.

b. Enter the following values:

Id: comment

Label: Leave empty

Type: String

c. Click Create and continue, and then enter the following values:

Id: deliveredOnTime

Label: Leave empty

Type: Boolean

d. Click Create and continue, and then enter the following values:

Id: missingEquipment

Label: Leave empty

Type: String

e. Click Create and continue, and then enter the following values:

Id: satisfied

Label: Leave empty

Type: Boolean

f. Click Create.

6. Click Save to confirm your changes.

Figure 5.1. Survey data object details
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CHAPTER 6. DESIGNING THE CASE DEFINITION
You design cases using the process designer in Business Central. Case design is the basis of case
management and sets the specific goals and tasks for each case. The case flow can be modified
dynamically during run time by adding dynamic tasks or processes. In this procedure, you will create this
same case definition to familiarize yourself with the case definition design process.

The IT_Orders sample project in Business Central includes the following orderhardware business
process case definition.

Figure 6.1. orderhardware business process case definition

Prerequisites

You have created a new case in Business Central. For more information, see Chapter 4,
Creating a new IT_Orders case project .

You have created the data objects. For more information, see Chapter 5, Data objects.

Procedure

1. In Business Central, go to Menu → Design → Projects and click IT_Orders_New.

2. Click Add Asset → Case Definition.

3. In the Create new Case definition window, add the following required information:

Case Definition: Input orderhardware. This is usually the subject of the case or project that
is being case managed.

Package: Select com.myspace.it_orders_new to specify the location that the case file is
created in.

4. Click Ok to open the process designer.

5. Define values for the case file variables that are accessible to the subprocesses, subcases, and
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5. Define values for the case file variables that are accessible to the subprocesses, subcases, and
business rules used in the case.

a. In the upper-right corner, click the Diagram properties  icon.

b. Scroll down and expand Case Management, click  in the Case File Variables section,
and enter the following:

Figure 6.2. orderhardware case file variables

NOTE

The following case file variables are custom data types:

hwSpec: org.jbpm.document.Document (type in this value)

survey: Survey [com.myspace.it_orders_new] (select this value)

6. Click Save.

7. Define the roles involved in the case.

a. In the upper-right corner, click the Diagram properties  icon.

b. Scroll down and expand Case Management, click  in the Case Roles section, and
enter the following:

Figure 6.3. orderhardware case roles
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Figure 6.3. orderhardware case roles

owner: The employee who is making the hardware order request. The role cardinality is
set to 1, which means that only one person or group can be assigned to this role.

manager: The employee’s manager; the person who will approve or deny the requested
hardware. The role cardinality is set to 1, which means that only one person or group can
be assigned to this role.

supplier: The available suppliers of IT hardware in the system. The role cardinality is set
to 2, which means that more than one supplier can be assigned to this role.

8. Click Save.

6.1. CREATING THE PLACE ORDER SUBPROCESS

Create the Place order subprocess, which is a separate business process that is carried out by the
supplier. This is a reusable process that occurs during the course of case execution as described in
Chapter 6, Designing the case definition .

Prerequisites

You have created a new case in Business Central. For more information, see Chapter 4,
Creating a new IT_Orders case project .

You have created the data objects. For more information, see Chapter 5, Data objects.

Procedure

1. In Business Central, go to Menu → Design → Projects → IT_Orders_New.

2. From the project menu, click Add Asset → Business Process.

3. In the Create new Business Process wizard, enter the following values:

Business Process: place-order

Package: Select com.myspace.it_orders_new

4. Click Ok. The diagram editor opens.

5. Click an empty space in the canvas, and in the upper-right corner, click the Diagram properties 

 icon.

CHAPTER 6. DESIGNING THE CASE DEFINITION

17



6. Scroll down and expand Process Data and click  in the Process Variables section and
enter the following:

7. Click Save.

8. Drag a start event onto the canvas and create an outgoing connection from the start event to a
task and convert the new task to a user task.
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9. Click the user task and in the Diagram properties panel, input Place order in the Name field.

10. Expand Implementation/Execution, click Add below the Groups menu, click Select → New,
and input supplier.

11. Click  in the Assignments field and add the following:

For the first input assignment, select Custom for the Data Type and input 
org.jbpm.document.Document.
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12. Click Save.

13. Select the Skippable check box and enter the following text in the Description field:
Approved order #{CaseId} to be placed

14. Create an outgoing connection from the Place order user task and connect it to an end event.

15. Click Save to confirm your changes.

6.2. CREATING THE MANAGER APPROVAL BUSINESS PROCESS

The manager approval process determines whether or not the order will be placed or rejected.

Procedure

1. In Business Central, go to Menu → Design → Projects → IT_Orders_New → orderhardware
Business Processes.
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2. Create and configure the prepare hardware spec user task:

a. Drag a start event onto the canvas and create an outgoing connection from the start event
to a task and convert the new task to a user task.

b. Click the new user task and in the upper-right corner click the Properties  icon.

c. Input Prepare hardware spec in the Name field.

d. Expand Implementation/Execution, click Add below the Groups menu, click Select →
New, and input supplier.

e. Input PrepareHardwareSpec in the Task Name field.

f. Select the Skippable check box and enter the following text in the Description field:
Prepare hardware specification for #{initiator} (order number #{CaseId})

g. Click  in the Assignments field and add the following:

h. Click Save.

3. Create and configure the manager approval user task:

a. Click the Prepare hardware spec user task and create a new user task.

b. Click the new user task and in the upper-right corner click the Properties  icon.

c. Click the user task and in the Properties panel input Manager approval in the Name field.

d. Expand Implementation/Execution, click Add below the Actors menu, click Select →
New, and input manager.
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e. Input ManagerApproval in the Task Name field.

f. Click  in the Assignments field and add the following:

g. Click Save.

h. Select the Skippable check box and enter the following text in the Description field:
Approval request for new hardware for #{initiator} (order number #{CaseId})

i. Enter the following Java expression in the On Exit Action field:
kcontext.setVariable("caseFile_managerDecision", approved);

j. Click Save.

4. Click the Manager approval user task and create a Data-based Exclusive (XOR) gateway.
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5. Create and configure the place order reusable subprocess:

a. From the Object Library, expand Subprocesses, click Reusable, and drag the new element
to the canvas on the right side of the Data-based Exclusive (XOR) gateway.

b. Connect the Data-based Exclusive (XOR) gateway to the subprocess.

c. Click the new sub task and in the upper-right corner click the Properties  icon.

d. Input Place order in the Name field.

e. Expand Data Assignments and click  in the Assignments field and add the following:
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f. Click the connection from the Data-based Exclusive (XOR) gateway to the subprocess and

click the Properties  icon.

g. Expand Implementation/Execution, select Condition, and set the following condition
expressions.

h. Click the Place order user task and create an end event.

6. Create and configure the order rejected user task:

a. Click the Data-based Exclusive (XOR) gateway and create a new user task.

b. Drag the new task to align it below the Place order task.
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c. Click the new user task and in the upper-right corner click the Properties  icon.

d. Input Order rejected in the Name field.

e. Expand Implementation/Execution and input OrderRejected in the Task Name field.

f. Click Add below the Actors menu, click Select → New, and input owner.

g. Click  in the Assignments field and add the following:

h. Click Save.

i. Select the Skippable check box and enter the following text in the Description field:
Order #{CaseId} has been rejected by manager

j. Click the Order rejected user task and create an end event.

k. Click Save.

7. Click the connection from the Data-based Exclusive (XOR) gateway to the Order rejected user

task and click the Properties  icon.

8. Expand Implementation/Execution, select Condition, and set the following condition
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8. Expand Implementation/Execution, select Condition, and set the following condition
expressions.

9. Click Save.

Figure 6.4. Manager approval business process
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CHAPTER 7. MILESTONES
Milestones are a special service task that can be configured in the case definition designer by adding the
milestone node to the process designer palette. When creating a new case definition, a milestone
configured as Adhoc autostart is included on the design palette by default. Newly created milestones
are not set to Adhoc autostart by default.

Case management milestones generally occur at the end of a stage, but they can also be the result of
achieving other milestones. A milestone always requires a condition to be defined in order to track
progress. Milestones react to case file data when data is added to a case. A milestone represents a
single point of achievement within the case instance. It can be used to flag certain events, which can be
useful for Key Performance Indicator (KPI) tracking or identifying the tasks that are still to be
completed.

Milestones can be in any of the following states during case execution:

Active - The condition has been defined on the milestone but it has not been met.

Completed - The milestone condition has been met, the milestone has been achieved, and the
case can proceed to the next task.

Terminated - The milestone is no longer a part of the case process and is no longer required.

While a milestone is available or completed it can be triggered manually by a signal or automatically if 
Adhoc autostart is configured when a case instance starts. Milestones can be triggered as many times
as required, however, it is directly achieved when the condition is met.

7.1. CREATING THE HARDWARE SPEC READY MILESTONE

Create a HardwareSpecReady milestone that is reached when the required hardware specification
document is completed.

Procedure

1. In the process designer, expand Milestone in the Object Library and drag a new milestone on
the canvas and place it on the right side of the Place order end event.

2. Click the new milestone and in the upper-right corner click the Properties  icon.

3. Input Hardware spec ready in the Name field.

4. Expand Implementation/Execution and select Adhoc Autostart.

5. Expand Data Assignments, click  in the Assignments field, and add the following:

CHAPTER 7. MILESTONES

27



Click the Source column drop-down, select Constant, and input 
org.kie.api.runtime.process.CaseData(data.get("hwSpec") != null).

6. Click Save.

7.2. CREATING THE MANAGER DECISION MILESTONE

This milestone is reached when the managerDecision variable has been given a response.

Procedure

1. In the process designer, expand Milestone in the Object Library and drag a new milestone on
to the canvas below the HardwareSpecReady milestone.

2. Click the new milestone and in the upper-right corner click the Properties  icon.

3. Input Manager decision in the Name field.

4. Expand Implementation/Execution and select Adhoc Autostart.

5. Expand Data Assignments and click  in the Assignments field and add the following:
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Click the Source column drop-down, select Constant, and input 
org.kie.api.runtime.process.CaseData(data.get("managerDecision") != null).

6. Click Save.

7.3. CREATING THE ORDER PLACED MILESTONE

This milestone is reached when the ordered variable, which is part of the Place order sub-process, has
been given a response.

Procedure

1. In the process designer, expand Milestone in the Object Library and drag a new milestone on
the canvas below the Prepare hardware spec user task.

2. Click the new milestone and in the upper-right corner click the Properties  icon.

3. Input Milestone 1: Order placed in the Name field.

4. Expand Implementation/Execution and select Adhoc Autostart.

5. Expand Data Assignments, click  in the Assignments field, and add the following:

Click the Source column drop-down, select Constant, and input 
org.kie.api.runtime.process.CaseData(data.get("ordered") == true). This means that a case
variable named ordered exists with the value true.

6. Click Save.

7. Click Milestone 1: Order placed and create a new script task.
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8. Click the new script task and in the upper-right corner click the Properties  icon.

9. Input Notify requestor in the Name field.

10. Expand Implementation/Execution and input System.out.println("Notification::Order 
placed");.

11. Click the Notify requestor script task and create a signal end event.

12. Click the signal event and in the upper-right corner click the Properties.  icon.

13. Expand Implementation/Execution, click the down arrow in the Signal field, and select New.

14. Input Milestone 2: Order shipped.

15. Click the down arrow in the Signal Scope field, select Process Instance.

16. Click Save.

Figure 7.1. Order placed milestone

7.4. CREATING THE ORDER SHIPPED MILESTONE
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The condition for this milestone is that a case file variable named shipped is true. Adhoc autostart is
not enabled for this milestone. Instead, it is triggered by a signal event when the order is ready to be
sent.

Procedure

1. In the process designer, expand Milestone in the Object Library and drag a new milestone on
the canvas below the Notify requestor script task.

2. Click the new milestone and in the upper-right corner click the Properties  icon.

3. Input Milestone 2: Order shipped in the Name field.

4. Expand Implementation/Execution and ensure that Adhoc Autostart is not selected.

5. Expand Data Assignments, click  in the Assignments field, and add the following:

Click the Source column drop-down, select Constant, and input 
org.kie.api.runtime.process.CaseData(data.get("shipped") == true). This means that a case
variable named shipped exists with the value true.

6. Click Save.

7. Click Milestone 2: Order shipped and create a new script task.

8. Click the new script task and in the upper-right corner click the Properties  icon.

9. Input Send to tracking system in the Name field.

10. Expand Implementation/Execution and input System.out.println("Order added to tracking 
system");.

11. Click the Send to tracking system script task and create a signal end event.

12. Click the signal event and in the upper-right corner click the Properties.  icon.

13. Expand Implementation/Execution, click the down arrow in the Signal field, and select New.
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14. Input Milestone 3: Delivered to customer.

15. Click the down arrow in the Signal Scope field, select Process Instance.

16. Click Save.

Figure 7.2. Order shipped milestone

7.5. CREATING THE DELIVERED TO CUSTOMER MILESTONE

The condition for this milestone is that a case file variable named delivered is true. Adhoc autostart is
not enabled for this milestone. Instead, it is triggered by a signal event after the order has successfully
shipped to the customer.

Procedure

1. In the process designer, expand Milestone in the Object Library and drag a new milestone on
the canvas below the Send to tracking system script task.

2. Click the new milestone and in the upper-right corner click the Properties  icon.

3. Input Milestone 3: Delivered to customer in the Name field.

4. Expand Implementation/Execution and ensure that Adhoc Autostart is not selected.

5. Expand Data Assignments, click  in the Assignments field, and add the following:

Click the Source column drop-down, select Constant, and input 
org.kie.api.runtime.process.CaseData(data.get("delivered") == true). This means that a case
variable named delivered exists with the value true.
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6. Click Save.

7. Click Milestone 3: Delivered to customer and create a new user task.

a. Click the new user task and in the upper-right corner click the Properties  icon.

b. Input Customer satisfaction survey in the Name field.

c. Expand Implementation/Execution, click Add below the Actors menu, click Select →
New, and input owner.

d. Input CustomerSurvey in the Task Name field.

e. Select the Skippable check box and enter the following text in the in the Description field:
Satisfaction survey for order #{CaseId}

f. Click  in the Assignments field and add the following:

g. Click Save.

8. Click the Customer satisfaction survey user task and create an end event.

9. Click Save to confirm your changes.

Figure 7.3. Delivered to customer milestone

The IT Orders case can be closed after all milestone sequences are completed. However, due to the ad
hoc nature of cases, the case could be reopened if, for example, the order was never received by the
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customer or the item is faulty. Tasks can be re-triggered or added to the case definition as required,
even during run time.
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CHAPTER 8. DEPLOYING AND TESTING THE IT ORDER CASE
PROJECT

Prerequisites

You have a running KIE Server instance connected to Business Central. For more information
see Installing and configuring Red Hat Process Automation Manager on Red Hat JBoss EAP 7.2 .

You have created a new case in Business Central. For more information, see Chapter 4,
Creating a new IT_Orders case project .

You have created the data objects. For more information, see Chapter 5, Data objects.

You have created the Place order subprocess. For more information, see Section 6.1, “Creating
the Place order subprocess”.

You have designed the Order for IT hardware case. For more information, see Chapter 6,
Designing the case definition .

Procedure

1. In Business Central, go to Menu → Design → Projects and click IT_Orders_New.

2. Click Deploy.

3. Go to Menu → Manage → Process Definitions → Manage Process Instances → New Process
Instance.

4. Go to Menu → Deploy and click Execution Servers and verify that a new container is deployed
and started.

5. Use the Case Management Showcase application to start a new case instance. For instructions
about using the Showcase application, see Using the Showcase application for case
management.
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CHAPTER 9. ADDITIONAL RESOURCES
Designing and building cases for case management

Using the Showcase application for case management

Getting started with business processes
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Documentation last updated on Monday, May 25, 2020.
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