Chapter 1. Introduction

This document provides a workflow to help keep your Red Hat OpenStack Platform 16.1 environment updated with the latest packages and containers.

This guide provides an upgrade path through the following versions:

Old OpenStack VersionNew OpenStack Version

Red Hat OpenStack Platform 16.0

Red Hat OpenStack Platform 16.1.z

Red Hat OpenStack Platform 16.1

Red Hat OpenStack Platform 16.1.z

1.1. High level workflow

The following table provides an outline of the steps required for the upgrade process:

StepDescription

Updating the undercloud

Update the undercloud to the latest OpenStack Platform 16.1.z version.

Updating the overcloud

Update the overcloud to the latest OpenStack Platform 16.1.z version.

Updating the Ceph Storage nodes

Upgrade all Ceph Storage services.

Finalize the upgrade

Run the convergence command to refresh your overcloud stack.

1.2. Known issues that might block an update

Review the following known issues that might affect a successful minor version update.

BZ#1973660 - (update) from 16.1 to 16.2 breaks trying to configure the rabbitmq service.

Overcloud nodes that run Pacemaker version 2.0.3-5.el8_2.4 might fail to update successfully because of a race condition that occurs when shutting down the cluster on a node.

If Pacemaker version 2.0.3-5.el8_2.4 is currently installed on any of the overcloud nodes, to avoid BZ#1973660, you must upgrade Pacemaker before you can update the overcloud nodes. For more information, see the following Red Hat Knowledgebase solution Update from OSP16.1 to OSP16.2 might fail to update certain HA containers.

BZ#1872404 - restarting nodes in parallel while maintaining quorum creates an unexpected node shutdown
Until this issue is resolved, for nodes based on composable roles, you must update the Database role first, before you can update Controller, Messaging, Compute, Ceph, and other roles.