Red Hat OpenShift Data Foundation 4.11

Deploying OpenShift Data Foundation using Red Hat Virtualization platform

Instructions on deploying OpenShift Data Foundation on Red Hat Virtualization Platform
Abstract

Read this document for instructions about how to install Red Hat OpenShift Data Foundation using Red Hat OpenShift Container Platform on Red Hat Virtualization platform.
Table of Contents

MAKING OPEN SOURCE MORE INCLUSIVE .................................................. 3
PROVIDING FEEDBACK ON RED HAT DOCUMENTATION .................................. 4
PREFACE ............................................................................................... 5

CHAPTER 1. PREPARING TO DEPLOY OPENSHEET DATA FOUNDATION USING RED HAT VIRTUALIZATION PLATFORM .................................................. 6
  1.1. REQUIREMENTS FOR INSTALLING OPENSHEET DATA FOUNDATION USING LOCAL STORAGE DEVICES ................................................................. 6

CHAPTER 2. DEPLOY USING DYNAMIC STORAGE DEVICES ................................................. 8
  2.1. INSTALLING RED HAT OPENSHEET DATA FOUNDATION OPERATOR ...................... 8
  2.2. ENABLING CLUSTER-WIDE ENCRYPTION WITH KMS USING THE TOKEN AUTHENTICATION METHOD ................................................................. 9
  2.3. ENABLING CLUSTER-WIDE ENCRYPTION WITH KMS USING THE KUBERNETES AUTHENTICATION METHOD ...................................................... 10
  2.4. CREATING AN OPENSHEET DATA FOUNDATION CLUSTER .................................. 13

CHAPTER 3. DEPLOY USING LOCAL STORAGE DEVICES .................................................. 16
  3.1. INSTALLING LOCAL STORAGE OPERATOR .................................................... 16
  3.2. INSTALLING RED HAT OPENSHEET DATA FOUNDATION OPERATOR ................. 16
  3.3. CREATING OPENSHEET DATA FOUNDATION CLUSTER ON RED HAT VIRTUALIZATION PLATFORM ............................................................ 18

CHAPTER 4. VERIFYING OPENSHEET DATA FOUNDATION DEPLOYMENT .................... 22
  4.1. VERIFYING THE STATE OF THE PODS .......................................................... 22
  4.2. VERIFYING THE OPENSHEET DATA FOUNDATION CLUSTER IS HEALTHY ............ 24
  4.3. VERIFYING THE MULTICLOUD OBJECT GATEWAY IS HEALTHY ......................... 24
  4.4. VERIFYING THAT THE OPENSHEET DATA FOUNDATION SPECIFIC STORAGE CLASSES EXIST .................................................................................. 24

CHAPTER 5. DEPLOY STANDALONE MULTICLOUD OBJECT GATEWAY ......................... 26
  5.1. DEPLOY STANDALONE MULTICLOUD OBJECT GATEWAY USING DYNAMIC STORAGE DEVICES ................................................................. 26
    5.1.1. Installing Red Hat OpenShift Data Foundation Operator ................................ 26
    5.1.2. Creating a standalone Multicloud Object Gateway ...................................... 27
  5.2. DEPLOY STANDALONE MULTICLOUD OBJECT GATEWAY USING LOCAL STORAGE DEVICES ................................................................. 29
    5.2.1. Installing Local Storage Operator .................................................................. 29
    5.2.2. Installing Red Hat OpenShift Data Foundation Operator ............................ 30
    5.2.3. Creating a standalone Multicloud Object Gateway ...................................... 31

CHAPTER 6. UNINSTALLING OPENSHEET DATA FOUNDATION ....................................... 35
  6.1. UNINSTALLING OPENSHEET DATA FOUNDATION IN INTERNAL MODE .............. 35
MAKING OPEN SOURCE MORE INCLUSIVE

Red Hat is committed to replacing problematic language in our code, documentation, and web properties. We are beginning with these four terms: master, slave, blacklist, and whitelist. Because of the enormity of this endeavor, these changes will be implemented gradually over several upcoming releases. For more details, see our CTO Chris Wright’s message.
PROVIDING FEEDBACK ON RED HAT DOCUMENTATION

We appreciate your input on our documentation. Do let us know how we can make it better. To give feedback:

- For simple comments on specific passages:
  1. Make sure you are viewing the documentation in the *Multi-page HTML* format. In addition, ensure you see the **Feedback** button in the upper right corner of the document.
  2. Use your mouse cursor to highlight the part of text that you want to comment on.
  3. Click the **Add Feedback** pop-up that appears below the highlighted text.
  4. Follow the displayed instructions.

- For submitting more complex feedback, create a Bugzilla ticket:
  1. Go to the **Bugzilla** website.
  2. In the **Component** section, choose **documentation**.
  3. Fill in the **Description** field with your suggestion for improvement. Include a link to the relevant part(s) of documentation.
  4. Click **Submit Bug**.
Red Hat OpenShift Data Foundation supports deployment on existing Red Hat OpenShift Container Platform (RHOCP) Red Hat Virtualization platform clusters.

Deploying OpenShift Data Foundation on OpenShift Container Platform using shared storage devices provided by Red Hat Virtualization installer-provisioned infrastructure (IPI) enables you to create internal cluster resources.

Also, it is possible to deploy only the Multicloud Object Gateway (MCG) component with OpenShift Data Foundation.

NOTE

Only internal OpenShift Data Foundation clusters are supported on Red Hat Virtualization platform. See Planning your deployment for more information about deployment requirements.

Based on your requirement, perform one of the following methods of deployment:

- **Deploy using dynamic storage devices** for the full deployment of OpenShift Data Foundation using dynamic storage devices.

- **Deploy using local storage devices** for the full deployment of OpenShift Data Foundation using local storage devices.

- **Deploy standalone Multicloud Object Gateway component** for deploying only the Multicloud Object Gateway component with OpenShift Data Foundation.
CHAPTER 1. PREPARING TO DEPLOY OPENSOURCE DATA FOUNDATION USING RED HAT VIRTUALIZATION PLATFORM

Before you begin the deployment of Red Hat OpenShift Data Foundation using dynamic or local storage, ensure that your resource requirements are met. See Planning your deployment.

1. Optional: If you want to enable cluster-wide encryption using an external Key Management System (KMS) then follow the steps:
   - Ensure that you have a valid Red Hat OpenShift Data Foundation Advanced subscription. To know how subscriptions for OpenShift Data Foundation work, see knowledgebase article on OpenShift Data Foundation subscriptions.
   - When the Token authentication method is selected for encryption then refer to Enabling cluster-wide encryption with the Token authentication using KMS.
   - When the Kubernetes authentication method is selected for encryption then refer to Enabling cluster-wide encryption with the Kubernetes authentication using KMS.
   - Ensure that you are using signed certificates on your Vault servers.

2. Minimum starting node requirements
   An OpenShift Data Foundation cluster will be deployed with minimum configuration when the standard deployment resource requirement is not met. See Resource requirements section in Planning guide.

3. Disaster recovery requirements [Developer Preview]
   Disaster Recovery features supported by Red Hat OpenShift Data Foundation require all of the following prerequisites to successfully implement a disaster recovery solution:
   - A valid Red Hat OpenShift Data Foundation Advanced subscription
   - A valid Red Hat Advanced Cluster Management for Kubernetes subscription
   To know how subscriptions for OpenShift Data Foundation work, see knowledgebase article on OpenShift Data Foundation subscriptions.

   For detailed requirements, see Configuring OpenShift Data Foundation Disaster Recovery for OpenShift Workloads guide, and Requirements and recommendations section of the Install guide in Red Hat Advanced Cluster Management for Kubernetes documentation.

4. Ensure that the requirements for installing OpenShift Data Foundation using local storage devices are met.

1.1. REQUIREMENTS FOR INSTALLING OPENSOURCE DATA FOUNDATION USING LOCAL STORAGE DEVICES

Node requirements
The cluster must consist of at least three OpenShift Container Platform worker nodes with locally attached-storage devices on each of them.

- Each of the three selected nodes must have at least one raw block device available. OpenShift Data Foundation uses the one or more available raw block devices.
The devices you use must be empty, the disks must not include Physical Volumes (PVs), Volume Groups (VGs), or Logical Volumes (LVs) remaining on the disk.

For more information, see the Resource requirements section in the Planning guide.

Disaster recovery requirements [Developer Preview]

Disaster Recovery features supported by Red Hat OpenShift Data Foundation require all of the following prerequisites to successfully implement a disaster recovery solution:

- A valid Red Hat OpenShift Data Foundation Advanced subscription.
- A valid Red Hat Advanced Cluster Management (RHACM) for Kubernetes subscription.

To know in detail how subscriptions for OpenShift Data Foundation work, see knowledgebase article on OpenShift Data Foundation subscriptions.

For detailed disaster recovery solution requirements, see Configuring OpenShift Data Foundation Disaster Recovery for OpenShift Workloads guide, and Requirements and recommendations section of the Install guide in Red Hat Advanced Cluster Management for Kubernetes documentation.

Arbiter stretch cluster requirements [Technology Preview]

In this case, a single cluster is stretched across two zones with a third zone as the location for the arbiter. This is a Technology Preview feature that is currently intended for deployment in the OpenShift Container Platform on-premises.

For detailed requirements and instructions, see the Knowledgebase article on Configuring OpenShift Data Foundation for stretch cluster.

To know in detail how subscriptions for OpenShift Data Foundation work, see knowledgebase article on OpenShift Data Foundation subscriptions.

NOTE

You cannot enable Flexible scaling and Arbiter both at the same time as they have conflicting scaling logic. With Flexible scaling, you can add one node at a time to your OpenShift Data Foundation cluster. Whereas, in an Arbiter cluster, you need to add at least one node in each of the two data zones.

Minimum starting node requirements

An OpenShift Data Foundation cluster is deployed with a minimum configuration when the resource requirement for a standard deployment is not met.

For more information, see the Resource requirements section in the Planning guide.
CHAPTER 2. DEPLOY USING DYNAMIC STORAGE DEVICES

Deploying OpenShift Data Foundation on OpenShift Container Platform using dynamic storage devices provided by Red Hat Virtualization gives you the option to create internal cluster resources. This results in the internal provisioning of the base services, which helps to make additional storage classes available to applications.

Ensure that you have addressed the requirements in Preparing to deploy OpenShift Data Foundation chapter before proceeding with the below steps for deploying using dynamic storage devices:

1. Install the Red Hat OpenShift Data Foundation Operator.
2. Create the OpenShift Data Foundation Cluster.

2.1. INSTALLING RED HAT OPENSHIFT DATA FOUNDATION OPERATOR

You can install Red Hat OpenShift Data Foundation Operator using the Red Hat OpenShift Container Platform Operator Hub.

Prerequisites

- Access to an OpenShift Container Platform cluster using an account with cluster-admin and operator installation permissions.
- You must have at least three worker nodes in the Red Hat OpenShift Container Platform cluster.
- For additional resource requirements, see the Planning your deployment guide.

IMPORTANT

- When you need to override the cluster-wide default node selector for OpenShift Data Foundation, you can use the following command to specify a blank node selector for the openshift-storage namespace (create openshift-storage namespace in this case):
  
  ```
  $ oc annotate namespace openshift-storage openshift.io/node-selector=
  
  ```

- Taint a node as infra to ensure only Red Hat OpenShift Data Foundation resources are scheduled on that node. This helps you save on subscription costs. For more information, see the How to use dedicated worker nodes for Red Hat OpenShift Data Foundation section in the Managing and Allocating Storage Resources guide.

Procedure

1. Log in to the OpenShift Web Console.
2. Click Operators → OperatorHub.
3. Scroll or type OpenShift Data Foundation into the Filter by keyword box to find the OpenShift Data Foundation Operator.
4. Click **Install**.

5. Set the following options on the **Install Operator** page:
   
a. Update Channel as **stable-4.11**.

b. Installation Mode as **A specific namespace on the cluster**

c. Installed Namespace as **Operator recommended namespace openshift-storage**. If Namespace **openshift-storage** does not exist, it is created during the operator installation.

d. Select Approval Strategy as **Automatic** or **Manual**.
   
   If you select **Automatic** updates, then the Operator Lifecycle Manager (OLM) automatically upgrades the running instance of your Operator without any intervention.

   If you select **Manual** updates, then the OLM creates an update request. As a cluster administrator, you must then manually approve that update request to update the Operator to a newer version.

e. Ensure that the **Enable** option is selected for the **Console plugin**.

f. Click **Install**.

**Verification steps**

- Verify that the **OpenShift Data Foundation** Operator shows a green tick indicating successful installation.

- **After the operator is successfully installed, a pop-up with a message, Web console update is available** appears on the user interface. Click **Refresh web console** from this pop-up for the console changes to reflect.

- In the Web Console, navigate to **Operators** and verify if **OpenShift Data Foundation** is available.

**2.2. ENABLING CLUSTER-WIDE ENCRYPTION WITH KMS USING THE TOKEN AUTHENTICATION METHOD**

You can enable the key value backend path and policy in the vault for token authentication.

**Prerequisites**

- Administrator access to the vault.

- A valid Red Hat OpenShift Data Foundation Advanced subscription. For more information, see the knowledgebase article on OpenShift Data Foundation subscriptions.

- Carefully, select a unique path name as the backend **path** that follows the naming convention since you cannot change it later.

**Procedure**

1. Enable the Key/Value (KV) backend path in the vault.
   For vault KV secret engine API, version 1:
$ vault secrets enable -path=odf kv

For vault KV secret engine API, version 2:

$ vault secrets enable -path=odf kv-v2

2. Create a policy to restrict the users to perform a write or delete operation on the secret:

```bash
echo 'path "odf/**" {
capabilities = ["create", "read", "update", "delete", "list"]
}
path "sys/mounts" {
capabilities = ["read"]
}' | vault policy write odf -
```

3. Create a token that matches the above policy:

$ vault token create -policy=odf -format json

2.3. ENABLING CLUSTER-WIDE ENCRYPTION WITH KMS USING THE KUBERNETES AUTHENTICATION METHOD

You can enable the Kubernetes authentication method for cluster-wide encryption using the Key Management System (KMS).

Prerequisites

- Administrator access to Vault.
- A valid Red Hat OpenShift Data Foundation Advanced subscription. For more information, see the knowledgebase article on OpenShift Data Foundation subscriptions.
- The OpenShift Data Foundation operator must be installed from the Operator Hub.
- Select a unique path name as the backend path that follows the naming convention carefully. You cannot change this path name later.

**NOTE**

Use of Vault namespaces are not supported with the Kubernetes authentication method in OpenShift Data Foundation 4.11.

Procedure

1. Create a service account:

   $ oc -n openshift-storage create serviceaccount <serviceaccount_name>

   where, `<serviceaccount_name>` specifies the name of the service account.

   For example:
   -
$ oc -n openshift-storage create serviceaccount odf-vault-auth

2. Create `clusterrolebindings` and `clusterroles`:

   $ oc -n openshift-storage create clusterrolebinding vault-tokenreview-binding --
   clusterrole=system:auth-delegator --serviceaccount=openshift-
   storage:_.<serviceaccount_name>_.

   For example:

   $ oc -n openshift-storage create clusterrolebinding vault-tokenreview-binding --
   clusterrole=system:auth-delegator --serviceaccount=openshift-storage:odf-vault-auth

3. Create a secret for the `serviceaccount` token and CA certificate.

   $ cat <<EOF | oc create -f -
   apiVersion: v1
   kind: Secret
   metadata:
   name: odf-vault-auth-token
   namespace: openshift-storage
   annotations:
   kubernetes.io/service-account.name: <serviceaccount_name>
   type: kubernetes.io/service-account-token
   data: {}
   EOF

   where, `<serviceaccount_name>` is the service account created in the earlier step.

4. Get the token and the CA certificate from the secret.

   $ SA_JWT_TOKEN=$(oc -n openshift-storage get secret odf-vault-auth-token -o jsonpath="
   {.data['token']}'" | base64 --decode; echo)
   $ SA_CA_CRT=$(oc -n openshift-storage get secret odf-vault-auth-token -o jsonpath="
   {.data['ca.crt']}'" | base64 --decode; echo)

5. Retrieve the OCP cluster endpoint.

   $ OCP_HOST=$(oc config view --minify --flatten -o jsonpath="{.clusters[0].cluster.server}")

6. Fetch the service account issuer:

   $ oc proxy &
   $ proxy_pid=$!
   $ issuer="$(curl --silent http://127.0.0.1.8001/.well-known/openid-configuration |
   jq -r .issuer)"
   $ kill $proxy_pid

7. Use the information collected in the previous step to setup the Kubernetes authentication
   method in Vault:

   $ vault auth enable kubernetes
$ vault write auth/kubernetes/config \
  token_reviewer_jwt="$SA_JWT_TOKEN" \
  kubernetes_host="$OCP_HOST" \
  kubernetes_ca_cert="$SA_CA_CRT" \
  issuer="$issuer"

**IMPORTANT**

To configure the Kubernetes authentication method in Vault when the issuer is empty:

$ vault write auth/kubernetes/config \
  token_reviewer_jwt="$SA_JWT_TOKEN" \
  kubernetes_host="$OCP_HOST" \
  kubernetes_ca_cert="$SA_CA_CRT"

8. Enable the Key/Value (KV) backend path in Vault.
   For Vault KV secret engine API, version 1:

   $ vault secrets enable -path=odf kv

   For Vault KV secret engine API, version 2:

   $ vault secrets enable -path=odf kv-v2

9. Create a policy to restrict the users to perform a **write** or **delete** operation on the secret:

   ```
   echo 'path "odf/*/" {
     capabilities = ["create", "read", "update", "delete", "list"]
   }
   path "sys/mounts" {
     capabilities = ["read"]
   }' | vault policy write odf -
   ```

10. Generate the roles:

    $ vault write auth/kubernetes/role/odf-rook-ceph-op \
        bound_service_account_names=rook-ceph-system,rook-ceph-osd,noobaa \
        bound_service_account_namespaces=openshift-storage \
        policies=odf \
        ttl=1440h

    The role **odf-rook-ceph-op** is later used while you configure the KMS connection details during the creation of the storage system.

    $ vault write auth/kubernetes/role/odf-rook-ceph-osd \
        bound_service_account_names=rook-ceph-osd \
        bound_service_account_namespaces=openshift-storage \
        policies=odf \
        ttl=1440h
2.4. CREATING AN OPENS SHIFT DATA FOUNDATION CLUSTER

Create an OpenShift Data Foundation cluster after you install the OpenShift Data Foundation operator.

Prerequisites

- The OpenShift Data Foundation operator must be installed from the Operator Hub. For more information, see Installing OpenShift Data Foundation Operator

Procedure

1. In the OpenShift Web Console, click **Operators → Installed Operators** to view all the installed operators. Ensure that the **Project** selected is **openshift-storage**.

2. Click on the **OpenShift Data Foundation** operator, and then click **Create StorageSystem**.

3. In the **Backing storage** page, select the following:
   a. Select **Full Deployment** for the **Deployment type** option.
   b. Select the **Use an existing StorageClass** option.
   c. Click **Next**.

4. In the **Capacity and nodes** page, provide the necessary information:
   a. Select a value for **Requested Capacity** from the dropdown list. It is set to **2 TiB** by default.

   **NOTE**
   
   Once you select the initial storage capacity, cluster expansion is performed only using the selected usable capacity (three times of raw storage).
   
   b. In the **Select Nodes** section, select at least three available nodes.
   c. Optional: Select the **Taint nodes** checkbox to dedicate the selected nodes for OpenShift Data Foundation.
   d. Click **Next**.

5. Optional: In the **Security and network** page, configure the following based on your requirements:
   a. To enable encryption, select **Enable data encryption for block and file storage**
   b. Select either one or both the encryption levels:

   - **Cluster-wide encryption**
     Encrypts the entire cluster (block and file).
   - **StorageClass encryption**
     Creates encrypted persistent volume (block only) using encryption enabled storage class.
c. Select the **Connect to an external key management service** checkbox. This is optional for cluster-wide encryption.

i. **Key Management Service Provider** is set to **Vault** by default.

ii. Select an **Authentication Method**.

Using **Token authentication method**

- Enter a unique **Connection Name**, host **Address** of the Vault server (`https://<hostname or ip>`), **Port** number and **Token**.

- Expand **Advanced Settings** to enter additional settings and certificate details based on your **Vault** configuration:
  
  o Enter the Key Value secret path in **Backend Path** that is dedicated and unique to OpenShift Data Foundation.

  o Optional: Enter **TLS Server Name** and **Vault Enterprise Namespace**

  o Upload the respective PEM encoded certificate file to provide the **CA Certificate**, **Client Certificate** and **Client Private Key**.

  o Click **Save**.

Using **Kubernetes authentication method**

- Enter a unique Vault **Connection Name**, host **Address** of the Vault server (`https://<hostname or ip>`), **Port** number and **Role** name.

- Expand **Advanced Settings** to enter additional settings and certificate details based on your **Vault** configuration:

  o Enter the Key Value secret path in **Backend Path** that is dedicated and unique to OpenShift Data Foundation.

  o Optional: Enter **TLS Server Name** and **Authentication Path** if applicable.

  o Upload the respective PEM encoded certificate file to provide the **CA Certificate**, **Client Certificate** and **Client Private Key**.

  o Click **Save**.

d. Click **Next**.

6. In the **Review and create** page, review the configuration details.
   To modify any configuration settings, click **Back**.

7. Click **Create StorageSystem**.

**Verification steps**

- To verify the final Status of the installed storage cluster:

  a. In the OpenShift Web Console, navigate to **Installed Operators → OpenShift Data Foundation → Storage System → ocs-storagecluster-storagesystem → Resources**.
b. Verify that **Status** of **StorageCluster** is **Ready** and has a green tick mark next to it.

- To verify that all the components for OpenShift Data Foundation are successfully installed, see **Verifying OpenShift Data Foundation deployment**.

**Additional resources**

To enable Overprovision Control alerts, refer to **Alerts** in Monitoring guide.
CHAPTER 3. DEPLOY USING LOCAL STORAGE DEVICES

Deploying OpenShift Data Foundation on OpenShift Container Platform using local storage devices provides you with the option to create internal cluster resources. This results in the internal provisioning of the base services, which helps to make additional storage classes available to applications.

Use this section to deploy OpenShift Data Foundation on Red Hat Virtualization where OpenShift Container Platform is already installed.

Also, ensure that you have addressed the requirements in Preparing to deploy OpenShift Data Foundation chapter before proceeding with the next steps.

1. Installing Local Storage Operator
2. Install the Red Hat OpenShift Data Foundation Operator.
3. Create the OpenShift Data Foundation Cluster.

3.1. INSTALLING LOCAL STORAGE OPERATOR

Install the Local Storage Operator from the Operator Hub before creating Red Hat OpenShift Data Foundation clusters on local storage devices.

Procedure

1. Log in to the OpenShift Web Console.
2. Click Operators → OperatorHub.
3. Type local storage in the Filter by keyword box to find the Local Storage Operator from the list of operators, and click on it.
4. Set the following options on the Install Operator page:
   a. Update channel as either 4.11 or stable.
   b. Installation mode as A specific namespace on the cluster
   c. Installed Namespace as Operator recommended namespace openshift-local-storage.
   d. Update approval as Automatic.
5. Click Install.

Verification steps

- Verify that the Local Storage Operator shows a green tick indicating successful installation.

3.2. INSTALLING RED HAT OPENSIGHT DATA FOUNDATION OPERATOR

You can install Red Hat OpenShift Data Foundation Operator using the Red Hat OpenShift Container Platform Operator Hub.
Prerequisites

- Access to an OpenShift Container Platform cluster using an account with `cluster-admin` and operator installation permissions.
- You must have at least three worker nodes in the Red Hat OpenShift Container Platform cluster.
- For additional resource requirements, see the Planning your deployment guide.

**IMPORTANT**

- When you need to override the cluster-wide default node selector for OpenShift Data Foundation, you can use the following command to specify a blank node selector for the `openshift-storage` namespace (create `openshift-storage` namespace in this case):

  ```bash
  $ oc annotate namespace openshift-storage openshift.io/node-selector=
  
  - Taint a node as `infra` to ensure only Red Hat OpenShift Data Foundation resources are scheduled on that node. This helps you save on subscription costs. For more information, see the How to use dedicated worker nodes for Red Hat OpenShift Data Foundation section in the Managing and Allocating Storage Resources guide.

Procedure

1. Log in to the OpenShift Web Console.
2. Click **Operators → OperatorHub.**
3. Scroll or type **OpenShift Data Foundation** into the **Filter by keyword** box to find the **OpenShift Data Foundation** Operator.
4. Click **Install.**
5. Set the following options on the **Install Operator** page:
   a. Update Channel as **stable-4.11.**
   b. Installation Mode as **A specific namespace on the cluster**
   c. Installed Namespace as **Operator recommended namespace openshift-storage.** If Namespace `openshift-storage` does not exist, it is created during the operator installation.
   d. Select Approval Strategy as **Automatic** or **Manual.**
      If you select **Automatic** updates, then the Operator Lifecycle Manager (OLM) automatically upgrades the running instance of your Operator without any intervention.
      If you select **Manual** updates, then the OLM creates an update request. As a cluster administrator, you must then manually approve that update request to update the Operator to a newer version.
   e. Ensure that the **Enable** option is selected for the **Console plugin.**
   f. Click **Install.**
Verification steps

- Verify that the OpenShift Data Foundation Operator shows a green tick indicating successful installation.

- After the operator is successfully installed, a pop-up with a message, Web console update is available appears on the user interface. Click Refresh web console from this pop-up for the console changes to reflect.
  - In the Web Console, navigate to Operators and verify if OpenShift Data Foundation is available.

3.3. CREATING OPENSIGHT DATA FOUNDATION CLUSTER ON RED HAT VIRTUALIZATION PLATFORM

Use this procedure to create an OpenShift Data Foundation Cluster using local storage devices after you install the OpenShift Data Foundation operator.

Prerequisites

- The OpenShift Data Foundation operator must be installed from the Operator Hub. For more information, see Installing OpenShift Data Foundation Operator.
- Ensure that all the requirements in the Requirements for installing OpenShift Data Foundation using local storage devices section are met.

Procedure

1. In the OpenShift Web Console, click Operators → Installed Operators to view all the installed operators.
   Ensure that the Project selected is openshift-storage.

2. Click on the OpenShift Data Foundation operator and then click Create StorageSystem.

3. In the Backing storage page, perform the following:
   a. Select Full Deployment for the Deployment type option.
   b. Select the Create a new StorageClass using the local storage devices option.
   c. Click Next.

   **NOTE**
   You are prompted to install the Local Storage Operator if it is not already installed. Click Install and follows procedure as described in Installing Local Storage Operator.

4. In the Create local volume set page, provide the following information:
   a. Enter a name for the LocalVolumeSet and the StorageClass.
      By default, the local volume set name appears for the storage class name. You can change the name.
   b. Choose one of the following:
• **Disks on all nodes** to use the available disks that match the selected filters on all nodes.

• **Disks on selected nodes** to use the available disks that match the selected filters only on selected nodes.

**IMPORTANT**

- The flexible scaling feature is enabled only when the storage cluster that you created with 3 or more nodes are spread across fewer than the minimum requirement of 3 availability zones. For information about flexible scaling, see *Add capacity using YAML* section in Scaling Storage guide.

- If the nodes selected do not match the OpenShift Data Foundation cluster requirement of an aggregated 30 CPUs and 72 GiB of RAM, a minimal cluster is deployed. For minimum starting node requirements, see *Resource requirements* section in Planning guide.

c. From the available list of **Disk Type**, select **SSD/NVMe**.

d. Expand the **Advanced** section and set the following options:

<table>
<thead>
<tr>
<th>Volume Mode</th>
<th>Block is selected by default.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device Type</td>
<td>Select one or more device type from the dropdown list.</td>
</tr>
<tr>
<td>Disk Size</td>
<td>Set a minimum size of 100GB for the device and maximum available size of the device that needs to be included.</td>
</tr>
<tr>
<td>Maximum Disks Limit</td>
<td>This indicates the maximum number of PVs that can be created on a node. If this field is left empty, then PVs are created for all the available disks on the matching nodes.</td>
</tr>
</tbody>
</table>

e. Click **Next**.

A pop-up to confirm the creation of LocalVolumeSet is displayed.

f. Click **Yes** to continue.

1. In the **Capacity and nodes page**, configure the following:

   a. **Available raw capacity** is populated with the capacity value based on all the attached disks associated with the storage class. This takes some time to show up. The **Selected nodes** list shows the nodes based on the storage class.

   b. Optional: Select the **Taint nodes** checkbox to dedicate the selected nodes for OpenShift Data Foundation.

   c. Click **Next**.

2. Optional: In the Security and network page, configure the following based on your requirement:

   a. To enable encryption, select **Enable data encryption for block and file storage**
b. Choose one of the following **Encryption level**:

- **Cluster-wide encryption** to encrypt the entire cluster (block and file).
- **StorageClass encryption** to create encrypted persistent volume (block only) using encryption enabled storage class.

c. Select **Connect to an external key management service** checkbox. This is optional for cluster-wide encryption.

   i. **Key Management Service Provider** is set to **Vault** by default.
   
   ii. Select an **Authentication Method**.

      **Using Token authentication method**

      - Enter a unique **Connection Name**, host **Address** of the Vault server (`https://<hostname or ip>`), **Port** number and **Token**.

      - Expand **Advanced Settings** to enter additional settings and certificate details based on your **Vault** configuration:

        - Enter the Key Value secret path in **Backend Path** that is dedicated and unique to OpenShift Data Foundation.

        - Optional: Enter **TLS Server Name** and **Vault Enterprise Namespace**.

        - Upload the respective PEM encoded certificate file to provide the **CA Certificate**, **Client Certificate** and **Client Private Key**.

        - Click **Save**.

      **Using Kubernetes authentication method**

      - Enter a unique Vault **Connection Name**, host **Address** of the Vault server (`https://<hostname or ip>`), **Port** number and **Role** name.

      - Expand **Advanced Settings** to enter additional settings and certificate details based on your **Vault** configuration:

        - Enter the Key Value secret path in **Backend Path** that is dedicated and unique to OpenShift Data Foundation.

        - Optional: Enter **TLS Server Name** and **Authentication Path** if applicable.

        - Upload the respective PEM encoded certificate file to provide the **CA Certificate**, **Client Certificate** and **Client Private Key**.

        - Click **Save**.

a. Click **Next**.

1. In the Review and create page, review the configuration details.

   - To modify any configuration settings, click **Back** to go back to the previous configuration page.
2. Click **Create StorageSystem**.

**Verification steps**

- To verify the final Status of the installed storage cluster:
  
  a. In the OpenShift Web Console, navigate to **Installed Operators → OpenShift Data Foundation → Storage System → ocs-storagecluster-storagesystem → Resources**.
  
  b. Verify that **Status of StorageCluster is Ready** and has a green tick mark next to it.

- To verify if flexible scaling is enabled on your storage cluster, perform the following steps (for arbiter mode, flexible scaling is disabled):
  
  1. In the OpenShift Web Console, navigate to **Installed Operators → OpenShift Data Foundation → Storage System → ocs-storagecluster-storagesystem → Resources**.
  
  2. In the YAML tab, search for the keys **flexibleScaling in spec section and failureDomain in status section**. If **flexible scaling is true and failureDomain is set to host**, flexible scaling feature is enabled.

```yaml
spec:
  flexibleScaling: true
  […]
status:
  failureDomain: host
```

- To verify that all components for OpenShift Data Foundation are successfully installed, see **Verifying your OpenShift Data Foundation deployment**.

**Additional resources**

- To expand the capacity of the initial cluster, see **Scaling Storage**.
CHAPTER 4. VERIFYING OPENSOURCE DATA FOUNDATION DEPLOYMENT

Use this section to verify that OpenShift Data Foundation is deployed correctly.

4.1. VERIFYING THE STATE OF THE PODS

Procedure

1. Click Workloads → Pods from the OpenShift Web Console.

2. Select openshift-storage from the Project drop-down list.

   **NOTE**

   If the Show default projects option is disabled, use the toggle button to list all the default projects.

   For more information on the expected number of pods for each component and how it varies depending on the number of nodes, see Table 4.1, “Pods corresponding to OpenShift Data Foundation cluster”.

3. Click the Running and Completed tabs to verify that the following pods are in Running and Completed state:

<table>
<thead>
<tr>
<th>Component</th>
<th>Corresponding pods</th>
</tr>
</thead>
<tbody>
<tr>
<td>OpenShift Data Foundation Operator</td>
<td>• ocs-operator-* (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>• ocs-metrics-exporter-* (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>• odf-operator-controller-manager-* (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>• odf-console-* (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>• csi-addons-controller-manager-* (1 pod on any worker node)</td>
</tr>
<tr>
<td>Rook-ceph Operator</td>
<td>rook-ceph-operator-*</td>
</tr>
<tr>
<td></td>
<td>(1 pod on any worker node)</td>
</tr>
<tr>
<td>Component</td>
<td>Corresponding pods</td>
</tr>
<tr>
<td>----------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Multicloud Object Gateway  | ● noobaa-operator-\* (1 pod on any worker node)  
|                            | ● noobaa-core-\* (1 pod on any storage node)  
|                            | ● noobaa-db-pg-\* (1 pod on any storage node)  
|                            | ● noobaa-endpoint-\* (1 pod on any storage node)  |
|                            | **rook-ceph-mgr-\***  
|                            | (1 pod on any storage node)  |
|                            | **rook-ceph-mds-ocs-storagecluster-cephfilesystem-\***  
|                            | (2 pods distributed across storage nodes)  |
|                            | **rook-ceph-rgw-ocs-storagecluster-cephobjectstore-\***  
|                            | (1 pod on any storage node)  |
|                            | **rook-ceph-crashcollector-\***  
|                            | (1 pod on each storage node)  |
|                            | **rook-ceph-crashcollector-\***  
|                            | (1 pod on each storage node)  |
|                            | **rook-ceph-mgr-\***  
|                            | (1 pod on any storage node)  |
|                            | **rook-ceph-mds-ocs-storagecluster-cephfilesystem-\***  
|                            | (2 pods distributed across storage nodes)  |
|                            | **rook-ceph-rgw-ocs-storagecluster-cephobjectstore-\***  
|                            | (1 pod on any storage node)  |
|                            | **rook-ceph-crashcollector-\***  
|                            | (1 pod on each storage node)  |

**CSI**  

<table>
<thead>
<tr>
<th>Component</th>
<th>Corresponding pods</th>
</tr>
</thead>
<tbody>
<tr>
<td>cephfs</td>
<td></td>
</tr>
<tr>
<td></td>
<td>● csi-cephfsplugin-* (1 pod on each worker node)</td>
</tr>
<tr>
<td></td>
<td>● csi-cephfsplugin-provisioner-* (2 pods distributed across worker nodes)</td>
</tr>
<tr>
<td>rbd</td>
<td></td>
</tr>
<tr>
<td></td>
<td>● csi-rbdplugin-* (1 pod on each worker node)</td>
</tr>
<tr>
<td></td>
<td>● csi-rbdplugin-provisioner-* (2 pods distributed across worker nodes)</td>
</tr>
<tr>
<td>rook-ceph-crashcollector</td>
<td>rook-ceph-crashcollector-*</td>
</tr>
<tr>
<td></td>
<td>(1 pod on each storage node)</td>
</tr>
</tbody>
</table>
4.2. VERIFYING THE OPENSSHIFT DATA FOUNDATION CLUSTER IS HEALTHY

Procedure

1. In the OpenShift Web Console, click Storage → Data Foundation.
2. In the Status card of the Overview tab, click Storage System and then click the storage system link from the pop up that appears.
3. In the Status card of the Block and File tab, verify that Storage Cluster has a green tick.
4. In the Details card, verify that the cluster information is displayed.

For more information on the health of the OpenShift Data Foundation cluster using the Block and File dashboard, see Monitoring OpenShift Data Foundation.

4.3. VERIFYING THE MULTICLOUD OBJECT GATEWAY IS HEALTHY

Procedure

1. In the OpenShift Web Console, click Storage → Data Foundation.
2. In the Status card of the Overview tab, click Storage System and then click the storage system link from the pop up that appears.
   a. In the Status card of the Object tab, verify that both Object Service and Data Resiliency have a green tick.
   b. In the Details card, verify that the MCG information is displayed.

For more information on the health of the OpenShift Data Foundation cluster using the object service dashboard, see Monitoring OpenShift Data Foundation.

4.4. VERIFYING THAT THE OPENSSHIFT DATA FOUNDATION SPECIFIC STORAGE CLASSES EXIST

Procedure

1. Click Storage → Storage Classes from the left pane of the OpenShift Web Console.
2. Verify that the following storage classes are created with the OpenShift Data Foundation cluster creation:

<table>
<thead>
<tr>
<th>Component</th>
<th>Corresponding pods</th>
</tr>
</thead>
<tbody>
<tr>
<td>OSD</td>
<td>• rook-ceph-osd-* (1 pod for each device)</td>
</tr>
<tr>
<td></td>
<td>• rook-ceph-osd-prepare-ocs-deviceset-* (1 pod for each device)</td>
</tr>
</tbody>
</table>
- ocs-storagecluster-ceph-rbd
- ocs-storagecluster-cephfs
- openshift-storage.noobaa.io
- ocs-storagecluster-ceph-rgw
CHAPTER 5. DEPLOY STANDALONE MULTICLOUD OBJECT GATEWAY

Deploying only the Multicloud Object Gateway component with the OpenShift Data Foundation provides the flexibility in deployment and helps to reduce the resource consumption. You can deploy the Multicloud Object Gateway component either using dynamic storage devices or using the local storage devices.

5.1. DEPLOY STANDALONE MULTICLOUD OBJECT GATEWAY USING DYNAMIC STORAGE DEVICES

Use this section to deploy only the standalone Multicloud Object Gateway component, which involves the following steps:

- Installing Red Hat OpenShift Data Foundation Operator
- Creating standalone Multicloud Object Gateway

5.1.1. Installing Red Hat OpenShift Data Foundation Operator

You can install Red Hat OpenShift Data Foundation Operator using the Red Hat OpenShift Container Platform Operator Hub.

Prerequisites

- Access to an OpenShift Container Platform cluster using an account with `cluster-admin` and operator installation permissions.
- You must have at least three worker nodes in the Red Hat OpenShift Container Platform cluster.
- For additional resource requirements, see the Planning your deployment guide.

**IMPORTANT**

- When you need to override the cluster-wide default node selector for OpenShift Data Foundation, you can use the following command to specify a blank node selector for the `openshift-storage` namespace (create `openshift-storage` namespace in this case):

  ```bash
  $ oc annotate namespace openshift-storage openshift.io/node-selector=
  ```

- Taint a node as `infra` to ensure only Red Hat OpenShift Data Foundation resources are scheduled on that node. This helps you save on subscription costs. For more information, see the How to use dedicated worker nodes for Red Hat OpenShift Data Foundation section in the Managing and Allocating Storage Resources guide.

Procedure

1. Log in to the OpenShift Web Console.

2. Click **Operators → OperatorHub**.
3. Scroll or type **OpenShift Data Foundation** into the **Filter by keyword** box to find the **OpenShift Data Foundation** Operator.

4. Click **Install**.

5. Set the following options on the **Install Operator** page:
   a. Update Channel as **stable-4.11**.
   b. Installation Mode as **A specific namespace on the cluster**
   c. Installed Namespace as **Operator recommended namespace openshift-storage**. If Namespace **openshift-storage** does not exist, it is created during the operator installation.
   d. Select Approval Strategy as **Automatic** or **Manual**.
      If you select **Automatic** updates, then the Operator Lifecycle Manager (OLM) automatically upgrades the running instance of your Operator without any intervention.
      If you select **Manual** updates, then the OLM creates an update request. As a cluster administrator, you must then manually approve that update request to update the Operator to a newer version.
   e. Ensure that the **Enable** option is selected for the **Console plugin**.
   f. Click **Install**.

**Verification steps**

- Verify that the **OpenShift Data Foundation** Operator shows a green tick indicating successful installation.
- After the operator is successfully installed, a pop-up with a message, **Web console update is available** appears on the user interface. Click **Refresh web console** from this pop-up for the console changes to reflect.
  - In the Web Console, navigate to **Operators** and verify if **OpenShift Data Foundation** is available.

**5.1.2. Creating a standalone Multicloud Object Gateway**

You can create only the standalone Multicloud Object Gateway component while deploying OpenShift Data Foundation.

**Prerequisites**

- Ensure that the OpenShift Data Foundation Operator is installed.

**Procedure**

1. In the OpenShift Web Console, click **Operators → Installed Operators** to view all the installed operators.
   Ensure that the **Project** selected is **openshift-storage**.
2. Click **OpenShift Data Foundation** operator and then click **Create StorageSystem**.
3. In the **Backing storage** page, select the following:
a. Select Multicloud Object Gateway for Deployment type.
b. Select the Use an existing StorageClass option.
c. Click Next.

4. Optional: In the Security page, select Connect to an external key management service
   a. Key Management Service Provider is set to Vault by default.
   b. Enter Vault Service Name, host Address of Vault server ('https://<hostname or ip>'), Port number, and Token.
   c. Expand Advanced Settings to enter additional settings and certificate details based on your Vault configuration:
      i. Enter the Key Value secret path in the Backend Path that is dedicated and unique to OpenShift Data Foundation.
      ii. Optional: Enter TLS Server Name and Vault Enterprise Namespace.
      iii. Upload the respective PEM encoded certificate file to provide the CA Certificate, Client Certificate, and Client Private Key.
      iv. Click Save.
   d. Click Next.

5. In the Review and create page, review the configuration details:
   To modify any configuration settings, click Back.

6. Click Create StorageSystem.

Verification steps

Verifying that the OpenShift Data Foundation cluster is healthy
1. In the OpenShift Web Console, click Storage → Data Foundation.
2. In the Status card of the Overview tab, click Storage System and then click the storage system link from the pop up that appears.
   a. In the Status card of the Object tab, verify that both Object Service and Data Resiliency have a green tick.
   b. In the Details card, verify that the MCG information is displayed.

Verifying the state of the pods
1. Click Workloads → Pods from the OpenShift Web Console.
2. Select openshift-storage from the Project drop-down list and verify that the following pods are in Running state.
NOTE

If the Show default projects option is disabled, use the toggle button to list all the default projects.

<table>
<thead>
<tr>
<th>Component</th>
<th>Corresponding pods</th>
</tr>
</thead>
<tbody>
<tr>
<td>OpenShift Data Foundation Operator</td>
<td>• ocs-operator-* (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>• ocs-metrics-exporter-* (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>• odf-operator-controller-manager-* (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>• odf-console-* (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>• csi-addons-controller-manager-* (1 pod on any worker node)</td>
</tr>
<tr>
<td>Rook-ceph Operator</td>
<td>rook-ceph-operator-*</td>
</tr>
<tr>
<td></td>
<td>(1 pod on any worker node)</td>
</tr>
<tr>
<td>Multicloud Object Gateway</td>
<td>• noobaa-operator-* (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>• noobaa-core-* (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>• noobaa-db-pg-* (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>• noobaa-endpoint-* (1 pod on any worker node)</td>
</tr>
</tbody>
</table>

5.2. DEPLOY STANDALONE MULTICLOUD OBJECT GATEWAY USING LOCAL STORAGE DEVICES

Use this section to deploy only the standalone Multicloud Object Gateway component, which involves the following steps:

- Installing the Local Storage Operator
- Installing Red Hat OpenShift Data Foundation Operator
- Creating standalone Multicloud Object Gateway

5.2.1. Installing Local Storage Operator

Install the Local Storage Operator from the Operator Hub before creating Red Hat OpenShift Data Foundation clusters on local storage devices.

Procedure

1. Log in to the OpenShift Web Console.
2. Click Operators → OperatorHub.

3. Type local storage in the Filter by keyword box to find the Local Storage Operator from the list of operators, and click on it.

4. Set the following options on the Install Operator page:
   a. Update channel as either 4.11 or stable.
   b. Installation mode as A specific namespace on the cluster
   c. Installed Namespace as Operator recommended namespace openshift-local-storage.
   d. Update approval as Automatic.

5. Click Install.

Verification steps
- Verify that the Local Storage Operator shows a green tick indicating successful installation.

5.2.2. Installing Red Hat OpenShift Data Foundation Operator

You can install Red Hat OpenShift Data Foundation Operator using the Red Hat OpenShift Container Platform Operator Hub.

Prerequisites
- Access to an OpenShift Container Platform cluster using an account with cluster-admin and operator installation permissions.
- You must have at least three worker nodes in the Red Hat OpenShift Container Platform cluster.
- For additional resource requirements, see the Planning your deployment guide.

IMPORTANT
- When you need to override the cluster-wide default node selector for OpenShift Data Foundation, you can use the following command to specify a blank node selector for the openshift-storage namespace (create openshift-storage namespace in this case):

  $ oc annotate namespace openshift-storage openshift.io/node-selector=

- Taint a node as infra to ensure only Red Hat OpenShift Data Foundation resources are scheduled on that node. This helps you save on subscription costs. For more information, see the How to use dedicated worker nodes for Red Hat OpenShift Data Foundation section in the Managing and Allocating Storage Resources guide.

Procedure
1. Log in to the OpenShift Web Console.
2. Click **Operators → OperatorHub**.

3. Scroll or type **OpenShift Data Foundation** into the **Filter by keyword** box to find the **OpenShift Data Foundation** Operator.

4. Click **Install**.

5. Set the following options on the **Install Operator** page:
   
   a. **Update Channel** as **stable-4.11**.
   
   b. **Installation Mode** as **A specific namespace on the cluster**
   
   c. **Installed Namespace** as **Operator recommended namespace openshift-storage**. If Namespace **openshift-storage** does not exist, it is created during the operator installation.
   
   d. Select **Approval Strategy** as **Automatic** or **Manual**.
      
      If you select **Automatic** updates, then the Operator Lifecycle Manager (OLM) automatically upgrades the running instance of your Operator without any intervention.
      
      If you select **Manual** updates, then the OLM creates an update request. As a cluster administrator, you must then manually approve that update request to update the Operator to a newer version.
   
   e. Ensure that the **Enable** option is selected for the **Console plugin**.
   
   f. Click **Install**.

**Verification steps**

- Verify that the **OpenShift Data Foundation** Operator shows a green tick indicating successful installation.

- After the operator is successfully installed, a pop-up with a message, **Web console update is available** appears on the user interface. Click **Refresh web console** from this pop-up for the console changes to reflect.
   
   - In the Web Console, navigate to **Operators** and verify if **OpenShift Data Foundation** is available.

---

**5.2.3. Creating a standalone Multicloud Object Gateway**

You can create only the standalone Multicloud Object Gateway component while deploying OpenShift Data Foundation.

**Prerequisites**

- Ensure that the OpenShift Data Foundation Operator is installed.

**Procedure**

1. In the OpenShift Web Console, click **Operators → Installed Operators** to view all the installed operators. Ensure that the **Project** selected is **openshift-storage**.

2. Click **OpenShift Data Foundation** operator and then click **Create StorageSystem**.
3. In the **Backing storage** page, select the following:
   a. Select **Multicloud Object Gateway** for **Deployment type**
   b. Select the **Create a new StorageClass using the local storage devices** option.
   c. Click **Next**.

   **NOTE**
   You are prompted to install the Local Storage Operator if it is not already installed. Click **Install**, and follow the procedure as described in [Installing Local Storage Operator](#).

4. In the **Create local volume set** page, provide the following information:
   a. Enter a name for the **LocalVolumeSet** and the **StorageClass**. By default, the local volume set name appears for the storage class name. You can change the name.
   b. Choose one of the following:
      - **Disks on all nodes**
        Uses the available disks that match the selected filters on all the nodes.
      - **Disks on selected nodes**
        Uses the available disks that match the selected filters only on the selected nodes.
   c. From the available list of **Disk Type**, select **SSD/NVMe**.
   d. Expand the **Advanced** section and set the following options:

      | Volume Mode | Filesystem is selected by default. Always ensure that Filesystem is selected for Volume Mode. |
      |-------------|-------------------------------------------------------------------------------------------------|
      | Device Type | Select one or more device type from the dropdown list.                                        |
      | Disk Size   | Set a minimum size of 100GB for the device and maximum available size of the device that needs to be included. |
      | Maximum Disks Limit | This indicates the maximum number of PVs that can be created on a node. If this field is left empty, then PVs are created for all the available disks on the matching nodes. |
   e. Click **Next**.
      A pop-up to confirm the creation of LocalVolumeSet is displayed.
   f. Click **Yes** to continue.

5. In the **Capacity and nodes** page, configure the following:
   a. **Available raw capacity** is populated with the capacity value based on all the attached disks associated with the storage class. This takes some time to show up. The **Selected nodes** list shows the nodes based on the storage class.
b. Click Next.

6. Optional: In the Security page, select Connect to an external key management service
   a. Key Management Service Provider is set to Vault by default.
   b. Enter Vault Service Name, host Address of Vault server ('https://<hostname or ip>'), Port number, and Token.
   c. Expand Advanced Settings to enter additional settings and certificate details based on your Vault configuration:
      i. Enter the Key Value secret path in the Backend Path that is dedicated and unique to OpenShift Data Foundation.
      ii. Optional: Enter TLS Server Name and Vault Enterprise Namespace
      iii. Upload the respective PEM encoded certificate file to provide the CA Certificate, Client Certificate, and Client Private Key.
   d. Click Next.

7. In the Review and create page, review the configuration details:
   To modify any configuration settings, click Back.

8. Click Create StorageSystem.

Verification steps

Verifying that the OpenShift Data Foundation cluster is healthy

1. In the OpenShift Web Console, click Storage → Data Foundation.

2. In the Status card of the Overview tab, click Storage System and then click the storage system link from the pop up that appears.
   a. In the Status card of the Object tab, verify that both Object Service and Data Resiliency have a green tick.
   b. In the Details card, verify that the MCG information is displayed.

Verifying the state of the pods

1. Click Workloads → Pods from the OpenShift Web Console.

2. Select openshift-storage from the Project drop-down list and verify that the following pods are in Running state.

   NOTE
   If the Show default projects option is disabled, use the toggle button to list all the default projects.
<table>
<thead>
<tr>
<th>Component</th>
<th>Corresponding pods</th>
</tr>
</thead>
<tbody>
<tr>
<td>OpenShift Data Foundation Operator</td>
<td>- <strong>ocs-operator-</strong>( * ) (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>- <strong>ocs-metrics-exporter-</strong>( * ) (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>- <strong>odf-operator-controller-manager-</strong>( * ) (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>- <strong>odf-console-</strong>( * ) (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>- <strong>csi-addons-controller-manager-</strong>( * ) (1 pod on any worker node)</td>
</tr>
<tr>
<td>Rook-ceph Operator</td>
<td><strong>rook-ceph-operator-</strong>( * )</td>
</tr>
<tr>
<td></td>
<td>(1 pod on any worker node)</td>
</tr>
<tr>
<td>Multicloud Object Gateway</td>
<td>- <strong>noobaa-operator-</strong>( * ) (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>- <strong>noobaa-core-</strong>( * ) (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>- <strong>noobaa-db-pg-</strong>( * ) (1 pod on any worker node)</td>
</tr>
<tr>
<td></td>
<td>- <strong>noobaa-endpoint-</strong>( * ) (1 pod on any worker node)</td>
</tr>
</tbody>
</table>
CHAPTER 6. UNINSTALLING OPENSSHIFT DATA FOUNDATION

6.1. UNINSTALLING OPENSSHIFT DATA FOUNDATION IN INTERNAL MODE

To uninstall OpenShift Data Foundation in Internal mode, refer to the knowledge base article on Uninstalling OpenShift Data Foundation.