Chapter 1. Required Infrastructure Component Versions

The following versions of infrastructure components are required for all runtimes distributed as part of a RHOAR release. Red Hat does not provide support for components listed below, with the exception of components explicitly designated as supported.

Component nameVersion

Node.js v8[a]

8.16.0 LTS

Node.js v10[b]

10.15.3 LTS

Web App Node.js v10[c]

10.15.3

Nodeshift

2.1.1

npm 5[d]

6.4.1

npm 6[e]

6.4.1

OpenShift Container Platform (OCP)[f]

3.11 or later

Minishift

1.34.0 or later

CDK[g]

3.8.0

git

2.0 or later

oc command line tool

3.11 or later[h]

[a] The RHOAR Node.js v8 release is supported by Red Hat
[b] The RHOAR Node.js v10 release is supported by Red Hat
[c] The RHOAR Web App Node.js v10 image release is Technology Preview
[d] Distributed with RHOAR as a supported RPM for Node.js 8
[e] Distributed with RHOAR as a supported RPM for Node.js 10
[f] OCP is supported by Red Hat
[g] CDK is supported by Red Hat
[h] The version of the oc CLI tool should correspond to the version of OCP that you are using.