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CHAPTER 1. INSTALLATION OPTIONS

Red Hat JBoss Developer Studio Integration Stack is provided as a set of plug-ins for Eclipse or
JBoss Developer Studio. Depending on whether you are already using Eclipse or
JBoss Developer Studio, there are a variety of ways of installing JBoss Developer Studio
Integration Stack and instructions are given here for each variation:

Chapter 4, Installing JBoss Developer Studio Integration Stack Using the Standalone Installer

Chapter 5, Installing JBoss Developer Studio Integration Stack in Eclipse when Online

Chapter 6, Installing JBoss Developer Studio Integration Stack in Eclipse when Offline

Chapter 7, Installing JBoss Developer Studio Integration Stack in JBoss Developer when Online

Chapter 8, Installing JBoss Developer Studio Integration Stack in JBoss Developer when Offline

Note

To install Eclipse, see https://eclipse.org/users/ on the Eclipse website. To install
JBoss Developer Studio BYOE or standalone, see the Install Red Hat
JBoss Developer Studio document for the relevant version on the Red Hat
JBoss Developer Studio documentation page.

Important

A variety of Eclipse installations are available, each with a different default configuration
and selection of pre-installed plug-ins. For using JBoss Developer Studio
Integration Stack, it is recommended that you use the variant Eclipse Mars for Java EE
Developers.

CHAPTER 1. INSTALLATION OPTIONS
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CHAPTER 2. SYSTEM REQUIREMENTS

This release of JBoss Developer Studio is supported for use with a range of operating system,
architecture and Java developer kit combinations; for a complete list, see Red Hat
JBoss Developer Studio Supported Configurations and Components on the Red Hat Customer
Portal.

To install and run this release of JBoss Developer Studio, the following memory requirements are
recommended:

4 GB RAM

2 GB of hard disk space

Note

The minimum memory requirements are 2 GB RAM and 1 GB of hard disk space.

Red Hat JBoss Developer Studio Integration Stack 9.0 Installation Guide

4

https://access.redhat.com/documentation/en/red-hat-jboss-developer-studio-integration-stack/9.0/single/supported-configurations-and-components/


CHAPTER 3. UPDATING JBOSS DEVELOPER STUDIO
INTEGRATION STACK

Each major version of JBoss Developer Studio Integration Stack is based on a different version of
Eclipse. As a result, it is not possible to update an older major version of JBoss Developer Studio
Integration Stack to a newer major version. For example, it is not possible to update an existing
JBoss Developer Studio Integration Stack 8.x or earlier installation to JBoss Developer Studio
Integration Stack 9.x. because JBoss Developer Studio Integration Stack 8.x is based on Eclipse
Luna (4.4) but JBoss Developer Studio Integration Stack 9.x is based on Eclipse Mars (4.5).

You may be automatically notified by the IDE when an update for the next minor version is available,
depending on your IDE settings for automatic updates. To check for updates, click Help → Check
for Updates.

CHAPTER 3. UPDATING JBOSS DEVELOPER STUDIO INTEGRATION STACK
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CHAPTER 4. INSTALLING JBOSS DEVELOPER STUDIO
INTEGRATION STACK USING THE STANDALONE
INSTALLER

Use the standalone installer to install JBoss Developer Studio Integration Stack with all the latest
versions of the integration stack components:

JBoss Developer Studio

JBoss Fuse & JBoss Fuse Service Works

JBoss Data Virtualization

JBoss Fuse Service Works

JBoss Business Rules Management System (BRMS)

JBoss Business Process Management Suite (BPM Suite)

Important

The embeddable version of Xulrunner works with GTK2, but not with GTK3. As a result,
the SWT (Standard Widget Toolkit) Browser, which is used for documentation in JBoss
Fuse tooling and Javadocs in the Java Editor, does not work.

The workaround for this issue is to install WebKitGTK when using GTK3. An additional
workaround is to enable GTK2 and use it instead of GTK3. Note that the browser widget
does not work with Red Hat Enterprise Linux 7 or supported Fedora version because they
do not have WebKitGTK installed by default.

Further information on what SWT Browser does in Eclipse is available here:
https://www.eclipse.org/swt/faq.php#browserlinux

To install JBoss Developer Studio Integration Stack using the Standalone Installer:

1. Download the JBoss Developer Studio Integration Stack Standalone Installer file from the
Customer Portal and run the file.

2. Agree to the terms and conditions and specify a target installation directory and a target JDK
for the installation.

3. At the Select Additional Features to Install screen, select the required
components:

Figure 4.1. Select Additional Features to Install

Red Hat JBoss Developer Studio Integration Stack 9.0 Installation Guide
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4. Click Next to continue the installation process until the process completes.

When done, JBoss Developer Studio Integration Stack and the integration stack components are
ready to use.

CHAPTER 4. INSTALLING JBOSS DEVELOPER STUDIO INTEGRATION STACK USING THE STANDALONE INSTALLER
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CHAPTER 5. INSTALLING JBOSS DEVELOPER STUDIO
INTEGRATION STACK IN ECLIPSE WHEN ONLINE

JBoss Developer Studio Integration Stack is available to install in Eclipse when you are online. All
components except JBoss SOA 5.x can be installed from the Eclipse Marketplace. Installing these
components also installs JBoss Developer Studio 9.1.

Important

The embeddable version of Xulrunner works with GTK2, but not with GTK3. As a result,
the SWT (Standard Widget Toolkit) Browser, which is used for documentation in JBoss
Fuse tooling and Javadocs in the Java Editor, does not work.

The workaround for this issue is to install WebKitGTK when using GTK3. An additional
workaround is to enable GTK2 and use it instead of GTK3. Note that the browser widget
does not work with Red Hat Enterprise Linux 7 or supported Fedora version because they
do not have WebKitGTK installed by default.

Further information on what SWT Browser does in Eclipse is available here:
https://www.eclipse.org/swt/faq.php#browserlinux

To install JBoss Developer Studio Integration Stack in Eclipse when online:

1. Start Eclipse Mars for Java EE Developers.

2. Click Help → Eclipse Marketplace, locate Red Hat JBoss Developer Studio Integration
Stack and click Install.

3. Select the components that you want to install.

a. For JBoss BRMS and JBoss BPM Suite, select JBoss Business and Rules
Development (BPEL, BPMN2, jBPM, Drools, Guvnor)

b. For JBoss Data Virtualization, select JBoss Data Virtualization Development
(Modeshape, Teiid Designer)

c. For JBoss Fuse, select JBoss Fuse Development (Fuse tooling releated to
Camel route development)

d. For JBoss Fuse Service Works, select JBoss Integration and SOA Development

e. JBoss SOA 5.x is deprecated from JBoss Developer Studio Integration Stack 9.0.0
onwards. As a result, JBoss SOA 5.x is not available in the Eclipse Marketplace. To
install JBoss SOA 5.x:

i. Install any JBoss Developer Studio or JBoss Developer Studio
Integration Stack component from the Eclipse Marketplace (as instructed in
step 2).

ii. Click Help → Red Hat Central.

iii. In the Red Hat Central tab, click the Software/Install tab at the bottom.

Red Hat JBoss Developer Studio Integration Stack 9.0 Installation Guide
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iv. In the list of components, check the * JBoss SOA 5.x Development
(Deprecated)* option and click Install/Update.

4. Follow the on-screen instructions to complete the installation process.

During the installation process, warnings about installing unsigned content may display. If this is the
case, review the details of the content and if satisfied click OK to continue with the installation.

Once installed, complete the additional configuration actions before you can use the
JBoss Developer Studio Integration Stack functionality. For plug-in specific configuration
information, see the appropriate Red Hat JBoss product documentation available from the Red Hat
Customer Portal.

Warning

The IDE changes do not take effect until the IDE is restarted and the IDE may be
unstable until it is restarted.

CHAPTER 5. INSTALLING JBOSS DEVELOPER STUDIO INTEGRATION STACK IN ECLIPSE WHEN ONLINE
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CHAPTER 6. INSTALLING JBOSS DEVELOPER STUDIO
INTEGRATION STACK IN ECLIPSE WHEN OFFLINE

To install JBoss Developer Studio Integration Stack in Eclipse when offline:

Important

The embeddable version of Xulrunner works with GTK2, but not with GTK3. As a result,
the SWT (Standard Widget Toolkit) Browser, which is used for documentation in JBoss
Fuse tooling and Javadocs in the Java Editor, does not work.

The workaround for this issue is to install WebKitGTK when using GTK3. An additional
workaround is to enable GTK2 and use it instead of GTK3. Note that the browser widget
does not work with Red Hat Enterprise Linux 7 or supported Fedora version because they
do not have WebKitGTK installed by default.

Further information on what SWT Browser does in Eclipse is available here:
https://www.eclipse.org/swt/faq.php#browserlinux

1. Locate and download the following files:

Red Hat JBoss Developer Studio 9.1.0.GA Update Site Zip file from
https://devstudio.redhat.com/9.0/stable/updates/

Red Hat JBoss Developer Studio Integration Stack 9.0.3.GA Update Site Zip file
from https://devstudio.redhat.com/9.0/stable/updates/integration-stack/

2. Start Eclipse Mars for Java EE Developers.

3. Click Window → Preferences → Install/Update → Available Software Sites.

4. Click Add, click Archive to locate the JBoss Developer Studio Update .zip file, select the
file and click OK.

5. Click OK again to close the Preferences window.

6. Click Help → Install New Software.

7. Next to the Work with field, click Add and click Archive to locate the Red Hat JBoss
Developer Studio Integration Stack 9.0.3.GA Update Site Zip file.

8. From the table of categories, select the JBoss Developer Studio Integration Stack
functionality you want to install:

For JBoss BRMS and JBoss BPM Suite, select JBoss Business and Rules
Development

For JBoss Data Virtualization, select JBoss Data Virtualization Development

For JBoss Fuse, select JBoss Fuse Development

For JBoss Fuse Service Works, select JBoss Integration and SOA Development

For JBoss SOA 5.x Development, select JBoss SOA 5.x Development (Deprecated)

Red Hat JBoss Developer Studio Integration Stack 9.0 Installation Guide
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Note

SOA 5.x is being deprecated starting from JBoss Developer Studio
Integration Stack 9.0.0.GA.

9. Click Next.

10. Follow the on-screen instructions to complete the installation process.

During the installation process, you may receive warnings about installing unsigned content. If this is
the case, review the details of the content and if satisfied click OK to continue with the installation.

Once installation is complete, you are prompted to restart the IDE. Click Yes to restart immediately
and No if you need to save any unsaved changes to open projects.

Warning

The IDE changes do not take effect until the IDE is restarted and the IDE may be
unstable until it is restarted.

CHAPTER 6. INSTALLING JBOSS DEVELOPER STUDIO INTEGRATION STACK IN ECLIPSE WHEN OFFLINE
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CHAPTER 7. INSTALLING JBOSS DEVELOPER STUDIO
INTEGRATION STACK IN JBOSS DEVELOPER WHEN
ONLINE

JBoss Developer Studio Integration Stack is available to install from JBoss Developer Studio,
through Red Hat Central Software/Update tab, when online.

Important

To install JBoss Developer Studio Integration Stack as detailed in the steps below, it is
essential that you have an instance of JBoss Developer Studio installed. For detailed
steps to install JBoss Developer Studio refer to Install Red Hat JBoss Developer Studio.

Important

The embeddable version of Xulrunner works with GTK2, but not with GTK3. As a result,
the SWT (Standard Widget Toolkit) Browser, which is used for documentation in JBoss
Fuse tooling and Javadocs in the Java Editor, does not work.

The workaround for this issue is to install WebKitGTK when using GTK3. An additional
workaround is to enable GTK2 and use it instead of GTK3. Note that the browser widget
does not work with Red Hat Enterprise Linux 7 or supported Fedora version because they
do not have WebKitGTK installed by default.

Further information on what SWT Browser does in Eclipse is available here:
https://www.eclipse.org/swt/faq.php#browserlinux

To install JBoss Developer Studio Integration Stack in JBoss Developer Studio when online,
complete the following steps:

1. Start JBoss Developer Studio 9.1.

2. In Red Hat Central, click the Software/Update tab. If Red Hat Central is not visible, click
Window → Red Hat Central.

3. In the list of available software, locate JBoss Developer Studio Integration Stack.

4. Select the check boxes corresponding to the JBoss Developer Studio Integration Stack
functionality you want to install:

For JBoss Fuse, select JBoss Fuse Development

For JBoss Data Virtualization, select JBoss Data Virtualization Development

For JBoss BRMS and JBoss BPM Suite, select JBoss Business and Rules
Development

For JBoss Fuse Service Works, select JBoss Integration and SOA Development

For JBoss SOA 5.x Development, select JBoss SOA 5.x Development (Deprecated)

Red Hat JBoss Developer Studio Integration Stack 9.0 Installation Guide
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Note

SOA 5.x is being deprecated starting from JBoss Developer Studio
Integration Stack 9.0.0.GA.

5. Click Install/Update.

6. Follow the on-screen instructions to complete the installation process.

Once installed, you may need to complete additional configuration actions before you can use the
JBoss Developer Studio Integration Stack functionality. For plug-in specific configuration
information, see the appropriate Red Hat JBoss product documentation available from the Red Hat
Customer Portal

Important

If you choose to install only selected functionality of a JBoss Developer Studio
Integration Stack category, for example only ModeShape Client from the JBoss Data
Virtualization Development category, then the category continues to be listed as
uninstalled in the JBoss Central Software/Update tab.

Warning

The IDE changes do not take effect until the IDE is restarted and the IDE may
be unstable until it is restarted.

CHAPTER 7. INSTALLING JBOSS DEVELOPER STUDIO INTEGRATION STACK IN JBOSS DEVELOPER WHEN ONLINE
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CHAPTER 8. INSTALLING JBOSS DEVELOPER STUDIO
INTEGRATION STACK IN JBOSS DEVELOPER WHEN
OFFLINE

Important

To install JBoss Developer Studio Integration Stack as detailed in the steps below, it is
essential that you have an instance of JBoss Developer Studio installed. For detailed
steps to install JBoss Developer Studio refer to Install Red Hat JBoss Developer Studio.

Important

The embeddable version of Xulrunner works with GTK2, but not with GTK3. As a result,
the SWT (Standard Widget Toolkit) Browser, which is used for documentation in JBoss
Fuse tooling and Javadocs in the Java Editor, does not work.

The workaround for this issue is to install WebKitGTK when using GTK3. An additional
workaround is to enable GTK2 and use it instead of GTK3. Note that the browser widget
does not work with Red Hat Enterprise Linux 7 or supported Fedora version because they
do not have WebKitGTK installed by default.

Further information on what SWT Browser does in Eclipse is available here:
https://www.eclipse.org/swt/faq.php#browserlinux

To install JBoss Developer Studio Integration Stack in JBoss Developer Studio when offline:

1. Locate and download the Red Hat JBoss Developer Studio Integration Stack 9.0.3.GA
Update Site Zip file from https://devstudio.redhat.com/9.0/stable/updates/integration-stack/

2. Start JBoss Developer Studio 9.1.

3. Click Help → Install New Software.

4. Next to the Work with field, click Add and click Archive to locate the Red Hat JBoss
Developer Studio Integration Stack 9.0.3.GA Update Site Zip file.

5. From the table of categories, select the JBoss Developer Studio Integration Stack
functionality you want to install:

For JBoss BRMS and JBoss BPM Suite, select JBoss Business and Rules
Development

For JBoss Data Virtualization, select JBoss Data Virtualization Development

For JBoss Fuse, select JBoss Fuse Development

For JBoss Fuse Service Works, select JBoss Integration and SOA Development

For JBoss SOA 5.x Development, select JBoss SOA 5.x Development (Deprecated)
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Note

SOA 5.x is being deprecated starting from JBoss Developer Studio
Integration Stack 9.0.0.GA.

6. Click Next.

7. Follow the on-screen instructions to complete the installation process.

During the installation process, you may receive warnings about installing unsigned content. If this is
the case, review the details of the content and if satisfied click OK to continue with the installation.

Once installation is complete, you are prompted to restart the IDE. Click Yes to restart immediately
and No if you need to save any unsaved changes to open projects.

Warning

The IDE changes do not take effect until the IDE is restarted and the IDE may be
unstable until it is restarted.
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CHAPTER 9. UNINSTALLATION OPTIONS

After concluding development in one of the Red Hat JBoss Developer Studio Integration Stack
tooling plug-ins, you can choose to uninstall either an entire category of plug-ins, or individual plug-
ins. Removing one or more plug-ins that are no longer required provides continued stability and
ensures continued optimal performance due to a smaller memory footprint. Uninstall a category of
features to remove all related features in an efficient manner, or select individual plug-ins to remove
for a customized uninstall process.

To uninstall an entire category of features, refer to Section 9.1, “Uninstalling an Entire Category
of JBoss Developer Studio Integration Stack”

To uninstall a single feature, refer to Section 9.2, “Uninstalling a Single Feature of
JBoss Developer Studio Integration Stack”

9.1. UNINSTALLING AN ENTIRE CATEGORY OF
JBOSS DEVELOPER STUDIO INTEGRATION STACK

To uninstall an entire category of JBoss Developer Studio Integration Stack:

1. In Red Hat Central, click the Software/Update tab.

Note

If Red Hat Central is not visible, click Window → Red Hat Central.

2. Click the Show installed check box.

3. In the Features Available list, locate JBoss Developer Studio Integration Stack.

4. Select the check boxes corresponding to the JBoss Developer Studio Integration Stack
category to uninstall:

For JBoss Data Virtualization, select JBoss Data Virtualization Development

For JBoss BRMS and JBoss BPM Suite, select JBoss Business and Rules
Development

For JBoss SOA Platform 5.x, select JBoss SOA 5.x Development

For JBoss Fuse Service Works, select JBoss Integration and SOA Development

For JBoss Fuse, select JBoss Fuse Development

5. Click Uninstall.

6. Follow the on-screen instructions to complete the process of uninstalling the selected
category.

7. Restart the IDE to implement the changes. An immediate restart is recommended because
the IDE may be unstable until a restart.

9.2. UNINSTALLING A SINGLE FEATURE OF
JBOSS DEVELOPER STUDIO INTEGRATION STACK

Red Hat JBoss Developer Studio Integration Stack 9.0 Installation Guide
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JBOSS DEVELOPER STUDIO INTEGRATION STACK

To uninstall a single feature of JBoss Developer Studio Integration Stack:

1. Click Help → Installation Details.

2. In the search field type the feature to uninstall.

3. Click the feature to uninstall and click Uninstall.

Note

To delete more than one feature select the features while you press the Shift key.

4. Follow the on-screen instructions to complete the process of uninstalling the selected
feature.

5. Restart the IDE to implement the changes. An immediate restart is recommended because
the IDE may be unstable until a restart.

CHAPTER 9. UNINSTALLATION OPTIONS
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