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This document details how to install JBoss Developer Studio.

http://creativecommons.org/licenses/by-sa/3.0/


. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Table of Contents

1. INSTALL OPTIONS

2. SYSTEM REQUIREMENTS

3. INSTALL JBOSS DEVELOPER STUDIO BYOE WHEN ONLINE

4. INSTALL JBOSS DEVELOPER STUDIO BYOE WHEN OFFLINE

5. INSTALL JBOSS DEVELOPER STUDIO STAND-ALONE

6. INSTALL JBOSS DEVELOPER STUDIO STAND-ALONE AND JBOSS EAP

7. ADVANCED INSTALL TASKS
7.1. Install JBoss Developer Studio by Script
7.2. Build the JBoss Developer Studio Stand-alone Installer from Source

A. REVISION HISTORY

2

2

2

4

5

7

8
8
9

11

Table of Contents

1



1. INSTALL OPTIONS

Red Hat JBoss Developer Studio is provided in two variants depending on your circumstance: stand-
alone and Bring-Your-Own-Eclipse (BYOE). JBoss Developer Studio stand-alone packages the JBoss
Developer Studio plug-ins with Eclipse and dependent third-party plug-ins in an installer for all operating
systems. JBoss Developer Studio BYOE packages the JBoss Developer Studio plug-ins for installing in
your existing Eclipse instance.

There are a variety of ways of installing each JBoss Developer Studio variant and instructions are given
here for completing the following tasks:

Section 3, “Install JBoss Developer Studio BYOE when Online”

Section 4, “Install JBoss Developer Studio BYOE when Offline”

Section 5, “Install JBoss Developer Studio Stand-alone”

Section 6, “Install JBoss Developer Studio Stand-alone and JBoss EAP”

There are also several advanced and less common ways of installing JBoss Developer Studio and
instructions are given here for completing the following tasks:

Section 7.1, “Install JBoss Developer Studio by Script”

Section 7.2, “Build the JBoss Developer Studio Stand-alone Installer from Source”

Report a bug

2. SYSTEM REQUIREMENTS

This release of JBoss Developer Studio is supported for use with a range of operating system,
architecture and Java developer kit combinations; for a complete list, see
https://access.redhat.com/articles/427493 on the Red Hat Customer Portal.

To install and run this release of JBoss Developer Studio, the following memory requirements are
recommended:

4 GB RAM

1.5 GB of hard disk space

NOTE

The minimum memory requirements are 2 GB RAM and 750 MB of hard disk space.

Report a bug

3. INSTALL JBOSS DEVELOPER STUDIO BYOE WHEN ONLINE

JBoss Developer Studio BYOE is available to install from Eclipse Marketplace when you are online.

Install Red Hat JBoss Developer Studio
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To install JBoss Developer Studio BYOE from Eclipse Marketplace, complete the following steps:

1. Start Eclipse Luna.

2. Drag the following link into your Eclipse workspace: http://marketplace.eclipse.org/marketplace-
client-intro?mpc_install=1616973. Alternatively, click Help→Eclipse Marketplace, locate Red 
Hat JBoss Developer Studio 8.1.0 GA and click Install.

Figure 1. Red Hat JBoss Developer Studio (Luna) Available from Eclipse Marketplace

3. Follow the on-screen instructions to complete the installation process.

During the installation process you may receive warnings about installing unsigned content. If this is the
case, review the details of the content and if satisfied click OK to continue with the installation.
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Once installation is complete, you are prompted to restart Eclipse. Click Yes to restart immediately and 
No if you need to save any unsaved changes to open projects. Note that IDE changes do not take effect
until Eclipse is restarted.

Report a bug

4. INSTALL JBOSS DEVELOPER STUDIO BYOE WHEN OFFLINE

Two .zip files are provided for installing JBoss Developer Studio BYOE in offline mode, namely an
Update archive and a Target Platform archive. Both of these .zip files are necessary for a successful
install and they can be downloaded from https://devstudio.jboss.com/updates/8.0/ under Offline 
Install.

IMPORTANT

You must first be online to download the .zip files before proceeding to install JBoss
Developer Studio BYOE in offline mode.

To install JBoss Developer Studio BYOE in offline mode, complete the following steps:

1. Locate and download Red Hat JBoss Developer Studio <version> Update Site 
Zip and Target Platform Zip.

2. Start Eclipse Luna.

3. Click Window→Preferences→Install/Update→Available Software Sites.

4. Click Add and click Archive to locate the JBoss Developer Studio Target Platform .zip file.

Figure 2. Add JBoss Developer Studio 8.1 Offline Target Platform File

5. Click OK and click OK again to close the Preferences window.

6. Click Help→Install New Software.

Install Red Hat JBoss Developer Studio
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7. In the Work with field, enter the path of the Update .zip file. Alternatively, click Add and click 
Archive to locate the file.

8. From the table of components, select JBoss Developer Studio <version> - Bring 
Your Own Eclipse and click Next.

Figure 3. JBoss Developer Studio version - Bring Your Own Eclipse Selected for
Installation

9. Follow the on-screen instructions to complete the installation process.

During the installation process if you receive warnings about installing unsigned content, review the
details of the content and if satisfied click OK to continue with the installation.

Once installation is complete, you are prompted to restart Eclipse. Click Yes to restart immediately and 
No if you need to save any unsaved changes to open projects. Note that IDE changes do not take effect
until Eclipse is restarted.

Report a bug

5. INSTALL JBOSS DEVELOPER STUDIO STAND-ALONE

An installer is provided for JBoss Developer Studio stand-alone. This installer is available from a variety
of sources, including the Red Hat Customer Portal.

To install JBoss Developer Studio stand-alone, complete the following steps:

5. INSTALL JBOSS DEVELOPER STUDIO STAND-ALONE
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1. Locate and download Red Hat JBoss Developer Studio <version> Stand-alone 
Installer.

2. Start the installer

$ cd /path/to/.jar
$ java -jar jboss-devstudio-version-installer-standalone.jar

Alternatively, you may be able to start the installer by double-clicking the .jar file. On OS X
systems, hold control and click the .jar file, click Open, review the .jar file details and if
satisfied click Open.

3. Follow the on-screen instructions to complete the installation process.

When working through the installer you may find the following additional information useful:

Installer step 4

You must specify a Java developer kit with a 32-bit JRE to install a 32-bit version of JBoss Developer
Studio and a 64-bit JRE to install a 64-bit version of JBoss Developer Studio. To change the bit
version of the Java developer kit to be used for installing JBoss Developer Studio, in the text field type
the path to the appropriate bit version of the Java developer kit.

Figure 4. Default Java VM Selected for Running the IDE

Installer step 5

To make use of automatic runtime detection for finding already installed application servers, click 
Add. In the Location field, type the path from which recursive scanning for application servers is to
commence or click Browse to navigate to the location:

To detect a specific application server, select the install directory for that application server.

Install Red Hat JBoss Developer Studio
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To detect multiple application servers, select a directory higher up the directory tree.
Alternatively, this can be achieved by adding multiple locations for scanning.

Figure 5. Path Selected for Recursive Scanning for Application Servers

This task can also be completed after JBoss Developer Studio is installed using the JBoss Runtime 
Detection wizard, accessed through the IDE Preferences window.

Report a bug

6. INSTALL JBOSS DEVELOPER STUDIO STAND-ALONE AND JBOSS
EAP

A single installer is provided for both JBoss Developer Studio stand-alone and Red Hat JBoss Enterprise
Application Platform. A specific JBoss EAP version is packaged in the installer; for details of the JBoss
EAP version see https://access.redhat.com/articles/427493. This installer is available from a variety of
sources, including the Red Hat Customer Portal.

To install JBoss Developer Studio stand-alone and JBoss EAP, complete the following steps:

1. Locate and download Red Hat JBoss Developer Studio <version> Installer 
with EAP.

2. Start the installer

$ cd /path/to/.jar
$ java -jar jboss-devstudio-version-installer-eap.jar

6. INSTALL JBOSS DEVELOPER STUDIO STAND-ALONE AND JBOSS EAP
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Alternatively, you may be able to start the installer by double-clicking the .jar file. On OS X
systems, hold control and click the .jar file, click Open, review the .jar file details and if
satisfied click Open.

3. Follow the on-screen instructions to continue the installation process.

4. At installer step 5, when asked if you want to install JBoss EAP, click Yes.

Figure 6. Check Box Selected for Installing JBoss EAP

5. Continue to follow the on-screen instructions to complete the installation process.

This additional installer option installs JBoss EAP in a subdirectory of the JBoss Developer Studio
installation and generates a complete default server definition within the IDE with which to manage the
JBoss EAP instance and deployed applications.

Report a bug

7. ADVANCED INSTALL TASKS

7.1. Install JBoss Developer Studio by Script

A scripted method is available for use when installing JBoss Developer Studio stand-alone with the
installer. The scripted installation method removes the need to step through the installer GUI for every
installation, enabling simplified repeat installations or installations in bulk.

The instructions here detail how you can install JBoss Developer Studio stand-alone stepping through
the installer GUI once and then use a generated script for subsequent installations. The JBoss
Developer Studio stand-alone installer is available from a variety of sources, including the Red Hat
Customer Portal.

To install JBoss Developer Studio by script, complete the following steps:

Install Red Hat JBoss Developer Studio
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1. Locate and download Red Hat JBoss Developer Studio <version> Stand-alone 
Installer.

2. Start the installer

$ cd /path/to/.jar
$ java -jar jboss-devstudio-version-installer-standalone.jar

3. Step through the installer GUI once to generate a InstallConfigRecord.xml file located in
the /path/to/jboss-devstudio/ directory.

4. Perform repeat identical installations without stepping through the installer GUI

$ java -jar jboss-devstudio-version-installer-standalone.jar 
/path/to/jboss-devstudio/InstallConfigRecord.xml

NOTE

The generated InstallConfigRecord.xml file is machine-specific, using the Java
developer kit and installation paths of your system. To use the 
InstallConfigRecord.xml file for systems with different operating systems, Java
developer kits or paths, you must manually modify the file.

Report a bug

7.2. Build the JBoss Developer Studio Stand-alone Installer from Source

A .zip file is provided from which you can build the JBoss Developer Studio stand-alone installer. The
source code archive is available from a variety of sources, including the Red Hat Customer Portal.

IMPORTANT

Maven must be installed to build the installer from the source code. To obtain and
configure Maven, see http://maven.apache.org/.

To build the JBoss Developer Studio stand-alone installer from source, complete the following steps:

1. Locate and download Red Hat JBoss Developer Studio <version> Sources Zip.

2. Extract the contents of the downloaded archive

$ cd path/to/.zip
$ unzip jboss-devstudio-version-installer-src.zip

3. Build the installer

$ cd devstudio/product
$ mvn clean install

Building takes some time to complete, after which the installer .jar file is located in the 
/path/to/jboss-devstudio/installer/target/ directory.

7. ADVANCED INSTALL TASKS
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Report a bug
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