Red Hat Training

A Red Hat training course is available for Red Hat JBoss Developer Studio

3. Update the Version of Eclipse Used with JBoss Developer Studio BYOE

JBoss Developer Studio 8.0 Bring-Your-Own-Eclipse (BYOE) supports Eclipse Luna only. If you update the version of Eclipse you are using to Mars (4.5) or later and install JBoss Developer Studio 8.0 BYOE onto it, any problems that occur from this combination are not supported by Red Hat.
Information about the supported versions of Eclipse for each JBoss Developer Studio BYOE release is given in the table below.

Table 1. JBoss Developer Studio BYOE Releases and Supported Eclipse Versions

JBoss Developer Studio BYOE Release Supported Eclipse Version
JBoss Developer Studio 8.x Eclipse Luna (4.4)
JBoss Developer Studio 7.x Eclipse Kepler (4.3)
JBoss Developer Studio 6.x Eclipse Juno (4.2)