Installation Guide

Red Hat JBoss Developer Studio 11.0

Installing Red Hat JBoss Developer Studio

Misha Husnain Ali

Supriya Takkhi

Red Hat Developer Group Documentation Team

Abstract

Information for users installing Red Hat JBoss Developer Studio. This guide describes all prerequisites for a successful installation of the product followed by a number of installation methods, including how to use your existing installation of Eclipse.

Chapter 1. Introducing JBoss Developer Studio Installation Options

JBoss Developer Studio can be installed in a variety of ways. Depending on your circumstance, use one of the following installation methods:

Chapter 2. Understanding JBoss Developer Studio Installation Prerequisites

2.1. Hardware and Software Requirements

JBoss Developer Studio 11.0 is supported for use with a range of operating system, architecture, and Java developer kit combinations; for a complete list, see https://access.redhat.com/articles/427493 on the Red Hat Customer Portal.

Following are the prerequisites for installing JBoss Developer Studio:

  1. Minimum hardware requirements:

    1. 4 GB RAM (minimum 2 GB RAM)
    2. 2 GB hard disk space
  2. Software requirements:

    1. Install JDK 8 (Red Hat OpenJDK is recommended)

2.2. Installing OpenJDK 8

Unless you already have Java 8 installed on your system, use the OpenJDK distribution provided by Red Hat. This section describes how to install OpenJDK by Red Hat on Microsoft Windows and Red Hat Enterprise Linux.

2.2.1. Installing OpenJDK on Microsoft Windows

To install OpenJDK 1.8.0 on Windows using the MSI-based installer:

  1. Download the MSI-based installer from: http://developers.redhat.com/products/openjdk/overview/.
  2. Run the installer and follow the on-screen instructions to install.
  3. To configure JBoss Developer Studio to use OpenJDK, follow the instructions at Working with JREs.

2.2.2. Installing OpenJDK on Red Hat Enterprise Linux

To install OpenJDK 1.8.0 on Red Hat Enterprise Linux:

Note

All the commands in the following procedure must be run as the root user.

  1. Register and subscribe the system by running the following command:

    # subscription-manager register
  2. When prompted, enter your Red Hat Customer Portal user name and password.
  3. To find a suitable subscription, such as Developer Subscription, run the following command:

    # subscription-manager list --available

    This command lists the available subscriptions and details of the subscriptions. Note down the pool ID of the appropriate subscription.

  4. To attach a subscription to your system, run the following command:

    # subscription-manager attach --pool=<pool id from previous command>
  5. To install OpenJDK RPMs:

    # yum install java-1.8.0-openjdk-devel
Note

Install the java-1.8.0-openjdk-demo package for examples of Java applications and the java-1.8.0-openjdk-src package to debug your applications. Both packages are available from the Optional repository. Use the following command to enable that repository on your system:

# subscription-manager repos --enable=rhel-7-server-optional-rpms

Substitute the version number in the above command with 6 if you use Red Hat Enterprise Linux 6.

Use the following command to install the packages:

# yum install java-1.8.0-openjdk-src java-1.8.0-openjdk-demo

Chapter 3. Shared Installation of JBoss Developer Studio

For installation of JBoss Developer Studio on Red Hat Enterprise Linux:

  • If you install JBoss Developer Studio using RPM on Red Hat Enterprise Linux and then install or update any feature (example: install a feature from Red Hat Central), the newly installed feature gets installed in your home directory (~/.eclipse).

For installation of JBoss Developer Studio on Windows:

  • If you install JBoss Developer Studio on Windows in a folder accessible to all the users (example: c:\devstudio), this DevStudio instance can be used by all the users. However, if the main installation folder is not writable by a given user, any newly installed feature and update gets saved inside the user’s home directory.

Chapter 4. Installing JBoss Developer Studio in Eclipse

JBoss Developer Studio for Eclipse packages the JBoss Developer Studio plug-ins for your existing Eclipse instance. You can either install JBoss Developer Studio from the Eclipse Marketplace when you are online or use the Update Site Zip to install it when you are offline.

4.1. Installing JBoss Developer Studio in Eclipse when Online

JBoss Developer Studio is available to install from Eclipse Marketplace when you are online.

Important

If anytime before or during the installation, you are asked about selecting additional features to install, you may select JBoss Fuse Tooling to use the Fuse tooling features after the installation is complete

To install JBoss Developer Studio BYOE from Eclipse Marketplace:

  1. Start Eclipse Oxygen.
  2. Click HelpEclipse Marketplace, locate Red Hat JBoss Developer Studio 11.0 GA, and click Install.
  3. Follow the on-screen instructions to complete the installation process.

During the installation process, if you receive warnings about installing unsigned content, review the details of the content and if satisfied, click OK to continue with the installation.

Once installation is complete, you are prompted to restart Eclipse. Click Yes to restart immediately and No if you need to save any unsaved changes to open projects. Note that IDE changes do not take effect until Eclipse is restarted.

4.2. Installing JBoss Developer Studio in Eclipse when Offline

You need the Update Site Zip to install JBoss Developer Studio in Eclipse in the offline mode. Alternatively, you can also use an installer downloaded on your system instead of the Update Site Zip to install JBoss Developer Studio in Eclipse when Offline. Note that the Target Platform Zip contains the features on which DevStudio depends. It also contains the sources of all the included plugins. You can downlaod the Target Platform Zip from https://devstudio.redhat.com/11/stable/updates/.

Important
  • You must first be online to download the .zip file before proceeding to install JBoss Developer Studio in Eclipse in the offline mode.
  • If anytime before or during the installation, you are asked about selecting additional features to install, you may select JBoss Fuse Tooling to use the Fuse tooling features after the installation is complete

To install JBoss Developer Studio in Eclipse in offline mode:

  1. Download the Red Hat JBoss Developer Studio 11.0 Update Site Zip from https://devstudio.redhat.com/11/stable/updates/.
  2. Start Eclipse Oxygen.
  3. Click HelpInstall New Software.
  4. In the Work with field, enter the path of the Update Site Zip file. Alternatively, click Add and click Archive to locate the file.
  5. From the table of components, select Red Hat JBoss Developer Studio 11 - Bring Your Own Eclipse and click Next.
  6. Follow the on-screen instructions to complete the installation process.

During the installation process, you may receive warnings about installing unsigned content. If this is the case, review the details of the content and if satisfied, click OK to continue with the installation.

Once the installation is complete, you are prompted to restart Eclipse. Click Yes to restart immediately and No to save any unsaved changes to open projects. Note that the IDE changes do not take effect until Eclipse is restarted.

Chapter 5. Installing JBoss Developer Studio Stand-alone Using the Installer

JBoss Developer Studio stand-alone packages the JBoss Developer Studio plug-ins with Eclipse and dependent third-party plug-ins in an installer for all operating systems.

The installer provided to install JBoss Developer Studio stand-alone is available from a variety of sources, including the Red Hat Customer Portal.

Important

If anytime before or during the installation, you are asked about selecting additional features to install, you may select JBoss Fuse Tooling to use the Fuse tooling features after the installation is complete

To install JBoss Developer Studio stand-alone:

  1. Download Red Hat JBoss Developer Studio 11.0 Stand-alone Installer from JBoss Developer Studio Software Downloads.
  2. Start the installer:

    $ cd /path/to/.jar
    $ java -jar devstudio-11.0.0.GA-installer-standalone.jar

    Alternatively, you can start the installer by double-clicking the .jar file. On OS X systems, hold control and click the .jar file, click Open, review the .jar file details and if satisfied, click Open.

  3. Follow the on-screen instructions to complete the installation process.

Chapter 6. Installing JBoss Developer Studio through Red Hat Development Suite

You can install JBoss Developer Studio as part of Red Hat Development Suite on 64-bit Microsoft Windows, macOS, and Red Hat Enterprise Linux 7.

The Red Hat Development Suite Installer can install the following components; however, some of them are optional:

  • OpenJDK
  • Red Hat JBoss Developer Studio
  • Cygwin
  • Red Hat Container Development Kit
  • Vagrant
  • VirtualBox
  • Red Hat JBoss Enterprise Application Platform
  • Red Hat JBoss Fuse Tooling

For details of the components installed through Red Hat Development Suite, see Component Details in the Red Hat Development Suite Installation Guide.

For instructions on installing Red Hat Development Suite, see the Red Hat Development Suite Installation Guide.

Chapter 7. Installing JBoss Developer Studio Using RPM

On Red Hat Enterprise Linux 7.4 and higher, JBoss Developer Studio can be installed using the standard package management system. RPM packages that use the software collections format are provided in the Red Hat Developer Tools repository. This section explains how to enable that repository and install JBoss Developer Studio from RPM packages.

The Red Hat Developer Tools repository includes the following RPMs:

  • Eclipse
  • Devstudio
  • CDK
  • Kompose: Kompose is being released as Technology Preview for this Red Hat Developer Tools 1.0 release. For information on support for features released as Technology Preview, see Technology Preview Features Support Scope.
Important

Installation of third-party plugins that are not included in Red Hat Central, may corrupt JBoss Developer Studio. If you have installed any plugin in JBoss Developer Studio from an Update Site, including Red Hat Central, we highly recommend starting JBoss Developer Studio by running the following commands:

$ scl enable rh-eclipse47 bash
$ cd /opt/rh/rh-eclipse47/root/usr/lib64/eclipse/
$ ./eclipse -clean

If an installed plugin corrupts the JBoss Developer Studio istance, the only way to fix this issue is to delete the ~/.eclipse directory and then restart JBoss Developer Studio.

Prerequisites

7.1. Enabling the Red Hat Developer Tools Repositories

To install JBoss Developer Studio using the RPM package you must first enable the Red Hat Developer Tools repositories.

  • Enable the rhel-7-server-devtools-rpms repository on Red Hat Enterprise Linux Server or enable the rhel-7-workstation-devtools-rpms repository on Red Hat Enterprise Linux Workstation
  • Enable the rhel-server-rhscl-7-rpms reository
Note

Red Hat Developer Tools is not supported on the Client or the ComputeNode variant.

To enable the Red Hat Developer Tools repositories:

  1. Run the following commands as the root user:

    # subscription-manager repos --enable rhel-7-server-devtools-rpms
    # subscription-manager repos --enable rhel-server-rhscl-7-rpms
    Note

    In the above command, depending on the variant of Red Hat Enterprise Linux that you are using, Server or Workstation, the commands will be:

    • For the Workstation variant: subscription-manager repos --enable rhel-7-workstation-devtools-rpms
    • For the Server variant: subscription-manager repos --enable rhel-7-server-devtools-rpms

    For developers, we recommend using Red Hat Enterprise Linux Server for access to the widest range of development tools.

    For more information on registering and attaching subscriptions, see Using and Configuring Red Hat Subscription Management.

  2. To add the Red Hat Developer Tools key to your system, run the following commands as the root user:

    # cd /etc/pki/rpm-gpg
    # wget -O RPM-GPG-KEY-redhat-devel https://www.redhat.com/security/data/a5787476.txt
    # rpm --import RPM-GPG-KEY-redhat-devel

7.2. Installing JBoss Developer Studio and its Dependencies

To install JBoss Developer Studio and all the dependencies, run the following command:

yum install rh-eclipse47-devstudio

Chapter 8. Performing Advanced Installation Tasks

This section describes how to install JBoss Developer Studio using a script and how to build the JBoss Developer Studio installer from source code.

8.1. Installing JBoss Developer Studio Using a Script

Use the scripted method to install JBoss Developer Studio stand-alone using the GUI once and then a generated script for subsequent installations. This installation method enables simplified repeat installations or installations in bulk without stepping through the installer GUI for every installation.

The JBoss Developer Studio stand-alone installer is available from a variety of sources, including the Red Hat Customer Portal.

To install JBoss Developer Studio by script:

  1. Download Red Hat JBoss Developer Studio 11.0 Stand-alone Installer from JBoss Developer Studio Software Downloads.
  2. Start the installer:

    $ cd /path/to/.jar
    $ java -jar devstudio-11.0.0.GA-installer-standalone.jar
  3. Follow the on-screen instructions to complete the installation process. After the installation is complete, an InstallConfigRecord.xml file is generated in the JBoss Developer Studio installation directory.
  4. In the terminal window, enter the following command:

    $ java -jar devstudio-11.0.0.GA-installer-standalone.jar \
      /path/to/devstudio/InstallConfigRecord.xml
Note

The generated InstallConfigRecord.xml file is machine-specific and uses the Java Developer Kit and installation paths of your system. To use the InstallConfigRecord.xml file for other operating systems, Java Developer Kits, or paths, you must manually modify the file.

8.2. Building the JBoss Developer Studio Stand-alone Installer from Source

Prerequisite

  • Maven 3.3 or later, with Java 8 must be installed to build the installer from the source code. To obtain and configure Maven, see http://maven.apache.org/.

To build the JBoss Developer Studio stand-alone installer from source:

  1. Clone the git repository by running the command:

    $ git clone https://github.com/jbdevstudio/jbdevstudio-product.git
  2. Checkout branch master by running the command:

    $ git checkout master
  3. Build the installer by following the instructions in the jbdevstudio-product/README.adoc file.
Note

The jbdevstudio-product/README.adoc file is located in the extracted current folder at the highest level.

Building takes some time to complete, after which the devstudio-[version]-installer-standalone.jar file will be located in the /path/to/jbdevstudio-product/installer/target directory.

Chapter 9. Uninstalling JBoss Developer Studio

You may want to uninstall a specific version of JBoss Developer Studio if you have concluded development in one version, say 9.x, and you now want to install a newer version, say 10.x. However, you can have more than one version of Installer-installed JBoss Developer Studio or Eclipse-installed JBoss Developer Studio on your system, provided you have these versions located in different directories.

Note

You can not have more than one version of RPM-installed JBoss Developer Studio on the same system.

There are three ways to uninstall JBoss Developer Studio, depending on how you installed it. The following sections describe the three methods:

9.1. Uninstalling JBoss Developer Studio Installed Using the Installer

To uninstall JBoss Developer Studio:

  1. Ensure that JBoss Developer Studio is not running.
  2. On the command line, navigate to path/to/JBoss Developer Studio/Uninstaller.
  3. On the command line, type:

    $ java -jar uninstaller.jar
  4. In the IzPack Uninstaller dialog box:

    1. Click the Force the deletion of <path_to_JBoss Developer Studio_directory> check box, to remove the entire JBoss Developer Studio installation directory. If this is not selected, JBoss Developer Studio will be uninstalled but some files will be left as is in the installation directory.
    2. Click Uninstall.
  5. After the progress bar shows Finished, click Quit to close the Uninstaller dialog box.

Figure 9.1. Uninstall JBoss Developer Studio

Uninstall JBoss Developer Studio

9.2. Uninstalling JBoss Developer Studio Installed in Eclipse

JBoss Developer Studio can be uninstalled using the following steps regardless of whether it was installed via Eclipse Marketplace or the update .zip file.

To uninstall JBoss Developer Studio:

  1. Start Eclipse Oxygen.
  2. Click Help > Eclipse Marketplace.
  3. In the Eclipse Marketplace window, Find field, type Red Hat JBoss Developer Studio and then click Go.
  4. Click Installed in the Red Hat JBoss Developer Studio <version> section. This will show the Uninstall button.

    Figure 9.2. Uninstall Button

    Uninstall JBoss Developer Studio
  5. Click Uninstall.
  6. In the Confirm Selected Features window, ensure that Red Hat JBoss Developer Studio <version> is selected.
  7. Click Finish.

    Figure 9.3. Confirm Selected Feature Deletion

    Confirm Selected Feature Deletion
  8. In the Software Updates dialog box, click Yes to restart Eclipse for the changes to take effect.

9.3. Uninstalling JBoss Developer Studio Installed Using RPM

To uninstall JBoss Developer Studio completely, including Eclipse and the included plugins, use the following command:

$ sudo yum remove rh-eclipse47*

To uninstall only JBoss Developer Studio and leave Eclipse and other plugins as is, use the following command:

$ sudo yum remove rh-eclipse47-devstudio

Chapter 10. Upgrading JBoss Developer Studio

Depending on your need, refer to the following sections to upgrade JBoss Developer Studio:

10.1. Upgrading Major Versions of JBoss Developer Studio

Each major version of JBoss Developer Studio is based on a different version of Eclipse. As a result, it is not possible to update an older major version of JBoss Developer Studio to a newer major version. For example, it is not possible to update a devstudio 9.x installation to 10.x, nor is it possible to update a 10.x installation to 11.x. However, it is possible to use the workspaces created using JBoss Developer Studio 10.x with JBoss Developer Studio 11.x.

Important

If you have installed JBoss Developer Studio using the RPM package, you can also upgrade from one major version to another. Installation using RPM uninstalls and then re-installs the newest versions of JBoss Developer Studio and Eclipse. For details to update JBoss Developer Studio installed using the RPM package, refer to Section 10.3, “Updating JBoss Developer Studio Installed Using RPM”.

The following table details the version of Eclipse supported with each major version of JBoss Developer Studio:

Table 10.1. Eclipse Version Support Matrix

JBoss Developer Studio VersionBase Eclipse Version

JBoss Developer Studio 11.0

Eclipse Oxygen (4.7)

JBoss Developer Studio 10.x

Eclipse Neon (4.6)

JBoss Developer Studio 9.x

Eclipse Mars (4.5)

JBoss Developer Studio 8.x

Eclipse Luna (4.4)

JBoss Developer Studio 7.x

Eclipse Kepler (4.3)

JBoss Developer Studio 6.x

Eclipse Juno (4.2)

10.2. Updating Minor Versions of JBoss Developer Studio

You can update your JBoss Developer Studio to the latest minor versions within the major release. For example, you can update your JBoss Developer Studio 10.3 installation to 10.4.

Important

Before updating, back up your workspace. In addition to your project files, your workspace contains metadata about customized settings and preferences for the IDE. To back up your workspace, either copy the workspace directory to a backup location, or save it as a compressed file.

You may be automatically notified by the IDE when the JBoss Developer Studio 10.y update is available, depending on your IDE settings for automatic updates.

Alternatively, use the following instructions to manually check for and apply the most recent JBoss Developer Studio update:

  1. In the IDE, click Window > Preferences, expand Install/Update and click Available Software Sites.
  2. In the Available Software Sites table, ensure the URL https://devstudio.redhat.com/10.0/stable/updates/ is listed or, if not listed, add it.
  3. Close the Preferences window.
  4. Click Help > Check for Updates.
  5. For any JBoss Developer Studio updates found, follow the on-screen instructions to apply the update.

During the update process, you may receive warnings about installing unsigned content. If this is the case, review the details of the content and if satisfied click OK to continue with the update.

Once updating is complete, you are prompted to restart the IDE. Click Yes to restart immediately or No to save any unsaved changes to open projects. Note that IDE changes do not take effect until the IDE is restarted.

10.3. Updating JBoss Developer Studio Installed Using RPM

If you have installed JBoss Developer Studio using the RPM package, you can not update using the package manager and must unistall rh-eclipse46 and then install rh-eclipse47. It is possible to retain rh-eclipse46 and also install rh-eclipse47.

To uninstall JBoss Developer Studio completely, including Eclipse and the included plugins, use the following command:

$ sudo yum remove rh-eclipse46*

To install rh-eclipse47 see, Chapter 7, Installing JBoss Developer Studio Using RPM.

Chapter 11. Reporting Issues from within JBoss Developer Studio

Red Hat JBoss Developer Studio and JBoss Tools allow users to report issues from within the IDE as they are encountered. It is recommended that users report issues frequently and include as much detail as possible to help the development and testing teams replicate and fix the issue. The Report Problem wizard creates a zip file containing the relevant IDE log files. This zip file can be attached to the JIRAs submitted against each problem to provide context for the issue.

  1. Click Help and then click Report Problem.
  2. The Log file name field contains the zipped log files as a default. Click Browse to select a different log file to attach to the JIRA.
  3. In the Problem Description field, outline details about the problem, such as:

    • What you wanted to do with JBoss Developer Studio.
    • What steps you followed to arrive at the problem or error message.
    • Any other noteworthy information about the environment or any unsupported add-ons or plug-ins in use.
  4. Optionally, in the E-Mail field, add your e-mail address to be potentially contacted in the future about the issue.
  5. Click OK to submit the problem report.

You can also enable error reporting from: PreferencesGeneralError Reporting. If enabled, when you encounter a plugin related error, a pop-up notification describing the error will appear. The user can either dismiss or send the error directly, or provide more details about the error. You can optionally provide your e-mail ID to be contacted for more details on the error.

Legal Notice

Copyright © 2018 Red Hat, Inc.
The text of and illustrations in this document are licensed by Red Hat under a Creative Commons Attribution–Share Alike 3.0 Unported license ("CC-BY-SA"). An explanation of CC-BY-SA is available at http://creativecommons.org/licenses/by-sa/3.0/. In accordance with CC-BY-SA, if you distribute this document or an adaptation of it, you must provide the URL for the original version.
Red Hat, as the licensor of this document, waives the right to enforce, and agrees not to assert, Section 4d of CC-BY-SA to the fullest extent permitted by applicable law.
Red Hat, Red Hat Enterprise Linux, the Shadowman logo, JBoss, OpenShift, Fedora, the Infinity logo, and RHCE are trademarks of Red Hat, Inc., registered in the United States and other countries.
Linux® is the registered trademark of Linus Torvalds in the United States and other countries.
Java® is a registered trademark of Oracle and/or its affiliates.
XFS® is a trademark of Silicon Graphics International Corp. or its subsidiaries in the United States and/or other countries.
MySQL® is a registered trademark of MySQL AB in the United States, the European Union and other countries.
Node.js® is an official trademark of Joyent. Red Hat Software Collections is not formally related to or endorsed by the official Joyent Node.js open source or commercial project.
The OpenStack® Word Mark and OpenStack logo are either registered trademarks/service marks or trademarks/service marks of the OpenStack Foundation, in the United States and other countries and are used with the OpenStack Foundation's permission. We are not affiliated with, endorsed or sponsored by the OpenStack Foundation, or the OpenStack community.
All other trademarks are the property of their respective owners.