Chapter 3. Deploying Samba on Red Hat Gluster Storage

3.1. Prerequisites

To install Samba on Red Hat Gluster Storage you require access to the installation media either through an ISO or a properly configured software repository. The Red Hat Gluster Storage server requirements are:
  1. You must install Red Hat Gluster Storage Server on the target server.

    Warning

    • For layered installation of Red Hat Gluster Storage, ensure to have only the default Red Hat Enterprise Linux server installation, without the Samba or CTDB packages installed from Red Hat Enterprise Linux.
    • The Samba version 3 is being deprecated from Red Hat Gluster Storage 3.0 Update 4. Further updates will not be provided for samba-3.x. It is recommended that you upgrade to Samba-4.x, which is provided in a separate channel or repository, for all updates including the security updates.
    • CTDB version 2.5 is not supported from Red Hat Gluster Storage 3.1 Update 2. To use CTDB in Red Hat Gluster Storage 3.1.2 and later, you must upgrade the system to CTDB 4.x, which is provided in the Samba channel of Red Hat Gluster Storage.
    • Downgrade of Samba from Samba 4.x to Samba 3.x is not supported.
    • Ensure that Samba is upgraded on all the nodes simultaneously, as running different versions of Samba in the same cluster will lead to data corruption.
  2. Enable the channel where the Samba packages are available:
    For Red Hat Gluster Storage 3.5 on Red Hat Enterprise Linux 6.x

    1. If you have registered your machine using Red Hat Subscription Manager or Satellite server-6.x, enable the repository by running the following command:
      # subscription-manager repos --enable=rh-gluster-3-samba-for-rhel-6-server-rpms
    For Red Hat Gluster Storage 3.5 on Red Hat Enterprise Linux 7.7 and later

    1. If you have registered your machine using Red Hat Subscription Manager or Satellite server-7.x, enable the repository by running the following command:
      # subscription-manager repos --enable=rh-gluster-3-samba-for-rhel-7-server-rpms
    For Red Hat Gluster Storage 3.5 on Red Hat Enterprise Linux 8.2 and later

    1. If you have registered your machine using Red Hat Subscription Manager or Satellite server-8.x, enable the repository by running the following command:
      # subscription-manager repos --enable=rh-gluster-3-samba-for-rhel-8-x86_64-rpms