5.2. Red Hat Enterprise Virtualization 3.4 Upgrade Considerations

The following is a list of key considerations that must be made when planning your upgrade.

Important

Upgrading to version 3.4 can only be performed from version 3.3
To upgrade a previous version of Red Hat Enterprise Virtualization earlier than Red Hat Enterprise Virtualization 3.3 to Red Hat Enterprise Virtualization 3.4, you must sequentially upgrade to any newer versions of Red Hat Enterprise Virtualization before upgrading to the latest version. For example, if you are using Red Hat Enterprise Virtualization 3.2, you must upgrade to Red Hat Enterprise Virtualization 3.3 before you can upgrade to Red Hat Enterprise Virtualization 3.4.
Red Hat Enterprise Virtualization Manager cannot be installed on the same machine as IPA
An error message displays if the ipa-server package is installed. Red Hat Enterprise Virtualization Manager 3.4 does not support installation on the same machine as Identity Management (IdM). To resolve this issue, you must migrate the IdM configuration to another system before re-attempting the upgrade.
Upgrading to JBoss Enterprise Application Platform 6.2 is recommended
Although Red Hat Enterprise Virtualization Manager 3.4 supports Enterprise Application Platform 6.1.0, upgrading to the latest supported version of JBoss is recommended.
Reports and the Data Warehouse are now installed via engine-setup
From Red Hat Enterprise Virtualization 3.4, the Reports and Data Warehouse features are configured and upgraded using the engine-setup command. If you have configured the Reports and Data Warehouse features in your Red Hat Enterprise Virtualization 3.3 environment, you must install the rhevm-reports-setup and rhevm-dwh-setup packages prior to upgrading to Red Hat Enterprise Virtualization 3.4 to ensure these features are detected by engine-setup.