Chapter 6. The Resilient Storage add-on

The Resilient Storage add-on enables a shared storage or clustered file system to access the same storage device over a network through a pool of data that is available to each server in the group. The add-on is available with a separate subscription. For details, see Resilient Storage Add-On.

The following table lists all the packages available with the Resilient Storage add-on. For more information about core packages, see the Scope of Coverage Details document.

PackageCore package?License

awscli

Yes

ASL 2.0 and MIT

booth

Yes

GPLv2+

booth-arbitrator

Yes

GPLv2+

booth-core

No

GPLv2+

booth-site

Yes

GPLv2+

booth-test

Yes

GPLv2+

clufter-bin

No

GPLv2+

clufter-cli

Yes

GPLv2+

clufter-common

No

GPLv2+

clufter-lib-ccs

Yes

GPLv2+

clufter-lib-general

Yes

GPLv2+

clufter-lib-pcs

Yes

GPLv2+

cmirror

Yes

GPLv2

corosync

No

BSD

corosync-qdevice

Yes

BSD

corosync-qnetd

Yes

BSD

corosynclib-devel

No

BSD

dlm

Yes

GPLv2 and GPLv2+ and LGPLv2+

fence-agents-aliyun

Yes

GPLv2+ and LGPLv2+ and ASL 2.0 and BSD and MIT

fence-agents-aws

Yes

GPLv2+ and LGPLv2+

fence-agents-azure-arm

Yes

GPLv2+ and LGPLv2+

fence-agents-gce

Yes

GPLv2+ and LGPLv2+

libknet1

No

LGPLv2+

libknet1-compress-bzip2-plugin

No

LGPLv2+

libknet1-compress-lz4-plugin

No

LGPLv2+

libknet1-compress-lzma-plugin

No

LGPLv2+

libknet1-compress-lzo2-plugin

No

LGPLv2+

libknet1-compress-plugins-all

No

LGPLv2+

libknet1-compress-zlib-plugin

No

LGPLv2+

libknet1-crypto-nss-plugin

No

LGPLv2+

libknet1-crypto-openssl-plugin

No

LGPLv2+

libknet1-crypto-plugins-all

No

LGPLv2+

libknet1-plugins-all

Yes

LGPLv2+

libnozzle1

No

LGPLv2+

pacemaker

Yes

GPLv2+ and LGPLv2+

pacemaker-cli

No

GPLv2+ and LGPLv2+

pacemaker-cts

Yes

GPLv2+ and LGPLv2+

pacemaker-doc

Yes

CC-BY-SA-4.0

pacemaker-libs-devel

Yes

GPLv2+ and LGPLv2+

pacemaker-nagios-plugins-metadata

Yes

GPLv3

pacemaker-remote

Yes

GPLv2+ and LGPLv2+

pcs

Yes

GPLv2 and ASL 2.0 and MIT

pcs-snmp

Yes

GPLv2 and BSD-2-Clause

python3-azure-sdk

No

MIT and ASL 2.0 and MPLv2.0 and BSD and Python

python3-boto3

No

ASL 2.0

python3-botocore

No

ASL 2.0

python3-clufter

No

GPLv2+ and GFDL

python3-docutils

No

Public Domain and BSD and Python and GPLv3+

python3-fasteners

No

ASL 2.0

python3-gflags

No

BSD

python3-google-api-client

No

ASL 2.0

python3-httplib2

No

MIT

python3-oauth2client

No

ASL 2.0

python3-s3transfer

No

ASL 2.0

python3-uritemplate

No

BSD

resource-agents

Yes

GPLv2+ and LGPLv2+

resource-agents-aliyun

Yes

GPLv2+ and LGPLv2+ and ASL 2.0 and BSD and MIT

resource-agents-gcp

Yes

GPLv2+ and LGPLv2+ and BSD and ASL 2.0 and MIT and Python

spausedd

Yes

BSD