Red Hat Training

A Red Hat training course is available for Red Hat Enterprise Linux

Chapter 36. Compiler and Tools

java-1.8.0-openjdk component, BZ#1189530
With Red Hat Enterprise Linux 7.1, the java-1.8.0-openjdk packages do not provide "java" in the RPM metadata, which breaks compatibility with packages that require Java and are available from the Enterprise Application Platform (EAP) channel. To work around this problem, install another package that provides "java" in the RPM metadata before installing java-1.8.0-openjdk.