7.181. perl

Updated perl packages that fix one bug are now available for Red Hat Enterprise Linux 6.
The perl packages provide the high-level programming language Perl, which is commonly used for system administration utilities and web programming.

Bug Fix

BZ#720644
Prior to this update, computed Perl strings became corrupted or the interpreter could abort when a string with the "x" operator was repeated more than 2^31 times, for example, "my $s = "a' x (2**31+1);". This limits the right side of the "x" operator to 2^31 to prevent it from wrapping the internal representation of the count.
All users of perl are advised to upgrade to these updated packages, which fix this bug.