7.126. libvirt-cim

Updated libvirt-cim packages that fix two bugs are now available for Red Hat Enterprise Linux 6.
The libvirt-cim package contains a Common Information Model (CIM) provider based on Common Manageability Programming Interface (CMPI). It supports most libvirt virtualization features and allows management of multiple libvirt-based platforms.

Bug Fixes

BZ#805892
If the sblim-sfcb package was installed on the system, rebuilding the libvirt-cim package failed with an error due to an incomplete substitution in the Makefile. The substitution has been corrected and rebuilding libvirt-cim now works as expected.
BZ#864096
When upgrading the libvirt-cim package to a newer version after libvirt-cim had registered its classes with a cim-server, the %preun code unregistered the classes leaving the system without libvirt-cim classes being registered. Now the libvirt-cim package only unregisters the libvirt-cim classes on uninstall.
Users of libvirt-cim are advised to upgrade to these updated packages, which fix these bugs.