Red Hat Training

A Red Hat training course is available for Red Hat Linux

5.236. perl-IPC-Run

Updated perl-IPC-Run packages that fix one bug are now available for Red Hat Enterprise Linux 6.
The perl-IPC-Run packages provide a mechanism for Perl scripts to interact with child processes.

Bug Fix

BZ#856840
Prior to this update, the IO::Pty Perl module was not loaded when using the command "IPC::Run::harness" with the ">pty>" argument if the perl-IO-Tty package was not installed. As a consequence, the Perl code failed. This update adds a perl-IO-Tty dependency to the perl-IPC-Run packages.
All users of perl-IPC-Run are advised to upgrade to these updated packages, which fix this bug.