Red Hat Training

A Red Hat training course is available for Red Hat Linux

5.228. pam_pkcs11

Updated pam_pkcs11 packages which fix a bug are now available for Red Hat Enterprise Linux 6.
The pam_pkcs11 package allows X.509 certificate-based user authentication. It provides access to the certificate and its dedicated private key with an appropriate Public Key Cryptographic Standards #11 (PKCS#11) module.

Bug Fix

BZ#756917
When remotely logged into a system with smart card log-in turned on, users saw the following unnecessary error message when trying to use su:
ERROR:pam_pkcs11.c:224: Remote login (from localhost:13.0) is not (yet) supported
The user was still able to use su despite this message. With this update the message is logged but no longer displayed.
All users of pam_pkcs11 are advised to upgrade to these updated packages, which fix this bug.