Red Hat Training

A Red Hat training course is available for Red Hat Linux

5.193. mingw32-qpid-cpp

Updated mingw32-qpid-cpp packages that fix three bugs are now available for Red Hat Enterprise Linux 6.
The mingw32-qpid-cpp packages provide a message broker daemon that receives, stores, and routes messages by means of runtime libraries for Advanced Message Queuing Protocol (AMQP) client applications developed using the Qpid C++ language.

Bug Fixes

BZ#751349
Previously, HTML documentation was required by the mingw32-qpid-cpp package builds, but was not available. Consequently, the following error message was displayed during the build process:
CMake Error at docs/api/cmake_install.cmake:31 (FILE): file INSTALL cannot find file "/usr/src/redhat/BUILD/qpid-cpp-0.12/build/docs/api/html" to install.
As the HTML documentation is not considered essential, this update disables its generation. As a result, the aforementioned error message is not displayed during the build process of the mingw32-qpid-cpp package.
BZ#807345
Previously, mingw32-qpid-cpp had an unnecessary dependency on the mingw32-gnutls package. This update removes the dependency.
BZ#813537
Previously, mingw32-qpid-cpp had an unnecessary dependency on the mingw32-libxslt package. This update removes the dependency.
All users of mingw32-qpid-cpp are advised to upgrade to these updated packages, which fix these bugs.