20.6. Oracle 10g R1 on Red Hat Enterprise Linux 3 (x86_64)

On Red Hat Enterprise Linux 3 x86_64 you may have to install the following RPMs and dependencies to meet the software requirements:
rpm -Uvh gcc-3.2.3-52.x86_64.rpm \
    cpp-3.2.3-52.x86_64.rpm \
    glibc-devel-2.3.2-95.33.x86_64.rpm \
    glibc-headers-2.3.2-95.33.x86_64.rpm \
    glibc-kernheaders-2.4-8.34.1.x86_64.rpm

rpm -Uvh glibc-devel-2.3.2-95.33.i386.rpm

rpm -Uvh compat-db-4.0.14-5.1.x86_64.rpm \
    compat-gcc-7.3-2.96.128.i386.rpm \
    compat-gcc-c++-7.3-2.96.128.i386.rpm \
    compat-libstdc++-7.3-2.96.128.i386.rpm \
    compat-libstdc++-devel-7.3-2.96.128.i386.rpm \
    tcl-8.3.5-92.2.x86_64.rpm \
    libgcc-3.2.3-52.i386.rpm

rpm -Uvh libaio-0.3.96-5.x86_64.rpm \
    libaio-devel-0.3.96-5.x86_64.rpm
Note: Red Hat Enterprise Linux 3 x86-64 U5 does not come with a i386 gnome-libs RPM
rpm -Uvh gnome-libs-1.4.1.2.90-34.2.x86_64.rpm \
    ORBit-0.5.17-10.4.x86_64.rpm \
    audiofile-0.2.3-7.1.x86_64.rpm \
    esound-0.2.28-6.x86_64.rpm \
    gtk+-1.2.10-31.x86_64.rpm \
    imlib-1.9.13-13.4.x86_64.rpm \
    gdk-pixbuf-0.22.0-12.el3.x86_64.rpm \
    libpng10-1.0.13-15.x86_64.rpm \
    libungif-4.1.0-15.x86_64.rpm
Note: Red Hat Enterprise Linux 3 x86-64 U5 does not come with a x86-64 openmotif21 RPM
rpm -Uvh openmotif21-2.1.30-9.RHEL3.6.i386.rpm \
    XFree86-libs-4.3.0-81.EL.i386.rpm \
    XFree86-Mesa-libGL-4.3.0-81.EL.i386.rpm \
    expat-1.95.5-6.i386.rpm \
    fontconfig-2.2.1-13.i386.rpm \
    freetype-2.1.4-4.0.i386.rpm \
    zlib-1.1.4-8.1.i386.rpm
Make sure to use the right i386 and x86_64 RPMs as listed above.
Note, if you do not install the i386 XFree86-libs RPM, you will get an error message similar to this one:
/tmp/OraInstall2005-06-15_07-36-25AM/jre/1.4.2/lib/i386/libawt.so: \
libXp.so.6: cannot open shared object file: No such file or directory