Red Hat Training

A Red Hat training course is available for Red Hat Enterprise Linux

20.7. Oracle 10g R1 on Red Hat Enterprise Linux 2.1 (x86)

On Red Hat Enterprise Linux 2.1 x86 you may have to install the following RPMs and dependencies to meet the software requirements:
rpm -Uvh glibc-2.2.4-32.11.i686.rpm \
    glibc-common-2.2.4-32.11.i386.rpm

rpm -Uvh gcc-2.96-108.1.i386.rpm \
    binutils-2.11.90.0.8-12.i386.rpm \
    cpp-2.96-108.1.i386.rpm \
    glibc-devel-2.2.4-32.11.i386.rpm \
    kernel-headers-2.4.9-e.3.i386.rpm

rpm -Uvh openmotif-2.1.30-11.i386.rpm

rpm -Uvh redhat-release-as-2.1AS-4.noarch.rpm
You may have to upgrade glibc in order to pass Oracle's "Product-specific Prerequisite" checks. Oracle's recommended glibc version is 2.2.4.31.7 or higher.
There is no setarch RPM for Red Hat Enterprise Linux 2.1.
Also, it is important to install a newer kernel version for Red Hat Enterprise Linux 2.1. Do not use a kernel older than 2.4.9-e.25. To check the kernel version run uname -r.