Red Hat Training

A Red Hat training course is available for Red Hat Enterprise Linux

20.4. 10g R1 on Red Hat Enterprise Linux 4 and 5 (x86)

On Red Hat Enterprise Linux 4 x86 you may have to install the following RPMs and dependencies to meet the software requirements:
rpm -Uvh gcc-3.4.3-9.EL4.i386.rpm \
    glibc-devel-2.3.4-2.i386.rpm \
    glibc-headers-2.3.4-2.i386.rpm \
    glibc-kernheaders-2.4-9.1.87.i386.rpm

rpm -Uvh openmotif-2.2.3-6.RHEL4.2.i386.rpm \
    xorg-x11-deprecated-libs-6.8.1-23.EL.i386.rpm

Note

The 10g 10.1.0.3 OUI Product specific prerequisite check will fail for the gcc, binutils, and openmotif versions. You can ignore these failed checks and proceed.

Important

The redhat-release RPM should already be installed by default. But note that 10.1.0.3.0 OUI does not recognize Red Hat Enterprise Linux 4 or 5 as a supported release yet. This means you will have to edit the /etc/redhat-release file, see below, or you apply the 4153257 patch for 10g R1 on Red Hat Enterprise Linux 4 and 5.