Red Hat Training

A Red Hat training course is available for Red Hat Enterprise Linux

Chapter 31. Verifying Required Packages(RPMs)

You will need certain RPM development packages for the Oracle installer to build Oracle modules, otherwise you will get error messages similar to this one:
Error in invoking target ntcontab.o of makefile 
/u01/app/oracle/product/9.2.0/network/lib/ins_net_client.mk

Note

Always ensure you use the latest stable versions of RPM.
See the Oracle9i Release Notes Release 2 (9.2.0.4.0) for Linux x86 for the list of required RPMs.

31.1. Required Packages for Red Hat Advanced Server 2.1

Ensure the following development packages are installed:
rpm -q gcc cpp compat-libstdc++ glibc-devel kernel-headers binutils
Most of these packages will be missing on Red Hat Advanced Server 2.1 if the "Software Development" package was not selected during the OS install. If these RPMs are missing, execute the command below, remember your versions may be newer. If they are not newer than those seen below update to a more recent version.
rpm -ivh cpp-2.96-108.1.i386.rpm	\
    glibc-devel-2.2.4-26.i386.rpm     	\
    kernel-headers-2.4.9-e.3.i386.rpm 	\
    gcc-2.96-108.1.i386.rpm           	\
    binutils-2.11.90.0.8-12.i386.rpm