Chapter 20. Installing Required Software Packages

The following sections provide a detailed set of instructions for installing the required software packages(RPMs) before you install your Oracle Database 10g (R1 and R2). These sections include the following possible configurations:
  • 10g R2 on Red Hat Enterprise Linux 4 and 5 (x86-64),
  • 10g R2 on Red Hat Enterprise Linux 4 and 5 (x86),
  • 10g R1 on Red Hat Enterprise Linux 4 and 5 (x86-64),
  • 10g R1 on Red Hat Enterprise Linux 4 and 5 (x86),
  • 10g R1 and R2 on Red Hat Enterprise Linux 3 (x86),
  • 10g R1 on Red Hat Enterprise Linux 3 (x86-64), and
  • 10g R1 on Red Hat Enterprise Linux 2.1 (x86).

20.1. 10g R2 on Red Hat Enterprise Linux 4 and 5 x86-64 version

On Red Hat Enterprise Linux 4 x86-64 you may have to install the following RPMs and dependencies:
# rpm -Uvh gcc-3.4.4-2.x86_64.rpm      \
    gcc-c++-3.4.4-2.x86_64.rpm                   \
    libstdc++-devel-3.4.4-2.x86_64.rpm           \
    cpp-3.4.4-2.x86_64.rpm                       \
    glibc-devel-2.3.4-2.13.x86_64.rpm            \
    glibc-headers-2.3.4-2.13.x86_64.rpm          \
    glibc-kernheaders-2.4-9.1.98.EL.x86_64.rpm

#rpm -Uvh gnome-libs-1.4.1.2.90-44.1.x86_64.rpm   \
    compat-db-4.1.25-9.x86_64.rpm                    \
    ORBit-0.5.17-14.x86_64.rpm                       \
    gtk+-1.2.10-33.x86_64.rpm                        \
    imlib-1.9.13-23.x86_64.rpm                       \
    libpng10-1.0.16-1.x86_64.rpm                     \
    gdk-pixbuf-0.22.0-16.el4.x86_64.rpm              \
    libungif-4.1.3-1.x86_64.rpm

# rpm -Uvh sysstat-5.0.5-1.x86_64.rpm
You also need to install the following i386 and x86-64 RPMs if not already installed, otherwise you will get various different error messages.
rpm -Uvh xorg-x11-deprecated-libs-6.8.2-1.EL.13.20.i386.rpm \
    xorg-x11-libs-6.8.2-1.EL.13.20.i386.rpm                             \
    xorg-x11-Mesa-libGL-6.8.2-1.EL.13.20.i386.rpm                       \
    expat-1.95.7-4.i386.rpm                                             \
    fontconfig-2.2.3-7.i386.rpm                                         \
    freetype-2.1.9-1.i386.rpm                                           \
    zlib-1.2.1.2-1.2.i386.rpm
    
rpm -Uvh libaio-0.3.103-3.x86_64.rpm

rpm -Uvh compat-libstdc++-33-3.2.3-47.3.x86_64.rpm

rpm -Uvh glibc-devel-2.3.4-2.13.i386.rpm libgcc-3.4.4-2.i386.rpm
If you are yet to install Update 3 or later, do not forget to install an updated binutils RPM from https://rhn.redhat.com/ or from http://oss.oracle.com/. This command will install the newer version of binutils, remember to change the version number if the one you downloaded is newer.
rpm -Uvh --force binutils-2.15.92.0.2-13.0.0.0.2.x86_64.rpm
If you do not install a newer binutil RPM from Oracle or RHN, then you will get the following error message:
/usr/bin/ld: /u01/app/oracle/oracle/product/10.2.0/db_1/lib//libirc.a(fast_memcpy.o): 
    relocation R_X86_64_PC32 against `_memcpy_mem_ops_method' can not  
    be used when making a shared object; recompile with -fPIC
    /usr/bin/ld: final link failed: Bad value
    collect2: ld returned 1 exit status
For more information on this bug, see Bugzilla Bug 679.
Oracle lists the control-center and xscreensaver RPMs as a requirements. But you should not have any problems when these RPMs are missing. But if you want to install them, you may have to install many additional RPMs in order to satisfy dependencies:
rpm -Uvh gcc-3.4.4-2.x86_64.rpm \
    gcc-c++-3.4.4-2.x86_64.rpm \
    libstdc++-devel-3.4.4-2.x86_64.rpm \
    cpp-3.4.4-2.x86_64.rpm \
    glibc-devel-2.3.4-2.13.x86_64.rpm \
    glibc-headers-2.3.4-2.13.x86_64.rpm \
    glibc-kernheaders-2.4-9.1.98.EL.x86_64.rpm

rpm -Uvh control-center-2.8.0-12.rhel4.2.x86_64.rpm \
    xscreensaver-4.18-5.rhel4.9.x86_64.rpm \
    eel2-2.8.1-2.x86_64.rpm \
    gail-1.8.0-2.x86_64.rpm \
    gnome-desktop-2.8.0-5.x86_64.rpm \
    gnome-icon-theme-2.8.0-1.el4.1.3.noarch.rpm \
    libgail-gnome-1.1.0-1.x86_64.rpm \
    libxklavier-1.02-3.x86_64.rpm \
    metacity-2.8.6-2.8.x86_64.rpm \
    nautilus-2.8.1-4.x86_64.rpm \
    startup-notification-0.7-1.x86_64.rpm \
    xloadimage-4.1-34.RHEL4.x86_64.rpm \
    xorg-x11-Mesa-libGLU-6.8.2-1.EL.13.20.x86_64.rpm \
    at-spi-1.6.0-3.x86_64.rpm \
    desktop-backgrounds-basic-2.0-26.2.1E.noarch.rpm \
    eog-2.8.1-2.x86_64.rpm \
    gnome-panel-2.8.1-3.3E.x86_64.rpm \
    gnome-vfs2-smb-2.8.2-8.2.x86_64.rpm \
    hicolor-icon-theme-0.3-3.noarch.rpm \
    libexif-0.5.12-5.1.x86_64.rpm \
    librsvg2-2.8.1-1.x86_64.rpm \
    nautilus-cd-burner-2.8.3-6.x86_64.rpm \
    redhat-artwork-0.120.1-1.2E.x86_64.rpm \
    scrollkeeper-0.3.14-3.x86_64.rpm \
    cdrecord-2.01.1-5.x86_64.rpm \
    docbook-dtds-1.0-25.noarch.rpm \
    evolution-data-server-1.0.2-9.x86_64.rpm \
    intltool-0.31.2-1.x86_64.rpm \
    libcroco-0.6.0-4.x86_64.rpm \
    libgnomeprint22-2.8.0-3.x86_64.rpm \
    libgnomeprintui22-2.8.0-1.x86_64.rpm \
    libgsf-1.10.1-1.x86_64.rpm \
    libwnck-2.8.1-1.rhel4.1.x86_64.rpm \
    mkisofs-2.01.1-5.x86_64.rpm \
    samba-common-3.0.10-1.4E.2.x86_64.rpm \
    ghostscript-7.07-33.x86_64.rpm \
    ghostscript-fonts-5.50-13.noarch.rpm \
    gnutls-1.0.20-3.2.1.x86_64.rpm \
    libgnomecups-0.1.12-5.x86_64.rpm \
    libsoup-2.2.1-2.x86_64.rpm \
    openjade-1.3.2-14.x86_64.rpm \
    perl-XML-Parser-2.34-5.x86_64.rpm \
    sgml-common-0.6.3-17.noarch.rpm \
    urw-fonts-2.2-6.1.noarch.rpm \
    xml-common-0.6.3-17.noarch.rpm \
    VFlib2-2.25.6-25.x86_64.rpm \
    chkfontpath-1.10.0-2.x86_64.rpm \
    perl-URI-1.30-4.noarch.rpm \
    perl-libwww-perl-5.79-5.noarch.rpm \
    xorg-x11-font-utils-6.8.2-1.EL.13.20.x86_64.rpm \
    perl-HTML-Parser-3.35-6.x86_64.rpm \
    xorg-x11-xfs-6.8.2-1.EL.13.20.x86_64.rpm \
    perl-HTML-Tagset-3.03-30.noarch.rpm \
    ttmkfdir-3.0.9-14.1.EL.x86_64.rpm