4.31. device-mapper

Updated device-mapper packages that fix several bugs and add various enhancements are now available for Red Hat Enterprise Linux 5.
The device-mapper packages provide the dmsetup utility and libdevmapper library required by logical volume management utilities such as LVM2 and dmraid.
The device-mapper packages have been upgraded to upstream version 1.02.67, which provides a number of bug fixes and enhancements over the previous version. (BZ#746300)

Bug Fix

BZ#454618
The dmeventd daemon was not properly restarted after the package update. Consequently, dmeventd did not apply the newly updated libraries and continued using the old libraries. Therefore, logical volume monitoring failed and had to be re-activated because particular monitoring events were not handled as expected. With this update, dmeventd properly restarts after the package update so that updated libraries are applied and logical volumes are monitored as expected.
Users are advised to upgrade to these updated device-mapper packages, which fix these bugs and add these enhancements.